MSS Namespace

Reference Library
MSS Namespace
Namespaces >> MSS
Declaration Syntax
C#
namespace MSS
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | Context | Easy access to current context objects.
 | Context..::ContextChangedDelegate | Called when the site display mode is to be changed.
 | Context..::ContextMode | Site display modes
(c) Sitecore A/S. All rights reserved. Send comments about this topic to Sitecore.


Context Class

Context Class
Namespaces >> MSS >> Context
Easy access to current context objects.
Declaration Syntax
C#
public class Context
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextContextNew()() |
 | CacheManager | Gets the cache manager.
 | ContentDatabase | Gets the content database for the current server.
 | ContextModeChanged |
 | CultureInfo | Gets the current culture.
 | CurrentDatabase | Gets the current database for the current server
 | Device | Gets the device.
 | Dictionary | Gets the dictionary.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLocalAdministrator | Determines whether a user is local administrator.
 | Item | Gets the current item.
 | Language | Gets the current language.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mode | Gets or sets the context mode.
 | Security | Gets the security manager.
 | Server | Gets the current server.
 | Site | Gets the current site.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Context

Assembly: MSS.Kernel (Module: MSS.Kernel)


Context Constructor

Context Constructor
Namespaces >> MSS >> Context >> ContextContextNew()()
Declaration Syntax
C#
public Context()

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheManager Property

CacheManager Property
Namespaces >> MSS >> Context >> CacheManager
Gets the cache manager.
Declaration Syntax
C#
public static CacheManager<ID> CacheManager{ get;}
Value
The cache manager.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ContentDatabase Property

ContentDatabase Property
Namespaces >> MSS >> Context >> ContentDatabase
Gets the content database for the current server.
Declaration Syntax
C#
public static Database ContentDatabase{ get;}
Value
The content database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ContextModeChanged Event

ContextModeChanged Event
Namespaces >> MSS >> Context >> ContextModeChanged
Declaration Syntax
C#
public static event Context.Context..::ContextChangedDelegate ContextModeChanged

Assembly: MSS.Kernel (Module: MSS.Kernel)


CultureInfo Property

CultureInfo Property
Namespaces >> MSS >> Context >> CultureInfo
Gets the current culture.
Declaration Syntax
C#
public static CultureInfo CultureInfo{ get;}
Value
The current culture.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CurrentDatabase Property

CurrentDatabase Property
Namespaces >> MSS >> Context >> CurrentDatabase
Gets the current database for the current server
Declaration Syntax
C#
public static Database CurrentDatabase{ get;}
Value
The current database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Device Property

Device Property
Namespaces >> MSS >> Context >> Device
Gets the device.
Declaration Syntax
C#
public static DeviceItem Device{ get;}
Value
The device.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Dictionary Property

Dictionary Property
Namespaces >> MSS >> Context >> Dictionary
Gets the dictionary.
Declaration Syntax
C#
public static DictionaryManager Dictionary{ get;}
Value
The dictionary.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalAdministrator Property

IsLocalAdministrator Property
Namespaces >> MSS >> Context >> IsLocalAdministrator
Determines whether a user is local administrator.
Declaration Syntax
C#
public static bool IsLocalAdministrator{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property

Item Property
Namespaces >> MSS >> Context >> Item
Gets the current item.
Declaration Syntax
C#
public static Item Item{ get;}
Value
The current item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Language Property

Language Property
Namespaces >> MSS >> Context >> Language
Gets the current language.
Declaration Syntax
C#
public static Language Language{ get;}
Value
The current language.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Mode Property

Mode Property
Namespaces >> MSS >> Context >> Mode
Gets or sets the context mode.
Declaration Syntax
C#
public static Context.Context..::ContextMode Mode{ get; set;}
Value
The conext mode.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Security Property

Security Property
Namespaces >> MSS >> Context >> Security
Gets the security manager.
Declaration Syntax
C#
public static SecurityManager Security{ get;}
Value
The security manager.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Server Property

Server Property
Namespaces >> MSS >> Context >> Server
Gets the current server.
Declaration Syntax
C#
public static Server Server{ get;}
Value
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Site Property

Site Property
Namespaces >> MSS >> Context >> Site
Gets the current site.
Declaration Syntax
C#
public static SiteContext Site{ get;}
Value
The site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Context.ContextChangedDelegate Delegate

Context..::ContextChangedDelegate Delegate
Namespaces >> MSS >> Context >> Context..::ContextChangedDelegate
Called when the site display mode is to be changed.
Declaration Syntax
C#
public delegate void ContextChangedDelegate(
    Context.Context..::ContextMode currentMode,
    Context.Context..::ContextMode newMode
)
Parameters
currentMode (Context..::ContextMode)
The current mode.
newMode (Context..::ContextMode)
The new mode.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Context.ContextMode Enumeration

Context..::ContextMode Enumeration
Namespaces >> MSS >> Context >> Context..::ContextMode
Site display modes
Declaration Syntax
C#
public enum ContextMode
Members
Member | Description
PreviewMode |
WebMode |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Administration.Application.BackupAndRestore Namespace

MSS.Administration.Application.BackupAndRestore Namespace
Namespaces >> MSS.Administration.Application.BackupAndRestore
Declaration Syntax
C#
namespace MSS.Administration.Application.BackupAndRestore
Types
All Types Classes
Icon | Type | Description
 | BackupAndRestoreForm | Backup and restore form
 | BackupWorker | The application which performs a site backup.
 | RestoreWorker | The application that restores the site.


BackupAndRestoreForm Class

BackupAndRestoreForm Class
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm
Backup and restore form
Declaration Syntax
C#
public class BackupAndRestoreForm : BaseForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BackupAndRestoreFormBackupAndRestoreFormNew()() |
 | BackupSite(ClientPipelineArgs) | Starts the site Backup.
 | BackupSiteButton |
 | DisableButtons | Sets a value indicating whether to disable buttons on the form.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Monitor |
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | ProgressBar |
 | ProgressBarText | Progress bar text
 | ProgressText |
 | RestoreSite()() | Starts the site Restore.
 | RestoreSiteButton |
 | RestoreSiteFileName |
 | SelectRestoredSite(ClientPipelineArgs) | Selects the restored site.
 | ServerProperties()() | (Inherited from BaseForm.)
 | ShowProgressBar | Sets a value indicating whether to show the progress bar.
 | SiteList |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Worker | Gets or sets the worker.
 | WorkerID | Gets or sets the worker ID.
Inheritance Hierarchy
Object
 | BaseForm
 |  | BackupAndRestoreForm

Assembly: MSS.Administration (Module: MSS.Administration)


BackupAndRestoreForm Constructor

BackupAndRestoreForm Constructor
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> BackupAndRestoreFormBackupAndRestoreFormNew()()
Declaration Syntax
C#
public BackupAndRestoreForm()

Assembly: MSS.Administration (Module: MSS.Administration)


BackupSite Method (args)

BackupSite Method (args)
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> BackupSite(ClientPipelineArgs)
Starts the site Backup.
Declaration Syntax
C#
[HandleMessageAttribute("backupcenter:backupsite", true)]
protected void BackupSite(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


BackupSiteButton Field

BackupSiteButton Field
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> BackupSiteButton
Declaration Syntax
C#
protected Button BackupSiteButton

Assembly: MSS.Administration (Module: MSS.Administration)


DisableButtons Property

DisableButtons Property
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> DisableButtons
Sets a value indicating whether to disable buttons on the form.
Declaration Syntax
C#
protected bool DisableButtons{ set;}
Value
True if [disable buttons]; otherwise, false.

Assembly: MSS.Administration (Module: MSS.Administration)


Monitor Field

Monitor Field
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> Monitor
Declaration Syntax
C#
protected TaskMonitor Monitor

Assembly: MSS.Administration (Module: MSS.Administration)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


ProgressBar Field

ProgressBar Field
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> ProgressBar
Declaration Syntax
C#
protected Control ProgressBar

Assembly: MSS.Administration (Module: MSS.Administration)


ProgressBarText Property

ProgressBarText Property
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> ProgressBarText
Progress bar text
Declaration Syntax
C#
protected string ProgressBarText{ set;}

Assembly: MSS.Administration (Module: MSS.Administration)


ProgressText Field

ProgressText Field
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> ProgressText
Declaration Syntax
C#
protected Label ProgressText

Assembly: MSS.Administration (Module: MSS.Administration)


RestoreSite Method

RestoreSite Method
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> RestoreSite()()
Starts the site Restore.
Declaration Syntax
C#
protected void RestoreSite()

Assembly: MSS.Administration (Module: MSS.Administration)


RestoreSiteButton Field

RestoreSiteButton Field
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> RestoreSiteButton
Declaration Syntax
C#
protected Button RestoreSiteButton

Assembly: MSS.Administration (Module: MSS.Administration)


RestoreSiteFileName Field

RestoreSiteFileName Field
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> RestoreSiteFileName
Declaration Syntax
C#
protected Edit RestoreSiteFileName

Assembly: MSS.Administration (Module: MSS.Administration)


SelectRestoredSite Method (args)

SelectRestoredSite Method (args)
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> SelectRestoredSite(ClientPipelineArgs)
Selects the restored site.
Declaration Syntax
C#
[HandleMessageAttribute("backupcenter:uploadpackage", true)]
protected void SelectRestoredSite(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


ShowProgressBar Property

ShowProgressBar Property
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> ShowProgressBar
Sets a value indicating whether to show the progress bar.
Declaration Syntax
C#
protected bool ShowProgressBar{ set;}
Value
True, if progress bar is to be shown; otherwise, false.

Assembly: MSS.Administration (Module: MSS.Administration)


SiteList Field

SiteList Field
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> SiteList
Declaration Syntax
C#
protected Combobox SiteList

Assembly: MSS.Administration (Module: MSS.Administration)


Worker Property

Worker Property
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> Worker
Gets or sets the worker.
Declaration Syntax
C#
protected Worker Worker{ get; set;}
Value
The worker.

Assembly: MSS.Administration (Module: MSS.Administration)


WorkerID Property

WorkerID Property
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupAndRestoreForm >> WorkerID
Gets or sets the worker ID.
Declaration Syntax
C#
protected ID WorkerID{ get; set;}
Value
The worker ID.

Assembly: MSS.Administration (Module: MSS.Administration)


BackupWorker Class

BackupWorker Class
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupWorker
The application which performs a site backup.
Declaration Syntax
C#
public class BackupWorker : Worker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BackupWorkerBackupWorkerNew(SiteContext, String) | Initializes a new instance of the BackupWorker class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets or sets the work message. (Inherited from Worker.)
 | Start()() | Starts the BackupWorker. (Overrides Worker.Start()().)
 | Succeed | Gets or sets a value indicating whether the result of the work is a success. (Inherited from Worker.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Worker
 |  | BackupWorker

Assembly: MSS.Administration (Module: MSS.Administration)


BackupWorker Constructor (site, backupName)

BackupWorker Constructor (site, backupName)
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupWorker >> BackupWorkerBackupWorkerNew(SiteContext, String)
Initializes a new instance of the BackupWorker class.
Declaration Syntax
C#
public BackupWorker(
    SiteContext site,
    string backupName
)
Parameters
site (SiteContext)
The site.
backupName (String)
Name of the backup.

Assembly: MSS.Administration (Module: MSS.Administration)


Start Method

Start Method
Namespaces >> MSS.Administration.Application.BackupAndRestore >> BackupWorker >> Start()()
Starts the BackupWorker.
Declaration Syntax
C#
public override void Start()

Assembly: MSS.Administration (Module: MSS.Administration)


RestoreWorker Class

RestoreWorker Class
Namespaces >> MSS.Administration.Application.BackupAndRestore >> RestoreWorker
The application that restores the site.
Declaration Syntax
C#
public class RestoreWorker : Worker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RestoreWorkerRestoreWorkerNew(String) | Initializes a new instance of the RestoreWorker class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets or sets the work message. (Inherited from Worker.)
 | Start()() | Starts the RestoreWorker. (Overrides Worker.Start()().)
 | Succeed | Gets or sets a value indicating whether the result of the work is a success. (Inherited from Worker.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Worker
 |  | RestoreWorker

Assembly: MSS.Administration (Module: MSS.Administration)


RestoreWorker Constructor (backupName)

RestoreWorker Constructor (backupName)
Namespaces >> MSS.Administration.Application.BackupAndRestore >> RestoreWorker >> RestoreWorkerRestoreWorkerNew(String)
Initializes a new instance of the RestoreWorker class.
Declaration Syntax
C#
public RestoreWorker(
    string backupName
)
Parameters
backupName (String)
Name of the backup.

Assembly: MSS.Administration (Module: MSS.Administration)


Start Method

Start Method
Namespaces >> MSS.Administration.Application.BackupAndRestore >> RestoreWorker >> Start()()
Starts the RestoreWorker.
Declaration Syntax
C#
public override void Start()

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Application.DictionaryManager Namespace

MSS.Administration.Application.DictionaryManager Namespace
Namespaces >> MSS.Administration.Application.DictionaryManager
Declaration Syntax
C#
namespace MSS.Administration.Application.DictionaryManager
Types
All Types Classes
Icon | Type | Description
 | DictionaryKeyParser | Summary: Dictionary Key Parser application.
 | DictionaryManagerForm | Dictionary manager form.


DictionaryKeyParser Class

DictionaryKeyParser Class
Namespaces >> MSS.Administration.Application.DictionaryManager >> DictionaryKeyParser
Summary: Dictionary Key Parser application.
Declaration Syntax
C#
public class DictionaryKeyParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DictionaryKeyParserDictionaryKeyParserNew(String) | Initializes a new instance of the DictionaryKeyParser.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folders | Gets the dictionary item folders.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the dictionary item name.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryKeyParser

Assembly: MSS.Administration (Module: MSS.Administration)


DictionaryKeyParser Constructor (key)

DictionaryKeyParser Constructor (key)
Namespaces >> MSS.Administration.Application.DictionaryManager >> DictionaryKeyParser >> DictionaryKeyParserDictionaryKeyParserNew(String)
Initializes a new instance of the DictionaryKeyParser.
Declaration Syntax
C#
public DictionaryKeyParser(
    string key
)
Parameters
key (String)
The new key.

Assembly: MSS.Administration (Module: MSS.Administration)


Folders Property

Folders Property
Namespaces >> MSS.Administration.Application.DictionaryManager >> DictionaryKeyParser >> Folders
Gets the dictionary item folders.
Declaration Syntax
C#
public ArrayList Folders{ get;}
Value
The folders.

Assembly: MSS.Administration (Module: MSS.Administration)


Name Property

Name Property
Namespaces >> MSS.Administration.Application.DictionaryManager >> DictionaryKeyParser >> Name
Gets the dictionary item name.
Declaration Syntax
C#
public string Name{ get;}
Value
The dictionary item name.

Assembly: MSS.Administration (Module: MSS.Administration)


DictionaryManagerForm Class

DictionaryManagerForm Class
Namespaces >> MSS.Administration.Application.DictionaryManager >> DictionaryManagerForm
Dictionary manager form.
Declaration Syntax
C#
public class DictionaryManagerForm : BaseForm
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DictionaryManagerFormDictionaryManagerFormNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | ServerProperties()() | (Inherited from BaseForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | DictionaryManagerForm

Assembly: MSS.Administration (Module: MSS.Administration)


DictionaryManagerForm Constructor

DictionaryManagerForm Constructor
Namespaces >> MSS.Administration.Application.DictionaryManager >> DictionaryManagerForm >> DictionaryManagerFormDictionaryManagerFormNew()()
Declaration Syntax
C#
public DictionaryManagerForm()

Assembly: MSS.Administration (Module: MSS.Administration)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Administration.Application.DictionaryManager >> DictionaryManagerForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Application.DictionaryManager.Pages Namespace

MSS.Administration.Application.DictionaryManager.Pages Namespace
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages
Declaration Syntax
C#
namespace MSS.Administration.Application.DictionaryManager.Pages
Types
All Types Classes
Icon | Type | Description
 | Default | Dictionary manager's default page
 | Edit | Edit dictionary item page


Default Class

Default Class
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default
Dictionary manager's default page
Declaration Syntax
C#
[HidePageExtendersAttribute]
public class Default : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultDefaultNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | equalCheckBox |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | errorMessageLabel |
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | Form1 |
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | languageDropDownList |
 | languageLabel |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | notEqualCheckBox |
 | notSystemCheckBox |
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | resultTable |
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowButton |
 | ShowButton_Click(Object, EventArgs) | Handle click on the "Show" button.
 | showLabel |
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | siteDropDownList |
 | siteLabel |
 | siteTypeDropDownList |
 | siteTypeLabel |
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | systemOnlyCheckBox |
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Default

Assembly: MSS.Administration (Module: MSS.Administration)


Default Constructor

Default Constructor
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> DefaultDefaultNew()()
Declaration Syntax
C#
public Default()

Assembly: MSS.Administration (Module: MSS.Administration)


equalCheckBox Field

equalCheckBox Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> equalCheckBox
Declaration Syntax
C#
protected CheckBox equalCheckBox

Assembly: MSS.Administration (Module: MSS.Administration)


errorMessageLabel Field

errorMessageLabel Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> errorMessageLabel
Declaration Syntax
C#
protected Label errorMessageLabel

Assembly: MSS.Administration (Module: MSS.Administration)


Form1 Field

Form1 Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> Form1
Declaration Syntax
C#
protected HtmlForm Form1

Assembly: MSS.Administration (Module: MSS.Administration)


languageDropDownList Field

languageDropDownList Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> languageDropDownList
Declaration Syntax
C#
protected DropDownList languageDropDownList

Assembly: MSS.Administration (Module: MSS.Administration)


languageLabel Field

languageLabel Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> languageLabel
Declaration Syntax
C#
protected Label languageLabel

Assembly: MSS.Administration (Module: MSS.Administration)


notEqualCheckBox Field

notEqualCheckBox Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> notEqualCheckBox
Declaration Syntax
C#
protected CheckBox notEqualCheckBox

Assembly: MSS.Administration (Module: MSS.Administration)


notSystemCheckBox Field

notSystemCheckBox Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> notSystemCheckBox
Declaration Syntax
C#
protected CheckBox notSystemCheckBox

Assembly: MSS.Administration (Module: MSS.Administration)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


resultTable Field

resultTable Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> resultTable
Declaration Syntax
C#
protected Table resultTable

Assembly: MSS.Administration (Module: MSS.Administration)


ShowButton Field

ShowButton Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> ShowButton
Declaration Syntax
C#
protected Button ShowButton

Assembly: MSS.Administration (Module: MSS.Administration)


ShowButton_Click Method (sender, args)

ShowButton_Click Method (sender, args)
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> ShowButton_Click(Object, EventArgs)
Handle click on the "Show" button.
Declaration Syntax
C#
protected void ShowButton_Click(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The Sender.
args (EventArgs)
The arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


showLabel Field

showLabel Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> showLabel
Declaration Syntax
C#
protected Label showLabel

Assembly: MSS.Administration (Module: MSS.Administration)


siteDropDownList Field

siteDropDownList Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> siteDropDownList
Declaration Syntax
C#
protected DropDownList siteDropDownList

Assembly: MSS.Administration (Module: MSS.Administration)


siteLabel Field

siteLabel Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> siteLabel
Declaration Syntax
C#
protected Label siteLabel

Assembly: MSS.Administration (Module: MSS.Administration)


siteTypeDropDownList Field

siteTypeDropDownList Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> siteTypeDropDownList
Declaration Syntax
C#
protected DropDownList siteTypeDropDownList

Assembly: MSS.Administration (Module: MSS.Administration)


siteTypeLabel Field

siteTypeLabel Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> siteTypeLabel
Declaration Syntax
C#
protected Label siteTypeLabel

Assembly: MSS.Administration (Module: MSS.Administration)


systemOnlyCheckBox Field

systemOnlyCheckBox Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> systemOnlyCheckBox
Declaration Syntax
C#
protected CheckBox systemOnlyCheckBox

Assembly: MSS.Administration (Module: MSS.Administration)


Edit Class

Edit Class
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit
Edit dictionary item page
Declaration Syntax
C#
[HidePageExtendersAttribute]
public class Edit : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditEditNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | errorMessageLabel |
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | Form1 |
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | lblCaption |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | resultTable |
 | returnButton |
 | returnButton_Click(Object, EventArgs) | Return to the default page.
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Edit

Assembly: MSS.Administration (Module: MSS.Administration)


Edit Constructor

Edit Constructor
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> EditEditNew()()
Declaration Syntax
C#
public Edit()

Assembly: MSS.Administration (Module: MSS.Administration)


errorMessageLabel Field

errorMessageLabel Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> errorMessageLabel
Declaration Syntax
C#
protected Label errorMessageLabel

Assembly: MSS.Administration (Module: MSS.Administration)


Form1 Field

Form1 Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> Form1
Declaration Syntax
C#
protected HtmlForm Form1

Assembly: MSS.Administration (Module: MSS.Administration)


lblCaption Field

lblCaption Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> lblCaption
Declaration Syntax
C#
protected Label lblCaption

Assembly: MSS.Administration (Module: MSS.Administration)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


resultTable Field

resultTable Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> resultTable
Declaration Syntax
C#
protected Table resultTable

Assembly: MSS.Administration (Module: MSS.Administration)


returnButton Field

returnButton Field
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> returnButton
Declaration Syntax
C#
protected Button returnButton

Assembly: MSS.Administration (Module: MSS.Administration)


returnButton_Click Method (sender, args)

returnButton_Click Method (sender, args)
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> returnButton_Click(Object, EventArgs)
Return to the default page.
Declaration Syntax
C#
protected void returnButton_Click(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The Sender.
args (EventArgs)
The arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Application.MultiSiteControlCenter Namespace

MSS.Administration.Application.MultiSiteControlCenter Namespace
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter
Declaration Syntax
C#
namespace MSS.Administration.Application.MultiSiteControlCenter
Types
All Types Classes
Icon | Type | Description
 | MultiSiteControlCenterForm | Multi site control center application.


MultiSiteControlCenterForm Class

MultiSiteControlCenterForm Class
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm
Multi site control center application.
Declaration Syntax
C#
public class MultiSiteControlCenterForm : BaseForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiSiteControlCenterFormMultiSiteControlCenterFormNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Overrides BaseForm.HandleMessage(Message).)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | RibbonFrame |
 | RunBuackupAndRestore(Message) | Handles the "controlcenter:runBackupAndRestore" event.
 | RunDictionaryManager(Message) | Handles the "controlcenter:rundictionarymanager" event.
 | SelectedTab | Gets or sets the index of the selected tab.
 | ServerProperties()() | (Inherited from BaseForm.)
 | TabContainer |
 | Tabs | Gets the MultiSiteControlCenter tab list.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | MultiSiteControlCenterForm

Assembly: MSS.Administration (Module: MSS.Administration)


MultiSiteControlCenterForm Constructor

MultiSiteControlCenterForm Constructor
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> MultiSiteControlCenterFormMultiSiteControlCenterFormNew()()
Declaration Syntax
C#
public MultiSiteControlCenterForm()

Assembly: MSS.Administration (Module: MSS.Administration)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> HandleMessage(Message)
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)

Assembly: MSS.Administration (Module: MSS.Administration)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


RibbonFrame Field

RibbonFrame Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> RibbonFrame
Declaration Syntax
C#
protected Border RibbonFrame

Assembly: MSS.Administration (Module: MSS.Administration)


RunBuackupAndRestore Method (message)

RunBuackupAndRestore Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> RunBuackupAndRestore(Message)
Handles the "controlcenter:runBackupAndRestore" event.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:runBackupAndRestore")]
protected void RunBuackupAndRestore(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


RunDictionaryManager Method (message)

RunDictionaryManager Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> RunDictionaryManager(Message)
Handles the "controlcenter:rundictionarymanager" event.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:rundictionarymanager")]
protected void RunDictionaryManager(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


SelectedTab Property

SelectedTab Property
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> SelectedTab
Gets or sets the index of the selected tab.
Declaration Syntax
C#
protected int SelectedTab{ get; set;}
Value
The selected tab.

Assembly: MSS.Administration (Module: MSS.Administration)


TabContainer Field

TabContainer Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> TabContainer
Declaration Syntax
C#
protected Tabstrip TabContainer

Assembly: MSS.Administration (Module: MSS.Administration)


Tabs Property

Tabs Property
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter >> MultiSiteControlCenterForm >> Tabs
Gets the MultiSiteControlCenter tab list.
Declaration Syntax
C#
protected List<Item> Tabs{ get;}
Value
The list of tabs.

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Application.MultiSiteControlCenter.Classes Namespace

MSS.Administration.Application.MultiSiteControlCenter.Classes Namespace
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Classes
Declaration Syntax
C#
namespace MSS.Administration.Application.MultiSiteControlCenter.Classes
Types
All Types Classes
Icon | Type | Description
 | CreationWorker | Summary: Site creation worker application.


CreationWorker Class

CreationWorker Class
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Classes >> CreationWorker
Summary: Site creation worker application.
Declaration Syntax
C#
public class CreationWorker : Worker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreationWorkerCreationWorkerNew(WindowsIdentity) | Initializes a new instance of the CreationWorker.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets or sets the CreationWorker message. (Overrides Worker.Message.)
 | SetSiteParameters(String, String, String, String, String, String) | Sets the new site parameters.
 | Start()() | Starts site creation. (Overrides Worker.Start()().)
 | Succeed | Gets or sets a value indicating whether the result of the work is a success. (Inherited from Worker.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Worker
 |  | CreationWorker

Assembly: MSS.Administration (Module: MSS.Administration)


CreationWorker Constructor (identity)

CreationWorker Constructor (identity)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Classes >> CreationWorker >> CreationWorkerCreationWorkerNew(WindowsIdentity)
Initializes a new instance of the CreationWorker.
Declaration Syntax
C#
public CreationWorker(
    WindowsIdentity identity
)
Parameters
identity (WindowsIdentity)
The identity of the new instance.

Assembly: MSS.Administration (Module: MSS.Administration)


Message Property

Message Property
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Classes >> CreationWorker >> Message
Gets or sets the CreationWorker message.
Declaration Syntax
C#
public override string Message{ get; set;}
Value
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


SetSiteParameters Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage)

SetSiteParameters Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Classes >> CreationWorker >> SetSiteParameters(String, String, String, String, String, String)
Sets the new site parameters.
Declaration Syntax
C#
public void SetSiteParameters(
    string siteType,
    string siteID,
    string url,
    string administratorInitials,
    string administratorEmail,
    string defaultLanguage
)
Parameters
siteType (String)
Type of the site.
siteID (String)
The site ID.
url (String)
The site URL.
administratorInitials (String)
The administrator's initials.
administratorEmail (String)
The administrator's email address.
defaultLanguage (String)
The default language.

Assembly: MSS.Administration (Module: MSS.Administration)


Start Method

Start Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Classes >> CreationWorker >> Start()()
Starts site creation.
Declaration Syntax
C#
public override void Start()

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Application.MultiSiteControlCenter.Commands Namespace

MSS.Administration.Application.MultiSiteControlCenter.Commands Namespace
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Commands
Declaration Syntax
C#
namespace MSS.Administration.Application.MultiSiteControlCenter.Commands
Types
All Types Classes
Icon | Type | Description
 | CreateSite | Create site command


CreateSite Class

CreateSite Class
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Commands >> CreateSite
Create site command
Declaration Syntax
C#
public class CreateSite : Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateSiteCreateSiteNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the CreateSite command. (Overrides Command.Execute(CommandContext).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | Gets the click event. (Overrides Command.GetClick(CommandContext, String).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | (Inherited from Command.)
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CreateSite

Assembly: MSS.Administration (Module: MSS.Administration)


CreateSite Constructor

CreateSite Constructor
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Commands >> CreateSite >> CreateSiteCreateSiteNew()()
Declaration Syntax
C#
public CreateSite()

Assembly: MSS.Administration (Module: MSS.Administration)


Execute Method (context)

Execute Method (context)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Commands >> CreateSite >> Execute(CommandContext)
Executes the CreateSite command.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Assembly: MSS.Administration (Module: MSS.Administration)


GetClick Method (context, click)

GetClick Method (context, click)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Commands >> CreateSite >> GetClick(CommandContext, String)
Gets the click event.
Declaration Syntax
C#
public override string GetClick(
    CommandContext context,
    string click
)
Parameters
context (CommandContext)
The context.
click (String)
The default click event.
Return Value
The click event.

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Application.MultiSiteControlCenter.Controls Namespace

MSS.Administration.Application.MultiSiteControlCenter.Controls Namespace
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls
Declaration Syntax
C#
namespace MSS.Administration.Application.MultiSiteControlCenter.Controls
Types
All Types Classes
Icon | Type | Description
 | CreateSiteForm | Create site form
 | SitesOverviewForm | Sites overview form.
 | SiteTypesForm | Site types control management form.


CreateSiteForm Class

CreateSiteForm Class
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm
Create site form
Declaration Syntax
C#
public class CreateSiteForm : MssXmlControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateSiteFormCreateSiteFormNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AdministrationEmail |
 | AdministrationInitials |
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AlertHostnameAlreadyExist |
 | AlertIncorrectEmail |
 | AlertIncorrectHostname |
 | AlertIncorrectInitials |
 | AlertIncorrectSiteName |
 | AlertNoSiteTypeFound |
 | AlertSiteAlreadyExists |
 | AlertSiteNameIsDenied |
 | AlertSiteNameIsNotEntered |
 | AlertSitesCountIsRestrictedByLicense |
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateSiteClick(Message) | "Createsite" button event handler
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DefaultLanguageList |
 | DeniedSiteNames |
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DictionaryRoot |
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DomainName |
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from MssXmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MainPanel |
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Monitor |
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | MsgSiteWasCreated |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageViewState | Gets the view state of the page. (Inherited from MssXmlControl.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | Refresh(Message) | Refresh control center.
 | RefreshSiteCreationReport(Message) | Refreshes the report.
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | ResultLabel |
 | ResultPanel |
 | ResultUrl |
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from MssXmlControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary. (Inherited from MssXmlControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary. (Inherited from MssXmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePanel |
 | SiteTypeList |
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WebSiteName |
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | WorkerThreadSessionVariable |
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | MssXmlControl
 |  |  |  |  |  | CreateSiteForm

Assembly: MSS.Administration (Module: MSS.Administration)


CreateSiteForm Constructor

CreateSiteForm Constructor
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> CreateSiteFormCreateSiteFormNew()()
Declaration Syntax
C#
public CreateSiteForm()

Assembly: MSS.Administration (Module: MSS.Administration)


AdministrationEmail Field

AdministrationEmail Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AdministrationEmail
Declaration Syntax
C#
protected Edit AdministrationEmail

Assembly: MSS.Administration (Module: MSS.Administration)


AdministrationInitials Field

AdministrationInitials Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AdministrationInitials
Declaration Syntax
C#
protected Edit AdministrationInitials

Assembly: MSS.Administration (Module: MSS.Administration)


AlertHostnameAlreadyExist Field

AlertHostnameAlreadyExist Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertHostnameAlreadyExist
Declaration Syntax
C#
protected static readonly string AlertHostnameAlreadyExist

Assembly: MSS.Administration (Module: MSS.Administration)


AlertIncorrectEmail Field

AlertIncorrectEmail Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertIncorrectEmail
Declaration Syntax
C#
protected static readonly string AlertIncorrectEmail

Assembly: MSS.Administration (Module: MSS.Administration)


AlertIncorrectHostname Field

AlertIncorrectHostname Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertIncorrectHostname
Declaration Syntax
C#
protected static readonly string AlertIncorrectHostname

Assembly: MSS.Administration (Module: MSS.Administration)


AlertIncorrectInitials Field

AlertIncorrectInitials Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertIncorrectInitials
Declaration Syntax
C#
protected static readonly string AlertIncorrectInitials

Assembly: MSS.Administration (Module: MSS.Administration)


AlertIncorrectSiteName Field

AlertIncorrectSiteName Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertIncorrectSiteName
Declaration Syntax
C#
protected static readonly string AlertIncorrectSiteName

Assembly: MSS.Administration (Module: MSS.Administration)


AlertNoSiteTypeFound Field

AlertNoSiteTypeFound Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertNoSiteTypeFound
Declaration Syntax
C#
protected static readonly string AlertNoSiteTypeFound

Assembly: MSS.Administration (Module: MSS.Administration)


AlertSiteAlreadyExists Field

AlertSiteAlreadyExists Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertSiteAlreadyExists
Declaration Syntax
C#
protected static readonly string AlertSiteAlreadyExists

Assembly: MSS.Administration (Module: MSS.Administration)


AlertSiteNameIsDenied Field

AlertSiteNameIsDenied Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertSiteNameIsDenied
Declaration Syntax
C#
protected static readonly string AlertSiteNameIsDenied

Assembly: MSS.Administration (Module: MSS.Administration)


AlertSiteNameIsNotEntered Field

AlertSiteNameIsNotEntered Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertSiteNameIsNotEntered
Declaration Syntax
C#
protected static readonly string AlertSiteNameIsNotEntered

Assembly: MSS.Administration (Module: MSS.Administration)


AlertSitesCountIsRestrictedByLicense Field

AlertSitesCountIsRestrictedByLicense Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AlertSitesCountIsRestrictedByLicense
Declaration Syntax
C#
protected static readonly string AlertSitesCountIsRestrictedByLicense

Assembly: MSS.Administration (Module: MSS.Administration)


CreateSiteClick Method (message)

CreateSiteClick Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> CreateSiteClick(Message)
"Createsite" button event handler
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:createsite")]
protected void CreateSiteClick(
    Message message
)
Parameters
message (Message)

Assembly: MSS.Administration (Module: MSS.Administration)


DefaultLanguageList Field

DefaultLanguageList Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> DefaultLanguageList
Declaration Syntax
C#
protected Listbox DefaultLanguageList

Assembly: MSS.Administration (Module: MSS.Administration)


DeniedSiteNames Field

DeniedSiteNames Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> DeniedSiteNames
Declaration Syntax
C#
protected static readonly string DeniedSiteNames

Assembly: MSS.Administration (Module: MSS.Administration)


DictionaryRoot Field

DictionaryRoot Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> DictionaryRoot
Declaration Syntax
C#
protected static readonly string DictionaryRoot

Assembly: MSS.Administration (Module: MSS.Administration)


DomainName Field

DomainName Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> DomainName
Declaration Syntax
C#
protected Edit DomainName

Assembly: MSS.Administration (Module: MSS.Administration)


MainPanel Field

MainPanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> MainPanel
Declaration Syntax
C#
protected GridPanel MainPanel

Assembly: MSS.Administration (Module: MSS.Administration)


Monitor Field

Monitor Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> Monitor
Declaration Syntax
C#
protected TaskMonitor Monitor

Assembly: MSS.Administration (Module: MSS.Administration)


MsgSiteWasCreated Field

MsgSiteWasCreated Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> MsgSiteWasCreated
Declaration Syntax
C#
protected static readonly string MsgSiteWasCreated

Assembly: MSS.Administration (Module: MSS.Administration)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


Refresh Method (message)

Refresh Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> Refresh(Message)
Refresh control center.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:dorefresh")]
protected void Refresh(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


RefreshSiteCreationReport Method (message)

RefreshSiteCreationReport Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> RefreshSiteCreationReport(Message)
Refreshes the report.
Declaration Syntax
C#
[HandleMessageAttribute("taskmonitor:check")]
protected void RefreshSiteCreationReport(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


ResultLabel Field

ResultLabel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> ResultLabel
Declaration Syntax
C#
protected Literal ResultLabel

Assembly: MSS.Administration (Module: MSS.Administration)


ResultPanel Field

ResultPanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> ResultPanel
Declaration Syntax
C#
protected CollapsePanel ResultPanel

Assembly: MSS.Administration (Module: MSS.Administration)


ResultUrl Field

ResultUrl Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> ResultUrl
Declaration Syntax
C#
protected Edit ResultUrl

Assembly: MSS.Administration (Module: MSS.Administration)


SitePanel Field

SitePanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> SitePanel
Declaration Syntax
C#
protected CollapsePanel SitePanel

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypeList Field

SiteTypeList Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> SiteTypeList
Declaration Syntax
C#
protected Listbox SiteTypeList

Assembly: MSS.Administration (Module: MSS.Administration)


WebSiteName Field

WebSiteName Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> WebSiteName
Declaration Syntax
C#
protected Edit WebSiteName

Assembly: MSS.Administration (Module: MSS.Administration)


WorkerThreadSessionVariable Field

WorkerThreadSessionVariable Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> WorkerThreadSessionVariable
Declaration Syntax
C#
protected static readonly string WorkerThreadSessionVariable

Assembly: MSS.Administration (Module: MSS.Administration)


SitesOverviewForm Class

SitesOverviewForm Class
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm
Sites overview form.
Declaration Syntax
C#
public class SitesOverviewForm : MssXmlControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitesOverviewFormSitesOverviewFormNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangeSiteUrl(ClientPipelineArgs) | Changes the site URL.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | ConfirmDeleteAllSites |
 | ConfirmDeleteSite |
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssCacheResetSuccessfully |
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DeleteAllSites(ClientPipelineArgs) | Deletes all sites.
 | DeleteAllSitesClick(Message) | Handles "controlcenter:deleteallsites" event.
 | DeleteSiteClick(Message) | Handles controlcenter:deletesite event.
 | DeletingSite(ClientPipelineArgs) | Deletes the selected site.
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DictionaryRoot |
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DomainNameRegEx |
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetSiteContextMenu(Message) |
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from MssXmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | HostnameAlreadyExistsMsg |
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IISBindingsUpdatedSuccessfully |
 | IISBindingsUpdateFailed |
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MainPanel |
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnSiteCreated(Message) | Called when site has been created.
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | OpenSiteWindow(Message) | Opens the site in new window.
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageViewState | Gets the view state of the page. (Inherited from MssXmlControl.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RebuildSearchIndexes(Message) | Rebuilds the search indexes.
 | RefreshSiteList(Message) | Handles "controlcenter:reloadsite" event.
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | ReloadSitesClick(Message) | Handles "controlcenter:reloadsites" event.
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResetCssCache(Message) | Resets the CSS cache.
 | ResetSiteCaches(Message) | Resets the site caches.
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | ResultLabel |
 | ResultPanel |
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | sclList |
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from MssXmlControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary. (Inherited from MssXmlControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary. (Inherited from MssXmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SiteContextMenu |
 | SiteContextMenuItemPath |
 | SiteDeletedSuccessfully |
 | SiteID |
 | SiteNotFoundMessage |
 | SitesCacheResetSuccessfully |
 | SitesDeletedSuccessfully |
 | SitesIndexesRebuildedSuccessfully |
 | SitesListRefreshedSuccessfully |
 | SitesListReloadedSuccessfully |
 | SitesListView |
 | SitesPanel |
 | SitesText |
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | UpdateIISBindings(Message) |
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | MssXmlControl
 |  |  |  |  |  | SitesOverviewForm

Assembly: MSS.Administration (Module: MSS.Administration)


SitesOverviewForm Constructor

SitesOverviewForm Constructor
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesOverviewFormSitesOverviewFormNew()()
Declaration Syntax
C#
public SitesOverviewForm()

Assembly: MSS.Administration (Module: MSS.Administration)


ChangeSiteUrl Method (args)

ChangeSiteUrl Method (args)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ChangeSiteUrl(ClientPipelineArgs)
Changes the site URL.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:changesiteurl", true)]
protected void ChangeSiteUrl(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


ConfirmDeleteAllSites Field

ConfirmDeleteAllSites Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ConfirmDeleteAllSites
Declaration Syntax
C#
protected static readonly string ConfirmDeleteAllSites

Assembly: MSS.Administration (Module: MSS.Administration)


ConfirmDeleteSite Field

ConfirmDeleteSite Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ConfirmDeleteSite
Declaration Syntax
C#
protected static readonly string ConfirmDeleteSite

Assembly: MSS.Administration (Module: MSS.Administration)


CssCacheResetSuccessfully Field

CssCacheResetSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> CssCacheResetSuccessfully
Declaration Syntax
C#
protected static readonly string CssCacheResetSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


DeleteAllSites Method (args)

DeleteAllSites Method (args)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> DeleteAllSites(ClientPipelineArgs)
Deletes all sites.
Declaration Syntax
C#
protected void DeleteAllSites(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


DeleteAllSitesClick Method (message)

DeleteAllSitesClick Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> DeleteAllSitesClick(Message)
Handles "controlcenter:deleteallsites" event.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:deleteallsites")]
protected void DeleteAllSitesClick(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


DeleteSiteClick Method (message)

DeleteSiteClick Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> DeleteSiteClick(Message)
Handles controlcenter:deletesite event.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:deletesite")]
protected void DeleteSiteClick(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


DeletingSite Method (args)

DeletingSite Method (args)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> DeletingSite(ClientPipelineArgs)
Deletes the selected site.
Declaration Syntax
C#
protected void DeletingSite(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


DictionaryRoot Field

DictionaryRoot Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> DictionaryRoot
Declaration Syntax
C#
protected static readonly string DictionaryRoot

Assembly: MSS.Administration (Module: MSS.Administration)


DomainNameRegEx Field

DomainNameRegEx Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> DomainNameRegEx
Declaration Syntax
C#
protected static readonly string DomainNameRegEx

Assembly: MSS.Administration (Module: MSS.Administration)


GetSiteContextMenu Method (msg)

GetSiteContextMenu Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> GetSiteContextMenu(Message)
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:getsitecontextmenu")]
protected void GetSiteContextMenu(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Administration (Module: MSS.Administration)


HostnameAlreadyExistsMsg Field

HostnameAlreadyExistsMsg Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> HostnameAlreadyExistsMsg
Declaration Syntax
C#
protected static readonly string HostnameAlreadyExistsMsg

Assembly: MSS.Administration (Module: MSS.Administration)


IISBindingsUpdatedSuccessfully Field

IISBindingsUpdatedSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> IISBindingsUpdatedSuccessfully
Declaration Syntax
C#
protected static readonly string IISBindingsUpdatedSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


IISBindingsUpdateFailed Field

IISBindingsUpdateFailed Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> IISBindingsUpdateFailed
Declaration Syntax
C#
protected static readonly string IISBindingsUpdateFailed

Assembly: MSS.Administration (Module: MSS.Administration)


MainPanel Field

MainPanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> MainPanel
Declaration Syntax
C#
protected GridPanel MainPanel

Assembly: MSS.Administration (Module: MSS.Administration)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


OnSiteCreated Method (msg)

OnSiteCreated Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> OnSiteCreated(Message)
Called when site has been created.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:newsitewascreated")]
[HandleMessageAttribute("controlcenter:sitedeleted")]
protected void OnSiteCreated(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


OpenSiteWindow Method (msg)

OpenSiteWindow Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> OpenSiteWindow(Message)
Opens the site in new window.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:opensite")]
protected void OpenSiteWindow(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


RebuildSearchIndexes Method (msg)

RebuildSearchIndexes Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> RebuildSearchIndexes(Message)
Rebuilds the search indexes.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:rebuildsearchindexes")]
protected void RebuildSearchIndexes(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


RefreshSiteList Method (message)

RefreshSiteList Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> RefreshSiteList(Message)
Handles "controlcenter:reloadsite" event.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:refreshsitelist")]
protected void RefreshSiteList(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


ReloadSitesClick Method (message)

ReloadSitesClick Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ReloadSitesClick(Message)
Handles "controlcenter:reloadsites" event.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:reloadsites")]
protected void ReloadSitesClick(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


ResetCssCache Method (msg)

ResetCssCache Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ResetCssCache(Message)
Resets the CSS cache.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:resetcsscache")]
protected void ResetCssCache(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


ResetSiteCaches Method (msg)

ResetSiteCaches Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ResetSiteCaches(Message)
Resets the site caches.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:resetsitecaches")]
protected void ResetSiteCaches(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


ResultLabel Field

ResultLabel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ResultLabel
Declaration Syntax
C#
protected Literal ResultLabel

Assembly: MSS.Administration (Module: MSS.Administration)


ResultPanel Field

ResultPanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ResultPanel
Declaration Syntax
C#
protected CollapsePanel ResultPanel

Assembly: MSS.Administration (Module: MSS.Administration)


sclList Field

sclList Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> sclList
Declaration Syntax
C#
protected Scrollbox sclList

Assembly: MSS.Administration (Module: MSS.Administration)


SiteContextMenu Property

SiteContextMenu Property
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SiteContextMenu
Declaration Syntax
C#
protected virtual Menu SiteContextMenu{ get;}

Assembly: MSS.Administration (Module: MSS.Administration)


SiteContextMenuItemPath Field

SiteContextMenuItemPath Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SiteContextMenuItemPath
Declaration Syntax
C#
protected static readonly string SiteContextMenuItemPath

Assembly: MSS.Administration (Module: MSS.Administration)


SiteDeletedSuccessfully Field

SiteDeletedSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SiteDeletedSuccessfully
Declaration Syntax
C#
protected static readonly string SiteDeletedSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


SiteID Field

SiteID Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SiteID
Declaration Syntax
C#
protected static readonly string SiteID

Assembly: MSS.Administration (Module: MSS.Administration)


SiteNotFoundMessage Field

SiteNotFoundMessage Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SiteNotFoundMessage
Declaration Syntax
C#
protected static readonly string SiteNotFoundMessage

Assembly: MSS.Administration (Module: MSS.Administration)


SitesCacheResetSuccessfully Field

SitesCacheResetSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesCacheResetSuccessfully
Declaration Syntax
C#
protected static readonly string SitesCacheResetSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


SitesDeletedSuccessfully Field

SitesDeletedSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesDeletedSuccessfully
Declaration Syntax
C#
protected static readonly string SitesDeletedSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


SitesIndexesRebuildedSuccessfully Field

SitesIndexesRebuildedSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesIndexesRebuildedSuccessfully
Declaration Syntax
C#
protected static readonly string SitesIndexesRebuildedSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


SitesListRefreshedSuccessfully Field

SitesListRefreshedSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesListRefreshedSuccessfully
Declaration Syntax
C#
protected static readonly string SitesListRefreshedSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


SitesListReloadedSuccessfully Field

SitesListReloadedSuccessfully Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesListReloadedSuccessfully
Declaration Syntax
C#
protected static readonly string SitesListReloadedSuccessfully

Assembly: MSS.Administration (Module: MSS.Administration)


SitesListView Field

SitesListView Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesListView
Declaration Syntax
C#
protected Listview SitesListView

Assembly: MSS.Administration (Module: MSS.Administration)


SitesPanel Field

SitesPanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesPanel
Declaration Syntax
C#
protected CollapsePanel SitesPanel

Assembly: MSS.Administration (Module: MSS.Administration)


SitesText Field

SitesText Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> SitesText
Declaration Syntax
C#
protected Literal SitesText

Assembly: MSS.Administration (Module: MSS.Administration)


UpdateIISBindings Method (msg)

UpdateIISBindings Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> UpdateIISBindings(Message)
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:updateiisbindings")]
protected void UpdateIISBindings(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypesForm Class

SiteTypesForm Class
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm
Site types control management form.
Declaration Syntax
C#
public class SiteTypesForm : MssXmlControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteTypesFormSiteTypesFormNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | ConfirmDeletingSiteType |
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DeleteSiteTypeClick(Message) | Handles the "controlcenter:deletesitetype" event.
 | DeletingSiteType(ClientPipelineArgs) | Deletes the selected site type.
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DictionaryRoot |
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRefresh(Message) | Refreshes the form.
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | DuplicateSiteTypeClick(ClientPipelineArgs) | The “Duplicate site type” button has been clicked.
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from MssXmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MainPanel |
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDuplicateSiteTypeClick(Message) | Duplicates the selected site type.
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageViewState | Gets the view state of the page. (Inherited from MssXmlControl.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | ResultLabel |
 | ResultPanel |
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from MssXmlControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary. (Inherited from MssXmlControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary. (Inherited from MssXmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SiteTypeAlreadyExistMsg |
 | SiteTypeCannotBeDeletedMsg |
 | SiteTypeDeletedMsg |
 | SiteTypeDuplicatedMsg |
 | SiteTypeHasBadNameMsg |
 | SiteTypeList |
 | SiteTypePanel |
 | SiteTypePublishingMsg |
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | MssXmlControl
 |  |  |  |  |  | SiteTypesForm

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypesForm Constructor

SiteTypesForm Constructor
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypesFormSiteTypesFormNew()()
Declaration Syntax
C#
public SiteTypesForm()

Assembly: MSS.Administration (Module: MSS.Administration)


ConfirmDeletingSiteType Field

ConfirmDeletingSiteType Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> ConfirmDeletingSiteType
Declaration Syntax
C#
protected static readonly string ConfirmDeletingSiteType

Assembly: MSS.Administration (Module: MSS.Administration)


DeleteSiteTypeClick Method (message)

DeleteSiteTypeClick Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> DeleteSiteTypeClick(Message)
Handles the "controlcenter:deletesitetype" event.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:deletesitetype")]
protected void DeleteSiteTypeClick(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


DeletingSiteType Method (args)

DeletingSiteType Method (args)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> DeletingSiteType(ClientPipelineArgs)
Deletes the selected site type.
Declaration Syntax
C#
protected void DeletingSiteType(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The args.

Assembly: MSS.Administration (Module: MSS.Administration)


DictionaryRoot Field

DictionaryRoot Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> DictionaryRoot
Declaration Syntax
C#
protected static readonly string DictionaryRoot

Assembly: MSS.Administration (Module: MSS.Administration)


DoRefresh Method (message)

DoRefresh Method (message)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> DoRefresh(Message)
Refreshes the form.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:dorefresh")]
protected void DoRefresh(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


DuplicateSiteTypeClick Method (args)

DuplicateSiteTypeClick Method (args)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> DuplicateSiteTypeClick(ClientPipelineArgs)
The “Duplicate site type” button has been clicked.
Declaration Syntax
C#
protected void DuplicateSiteTypeClick(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)
The pipeline arguments.

Assembly: MSS.Administration (Module: MSS.Administration)


MainPanel Field

MainPanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> MainPanel
Declaration Syntax
C#
protected GridPanel MainPanel

Assembly: MSS.Administration (Module: MSS.Administration)


OnDuplicateSiteTypeClick Method (msg)

OnDuplicateSiteTypeClick Method (msg)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> OnDuplicateSiteTypeClick(Message)
Duplicates the selected site type.
Declaration Syntax
C#
[HandleMessageAttribute("controlcenter:duplicatesitetype")]
protected void OnDuplicateSiteTypeClick(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Administration (Module: MSS.Administration)


ResultLabel Field

ResultLabel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> ResultLabel
Declaration Syntax
C#
protected Literal ResultLabel

Assembly: MSS.Administration (Module: MSS.Administration)


ResultPanel Field

ResultPanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> ResultPanel
Declaration Syntax
C#
protected CollapsePanel ResultPanel

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypeAlreadyExistMsg Field

SiteTypeAlreadyExistMsg Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypeAlreadyExistMsg
Declaration Syntax
C#
protected static readonly string SiteTypeAlreadyExistMsg

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypeCannotBeDeletedMsg Field

SiteTypeCannotBeDeletedMsg Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypeCannotBeDeletedMsg
Declaration Syntax
C#
protected static readonly string SiteTypeCannotBeDeletedMsg

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypeDeletedMsg Field

SiteTypeDeletedMsg Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypeDeletedMsg
Declaration Syntax
C#
protected static readonly string SiteTypeDeletedMsg

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypeDuplicatedMsg Field

SiteTypeDuplicatedMsg Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypeDuplicatedMsg
Declaration Syntax
C#
protected static readonly string SiteTypeDuplicatedMsg

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypeHasBadNameMsg Field

SiteTypeHasBadNameMsg Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypeHasBadNameMsg
Declaration Syntax
C#
protected static readonly string SiteTypeHasBadNameMsg

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypeList Field

SiteTypeList Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypeList
Declaration Syntax
C#
protected Listbox SiteTypeList

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypePanel Field

SiteTypePanel Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypePanel
Declaration Syntax
C#
protected CollapsePanel SiteTypePanel

Assembly: MSS.Administration (Module: MSS.Administration)


SiteTypePublishingMsg Field

SiteTypePublishingMsg Field
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> SiteTypePublishingMsg
Declaration Syntax
C#
protected static readonly string SiteTypePublishingMsg

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Application.Workers Namespace

MSS.Administration.Application.Workers Namespace
Namespaces >> MSS.Administration.Application.Workers
Declaration Syntax
C#
namespace MSS.Administration.Application.Workers
Types
All Types Classes
Icon | Type | Description
 | Worker | Base class for the background worker classes.
 | WorkerPool | WorkerPool application.


Worker Class

Worker Class
Namespaces >> MSS.Administration.Application.Workers >> Worker
Base class for the background worker classes.
Declaration Syntax
C#
public abstract class Worker
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WorkerWorkerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets or sets the work message.
 | Start()() | Starts the work.
 | Succeed | Gets or sets a value indicating whether the result of the work is a success.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Worker
 |  | CreationWorker
 |  | RestoreWorker
 |  | BackupWorker

Assembly: MSS.Administration (Module: MSS.Administration)


Worker Constructor

Worker Constructor
Namespaces >> MSS.Administration.Application.Workers >> Worker >> WorkerWorkerNew()()
Declaration Syntax
C#
protected Worker()

Assembly: MSS.Administration (Module: MSS.Administration)


Message Property

Message Property
Namespaces >> MSS.Administration.Application.Workers >> Worker >> Message
Gets or sets the work message.
Declaration Syntax
C#
public virtual string Message{ get; set;}
Value
The message.

Assembly: MSS.Administration (Module: MSS.Administration)


Start Method

Start Method
Namespaces >> MSS.Administration.Application.Workers >> Worker >> Start()()
Starts the work.
Declaration Syntax
C#
public abstract void Start()

Assembly: MSS.Administration (Module: MSS.Administration)


Succeed Property

Succeed Property
Namespaces >> MSS.Administration.Application.Workers >> Worker >> Succeed
Gets or sets a value indicating whether the result of the work is a success.
Declaration Syntax
C#
public virtual bool Succeed{ get; set;}
Value
True if a success; otherwise, false.

Assembly: MSS.Administration (Module: MSS.Administration)


WorkerPool Class

WorkerPool Class
Namespaces >> MSS.Administration.Application.Workers >> WorkerPool
WorkerPool application.
Declaration Syntax
C#
public class WorkerPool
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WorkerPoolWorkerPoolNew()() |
 | Add(ID, Worker) | Adds a new worker.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(ID) | Gets the worker by id.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsPresent(ID) | Determines whether the specified worker with a specific worker id is present.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(ID) | Removes a specific worker.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WorkerPool

Assembly: MSS.Administration (Module: MSS.Administration)


WorkerPool Constructor

WorkerPool Constructor
Namespaces >> MSS.Administration.Application.Workers >> WorkerPool >> WorkerPoolWorkerPoolNew()()
Declaration Syntax
C#
public WorkerPool()

Assembly: MSS.Administration (Module: MSS.Administration)


Add Method (workerId, worker)

Add Method (workerId, worker)
Namespaces >> MSS.Administration.Application.Workers >> WorkerPool >> Add(ID, Worker)
Adds a new worker.
Declaration Syntax
C#
public static void Add(
    ID workerId,
    Worker worker
)
Parameters
workerId (ID)
The worker id.
worker (Worker)
The worker.

Assembly: MSS.Administration (Module: MSS.Administration)


Get Method (workerId)

Get Method (workerId)
Namespaces >> MSS.Administration.Application.Workers >> WorkerPool >> Get(ID)
Gets the worker by id.
Declaration Syntax
C#
public static Worker Get(
    ID workerId
)
Parameters
workerId (ID)
The worker id.
Return Value

Assembly: MSS.Administration (Module: MSS.Administration)


IsPresent Method (workerId)

IsPresent Method (workerId)
Namespaces >> MSS.Administration.Application.Workers >> WorkerPool >> IsPresent(ID)
Determines whether the specified worker with a specific worker id is present.
Declaration Syntax
C#
public static bool IsPresent(
    ID workerId
)
Parameters
workerId (ID)
The worker id.
Return Value
true if the specified worker id is present; otherwise, false.

Assembly: MSS.Administration (Module: MSS.Administration)


Remove Method (workerId)

Remove Method (workerId)
Namespaces >> MSS.Administration.Application.Workers >> WorkerPool >> Remove(ID)
Removes a specific worker.
Declaration Syntax
C#
public static void Remove(
    ID workerId
)
Parameters
workerId (ID)
The worker id.

Assembly: MSS.Administration (Module: MSS.Administration)


MSS.Administration.Dialogs Namespace

MSS.Administration.Dialogs Namespace
Namespaces >> MSS.Administration.Dialogs
Declaration Syntax
C#
namespace MSS.Administration.Dialogs
Types
All Types Classes
Icon | Type | Description
 | ImageBrowserForm |
 | InsertVideoForm | Allows the user to select a media item from the media library and insert it in a html field.


ImageBrowserForm Class

ImageBrowserForm Class
Namespaces >> MSS.Administration.Dialogs >> ImageBrowserForm
Declaration Syntax
C#
public class ImageBrowserForm : InsertVideoForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageBrowserFormImageBrowserFormNew()() |
 | AdvancedMode |
 | Cancel()() | (Inherited from DialogForm.)
 | DataContext | (Inherited from InsertVideoForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from InsertVideoForm.)
 | Height | (Inherited from InsertVideoForm.)
 | MediaItemId | (Inherited from InsertVideoForm.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OK()() | (Inherited from DialogForm.)
 | OnCancel(Object, EventArgs) | (Inherited from DialogForm.)
 | OnLoad(EventArgs) | (Inherited from InsertVideoForm.)
 | OnOK(Object, EventArgs) | Called when Ok button has been clicked. (Inherited from InsertVideoForm.)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | Options | (Inherited from InsertVideoForm.)
 | Preview | (Inherited from InsertVideoForm.)
 | RefreshOptions()() | (Overrides InsertVideoForm.RefreshOptions()().)
 | ReturnValue(Item) | (Overrides InsertVideoForm.ReturnValue(Item).)
 | SelectTreeNode()() | (Inherited from InsertVideoForm.)
 | ServerProperties()() | (Inherited from BaseForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UploadClick()() | (Inherited from InsertVideoForm.)
 | VideoItem | (Inherited from InsertVideoForm.)
 | Width | (Inherited from InsertVideoForm.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | DialogForm
 |  |  | InsertVideoForm
 |  |  |  | ImageBrowserForm

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


ImageBrowserForm Constructor

ImageBrowserForm Constructor
Namespaces >> MSS.Administration.Dialogs >> ImageBrowserForm >> ImageBrowserFormImageBrowserFormNew()()
Declaration Syntax
C#
public ImageBrowserForm()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


AdvancedMode Property

AdvancedMode Property
Namespaces >> MSS.Administration.Dialogs >> ImageBrowserForm >> AdvancedMode
Declaration Syntax
C#
protected bool AdvancedMode{ get;}

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


RefreshOptions Method

RefreshOptions Method
Namespaces >> MSS.Administration.Dialogs >> ImageBrowserForm >> RefreshOptions()()
Declaration Syntax
C#
protected override void RefreshOptions()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


ReturnValue Method (mediaItem)

ReturnValue Method (mediaItem)
Namespaces >> MSS.Administration.Dialogs >> ImageBrowserForm >> ReturnValue(Item)
Declaration Syntax
C#
protected override void ReturnValue(
    Item mediaItem
)
Parameters
mediaItem (Item)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


InsertVideoForm Class

InsertVideoForm Class
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm
Allows the user to select a media item from the media library and insert it in a html field.
Declaration Syntax
C#
public class InsertVideoForm : DialogForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InsertVideoFormInsertVideoFormNew()() |
 | Cancel()() | (Inherited from DialogForm.)
 | DataContext |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Overrides BaseForm.HandleMessage(Message).)
 | Height |
 | MediaItemId |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OK()() | (Inherited from DialogForm.)
 | OnCancel(Object, EventArgs) | (Inherited from DialogForm.)
 | OnLoad(EventArgs) | (Overrides DialogForm.OnLoad(EventArgs).)
 | OnOK(Object, EventArgs) | Called when Ok button has been clicked. (Overrides DialogForm.OnOK(Object, EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | Options |
 | Preview |
 | RefreshOptions()() |
 | ReturnValue(Item) |
 | SelectTreeNode()() |
 | ServerProperties()() | (Inherited from BaseForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UploadClick()() |
 | VideoItem |
 | Width |
Inheritance Hierarchy
Object
 | BaseForm
 |  | DialogForm
 |  |  | InsertVideoForm
 |  |  |  | ImageBrowserForm

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


InsertVideoForm Constructor

InsertVideoForm Constructor
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> InsertVideoFormInsertVideoFormNew()()
Declaration Syntax
C#
public InsertVideoForm()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


DataContext Field

DataContext Field
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> DataContext
Declaration Syntax
C#
protected DataContext DataContext

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> HandleMessage(Message)
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


Height Field

Height Field
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> Height
Declaration Syntax
C#
protected Edit Height

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


MediaItemId Property

MediaItemId Property
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> MediaItemId
Declaration Syntax
C#
protected ID MediaItemId{ get; set;}

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


OnOK Method (sender, args)

OnOK Method (sender, args)
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> OnOK(Object, EventArgs)
Called when Ok button has been clicked.
Declaration Syntax
C#
protected override void OnOK(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


Options Field

Options Field
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> Options
Declaration Syntax
C#
protected Border Options

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


Preview Field

Preview Field
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> Preview
Declaration Syntax
C#
protected Border Preview

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


RefreshOptions Method

RefreshOptions Method
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> RefreshOptions()()
Declaration Syntax
C#
protected virtual void RefreshOptions()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


ReturnValue Method (mediaItem)

ReturnValue Method (mediaItem)
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> ReturnValue(Item)
Declaration Syntax
C#
protected virtual void ReturnValue(
    Item mediaItem
)
Parameters
mediaItem (Item)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


SelectTreeNode Method

SelectTreeNode Method
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> SelectTreeNode()()
Declaration Syntax
C#
protected void SelectTreeNode()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


UploadClick Method

UploadClick Method
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> UploadClick()()
Declaration Syntax
C#
protected void UploadClick()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


VideoItem Property

VideoItem Property
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> VideoItem
Declaration Syntax
C#
protected bool VideoItem{ get; set;}

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


Width Field

Width Field
Namespaces >> MSS.Administration.Dialogs >> InsertVideoForm >> Width
Declaration Syntax
C#
protected Edit Width

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


MSS.Caching Namespace

MSS.Caching Namespace
Namespaces >> MSS.Caching
Declaration Syntax
C#
namespace MSS.Caching
Types
All Types Classes Interfaces
Icon | Type | Description
 | Cache<(Of <TKey, TData>)> | Cache which contains the ICacheable entity.
 | CacheClearer | Clear entity from the cache
 | CacheEntry<(Of <TKey>)> | Represents a key/value pair
 | CacheEventHandler | Clear caches on the “item:saved” and “item:deleted” events.
 | CacheManager<(Of <TKey>)> |
 | ICache<(Of <TKey>)> | Interface for all caches
 | ICacheable | Defines that an object can be cacheable.
 | ICacheClearer | Cache clearer
 | ICacheManager<(Of <TKey>)> | Defines the properties and methods that cache manager must implement.
 | ParentItemCacheClearer | Search the item in the parent items with templateID. If the item exists remove it from cache.


Cache Class

Cache<(Of <TKey, TData>)> Class
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)>
Cache which contains the ICacheable entity.
Declaration Syntax
C#
public class Cache<TKey, TData> : ICache<TKey>
Generic Template Parameters
TKey
TData
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cache<(Of <TKey, TData>)>Cache<(Of <TKey, TData>)>New()() |
 | Add(TKey, ICacheable) | Adds an entity.
 | Clear()() | Removes all elements from the cache.
 | Count | Gets a count of the elements in the cache.
 | CreateEntry(TKey, ICacheable) | Creates a cache entry.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetData(TKey) | Gets the entity by key.
 | GetEntries<(Of <TReturnType>)>()() | Gets the cache entries.
 | GetEntry(TKey) | Gets the cache entry.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(TKey) | Removes an element from the cache.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Cache<(Of <TKey, TData>)>

Assembly: MSS.Kernel (Module: MSS.Kernel)


Cache Constructor

Cache<(Of <TKey, TData>)> Constructor
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> Cache<(Of <TKey, TData>)>Cache<(Of <TKey, TData>)>New()()
Declaration Syntax
C#
public Cache()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Add Method (key, data)

Add Method (key, data)
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> Add(TKey, ICacheable)
Adds an entity.
Declaration Syntax
C#
public void Add(
    TKey key,
    ICacheable data
)
Parameters
key (TKey)
The key.
data (ICacheable)
The data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clear Method

Clear Method
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> Clear()()
Removes all elements from the cache.
Declaration Syntax
C#
public void Clear()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Count Property

Count Property
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> Count
Gets a count of the elements in the cache.
Declaration Syntax
C#
public int Count{ get;}
Value
The count.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateEntry Method (key, data)

CreateEntry Method (key, data)
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> CreateEntry(TKey, ICacheable)
Creates a cache entry.
Declaration Syntax
C#
protected virtual CacheEntry<TKey> CreateEntry(
    TKey key,
    ICacheable data
)
Parameters
key (TKey)
The key.
data (ICacheable)
The data.
Return Value
The cache entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetData Method (key)

GetData Method (key)
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> GetData(TKey)
Gets the entity by key.
Declaration Syntax
C#
public ICacheable GetData(
    TKey key
)
Parameters
key (TKey)
The key.
Return Value
The entity key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntries Method

GetEntries<(Of <TReturnType>)> Method
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> GetEntries<(Of <TReturnType>)>()()
Gets the cache entries.
Declaration Syntax
C#
public IEnumerable<TReturnType> GetEntries<TReturnType>() where TReturnType : class
Generic Template Parameters
TReturnType
Return Value
The cache entries.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntry Method (key)

GetEntry Method (key)
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> GetEntry(TKey)
Gets the cache entry.
Declaration Syntax
C#
public CacheEntry<TKey> GetEntry(
    TKey key
)
Parameters
key (TKey)
The key.
Return Value
The cache entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Remove Method (key)

Remove Method (key)
Namespaces >> MSS.Caching >> Cache<(Of <TKey, TData>)> >> Remove(TKey)
Removes an element from the cache.
Declaration Syntax
C#
public void Remove(
    TKey key
)
Parameters
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheClearer Class

CacheClearer Class
Namespaces >> MSS.Caching >> CacheClearer
Clear entity from the cache
Declaration Syntax
C#
public class CacheClearer : ICacheClearer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CacheClearerCacheClearerNew(ID, Boolean) | Initializes a new instance of the CacheClearer class.
 | Clear(Database, ID) | Clears the entity from the cache
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheClearer

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheClearer Constructor (cacheID, useDatabase)

CacheClearer Constructor (cacheID, useDatabase)
Namespaces >> MSS.Caching >> CacheClearer >> CacheClearerCacheClearerNew(ID, Boolean)
Initializes a new instance of the CacheClearer class.
Declaration Syntax
C#
public CacheClearer(
    ID cacheID,
    bool useDatabase
)
Parameters
cacheID (ID)
The cache ID.
useDatabase (Boolean)
If set to true use the database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clear Method (database, entityID)

Clear Method (database, entityID)
Namespaces >> MSS.Caching >> CacheClearer >> Clear(Database, ID)
Clears the entity from the cache
Declaration Syntax
C#
public void Clear(
    Database database,
    ID entityID
)
Parameters
database (Database)
The database.
entityID (ID)
The entity ID.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheEntry Class

CacheEntry<(Of <TKey>)> Class
Namespaces >> MSS.Caching >> CacheEntry<(Of <TKey>)>
Represents a key/value pair
Declaration Syntax
C#
public class CacheEntry<TKey>
Generic Template Parameters
TKey
Type of keys
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheEntry<(Of <TKey>)>CacheEntry<(Of <TKey>)>New(TKey, ICacheable) |
 | Data |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheEntry<(Of <TKey>)>

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheEntry Constructor (key, data)

CacheEntry<(Of <TKey>)> Constructor (key, data)
Namespaces >> MSS.Caching >> CacheEntry<(Of <TKey>)> >> CacheEntry<(Of <TKey>)>CacheEntry<(Of <TKey>)>New(TKey, ICacheable)
Declaration Syntax
C#
public CacheEntry(
    TKey key,
    ICacheable data
)
Parameters
key (TKey)
data (ICacheable)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Data Property

Data Property
Namespaces >> MSS.Caching >> CacheEntry<(Of <TKey>)> >> Data
Declaration Syntax
C#
public ICacheable Data{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheEventHandler Class

CacheEventHandler Class
Namespaces >> MSS.Caching >> CacheEventHandler
Clear caches on the “item:saved” and “item:deleted” events.
Declaration Syntax
C#
public class CacheEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CacheEventHandlerCacheEventHandlerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Handle “item:deleted” events.
 | OnItemSaved(Object, EventArgs) | Handle “item:saved” events.
 | RegisterClearer(ID, ICacheClearer) | Registers the cache clearer.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheEventHandler

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheEventHandler Constructor

CacheEventHandler Constructor
Namespaces >> MSS.Caching >> CacheEventHandler >> CacheEventHandlerCacheEventHandlerNew()()
Declaration Syntax
C#
public CacheEventHandler()

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces >> MSS.Caching >> CacheEventHandler >> OnItemDeleted(Object, EventArgs)
Handle “item:deleted” events.
Declaration Syntax
C#
public void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces >> MSS.Caching >> CacheEventHandler >> OnItemSaved(Object, EventArgs)
Handle “item:saved” events.
Declaration Syntax
C#
public void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RegisterClearer Method (templateId, clearer)

RegisterClearer Method (templateId, clearer)
Namespaces >> MSS.Caching >> CacheEventHandler >> RegisterClearer(ID, ICacheClearer)
Registers the cache clearer.
Declaration Syntax
C#
public static void RegisterClearer(
    ID templateId,
    ICacheClearer clearer
)
Parameters
templateId (ID)
The template id.
clearer (ICacheClearer)
The clearer.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheManager Class

CacheManager<(Of <TKey>)> Class
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)>
Declaration Syntax
C#
public class CacheManager<TKey> : ICacheManager<TKey>
Generic Template Parameters
TKey
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CacheManager<(Of <TKey>)>CacheManager<(Of <TKey>)>New()() | Initializes a new instance of the CacheManager<(Of <TKey>)> class.
 | AddCache(TKey, ICache<(Of <TKey>)>) | Adds the cache.
 | AddCache(Database, TKey, ICache<(Of <TKey>)>) | Adds the cache for a specific database.
 | ClearAllCaches()() | Remove all caches from the cache manager.
 | ClearAllDatabaseCaches(Database) | Remove all caches from the cache manager for a specific database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCache(TKey) | Gets the cache with a specific key.
 | GetCache(Database, TKey) | Gets the cache for a specific database.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveCache(TKey) | Removes the cache with a specific key.
 | RemoveCache(Database, TKey) | Removes the cache for a specific database.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheManager<(Of <TKey>)>

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheManager Constructor

CacheManager<(Of <TKey>)> Constructor
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> CacheManager<(Of <TKey>)>CacheManager<(Of <TKey>)>New()()
Initializes a new instance of the CacheManager<(Of <TKey>)> class.
Declaration Syntax
C#
public CacheManager()

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddCache Method

AddCache Method
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> AddCache()()
Members
Icon | Member | Description
 | AddCache(TKey, ICache<(Of <TKey>)>) | Adds the cache.
 | AddCache(Database, TKey, ICache<(Of <TKey>)>) | Adds the cache for a specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddCache Method (database, key, cache)

AddCache Method (database, key, cache)
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> AddCache(Database, TKey, ICache<(Of <TKey>)>)
Adds the cache for a specific database.
Declaration Syntax
C#
public void AddCache(
    Database database,
    TKey key,
    ICache<TKey> cache
)
Parameters
database (Database)
The database.
key (TKey)
The key.
cache (ICache <(Of <TKey>)>)
The cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddCache Method (key, cache)

AddCache Method (key, cache)
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> AddCache(TKey, ICache<(Of <TKey>)>)
Adds the cache.
Declaration Syntax
C#
public void AddCache(
    TKey key,
    ICache<TKey> cache
)
Parameters
key (TKey)
The key.
cache (ICache <(Of <TKey>)>)
The cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAllCaches Method

ClearAllCaches Method
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> ClearAllCaches()()
Remove all caches from the cache manager.
Declaration Syntax
C#
public void ClearAllCaches()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAllDatabaseCaches Method (database)

ClearAllDatabaseCaches Method (database)
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> ClearAllDatabaseCaches(Database)
Remove all caches from the cache manager for a specific database.
Declaration Syntax
C#
public void ClearAllDatabaseCaches(
    Database database
)
Parameters
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCache Method

GetCache Method
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> GetCache()()
Members
Icon | Member | Description
 | GetCache(TKey) | Gets the cache with a specific key.
 | GetCache(Database, TKey) | Gets the cache for a specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCache Method (database, key)

GetCache Method (database, key)
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> GetCache(Database, TKey)
Gets the cache for a specific database.
Declaration Syntax
C#
public ICache<TKey> GetCache(
    Database database,
    TKey key
)
Parameters
database (Database)
The database.
key (TKey)
The key.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCache Method (key)

GetCache Method (key)
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> GetCache(TKey)
Gets the cache with a specific key.
Declaration Syntax
C#
public ICache<TKey> GetCache(
    TKey key
)
Parameters
key (TKey)
The key.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveCache Method

RemoveCache Method
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> RemoveCache()()
Members
Icon | Member | Description
 | RemoveCache(TKey) | Removes the cache with a specific key.
 | RemoveCache(Database, TKey) | Removes the cache for a specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveCache Method (database, key)

RemoveCache Method (database, key)
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> RemoveCache(Database, TKey)
Removes the cache for a specific database.
Declaration Syntax
C#
public void RemoveCache(
    Database database,
    TKey key
)
Parameters
database (Database)
The database.
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveCache Method (key)

RemoveCache Method (key)
Namespaces >> MSS.Caching >> CacheManager<(Of <TKey>)> >> RemoveCache(TKey)
Removes the cache with a specific key.
Declaration Syntax
C#
public void RemoveCache(
    TKey key
)
Parameters
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ICache Interface

ICache<(Of <TKey>)> Interface
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)>
Interface for all caches
Declaration Syntax
C#
public interface ICache<TKey>
Generic Template Parameters
TKey
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(TKey, ICacheable) | Add entity.
 | Clear()() | Removes all elements from the cache.
 | Count | Gets the count of the elements in the cache.
 | GetData(TKey) | Gets the data by key.
 | GetEntries<(Of <TReturnType>)>()() | Gets the cache entities.
 | GetEntry(TKey) | Gets the cache entry.
 | Remove(TKey) | Removes an element.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Add Method (key, value)

Add Method (key, value)
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)> >> Add(TKey, ICacheable)
Add entity.
Declaration Syntax
C#
void Add(
    TKey key,
    ICacheable value
)
Parameters
key (TKey)
The key.
value (ICacheable)
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clear Method

Clear Method
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)> >> Clear()()
Removes all elements from the cache.
Declaration Syntax
C#
void Clear()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Count Property

Count Property
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)> >> Count
Gets the count of the elements in the cache.
Declaration Syntax
C#
int Count{ get;}
Value
The count.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetData Method (key)

GetData Method (key)
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)> >> GetData(TKey)
Gets the data by key.
Declaration Syntax
C#
ICacheable GetData(
    TKey key
)
Parameters
key (TKey)
The key.
Return Value
The data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntries Method

GetEntries<(Of <TReturnType>)> Method
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)> >> GetEntries<(Of <TReturnType>)>()()
Gets the cache entities.
Declaration Syntax
C#
IEnumerable<TReturnType> GetEntries<TReturnType>() where TReturnType : class
Generic Template Parameters
TReturnType
Return Value
The cache entries.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntry Method (key)

GetEntry Method (key)
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)> >> GetEntry(TKey)
Gets the cache entry.
Declaration Syntax
C#
CacheEntry<TKey> GetEntry(
    TKey key
)
Parameters
key (TKey)
The key.
Return Value
The cache entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Remove Method (key)

Remove Method (key)
Namespaces >> MSS.Caching >> ICache<(Of <TKey>)> >> Remove(TKey)
Removes an element.
Declaration Syntax
C#
void Remove(
    TKey key
)
Parameters
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ICacheable Interface

ICacheable Interface
Namespaces >> MSS.Caching >> ICacheable
Defines that an object can be cacheable.
Declaration Syntax
C#
public interface ICacheable

Assembly: MSS.Kernel (Module: MSS.Kernel)


ICacheClearer Interface

ICacheClearer Interface
Namespaces >> MSS.Caching >> ICacheClearer
Cache clearer
Declaration Syntax
C#
public interface ICacheClearer
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear(Database, ID) | Clears the entity from the cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clear Method (database, entityID)

Clear Method (database, entityID)
Namespaces >> MSS.Caching >> ICacheClearer >> Clear(Database, ID)
Clears the entity from the cache.
Declaration Syntax
C#
void Clear(
    Database database,
    ID entityID
)
Parameters
database (Database)
The database.
entityID (ID)
The entity ID.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ICacheManager Interface

ICacheManager<(Of <TKey>)> Interface
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)>
Defines the properties and methods that cache manager must implement.
Declaration Syntax
C#
public interface ICacheManager<TKey>
Generic Template Parameters
TKey
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddCache(TKey, ICache<(Of <TKey>)>) | Adds the cache for a specific database.
 | AddCache(Database, TKey, ICache<(Of <TKey>)>) | Adds the cache.
 | ClearAllCaches()() | Clears all caches.
 | ClearAllDatabaseCaches(Database) | Clears all caches for a specific database.
 | GetCache(TKey) | Gets the cache.
 | GetCache(Database, TKey) | Gets the cache.
 | RemoveCache(TKey) | Removes the cache.
 | RemoveCache(Database, TKey) | Removes the cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddCache Method

AddCache Method
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> AddCache()()
Members
Icon | Member | Description
 | AddCache(TKey, ICache<(Of <TKey>)>) | Adds the cache for a specific database.
 | AddCache(Database, TKey, ICache<(Of <TKey>)>) | Adds the cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddCache Method (database, key, cache)

AddCache Method (database, key, cache)
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> AddCache(Database, TKey, ICache<(Of <TKey>)>)
Adds the cache.
Declaration Syntax
C#
void AddCache(
    Database database,
    TKey key,
    ICache<TKey> cache
)
Parameters
database (Database)
The database.
key (TKey)
The key.
cache (ICache <(Of <TKey>)>)
The cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddCache Method (key, cache)

AddCache Method (key, cache)
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> AddCache(TKey, ICache<(Of <TKey>)>)
Adds the cache for a specific database.
Declaration Syntax
C#
void AddCache(
    TKey key,
    ICache<TKey> cache
)
Parameters
key (TKey)
The key.
cache (ICache <(Of <TKey>)>)
The cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAllCaches Method

ClearAllCaches Method
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> ClearAllCaches()()
Clears all caches.
Declaration Syntax
C#
void ClearAllCaches()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAllDatabaseCaches Method (database)

ClearAllDatabaseCaches Method (database)
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> ClearAllDatabaseCaches(Database)
Clears all caches for a specific database.
Declaration Syntax
C#
void ClearAllDatabaseCaches(
    Database database
)
Parameters
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCache Method

GetCache Method
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> GetCache()()
Members
Icon | Member | Description
 | GetCache(TKey) | Gets the cache.
 | GetCache(Database, TKey) | Gets the cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCache Method (database, key)

GetCache Method (database, key)
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> GetCache(Database, TKey)
Gets the cache.
Declaration Syntax
C#
ICache<TKey> GetCache(
    Database database,
    TKey key
)
Parameters
database (Database)
The database.
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCache Method (key)

GetCache Method (key)
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> GetCache(TKey)
Gets the cache.
Declaration Syntax
C#
ICache<TKey> GetCache(
    TKey key
)
Parameters
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveCache Method

RemoveCache Method
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> RemoveCache()()
Members
Icon | Member | Description
 | RemoveCache(TKey) | Removes the cache.
 | RemoveCache(Database, TKey) | Removes the cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveCache Method (database, key)

RemoveCache Method (database, key)
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> RemoveCache(Database, TKey)
Removes the cache.
Declaration Syntax
C#
void RemoveCache(
    Database database,
    TKey key
)
Parameters
database (Database)
The database.
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveCache Method (key)

RemoveCache Method (key)
Namespaces >> MSS.Caching >> ICacheManager<(Of <TKey>)> >> RemoveCache(TKey)
Removes the cache.
Declaration Syntax
C#
void RemoveCache(
    TKey key
)
Parameters
key (TKey)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ParentItemCacheClearer Class

ParentItemCacheClearer Class
Namespaces >> MSS.Caching >> ParentItemCacheClearer
Search the item in the parent items with templateID. If the item exists remove it from cache.
Declaration Syntax
C#
public class ParentItemCacheClearer : ICacheClearer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParentItemCacheClearerParentItemCacheClearerNew(ID, Boolean, ID, Int32) | Initializes a new instance of the ParentItemCacheClearer class.
 | Clear(Database, ID) | Clears the entity from the cache
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ParentItemCacheClearer

Assembly: MSS.Kernel (Module: MSS.Kernel)


ParentItemCacheClearer Constructor (cacheID, useDatabase, parentTemplateID, level)

ParentItemCacheClearer Constructor (cacheID, useDatabase, parentTemplateID, level)
Namespaces >> MSS.Caching >> ParentItemCacheClearer >> ParentItemCacheClearerParentItemCacheClearerNew(ID, Boolean, ID, Int32)
Initializes a new instance of the ParentItemCacheClearer class.
Declaration Syntax
C#
public ParentItemCacheClearer(
    ID cacheID,
    bool useDatabase,
    ID parentTemplateID,
    int level
)
Parameters
cacheID (ID)
The cache ID.
useDatabase (Boolean)
If set to true use the database.
parentTemplateID (ID)
The parent template ID.
level (Int32)
The parent items level.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clear Method (database, entityID)

Clear Method (database, entityID)
Namespaces >> MSS.Caching >> ParentItemCacheClearer >> Clear(Database, ID)
Clears the entity from the cache
Declaration Syntax
C#
public void Clear(
    Database database,
    ID entityID
)
Parameters
database (Database)
The database.
entityID (ID)
The entity ID.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Configuration Namespace

MSS.Configuration Namespace
Namespaces >> MSS.Configuration
Declaration Syntax
C#
namespace MSS.Configuration
Types
All Types Classes
Icon | Type | Description
 | CacheIDs | IDs of the caches
 | ConfigFile | Provides a global Settings mechanism. Uses system filewatcher functionality to register file changes
 | Factory | MSS factory.
 | FieldIDs | Field ID’s application.
 | ItemIDs | IDs of the some items
 | Settings | Strongly type systemwide settings. Settings can come from a file or Sitecore content.
 | TemplateIDs | Template IDs.


CacheIDs Class

CacheIDs Class
Namespaces >> MSS.Configuration >> CacheIDs
IDs of the caches
Declaration Syntax
C#
public class CacheIDs
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheIDsCacheIDsNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SiteContextCache |
 | SiteDataCache |
 | SiteTemplateCache |
 | SiteTypeCache |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CacheIDs

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheIDs Constructor

CacheIDs Constructor
Namespaces >> MSS.Configuration >> CacheIDs >> CacheIDsCacheIDsNew()()
Declaration Syntax
C#
public CacheIDs()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextCache Field

SiteContextCache Field
Namespaces >> MSS.Configuration >> CacheIDs >> SiteContextCache
Declaration Syntax
C#
public static ID SiteContextCache

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteDataCache Field

SiteDataCache Field
Namespaces >> MSS.Configuration >> CacheIDs >> SiteDataCache
Declaration Syntax
C#
public static ID SiteDataCache

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTemplateCache Field

SiteTemplateCache Field
Namespaces >> MSS.Configuration >> CacheIDs >> SiteTemplateCache
Declaration Syntax
C#
public static ID SiteTemplateCache

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeCache Field

SiteTypeCache Field
Namespaces >> MSS.Configuration >> CacheIDs >> SiteTypeCache
Declaration Syntax
C#
public static ID SiteTypeCache

Assembly: MSS.Kernel (Module: MSS.Kernel)


ConfigFile Class

ConfigFile Class
Namespaces >> MSS.Configuration >> ConfigFile
Provides a global Settings mechanism. Uses system filewatcher functionality to register file changes
Declaration Syntax
C#
public class ConfigFile : Singleton<ConfigFile>
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigFileChanged |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSecurityRolesForRight(String, Boolean) | Gets the list or role names which were allowed/denyed to have a right
 | GetSetting(String) | Gets the setting by the key.
 | GetSetting(String, String) | Gets the setting by the key.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSaving | Gets or sets a value indicating whether the config file is saving.
 | Item[([String])] | Gets or Sets the value of a //configuration/appSettings/add node.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnConfigFileChanged()() | Notify subscribers that config settings has changed
 | Save()() | Saves settings to the config file.
 | SiteTemplate | Gets the site template.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteSetting(String, String) | Write setting to config file.
Inheritance Hierarchy
Object
 | Singleton <(Of <ConfigFile>)>
 |  | ConfigFile

Assembly: MSS.Kernel (Module: MSS.Kernel)


ConfigFileChanged Event

ConfigFileChanged Event
Namespaces >> MSS.Configuration >> ConfigFile >> ConfigFileChanged
Declaration Syntax
C#
public event EventHandler ConfigFileChanged

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSecurityRolesForRight Method (right, allowed)

GetSecurityRolesForRight Method (right, allowed)
Namespaces >> MSS.Configuration >> ConfigFile >> GetSecurityRolesForRight(String, Boolean)
Gets the list or role names which were allowed/denyed to have a right
Declaration Syntax
C#
public string[] GetSecurityRolesForRight(
    string right,
    bool allowed
)
Parameters
right (String)
Right name
allowed (Boolean)
If true returns roles which have the right, otherwice returns the roles which were denyed to have the right
Return Value
Role name list

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSetting Method

GetSetting Method
Namespaces >> MSS.Configuration >> ConfigFile >> GetSetting()()
Members
Icon | Member | Description
 | GetSetting(String) | Gets the setting by the key.
 | GetSetting(String, String) | Gets the setting by the key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSetting Method (key)

GetSetting Method (key)
Namespaces >> MSS.Configuration >> ConfigFile >> GetSetting(String)
Gets the setting by the key.
Declaration Syntax
C#
public string GetSetting(
    string key
)
Parameters
key (String)
The key.
Return Value
The settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSetting Method (key, defaultValue)

GetSetting Method (key, defaultValue)
Namespaces >> MSS.Configuration >> ConfigFile >> GetSetting(String, String)
Gets the setting by the key.
Declaration Syntax
C#
public string GetSetting(
    string key,
    string defaultValue
)
Parameters
key (String)
The key.
defaultValue (String)
The default value.
Return Value
The settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsSaving Property

IsSaving Property
Namespaces >> MSS.Configuration >> ConfigFile >> IsSaving
Gets or sets a value indicating whether the config file is saving.
Declaration Syntax
C#
public bool IsSaving{ get; set;}
Value
True if this instance is saving; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property (key)

Item Property (key)
Namespaces >> MSS.Configuration >> ConfigFile >> Item[([String])]
Gets or Sets the value of a //configuration/appSettings/add node.
Declaration Syntax
C#
public string this[
    string key
]{ get; set;}
Parameters
key (String)
Value
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnConfigFileChanged Method

OnConfigFileChanged Method
Namespaces >> MSS.Configuration >> ConfigFile >> OnConfigFileChanged()()
Notify subscribers that config settings has changed
Declaration Syntax
C#
protected virtual void OnConfigFileChanged()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Save Method

Save Method
Namespaces >> MSS.Configuration >> ConfigFile >> Save()()
Saves settings to the config file.
Declaration Syntax
C#
public void Save()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTemplate Property

SiteTemplate Property
Namespaces >> MSS.Configuration >> ConfigFile >> SiteTemplate
Gets the site template.
Declaration Syntax
C#
public string SiteTemplate{ get;}
Value
The site template.

Assembly: MSS.Kernel (Module: MSS.Kernel)


WriteSetting Method (Key, Value)

WriteSetting Method (Key, Value)
Namespaces >> MSS.Configuration >> ConfigFile >> WriteSetting(String, String)
Write setting to config file.
Declaration Syntax
C#
public void WriteSetting(
    string Key,
    string Value
)
Parameters
Key (String)
The key.
Value (String)
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Factory Class

Factory Class
Namespaces >> MSS.Configuration >> Factory
MSS factory.
Declaration Syntax
C#
public class Factory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FactoryFactoryNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSearchEngine()() | Gets the search engine.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Factory

Assembly: MSS.Kernel (Module: MSS.Kernel)


Factory Constructor

Factory Constructor
Namespaces >> MSS.Configuration >> Factory >> FactoryFactoryNew()()
Declaration Syntax
C#
public Factory()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSearchEngine Method

GetSearchEngine Method
Namespaces >> MSS.Configuration >> Factory >> GetSearchEngine()()
Gets the search engine.
Declaration Syntax
C#
public static ISearch GetSearchEngine()
Return Value
The search engine.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldIDs Class

FieldIDs Class
Namespaces >> MSS.Configuration >> FieldIDs
Field ID’s application.
Declaration Syntax
C#
public class FieldIDs
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldIDsFieldIDsNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SiteTypeAdministrationMenu |
 | SiteTypeGlobalMenu |
 | SiteTypeModules |
 | SiteTypeSkinFactoryAssembly |
 | SiteTypeSkinFactoryType |
 | SiteTypeWizard |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WizardModules |
Inheritance Hierarchy
Object
FieldIDs

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldIDs Constructor

FieldIDs Constructor
Namespaces >> MSS.Configuration >> FieldIDs >> FieldIDsFieldIDsNew()()
Declaration Syntax
C#
public FieldIDs()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeAdministrationMenu Field

SiteTypeAdministrationMenu Field
Namespaces >> MSS.Configuration >> FieldIDs >> SiteTypeAdministrationMenu
Declaration Syntax
C#
public static readonly ID SiteTypeAdministrationMenu

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeGlobalMenu Field

SiteTypeGlobalMenu Field
Namespaces >> MSS.Configuration >> FieldIDs >> SiteTypeGlobalMenu
Declaration Syntax
C#
public static readonly ID SiteTypeGlobalMenu

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeModules Field

SiteTypeModules Field
Namespaces >> MSS.Configuration >> FieldIDs >> SiteTypeModules
Declaration Syntax
C#
public static readonly ID SiteTypeModules

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeSkinFactoryAssembly Field

SiteTypeSkinFactoryAssembly Field
Namespaces >> MSS.Configuration >> FieldIDs >> SiteTypeSkinFactoryAssembly
Declaration Syntax
C#
public static readonly ID SiteTypeSkinFactoryAssembly

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeSkinFactoryType Field

SiteTypeSkinFactoryType Field
Namespaces >> MSS.Configuration >> FieldIDs >> SiteTypeSkinFactoryType
Declaration Syntax
C#
public static readonly ID SiteTypeSkinFactoryType

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeWizard Field

SiteTypeWizard Field
Namespaces >> MSS.Configuration >> FieldIDs >> SiteTypeWizard
Declaration Syntax
C#
public static readonly ID SiteTypeWizard

Assembly: MSS.Kernel (Module: MSS.Kernel)


WizardModules Field

WizardModules Field
Namespaces >> MSS.Configuration >> FieldIDs >> WizardModules
Declaration Syntax
C#
public static readonly ID WizardModules

Assembly: MSS.Kernel (Module: MSS.Kernel)


ItemIDs Class

ItemIDs Class
Namespaces >> MSS.Configuration >> ItemIDs
IDs of the some items
Declaration Syntax
C#
public class ItemIDs
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemIDsItemIDsNew()() |
 | AdminitrationMenus |
 | BaseSettings |
 | Content |
 | Creation |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalDictionary |
 | GlobalMenus |
 | LookupBuildCategories |
 | LookupColumnLayouts |
 | LookupReplaceCharacters |
 | LookupSiteStatus |
 | LookupSiteTypes |
 | LookupSkinPackageItemTemplates |
 | LookupSkinPackages |
 | LookupWebEditMode |
 | LookupWizardSteps |
 | Maintenance |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modules |
 | SiteTemplates |
 | System |
 | SystemDictionary |
 | SystemModules |
 | SystemPackages |
 | SystemSettings |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WebSitesRoot |
 | Wizards |
Inheritance Hierarchy
Object
ItemIDs

Assembly: MSS.Kernel (Module: MSS.Kernel)


ItemIDs Constructor

ItemIDs Constructor
Namespaces >> MSS.Configuration >> ItemIDs >> ItemIDsItemIDsNew()()
Declaration Syntax
C#
public ItemIDs()

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdminitrationMenus Field

AdminitrationMenus Field
Namespaces >> MSS.Configuration >> ItemIDs >> AdminitrationMenus
Declaration Syntax
C#
public static readonly ID AdminitrationMenus

Assembly: MSS.Kernel (Module: MSS.Kernel)


BaseSettings Field

BaseSettings Field
Namespaces >> MSS.Configuration >> ItemIDs >> BaseSettings
Declaration Syntax
C#
public static readonly ID BaseSettings

Assembly: MSS.Kernel (Module: MSS.Kernel)


Content Field

Content Field
Namespaces >> MSS.Configuration >> ItemIDs >> Content
Declaration Syntax
C#
public static readonly ID Content

Assembly: MSS.Kernel (Module: MSS.Kernel)


Creation Field

Creation Field
Namespaces >> MSS.Configuration >> ItemIDs >> Creation
Declaration Syntax
C#
public static readonly ID Creation

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalDictionary Field

GlobalDictionary Field
Namespaces >> MSS.Configuration >> ItemIDs >> GlobalDictionary
Declaration Syntax
C#
public static readonly ID GlobalDictionary

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalMenus Field

GlobalMenus Field
Namespaces >> MSS.Configuration >> ItemIDs >> GlobalMenus
Declaration Syntax
C#
public static readonly ID GlobalMenus

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupBuildCategories Field

LookupBuildCategories Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupBuildCategories
Declaration Syntax
C#
public static readonly ID LookupBuildCategories

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupColumnLayouts Field

LookupColumnLayouts Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupColumnLayouts
Declaration Syntax
C#
public static readonly ID LookupColumnLayouts

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupReplaceCharacters Field

LookupReplaceCharacters Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupReplaceCharacters
Declaration Syntax
C#
public static readonly ID LookupReplaceCharacters

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupSiteStatus Field

LookupSiteStatus Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupSiteStatus
Declaration Syntax
C#
public static readonly ID LookupSiteStatus

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupSiteTypes Field

LookupSiteTypes Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupSiteTypes
Declaration Syntax
C#
public static readonly ID LookupSiteTypes

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupSkinPackageItemTemplates Field

LookupSkinPackageItemTemplates Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupSkinPackageItemTemplates
Declaration Syntax
C#
public static readonly ID LookupSkinPackageItemTemplates

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupSkinPackages Field

LookupSkinPackages Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupSkinPackages
Declaration Syntax
C#
public static readonly ID LookupSkinPackages

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupWebEditMode Field

LookupWebEditMode Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupWebEditMode
Declaration Syntax
C#
public static readonly ID LookupWebEditMode

Assembly: MSS.Kernel (Module: MSS.Kernel)


LookupWizardSteps Field

LookupWizardSteps Field
Namespaces >> MSS.Configuration >> ItemIDs >> LookupWizardSteps
Declaration Syntax
C#
public static readonly ID LookupWizardSteps

Assembly: MSS.Kernel (Module: MSS.Kernel)


Maintenance Field

Maintenance Field
Namespaces >> MSS.Configuration >> ItemIDs >> Maintenance
Declaration Syntax
C#
public static readonly ID Maintenance

Assembly: MSS.Kernel (Module: MSS.Kernel)


Modules Field

Modules Field
Namespaces >> MSS.Configuration >> ItemIDs >> Modules
Declaration Syntax
C#
public static readonly ID Modules

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTemplates Field

SiteTemplates Field
Namespaces >> MSS.Configuration >> ItemIDs >> SiteTemplates
Declaration Syntax
C#
public static readonly ID SiteTemplates

Assembly: MSS.Kernel (Module: MSS.Kernel)


System Field

System Field
Namespaces >> MSS.Configuration >> ItemIDs >> System
Declaration Syntax
C#
public static readonly ID System

Assembly: MSS.Kernel (Module: MSS.Kernel)


SystemDictionary Field

SystemDictionary Field
Namespaces >> MSS.Configuration >> ItemIDs >> SystemDictionary
Declaration Syntax
C#
public static readonly ID SystemDictionary

Assembly: MSS.Kernel (Module: MSS.Kernel)


SystemModules Field

SystemModules Field
Namespaces >> MSS.Configuration >> ItemIDs >> SystemModules
Declaration Syntax
C#
public static readonly ID SystemModules

Assembly: MSS.Kernel (Module: MSS.Kernel)


SystemPackages Field

SystemPackages Field
Namespaces >> MSS.Configuration >> ItemIDs >> SystemPackages
Declaration Syntax
C#
public static readonly ID SystemPackages

Assembly: MSS.Kernel (Module: MSS.Kernel)


SystemSettings Field

SystemSettings Field
Namespaces >> MSS.Configuration >> ItemIDs >> SystemSettings
Declaration Syntax
C#
public static readonly ID SystemSettings

Assembly: MSS.Kernel (Module: MSS.Kernel)


WebSitesRoot Field

WebSitesRoot Field
Namespaces >> MSS.Configuration >> ItemIDs >> WebSitesRoot
Declaration Syntax
C#
public static readonly ID WebSitesRoot

Assembly: MSS.Kernel (Module: MSS.Kernel)


Wizards Field

Wizards Field
Namespaces >> MSS.Configuration >> ItemIDs >> Wizards
Declaration Syntax
C#
public static readonly ID Wizards

Assembly: MSS.Kernel (Module: MSS.Kernel)


Settings Class

Settings Class
Namespaces >> MSS.Configuration >> Settings
Strongly type systemwide settings. Settings can come from a file or Sitecore content.
Declaration Syntax
C#
public class Settings : Singleton<Settings>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BackupFolder | Returns the default suffix for website hostnames
 | DefaultLanguage | Gets the default language.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAppSetting(String) | Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.
 | GetAppSetting(String, String) | Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.
 | GetBoolSetting(String, Boolean) | Gets the Boolean setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSecuritySetting(String, Boolean) | Gets the security setting.
 | GetSetting(String) | Gets the setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.
 | GetSetting(String, String) | Gets the setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([String])] | Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.
 | MainSiteAddress | Returns the default suffix for website hostnames
 | MainSiteDescription | Returns the name (description) of the Sitecore box website as setup in the IIS Property: MSS.Configuration.Settings.MainSiteAddress.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SiteTemplate | Gets the site template.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseSingleDatabase | Gets a value indicating whether to use a single database for the site.
 | WebRootPath | Returns the root of the website based on the host server name and the site domain configuration stored in the config file
Inheritance Hierarchy
Object
 | Singleton <(Of <Settings>)>
 |  | Settings

Assembly: MSS.Kernel (Module: MSS.Kernel)


BackupFolder Property

BackupFolder Property
Namespaces >> MSS.Configuration >> Settings >> BackupFolder
Returns the default suffix for website hostnames
Declaration Syntax
C#
public string BackupFolder{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


DefaultLanguage Property

DefaultLanguage Property
Namespaces >> MSS.Configuration >> Settings >> DefaultLanguage
Gets the default language.
Declaration Syntax
C#
public string DefaultLanguage{ get;}
Value
The default language.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAppSetting Method

GetAppSetting Method
Namespaces >> MSS.Configuration >> Settings >> GetAppSetting()()
Members
Icon | Member | Description
 | GetAppSetting(String) | Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.
 | GetAppSetting(String, String) | Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAppSetting Method (Key)

GetAppSetting Method (Key)
Namespaces >> MSS.Configuration >> Settings >> GetAppSetting(String)
Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.
Declaration Syntax
C#
public string GetAppSetting(
    string Key
)
Parameters
Key (String)
The key.
Return Value
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAppSetting Method (Key, Default)

GetAppSetting Method (Key, Default)
Namespaces >> MSS.Configuration >> Settings >> GetAppSetting(String, String)
Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.
Declaration Syntax
C#
public string GetAppSetting(
    string Key,
    string Default
)
Parameters
Key (String)
The key.
Default (String)
The default.
Return Value
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetBoolSetting Method (key, defaultValue)

GetBoolSetting Method (key, defaultValue)
Namespaces >> MSS.Configuration >> Settings >> GetBoolSetting(String, Boolean)
Gets the Boolean setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.
Declaration Syntax
C#
public bool GetBoolSetting(
    string key,
    bool defaultValue
)
Parameters
key (String)
The key.
defaultValue (Boolean)
if set to true [default value].
Return Value
the value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSecuritySetting Method (rightName, allowed)

GetSecuritySetting Method (rightName, allowed)
Namespaces >> MSS.Configuration >> Settings >> GetSecuritySetting(String, Boolean)
Gets the security setting.
Declaration Syntax
C#
public string[] GetSecuritySetting(
    string rightName,
    bool allowed
)
Parameters
rightName (String)
Name of the right.
allowed (Boolean)
if set to true [allowed].
Return Value
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSetting Method

GetSetting Method
Namespaces >> MSS.Configuration >> Settings >> GetSetting()()
Members
Icon | Member | Description
 | GetSetting(String) | Gets the setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.
 | GetSetting(String, String) | Gets the setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSetting Method (Key)

GetSetting Method (Key)
Namespaces >> MSS.Configuration >> Settings >> GetSetting(String)
Gets the setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.
Declaration Syntax
C#
public string GetSetting(
    string Key
)
Parameters
Key (String)
The key.
Return Value
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSetting Method (key, defaultValue)

GetSetting Method (key, defaultValue)
Namespaces >> MSS.Configuration >> Settings >> GetSetting(String, String)
Gets the setting. Reads the setting from the config file. If the setting does not exist returns a value from the "settings" section.
Declaration Syntax
C#
public string GetSetting(
    string key,
    string defaultValue
)
Parameters
key (String)
The key.
defaultValue (String)
The default value.
Return Value
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property (key)

Item Property (key)
Namespaces >> MSS.Configuration >> Settings >> Item[([String])]
Gets the application setting. Reads the setting from the config file. If the setting does not exist returns a value from the "appSettings" section.
Declaration Syntax
C#
public string this[
    string key
]{ get; set;}
Parameters
key (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


MainSiteAddress Property

MainSiteAddress Property
Namespaces >> MSS.Configuration >> Settings >> MainSiteAddress
Returns the default suffix for website hostnames
Declaration Syntax
C#
public string MainSiteAddress{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


MainSiteDescription Property

MainSiteDescription Property
Namespaces >> MSS.Configuration >> Settings >> MainSiteDescription
Returns the name (description) of the Sitecore box website as setup in the IIS Property: MSS.Configuration.Settings.MainSiteAddress.
Declaration Syntax
C#
public string MainSiteDescription{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTemplate Property

SiteTemplate Property
Namespaces >> MSS.Configuration >> Settings >> SiteTemplate
Gets the site template.
Declaration Syntax
C#
public string SiteTemplate{ get;}
Value
The site template.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UseSingleDatabase Property

UseSingleDatabase Property
Namespaces >> MSS.Configuration >> Settings >> UseSingleDatabase
Gets a value indicating whether to use a single database for the site.
Declaration Syntax
C#
public bool UseSingleDatabase{ get;}
Value
True if to use a single database for the site; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


WebRootPath Property

WebRootPath Property
Namespaces >> MSS.Configuration >> Settings >> WebRootPath
Returns the root of the website based on the host server name and the site domain configuration stored in the config file
Declaration Syntax
C#
public string WebRootPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


TemplateIDs Class

TemplateIDs Class
Namespaces >> MSS.Configuration >> TemplateIDs
Template IDs.
Declaration Syntax
C#
public class TemplateIDs
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplateIDsTemplateIDsNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SecurityGroup |
 | SecurityUser |
 | Site |
 | SiteData |
 | SiteType |
 | SkinSettings |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TemplateIDs

Assembly: MSS.Kernel (Module: MSS.Kernel)


TemplateIDs Constructor

TemplateIDs Constructor
Namespaces >> MSS.Configuration >> TemplateIDs >> TemplateIDsTemplateIDsNew()()
Declaration Syntax
C#
public TemplateIDs()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityGroup Field

SecurityGroup Field
Namespaces >> MSS.Configuration >> TemplateIDs >> SecurityGroup
Declaration Syntax
C#
public static readonly ID SecurityGroup

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityUser Field

SecurityUser Field
Namespaces >> MSS.Configuration >> TemplateIDs >> SecurityUser
Declaration Syntax
C#
public static readonly ID SecurityUser

Assembly: MSS.Kernel (Module: MSS.Kernel)


Site Field

Site Field
Namespaces >> MSS.Configuration >> TemplateIDs >> Site
Declaration Syntax
C#
public static readonly ID Site

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteData Field

SiteData Field
Namespaces >> MSS.Configuration >> TemplateIDs >> SiteData
Declaration Syntax
C#
public static readonly ID SiteData

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteType Field

SiteType Field
Namespaces >> MSS.Configuration >> TemplateIDs >> SiteType
Declaration Syntax
C#
public static readonly ID SiteType

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinSettings Field

SkinSettings Field
Namespaces >> MSS.Configuration >> TemplateIDs >> SkinSettings
Declaration Syntax
C#
public static readonly ID SkinSettings

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Counters Namespace

MSS.Counters Namespace
Namespaces >> MSS.Counters
Declaration Syntax
C#
namespace MSS.Counters
Types
All Types Classes
Icon | Type | Description
 | CounterManager | Counter manager.
 | MSSCounter | MSS performance counter
 | SiteCounters | Gets the counters for a site.


CounterManager Class

CounterManager Class
Namespaces >> MSS.Counters >> CounterManager
Counter manager.
Declaration Syntax
C#
public class CounterManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CounterManagerCounterManagerNew()() |
 | DictionaryCounter | Returns PerformanceCounter for counting exception on a site, return value can be null if the property was called from the backend.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionCounter | Returns PerformanceCounter for counting exception on a site, return value can be null if the property was called from the backend.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CounterManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


CounterManager Constructor

CounterManager Constructor
Namespaces >> MSS.Counters >> CounterManager >> CounterManagerCounterManagerNew()()
Declaration Syntax
C#
public CounterManager()

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryCounter Property

DictionaryCounter Property
Namespaces >> MSS.Counters >> CounterManager >> DictionaryCounter
Returns PerformanceCounter for counting exception on a site, return value can be null if the property was called from the backend.
Declaration Syntax
C#
public static MSSCounter DictionaryCounter{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


ExceptionCounter Property

ExceptionCounter Property
Namespaces >> MSS.Counters >> CounterManager >> ExceptionCounter
Returns PerformanceCounter for counting exception on a site, return value can be null if the property was called from the backend.
Declaration Syntax
C#
public static MSSCounter ExceptionCounter{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSSCounter Class

MSSCounter Class
Namespaces >> MSS.Counters >> MSSCounter
MSS performance counter
Declaration Syntax
C#
public class MSSCounter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Decrement()() | Decrements the counter's value.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Increment()() | Increments the counter's value.
 | IncrementBy(Int64) | Increments the counter's value.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MSSCounter

Assembly: MSS.Kernel (Module: MSS.Kernel)


Decrement Method

Decrement Method
Namespaces >> MSS.Counters >> MSSCounter >> Decrement()()
Decrements the counter's value.
Declaration Syntax
C#
public void Decrement()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Increment Method

Increment Method
Namespaces >> MSS.Counters >> MSSCounter >> Increment()()
Increments the counter's value.
Declaration Syntax
C#
public void Increment()

Assembly: MSS.Kernel (Module: MSS.Kernel)


IncrementBy Method (value)

IncrementBy Method (value)
Namespaces >> MSS.Counters >> MSSCounter >> IncrementBy(Int64)
Increments the counter's value.
Declaration Syntax
C#
public void IncrementBy(
    long value
)
Parameters
value (Int64)
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteCounters Class

SiteCounters Class
Namespaces >> MSS.Counters >> SiteCounters
Gets the counters for a site.
Declaration Syntax
C#
public class SiteCounters
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteCountersSiteCountersNew(String) | Initializes a new instance of the SiteCounters class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionCounter |
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RequestsToDictionaryCounter |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SiteCounters

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteCounters Constructor (key)

SiteCounters Constructor (key)
Namespaces >> MSS.Counters >> SiteCounters >> SiteCountersSiteCountersNew(String)
Initializes a new instance of the SiteCounters class.
Declaration Syntax
C#
public SiteCounters(
    string key
)
Parameters
key (String)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ExceptionCounter Field

ExceptionCounter Field
Namespaces >> MSS.Counters >> SiteCounters >> ExceptionCounter
Declaration Syntax
C#
public readonly MSSCounter ExceptionCounter

Assembly: MSS.Kernel (Module: MSS.Kernel)


RequestsToDictionaryCounter Field

RequestsToDictionaryCounter Field
Namespaces >> MSS.Counters >> SiteCounters >> RequestsToDictionaryCounter
Declaration Syntax
C#
public readonly MSSCounter RequestsToDictionaryCounter

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Diagnostics Namespace

MSS.Diagnostics Namespace
Namespaces >> MSS.Diagnostics
Declaration Syntax
C#
namespace MSS.Diagnostics
Types
All Types Classes
Icon | Type | Description
 | Log | Handles logging in MSS.
 | MSSAssert | Provides a set of methods that help check your code in runtime.


Log Class

Log Class
Namespaces >> MSS.Diagnostics >> Log
Handles logging in MSS.
Declaration Syntax
C#
public class Log
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LogLogNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error(Object, Exception) | Writes error message to the log.
 | Error(Object) | Writes error message to the log.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Info(Object) | Writes info message to the log.
 | Info(Object, Exception) | Writes info message to the log.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Warn(Object, Exception) | Writes warning message to the log.
 | Warn(Object) | Writes warning message to the log.
Inheritance Hierarchy
Object
Log

Assembly: MSS.Kernel (Module: MSS.Kernel)


Log Constructor

Log Constructor
Namespaces >> MSS.Diagnostics >> Log >> LogLogNew()()
Declaration Syntax
C#
public Log()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Error Method

Error Method
Namespaces >> MSS.Diagnostics >> Log >> Error()()
Members
Icon | Member | Description
 | Error(Object, Exception) | Writes error message to the log.
 | Error(Object) | Writes error message to the log.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Error Method (message)

Error Method (message)
Namespaces >> MSS.Diagnostics >> Log >> Error(Object)
Writes error message to the log.
Declaration Syntax
C#
public static void Error(
    Object message
)
Parameters
message (Object)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Error Method (message, ex)

Error Method (message, ex)
Namespaces >> MSS.Diagnostics >> Log >> Error(Object, Exception)
Writes error message to the log.
Declaration Syntax
C#
public static void Error(
    Object message,
    Exception ex
)
Parameters
message (Object)
The message.
ex (Exception)
The exeption.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Info Method

Info Method
Namespaces >> MSS.Diagnostics >> Log >> Info()()
Members
Icon | Member | Description
 | Info(Object) | Writes info message to the log.
 | Info(Object, Exception) | Writes info message to the log.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Info Method (message)

Info Method (message)
Namespaces >> MSS.Diagnostics >> Log >> Info(Object)
Writes info message to the log.
Declaration Syntax
C#
public static void Info(
    Object message
)
Parameters
message (Object)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Info Method (message, ex)

Info Method (message, ex)
Namespaces >> MSS.Diagnostics >> Log >> Info(Object, Exception)
Writes info message to the log.
Declaration Syntax
C#
public static void Info(
    Object message,
    Exception ex
)
Parameters
message (Object)
The message.
ex (Exception)
The exeption.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Warn Method

Warn Method
Namespaces >> MSS.Diagnostics >> Log >> Warn()()
Members
Icon | Member | Description
 | Warn(Object, Exception) | Writes warning message to the log.
 | Warn(Object) | Writes warning message to the log.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Warn Method (message)

Warn Method (message)
Namespaces >> MSS.Diagnostics >> Log >> Warn(Object)
Writes warning message to the log.
Declaration Syntax
C#
public static void Warn(
    Object message
)
Parameters
message (Object)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Warn Method (message, ex)

Warn Method (message, ex)
Namespaces >> MSS.Diagnostics >> Log >> Warn(Object, Exception)
Writes warning message to the log.
Declaration Syntax
C#
public static void Warn(
    Object message,
    Exception ex
)
Parameters
message (Object)
The message.
ex (Exception)
The exeption.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSSAssert Class

MSSAssert Class
Namespaces >> MSS.Diagnostics >> MSSAssert
Provides a set of methods that help check your code in runtime.
Declaration Syntax
C#
public class MSSAssert
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MSSAssertMSSAssertNew()() |
 | ArgumentCondition(Boolean, String, String) | Throws an ArgumentException if a specific condition is not met.
 | ArgumentCondition(Boolean, String, array<Object>[]()) | Throws an ArgumentException if a specific condition is not met.
 | ArgumentNotNull(Object, String) | Asserts that the arguments are not null.
 | ArgumentNotNull(Object, String, String) | Asserts that the arguments are not null.
 | ArgumentNotNullOrEmpty(String, String) | Asserts that the arguments are not null or empty.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsFalse(Boolean, String, array<Object>[]()) | Determines whether the specified condition is false.
 | IsFalse(Boolean, String) | Determines whether the specified condition is false.
 | IsNotNull(Object, String) | Asserts that the specified value is not null.
 | IsNotNull(Object, String, array<Object>[]()) | Asserts that the specified value is not null.
 | IsNull(Object, String) | Asserts that the specified value is null.
 | IsTrue(Boolean, String) | Determines whether the specified condition is true.
 | IsTrue(Boolean, String, array<Object>[]()) | Determines whether the specified condition is true.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Throw(Exception) | Throws the exception.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MSSAssert

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSSAssert Constructor

MSSAssert Constructor
Namespaces >> MSS.Diagnostics >> MSSAssert >> MSSAssertMSSAssertNew()()
Declaration Syntax
C#
public MSSAssert()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ArgumentCondition Method

ArgumentCondition Method
Namespaces >> MSS.Diagnostics >> MSSAssert >> ArgumentCondition()()
Members
Icon | Member | Description
 | ArgumentCondition(Boolean, String, String) | Throws an ArgumentException if a specific condition is not met.
 | ArgumentCondition(Boolean, String, array<Object>[]()) | Throws an ArgumentException if a specific condition is not met.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ArgumentCondition Method (condition, format, args)

ArgumentCondition Method (condition, format, args)
Namespaces >> MSS.Diagnostics >> MSSAssert >> ArgumentCondition(Boolean, String, array<Object>[]())
Throws an ArgumentException if a specific condition is not met.
Declaration Syntax
C#
public static void ArgumentCondition(
    bool condition,
    string format,
    params Object[] args
)
Parameters
condition (Boolean)
if set to true [condition].
format (String)
The format.
args (array< Object >[]())
The arguments.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ArgumentCondition Method (condition, paramName, message)

ArgumentCondition Method (condition, paramName, message)
Namespaces >> MSS.Diagnostics >> MSSAssert >> ArgumentCondition(Boolean, String, String)
Throws an ArgumentException if a specific condition is not met.
Declaration Syntax
C#
public static void ArgumentCondition(
    bool condition,
    string paramName,
    string message
)
Parameters
condition (Boolean)
if set to true [condition].
paramName (String)
Name of the parameter.
message (String)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ArgumentNotNull Method

ArgumentNotNull Method
Namespaces >> MSS.Diagnostics >> MSSAssert >> ArgumentNotNull()()
Members
Icon | Member | Description
 | ArgumentNotNull(Object, String) | Asserts that the arguments are not null.
 | ArgumentNotNull(Object, String, String) | Asserts that the arguments are not null.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ArgumentNotNull Method (value, paramName)

ArgumentNotNull Method (value, paramName)
Namespaces >> MSS.Diagnostics >> MSSAssert >> ArgumentNotNull(Object, String)
Asserts that the arguments are not null.
Declaration Syntax
C#
public static void ArgumentNotNull(
    Object value,
    string paramName
)
Parameters
value (Object)
The value.
paramName (String)
Name of the parameter.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ArgumentNotNull Method (value, paramName, message)

ArgumentNotNull Method (value, paramName, message)
Namespaces >> MSS.Diagnostics >> MSSAssert >> ArgumentNotNull(Object, String, String)
Asserts that the arguments are not null.
Declaration Syntax
C#
public static void ArgumentNotNull(
    Object value,
    string paramName,
    string message
)
Parameters
value (Object)
The value.
paramName (String)
Name of the parameter.
message (String)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ArgumentNotNullOrEmpty Method (value, paramName)

ArgumentNotNullOrEmpty Method (value, paramName)
Namespaces >> MSS.Diagnostics >> MSSAssert >> ArgumentNotNullOrEmpty(String, String)
Asserts that the arguments are not null or empty.
Declaration Syntax
C#
public static void ArgumentNotNullOrEmpty(
    string value,
    string paramName
)
Parameters
value (String)
The value.
paramName (String)
Name of the parameter.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsFalse Method

IsFalse Method
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsFalse()()
Members
Icon | Member | Description
 | IsFalse(Boolean, String, array<Object>[]()) | Determines whether the specified condition is false.
 | IsFalse(Boolean, String) | Determines whether the specified condition is false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsFalse Method (condition, message)

IsFalse Method (condition, message)
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsFalse(Boolean, String)
Determines whether the specified condition is false.
Declaration Syntax
C#
public static void IsFalse(
    bool condition,
    string message
)
Parameters
condition (Boolean)
if set to true [condition].
message (String)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsFalse Method (condition, format, args)

IsFalse Method (condition, format, args)
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsFalse(Boolean, String, array<Object>[]())
Determines whether the specified condition is false.
Declaration Syntax
C#
public static void IsFalse(
    bool condition,
    string format,
    params Object[] args
)
Parameters
condition (Boolean)
if set to true [condition].
format (String)
The format.
args (array< Object >[]())
The arguments.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsNotNull Method

IsNotNull Method
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsNotNull()()
Members
Icon | Member | Description
 | IsNotNull(Object, String) | Asserts that the specified value is not null.
 | IsNotNull(Object, String, array<Object>[]()) | Asserts that the specified value is not null.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsNotNull Method (value, message)

IsNotNull Method (value, message)
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsNotNull(Object, String)
Asserts that the specified value is not null.
Declaration Syntax
C#
public static void IsNotNull(
    Object value,
    string message
)
Parameters
value (Object)
The value.
message (String)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsNotNull Method (value, format, args)

IsNotNull Method (value, format, args)
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsNotNull(Object, String, array<Object>[]())
Asserts that the specified value is not null.
Declaration Syntax
C#
public static void IsNotNull(
    Object value,
    string format,
    params Object[] args
)
Parameters
value (Object)
The value.
format (String)
The format.
args (array< Object >[]())
The arguments.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsNull Method (value, message)

IsNull Method (value, message)
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsNull(Object, String)
Asserts that the specified value is null.
Declaration Syntax
C#
public static void IsNull(
    Object value,
    string message
)
Parameters
value (Object)
The value.
message (String)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsTrue Method

IsTrue Method
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsTrue()()
Members
Icon | Member | Description
 | IsTrue(Boolean, String) | Determines whether the specified condition is true.
 | IsTrue(Boolean, String, array<Object>[]()) | Determines whether the specified condition is true.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsTrue Method (condition, message)

IsTrue Method (condition, message)
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsTrue(Boolean, String)
Determines whether the specified condition is true.
Declaration Syntax
C#
public static void IsTrue(
    bool condition,
    string message
)
Parameters
condition (Boolean)
if set to true [condition].
message (String)
The message.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsTrue Method (condition, format, args)

IsTrue Method (condition, format, args)
Namespaces >> MSS.Diagnostics >> MSSAssert >> IsTrue(Boolean, String, array<Object>[]())
Determines whether the specified condition is true.
Declaration Syntax
C#
public static void IsTrue(
    bool condition,
    string format,
    params Object[] args
)
Parameters
condition (Boolean)
if set to true [condition].
format (String)
The format.
args (array< Object >[]())
The arguments.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Throw Method (e)

Throw Method (e)
Namespaces >> MSS.Diagnostics >> MSSAssert >> Throw(Exception)
Throws the exception.
Declaration Syntax
C#
public static void Throw(
    Exception e
)
Parameters
e (Exception)
The exception.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Dictionaries Namespace

MSS.Dictionaries Namespace
Namespaces >> MSS.Dictionaries
Declaration Syntax
C#
namespace MSS.Dictionaries
Types
All Types Classes
Icon | Type | Description
 | Dictionary | Used for looking up string values in sitecore content
 | DictionaryDefinitions | International settings for dictionaries.
 | DictionaryItem | Structure class for handling dictionary items.
 | DictionaryManager | Handles requests to dictionary items on a site context. Resolves which dictionary to use


Dictionary Class

Dictionary Class
Namespaces >> MSS.Dictionaries >> Dictionary
Used for looking up string values in sitecore content
Declaration Syntax
C#
public class Dictionary
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DictionaryPath | Gets the dictionary path.
 | DictionaryRoot | Gets the dictionary root.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessKey(String) | Gets the access key.
 | GetAccessKey(String, String) | Gets the access key in a specified language.
 | GetAccessKey(String, String, String) | Gets the access key by the key, the language and the path.
 | GetDictionaryItem(String) | Gets the dictionary item.
 | GetFieldValue(String, String) | Gets the field value.
 | GetFieldValue(String, String, String) | Gets the field value in a specified language.
 | GetFieldValue(String, String, String, String) | Gets the field value by the field, the key, the language and the path.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHint(String) | Gets the hint by the key.
 | GetHint(String, String) | Gets the hint in a specific language.
 | GetHint(String, String, String) | Gets the hint by the key, the language and the path.
 | GetTabIndex(String) | Gets the index of the tab.
 | GetTabIndex(String, String) | Gets the index of the tab in a specified language.
 | GetTabIndex(String, String, String) | Gets the index of the tab by the key, the language and the path.
 | GetText(String) | Gets the text by the key.
 | GetText(String, String) | Gets the text in a specific language.
 | GetText(String, String, String) | Gets the text by the key, the language and the path.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReloadDictionaryItem(String) | Reloads the dictionary item.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Dictionary

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Dictionaries >> Dictionary >> DictionaryPath
Gets the dictionary path.
Declaration Syntax
C#
public string DictionaryPath{ get;}
Value
The dictionary path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Dictionaries >> Dictionary >> DictionaryRoot
Gets the dictionary root.
Declaration Syntax
C#
public Item DictionaryRoot{ get;}
Value
The dictionary root.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method

GetAccessKey Method
Namespaces >> MSS.Dictionaries >> Dictionary >> GetAccessKey()()
Members
Icon | Member | Description
 | GetAccessKey(String) | Gets the access key.
 | GetAccessKey(String, String) | Gets the access key in a specified language.
 | GetAccessKey(String, String, String) | Gets the access key by the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method (key)

GetAccessKey Method (key)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetAccessKey(String)
Gets the access key.
Declaration Syntax
C#
public string GetAccessKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The access key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method (key, language)

GetAccessKey Method (key, language)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetAccessKey(String, String)
Gets the access key in a specified language.
Declaration Syntax
C#
public string GetAccessKey(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The access key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method (key, language, path)

GetAccessKey Method (key, language, path)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetAccessKey(String, String, String)
Gets the access key by the key, the language and the path.
Declaration Syntax
C#
public string GetAccessKey(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The path.
Return Value
The access key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetDictionaryItem Method (key)

GetDictionaryItem Method (key)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetDictionaryItem(String)
Gets the dictionary item.
Declaration Syntax
C#
public DictionaryItem GetDictionaryItem(
    string key
)
Parameters
key (String)
The key.
Return Value
The dictionary item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method

GetFieldValue Method
Namespaces >> MSS.Dictionaries >> Dictionary >> GetFieldValue()()
Members
Icon | Member | Description
 | GetFieldValue(String, String) | Gets the field value.
 | GetFieldValue(String, String, String) | Gets the field value in a specified language.
 | GetFieldValue(String, String, String, String) | Gets the field value by the field, the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (field, key)

GetFieldValue Method (field, key)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetFieldValue(String, String)
Gets the field value.
Declaration Syntax
C#
public string GetFieldValue(
    string field,
    string key
)
Parameters
field (String)
The field.
key (String)
The key.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (field, key, language)

GetFieldValue Method (field, key, language)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetFieldValue(String, String, String)
Gets the field value in a specified language.
Declaration Syntax
C#
public string GetFieldValue(
    string field,
    string key,
    string language
)
Parameters
field (String)
The field.
key (String)
The key.
language (String)
The language.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (field, key, language, path)

GetFieldValue Method (field, key, language, path)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetFieldValue(String, String, String, String)
Gets the field value by the field, the key, the language and the path.
Declaration Syntax
C#
public string GetFieldValue(
    string field,
    string key,
    string language,
    string path
)
Parameters
field (String)
The field.
key (String)
The key.
language (String)
The language.
path (String)
The path.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method

GetHint Method
Namespaces >> MSS.Dictionaries >> Dictionary >> GetHint()()
Members
Icon | Member | Description
 | GetHint(String) | Gets the hint by the key.
 | GetHint(String, String) | Gets the hint in a specific language.
 | GetHint(String, String, String) | Gets the hint by the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method (key)

GetHint Method (key)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetHint(String)
Gets the hint by the key.
Declaration Syntax
C#
public string GetHint(
    string key
)
Parameters
key (String)
The key.
Return Value
The hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method (key, language)

GetHint Method (key, language)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetHint(String, String)
Gets the hint in a specific language.
Declaration Syntax
C#
public string GetHint(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method (key, language, path)

GetHint Method (key, language, path)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetHint(String, String, String)
Gets the hint by the key, the language and the path.
Declaration Syntax
C#
public string GetHint(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The dictionary item path.
Return Value
The hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method

GetTabIndex Method
Namespaces >> MSS.Dictionaries >> Dictionary >> GetTabIndex()()
Members
Icon | Member | Description
 | GetTabIndex(String) | Gets the index of the tab.
 | GetTabIndex(String, String) | Gets the index of the tab in a specified language.
 | GetTabIndex(String, String, String) | Gets the index of the tab by the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method (key)

GetTabIndex Method (key)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetTabIndex(String)
Gets the index of the tab.
Declaration Syntax
C#
public string GetTabIndex(
    string key
)
Parameters
key (String)
The key.
Return Value
The index.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method (key, language)

GetTabIndex Method (key, language)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetTabIndex(String, String)
Gets the index of the tab in a specified language.
Declaration Syntax
C#
public string GetTabIndex(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The index

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method (key, language, path)

GetTabIndex Method (key, language, path)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetTabIndex(String, String, String)
Gets the index of the tab by the key, the language and the path.
Declaration Syntax
C#
public string GetTabIndex(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The path.
Return Value
The index.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method

GetText Method
Namespaces >> MSS.Dictionaries >> Dictionary >> GetText()()
Members
Icon | Member | Description
 | GetText(String) | Gets the text by the key.
 | GetText(String, String) | Gets the text in a specific language.
 | GetText(String, String, String) | Gets the text by the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method (key)

GetText Method (key)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetText(String)
Gets the text by the key.
Declaration Syntax
C#
public string GetText(
    string key
)
Parameters
key (String)
The key.
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method (key, language)

GetText Method (key, language)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetText(String, String)
Gets the text in a specific language.
Declaration Syntax
C#
public string GetText(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method (key, language, path)

GetText Method (key, language, path)
Namespaces >> MSS.Dictionaries >> Dictionary >> GetText(String, String, String)
Gets the text by the key, the language and the path.
Declaration Syntax
C#
public string GetText(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The dictionary item path.
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ReloadDictionaryItem Method (key)

ReloadDictionaryItem Method (key)
Namespaces >> MSS.Dictionaries >> Dictionary >> ReloadDictionaryItem(String)
Reloads the dictionary item.
Declaration Syntax
C#
public void ReloadDictionaryItem(
    string key
)
Parameters
key (String)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryDefinitions Class

DictionaryDefinitions Class
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions
International settings for dictionaries.
Declaration Syntax
C#
public class DictionaryDefinitions
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DictionaryDefinitionsDictionaryDefinitionsNew()() |
 | DictionaryRootName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldAccessKey |
 | FieldHint |
 | FieldNote |
 | FieldTabIndex |
 | FieldText |
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryDefinitions

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryDefinitions Constructor

DictionaryDefinitions Constructor
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions >> DictionaryDefinitionsDictionaryDefinitionsNew()()
Declaration Syntax
C#
public DictionaryDefinitions()

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryRootName Field

DictionaryRootName Field
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions >> DictionaryRootName
Declaration Syntax
C#
public const string DictionaryRootName

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldAccessKey Field

FieldAccessKey Field
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions >> FieldAccessKey
Declaration Syntax
C#
public const string FieldAccessKey

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldHint Field

FieldHint Field
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions >> FieldHint
Declaration Syntax
C#
public const string FieldHint

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldNote Field

FieldNote Field
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions >> FieldNote
Declaration Syntax
C#
public const string FieldNote

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldTabIndex Field

FieldTabIndex Field
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions >> FieldTabIndex
Declaration Syntax
C#
public const string FieldTabIndex

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldText Field

FieldText Field
Namespaces >> MSS.Dictionaries >> DictionaryDefinitions >> FieldText
Declaration Syntax
C#
public const string FieldText

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryItem Class

DictionaryItem Class
Namespaces >> MSS.Dictionaries >> DictionaryItem
Structure class for handling dictionary items.
Declaration Syntax
C#
public class DictionaryItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DictionaryItemDictionaryItemNew(String) | Initializes a new instance of the DictionaryItem class using the path.
 | DictionaryItemDictionaryItemNew(Item) | Initializes a new instance of the DictionaryItem class using the path.
 | Clear()() | Clears the caches.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists | Gets a value indicating whether this DictionaryItem exists.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessKey(String) | Get a AccessKey in specified language
 | GetAccessKey()() | Gets a AccessKey in current language.
 | GetFieldValue(String, String) | Gets the field value.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHint(String) | Get a Hint in specified language.
 | GetHint()() | Gets a Hint in current language.
 | GetTabIndex(String) | Gets the tabIndex in specified language.
 | GetTabIndex()() | Gets the tabIndex in current language
 | GetText(String) | Get the Text in specified language.
 | GetText()() | Gets the Text in current language.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateData(String) | If Sitecore content has been updated and is stored in this dictionary item, clear the item.
Inheritance Hierarchy
Object
DictionaryItem

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryItem Constructor

DictionaryItem Constructor
Namespaces >> MSS.Dictionaries >> DictionaryItem >> DictionaryItemDictionaryItemNew()()
Members
Icon | Member | Description
 | DictionaryItemDictionaryItemNew(String) | Initializes a new instance of the DictionaryItem class using the path.
 | DictionaryItemDictionaryItemNew(Item) | Initializes a new instance of the DictionaryItem class using the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryItem Constructor (item)

DictionaryItem Constructor (item)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> DictionaryItemDictionaryItemNew(Item)
Initializes a new instance of the DictionaryItem class using the path.
Declaration Syntax
C#
public DictionaryItem(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryItem Constructor (path)

DictionaryItem Constructor (path)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> DictionaryItemDictionaryItemNew(String)
Initializes a new instance of the DictionaryItem class using the path.
Declaration Syntax
C#
public DictionaryItem(
    string path
)
Parameters
path (String)
The path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clear Method

Clear Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> Clear()()
Clears the caches.
Declaration Syntax
C#
public void Clear()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Exists Property

Exists Property
Namespaces >> MSS.Dictionaries >> DictionaryItem >> Exists
Gets a value indicating whether this DictionaryItem exists.
Declaration Syntax
C#
public bool Exists{ get;}
Value
True, if the DictionaryItem exists; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method

GetAccessKey Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetAccessKey()()
Members
Icon | Member | Description
 | GetAccessKey(String) | Get a AccessKey in specified language
 | GetAccessKey()() | Gets a AccessKey in current language.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method

GetAccessKey Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetAccessKey()()
Gets a AccessKey in current language.
Declaration Syntax
C#
public string GetAccessKey()
Return Value
The AccessKey.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method (language)

GetAccessKey Method (language)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetAccessKey(String)
Get a AccessKey in specified language
Declaration Syntax
C#
public string GetAccessKey(
    string language
)
Parameters
language (String)
The language.
Return Value
The AccessKey.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (field, language)

GetFieldValue Method (field, language)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetFieldValue(String, String)
Gets the field value.
Declaration Syntax
C#
public string GetFieldValue(
    string field,
    string language
)
Parameters
field (String)
The field.
language (String)
The language.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method

GetHint Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetHint()()
Members
Icon | Member | Description
 | GetHint(String) | Get a Hint in specified language.
 | GetHint()() | Gets a Hint in current language.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method

GetHint Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetHint()()
Gets a Hint in current language.
Declaration Syntax
C#
public string GetHint()
Return Value
The Hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method (language)

GetHint Method (language)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetHint(String)
Get a Hint in specified language.
Declaration Syntax
C#
public string GetHint(
    string language
)
Parameters
language (String)
The language.
Return Value
The Hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method

GetTabIndex Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetTabIndex()()
Members
Icon | Member | Description
 | GetTabIndex(String) | Gets the tabIndex in specified language.
 | GetTabIndex()() | Gets the tabIndex in current language

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method

GetTabIndex Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetTabIndex()()
Gets the tabIndex in current language
Declaration Syntax
C#
public short GetTabIndex()
Return Value
The TabIndex.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method (language)

GetTabIndex Method (language)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetTabIndex(String)
Gets the tabIndex in specified language.
Declaration Syntax
C#
public short GetTabIndex(
    string language
)
Parameters
language (String)
The language.
Return Value
The TabIndex.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method

GetText Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetText()()
Members
Icon | Member | Description
 | GetText(String) | Get the Text in specified language.
 | GetText()() | Gets the Text in current language.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method

GetText Method
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetText()()
Gets the Text in current language.
Declaration Syntax
C#
public string GetText()
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method (language)

GetText Method (language)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> GetText(String)
Get the Text in specified language.
Declaration Syntax
C#
public string GetText(
    string language
)
Parameters
language (String)
The language.
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UpdateData Method (contentPath)

UpdateData Method (contentPath)
Namespaces >> MSS.Dictionaries >> DictionaryItem >> UpdateData(String)
If Sitecore content has been updated and is stored in this dictionary item, clear the item.
Declaration Syntax
C#
public void UpdateData(
    string contentPath
)
Parameters
contentPath (String)
The content path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryManager Class

DictionaryManager Class
Namespaces >> MSS.Dictionaries >> DictionaryManager
Handles requests to dictionary items on a site context. Resolves which dictionary to use
Declaration Syntax
C#
public class DictionaryManager
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessKey(String) | Gets the access key.
 | GetAccessKey(String, String) | Gets the access key.
 | GetAccessKey(String, String, String) | Gets the access key.
 | GetDictionaryItem(String) | Gets the dictionary item.
 | GetFieldValue(String, String) | Gets the field value.
 | GetFieldValue(String, String, String) | Gets the field value in a specific language.
 | GetFieldValue(String, String, String, String) | Gets the field value by the key, the language and the path.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHint(String) | Gets the hint.
 | GetHint(String, String) | Gets the hint in a specific language.
 | GetHint(String, String, String) | Gets the hint.
 | GetTabIndex(String) | Gets the index of the tab.
 | GetTabIndex(String, String) | Gets the index of the tab in a specific language.
 | GetTabIndex(String, String, String) | Gets the index of the tab by the key, the language and the path.
 | GetText(String) | Gets the text.
 | GetText(String, String) | Gets the text in specified lanugage.
 | GetText(String, String, String) | Gets the text by the key, the language and the path.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method

GetAccessKey Method
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetAccessKey()()
Members
Icon | Member | Description
 | GetAccessKey(String) | Gets the access key.
 | GetAccessKey(String, String) | Gets the access key.
 | GetAccessKey(String, String, String) | Gets the access key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method (key)

GetAccessKey Method (key)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetAccessKey(String)
Gets the access key.
Declaration Syntax
C#
public string GetAccessKey(
    string key
)
Parameters
key (String)
The key.
Return Value
The access key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method (key, language)

GetAccessKey Method (key, language)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetAccessKey(String, String)
Gets the access key.
Declaration Syntax
C#
public string GetAccessKey(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The access key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAccessKey Method (key, language, path)

GetAccessKey Method (key, language, path)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetAccessKey(String, String, String)
Gets the access key.
Declaration Syntax
C#
public string GetAccessKey(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The dictionary item path.
Return Value
The access key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetDictionaryItem Method (key)

GetDictionaryItem Method (key)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetDictionaryItem(String)
Gets the dictionary item.
Declaration Syntax
C#
public DictionaryItem GetDictionaryItem(
    string key
)
Parameters
key (String)
The key.
Return Value
The dictionary item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method

GetFieldValue Method
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetFieldValue()()
Members
Icon | Member | Description
 | GetFieldValue(String, String) | Gets the field value.
 | GetFieldValue(String, String, String) | Gets the field value in a specific language.
 | GetFieldValue(String, String, String, String) | Gets the field value by the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (field, key)

GetFieldValue Method (field, key)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetFieldValue(String, String)
Gets the field value.
Declaration Syntax
C#
public string GetFieldValue(
    string field,
    string key
)
Parameters
field (String)
The field.
key (String)
The key.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (field, key, language)

GetFieldValue Method (field, key, language)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetFieldValue(String, String, String)
Gets the field value in a specific language.
Declaration Syntax
C#
public string GetFieldValue(
    string field,
    string key,
    string language
)
Parameters
field (String)
The field.
key (String)
The key.
language (String)
The language.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (field, key, language, path)

GetFieldValue Method (field, key, language, path)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetFieldValue(String, String, String, String)
Gets the field value by the key, the language and the path.
Declaration Syntax
C#
public string GetFieldValue(
    string field,
    string key,
    string language,
    string path
)
Parameters
field (String)
The field.
key (String)
The key.
language (String)
The language.
path (String)
The dictionary item path.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method

GetHint Method
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetHint()()
Members
Icon | Member | Description
 | GetHint(String) | Gets the hint.
 | GetHint(String, String) | Gets the hint in a specific language.
 | GetHint(String, String, String) | Gets the hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method (key)

GetHint Method (key)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetHint(String)
Gets the hint.
Declaration Syntax
C#
public string GetHint(
    string key
)
Parameters
key (String)
The key.
Return Value
The hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method (key, language)

GetHint Method (key, language)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetHint(String, String)
Gets the hint in a specific language.
Declaration Syntax
C#
public string GetHint(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHint Method (key, language, path)

GetHint Method (key, language, path)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetHint(String, String, String)
Gets the hint.
Declaration Syntax
C#
public string GetHint(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The dictionary item path.
Return Value
The hint.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method

GetTabIndex Method
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetTabIndex()()
Members
Icon | Member | Description
 | GetTabIndex(String) | Gets the index of the tab.
 | GetTabIndex(String, String) | Gets the index of the tab in a specific language.
 | GetTabIndex(String, String, String) | Gets the index of the tab by the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method (key)

GetTabIndex Method (key)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetTabIndex(String)
Gets the index of the tab.
Declaration Syntax
C#
public string GetTabIndex(
    string key
)
Parameters
key (String)
The key.
Return Value
The tab index.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method (key, language)

GetTabIndex Method (key, language)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetTabIndex(String, String)
Gets the index of the tab in a specific language.
Declaration Syntax
C#
public string GetTabIndex(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The tab index.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTabIndex Method (key, language, path)

GetTabIndex Method (key, language, path)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetTabIndex(String, String, String)
Gets the index of the tab by the key, the language and the path.
Declaration Syntax
C#
public string GetTabIndex(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The dictionary item path.
Return Value
The tab index.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method

GetText Method
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetText()()
Members
Icon | Member | Description
 | GetText(String) | Gets the text.
 | GetText(String, String) | Gets the text in specified lanugage.
 | GetText(String, String, String) | Gets the text by the key, the language and the path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method (key)

GetText Method (key)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetText(String)
Gets the text.
Declaration Syntax
C#
public string GetText(
    string key
)
Parameters
key (String)
The key.
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method (key, language)

GetText Method (key, language)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetText(String, String)
Gets the text in specified lanugage.
Declaration Syntax
C#
public string GetText(
    string key,
    string language
)
Parameters
key (String)
The key.
language (String)
The language.
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetText Method (key, language, path)

GetText Method (key, language, path)
Namespaces >> MSS.Dictionaries >> DictionaryManager >> GetText(String, String, String)
Gets the text by the key, the language and the path.
Declaration Syntax
C#
public string GetText(
    string key,
    string language,
    string path
)
Parameters
key (String)
The key.
language (String)
The language.
path (String)
The path.
Return Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Entities Namespace

MSS.Entities Namespace
Namespaces >> MSS.Entities
Declaration Syntax
C#
namespace MSS.Entities
Types
All Types Classes
Icon | Type | Description
 | Entity | Encapsulates a Sitecore item entity
 | EntityBase | Provides the base interface for a entity
 | Manager<(Of <TValue>)> | Base entity manager


Entity Class

Entity Class
Namespaces >> MSS.Entities >> Entity
Encapsulates a Sitecore item entity
Declaration Syntax
C#
[SerializableAttribute]
public abstract class Entity : EntityBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntityEntityNew(ID, Server, Database) | Initializes a new instance of the Entity class.
 | Clone()() | Clones this instance of an entity.
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Entity) | Moves an entity to the specified destination.
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | Skin
 |  |  | Wizard
 |  |  | SiteContext
 |  |  | Module
 |  |  | SiteType
 |  |  | AdministrationMenu
 |  |  | GlobalMenu
 |  |  | MediaLibraryContext

Assembly: MSS.Kernel (Module: MSS.Kernel)


Entity Constructor (id, server, database)

Entity Constructor (id, server, database)
Namespaces >> MSS.Entities >> Entity >> EntityEntityNew(ID, Server, Database)
Initializes a new instance of the Entity class.
Declaration Syntax
C#
public Entity(
    ID id,
    Server server,
    Database database
)
Parameters
id (ID)
The id.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Entities >> Entity >> Clone()()
Clones this instance of an entity.
Declaration Syntax
C#
public abstract Entity Clone()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Delete Method

Delete Method
Namespaces >> MSS.Entities >> Entity >> Delete()()
Deletes an entity.
Declaration Syntax
C#
public virtual void Delete()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Move Method (destination)

Move Method (destination)
Namespaces >> MSS.Entities >> Entity >> Move(Entity)
Moves an entity to the specified destination.
Declaration Syntax
C#
public virtual void Move(
    Entity destination
)
Parameters
destination (Entity)
The destination.

Assembly: MSS.Kernel (Module: MSS.Kernel)


EntityBase Class

EntityBase Class
Namespaces >> MSS.Entities >> EntityBase
Provides the base interface for a entity
Declaration Syntax
C#
[SerializableAttribute]
public abstract class EntityBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntityBaseEntityBaseNew(ID, Server, Database) | Initializes a new instance of the EntityBase class.
 | Database | Gets the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID.
 | Item | Gets the item.
 | Key | Gets the entity key.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the entity path.
 | Server | Gets the server.
 | SetFieldValue(String, String) | Sets the field value.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  | SkinPackage
 |  | SkinPackageItem
 |  | GroupTemplate

Assembly: MSS.Kernel (Module: MSS.Kernel)


EntityBase Constructor (id, server, database)

EntityBase Constructor (id, server, database)
Namespaces >> MSS.Entities >> EntityBase >> EntityBaseEntityBaseNew(ID, Server, Database)
Initializes a new instance of the EntityBase class.
Declaration Syntax
C#
public EntityBase(
    ID id,
    Server server,
    Database database
)
Parameters
id (ID)
The id.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Database Property

Database Property
Namespaces >> MSS.Entities >> EntityBase >> Database
Gets the database.
Declaration Syntax
C#
public Database Database{ get;}
Value
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (fieldName)

GetFieldValue Method (fieldName)
Namespaces >> MSS.Entities >> EntityBase >> GetFieldValue(String)
Returns the value of the field with name fieldname.
Declaration Syntax
C#
protected string GetFieldValue(
    string fieldName
)
Parameters
fieldName (String)
The field name.
Return Value
The value of the field.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ID Property

ID Property
Namespaces >> MSS.Entities >> EntityBase >> ID
Gets the sitecore item ID.
Declaration Syntax
C#
public ID ID{ get;}
Value
The ID.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property

Item Property
Namespaces >> MSS.Entities >> EntityBase >> Item
Gets the item.
Declaration Syntax
C#
public virtual Item Item{ get;}
Value
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Key Property

Key Property
Namespaces >> MSS.Entities >> EntityBase >> Key
Gets the entity key.
Declaration Syntax
C#
public string Key{ get;}
Value
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Path Property

Path Property
Namespaces >> MSS.Entities >> EntityBase >> Path
Gets the entity path.
Declaration Syntax
C#
public string Path{ get;}
Value
The path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Server Property

Server Property
Namespaces >> MSS.Entities >> EntityBase >> Server
Gets the server.
Declaration Syntax
C#
public Server Server{ get;}
Value
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetFieldValue Method (fieldName, value)

SetFieldValue Method (fieldName, value)
Namespaces >> MSS.Entities >> EntityBase >> SetFieldValue(String, String)
Sets the field value.
Declaration Syntax
C#
protected void SetFieldValue(
    string fieldName,
    string value
)
Parameters
fieldName (String)
The field name.
value (String)
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Manager Class

Manager<(Of <TValue>)> Class
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)>
Base entity manager
Declaration Syntax
C#
public abstract class Manager<TValue> where TValue : Entity, ICacheable
Generic Template Parameters
TValue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Manager<(Of <TValue>)>Manager<(Of <TValue>)>New(ID) | Initializes a new instance of the Manager<(Of <TValue>)> class.
 | Add(ID, TValue) | Adds the value using a specified entity.
 | ClearCache(Database) | Clears the database cache.
 | CreateEntity(Item) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.
 | CreateEntity(ID, Database) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.
 | CreateNewEntity(ID, Database) | Creates the new entity.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCache(Database) | Gets the cache.
 | GetEntities(Database) | Gets the entities using a specified database.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([ID, Database])] | Gets the value with the specified key.
 | Load()() | Loads this instance of Manager<(Of <TValue>)>.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(ID, Database) | Removes entity value using a specified database.
 | RemoveEntityFromCache(ID, Database) | Removes the entity from the cache.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Manager<(Of <TValue>)>
 |  | SiteContextManager
 |  | SiteTypeManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


Manager Constructor (cacheID)

Manager<(Of <TValue>)> Constructor (cacheID)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> Manager<(Of <TValue>)>Manager<(Of <TValue>)>New(ID)
Initializes a new instance of the Manager<(Of <TValue>)> class.
Declaration Syntax
C#
public Manager(
    ID cacheID
)
Parameters
cacheID (ID)
The cache ID.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Add Method (key, entity)

Add Method (key, entity)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> Add(ID, TValue)
Adds the value using a specified entity.
Declaration Syntax
C#
public virtual void Add(
    ID key,
    TValue entity
)
Parameters
key (ID)
The key.
entity (TValue)
The entity.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearCache Method (database)

ClearCache Method (database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> ClearCache(Database)
Clears the database cache.
Declaration Syntax
C#
public virtual void ClearCache(
    Database database
)
Parameters
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateEntity Method

CreateEntity Method
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> CreateEntity()()
Members
Icon | Member | Description
 | CreateEntity(Item) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.
 | CreateEntity(ID, Database) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateEntity Method (id, database)

CreateEntity Method (id, database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> CreateEntity(ID, Database)
Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.
Declaration Syntax
C#
protected TValue CreateEntity(
    ID id,
    Database database
)
Parameters
id (ID)
The id.
database (Database)
The database.
Return Value
The new entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateEntity Method (item)

CreateEntity Method (item)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> CreateEntity(Item)
Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.
Declaration Syntax
C#
protected TValue CreateEntity(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The new entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateNewEntity Method (id, database)

CreateNewEntity Method (id, database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> CreateNewEntity(ID, Database)
Creates the new entity.
Declaration Syntax
C#
protected abstract TValue CreateNewEntity(
    ID id,
    Database database
)
Parameters
id (ID)
The id.
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCache Method (database)

GetCache Method (database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> GetCache(Database)
Gets the cache.
Declaration Syntax
C#
protected Cache<ID, TValue> GetCache(
    Database database
)
Parameters
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntities Method (database)

GetEntities Method (database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> GetEntities(Database)
Gets the entities using a specified database.
Declaration Syntax
C#
public IEnumerable<TValue> GetEntities(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The entries.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property (key, database)

Item Property (key, database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> Item[([ID, Database])]
Gets the value with the specified key.
Declaration Syntax
C#
public virtual TValue this[
    ID key,
    Database database
]{ get;}
Parameters
key (ID)
database (Database)
Value
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Load Method

Load Method
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> Load()()
Loads this instance of Manager<(Of <TValue>)>.
Declaration Syntax
C#
public abstract void Load()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Remove Method (key, database)

Remove Method (key, database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> Remove(ID, Database)
Removes entity value using a specified database.
Declaration Syntax
C#
public virtual void Remove(
    ID key,
    Database database
)
Parameters
key (ID)
The key.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveEntityFromCache Method (key, database)

RemoveEntityFromCache Method (key, database)
Namespaces >> MSS.Entities >> Manager<(Of <TValue>)> >> RemoveEntityFromCache(ID, Database)
Removes the entity from the cache.
Declaration Syntax
C#
protected void RemoveEntityFromCache(
    ID key,
    Database database
)
Parameters
key (ID)
The key.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Exceptions Namespace

MSS.Exceptions Namespace
Namespaces >> MSS.Exceptions
Declaration Syntax
C#
namespace MSS.Exceptions
Types
All Types Classes
Icon | Type | Description
 | ExceptionHandling | A single common way of handling exceptions. Does logging in a file in system events.


ExceptionHandling Class

ExceptionHandling Class
Namespaces >> MSS.Exceptions >> ExceptionHandling
A single common way of handling exceptions. Does logging in a file in system events.
Declaration Syntax
C#
public class ExceptionHandling
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExceptionHandlingExceptionHandlingNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionKey |
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleException()() | Handles the exception.
 | HandleException(Exception) | Handles the exception.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PageUrlKey |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExceptionHandling

Assembly: MSS.Kernel (Module: MSS.Kernel)


ExceptionHandling Constructor

ExceptionHandling Constructor
Namespaces >> MSS.Exceptions >> ExceptionHandling >> ExceptionHandlingExceptionHandlingNew()()
Declaration Syntax
C#
public ExceptionHandling()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ExceptionKey Field

ExceptionKey Field
Namespaces >> MSS.Exceptions >> ExceptionHandling >> ExceptionKey
Declaration Syntax
C#
public static string ExceptionKey

Assembly: MSS.Kernel (Module: MSS.Kernel)


HandleException Method

HandleException Method
Namespaces >> MSS.Exceptions >> ExceptionHandling >> HandleException()()
Members
Icon | Member | Description
 | HandleException()() | Handles the exception.
 | HandleException(Exception) | Handles the exception.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HandleException Method

HandleException Method
Namespaces >> MSS.Exceptions >> ExceptionHandling >> HandleException()()
Handles the exception.
Declaration Syntax
C#
public static void HandleException()

Assembly: MSS.Kernel (Module: MSS.Kernel)


HandleException Method (exception)

HandleException Method (exception)
Namespaces >> MSS.Exceptions >> ExceptionHandling >> HandleException(Exception)
Handles the exception.
Declaration Syntax
C#
public static void HandleException(
    Exception exception
)
Parameters
exception (Exception)
The exception.

Assembly: MSS.Kernel (Module: MSS.Kernel)


PageUrlKey Field

PageUrlKey Field
Namespaces >> MSS.Exceptions >> ExceptionHandling >> PageUrlKey
Declaration Syntax
C#
public static string PageUrlKey

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.FileSystem Namespace

MSS.FileSystem Namespace
Namespaces >> MSS.FileSystem
Declaration Syntax
C#
namespace MSS.FileSystem
Types
All Types Classes
Icon | Type | Description
 | File | Utility functions related to handling files


File Class

File Class
Namespaces >> MSS.FileSystem >> File
Utility functions related to handling files
Declaration Syntax
C#
public class File
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FileFileNew()() |
 | DeleteFile(String) | Delete file at given path relative to website. If none given ignore
 | EnsurePhysicalPath(String) | If the given path is relative to website root make it a physical path relative to local file system.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsRelativePath(String) | Is given path is relative to website root or a physical path relative to local file system.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
File

Assembly: MSS.Kernel (Module: MSS.Kernel)


File Constructor

File Constructor
Namespaces >> MSS.FileSystem >> File >> FileFileNew()()
Declaration Syntax
C#
public File()

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteFile Method (filename)

DeleteFile Method (filename)
Namespaces >> MSS.FileSystem >> File >> DeleteFile(String)
Delete file at given path relative to website. If none given ignore
Declaration Syntax
C#
public static void DeleteFile(
    string filename
)
Parameters
filename (String)
Path to file

Assembly: MSS.Kernel (Module: MSS.Kernel)


EnsurePhysicalPath Method (path)

EnsurePhysicalPath Method (path)
Namespaces >> MSS.FileSystem >> File >> EnsurePhysicalPath(String)
If the given path is relative to website root make it a physical path relative to local file system.
Declaration Syntax
C#
public static string EnsurePhysicalPath(
    string path
)
Parameters
path (String)
Path to test
Return Value
The physical path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsRelativePath Method (path)

IsRelativePath Method (path)
Namespaces >> MSS.FileSystem >> File >> IsRelativePath(String)
Is given path is relative to website root or a physical path relative to local file system.
Declaration Syntax
C#
public static bool IsRelativePath(
    string path
)
Parameters
path (String)
Path to test
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.IIS Namespace

MSS.IIS Namespace
Namespaces >> MSS.IIS
Declaration Syntax
C#
namespace MSS.IIS
Types
All Types Classes
Icon | Type | Description
 | IISManager | Handles all communication with the Internet Information Server (IIS).


IISManager Class

IISManager Class
Namespaces >> MSS.IIS >> IISManager
Handles all communication with the Internet Information Server (IIS).
Declaration Syntax
C#
public class IISManager : Singleton<IISManager>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddBinding(String) | Adds the bindings to iis server.
 | ChangeServerBinding(String, String) | Changes the server bindings.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedUpdateAliases | Gets a value indicating whether IIS aliases need be updated.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateBindings(List<(Of <String>)>) | Connects to the local IIS to update alias settings for a given site. Requires that the user running this process has administrator priviliges. Consider using impersonation to obtain administrator privileges.
Inheritance Hierarchy
Object
 | Singleton <(Of <IISManager>)>
 |  | IISManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddBinding Method (url)

AddBinding Method (url)
Namespaces >> MSS.IIS >> IISManager >> AddBinding(String)
Adds the bindings to iis server.
Declaration Syntax
C#
public void AddBinding(
    string url
)
Parameters
url (String)
The URL.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ChangeServerBinding Method (oldUrl, newUrl)

ChangeServerBinding Method (oldUrl, newUrl)
Namespaces >> MSS.IIS >> IISManager >> ChangeServerBinding(String, String)
Changes the server bindings.
Declaration Syntax
C#
public bool ChangeServerBinding(
    string oldUrl,
    string newUrl
)
Parameters
oldUrl (String)
The old url.
newUrl (String)
The new url.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


NeedUpdateAliases Property

NeedUpdateAliases Property
Namespaces >> MSS.IIS >> IISManager >> NeedUpdateAliases
Gets a value indicating whether IIS aliases need be updated.
Declaration Syntax
C#
public bool NeedUpdateAliases{ get;}
Value
true if [need update aliases]; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UpdateBindings Method (hosts)

UpdateBindings Method (hosts)
Namespaces >> MSS.IIS >> IISManager >> UpdateBindings(List<(Of <String>)>)
Connects to the local IIS to update alias settings for a given site. Requires that the user running this process has administrator priviliges. Consider using impersonation to obtain administrator privileges.
Declaration Syntax
C#
public void UpdateBindings(
    List<string> hosts
)
Parameters
hosts (List <(Of < String >)>)
The hosts.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Licenses Namespace

MSS.Licenses Namespace
Namespaces >> MSS.Licenses
Declaration Syntax
C#
namespace MSS.Licenses
Types
All Types Classes Interfaces
Icon | Type | Description
 | ILicensed |
 | LicenseManager | Sitecore foundry license manager.


ILicensed Interface

ILicensed Interface
Namespaces >> MSS.Licenses >> ILicensed
Declaration Syntax
C#
public interface ILicensed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HasLicense()() |
 | LicenseKey |

Assembly: MSS.Kernel (Module: MSS.Kernel)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Licenses >> ILicensed >> HasLicense()()
Declaration Syntax
C#
bool HasLicense()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Licenses >> ILicensed >> LicenseKey
Declaration Syntax
C#
string LicenseKey{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


LicenseManager Class

LicenseManager Class
Namespaces >> MSS.Licenses >> LicenseManager
Sitecore foundry license manager.
Declaration Syntax
C#
public class LicenseManager
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LicenseManagerLicenseManagerNew(Server) | Class constructor. Create a new instance of LicenseManager.
 | EnsureSitecoreFoundry()() | Ensures the sitecore foundry runtime license.
 | EnsureSitecoreFoundry(String) | Ensures specified sitecore foundry license.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetModuleCount(String) | Gets a count of modules.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasLicense()() | Determines whether the current installation has sitecore foundry license.
 | HasLicense(String) | Determines whether the current installation has sitecore foundry license.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoLicense(String) | Redirect to no license page.
 | server |
 | SitecoreFoundryRuntime |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LicenseManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


LicenseManager Constructor (server)

LicenseManager Constructor (server)
Namespaces >> MSS.Licenses >> LicenseManager >> LicenseManagerLicenseManagerNew(Server)
Class constructor. Create a new instance of LicenseManager.
Declaration Syntax
C#
public LicenseManager(
    Server server
)
Parameters
server (Server)

Assembly: MSS.Kernel (Module: MSS.Kernel)


EnsureSitecoreFoundry Method

EnsureSitecoreFoundry Method
Namespaces >> MSS.Licenses >> LicenseManager >> EnsureSitecoreFoundry()()
Members
Icon | Member | Description
 | EnsureSitecoreFoundry()() | Ensures the sitecore foundry runtime license.
 | EnsureSitecoreFoundry(String) | Ensures specified sitecore foundry license.

Assembly: MSS.Kernel (Module: MSS.Kernel)


EnsureSitecoreFoundry Method

EnsureSitecoreFoundry Method
Namespaces >> MSS.Licenses >> LicenseManager >> EnsureSitecoreFoundry()()
Ensures the sitecore foundry runtime license.
Declaration Syntax
C#
public virtual void EnsureSitecoreFoundry()

Assembly: MSS.Kernel (Module: MSS.Kernel)


EnsureSitecoreFoundry Method (licenseName)

EnsureSitecoreFoundry Method (licenseName)
Namespaces >> MSS.Licenses >> LicenseManager >> EnsureSitecoreFoundry(String)
Ensures specified sitecore foundry license.
Declaration Syntax
C#
public virtual void EnsureSitecoreFoundry(
    string licenseName
)
Parameters
licenseName (String)
Name of the license to ensure.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetModuleCount Method (licenseName)

GetModuleCount Method (licenseName)
Namespaces >> MSS.Licenses >> LicenseManager >> GetModuleCount(String)
Gets a count of modules.
Declaration Syntax
C#
public virtual int GetModuleCount(
    string licenseName
)
Parameters
licenseName (String)
License name
Return Value
Count of modules

Assembly: MSS.Kernel (Module: MSS.Kernel)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Licenses >> LicenseManager >> HasLicense()()
Members
Icon | Member | Description
 | HasLicense()() | Determines whether the current installation has sitecore foundry license.
 | HasLicense(String) | Determines whether the current installation has sitecore foundry license.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Licenses >> LicenseManager >> HasLicense()()
Determines whether the current installation has sitecore foundry license.
Declaration Syntax
C#
public virtual bool HasLicense()
Return Value
true if the current installation has sitecore foundry license, otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HasLicense Method (licenseName)

HasLicense Method (licenseName)
Namespaces >> MSS.Licenses >> LicenseManager >> HasLicense(String)
Determines whether the current installation has sitecore foundry license.
Declaration Syntax
C#
public virtual bool HasLicense(
    string licenseName
)
Parameters
licenseName (String)
Name of the license.
Return Value
true if the current installation has sitecore foundry license, otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


NoLicense Method (licenseName)

NoLicense Method (licenseName)
Namespaces >> MSS.Licenses >> LicenseManager >> NoLicense(String)
Redirect to no license page.
Declaration Syntax
C#
public virtual void NoLicense(
    string licenseName
)
Parameters
licenseName (String)
Name of the license.

Assembly: MSS.Kernel (Module: MSS.Kernel)


server Field

server Field
Namespaces >> MSS.Licenses >> LicenseManager >> server
Declaration Syntax
C#
protected Server server

Assembly: MSS.Kernel (Module: MSS.Kernel)


SitecoreFoundryRuntime Field

SitecoreFoundryRuntime Field
Namespaces >> MSS.Licenses >> LicenseManager >> SitecoreFoundryRuntime
Declaration Syntax
C#
protected static readonly string SitecoreFoundryRuntime

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Modules Namespace

MSS.Modules Namespace
Namespaces >> MSS.Modules
Declaration Syntax
C#
namespace MSS.Modules
Types
All Types Classes
Icon | Type | Description
 | Module | MSS module.
 | ModuleControl |
 | ModuleManager | Module manager application.


Module Class

Module Class
Namespaces >> MSS.Modules >> Module
MSS module.
Declaration Syntax
C#
public class Module : Entity
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clone()() | Clones this instance. (Overrides Entity.Clone()().)
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRenderings(Page) | Gets the renderings.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | IsSpot | Gets a value indicating whether this instance is a spot.
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | Text | Gets the text.
 | Title | Gets the module title.
 | ToString()() | (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | Module

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Modules >> Module >> Clone()()
Clones this instance.
Declaration Syntax
C#
public override Entity Clone()
Return Value
The cloned instance.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetRenderings Method (page)

GetRenderings Method (page)
Namespaces >> MSS.Modules >> Module >> GetRenderings(Page)
Gets the renderings.
Declaration Syntax
C#
public Control[] GetRenderings(
    Page page
)
Parameters
page (Page)
The page.
Return Value
The renderings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsSpot Property

IsSpot Property
Namespaces >> MSS.Modules >> Module >> IsSpot
Gets a value indicating whether this instance is a spot.
Declaration Syntax
C#
public bool IsSpot{ get;}
Value
True if this instance is a spot; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Text Property

Text Property
Namespaces >> MSS.Modules >> Module >> Text
Gets the text.
Declaration Syntax
C#
public string Text{ get;}
Value
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Title Property

Title Property
Namespaces >> MSS.Modules >> Module >> Title
Gets the module title.
Declaration Syntax
C#
public string Title{ get;}
Value
The title.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToString Method

ToString Method
Namespaces >> MSS.Modules >> Module >> ToString()()
Declaration Syntax
C#
public override string ToString()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModuleControl Class

ModuleControl Class
Namespaces >> MSS.Modules >> ModuleControl
Declaration Syntax
C#
public abstract class ModuleControl : SiteControl, ILicensed
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModuleControlModuleControlNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() |
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LicenseKey |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key.
 | NoLicenseText | Gets a no license text.
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() |
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | PictureSeries
 |  |  |  |  |  | NewsDocument
 |  |  |  |  |  | News
 |  |  |  |  |  | MiniForum
 |  |  |  |  |  | Subscribe
 |  |  |  |  |  | CalendarModuleControl
 |  |  |  |  |  | EventDocument
 |  |  |  |  |  | Subscribe

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleControl Constructor

ModuleControl Constructor
Namespaces >> MSS.Modules >> ModuleControl >> ModuleControlModuleControlNew()()
Declaration Syntax
C#
protected ModuleControl()

Assembly: MSS.Modules (Module: MSS.Modules)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Modules >> ModuleControl >> DictionaryRoot
Gets a dictionary root item.
Declaration Syntax
C#
protected virtual string DictionaryRoot{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Modules >> ModuleControl >> HasLicense()()
Declaration Syntax
C#
public virtual bool HasLicense()

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules >> ModuleControl >> LicenseKey
Declaration Syntax
C#
public virtual string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


NoLicenseDictionaryKey Property

NoLicenseDictionaryKey Property
Namespaces >> MSS.Modules >> ModuleControl >> NoLicenseDictionaryKey
Gets a no license dictionary key.
Declaration Syntax
C#
protected virtual string NoLicenseDictionaryKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


NoLicenseText Property

NoLicenseText Property
Namespaces >> MSS.Modules >> ModuleControl >> NoLicenseText
Gets a no license text.
Declaration Syntax
C#
protected virtual string NoLicenseText{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules >> ModuleControl >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


ShowNoLicense Method

ShowNoLicense Method
Namespaces >> MSS.Modules >> ModuleControl >> ShowNoLicense()()
Declaration Syntax
C#
protected virtual void ShowNoLicense()

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleManager Class

ModuleManager Class
Namespaces >> MSS.Modules >> ModuleManager
Module manager application.
Declaration Syntax
C#
public class ModuleManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ModuleManagerModuleManagerNew(Server) | Initializes a new instance of the ModuleManager class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAvailableModules(Item) | Gets the defined (not all allowed) modules for specified item.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetModules(SiteType) | Gets the modules for the site type.
 | GetModules(Item) | Gets all modules for the specified item.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAvailable(ID, SiteContext) | Determines whether the specified module ID is available.
 | IsAvailable(Module, SiteContext) | Determines whether the specified module is available for the specified site.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ModuleManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModuleManager Constructor (server)

ModuleManager Constructor (server)
Namespaces >> MSS.Modules >> ModuleManager >> ModuleManagerModuleManagerNew(Server)
Initializes a new instance of the ModuleManager class.
Declaration Syntax
C#
public ModuleManager(
    Server server
)
Parameters
server (Server)
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAvailableModules Method (item)

GetAvailableModules Method (item)
Namespaces >> MSS.Modules >> ModuleManager >> GetAvailableModules(Item)
Gets the defined (not all allowed) modules for specified item.
Declaration Syntax
C#
public virtual Module[] GetAvailableModules(
    Item item
)
Parameters
item (Item)
The item.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetModules Method

GetModules Method
Namespaces >> MSS.Modules >> ModuleManager >> GetModules()()
Members
Icon | Member | Description
 | GetModules(SiteType) | Gets the modules for the site type.
 | GetModules(Item) | Gets all modules for the specified item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetModules Method (type)

GetModules Method (type)
Namespaces >> MSS.Modules >> ModuleManager >> GetModules(SiteType)
Gets the modules for the site type.
Declaration Syntax
C#
public virtual Module[] GetModules(
    SiteType type
)
Parameters
type (SiteType)
The site type.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetModules Method (item)

GetModules Method (item)
Namespaces >> MSS.Modules >> ModuleManager >> GetModules(Item)
Gets all modules for the specified item.
Declaration Syntax
C#
public virtual Module[] GetModules(
    Item item
)
Parameters
item (Item)
The item.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAvailable Method

IsAvailable Method
Namespaces >> MSS.Modules >> ModuleManager >> IsAvailable()()
Members
Icon | Member | Description
 | IsAvailable(ID, SiteContext) | Determines whether the specified module ID is available.
 | IsAvailable(Module, SiteContext) | Determines whether the specified module is available for the specified site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAvailable Method (module, site)

IsAvailable Method (module, site)
Namespaces >> MSS.Modules >> ModuleManager >> IsAvailable(Module, SiteContext)
Determines whether the specified module is available for the specified site.
Declaration Syntax
C#
public virtual bool IsAvailable(
    Module module,
    SiteContext site
)
Parameters
module (Module)
The module.
site (SiteContext)
The site.
Return Value
true if the specified module is available; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAvailable Method (moduleID, site)

IsAvailable Method (moduleID, site)
Namespaces >> MSS.Modules >> ModuleManager >> IsAvailable(ID, SiteContext)
Determines whether the specified module ID is available.
Declaration Syntax
C#
public virtual bool IsAvailable(
    ID moduleID,
    SiteContext site
)
Parameters
moduleID (ID)
The module ID.
site (SiteContext)
The site.
Return Value
true if the specified module ID is available; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Modules.Common Namespace

MSS.Modules.Common Namespace
Namespaces >> MSS.Modules.Common
Declaration Syntax
C#
namespace MSS.Modules.Common
Types
All Types Classes
Icon | Type | Description
 | DbHelper |
 | SecurityHelper | In modules such as SMS and Newsletter we are using different kinds of restricted access to those in MSS.Security, which are based on denying access to the Anonymous user, and this functionality is implemented in this module.
 | YearMonthItemHandler | Handler that moves a module item in the case of changing the date field.
 | YearMonthItemHandlerException |
 | YearMonthItems | Handles items which contains a data field and needs to be categorized in year and month "folders" inside Sitecore. Handles creation, editing of dates and deletion of items.


DbHelper Class

DbHelper Class
Namespaces >> MSS.Modules.Common >> DbHelper
Declaration Syntax
C#
public class DbHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DbHelperDbHelperNew()() |
 | AddParameter(IDbCommand, String, Object) |
 | CreateCommand(IDbConnection, String) |
 | CreateConnection(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConnectionString(String) |
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DbHelper

Assembly: MSS.Modules (Module: MSS.Modules)


DbHelper Constructor

DbHelper Constructor
Namespaces >> MSS.Modules.Common >> DbHelper >> DbHelperDbHelperNew()()
Declaration Syntax
C#
public DbHelper()

Assembly: MSS.Modules (Module: MSS.Modules)


AddParameter Method (command, name, value)

AddParameter Method (command, name, value)
Namespaces >> MSS.Modules.Common >> DbHelper >> AddParameter(IDbCommand, String, Object)
Declaration Syntax
C#
public static void AddParameter(
    IDbCommand command,
    string name,
    Object value
)
Parameters
command (IDbCommand)
name (String)
value (Object)

Assembly: MSS.Modules (Module: MSS.Modules)


CreateCommand Method (connection, commandText)

CreateCommand Method (connection, commandText)
Namespaces >> MSS.Modules.Common >> DbHelper >> CreateCommand(IDbConnection, String)
Declaration Syntax
C#
public static IDbCommand CreateCommand(
    IDbConnection connection,
    string commandText
)
Parameters
connection (IDbConnection)
commandText (String)

Assembly: MSS.Modules (Module: MSS.Modules)


CreateConnection Method (connectionString)

CreateConnection Method (connectionString)
Namespaces >> MSS.Modules.Common >> DbHelper >> CreateConnection(String)
Declaration Syntax
C#
public static IDbConnection CreateConnection(
    string connectionString
)
Parameters
connectionString (String)

Assembly: MSS.Modules (Module: MSS.Modules)


GetConnectionString Method (databaseName)

GetConnectionString Method (databaseName)
Namespaces >> MSS.Modules.Common >> DbHelper >> GetConnectionString(String)
Declaration Syntax
C#
public static string GetConnectionString(
    string databaseName
)
Parameters
databaseName (String)

Assembly: MSS.Modules (Module: MSS.Modules)


SecurityHelper Class

SecurityHelper Class
Namespaces >> MSS.Modules.Common >> SecurityHelper
In modules such as SMS and Newsletter we are using different kinds of restricted access to those in MSS.Security, which are based on denying access to the Anonymous user, and this functionality is implemented in this module.
Declaration Syntax
C#
public static class SecurityHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetGroupsWithAccess(Item) | Gets the list of groups that have access to the item.
 | IsAccessibleForCurrentUser(Item) | Indicates whether a newsletter should be visible for a module.
 | IsRestrictedAccess(Item) | Checks whether there is restricted access to the item.
 | RemoveRestrictAccess(Item) | Remove/restrict access for a specific item.
 | SetRestrictedAccess(Item, array<String>[]()) | Sets restricted access to the item
Inheritance Hierarchy
Object
SecurityHelper

Assembly: MSS.Modules (Module: MSS.Modules)


GetGroupsWithAccess Method (item)

GetGroupsWithAccess Method (item)
Namespaces >> MSS.Modules.Common >> SecurityHelper >> GetGroupsWithAccess(Item)
Gets the list of groups that have access to the item.
Declaration Syntax
C#
public static string[] GetGroupsWithAccess(
    Item item
)
Parameters
item (Item)
Item.
Return Value
List of groups that have access to the item.

Assembly: MSS.Modules (Module: MSS.Modules)


IsAccessibleForCurrentUser Method (item)

IsAccessibleForCurrentUser Method (item)
Namespaces >> MSS.Modules.Common >> SecurityHelper >> IsAccessibleForCurrentUser(Item)
Indicates whether a newsletter should be visible for a module.
Declaration Syntax
C#
public static bool IsAccessibleForCurrentUser(
    Item item
)
Parameters
item (Item)
The newsletter.
Return Value
True if the newsletter should be visible for a module; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


IsRestrictedAccess Method (item)

IsRestrictedAccess Method (item)
Namespaces >> MSS.Modules.Common >> SecurityHelper >> IsRestrictedAccess(Item)
Checks whether there is restricted access to the item.
Declaration Syntax
C#
public static bool IsRestrictedAccess(
    Item item
)
Parameters
item (Item)
Item.
Return Value
True if there is restrict access to the item; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


RemoveRestrictAccess Method (item)

RemoveRestrictAccess Method (item)
Namespaces >> MSS.Modules.Common >> SecurityHelper >> RemoveRestrictAccess(Item)
Remove/restrict access for a specific item.
Declaration Syntax
C#
public static void RemoveRestrictAccess(
    Item item
)
Parameters
item (Item)
Item.

Assembly: MSS.Modules (Module: MSS.Modules)


SetRestrictedAccess Method (item, groupsWithAccess)

SetRestrictedAccess Method (item, groupsWithAccess)
Namespaces >> MSS.Modules.Common >> SecurityHelper >> SetRestrictedAccess(Item, array<String>[]())
Sets restricted access to the item
Declaration Syntax
C#
public static void SetRestrictedAccess(
    Item item,
    string[] groupsWithAccess
)
Parameters
item (Item)
Item
groupsWithAccess (array< String >[]())
Group which should have restricted access, can be null

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItemHandler Class

YearMonthItemHandler Class
Namespaces >> MSS.Modules.Common >> YearMonthItemHandler
Handler that moves a module item in the case of changing the date field.
Declaration Syntax
C#
public abstract class YearMonthItemHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | YearMonthItemHandlerYearMonthItemHandlerNew()() |
 | CreateModule(Item) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Handles the item:deleted event.
 | OnItemSaved(Object, EventArgs) | Handles the item:saved event.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | YearMonthItemHandler
 |  | ItemHandler
 |  | ItemMover

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItemHandler Constructor

YearMonthItemHandler Constructor
Namespaces >> MSS.Modules.Common >> YearMonthItemHandler >> YearMonthItemHandlerYearMonthItemHandlerNew()()
Declaration Syntax
C#
protected YearMonthItemHandler()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateModule Method (item)

CreateModule Method (item)
Namespaces >> MSS.Modules.Common >> YearMonthItemHandler >> CreateModule(Item)
Declaration Syntax
C#
protected abstract YearMonthItems CreateModule(
    Item item
)
Parameters
item (Item)

Assembly: MSS.Modules (Module: MSS.Modules)


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces >> MSS.Modules.Common >> YearMonthItemHandler >> OnItemDeleted(Object, EventArgs)
Handles the item:deleted event.
Declaration Syntax
C#
public void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces >> MSS.Modules.Common >> YearMonthItemHandler >> OnItemSaved(Object, EventArgs)
Handles the item:saved event.
Declaration Syntax
C#
public void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItemHandlerException Class

YearMonthItemHandlerException Class
Namespaces >> MSS.Modules.Common >> YearMonthItemHandlerException
Declaration Syntax
C#
public class YearMonthItemHandlerException : ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | YearMonthItemHandlerExceptionYearMonthItemHandlerExceptionNew(String) |
 | YearMonthItemHandlerExceptionYearMonthItemHandlerExceptionNew(String, Exception) |
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | YearMonthItemHandlerException

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItemHandlerException Constructor

YearMonthItemHandlerException Constructor
Namespaces >> MSS.Modules.Common >> YearMonthItemHandlerException >> YearMonthItemHandlerExceptionYearMonthItemHandlerExceptionNew()()
Members
Icon | Member | Description
 | YearMonthItemHandlerExceptionYearMonthItemHandlerExceptionNew(String) |
 | YearMonthItemHandlerExceptionYearMonthItemHandlerExceptionNew(String, Exception) |

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItemHandlerException Constructor (Message)

YearMonthItemHandlerException Constructor (Message)
Namespaces >> MSS.Modules.Common >> YearMonthItemHandlerException >> YearMonthItemHandlerExceptionYearMonthItemHandlerExceptionNew(String)
Declaration Syntax
C#
public YearMonthItemHandlerException(
    string Message
)
Parameters
Message (String)

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItemHandlerException Constructor (Message, InnerException)

YearMonthItemHandlerException Constructor (Message, InnerException)
Namespaces >> MSS.Modules.Common >> YearMonthItemHandlerException >> YearMonthItemHandlerExceptionYearMonthItemHandlerExceptionNew(String, Exception)
Declaration Syntax
C#
public YearMonthItemHandlerException(
    string Message,
    Exception InnerException
)
Parameters
Message (String)
InnerException (Exception)

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItems Class

YearMonthItems Class
Namespaces >> MSS.Modules.Common >> YearMonthItems
Handles items which contains a data field and needs to be categorized in year and month "folders" inside Sitecore. Handles creation, editing of dates and deletion of items.
Declaration Syntax
C#
public abstract class YearMonthItems
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | YearMonthItemsYearMonthItemsNew()() |
 | YearMonthItemsYearMonthItemsNew(Item) |
 | CleanUpParentFolders(Item) |
 | CleanUpYear(Item) |
 | Create(String, String) | Creates the item.
 | Create(String) | Creates the item.
 | Create(DateTime) | Creates the item.
 | CreateItem(String, String) |
 | CreateItem(Item, String) |
 | DateTimeField | Gets the date time field.
 | Delete(Item, Item) | Deletes the item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFolder(DateTime) | Get month folder for the given date. If no month folder exists, it is created. If no year folder exists, it is created.
 | GetFolder(DateTime, Boolean) | Gets the folder for the date.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItems(DateTime) | Returns an array-list of items.
 | GetItems()() | Returns an array-list of items.
 | GetMonthFolder(DateTime) | Gets the month folder.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalPath | Gets the global path.
 | Item |
 | MasterName | Gets the name of the master.
 | MasterRoot | Gets the master root.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleName | Gets the name of the module.
 | MonthMasterName | Gets the master name of the month.
 | Move(Item) | Moves the item.
 | Move(Item, DateTime) | Moves the item.
 | RootPath | Gets the root path.
 | Site |
 | TemplateKey | Gets the template key.
 | TitleField | Gets the title field.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WebRoot | Gets the root item.
 | YearMasterName | Gets the master name of the year.
Inheritance Hierarchy
Object
 | YearMonthItems
 |  | NewsItem
 |  | EventCalendar

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItems Constructor

YearMonthItems Constructor
Namespaces >> MSS.Modules.Common >> YearMonthItems >> YearMonthItemsYearMonthItemsNew()()
Members
Icon | Member | Description
 | YearMonthItemsYearMonthItemsNew()() |
 | YearMonthItemsYearMonthItemsNew(Item) |

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItems Constructor

YearMonthItems Constructor
Namespaces >> MSS.Modules.Common >> YearMonthItems >> YearMonthItemsYearMonthItemsNew()()
Declaration Syntax
C#
public YearMonthItems()

Assembly: MSS.Modules (Module: MSS.Modules)


YearMonthItems Constructor (item)

YearMonthItems Constructor (item)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> YearMonthItemsYearMonthItemsNew(Item)
Declaration Syntax
C#
public YearMonthItems(
    Item item
)
Parameters
item (Item)

Assembly: MSS.Modules (Module: MSS.Modules)


CleanUpParentFolders Method (Parent)

CleanUpParentFolders Method (Parent)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> CleanUpParentFolders(Item)
Declaration Syntax
C#
protected void CleanUpParentFolders(
    Item Parent
)
Parameters
Parent (Item)

Assembly: MSS.Modules (Module: MSS.Modules)


CleanUpYear Method (Parent)

CleanUpYear Method (Parent)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> CleanUpYear(Item)
Declaration Syntax
C#
protected void CleanUpYear(
    Item Parent
)
Parameters
Parent (Item)

Assembly: MSS.Modules (Module: MSS.Modules)


Create Method

Create Method
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Create()()
Members
Icon | Member | Description
 | Create(String, String) | Creates the item.
 | Create(String) | Creates the item.
 | Create(DateTime) | Creates the item.

Assembly: MSS.Modules (Module: MSS.Modules)


Create Method (CreateDate)

Create Method (CreateDate)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Create(DateTime)
Creates the item.
Declaration Syntax
C#
public virtual bool Create(
    DateTime CreateDate
)
Parameters
CreateDate (DateTime)
The create date.
Return Value

Assembly: MSS.Modules (Module: MSS.Modules)


Create Method (CreateDate)

Create Method (CreateDate)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Create(String)
Creates the item.
Declaration Syntax
C#
public virtual bool Create(
    string CreateDate
)
Parameters
CreateDate (String)
The create date.
Return Value

Assembly: MSS.Modules (Module: MSS.Modules)


Create Method (CreateDate, Format)

Create Method (CreateDate, Format)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Create(String, String)
Creates the item.
Declaration Syntax
C#
public virtual bool Create(
    string CreateDate,
    string Format
)
Parameters
CreateDate (String)
The create date.
Format (String)
The format.
Return Value

Assembly: MSS.Modules (Module: MSS.Modules)


CreateItem Method

CreateItem Method
Namespaces >> MSS.Modules.Common >> YearMonthItems >> CreateItem()()
Members
Icon | Member | Description
 | CreateItem(String, String) |
 | CreateItem(Item, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


CreateItem Method (itm, fieldDateTime)

CreateItem Method (itm, fieldDateTime)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> CreateItem(Item, String)
Declaration Syntax
C#
protected virtual Object CreateItem(
    Item itm,
    string fieldDateTime
)
Parameters
itm (Item)
fieldDateTime (String)

Assembly: MSS.Modules (Module: MSS.Modules)


CreateItem Method (id, fieldDateTime)

CreateItem Method (id, fieldDateTime)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> CreateItem(String, String)
Declaration Syntax
C#
protected virtual Object CreateItem(
    string id,
    string fieldDateTime
)
Parameters
id (String)
fieldDateTime (String)

Assembly: MSS.Modules (Module: MSS.Modules)


DateTimeField Property

DateTimeField Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> DateTimeField
Gets the date time field.
Declaration Syntax
C#
public abstract string DateTimeField{ get;}
Value
The date time field.

Assembly: MSS.Modules (Module: MSS.Modules)


Delete Method (itm, oldParent)

Delete Method (itm, oldParent)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Delete(Item, Item)
Deletes the item.
Declaration Syntax
C#
public virtual void Delete(
    Item itm,
    Item oldParent
)
Parameters
itm (Item)
The item.
oldParent (Item)
The old parent.

Assembly: MSS.Modules (Module: MSS.Modules)


GetFolder Method

GetFolder Method
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GetFolder()()
Members
Icon | Member | Description
 | GetFolder(DateTime) | Get month folder for the given date. If no month folder exists, it is created. If no year folder exists, it is created.
 | GetFolder(DateTime, Boolean) | Gets the folder for the date.

Assembly: MSS.Modules (Module: MSS.Modules)


GetFolder Method (date)

GetFolder Method (date)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GetFolder(DateTime)
Get month folder for the given date. If no month folder exists, it is created. If no year folder exists, it is created.
Declaration Syntax
C#
protected Item GetFolder(
    DateTime date
)
Parameters
date (DateTime)
The date of the new item
Return Value
The month folder for the given date.

Assembly: MSS.Modules (Module: MSS.Modules)


GetFolder Method (date, createFolders)

GetFolder Method (date, createFolders)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GetFolder(DateTime, Boolean)
Gets the folder for the date.
Declaration Syntax
C#
protected Item GetFolder(
    DateTime date,
    bool createFolders
)
Parameters
date (DateTime)
The date.
createFolders (Boolean)
If set to true then any missing folders will be created.
Return Value
The month folder for the given date.

Assembly: MSS.Modules (Module: MSS.Modules)


GetItems Method

GetItems Method
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GetItems()()
Members
Icon | Member | Description
 | GetItems(DateTime) | Returns an array-list of items.
 | GetItems()() | Returns an array-list of items.

Assembly: MSS.Modules (Module: MSS.Modules)


GetItems Method

GetItems Method
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GetItems()()
Returns an array-list of items.
Declaration Syntax
C#
public virtual ArrayList GetItems()
Return Value
The items.

Assembly: MSS.Modules (Module: MSS.Modules)


GetItems Method (day)

GetItems Method (day)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GetItems(DateTime)
Returns an array-list of items.
Declaration Syntax
C#
public virtual ArrayList GetItems(
    DateTime day
)
Parameters
day (DateTime)
The day.
Return Value
The items.

Assembly: MSS.Modules (Module: MSS.Modules)


GetMonthFolder Method (date)

GetMonthFolder Method (date)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GetMonthFolder(DateTime)
Gets the month folder.
Declaration Syntax
C#
protected Item GetMonthFolder(
    DateTime date
)
Parameters
date (DateTime)
The date.
Return Value
The month folder.

Assembly: MSS.Modules (Module: MSS.Modules)


GlobalPath Property

GlobalPath Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> GlobalPath
Gets the global path.
Declaration Syntax
C#
public abstract string GlobalPath{ get;}
Value
The global path.

Assembly: MSS.Modules (Module: MSS.Modules)


Item Field

Item Field
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Item
Declaration Syntax
C#
protected Item Item

Assembly: MSS.Modules (Module: MSS.Modules)


MasterName Property

MasterName Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> MasterName
Gets the name of the master.
Declaration Syntax
C#
public abstract string MasterName{ get;}
Value
The name of the master.

Assembly: MSS.Modules (Module: MSS.Modules)


MasterRoot Property

MasterRoot Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> MasterRoot
Gets the master root.
Declaration Syntax
C#
public virtual Item MasterRoot{ get;}
Value
The master root.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleName Property

ModuleName Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> ModuleName
Gets the name of the module.
Declaration Syntax
C#
public abstract string ModuleName{ get;}
Value
The name of the module.

Assembly: MSS.Modules (Module: MSS.Modules)


MonthMasterName Property

MonthMasterName Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> MonthMasterName
Gets the master name of the month.
Declaration Syntax
C#
public abstract string MonthMasterName{ get;}
Value
The name of the month master.

Assembly: MSS.Modules (Module: MSS.Modules)


Move Method

Move Method
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Move()()
Members
Icon | Member | Description
 | Move(Item) | Moves the item.
 | Move(Item, DateTime) | Moves the item.

Assembly: MSS.Modules (Module: MSS.Modules)


Move Method (itm)

Move Method (itm)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Move(Item)
Moves the item.
Declaration Syntax
C#
public virtual bool Move(
    Item itm
)
Parameters
itm (Item)
The item.

Assembly: MSS.Modules (Module: MSS.Modules)


Move Method (itm, CreateDate)

Move Method (itm, CreateDate)
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Move(Item, DateTime)
Moves the item.
Declaration Syntax
C#
public virtual bool Move(
    Item itm,
    DateTime CreateDate
)
Parameters
itm (Item)
The item.
CreateDate (DateTime)
The create date.

Assembly: MSS.Modules (Module: MSS.Modules)


RootPath Property

RootPath Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> RootPath
Gets the root path.
Declaration Syntax
C#
protected virtual string RootPath{ get;}
Value
The root path.

Assembly: MSS.Modules (Module: MSS.Modules)


Site Property

Site Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> Site
Declaration Syntax
C#
public virtual SiteContext Site{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


TemplateKey Property

TemplateKey Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> TemplateKey
Gets the template key.
Declaration Syntax
C#
public abstract string TemplateKey{ get;}
Value
The template key.

Assembly: MSS.Modules (Module: MSS.Modules)


TitleField Property

TitleField Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> TitleField
Gets the title field.
Declaration Syntax
C#
public abstract string TitleField{ get;}
Value
The title field.

Assembly: MSS.Modules (Module: MSS.Modules)


WebRoot Property

WebRoot Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> WebRoot
Gets the root item.
Declaration Syntax
C#
public virtual Item WebRoot{ get;}
Value
The web root.

Assembly: MSS.Modules (Module: MSS.Modules)


YearMasterName Property

YearMasterName Property
Namespaces >> MSS.Modules.Common >> YearMonthItems >> YearMasterName
Gets the master name of the year.
Declaration Syntax
C#
public abstract string YearMasterName{ get;}
Value
The name of the year master.

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.Common.DataViewer Namespace

MSS.Modules.Common.DataViewer Namespace
Namespaces >> MSS.Modules.Common.DataViewer
Declaration Syntax
C#
namespace MSS.Modules.Common.DataViewer
Types
All Types Classes
Icon | Type | Description
 | ExcelConverter |
 | Header | Represents the header for each of a table column, and also its sequence in a row.
 | Row | Represent a row in a table.
 | Settings | Dataviewer module settings.
 | Viewer | Data viewer form.


ExcelConverter Class

ExcelConverter Class
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter
Declaration Syntax
C#
public class ExcelConverter : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExcelConverterExcelConverterNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Init(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | ExcelConverter

Assembly: MSS.Modules (Module: MSS.Modules)


ExcelConverter Constructor

ExcelConverter Constructor
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> ExcelConverterExcelConverterNew()()
Declaration Syntax
C#
public ExcelConverter()

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Init Method (sender, e)

Page_Init Method (sender, e)
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> Page_Init(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Init(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Header Class

Header Class
Namespaces >> MSS.Modules.Common.DataViewer >> Header
Represents the header for each of a table column, and also its sequence in a row.
Declaration Syntax
C#
public class Header : IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HeaderHeaderNew(String, Int32) |
 | CompareTo(Object) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | (Overrides Object.GetHashCode()().)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | Sequence | Gets or sets the sequence.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Header

Assembly: MSS.Modules (Module: MSS.Modules)


Header Constructor (name, sequence)

Header Constructor (name, sequence)
Namespaces >> MSS.Modules.Common.DataViewer >> Header >> HeaderHeaderNew(String, Int32)
Declaration Syntax
C#
public Header(
    string name,
    int sequence
)
Parameters
name (String)
sequence (Int32)

Assembly: MSS.Modules (Module: MSS.Modules)


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces >> MSS.Modules.Common.DataViewer >> Header >> CompareTo(Object)
Declaration Syntax
C#
public int CompareTo(
    Object obj
)
Parameters
obj (Object)

Assembly: MSS.Modules (Module: MSS.Modules)


Equals Method (obj)

Equals Method (obj)
Namespaces >> MSS.Modules.Common.DataViewer >> Header >> Equals(Object)
Declaration Syntax
C#
public override bool Equals(
    Object obj
)
Parameters
obj (Object)

Assembly: MSS.Modules (Module: MSS.Modules)


GetHashCode Method

GetHashCode Method
Namespaces >> MSS.Modules.Common.DataViewer >> Header >> GetHashCode()()
Declaration Syntax
C#
public override int GetHashCode()

Assembly: MSS.Modules (Module: MSS.Modules)


Name Property

Name Property
Namespaces >> MSS.Modules.Common.DataViewer >> Header >> Name
Gets or sets the name.
Declaration Syntax
C#
public string Name{ get; set;}
Value
The name.

Assembly: MSS.Modules (Module: MSS.Modules)


Sequence Property

Sequence Property
Namespaces >> MSS.Modules.Common.DataViewer >> Header >> Sequence
Gets or sets the sequence.
Declaration Syntax
C#
public int Sequence{ get; set;}
Value
The sequence.

Assembly: MSS.Modules (Module: MSS.Modules)


Row Class

Row Class
Namespaces >> MSS.Modules.Common.DataViewer >> Row
Represent a row in a table.
Declaration Syntax
C#
public class Row : IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RowRowNew()() |
 | CompareTo(Object) |
 | Entry |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hashtable |
 | Init(Dictionary<(Of <String, String>)>, String) |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToXmlNode(XmlDocument) |
Inheritance Hierarchy
Object
Row

Assembly: MSS.Modules (Module: MSS.Modules)


Row Constructor

Row Constructor
Namespaces >> MSS.Modules.Common.DataViewer >> Row >> RowRowNew()()
Declaration Syntax
C#
public Row()

Assembly: MSS.Modules (Module: MSS.Modules)


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces >> MSS.Modules.Common.DataViewer >> Row >> CompareTo(Object)
Declaration Syntax
C#
public int CompareTo(
    Object obj
)
Parameters
obj (Object)

Assembly: MSS.Modules (Module: MSS.Modules)


Entry Property

Entry Property
Namespaces >> MSS.Modules.Common.DataViewer >> Row >> Entry
Declaration Syntax
C#
public string Entry{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Hashtable Property

Hashtable Property
Namespaces >> MSS.Modules.Common.DataViewer >> Row >> Hashtable
Declaration Syntax
C#
public Dictionary<string, string> Hashtable{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Init Method (ht, entry)

Init Method (ht, entry)
Namespaces >> MSS.Modules.Common.DataViewer >> Row >> Init(Dictionary<(Of <String, String>)>, String)
Declaration Syntax
C#
public void Init(
    Dictionary<string, string> ht,
    string entry
)
Parameters
ht (Dictionary <(Of < String, String >)>)
entry (String)

Assembly: MSS.Modules (Module: MSS.Modules)


ToXmlNode Method (doc)

ToXmlNode Method (doc)
Namespaces >> MSS.Modules.Common.DataViewer >> Row >> ToXmlNode(XmlDocument)
Declaration Syntax
C#
public XmlNode ToXmlNode(
    XmlDocument doc
)
Parameters
doc (XmlDocument)

Assembly: MSS.Modules (Module: MSS.Modules)


Settings Class

Settings Class
Namespaces >> MSS.Modules.Common.DataViewer >> Settings
Dataviewer module settings.
Declaration Syntax
C#
public class Settings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SettingsSettingsNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SortOrder | Returns an array list of the columns to sort by.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Settings

Assembly: MSS.Modules (Module: MSS.Modules)


Settings Constructor

Settings Constructor
Namespaces >> MSS.Modules.Common.DataViewer >> Settings >> SettingsSettingsNew()()
Declaration Syntax
C#
public Settings()

Assembly: MSS.Modules (Module: MSS.Modules)


SortOrder Property

SortOrder Property
Namespaces >> MSS.Modules.Common.DataViewer >> Settings >> SortOrder
Returns an array list of the columns to sort by.
Declaration Syntax
C#
public static List<string> SortOrder{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Viewer Class

Viewer Class
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer
Data viewer form.
Declaration Syntax
C#
public class Viewer : BaseForm, ILicensed
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewerViewerNew()() |
 | brdToolbar |
 | btnArchive |
 | btnCloseArchive |
 | btnOpenArchive |
 | cbxFormName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | grdMain |
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | HasLicense()() | Determines whether the module has a valid license.
 | LicenseKey | Gets the license key for current module.
 | litFormTitle |
 | litTable |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnArhiveClick(Message) | Handles the "DataViewer:Arhive" event.
 | OnCloseClick(Message) | Handles the "DataViewer:Close" event.
 | OnDeleteClick(Message) | Handles the "DataViewer:Delete" event.
 | OnExportExcelClick(Message) | Handles the "DataViewer:ExportExcel" event.
 | OnFormChanged(Message) | Handles the "Viewer:FormChanged" event.
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnOpenArhiveClick(Message) | Handles the "DataViewer:OpenArhive" event.
 | OnPreRender(EventArgs) | (Overrides BaseForm.OnPreRender(EventArgs).)
 | OnPrintClick(Message) | Handles the "DataViewer:Print" event.
 | OnRefreshClick(Message) | Handles the "DataViewer:Refresh" event.
 | OnSelectAllClick(Message) | Handles the "DataViewer:SelectAll" event.
 | ServerProperties()() | (Inherited from BaseForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | Viewer

Assembly: MSS.Modules (Module: MSS.Modules)


Viewer Constructor

Viewer Constructor
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> ViewerViewerNew()()
Declaration Syntax
C#
public Viewer()

Assembly: MSS.Modules (Module: MSS.Modules)


brdToolbar Field

brdToolbar Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> brdToolbar
Declaration Syntax
C#
protected Border brdToolbar

Assembly: MSS.Modules (Module: MSS.Modules)


btnArchive Field

btnArchive Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> btnArchive
Declaration Syntax
C#
protected Toolbutton btnArchive

Assembly: MSS.Modules (Module: MSS.Modules)


btnCloseArchive Field

btnCloseArchive Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> btnCloseArchive
Declaration Syntax
C#
protected Toolbutton btnCloseArchive

Assembly: MSS.Modules (Module: MSS.Modules)


btnOpenArchive Field

btnOpenArchive Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> btnOpenArchive
Declaration Syntax
C#
protected Toolbutton btnOpenArchive

Assembly: MSS.Modules (Module: MSS.Modules)


cbxFormName Field

cbxFormName Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> cbxFormName
Declaration Syntax
C#
protected Combobox cbxFormName

Assembly: MSS.Modules (Module: MSS.Modules)


grdMain Field

grdMain Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> grdMain
Declaration Syntax
C#
protected GridPanel grdMain

Assembly: MSS.Modules (Module: MSS.Modules)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> HasLicense()()
Determines whether the module has a valid license.
Declaration Syntax
C#
public bool HasLicense()
Return Value
True if the license is valid. Otherwise false.

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> LicenseKey
Gets the license key for current module.
Declaration Syntax
C#
public string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


litFormTitle Field

litFormTitle Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> litFormTitle
Declaration Syntax
C#
protected Literal litFormTitle

Assembly: MSS.Modules (Module: MSS.Modules)


litTable Field

litTable Field
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> litTable
Declaration Syntax
C#
protected Literal litTable

Assembly: MSS.Modules (Module: MSS.Modules)


OnArhiveClick Method (msg)

OnArhiveClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnArhiveClick(Message)
Handles the "DataViewer:Arhive" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:Arhive")]
public void OnArhiveClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnCloseClick Method (msg)

OnCloseClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnCloseClick(Message)
Handles the "DataViewer:Close" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:Close")]
public void OnCloseClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnDeleteClick Method (msg)

OnDeleteClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnDeleteClick(Message)
Handles the "DataViewer:Delete" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:Delete")]
public void OnDeleteClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnExportExcelClick Method (msg)

OnExportExcelClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnExportExcelClick(Message)
Handles the "DataViewer:ExportExcel" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:ExportExcel")]
public void OnExportExcelClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnFormChanged Method (msg)

OnFormChanged Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnFormChanged(Message)
Handles the "Viewer:FormChanged" event.
Declaration Syntax
C#
[HandleMessageAttribute("Viewer:FormChanged")]
public void OnFormChanged(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnOpenArhiveClick Method (msg)

OnOpenArhiveClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnOpenArhiveClick(Message)
Handles the "DataViewer:OpenArhive" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:OpenArhive")]
public void OnOpenArhiveClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnPrintClick Method (msg)

OnPrintClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnPrintClick(Message)
Handles the "DataViewer:Print" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:Print")]
public void OnPrintClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnRefreshClick Method (msg)

OnRefreshClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnRefreshClick(Message)
Handles the "DataViewer:Refresh" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:Refresh")]
public void OnRefreshClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSelectAllClick Method (msg)

OnSelectAllClick Method (msg)
Namespaces >> MSS.Modules.Common.DataViewer >> Viewer >> OnSelectAllClick(Message)
Handles the "DataViewer:SelectAll" event.
Declaration Syntax
C#
[HandleMessageAttribute("DataViewer:SelectAll")]
public void OnSelectAllClick(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.Common.DataViewer.Helpers Namespace

MSS.Modules.Common.DataViewer.Helpers Namespace
Namespaces >> MSS.Modules.Common.DataViewer.Helpers
Declaration Syntax
C#
namespace MSS.Modules.Common.DataViewer.Helpers
Types
All Types Classes
Icon | Type | Description
 | ExcelConverter |
 | RowCollection |


ExcelConverter Class

ExcelConverter Class
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> ExcelConverter
Declaration Syntax
C#
public class ExcelConverter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransformToXmlSpreadsheet(XmlDocument, XmlWriter) |
Inheritance Hierarchy
Object
ExcelConverter

Assembly: MSS.Modules (Module: MSS.Modules)


TransformToXmlSpreadsheet Method (doc, writer)

TransformToXmlSpreadsheet Method (doc, writer)
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> ExcelConverter >> TransformToXmlSpreadsheet(XmlDocument, XmlWriter)
Declaration Syntax
C#
public static void TransformToXmlSpreadsheet(
    XmlDocument doc,
    XmlWriter writer
)
Parameters
doc (XmlDocument)
writer (XmlWriter)

Assembly: MSS.Modules (Module: MSS.Modules)


RowCollection Class

RowCollection Class
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection
Declaration Syntax
C#
public class RowCollection : List<Row>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RowCollectionRowCollectionNew()() |
 | RowCollectionRowCollectionNew(List<(Of <Row>)>) |
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < Row >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < Row >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < Row >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < Row >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < Row >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < Row >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < Row >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < Row >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < Row >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < Row >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < Row >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < Row >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < Row >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < Row >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < Row >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < Row >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < Row >)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < Row >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < Row >)>.)
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < Row >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < Row >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < Row >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < Row >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < Row >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < Row >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < Row >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < Row >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < Row >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < Row >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < Row >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < Row >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < Row >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < Row >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < Row >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < Row >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < Row >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < Row >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < Row >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < Row >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < Row >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < Row >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < Row >)>.)
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < Row >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToXmlDocument()() |
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < Row >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < Row >)>.)
Inheritance Hierarchy
Object
 | List <(Of < Row >)>
 |  | RowCollection

Assembly: MSS.Modules (Module: MSS.Modules)


RowCollection Constructor

RowCollection Constructor
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> RowCollectionRowCollectionNew()()
Members
Icon | Member | Description
 | RowCollectionRowCollectionNew()() |
 | RowCollectionRowCollectionNew(List<(Of <Row>)>) |

Assembly: MSS.Modules (Module: MSS.Modules)


RowCollection Constructor

RowCollection Constructor
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> RowCollectionRowCollectionNew()()
Declaration Syntax
C#
public RowCollection()

Assembly: MSS.Modules (Module: MSS.Modules)


RowCollection Constructor (rows)

RowCollection Constructor (rows)
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> RowCollectionRowCollectionNew(List<(Of <Row>)>)
Declaration Syntax
C#
public RowCollection(
    List<Row> rows
)
Parameters
rows (List <(Of < Row >)>)

Assembly: MSS.Modules (Module: MSS.Modules)


ToXmlDocument Method

ToXmlDocument Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> ToXmlDocument()()
Declaration Syntax
C#
public XmlDocument ToXmlDocument()

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.Common.Subscriptions Namespace

MSS.Modules.Common.Subscriptions Namespace
Namespaces >> MSS.Modules.Common.Subscriptions
Declaration Syntax
C#
namespace MSS.Modules.Common.Subscriptions
Types
All Types Classes
Icon | Type | Description
 | Group | Represents subscribers group.
 | MailingListManager | Manages groups and subscribers.
 | Subscriber | Represents a module subscriber.
 | SubscriptionDefinitions | Represents a subscription.


Group Class

Group Class
Namespaces >> MSS.Modules.Common.Subscriptions >> Group
Represents subscribers group.
Declaration Syntax
C#
public class Group
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GroupGroupNew(SubscriptionDefinitions) |
 | Create(String, String) | Creates the group.
 | Delete(Guid) | Deletes the group.
 | Description | Gets the description.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the subscriber ID.
 | Init(Item) | Initialises the group.
 | Init(String) | Initialises the group.
 | InnerItem | Gets the inner item.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the subscriber name.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(Guid, String, String) | Updates the group.
Inheritance Hierarchy
Object
Group

Assembly: MSS.Modules (Module: MSS.Modules)


Group Constructor (subsInfo)

Group Constructor (subsInfo)
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> GroupGroupNew(SubscriptionDefinitions)
Declaration Syntax
C#
public Group(
    SubscriptionDefinitions subsInfo
)
Parameters
subsInfo (SubscriptionDefinitions)

Assembly: MSS.Modules (Module: MSS.Modules)


Create Method (name, description)

Create Method (name, description)
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Create(String, String)
Creates the group.
Declaration Syntax
C#
public bool Create(
    string name,
    string description
)
Parameters
name (String)
The name.
description (String)
The description.
Return Value
True, if the group created successfully. Otherwise false.

Assembly: MSS.Modules (Module: MSS.Modules)


Delete Method (guid)

Delete Method (guid)
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Delete(Guid)
Deletes the group.
Declaration Syntax
C#
public bool Delete(
    Guid guid
)
Parameters
guid (Guid)
The GUID.
Return Value
True, if the group deleted successfully. Otherwise false.

Assembly: MSS.Modules (Module: MSS.Modules)


Description Property

Description Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Description
Gets the description.
Declaration Syntax
C#
public string Description{ get;}
Value
The description.

Assembly: MSS.Modules (Module: MSS.Modules)


ID Property

ID Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> ID
Gets the subscriber ID.
Declaration Syntax
C#
public ID ID{ get;}
Value
The ID.

Assembly: MSS.Modules (Module: MSS.Modules)


Init Method

Init Method
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Init()()
Members
Icon | Member | Description
 | Init(Item) | Initialises the group.
 | Init(String) | Initialises the group.

Assembly: MSS.Modules (Module: MSS.Modules)


Init Method (group)

Init Method (group)
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Init(Item)
Initialises the group.
Declaration Syntax
C#
public bool Init(
    Item group
)
Parameters
group (Item)
The group.
Return Value
True, if the group initialized successfully. Otherwise false.

Assembly: MSS.Modules (Module: MSS.Modules)


Init Method (groupId)

Init Method (groupId)
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Init(String)
Initialises the group.
Declaration Syntax
C#
public bool Init(
    string groupId
)
Parameters
groupId (String)
The group id.
Return Value
True, if the group initialized successfully. Otherwise false.

Assembly: MSS.Modules (Module: MSS.Modules)


InnerItem Property

InnerItem Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> InnerItem
Gets the inner item.
Declaration Syntax
C#
public virtual Item InnerItem{ get;}
Value
The inner item.

Assembly: MSS.Modules (Module: MSS.Modules)


Name Property

Name Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Name
Gets the subscriber name.
Declaration Syntax
C#
public string Name{ get;}
Value
The name.

Assembly: MSS.Modules (Module: MSS.Modules)


Update Method (id, name, description)

Update Method (id, name, description)
Namespaces >> MSS.Modules.Common.Subscriptions >> Group >> Update(Guid, String, String)
Updates the group.
Declaration Syntax
C#
public bool Update(
    Guid id,
    string name,
    string description
)
Parameters
id (Guid)
The group id.
name (String)
The group name.
description (String)
The description.
Return Value
True, if the group updated successfully. Otherwise false.

Assembly: MSS.Modules (Module: MSS.Modules)


MailingListManager Class

MailingListManager Class
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager
Manages groups and subscribers.
Declaration Syntax
C#
public class MailingListManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MailingListManagerMailingListManagerNew(SubscriptionDefinitions) |
 | CreateGroup(String, String) | Creates a new mailing list group.
 | CreateSubscriber(String, String, String) | Creates an subscriber.
 | Delete(String) | Deletes a subscriber based on the email, if the email address is not found it does nothing.
 | DeleteGroup(Guid) | Deletes a group.
 | DeleteSubscriber(Int32) | Deletes the subscriber with the given id.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a subscriber for a given email or telephone number.
 | GetAccessibleGroups()() | Get the groups that are accessible for the current user.
 | GetGroup(Guid) | Get the group from the master database by id.
 | GetGroups()() | Gets the list of mailing list groups, using the master database
 | GetGroupsList()() | Returns a html select control with the list of groups.
 | GetGroupsWeb()() | Get the list of groups using the web database and only adding items the current user has the security to see.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSubscribers(String) | Gets the list of subscribers who have subscribed to at least one of the mailing lists in the parameter groups.
 | GetSubscribers()() | The list of all subscribers for the current web site.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateGroup(Guid, String, String) | Update a given group.
 | UpdateSubscriber(Int32, String, String, String) | Updates an existing subscriber.
Inheritance Hierarchy
Object
MailingListManager

Assembly: MSS.Modules (Module: MSS.Modules)


MailingListManager Constructor (definitions)

MailingListManager Constructor (definitions)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> MailingListManagerMailingListManagerNew(SubscriptionDefinitions)
Declaration Syntax
C#
public MailingListManager(
    SubscriptionDefinitions definitions
)
Parameters
definitions (SubscriptionDefinitions)

Assembly: MSS.Modules (Module: MSS.Modules)


CreateGroup Method (name, desc)

CreateGroup Method (name, desc)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> CreateGroup(String, String)
Creates a new mailing list group.
Declaration Syntax
C#
public Guid CreateGroup(
    string name,
    string desc
)
Parameters
name (String)
The mailing list name.
desc (String)
The mailing list description.
Return Value
The new group ID.

Assembly: MSS.Modules (Module: MSS.Modules)


CreateSubscriber Method (name, email, groups)

CreateSubscriber Method (name, email, groups)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> CreateSubscriber(String, String, String)
Creates an subscriber.
Declaration Syntax
C#
public void CreateSubscriber(
    string name,
    string email,
    string groups
)
Parameters
name (String)
Subscriber’s name.
email (String)
Subscriber’s email address.
groups (String)
The groups to subscribe to.

Assembly: MSS.Modules (Module: MSS.Modules)


Delete Method (email)

Delete Method (email)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> Delete(String)
Deletes a subscriber based on the email, if the email address is not found it does nothing.
Declaration Syntax
C#
public void Delete(
    string email
)
Parameters
email (String)
The email.

Assembly: MSS.Modules (Module: MSS.Modules)


DeleteGroup Method (id)

DeleteGroup Method (id)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> DeleteGroup(Guid)
Deletes a group.
Declaration Syntax
C#
public void DeleteGroup(
    Guid id
)
Parameters
id (Guid)
The group

Assembly: MSS.Modules (Module: MSS.Modules)


DeleteSubscriber Method (id)

DeleteSubscriber Method (id)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> DeleteSubscriber(Int32)
Deletes the subscriber with the given id.
Declaration Syntax
C#
public void DeleteSubscriber(
    int id
)
Parameters
id (Int32)
The ID.

Assembly: MSS.Modules (Module: MSS.Modules)


Get Method (value)

Get Method (value)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> Get(String)
Returns a subscriber for a given email or telephone number.
Declaration Syntax
C#
public Subscriber Get(
    string value
)
Parameters
value (String)
The email or telephone number.
Return Value
The subscriber.

Assembly: MSS.Modules (Module: MSS.Modules)


GetAccessibleGroups Method

GetAccessibleGroups Method
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetAccessibleGroups()()
Get the groups that are accessible for the current user.
Declaration Syntax
C#
public List<Group> GetAccessibleGroups()
Return Value
List of accessible groups.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGroup Method (groupId)

GetGroup Method (groupId)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetGroup(Guid)
Get the group from the master database by id.
Declaration Syntax
C#
public Group GetGroup(
    Guid groupId
)
Parameters
groupId (Guid)
The group id.
Return Value
The group.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGroups Method

GetGroups Method
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetGroups()()
Gets the list of mailing list groups, using the master database
Declaration Syntax
C#
public List<Group> GetGroups()
Return Value
The mailing list groups.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGroupsList Method

GetGroupsList Method
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetGroupsList()()
Returns a html select control with the list of groups.
Declaration Syntax
C#
public string GetGroupsList()
Return Value
The html select control with the list of groups.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGroupsWeb Method

GetGroupsWeb Method
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetGroupsWeb()()
Get the list of groups using the web database and only adding items the current user has the security to see.
Declaration Syntax
C#
public List<Group> GetGroupsWeb()
Return Value
The list of groups, using the web database that the current user has the security to see.

Assembly: MSS.Modules (Module: MSS.Modules)


GetSubscribers Method

GetSubscribers Method
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetSubscribers()()
Members
Icon | Member | Description
 | GetSubscribers(String) | Gets the list of subscribers who have subscribed to at least one of the mailing lists in the parameter groups.
 | GetSubscribers()() | The list of all subscribers for the current web site.

Assembly: MSS.Modules (Module: MSS.Modules)


GetSubscribers Method

GetSubscribers Method
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetSubscribers()()
The list of all subscribers for the current web site.
Declaration Syntax
C#
public List<Subscriber> GetSubscribers()
Return Value
The list of subscribers.

Assembly: MSS.Modules (Module: MSS.Modules)


GetSubscribers Method (groups)

GetSubscribers Method (groups)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> GetSubscribers(String)
Gets the list of subscribers who have subscribed to at least one of the mailing lists in the parameter groups.
Declaration Syntax
C#
public List<Subscriber> GetSubscribers(
    string groups
)
Parameters
groups (String)
The mailing list groups.
Return Value
The subscriber list.

Assembly: MSS.Modules (Module: MSS.Modules)


UpdateGroup Method (id, name, desc)

UpdateGroup Method (id, name, desc)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> UpdateGroup(Guid, String, String)
Update a given group.
Declaration Syntax
C#
public void UpdateGroup(
    Guid id,
    string name,
    string desc
)
Parameters
id (Guid)
The ID.
name (String)
The name.
desc (String)
The description.

Assembly: MSS.Modules (Module: MSS.Modules)


UpdateSubscriber Method (subID, name, value, groups)

UpdateSubscriber Method (subID, name, value, groups)
Namespaces >> MSS.Modules.Common.Subscriptions >> MailingListManager >> UpdateSubscriber(Int32, String, String, String)
Updates an existing subscriber.
Declaration Syntax
C#
public void UpdateSubscriber(
    int subID,
    string name,
    string value,
    string groups
)
Parameters
subID (Int32)
Subscriber's id.
name (String)
Subscriber's name.
value (String)
Either the email address or the telephone number.
groups (String)
The groups to subscribe to.

Assembly: MSS.Modules (Module: MSS.Modules)


Subscriber Class

Subscriber Class
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber
Represents a module subscriber.
Declaration Syntax
C#
public class Subscriber
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscriberSubscriberNew(SubscriptionDefinitions) | Initializes a new instance of the Subscriber class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Groups | Returns delimiter '|' separated list of the subscribers groups' ids.
 | ID | Gets the subscriber ID.
 | Init(Int32) | Initialises the object based on a subscriber ID.
 | Match(String) | Checks if the subscriber is subscribed to at least one of the groups.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the subscriber name.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets the value.
Inheritance Hierarchy
Object
Subscriber

Assembly: MSS.Modules (Module: MSS.Modules)


Subscriber Constructor (subsInfo)

Subscriber Constructor (subsInfo)
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber >> SubscriberSubscriberNew(SubscriptionDefinitions)
Initializes a new instance of the Subscriber class.
Declaration Syntax
C#
public Subscriber(
    SubscriptionDefinitions subsInfo
)
Parameters
subsInfo (SubscriptionDefinitions)
The subs info.

Assembly: MSS.Modules (Module: MSS.Modules)


Groups Property

Groups Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber >> Groups
Returns delimiter '|' separated list of the subscribers groups' ids.
Declaration Syntax
C#
public string Groups{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ID Property

ID Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber >> ID
Gets the subscriber ID.
Declaration Syntax
C#
public int ID{ get;}
Value
The ID.

Assembly: MSS.Modules (Module: MSS.Modules)


Init Method (subscriberID)

Init Method (subscriberID)
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber >> Init(Int32)
Initialises the object based on a subscriber ID.
Declaration Syntax
C#
public void Init(
    int subscriberID
)
Parameters
subscriberID (Int32)
The subscriber ID.

Assembly: MSS.Modules (Module: MSS.Modules)


Match Method (groups)

Match Method (groups)
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber >> Match(String)
Checks if the subscriber is subscribed to at least one of the groups.
Declaration Syntax
C#
public bool Match(
    string groups
)
Parameters
groups (String)
List of group ids which is separated by delimiter '|'.
Return Value
True if the subscriber is subscribed to at least one of the groups; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


Name Property

Name Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber >> Name
Gets the subscriber name.
Declaration Syntax
C#
public string Name{ get;}
Value
The name.

Assembly: MSS.Modules (Module: MSS.Modules)


Value Property

Value Property
Namespaces >> MSS.Modules.Common.Subscriptions >> Subscriber >> Value
Gets the value.
Declaration Syntax
C#
public string Value{ get;}
Value
The value.

Assembly: MSS.Modules (Module: MSS.Modules)


SubscriptionDefinitions Class

SubscriptionDefinitions Class
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions
Represents a subscription.
Declaration Syntax
C#
public abstract class SubscriptionDefinitions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscriptionDefinitionsSubscriptionDefinitionsNew()() |
 | ConnectionString | Gets the connection string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupDescriptionField | Gets the group description field name.
 | GroupMaster | Gets the group master.
 | GroupsMaster |
 | GroupsPath | Gets the groups path.
 | GroupsWeb |
 | GroupTemplate | Gets the group template.
 | GroupTitleField | Gets the group title field name.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleMaster |
 | ModuleRootPath | Gets the module root path.
 | ModuleWeb |
 | SubscribersTableName | Gets the name of the subscribers table.
 | SubscriptionsTableName | Gets the name of the subscriptions table.
 | SubsInfoFieldName | Gets the name of the subscriber info field.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SubscriptionDefinitions
 |  | Definitions
 |  | Definitions

Assembly: MSS.Modules (Module: MSS.Modules)


SubscriptionDefinitions Constructor

SubscriptionDefinitions Constructor
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> SubscriptionDefinitionsSubscriptionDefinitionsNew()()
Declaration Syntax
C#
protected SubscriptionDefinitions()

Assembly: MSS.Modules (Module: MSS.Modules)


ConnectionString Property

ConnectionString Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> ConnectionString
Gets the connection string.
Declaration Syntax
C#
public abstract string ConnectionString{ get;}
Value
The connection string.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupDescriptionField Property

GroupDescriptionField Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> GroupDescriptionField
Gets the group description field name.
Declaration Syntax
C#
public abstract string GroupDescriptionField{ get;}
Value
The group description field.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupMaster Property

GroupMaster Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> GroupMaster
Gets the group master.
Declaration Syntax
C#
public abstract string GroupMaster{ get;}
Value
The group master.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsMaster Property

GroupsMaster Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> GroupsMaster
Declaration Syntax
C#
public abstract Item GroupsMaster{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsPath Property

GroupsPath Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> GroupsPath
Gets the groups path.
Declaration Syntax
C#
public abstract string GroupsPath{ get;}
Value
The groups path.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsWeb Property

GroupsWeb Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> GroupsWeb
Declaration Syntax
C#
public abstract Item GroupsWeb{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupTemplate Property

GroupTemplate Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> GroupTemplate
Gets the group template.
Declaration Syntax
C#
public abstract string GroupTemplate{ get;}
Value
The group template.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupTitleField Property

GroupTitleField Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> GroupTitleField
Gets the group title field name.
Declaration Syntax
C#
public abstract string GroupTitleField{ get;}
Value
The group title field.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleMaster Property

ModuleMaster Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> ModuleMaster
Declaration Syntax
C#
public abstract Item ModuleMaster{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleRootPath Property

ModuleRootPath Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> ModuleRootPath
Gets the module root path.
Declaration Syntax
C#
public abstract string ModuleRootPath{ get;}
Value
The module root path.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleWeb Property

ModuleWeb Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> ModuleWeb
Declaration Syntax
C#
public abstract Item ModuleWeb{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersTableName Property

SubscribersTableName Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> SubscribersTableName
Gets the name of the subscribers table.
Declaration Syntax
C#
public abstract string SubscribersTableName{ get;}
Value
The name of the subscribers table.

Assembly: MSS.Modules (Module: MSS.Modules)


SubscriptionsTableName Property

SubscriptionsTableName Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> SubscriptionsTableName
Gets the name of the subscriptions table.
Declaration Syntax
C#
public abstract string SubscriptionsTableName{ get;}
Value
The name of the subscriptions table.

Assembly: MSS.Modules (Module: MSS.Modules)


SubsInfoFieldName Property

SubsInfoFieldName Property
Namespaces >> MSS.Modules.Common.Subscriptions >> SubscriptionDefinitions >> SubsInfoFieldName
Gets the name of the subscriber info field.
Declaration Syntax
C#
public abstract string SubsInfoFieldName{ get;}
Value
The name of the subs info field.

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.EventCalendar Namespace

MSS.Modules.EventCalendar Namespace
Namespaces >> MSS.Modules.EventCalendar
Declaration Syntax
C#
namespace MSS.Modules.EventCalendar
Types
All Types Classes
Icon | Type | Description
 | CalendarModuleControl |
 | Definitions | Event calendar definitions.
 | Event | Represents an event.
 | EventCalendar | Handles items which contains a data field and needs to be categorized in year and month "folders" inside Sitecore.
 | EventCalendarDataAccess | Event calendar data layer.


CalendarModuleControl Class

CalendarModuleControl Class
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl
Declaration Syntax
C#
public class CalendarModuleControl : ModuleControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalendarModuleControlCalendarModuleControlNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item path. (Overrides ModuleControl.DictionaryRoot.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LicenseKey | Gets a license key for EventCalendar module. (Overrides ModuleControl.LicenseKey.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | CalendarModuleControl
 |  |  |  |  |  |  | Calendar
 |  |  |  |  |  |  | Subscribe
 |  |  |  |  |  |  | Spot

Assembly: MSS.Modules (Module: MSS.Modules)


CalendarModuleControl Constructor

CalendarModuleControl Constructor
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> CalendarModuleControlCalendarModuleControlNew()()
Declaration Syntax
C#
public CalendarModuleControl()

Assembly: MSS.Modules (Module: MSS.Modules)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> DictionaryRoot
Gets a dictionary root item path.
Declaration Syntax
C#
protected override string DictionaryRoot{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> LicenseKey
Gets a license key for EventCalendar module.
Declaration Syntax
C#
public override string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Definitions Class

Definitions Class
Namespaces >> MSS.Modules.EventCalendar >> Definitions
Event calendar definitions.
Declaration Syntax
C#
public class Definitions
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultEventTemplate | Gets the default event template.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldDateTime | Gets the date time field name.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleName | Gets the name of the module.
 | ModuleRootPath | Gets the module root path.
 | TemplateKey | Gets the template key.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Definitions

Assembly: MSS.Modules (Module: MSS.Modules)


DefaultEventTemplate Property

DefaultEventTemplate Property
Namespaces >> MSS.Modules.EventCalendar >> Definitions >> DefaultEventTemplate
Gets the default event template.
Declaration Syntax
C#
public static string DefaultEventTemplate{ get;}
Value
The default event template.

Assembly: MSS.Modules (Module: MSS.Modules)


FieldDateTime Property

FieldDateTime Property
Namespaces >> MSS.Modules.EventCalendar >> Definitions >> FieldDateTime
Gets the date time field name.
Declaration Syntax
C#
public string FieldDateTime{ get;}
Value
The field date time.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleName Property

ModuleName Property
Namespaces >> MSS.Modules.EventCalendar >> Definitions >> ModuleName
Gets the name of the module.
Declaration Syntax
C#
public static string ModuleName{ get;}
Value
The name of the module.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleRootPath Property

ModuleRootPath Property
Namespaces >> MSS.Modules.EventCalendar >> Definitions >> ModuleRootPath
Gets the module root path.
Declaration Syntax
C#
public static string ModuleRootPath{ get;}
Value
The module root path.

Assembly: MSS.Modules (Module: MSS.Modules)


TemplateKey Property

TemplateKey Property
Namespaces >> MSS.Modules.EventCalendar >> Definitions >> TemplateKey
Gets the template key.
Declaration Syntax
C#
public string TemplateKey{ get;}
Value
The template key.

Assembly: MSS.Modules (Module: MSS.Modules)


Event Class

Event Class
Namespaces >> MSS.Modules.EventCalendar >> Event
Represents an event.
Declaration Syntax
C#
public class Event
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventEventNew(String, String) |
 | EventEventNew(Item, String) |
 | Date | Gets the event date.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the event ID.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets the event text.
 | Title | Gets the event title.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Event

Assembly: MSS.Modules (Module: MSS.Modules)


Event Constructor

Event Constructor
Namespaces >> MSS.Modules.EventCalendar >> Event >> EventEventNew()()
Members
Icon | Member | Description
 | EventEventNew(String, String) |
 | EventEventNew(Item, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


Event Constructor (itm, fieldDateTime)

Event Constructor (itm, fieldDateTime)
Namespaces >> MSS.Modules.EventCalendar >> Event >> EventEventNew(Item, String)
Declaration Syntax
C#
public Event(
    Item itm,
    string fieldDateTime
)
Parameters
itm (Item)
fieldDateTime (String)

Assembly: MSS.Modules (Module: MSS.Modules)


Event Constructor (ID, fieldDateTime)

Event Constructor (ID, fieldDateTime)
Namespaces >> MSS.Modules.EventCalendar >> Event >> EventEventNew(String, String)
Declaration Syntax
C#
public Event(
    string ID,
    string fieldDateTime
)
Parameters
ID (String)
fieldDateTime (String)

Assembly: MSS.Modules (Module: MSS.Modules)


Date Property

Date Property
Namespaces >> MSS.Modules.EventCalendar >> Event >> Date
Gets the event date.
Declaration Syntax
C#
public DateTime Date{ get;}
Value
The date.

Assembly: MSS.Modules (Module: MSS.Modules)


ID Property

ID Property
Namespaces >> MSS.Modules.EventCalendar >> Event >> ID
Gets the event ID.
Declaration Syntax
C#
public string ID{ get;}
Value
The ID.

Assembly: MSS.Modules (Module: MSS.Modules)


Text Property

Text Property
Namespaces >> MSS.Modules.EventCalendar >> Event >> Text
Gets the event text.
Declaration Syntax
C#
public string Text{ get;}
Value
The text.

Assembly: MSS.Modules (Module: MSS.Modules)


Title Property

Title Property
Namespaces >> MSS.Modules.EventCalendar >> Event >> Title
Gets the event title.
Declaration Syntax
C#
public string Title{ get;}
Value
The title.

Assembly: MSS.Modules (Module: MSS.Modules)


EventCalendar Class

EventCalendar Class
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar
Handles items which contains a data field and needs to be categorized in year and month "folders" inside Sitecore.
Declaration Syntax
C#
public class EventCalendar : YearMonthItems
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventCalendarEventCalendarNew()() |
 | EventCalendarEventCalendarNew(Item) |
 | CleanUpParentFolders(Item) | (Inherited from YearMonthItems.)
 | CleanUpYear(Item) | (Inherited from YearMonthItems.)
 | Create(String, String) | Creates the item. (Inherited from YearMonthItems.)
 | Create(String) | Creates the item. (Inherited from YearMonthItems.)
 | Create(DateTime) | Creates the item. (Inherited from YearMonthItems.)
 | CreateItem(String, String) | Creates the item. (Overrides YearMonthItems.CreateItem(String, String).)
 | CreateItem(Item, String) | Creates the item. (Overrides YearMonthItems.CreateItem(Item, String).)
 | DateTimeField | Gets the date time field name. (Overrides YearMonthItems.DateTimeField.)
 | Delete(Item, Item) | Deletes the item. (Inherited from YearMonthItems.)
 | DoShowDay(DateTime) | Redirects the browser to a page displaying appointments for a given day. The chosen view is dependent on configuration.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEvents(DateTime) | Get events for a specific day as a event collection
 | GetFolder(DateTime) | Get month folder for the given date. If no month folder exists, it is created. If no year folder exists, it is created. (Inherited from YearMonthItems.)
 | GetFolder(DateTime, Boolean) | Gets the folder for the date. (Inherited from YearMonthItems.)
 | GetGlobalDocument(String) | Get global document using the SiteInfo property.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItems(DateTime) | Returns an array-list of items. (Inherited from YearMonthItems.)
 | GetMonthFolder(DateTime) | Gets the month folder. (Inherited from YearMonthItems.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalPath | Gets the global path of the module. (Overrides YearMonthItems.GlobalPath.)
 | Item | (Inherited from YearMonthItems.)
 | MasterName | Gets the master name. (Overrides YearMonthItems.MasterName.)
 | MasterRoot | Gets the master root. (Inherited from YearMonthItems.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleName | Gets the name of the module. (Overrides YearMonthItems.ModuleName.)
 | MonthMasterName | Gets the name of the month item master. (Overrides YearMonthItems.MonthMasterName.)
 | Move(Item) | Moves the item. (Inherited from YearMonthItems.)
 | Move(Item, DateTime) | Moves the item. (Inherited from YearMonthItems.)
 | RootPath | Gets the root path. (Inherited from YearMonthItems.)
 | Site | (Inherited from YearMonthItems.)
 | TemplateKey | Gets the template key. (Overrides YearMonthItems.TemplateKey.)
 | TitleField | Gets the title field name. (Overrides YearMonthItems.TitleField.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WebRoot | Gets the root item. (Inherited from YearMonthItems.)
 | YearMasterName | Gets the master of the year item. (Overrides YearMonthItems.YearMasterName.)
Inheritance Hierarchy
Object
 | YearMonthItems
 |  | EventCalendar

Assembly: MSS.Modules (Module: MSS.Modules)


EventCalendar Constructor

EventCalendar Constructor
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> EventCalendarEventCalendarNew()()
Members
Icon | Member | Description
 | EventCalendarEventCalendarNew()() |
 | EventCalendarEventCalendarNew(Item) |

Assembly: MSS.Modules (Module: MSS.Modules)


EventCalendar Constructor

EventCalendar Constructor
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> EventCalendarEventCalendarNew()()
Declaration Syntax
C#
public EventCalendar()

Assembly: MSS.Modules (Module: MSS.Modules)


EventCalendar Constructor (item)

EventCalendar Constructor (item)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> EventCalendarEventCalendarNew(Item)
Declaration Syntax
C#
public EventCalendar(
    Item item
)
Parameters
item (Item)

Assembly: MSS.Modules (Module: MSS.Modules)


CreateItem Method

CreateItem Method
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> CreateItem()()
Members
Icon | Member | Description
 | CreateItem(String, String) | Creates the item. (Overrides YearMonthItems.CreateItem(String, String).)
 | CreateItem(Item, String) | Creates the item. (Overrides YearMonthItems.CreateItem(Item, String).)

Assembly: MSS.Modules (Module: MSS.Modules)


CreateItem Method (itm, fieldDateTime)

CreateItem Method (itm, fieldDateTime)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> CreateItem(Item, String)
Creates the item.
Declaration Syntax
C#
protected override Object CreateItem(
    Item itm,
    string fieldDateTime
)
Parameters
itm (Item)
The item.
fieldDateTime (String)
The field date time.

Assembly: MSS.Modules (Module: MSS.Modules)


CreateItem Method (id, fieldDateTime)

CreateItem Method (id, fieldDateTime)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> CreateItem(String, String)
Creates the item.
Declaration Syntax
C#
protected override Object CreateItem(
    string id,
    string fieldDateTime
)
Parameters
id (String)
The id.
fieldDateTime (String)
The field date time.

Assembly: MSS.Modules (Module: MSS.Modules)


DateTimeField Property

DateTimeField Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> DateTimeField
Gets the date time field name.
Declaration Syntax
C#
public override string DateTimeField{ get;}
Value
The date time field.

Assembly: MSS.Modules (Module: MSS.Modules)


DoShowDay Method (day)

DoShowDay Method (day)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> DoShowDay(DateTime)
Redirects the browser to a page displaying appointments for a given day. The chosen view is dependent on configuration.
Declaration Syntax
C#
public void DoShowDay(
    DateTime day
)
Parameters
day (DateTime)
The given day.

Assembly: MSS.Modules (Module: MSS.Modules)


GetEvents Method (day)

GetEvents Method (day)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> GetEvents(DateTime)
Get events for a specific day as a event collection
Declaration Syntax
C#
public List<Event> GetEvents(
    DateTime day
)
Parameters
day (DateTime)
The given date.
Return Value
The events.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalDocument Method (Documentname)

GetGlobalDocument Method (Documentname)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> GetGlobalDocument(String)
Get global document using the SiteInfo property.
Declaration Syntax
C#
protected Item GetGlobalDocument(
    string Documentname
)
Parameters
Documentname (String)
Document name.
Return Value
Global document.

Assembly: MSS.Modules (Module: MSS.Modules)


GlobalPath Property

GlobalPath Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> GlobalPath
Gets the global path of the module.
Declaration Syntax
C#
public override string GlobalPath{ get;}
Value
The global path.

Assembly: MSS.Modules (Module: MSS.Modules)


MasterName Property

MasterName Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> MasterName
Gets the master name.
Declaration Syntax
C#
public override string MasterName{ get;}
Value
The name of the master.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleName Property

ModuleName Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> ModuleName
Gets the name of the module.
Declaration Syntax
C#
public override string ModuleName{ get;}
Value
The name of the module.

Assembly: MSS.Modules (Module: MSS.Modules)


MonthMasterName Property

MonthMasterName Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> MonthMasterName
Gets the name of the month item master.
Declaration Syntax
C#
public override string MonthMasterName{ get;}
Value
The name of the month master.

Assembly: MSS.Modules (Module: MSS.Modules)


TemplateKey Property

TemplateKey Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> TemplateKey
Gets the template key.
Declaration Syntax
C#
public override string TemplateKey{ get;}
Value
The template key.

Assembly: MSS.Modules (Module: MSS.Modules)


TitleField Property

TitleField Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> TitleField
Gets the title field name.
Declaration Syntax
C#
public override string TitleField{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


YearMasterName Property

YearMasterName Property
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> YearMasterName
Gets the master of the year item.
Declaration Syntax
C#
public override string YearMasterName{ get;}
Value
The name of the year master.

Assembly: MSS.Modules (Module: MSS.Modules)


EventCalendarDataAccess Class

EventCalendarDataAccess Class
Namespaces >> MSS.Modules.EventCalendar >> EventCalendarDataAccess
Event calendar data layer.
Declaration Syntax
C#
public class EventCalendarDataAccess
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EventCalendarDataAccessEventCalendarDataAccessNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(Control, String%, String%) | Gets the control value.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Save(UserControl, String) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EventCalendarDataAccess

Assembly: MSS.Modules (Module: MSS.Modules)


EventCalendarDataAccess Constructor

EventCalendarDataAccess Constructor
Namespaces >> MSS.Modules.EventCalendar >> EventCalendarDataAccess >> EventCalendarDataAccessEventCalendarDataAccessNew()()
Declaration Syntax
C#
public EventCalendarDataAccess()

Assembly: MSS.Modules (Module: MSS.Modules)


GetValue Method (control, fieldValue, fieldType)

GetValue Method (control, fieldValue, fieldType)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendarDataAccess >> GetValue(Control, String%, String%)
Gets the control value.
Declaration Syntax
C#
public static bool GetValue(
    Control control,
    ref string fieldValue,
    ref string fieldType
)
Parameters
control (Control)
The control.
fieldValue (String %)
The field value.
fieldType (String %)
Type of the field.
Return Value

Assembly: MSS.Modules (Module: MSS.Modules)


Save Method (o, connectionString)

Save Method (o, connectionString)
Namespaces >> MSS.Modules.EventCalendar >> EventCalendarDataAccess >> Save(UserControl, String)
Declaration Syntax
C#
public void Save(
    UserControl o,
    string connectionString
)
Parameters
o (UserControl)
connectionString (String)

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.EventCalendar.ItemHandlers Namespace

MSS.Modules.EventCalendar.ItemHandlers Namespace
Namespaces >> MSS.Modules.EventCalendar.ItemHandlers
Declaration Syntax
C#
namespace MSS.Modules.EventCalendar.ItemHandlers
Types
All Types Classes
Icon | Type | Description
 | ItemMover | Handler that moves a calendar item when the date changes.


ItemMover Class

ItemMover Class
Namespaces >> MSS.Modules.EventCalendar.ItemHandlers >> ItemMover
Handler that moves a calendar item when the date changes.
Declaration Syntax
C#
public class ItemMover : YearMonthItemHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemMoverItemMoverNew()() |
 | CreateModule(Item) | (Overrides YearMonthItemHandler.CreateModule(Item).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Handles the item:deleted event. (Inherited from YearMonthItemHandler.)
 | OnItemSaved(Object, EventArgs) | Handles the item:saved event. (Inherited from YearMonthItemHandler.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | YearMonthItemHandler
 |  | ItemMover

Assembly: MSS.Modules (Module: MSS.Modules)


ItemMover Constructor

ItemMover Constructor
Namespaces >> MSS.Modules.EventCalendar.ItemHandlers >> ItemMover >> ItemMoverItemMoverNew()()
Declaration Syntax
C#
public ItemMover()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateModule Method (item)

CreateModule Method (item)
Namespaces >> MSS.Modules.EventCalendar.ItemHandlers >> ItemMover >> CreateModule(Item)
Declaration Syntax
C#
protected override YearMonthItems CreateModule(
    Item item
)
Parameters
item (Item)

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.EventCalendar.UserControls Namespace

MSS.Modules.EventCalendar.UserControls Namespace
Namespaces >> MSS.Modules.EventCalendar.UserControls
Declaration Syntax
C#
namespace MSS.Modules.EventCalendar.UserControls
Types
All Types Classes
Icon | Type | Description
 | Calendar | Displays the calendar.
 | EventDocument |
 | Spot | Spot class.
 | Subscribe | Subscribe to event control.


Calendar Class

Calendar Class
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar
Displays the calendar.
Declaration Syntax
C#
public class Calendar : CalendarModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalendarCalendarNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item path. (Inherited from CalendarModuleControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LicenseKey | Gets a license key for EventCalendar module. (Inherited from CalendarModuleControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Module_Calendar |
 | Module_Calendar_EventDocument |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | CalendarModuleControl
 |  |  |  |  |  |  | Calendar

Assembly: MSS.Modules (Module: MSS.Modules)


Calendar Constructor

Calendar Constructor
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> CalendarCalendarNew()()
Declaration Syntax
C#
public Calendar()

Assembly: MSS.Modules (Module: MSS.Modules)


Module_Calendar Field

Module_Calendar Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> Module_Calendar
Declaration Syntax
C#
protected XslFile Module_Calendar

Assembly: MSS.Modules (Module: MSS.Modules)


Module_Calendar_EventDocument Field

Module_Calendar_EventDocument Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> Module_Calendar_EventDocument
Declaration Syntax
C#
protected XslFile Module_Calendar_EventDocument

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


EventDocument Class

EventDocument Class
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument
Declaration Syntax
C#
public class EventDocument : ModuleControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventDocumentEventDocumentNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item. (Inherited from ModuleControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LicenseKey | (Inherited from ModuleControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | EventDocument

Assembly: MSS.Modules (Module: MSS.Modules)


EventDocument Constructor

EventDocument Constructor
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> EventDocumentEventDocumentNew()()
Declaration Syntax
C#
public EventDocument()

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Spot Class

Spot Class
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot
Spot class.
Declaration Syntax
C#
public class Spot : CalendarModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpotSpotNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | calCalendarSpot | calCalendarSpot control.
 | calCalendarSpot_DayRender(Object, DayRenderEventArgs) |
 | calCalendarSpot_SelectionChanged(Object, EventArgs) |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item path. (Inherited from CalendarModuleControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LicenseKey | Gets a license key for EventCalendar module. (Inherited from CalendarModuleControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides ModuleControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlCalendarSpot | pnlCalendarSpot control.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | CalendarModuleControl
 |  |  |  |  |  |  | Spot

Assembly: MSS.Modules (Module: MSS.Modules)


Spot Constructor

Spot Constructor
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> SpotSpotNew()()
Declaration Syntax
C#
public Spot()

Assembly: MSS.Modules (Module: MSS.Modules)


calCalendarSpot Field

calCalendarSpot Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> calCalendarSpot
calCalendarSpot control.
Declaration Syntax
C#
protected Calendar calCalendarSpot
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Modules (Module: MSS.Modules)


calCalendarSpot_DayRender Method (sender, e)

calCalendarSpot_DayRender Method (sender, e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> calCalendarSpot_DayRender(Object, DayRenderEventArgs)
Declaration Syntax
C#
protected void calCalendarSpot_DayRender(
    Object sender,
    DayRenderEventArgs e
)
Parameters
sender (Object)
e (DayRenderEventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


calCalendarSpot_SelectionChanged Method (sender, e)

calCalendarSpot_SelectionChanged Method (sender, e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> calCalendarSpot_SelectionChanged(Object, EventArgs)
Declaration Syntax
C#
protected void calCalendarSpot_SelectionChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


pnlCalendarSpot Field

pnlCalendarSpot Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> pnlCalendarSpot
pnlCalendarSpot control.
Declaration Syntax
C#
protected Panel pnlCalendarSpot
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Modules (Module: MSS.Modules)


Subscribe Class

Subscribe Class
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe
Subscribe to event control.
Declaration Syntax
C#
public class Subscribe : CalendarModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscribeSubscribeNew()() |
 | __Aktivitet |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnCancel |
 | btnCancel_Click(Object, EventArgs) |
 | btnSubscribe |
 | btnSubscribe_Click(Object, EventArgs) |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | CalendarSubscribeForm |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | date |
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item path. (Inherited from CalendarModuleControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblAddress |
 | lblComment |
 | lblEmail |
 | lblName |
 | lblPostNo |
 | lblRequiredFields |
 | lblTelephone |
 | lblTown |
 | LicenseKey | Gets a license key for EventCalendar module. (Inherited from CalendarModuleControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | reqAddress |
 | reqName |
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtAddress |
 | txtComment |
 | txtEmail |
 | txtName |
 | txtPostNo |
 | txtTelephone |
 | txtTown |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationSummary1 |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | CalendarModuleControl
 |  |  |  |  |  |  | Subscribe

Assembly: MSS.Modules (Module: MSS.Modules)


Subscribe Constructor

Subscribe Constructor
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> SubscribeSubscribeNew()()
Declaration Syntax
C#
public Subscribe()

Assembly: MSS.Modules (Module: MSS.Modules)


__Aktivitet Field

__Aktivitet Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> __Aktivitet
Declaration Syntax
C#
protected HtmlInputHidden __Aktivitet

Assembly: MSS.Modules (Module: MSS.Modules)


btnCancel Field

btnCancel Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> btnCancel
Declaration Syntax
C#
protected Button btnCancel

Assembly: MSS.Modules (Module: MSS.Modules)


btnCancel_Click Method (sender, e)

btnCancel_Click Method (sender, e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> btnCancel_Click(Object, EventArgs)
Declaration Syntax
C#
protected void btnCancel_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


btnSubscribe Field

btnSubscribe Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> btnSubscribe
Declaration Syntax
C#
protected Button btnSubscribe

Assembly: MSS.Modules (Module: MSS.Modules)


btnSubscribe_Click Method (sender, e)

btnSubscribe_Click Method (sender, e)
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> btnSubscribe_Click(Object, EventArgs)
Declaration Syntax
C#
protected void btnSubscribe_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


CalendarSubscribeForm Field

CalendarSubscribeForm Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> CalendarSubscribeForm
Declaration Syntax
C#
protected Form CalendarSubscribeForm

Assembly: MSS.Modules (Module: MSS.Modules)


date Field

date Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> date
Declaration Syntax
C#
protected HtmlInputHidden date

Assembly: MSS.Modules (Module: MSS.Modules)


lblAddress Field

lblAddress Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblAddress
Declaration Syntax
C#
protected Label lblAddress

Assembly: MSS.Modules (Module: MSS.Modules)


lblComment Field

lblComment Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblComment
Declaration Syntax
C#
protected Label lblComment

Assembly: MSS.Modules (Module: MSS.Modules)


lblEmail Field

lblEmail Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblEmail
Declaration Syntax
C#
protected Label lblEmail

Assembly: MSS.Modules (Module: MSS.Modules)


lblName Field

lblName Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblName
Declaration Syntax
C#
protected Label lblName

Assembly: MSS.Modules (Module: MSS.Modules)


lblPostNo Field

lblPostNo Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblPostNo
Declaration Syntax
C#
protected Label lblPostNo

Assembly: MSS.Modules (Module: MSS.Modules)


lblRequiredFields Field

lblRequiredFields Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblRequiredFields
Declaration Syntax
C#
protected Label lblRequiredFields

Assembly: MSS.Modules (Module: MSS.Modules)


lblTelephone Field

lblTelephone Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblTelephone
Declaration Syntax
C#
protected Label lblTelephone

Assembly: MSS.Modules (Module: MSS.Modules)


lblTown Field

lblTown Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> lblTown
Declaration Syntax
C#
protected Label lblTown

Assembly: MSS.Modules (Module: MSS.Modules)


reqAddress Field

reqAddress Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> reqAddress
Declaration Syntax
C#
protected RequiredFieldValidator reqAddress

Assembly: MSS.Modules (Module: MSS.Modules)


reqName Field

reqName Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> reqName
Declaration Syntax
C#
protected RequiredFieldValidator reqName

Assembly: MSS.Modules (Module: MSS.Modules)


txtAddress Field

txtAddress Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> txtAddress
Declaration Syntax
C#
protected TextBox txtAddress

Assembly: MSS.Modules (Module: MSS.Modules)


txtComment Field

txtComment Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> txtComment
Declaration Syntax
C#
protected TextBox txtComment

Assembly: MSS.Modules (Module: MSS.Modules)


txtEmail Field

txtEmail Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> txtEmail
Declaration Syntax
C#
protected TextBox txtEmail

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> txtName
Declaration Syntax
C#
protected TextBox txtName

Assembly: MSS.Modules (Module: MSS.Modules)


txtPostNo Field

txtPostNo Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> txtPostNo
Declaration Syntax
C#
protected TextBox txtPostNo

Assembly: MSS.Modules (Module: MSS.Modules)


txtTelephone Field

txtTelephone Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> txtTelephone
Declaration Syntax
C#
protected TextBox txtTelephone

Assembly: MSS.Modules (Module: MSS.Modules)


txtTown Field

txtTown Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> txtTown
Declaration Syntax
C#
protected TextBox txtTown

Assembly: MSS.Modules (Module: MSS.Modules)


ValidationSummary1 Field

ValidationSummary1 Field
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> ValidationSummary1
Declaration Syntax
C#
protected ValidationSummary ValidationSummary1

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.MiniForum Namespace

MSS.Modules.MiniForum Namespace
Namespaces >> MSS.Modules.MiniForum
Declaration Syntax
C#
namespace MSS.Modules.MiniForum
Types
All Types Classes Enumerations
Icon | Type | Description
 | ForumUser | Contains information about a forum user.
 | Utilities..::Interval | Represents time interval.
 | MessageFactory..::Message | Represents a forum message.
 | MessageFactory | Forum message factory. Provides methods for working with forum messages.
 | Utilities | Contains utility methods for the mini forum module.


ForumUser Class

ForumUser Class
Namespaces >> MSS.Modules.MiniForum >> ForumUser
Contains information about a forum user.
Declaration Syntax
C#
public class ForumUser
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Email | Gets or sets the user email.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the user name.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ForumUser

Assembly: MSS.Modules (Module: MSS.Modules)


Email Property

Email Property
Namespaces >> MSS.Modules.MiniForum >> ForumUser >> Email
Gets or sets the user email.
Declaration Syntax
C#
public static string Email{ get; set;}
Value
The email.

Assembly: MSS.Modules (Module: MSS.Modules)


Name Property

Name Property
Namespaces >> MSS.Modules.MiniForum >> ForumUser >> Name
Gets or sets the user name.
Declaration Syntax
C#
public static string Name{ get; set;}
Value
The name.

Assembly: MSS.Modules (Module: MSS.Modules)


Utilities.Interval Enumeration

Utilities..::Interval Enumeration
Namespaces >> MSS.Modules.MiniForum >> Utilities >> Utilities..::Interval
Represents time interval.
Declaration Syntax
C#
public enum Interval
Members
Member | Description
Second |
Minute |
Hour |
Day |
Week |
Month |
Year |

Assembly: MSS.Modules (Module: MSS.Modules)


MessageFactory.Message Class

MessageFactory..::Message Class
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> MessageFactory..::Message
Represents a forum message.
Declaration Syntax
C#
public class Message
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageFactory..::MessageMessageFactory..::MessageNew(Int32, String, String, DateTime, String) | Initializes a new instance of the MessageFactory..::Message class.
 | Body |
 | Created |
 | CreatedBy |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReplyId |
 | Subject |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MessageFactory..::Message

Assembly: MSS.Modules (Module: MSS.Modules)


MessageFactory.Message Constructor (replyId, subject, body, created, createdBy)

MessageFactory..::Message Constructor (replyId, subject, body, created, createdBy)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory..::Message >> MessageFactory..::MessageMessageFactory..::MessageNew(Int32, String, String, DateTime, String)
Initializes a new instance of the MessageFactory..::Message class.
Declaration Syntax
C#
public Message(
    int replyId,
    string subject,
    string body,
    DateTime created,
    string createdBy
)
Parameters
replyId (Int32)
subject (String)
body (String)
created (DateTime)
createdBy (String)

Assembly: MSS.Modules (Module: MSS.Modules)


Body Field

Body Field
Namespaces >> MSS.Modules.MiniForum >> MessageFactory..::Message >> Body
Declaration Syntax
C#
public string Body

Assembly: MSS.Modules (Module: MSS.Modules)


Created Field

Created Field
Namespaces >> MSS.Modules.MiniForum >> MessageFactory..::Message >> Created
Declaration Syntax
C#
public DateTime Created

Assembly: MSS.Modules (Module: MSS.Modules)


CreatedBy Field

CreatedBy Field
Namespaces >> MSS.Modules.MiniForum >> MessageFactory..::Message >> CreatedBy
Declaration Syntax
C#
public string CreatedBy

Assembly: MSS.Modules (Module: MSS.Modules)


ReplyId Field

ReplyId Field
Namespaces >> MSS.Modules.MiniForum >> MessageFactory..::Message >> ReplyId
Declaration Syntax
C#
public int ReplyId

Assembly: MSS.Modules (Module: MSS.Modules)


Subject Field

Subject Field
Namespaces >> MSS.Modules.MiniForum >> MessageFactory..::Message >> Subject
Declaration Syntax
C#
public string Subject

Assembly: MSS.Modules (Module: MSS.Modules)


MessageFactory Class

MessageFactory Class
Namespaces >> MSS.Modules.MiniForum >> MessageFactory
Forum message factory. Provides methods for working with forum messages.
Declaration Syntax
C#
public class MessageFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MessageFactoryMessageFactoryNew()() |
 | CreateMessage(Int32, String, String, Boolean, String, String) | Creates the new message.
 | CreateMessage(String, String, Boolean, String, String) | Creates the new message.
 | DeleteMessage(Int32) | Deletes the message.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Int32) | Determines if a specific message, with the specified message id, exists.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMessage(Int32) | Gets the message.
 | GetMessageList()() | Gets the message list.
 | GeTopicsPerPage()() | Ges the topics per page.
 | GetReplies(Int32) | Gets the replies.
 | GetRepliesPerPage()() | Gets the replies per page.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MapFileNames(String) |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MessageFactory

Assembly: MSS.Modules (Module: MSS.Modules)


MessageFactory Constructor

MessageFactory Constructor
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> MessageFactoryMessageFactoryNew()()
Declaration Syntax
C#
public MessageFactory()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateMessage Method

CreateMessage Method
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> CreateMessage()()
Members
Icon | Member | Description
 | CreateMessage(Int32, String, String, Boolean, String, String) | Creates the new message.
 | CreateMessage(String, String, Boolean, String, String) | Creates the new message.

Assembly: MSS.Modules (Module: MSS.Modules)


CreateMessage Method (parentMessageId, userName, userEmail, notifyByMail, subject, body)

CreateMessage Method (parentMessageId, userName, userEmail, notifyByMail, subject, body)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> CreateMessage(Int32, String, String, Boolean, String, String)
Creates the new message.
Declaration Syntax
C#
public static int CreateMessage(
    int parentMessageId,
    string userName,
    string userEmail,
    bool notifyByMail,
    string subject,
    string body
)
Parameters
parentMessageId (Int32)
The parent message id.
userName (String)
Name of the user.
userEmail (String)
The user email.
notifyByMail (Boolean)
if set to true [notify by mail].
subject (String)
The subject.
body (String)
The body.
Return Value
The message id.

Assembly: MSS.Modules (Module: MSS.Modules)


CreateMessage Method (userName, userEmail, notifyByMail, subject, body)

CreateMessage Method (userName, userEmail, notifyByMail, subject, body)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> CreateMessage(String, String, Boolean, String, String)
Creates the new message.
Declaration Syntax
C#
public static void CreateMessage(
    string userName,
    string userEmail,
    bool notifyByMail,
    string subject,
    string body
)
Parameters
userName (String)
Name of the user.
userEmail (String)
The user email.
notifyByMail (Boolean)
if set to true [notify by mail].
subject (String)
The subject.
body (String)
The body.

Assembly: MSS.Modules (Module: MSS.Modules)


DeleteMessage Method (messageId)

DeleteMessage Method (messageId)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> DeleteMessage(Int32)
Deletes the message.
Declaration Syntax
C#
public static void DeleteMessage(
    int messageId
)
Parameters
messageId (Int32)
The message id.

Assembly: MSS.Modules (Module: MSS.Modules)


Exists Method (messageId)

Exists Method (messageId)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> Exists(Int32)
Determines if a specific message, with the specified message id, exists.
Declaration Syntax
C#
public static bool Exists(
    int messageId
)
Parameters
messageId (Int32)
The message id.
Return Value
True if the message exists; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


GetMessage Method (messageId)

GetMessage Method (messageId)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> GetMessage(Int32)
Gets the message.
Declaration Syntax
C#
public static MessageFactory.MessageFactory..::Message GetMessage(
    int messageId
)
Parameters
messageId (Int32)
The message id.
Return Value
The message.

Assembly: MSS.Modules (Module: MSS.Modules)


GetMessageList Method

GetMessageList Method
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> GetMessageList()()
Gets the message list.
Declaration Syntax
C#
public static XPathDocument GetMessageList()
Return Value
The message list.

Assembly: MSS.Modules (Module: MSS.Modules)


GeTopicsPerPage Method

GeTopicsPerPage Method
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> GeTopicsPerPage()()
Ges the topics per page.
Declaration Syntax
C#
public static int GeTopicsPerPage()
Return Value
The topics.

Assembly: MSS.Modules (Module: MSS.Modules)


GetReplies Method (messageId)

GetReplies Method (messageId)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> GetReplies(Int32)
Gets the replies.
Declaration Syntax
C#
public static MessageFactory.MessageFactory..::Message[] GetReplies(
    int messageId
)
Parameters
messageId (Int32)
The message id.
Return Value
The replies.

Assembly: MSS.Modules (Module: MSS.Modules)


GetRepliesPerPage Method

GetRepliesPerPage Method
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> GetRepliesPerPage()()
Gets the replies per page.
Declaration Syntax
C#
public static int GetRepliesPerPage()
Return Value
The replies.

Assembly: MSS.Modules (Module: MSS.Modules)


MapFileNames Method (connectionString)

MapFileNames Method (connectionString)
Namespaces >> MSS.Modules.MiniForum >> MessageFactory >> MapFileNames(String)
Declaration Syntax
C#
public static string MapFileNames(
    string connectionString
)
Parameters
connectionString (String)

Assembly: MSS.Modules (Module: MSS.Modules)


Utilities Class

Utilities Class
Namespaces >> MSS.Modules.MiniForum >> Utilities
Contains utility methods for the mini forum module.
Declaration Syntax
C#
public class Utilities
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UtilitiesUtilitiesNew()() |
 | AddTag(String, String, String, String, Control) |
 | ConvertHtml(String, Boolean) | Converts text to the HTML.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatDate(String) | Formats the date.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPagingPanelHtml(Int32, Int32, Int32, String) |
 | GetSessionFieldValue(String) |
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HtmlDecode(String) |
 | IsForumAdmin()() | Determines whether current user is forum admin.
 | LinkToMessage(Int32) | Gets the link to message.
 | LinkToReply(Int32, Int32) | Gets the link to reply page.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageLink(String) | Gets the link to a message.
 | MessageListUrl()() | Gets the messages list URL.
 | RediectToReplies(Int32, Int32) | Redirects to replies.
 | RedirectToDefaultSheet()() | Redirects to the default sheet.
 | SetSessionFieldValue(String, String) |
 | TimeElapsed(DateTime, Utilities..::Interval) | Gets the elapsed time.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Utilities

Assembly: MSS.Modules (Module: MSS.Modules)


Utilities Constructor

Utilities Constructor
Namespaces >> MSS.Modules.MiniForum >> Utilities >> UtilitiesUtilitiesNew()()
Declaration Syntax
C#
public Utilities()

Assembly: MSS.Modules (Module: MSS.Modules)


AddTag Method (id, innerHtml, cssClass, tagType, parent)

AddTag Method (id, innerHtml, cssClass, tagType, parent)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> AddTag(String, String, String, String, Control)
Declaration Syntax
C#
public static HtmlGenericControl AddTag(
    string id,
    string innerHtml,
    string cssClass,
    string tagType,
    Control parent
)
Parameters
id (String)
innerHtml (String)
cssClass (String)
tagType (String)
parent (Control)

Assembly: MSS.Modules (Module: MSS.Modules)


ConvertHtml Method (text, convertSpaces)

ConvertHtml Method (text, convertSpaces)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> ConvertHtml(String, Boolean)
Converts text to the HTML.
Declaration Syntax
C#
public static string ConvertHtml(
    string text,
    bool convertSpaces
)
Parameters
text (String)
The text.
convertSpaces (Boolean)
If set to true the convert spaces.
Return Value
The converted HTML.

Assembly: MSS.Modules (Module: MSS.Modules)


FormatDate Method (dateString)

FormatDate Method (dateString)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> FormatDate(String)
Formats the date.
Declaration Syntax
C#
public static string FormatDate(
    string dateString
)
Parameters
dateString (String)
The date string.
Return Value
The formatted date.

Assembly: MSS.Modules (Module: MSS.Modules)


GetPagingPanelHtml Method (itemNumber, itemsCount, itemsPerPage, urlFormat)

GetPagingPanelHtml Method (itemNumber, itemsCount, itemsPerPage, urlFormat)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> GetPagingPanelHtml(Int32, Int32, Int32, String)
Declaration Syntax
C#
public static string GetPagingPanelHtml(
    int itemNumber,
    int itemsCount,
    int itemsPerPage,
    string urlFormat
)
Parameters
itemNumber (Int32)
itemsCount (Int32)
itemsPerPage (Int32)
urlFormat (String)

Assembly: MSS.Modules (Module: MSS.Modules)


GetSessionFieldValue Method (field)

GetSessionFieldValue Method (field)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> GetSessionFieldValue(String)
Declaration Syntax
C#
public static string GetSessionFieldValue(
    string field
)
Parameters
field (String)

Assembly: MSS.Modules (Module: MSS.Modules)


HtmlDecode Method (html)

HtmlDecode Method (html)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> HtmlDecode(String)
Declaration Syntax
C#
public static string HtmlDecode(
    string html
)
Parameters
html (String)

Assembly: MSS.Modules (Module: MSS.Modules)


IsForumAdmin Method

IsForumAdmin Method
Namespaces >> MSS.Modules.MiniForum >> Utilities >> IsForumAdmin()()
Determines whether current user is forum admin.
Declaration Syntax
C#
public static bool IsForumAdmin()
Return Value
True if current user is forum admin; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


LinkToMessage Method (messageId)

LinkToMessage Method (messageId)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> LinkToMessage(Int32)
Gets the link to message.
Declaration Syntax
C#
public static string LinkToMessage(
    int messageId
)
Parameters
messageId (Int32)
The message id.
Return Value
Tne message link.

Assembly: MSS.Modules (Module: MSS.Modules)


LinkToReply Method (messageId, replyId)

LinkToReply Method (messageId, replyId)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> LinkToReply(Int32, Int32)
Gets the link to reply page.
Declaration Syntax
C#
public static string LinkToReply(
    int messageId,
    int replyId
)
Parameters
messageId (Int32)
The message id.
replyId (Int32)
The reply id.
Return Value
The reply page link.

Assembly: MSS.Modules (Module: MSS.Modules)


MessageLink Method (messageId)

MessageLink Method (messageId)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> MessageLink(String)
Gets the link to a message.
Declaration Syntax
C#
public static string MessageLink(
    string messageId
)
Parameters
messageId (String)
The message id.
Return Value
Tne message link.

Assembly: MSS.Modules (Module: MSS.Modules)


MessageListUrl Method

MessageListUrl Method
Namespaces >> MSS.Modules.MiniForum >> Utilities >> MessageListUrl()()
Gets the messages list URL.
Declaration Syntax
C#
public static string MessageListUrl()
Return Value
The message list URL.

Assembly: MSS.Modules (Module: MSS.Modules)


RediectToReplies Method (messageId, replyId)

RediectToReplies Method (messageId, replyId)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> RediectToReplies(Int32, Int32)
Redirects to replies.
Declaration Syntax
C#
public static void RediectToReplies(
    int messageId,
    int replyId
)
Parameters
messageId (Int32)
The message id.
replyId (Int32)
The reply id.

Assembly: MSS.Modules (Module: MSS.Modules)


RedirectToDefaultSheet Method

RedirectToDefaultSheet Method
Namespaces >> MSS.Modules.MiniForum >> Utilities >> RedirectToDefaultSheet()()
Redirects to the default sheet.
Declaration Syntax
C#
public static void RedirectToDefaultSheet()

Assembly: MSS.Modules (Module: MSS.Modules)


SetSessionFieldValue Method (field, value)

SetSessionFieldValue Method (field, value)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> SetSessionFieldValue(String, String)
Declaration Syntax
C#
public static void SetSessionFieldValue(
    string field,
    string value
)
Parameters
field (String)
value (String)

Assembly: MSS.Modules (Module: MSS.Modules)


TimeElapsed Method (date, unit)

TimeElapsed Method (date, unit)
Namespaces >> MSS.Modules.MiniForum >> Utilities >> TimeElapsed(DateTime, Utilities..::Interval)
Gets the elapsed time.
Declaration Syntax
C#
public static int TimeElapsed(
    DateTime date,
    Utilities.Utilities..::Interval unit
)
Parameters
date (DateTime)
The date.
unit (Utilities..::Interval)
The unit.
Return Value
The elapsed time.

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.MiniForum.UserControls Namespace

MSS.Modules.MiniForum.UserControls Namespace
Namespaces >> MSS.Modules.MiniForum.UserControls
Declaration Syntax
C#
namespace MSS.Modules.MiniForum.UserControls
Types
All Types Classes
Icon | Type | Description
 | MessageAndReplies | Displays a message and replies to this message.
 | MessageList |
 | MiniForum | Mini forum.
 | Reply | Reply on the user message form.


MessageAndReplies Class

MessageAndReplies Class
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies
Displays a message and replies to this message.
Declaration Syntax
C#
public class MessageAndReplies : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageAndRepliesMessageAndRepliesNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | deleteMessageButton_ServerClick(Object, EventArgs) |
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | divMessage |
 | divReplies |
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | frmMessageList |
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HeaderHtmlFormat |
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageAndRepliesDictionaryPath |
 | MessageQueryStringKey |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | ReplyIDQueryStringKey |
 | ReplyNumberQueryStringKey |
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | MessageAndReplies

Assembly: MSS.Modules (Module: MSS.Modules)


MessageAndReplies Constructor

MessageAndReplies Constructor
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> MessageAndRepliesMessageAndRepliesNew()()
Declaration Syntax
C#
public MessageAndReplies()

Assembly: MSS.Modules (Module: MSS.Modules)


deleteMessageButton_ServerClick Method (sender, e)

deleteMessageButton_ServerClick Method (sender, e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> deleteMessageButton_ServerClick(Object, EventArgs)
Declaration Syntax
C#
protected void deleteMessageButton_ServerClick(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


divMessage Field

divMessage Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> divMessage
Declaration Syntax
C#
protected HtmlGenericControl divMessage

Assembly: MSS.Modules (Module: MSS.Modules)


divReplies Field

divReplies Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> divReplies
Declaration Syntax
C#
protected HtmlGenericControl divReplies

Assembly: MSS.Modules (Module: MSS.Modules)


frmMessageList Field

frmMessageList Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> frmMessageList
Declaration Syntax
C#
protected Form frmMessageList

Assembly: MSS.Modules (Module: MSS.Modules)


HeaderHtmlFormat Field

HeaderHtmlFormat Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> HeaderHtmlFormat
Declaration Syntax
C#
public static readonly string HeaderHtmlFormat

Assembly: MSS.Modules (Module: MSS.Modules)


MessageAndRepliesDictionaryPath Field

MessageAndRepliesDictionaryPath Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> MessageAndRepliesDictionaryPath
Declaration Syntax
C#
public static readonly string MessageAndRepliesDictionaryPath

Assembly: MSS.Modules (Module: MSS.Modules)


MessageQueryStringKey Field

MessageQueryStringKey Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> MessageQueryStringKey
Declaration Syntax
C#
public static readonly string MessageQueryStringKey

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


ReplyIDQueryStringKey Field

ReplyIDQueryStringKey Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> ReplyIDQueryStringKey
Declaration Syntax
C#
public static readonly string ReplyIDQueryStringKey

Assembly: MSS.Modules (Module: MSS.Modules)


ReplyNumberQueryStringKey Field

ReplyNumberQueryStringKey Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> ReplyNumberQueryStringKey
Declaration Syntax
C#
public static readonly string ReplyNumberQueryStringKey

Assembly: MSS.Modules (Module: MSS.Modules)


MessageList Class

MessageList Class
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList
Declaration Syntax
C#
public class MessageList : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageListMessageListNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnNewMessage |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | divMessageList |
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | errorMessage |
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | frmMessageList |
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PagingContainer |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | MessageList

Assembly: MSS.Modules (Module: MSS.Modules)


MessageList Constructor

MessageList Constructor
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> MessageListMessageListNew()()
Declaration Syntax
C#
public MessageList()

Assembly: MSS.Modules (Module: MSS.Modules)


btnNewMessage Field

btnNewMessage Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> btnNewMessage
Declaration Syntax
C#
protected Button btnNewMessage

Assembly: MSS.Modules (Module: MSS.Modules)


divMessageList Field

divMessageList Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> divMessageList
Declaration Syntax
C#
protected HtmlGenericControl divMessageList

Assembly: MSS.Modules (Module: MSS.Modules)


errorMessage Field

errorMessage Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> errorMessage
Declaration Syntax
C#
protected HtmlGenericControl errorMessage

Assembly: MSS.Modules (Module: MSS.Modules)


frmMessageList Field

frmMessageList Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> frmMessageList
Declaration Syntax
C#
protected Form frmMessageList

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


PagingContainer Property

PagingContainer Property
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> PagingContainer
Declaration Syntax
C#
public Control PagingContainer{ get; set;}

Assembly: MSS.Modules (Module: MSS.Modules)


MiniForum Class

MiniForum Class
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum
Mini forum.
Declaration Syntax
C#
public class MiniForum : ModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MiniForumMiniForumNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | ctlMessageAndReplies |
 | ctlMessageList |
 | ctlNewMessage |
 | ctlReply |
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root path. (Overrides ModuleControl.DictionaryRoot.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblTitle |
 | LicenseKey | Gets a license key. (Overrides ModuleControl.LicenseKey.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MiniForumForm |
 | ModeQueryStringKey |
 | mvSubcontrol |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Init(Object, EventArgs) |
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | plhPagingPanel |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | viewMessageAndReplies |
 | viewMessageList |
 | viewReply |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | MiniForum

Assembly: MSS.Modules (Module: MSS.Modules)


MiniForum Constructor

MiniForum Constructor
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> MiniForumMiniForumNew()()
Declaration Syntax
C#
public MiniForum()

Assembly: MSS.Modules (Module: MSS.Modules)


ctlMessageAndReplies Field

ctlMessageAndReplies Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> ctlMessageAndReplies
Declaration Syntax
C#
protected MessageAndReplies ctlMessageAndReplies

Assembly: MSS.Modules (Module: MSS.Modules)


ctlMessageList Field

ctlMessageList Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> ctlMessageList
Declaration Syntax
C#
protected MessageList ctlMessageList

Assembly: MSS.Modules (Module: MSS.Modules)


ctlNewMessage Field

ctlNewMessage Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> ctlNewMessage
Declaration Syntax
C#
protected Reply ctlNewMessage

Assembly: MSS.Modules (Module: MSS.Modules)


ctlReply Field

ctlReply Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> ctlReply
Declaration Syntax
C#
protected Reply ctlReply

Assembly: MSS.Modules (Module: MSS.Modules)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> DictionaryRoot
Gets a dictionary root path.
Declaration Syntax
C#
protected override string DictionaryRoot{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


lblTitle Field

lblTitle Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> lblTitle
Declaration Syntax
C#
protected Label lblTitle

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> LicenseKey
Gets a license key.
Declaration Syntax
C#
public override string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


MiniForumForm Field

MiniForumForm Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> MiniForumForm
Declaration Syntax
C#
protected Form MiniForumForm

Assembly: MSS.Modules (Module: MSS.Modules)


ModeQueryStringKey Field

ModeQueryStringKey Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> ModeQueryStringKey
Declaration Syntax
C#
public static readonly string ModeQueryStringKey

Assembly: MSS.Modules (Module: MSS.Modules)


mvSubcontrol Field

mvSubcontrol Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> mvSubcontrol
Declaration Syntax
C#
protected MultiView mvSubcontrol

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Init Method (sender, e)

Page_Init Method (sender, e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> Page_Init(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Init(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


plhPagingPanel Field

plhPagingPanel Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> plhPagingPanel
Declaration Syntax
C#
public PlaceHolder plhPagingPanel

Assembly: MSS.Modules (Module: MSS.Modules)


viewMessageAndReplies Field

viewMessageAndReplies Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> viewMessageAndReplies
Declaration Syntax
C#
protected View viewMessageAndReplies

Assembly: MSS.Modules (Module: MSS.Modules)


viewMessageList Field

viewMessageList Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> viewMessageList
Declaration Syntax
C#
protected View viewMessageList

Assembly: MSS.Modules (Module: MSS.Modules)


viewReply Field

viewReply Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> viewReply
Declaration Syntax
C#
protected View viewReply

Assembly: MSS.Modules (Module: MSS.Modules)


Reply Class

Reply Class
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply
Reply on the user message form.
Declaration Syntax
C#
public class Reply : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReplyReplyNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnSubmit |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | chkRememberUser |
 | chkSubsribe |
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | divSubject |
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | frmReply |
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblBody |
 | lblEmail |
 | lblName |
 | lblSubject |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowSubject | Gets or sets a value indicating whether to show the subject.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtBody |
 | txtEmail |
 | txtName |
 | txtSubject |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valBody |
 | valEmailExists |
 | valEmailWellFormed |
 | valName |
 | valSubject |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | Reply

Assembly: MSS.Modules (Module: MSS.Modules)


Reply Constructor

Reply Constructor
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> ReplyReplyNew()()
Declaration Syntax
C#
public Reply()

Assembly: MSS.Modules (Module: MSS.Modules)


btnSubmit Field

btnSubmit Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> btnSubmit
Declaration Syntax
C#
protected Button btnSubmit

Assembly: MSS.Modules (Module: MSS.Modules)


chkRememberUser Field

chkRememberUser Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> chkRememberUser
Declaration Syntax
C#
protected CheckBox chkRememberUser

Assembly: MSS.Modules (Module: MSS.Modules)


chkSubsribe Field

chkSubsribe Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> chkSubsribe
Declaration Syntax
C#
protected CheckBox chkSubsribe

Assembly: MSS.Modules (Module: MSS.Modules)


divSubject Field

divSubject Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> divSubject
Declaration Syntax
C#
protected HtmlGenericControl divSubject

Assembly: MSS.Modules (Module: MSS.Modules)


frmReply Field

frmReply Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> frmReply
Declaration Syntax
C#
protected Form frmReply

Assembly: MSS.Modules (Module: MSS.Modules)


lblBody Field

lblBody Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> lblBody
Declaration Syntax
C#
protected Label lblBody

Assembly: MSS.Modules (Module: MSS.Modules)


lblEmail Field

lblEmail Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> lblEmail
Declaration Syntax
C#
protected Label lblEmail

Assembly: MSS.Modules (Module: MSS.Modules)


lblName Field

lblName Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> lblName
Declaration Syntax
C#
protected Label lblName

Assembly: MSS.Modules (Module: MSS.Modules)


lblSubject Field

lblSubject Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> lblSubject
Declaration Syntax
C#
protected Label lblSubject

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


ShowSubject Property

ShowSubject Property
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> ShowSubject
Gets or sets a value indicating whether to show the subject.
Declaration Syntax
C#
public bool ShowSubject{ get; set;}
Value
True if the subject is to be shown; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


txtBody Field

txtBody Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> txtBody
Declaration Syntax
C#
protected TextBox txtBody

Assembly: MSS.Modules (Module: MSS.Modules)


txtEmail Field

txtEmail Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> txtEmail
Declaration Syntax
C#
protected TextBox txtEmail

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> txtName
Declaration Syntax
C#
protected TextBox txtName

Assembly: MSS.Modules (Module: MSS.Modules)


txtSubject Field

txtSubject Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> txtSubject
Declaration Syntax
C#
protected TextBox txtSubject

Assembly: MSS.Modules (Module: MSS.Modules)


valBody Field

valBody Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> valBody
Declaration Syntax
C#
protected RequiredFieldValidator valBody

Assembly: MSS.Modules (Module: MSS.Modules)


valEmailExists Field

valEmailExists Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> valEmailExists
Declaration Syntax
C#
protected RequiredFieldValidator valEmailExists

Assembly: MSS.Modules (Module: MSS.Modules)


valEmailWellFormed Field

valEmailWellFormed Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> valEmailWellFormed
Declaration Syntax
C#
protected RegularExpressionValidator valEmailWellFormed

Assembly: MSS.Modules (Module: MSS.Modules)


valName Field

valName Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> valName
Declaration Syntax
C#
protected RequiredFieldValidator valName

Assembly: MSS.Modules (Module: MSS.Modules)


valSubject Field

valSubject Field
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> valSubject
Declaration Syntax
C#
protected RequiredFieldValidator valSubject

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.News Namespace

MSS.Modules.News Namespace
Namespaces >> MSS.Modules.News
Declaration Syntax
C#
namespace MSS.Modules.News
Types
All Types Classes
Icon | Type | Description
 | CreationManager | Create news.
 | Definitions | New module's definitions.
 | News | Display news. Allow add new news in WebEdit mode.
 | NewsDocument |
 | NewsItem | News item.


CreationManager Class

CreationManager Class
Namespaces >> MSS.Modules.News >> CreationManager
Create news.
Declaration Syntax
C#
public class CreationManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreationManagerCreationManagerNew()() |
 | CreateGlobalNews(String) | Creates the global news.
 | CreateLocalNews(String) | create a new news article based on the master for the given site type, and adds it to the current item
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CreationManager

Assembly: MSS.Modules (Module: MSS.Modules)


CreationManager Constructor

CreationManager Constructor
Namespaces >> MSS.Modules.News >> CreationManager >> CreationManagerCreationManagerNew()()
Declaration Syntax
C#
public CreationManager()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateGlobalNews Method (name)

CreateGlobalNews Method (name)
Namespaces >> MSS.Modules.News >> CreationManager >> CreateGlobalNews(String)
Creates the global news.
Declaration Syntax
C#
public void CreateGlobalNews(
    string name
)
Parameters
name (String)
The name.

Assembly: MSS.Modules (Module: MSS.Modules)


CreateLocalNews Method (name)

CreateLocalNews Method (name)
Namespaces >> MSS.Modules.News >> CreationManager >> CreateLocalNews(String)
create a new news article based on the master for the given site type, and adds it to the current item
Declaration Syntax
C#
public void CreateLocalNews(
    string name
)
Parameters
name (String)

Assembly: MSS.Modules (Module: MSS.Modules)


Definitions Class

Definitions Class
Namespaces >> MSS.Modules.News >> Definitions
New module's definitions.
Declaration Syntax
C#
public class Definitions
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultNewsTemplate | Gets the default news template.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleMaster | Gets the module master.
 | ModuleName | Gets the name of the module.
 | ModuleRootPath | Gets the module root path.
 | ModuleWeb | Gets the module web item.
 | TemplateKey | Gets the template key.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Definitions

Assembly: MSS.Modules (Module: MSS.Modules)


DefaultNewsTemplate Property

DefaultNewsTemplate Property
Namespaces >> MSS.Modules.News >> Definitions >> DefaultNewsTemplate
Gets the default news template.
Declaration Syntax
C#
public static string DefaultNewsTemplate{ get;}
Value
The default news template.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleMaster Property

ModuleMaster Property
Namespaces >> MSS.Modules.News >> Definitions >> ModuleMaster
Gets the module master.
Declaration Syntax
C#
public static Item ModuleMaster{ get;}
Value
The module master.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleName Property

ModuleName Property
Namespaces >> MSS.Modules.News >> Definitions >> ModuleName
Gets the name of the module.
Declaration Syntax
C#
public static string ModuleName{ get;}
Value
The name of the module.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleRootPath Property

ModuleRootPath Property
Namespaces >> MSS.Modules.News >> Definitions >> ModuleRootPath
Gets the module root path.
Declaration Syntax
C#
public static string ModuleRootPath{ get;}
Value
The module root path.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleWeb Property

ModuleWeb Property
Namespaces >> MSS.Modules.News >> Definitions >> ModuleWeb
Gets the module web item.
Declaration Syntax
C#
public static Item ModuleWeb{ get;}
Value
The module web item.

Assembly: MSS.Modules (Module: MSS.Modules)


TemplateKey Property

TemplateKey Property
Namespaces >> MSS.Modules.News >> Definitions >> TemplateKey
Gets the template key.
Declaration Syntax
C#
public string TemplateKey{ get;}
Value
The template key.

Assembly: MSS.Modules (Module: MSS.Modules)


News Class

News Class
Namespaces >> MSS.Modules.News >> News
Display news. Allow add new news in WebEdit mode.
Declaration Syntax
C#
public class News : ModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewsNewsNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnCreateNewsarticle |
 | btnCreateNewsarticle_Click(Object, EventArgs) |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateNewsArticle |
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item. (Overrides ModuleControl.DictionaryRoot.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsGlobal | Gets or sets a value indicating whether the news is global.
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblName |
 | lblRequiredFields |
 | LicenseKey | Gets a license key for module. (Overrides ModuleControl.LicenseKey.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MSS_Modules_News |
 | MSS_Modules_News_NewsCreate |
 | MSS_Modules_News_NewsDocument |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license message key for news module. (Overrides ModuleControl.NoLicenseDictionaryKey.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Page_PreRender(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtName |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationGroup | Gets or sets a ValidationGroup.
 | validationSummary |
 | valNameIsCorrect |
 | valNameReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | News

Assembly: MSS.Modules (Module: MSS.Modules)


News Constructor

News Constructor
Namespaces >> MSS.Modules.News >> News >> NewsNewsNew()()
Declaration Syntax
C#
public News()

Assembly: MSS.Modules (Module: MSS.Modules)


btnCreateNewsarticle Field

btnCreateNewsarticle Field
Namespaces >> MSS.Modules.News >> News >> btnCreateNewsarticle
Declaration Syntax
C#
protected Button btnCreateNewsarticle

Assembly: MSS.Modules (Module: MSS.Modules)


btnCreateNewsarticle_Click Method (sender, e)

btnCreateNewsarticle_Click Method (sender, e)
Namespaces >> MSS.Modules.News >> News >> btnCreateNewsarticle_Click(Object, EventArgs)
Declaration Syntax
C#
protected void btnCreateNewsarticle_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


CreateNewsArticle Field

CreateNewsArticle Field
Namespaces >> MSS.Modules.News >> News >> CreateNewsArticle
Declaration Syntax
C#
protected Form CreateNewsArticle

Assembly: MSS.Modules (Module: MSS.Modules)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Modules.News >> News >> DictionaryRoot
Gets a dictionary root item.
Declaration Syntax
C#
protected override string DictionaryRoot{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsGlobal Property

IsGlobal Property
Namespaces >> MSS.Modules.News >> News >> IsGlobal
Gets or sets a value indicating whether the news is global.
Declaration Syntax
C#
public bool IsGlobal{ get; set;}
Value
true if the news is global; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


lblName Field

lblName Field
Namespaces >> MSS.Modules.News >> News >> lblName
Declaration Syntax
C#
protected Label lblName

Assembly: MSS.Modules (Module: MSS.Modules)


lblRequiredFields Field

lblRequiredFields Field
Namespaces >> MSS.Modules.News >> News >> lblRequiredFields
Declaration Syntax
C#
protected Label lblRequiredFields

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.News >> News >> LicenseKey
Gets a license key for module.
Declaration Syntax
C#
public override string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


MSS_Modules_News Field

MSS_Modules_News Field
Namespaces >> MSS.Modules.News >> News >> MSS_Modules_News
Declaration Syntax
C#
protected XslFile MSS_Modules_News

Assembly: MSS.Modules (Module: MSS.Modules)


MSS_Modules_News_NewsCreate Field

MSS_Modules_News_NewsCreate Field
Namespaces >> MSS.Modules.News >> News >> MSS_Modules_News_NewsCreate
Declaration Syntax
C#
protected HtmlGenericControl MSS_Modules_News_NewsCreate

Assembly: MSS.Modules (Module: MSS.Modules)


MSS_Modules_News_NewsDocument Field

MSS_Modules_News_NewsDocument Field
Namespaces >> MSS.Modules.News >> News >> MSS_Modules_News_NewsDocument
Declaration Syntax
C#
protected XslFile MSS_Modules_News_NewsDocument

Assembly: MSS.Modules (Module: MSS.Modules)


NoLicenseDictionaryKey Property

NoLicenseDictionaryKey Property
Namespaces >> MSS.Modules.News >> News >> NoLicenseDictionaryKey
Gets a no license message key for news module.
Declaration Syntax
C#
protected override string NoLicenseDictionaryKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.News >> News >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Page_PreRender Method (sender, e)

Page_PreRender Method (sender, e)
Namespaces >> MSS.Modules.News >> News >> Page_PreRender(Object, EventArgs)
Declaration Syntax
C#
protected void Page_PreRender(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.News >> News >> txtName
Declaration Syntax
C#
protected TextBox txtName

Assembly: MSS.Modules (Module: MSS.Modules)


ValidationGroup Property

ValidationGroup Property
Namespaces >> MSS.Modules.News >> News >> ValidationGroup
Gets or sets a ValidationGroup.
Declaration Syntax
C#
public string ValidationGroup{ get; set;}

Assembly: MSS.Modules (Module: MSS.Modules)


validationSummary Field

validationSummary Field
Namespaces >> MSS.Modules.News >> News >> validationSummary
Declaration Syntax
C#
protected ValidationSummary validationSummary

Assembly: MSS.Modules (Module: MSS.Modules)


valNameIsCorrect Field

valNameIsCorrect Field
Namespaces >> MSS.Modules.News >> News >> valNameIsCorrect
Declaration Syntax
C#
protected ItemNameValidator valNameIsCorrect

Assembly: MSS.Modules (Module: MSS.Modules)


valNameReq Field

valNameReq Field
Namespaces >> MSS.Modules.News >> News >> valNameReq
Declaration Syntax
C#
protected RequiredFieldValidator valNameReq

Assembly: MSS.Modules (Module: MSS.Modules)


NewsDocument Class

NewsDocument Class
Namespaces >> MSS.Modules.News >> NewsDocument
Declaration Syntax
C#
public class NewsDocument : ModuleControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewsDocumentNewsDocumentNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item. (Inherited from ModuleControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LicenseKey | (Inherited from ModuleControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | NewsDocument

Assembly: MSS.Modules (Module: MSS.Modules)


NewsDocument Constructor

NewsDocument Constructor
Namespaces >> MSS.Modules.News >> NewsDocument >> NewsDocumentNewsDocumentNew()()
Declaration Syntax
C#
public NewsDocument()

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.News >> NewsDocument >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


NewsItem Class

NewsItem Class
Namespaces >> MSS.Modules.News >> NewsItem
News item.
Declaration Syntax
C#
public class NewsItem : YearMonthItems
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewsItemNewsItemNew(Item) | Initialises a new instance of the NewsItem class. Note: Needs an item to obtain SiteContext if called as an ItemHandler outside a browser.
 | CleanUpParentFolders(Item) | (Inherited from YearMonthItems.)
 | CleanUpYear(Item) | (Inherited from YearMonthItems.)
 | Create(String, String) | Creates the item. (Inherited from YearMonthItems.)
 | Create(String) | Creates the item. (Inherited from YearMonthItems.)
 | Create(DateTime) | Creates the item. (Inherited from YearMonthItems.)
 | CreateItem(String, String) | (Inherited from YearMonthItems.)
 | CreateItem(Item, String) | (Inherited from YearMonthItems.)
 | DateTimeField | Gets the date time field. (Overrides YearMonthItems.DateTimeField.)
 | Delete(Item, Item) | Deletes the item. (Inherited from YearMonthItems.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFolder(DateTime) | Get month folder for the given date. If no month folder exists, it is created. If no year folder exists, it is created. (Inherited from YearMonthItems.)
 | GetFolder(DateTime, Boolean) | Gets the folder for the date. (Inherited from YearMonthItems.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItems(DateTime) | Returns an array-list of items. (Inherited from YearMonthItems.)
 | GetMonthFolder(DateTime) | Gets the month folder. (Inherited from YearMonthItems.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalPath | Gets the path to the global item. (Overrides YearMonthItems.GlobalPath.)
 | Item | (Inherited from YearMonthItems.)
 | MasterName | Gets the name of the master. (Overrides YearMonthItems.MasterName.)
 | MasterRoot | Gets the master root. (Inherited from YearMonthItems.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleName | Gets the name of the module. (Overrides YearMonthItems.ModuleName.)
 | MonthMasterName | Gets the name of the month master. (Overrides YearMonthItems.MonthMasterName.)
 | Move(Item) | Moves the item. (Inherited from YearMonthItems.)
 | Move(Item, DateTime) | Moves the item. (Inherited from YearMonthItems.)
 | RootPath | Gets the root path. (Inherited from YearMonthItems.)
 | Site | (Inherited from YearMonthItems.)
 | TemplateKey | Gets the template key. (Overrides YearMonthItems.TemplateKey.)
 | TitleField | Gets title field. (Overrides YearMonthItems.TitleField.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WebRoot | Gets the root item. (Inherited from YearMonthItems.)
 | YearMasterName | Gets the name of the year master. (Overrides YearMonthItems.YearMasterName.)
Inheritance Hierarchy
Object
 | YearMonthItems
 |  | NewsItem

Assembly: MSS.Modules (Module: MSS.Modules)


NewsItem Constructor (item)

NewsItem Constructor (item)
Namespaces >> MSS.Modules.News >> NewsItem >> NewsItemNewsItemNew(Item)
Initialises a new instance of the NewsItem class. Note: Needs an item to obtain SiteContext if called as an ItemHandler outside a browser.
Declaration Syntax
C#
public NewsItem(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.Modules (Module: MSS.Modules)


DateTimeField Property

DateTimeField Property
Namespaces >> MSS.Modules.News >> NewsItem >> DateTimeField
Gets the date time field.
Declaration Syntax
C#
public override string DateTimeField{ get;}
Value
The date time field.

Assembly: MSS.Modules (Module: MSS.Modules)


GlobalPath Property

GlobalPath Property
Namespaces >> MSS.Modules.News >> NewsItem >> GlobalPath
Gets the path to the global item.
Declaration Syntax
C#
public override string GlobalPath{ get;}
Value
The global path.

Assembly: MSS.Modules (Module: MSS.Modules)


MasterName Property

MasterName Property
Namespaces >> MSS.Modules.News >> NewsItem >> MasterName
Gets the name of the master.
Declaration Syntax
C#
public override string MasterName{ get;}
Value
The name of the master.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleName Property

ModuleName Property
Namespaces >> MSS.Modules.News >> NewsItem >> ModuleName
Gets the name of the module.
Declaration Syntax
C#
public override string ModuleName{ get;}
Value
The name of the module.

Assembly: MSS.Modules (Module: MSS.Modules)


MonthMasterName Property

MonthMasterName Property
Namespaces >> MSS.Modules.News >> NewsItem >> MonthMasterName
Gets the name of the month master.
Declaration Syntax
C#
public override string MonthMasterName{ get;}
Value
The name of the month master.

Assembly: MSS.Modules (Module: MSS.Modules)


TemplateKey Property

TemplateKey Property
Namespaces >> MSS.Modules.News >> NewsItem >> TemplateKey
Gets the template key.
Declaration Syntax
C#
public override string TemplateKey{ get;}
Value
The template key.

Assembly: MSS.Modules (Module: MSS.Modules)


TitleField Property

TitleField Property
Namespaces >> MSS.Modules.News >> NewsItem >> TitleField
Gets title field.
Declaration Syntax
C#
public override string TitleField{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


YearMasterName Property

YearMasterName Property
Namespaces >> MSS.Modules.News >> NewsItem >> YearMasterName
Gets the name of the year master.
Declaration Syntax
C#
public override string YearMasterName{ get;}
Value
The name of the year master.

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.News.ItemHandlers Namespace

MSS.Modules.News.ItemHandlers Namespace
Namespaces >> MSS.Modules.News.ItemHandlers
Declaration Syntax
C#
namespace MSS.Modules.News.ItemHandlers
Types
All Types Classes
Icon | Type | Description
 | ItemHandler | Handler that moves a news item in the case of changing the date field.


ItemHandler Class

ItemHandler Class
Namespaces >> MSS.Modules.News.ItemHandlers >> ItemHandler
Handler that moves a news item in the case of changing the date field.
Declaration Syntax
C#
public class ItemHandler : YearMonthItemHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemHandlerItemHandlerNew()() |
 | CreateModule(Item) | (Overrides YearMonthItemHandler.CreateModule(Item).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Handles the item:deleted event. (Inherited from YearMonthItemHandler.)
 | OnItemSaved(Object, EventArgs) | Handles the item:saved event. (Inherited from YearMonthItemHandler.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | YearMonthItemHandler
 |  | ItemHandler

Assembly: MSS.Modules (Module: MSS.Modules)


ItemHandler Constructor

ItemHandler Constructor
Namespaces >> MSS.Modules.News.ItemHandlers >> ItemHandler >> ItemHandlerItemHandlerNew()()
Declaration Syntax
C#
public ItemHandler()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateModule Method (item)

CreateModule Method (item)
Namespaces >> MSS.Modules.News.ItemHandlers >> ItemHandler >> CreateModule(Item)
Declaration Syntax
C#
protected override YearMonthItems CreateModule(
    Item item
)
Parameters
item (Item)

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.News.UserControls Namespace

MSS.Modules.News.UserControls Namespace
Namespaces >> MSS.Modules.News.UserControls
Declaration Syntax
C#
namespace MSS.Modules.News.UserControls
Types
All Types Classes
Icon | Type | Description
 | NewsGlobal | Displays the global news on the page.


NewsGlobal Class

NewsGlobal Class
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal
Displays the global news on the page.
Declaration Syntax
C#
public class NewsGlobal : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewsGlobalNewsGlobalNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | news |
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | NewsGlobal

Assembly: MSS.Modules (Module: MSS.Modules)


NewsGlobal Constructor

NewsGlobal Constructor
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> NewsGlobalNewsGlobalNew()()
Declaration Syntax
C#
public NewsGlobal()

Assembly: MSS.Modules (Module: MSS.Modules)


news Field

news Field
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> news
Declaration Syntax
C#
protected News news

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.NewsLetter Namespace

MSS.Modules.NewsLetter Namespace
Namespaces >> MSS.Modules.NewsLetter
Declaration Syntax
C#
namespace MSS.Modules.NewsLetter
Types
All Types Classes
Icon | Type | Description
 | Definitions | News letter module's definition.


Definitions Class

Definitions Class
Namespaces >> MSS.Modules.NewsLetter >> Definitions
News letter module's definition.
Declaration Syntax
C#
public class Definitions : SubscriptionDefinitions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefinitionsDefinitionsNew()() |
 | ConnectionString | Gets the connection string. (Overrides SubscriptionDefinitions.ConnectionString.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupDescriptionField | Gets the group description field. (Overrides SubscriptionDefinitions.GroupDescriptionField.)
 | GroupMaster | Gets the group master. (Overrides SubscriptionDefinitions.GroupMaster.)
 | GroupsMaster | Gets the groups master. (Overrides SubscriptionDefinitions.GroupsMaster.)
 | GroupsPath | Gets the groups path. (Overrides SubscriptionDefinitions.GroupsPath.)
 | GroupsWeb | Gets the groups item. (Overrides SubscriptionDefinitions.GroupsWeb.)
 | GroupTemplate | Gets the group template. (Overrides SubscriptionDefinitions.GroupTemplate.)
 | GroupTitleField | Gets the group title field. (Overrides SubscriptionDefinitions.GroupTitleField.)
 | Instance |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleMaster | Gets the module master. (Overrides SubscriptionDefinitions.ModuleMaster.)
 | ModuleRootPath | Gets the module root path. (Overrides SubscriptionDefinitions.ModuleRootPath.)
 | ModuleWeb | Gets the module item. (Overrides SubscriptionDefinitions.ModuleWeb.)
 | SubscribersTableName | Gets the name of the subscribers table. (Overrides SubscriptionDefinitions.SubscribersTableName.)
 | SubscriptionsTableName | Gets the name of the subscriptions table. (Overrides SubscriptionDefinitions.SubscriptionsTableName.)
 | SubsInfoFieldName | Gets the name of the subscribers info field. (Overrides SubscriptionDefinitions.SubsInfoFieldName.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnsubscribePath | Gets the unsubscribe path.
 | UnsubscribeWeb | Gets the unsubscribe item.
Inheritance Hierarchy
Object
 | SubscriptionDefinitions
 |  | Definitions

Assembly: MSS.Modules (Module: MSS.Modules)


Definitions Constructor

Definitions Constructor
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> DefinitionsDefinitionsNew()()
Declaration Syntax
C#
public Definitions()

Assembly: MSS.Modules (Module: MSS.Modules)


ConnectionString Property

ConnectionString Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> ConnectionString
Gets the connection string.
Declaration Syntax
C#
public override string ConnectionString{ get;}
Value
The connection string.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupDescriptionField Property

GroupDescriptionField Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> GroupDescriptionField
Gets the group description field.
Declaration Syntax
C#
public override string GroupDescriptionField{ get;}
Value
The group description field.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupMaster Property

GroupMaster Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> GroupMaster
Gets the group master.
Declaration Syntax
C#
public override string GroupMaster{ get;}
Value
The group master.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsMaster Property

GroupsMaster Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> GroupsMaster
Gets the groups master.
Declaration Syntax
C#
public override Item GroupsMaster{ get;}
Value
The groups master.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsPath Property

GroupsPath Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> GroupsPath
Gets the groups path.
Declaration Syntax
C#
public override string GroupsPath{ get;}
Value
The groups path.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsWeb Property

GroupsWeb Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> GroupsWeb
Gets the groups item.
Declaration Syntax
C#
public override Item GroupsWeb{ get;}
Value
The groups web.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupTemplate Property

GroupTemplate Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> GroupTemplate
Gets the group template.
Declaration Syntax
C#
public override string GroupTemplate{ get;}
Value
The group template.

Assembly: MSS.Modules (Module: MSS.Modules)


GroupTitleField Property

GroupTitleField Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> GroupTitleField
Gets the group title field.
Declaration Syntax
C#
public override string GroupTitleField{ get;}
Value
The group title field.

Assembly: MSS.Modules (Module: MSS.Modules)


Instance Property

Instance Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> Instance
Declaration Syntax
C#
public static Definitions Instance{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleMaster Property

ModuleMaster Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> ModuleMaster
Gets the module master.
Declaration Syntax
C#
public override Item ModuleMaster{ get;}
Value
The module master.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleRootPath Property

ModuleRootPath Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> ModuleRootPath
Gets the module root path.
Declaration Syntax
C#
public override string ModuleRootPath{ get;}
Value
The module root path.

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleWeb Property

ModuleWeb Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> ModuleWeb
Gets the module item.
Declaration Syntax
C#
public override Item ModuleWeb{ get;}
Value
The module web.

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersTableName Property

SubscribersTableName Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> SubscribersTableName
Gets the name of the subscribers table.
Declaration Syntax
C#
public override string SubscribersTableName{ get;}
Value
The name of the subscribers table.

Assembly: MSS.Modules (Module: MSS.Modules)


SubscriptionsTableName Property

SubscriptionsTableName Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> SubscriptionsTableName
Gets the name of the subscriptions table.
Declaration Syntax
C#
public override string SubscriptionsTableName{ get;}
Value
The name of the subscriptions table.

Assembly: MSS.Modules (Module: MSS.Modules)


SubsInfoFieldName Property

SubsInfoFieldName Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> SubsInfoFieldName
Gets the name of the subscribers info field.
Declaration Syntax
C#
public override string SubsInfoFieldName{ get;}
Value
The name of the subscribers info field.

Assembly: MSS.Modules (Module: MSS.Modules)


UnsubscribePath Property

UnsubscribePath Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> UnsubscribePath
Gets the unsubscribe path.
Declaration Syntax
C#
public static string UnsubscribePath{ get;}
Value
The unsubscribe path.

Assembly: MSS.Modules (Module: MSS.Modules)


UnsubscribeWeb Property

UnsubscribeWeb Property
Namespaces >> MSS.Modules.NewsLetter >> Definitions >> UnsubscribeWeb
Gets the unsubscribe item.
Declaration Syntax
C#
public static Item UnsubscribeWeb{ get;}
Value
The unsubscribe web.

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.NewsLetter.CodeBeside Namespace

MSS.Modules.NewsLetter.CodeBeside Namespace
Namespaces >> MSS.Modules.NewsLetter.CodeBeside
Declaration Syntax
C#
namespace MSS.Modules.NewsLetter.CodeBeside
Types
All Types Classes Delegates
Icon | Type | Description
 | NewsletterControl..::ChangePageDelegate |
 | EditGroup | Allows to user edit subscriber groups.
 | EditSubscriber | Edit subscriber page.
 | MailingList | Control that contains a list of mailing lists.
 | NewsLetter | News letter administration page.
 | NewsletterControl | Represents a page in newsletter administration.
 | SelectItem | Dialog on which a user selects an item to be attached to a letter.
 | SendMessage | Sends a message to the subscribers.
 | SubscribersList | Subscribers management panel.


NewsletterControl.ChangePageDelegate Delegate

NewsletterControl..::ChangePageDelegate Delegate
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> NewsletterControl..::ChangePageDelegate
Declaration Syntax
C#
public delegate void ChangePageDelegate(
    string page,
    Object[] parameters
)
Parameters
page (String)
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


EditGroup Class

EditGroup Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup
Allows to user edit subscriber groups.
Declaration Syntax
C#
public class EditGroup : NewsletterControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditGroupEditGroupNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | brdGroups |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from NewsletterControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from NewsletterControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetSelectedGroups()() |
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from NewsletterControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from NewsletterControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides NewsletterControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides NewsletterControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides NewsletterControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides NewsletterControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides NewsletterControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides NewsletterControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides NewsletterControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides NewsletterControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey | (Inherited from NewsletterControl.)
 | litDescription |
 | litName |
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClose(Message) |
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from NewsletterControl.)
 | OnLoad(EventArgs) | (Inherited from NewsletterControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSave(Message) |
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | rbnAccessToAll |
 | rbnRestrictedAccess |
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from NewsletterControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from NewsletterControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetFreeAccess(Message) |
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetRestrictAccess(Message) |
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | The submit message. (Inherited from NewsletterControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | tblAccess |
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from NewsletterControl.)
 | TitleKey | (Overrides NewsletterControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | txtDescription |
 | txtName |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | NewsletterControl
 |  |  |  |  |  | EditGroup

Assembly: MSS.Modules (Module: MSS.Modules)


EditGroup Constructor

EditGroup Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> EditGroupEditGroupNew()()
Declaration Syntax
C#
public EditGroup()

Assembly: MSS.Modules (Module: MSS.Modules)


brdGroups Field

brdGroups Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> brdGroups
Declaration Syntax
C#
protected Border brdGroups

Assembly: MSS.Modules (Module: MSS.Modules)


GetSelectedGroups Method

GetSelectedGroups Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> GetSelectedGroups()()
Declaration Syntax
C#
protected string[] GetSelectedGroups()

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


litDescription Field

litDescription Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> litDescription
Declaration Syntax
C#
protected Literal litDescription

Assembly: MSS.Modules (Module: MSS.Modules)


litName Field

litName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> litName
Declaration Syntax
C#
protected Literal litName

Assembly: MSS.Modules (Module: MSS.Modules)


OnClose Method (msg)

OnClose Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> OnClose(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:CloseEdit")]
public void OnClose(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSave Method (msg)

OnSave Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> OnSave(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Save")]
public void OnSave(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


rbnAccessToAll Field

rbnAccessToAll Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> rbnAccessToAll
Declaration Syntax
C#
protected Radiobutton rbnAccessToAll

Assembly: MSS.Modules (Module: MSS.Modules)


rbnRestrictedAccess Field

rbnRestrictedAccess Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> rbnRestrictedAccess
Declaration Syntax
C#
protected Radiobutton rbnRestrictedAccess

Assembly: MSS.Modules (Module: MSS.Modules)


SetFreeAccess Method (msg)

SetFreeAccess Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> SetFreeAccess(Message)
Declaration Syntax
C#
[HandleMessageAttribute("EditGroup:SetFreeAccess")]
public void SetFreeAccess(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


SetRestrictAccess Method (msg)

SetRestrictAccess Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> SetRestrictAccess(Message)
Declaration Syntax
C#
[HandleMessageAttribute("EditGroup:SetRestrictedAccess")]
public void SetRestrictAccess(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


tblAccess Field

tblAccess Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> tblAccess
Declaration Syntax
C#
protected GridPanel tblAccess

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


txtDescription Field

txtDescription Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> txtDescription
Declaration Syntax
C#
protected Memo txtDescription

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> txtName
Declaration Syntax
C#
protected Edit txtName

Assembly: MSS.Modules (Module: MSS.Modules)


EditSubscriber Class

EditSubscriber Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber
Edit subscriber page.
Declaration Syntax
C#
public class EditSubscriber : NewsletterControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditSubscriberEditSubscriberNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | brdSubscriptions |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from NewsletterControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from NewsletterControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from NewsletterControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from NewsletterControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | Initializes the control. (Overrides NewsletterControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides NewsletterControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides NewsletterControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides NewsletterControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides NewsletterControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides NewsletterControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides NewsletterControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides NewsletterControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey | (Inherited from NewsletterControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClose(Message) | Handles the "Tasks:CloseEdit" event.
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from NewsletterControl.)
 | OnLoad(EventArgs) | (Inherited from NewsletterControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSave(Message) | Handles the "Tasks:Save" event.
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from NewsletterControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from NewsletterControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | The submit message. (Inherited from NewsletterControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from NewsletterControl.)
 | TitleKey | (Overrides NewsletterControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | txtEmail |
 | txtName |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | NewsletterControl
 |  |  |  |  |  | EditSubscriber

Assembly: MSS.Modules (Module: MSS.Modules)


EditSubscriber Constructor

EditSubscriber Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> EditSubscriberEditSubscriberNew()()
Declaration Syntax
C#
public EditSubscriber()

Assembly: MSS.Modules (Module: MSS.Modules)


brdSubscriptions Field

brdSubscriptions Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> brdSubscriptions
Declaration Syntax
C#
protected Border brdSubscriptions

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> Initialize(array<Object>[]())
Initializes the control.
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())
The parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


OnClose Method (msg)

OnClose Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> OnClose(Message)
Handles the "Tasks:CloseEdit" event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:CloseEdit")]
public void OnClose(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Modules (Module: MSS.Modules)


OnSave Method (msg)

OnSave Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> OnSave(Message)
Handles the "Tasks:Save" event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Save")]
public void OnSave(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


txtEmail Field

txtEmail Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> txtEmail
Declaration Syntax
C#
protected Edit txtEmail

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> txtName
Declaration Syntax
C#
protected Edit txtName

Assembly: MSS.Modules (Module: MSS.Modules)


MailingList Class

MailingList Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList
Control that contains a list of mailing lists.
Declaration Syntax
C#
public class MailingList : NewsletterControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MailingListMailingListNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from NewsletterControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateNewTask(Message) | Handles the "Tasks:Create" event
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DeleteTask(Message) | Deletes the group.
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from NewsletterControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EditCurrentTask(Message) | Handles the "Tasks:Edit" event
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from NewsletterControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from NewsletterControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides NewsletterControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides NewsletterControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides NewsletterControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides NewsletterControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides NewsletterControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides NewsletterControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides NewsletterControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides NewsletterControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | lbxMailingLists |
 | LicenseKey | (Inherited from NewsletterControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from NewsletterControl.)
 | OnLoad(EventArgs) | (Inherited from NewsletterControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from NewsletterControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from NewsletterControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | The submit message. (Inherited from NewsletterControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from NewsletterControl.)
 | TitleKey | (Overrides NewsletterControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | NewsletterControl
 |  |  |  |  |  | MailingList

Assembly: MSS.Modules (Module: MSS.Modules)


MailingList Constructor

MailingList Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> MailingListMailingListNew()()
Declaration Syntax
C#
public MailingList()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateNewTask Method (msg)

CreateNewTask Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> CreateNewTask(Message)
Handles the "Tasks:Create" event
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Create")]
public void CreateNewTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


DeleteTask Method (msg)

DeleteTask Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> DeleteTask(Message)
Deletes the group.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Delete")]
public void DeleteTask(
    Message msg
)
Parameters
msg (Message)
The message.

Assembly: MSS.Modules (Module: MSS.Modules)


EditCurrentTask Method (msg)

EditCurrentTask Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> EditCurrentTask(Message)
Handles the "Tasks:Edit" event
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Edit")]
public void EditCurrentTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


lbxMailingLists Field

lbxMailingLists Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> lbxMailingLists
Declaration Syntax
C#
protected Listbox lbxMailingLists

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


NewsLetter Class

NewsLetter Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter
News letter administration page.
Declaration Syntax
C#
public class NewsLetter : BaseForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewsLetterNewsLetterNew()() |
 | BindChangePageCallback(NewsletterControl) |
 | brdCenter |
 | btnList |
 | btnMessage |
 | btnSubscribers |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | grdMain |
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | litFormTitle |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnClose(Message) |
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides BaseForm.OnPreRender(EventArgs).)
 | OnSendMessage(Message) |
 | OnShowMailingLists(Message) |
 | OnShowSubscribers(Message) |
 | RefreshContols()() |
 | ServerProperties()() | (Inherited from BaseForm.)
 | SetControl(String, array<Object>[]()) |
 | tkbCreateEditDelete |
 | tkbMain |
 | tkbMessage |
 | tkbSaveClose |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | NewsLetter

Assembly: MSS.Modules (Module: MSS.Modules)


NewsLetter Constructor

NewsLetter Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> NewsLetterNewsLetterNew()()
Declaration Syntax
C#
public NewsLetter()

Assembly: MSS.Modules (Module: MSS.Modules)


BindChangePageCallback Method (newsletterControl)

BindChangePageCallback Method (newsletterControl)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> BindChangePageCallback(NewsletterControl)
Declaration Syntax
C#
protected void BindChangePageCallback(
    NewsletterControl newsletterControl
)
Parameters
newsletterControl (NewsletterControl)

Assembly: MSS.Modules (Module: MSS.Modules)


brdCenter Field

brdCenter Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> brdCenter
Declaration Syntax
C#
protected Border brdCenter

Assembly: MSS.Modules (Module: MSS.Modules)


btnList Field

btnList Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> btnList
Declaration Syntax
C#
protected TaskboxItem btnList

Assembly: MSS.Modules (Module: MSS.Modules)


btnMessage Field

btnMessage Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> btnMessage
Declaration Syntax
C#
protected TaskboxItem btnMessage

Assembly: MSS.Modules (Module: MSS.Modules)


btnSubscribers Field

btnSubscribers Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> btnSubscribers
Declaration Syntax
C#
protected TaskboxItem btnSubscribers

Assembly: MSS.Modules (Module: MSS.Modules)


grdMain Field

grdMain Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> grdMain
Declaration Syntax
C#
protected GridPanel grdMain

Assembly: MSS.Modules (Module: MSS.Modules)


litFormTitle Field

litFormTitle Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> litFormTitle
Declaration Syntax
C#
protected Literal litFormTitle

Assembly: MSS.Modules (Module: MSS.Modules)


OnClose Method (msg)

OnClose Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> OnClose(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:Close")]
public void OnClose(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSendMessage Method (msg)

OnSendMessage Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> OnSendMessage(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:Message")]
public void OnSendMessage(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnShowMailingLists Method (msg)

OnShowMailingLists Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> OnShowMailingLists(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:List")]
public void OnShowMailingLists(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnShowSubscribers Method (msg)

OnShowSubscribers Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> OnShowSubscribers(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:Subscribers")]
public void OnShowSubscribers(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


RefreshContols Method

RefreshContols Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> RefreshContols()()
Declaration Syntax
C#
protected void RefreshContols()

Assembly: MSS.Modules (Module: MSS.Modules)


SetControl Method (controlName, parameters)

SetControl Method (controlName, parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> SetControl(String, array<Object>[]())
Declaration Syntax
C#
protected void SetControl(
    string controlName,
    Object[] parameters
)
Parameters
controlName (String)
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


tkbCreateEditDelete Field

tkbCreateEditDelete Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> tkbCreateEditDelete
Declaration Syntax
C#
protected TaskBoxEx tkbCreateEditDelete

Assembly: MSS.Modules (Module: MSS.Modules)


tkbMain Field

tkbMain Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> tkbMain
Declaration Syntax
C#
protected TaskBoxEx tkbMain

Assembly: MSS.Modules (Module: MSS.Modules)


tkbMessage Field

tkbMessage Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> tkbMessage
Declaration Syntax
C#
protected TaskBoxEx tkbMessage

Assembly: MSS.Modules (Module: MSS.Modules)


tkbSaveClose Field

tkbSaveClose Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsLetter >> tkbSaveClose
Declaration Syntax
C#
protected TaskBoxEx tkbSaveClose

Assembly: MSS.Modules (Module: MSS.Modules)


NewsletterControl Class

NewsletterControl Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl
Represents a page in newsletter administration.
Declaration Syntax
C#
public abstract class NewsletterControl : XmlControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NewsletterControlNewsletterControlNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page.
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EditGroupControlName |
 | EditSubscriberControlName |
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Overrides XmlControl.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() |
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | Initializes the control.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | Gets a value indicating whether the create/edit/delete toolbar is visible.
 | IsVisibleMainToolbar | Gets a value indicating whether the main toolbar is visible.
 | IsVisibleMessageButton | Gets a value indicating whether the message button is visible.
 | IsVisibleMessageToolbar | Gets a value indicating whether the message toolbar is visible.
 | IsVisibleSaveCloseToolbar | Gets a value indicating whether the save/close toolbar is visible.
 | IsVisibleSubscribersButton | Gets a value indicating whether the subscribers button is visible.
 | IsVisibleSubscribitionsButton | Gets a value indicating whether the subscribtions button is visible.
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey |
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MailingListControlName |
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MessageControlName |
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() |
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties |
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message.
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | The submit message.
 | SubscribersControlName |
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title.
 | TitleKey | Gets the title key.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | NewsletterControl
 |  |  |  |  |  | EditSubscriber
 |  |  |  |  |  | SubscribersList
 |  |  |  |  |  | SendMessage
 |  |  |  |  |  | MailingList
 |  |  |  |  |  | EditGroup

Assembly: MSS.Modules (Module: MSS.Modules)


NewsletterControl Constructor

NewsletterControl Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> NewsletterControlNewsletterControlNew()()
Declaration Syntax
C#
protected NewsletterControl()

Assembly: MSS.Modules (Module: MSS.Modules)


ChangePage Event

ChangePage Event
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> ChangePage
Declaration Syntax
C#
public event NewsletterControl.NewsletterControl..::ChangePageDelegate ChangePage

Assembly: MSS.Modules (Module: MSS.Modules)


DoChangePage Method (page, parameters)

DoChangePage Method (page, parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> DoChangePage(String, array<Object>[]())
Changes a page.
Declaration Syntax
C#
protected void DoChangePage(
    string page,
    Object[] parameters
)
Parameters
page (String)
The page.
parameters (array< Object >[]())
The parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


EditGroupControlName Field

EditGroupControlName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> EditGroupControlName
Declaration Syntax
C#
public static readonly string EditGroupControlName

Assembly: MSS.Modules (Module: MSS.Modules)


EditSubscriberControlName Field

EditSubscriberControlName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> EditSubscriberControlName
Declaration Syntax
C#
public static readonly string EditSubscriberControlName

Assembly: MSS.Modules (Module: MSS.Modules)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> HandleMessage(Message)
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> HasLicense()()
Declaration Syntax
C#
public bool HasLicense()

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> Initialize(array<Object>[]())
Initializes the control.
Declaration Syntax
C#
public abstract void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())
The parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> IsVisibleCreareEditDeleteToolbar
Gets a value indicating whether the create/edit/delete toolbar is visible.
Declaration Syntax
C#
public abstract bool IsVisibleCreareEditDeleteToolbar{ get;}
Value
True if the creare/edit/delete toolbar is visible; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> IsVisibleMainToolbar
Gets a value indicating whether the main toolbar is visible.
Declaration Syntax
C#
public abstract bool IsVisibleMainToolbar{ get;}
Value
True if the main toolbar is vislible; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> IsVisibleMessageButton
Gets a value indicating whether the message button is visible.
Declaration Syntax
C#
public abstract bool IsVisibleMessageButton{ get;}
Value
True if the message button is visible; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> IsVisibleMessageToolbar
Gets a value indicating whether the message toolbar is visible.
Declaration Syntax
C#
public abstract bool IsVisibleMessageToolbar{ get;}
Value
True if the message toolbar is visible; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> IsVisibleSaveCloseToolbar
Gets a value indicating whether the save/close toolbar is visible.
Declaration Syntax
C#
public abstract bool IsVisibleSaveCloseToolbar{ get;}
Value
True if the save/close toolbar is visible; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> IsVisibleSubscribersButton
Gets a value indicating whether the subscribers button is visible.
Declaration Syntax
C#
public abstract bool IsVisibleSubscribersButton{ get;}
Value
True if the subscribers button is visible; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> IsVisibleSubscribitionsButton
Gets a value indicating whether the subscribtions button is visible.
Declaration Syntax
C#
public abstract bool IsVisibleSubscribitionsButton{ get;}
Value
True if the subscribtions button is visible; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> LicenseKey
Declaration Syntax
C#
public string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


MailingListControlName Field

MailingListControlName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> MailingListControlName
Declaration Syntax
C#
public static readonly string MailingListControlName

Assembly: MSS.Modules (Module: MSS.Modules)


MessageControlName Field

MessageControlName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> MessageControlName
Declaration Syntax
C#
public static readonly string MessageControlName

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


RegisterOnSubmitStatement Method

RegisterOnSubmitStatement Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> RegisterOnSubmitStatement()()
Declaration Syntax
C#
protected virtual void RegisterOnSubmitStatement()

Assembly: MSS.Modules (Module: MSS.Modules)


ServerProperties Property

ServerProperties Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> ServerProperties
Declaration Syntax
C#
protected StateBag ServerProperties{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlert Method (text)

ShowAlert Method (text)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> ShowAlert(String)
Shows the alert message.
Declaration Syntax
C#
protected void ShowAlert(
    string text
)
Parameters
text (String)
The text.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method (entryName)

ShowAlertFromDictionary Method (entryName)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> ShowAlertFromDictionary(String)
Shows the alert. The text is taken from the dictionary.
Declaration Syntax
C#
protected void ShowAlertFromDictionary(
    string entryName
)
Parameters
entryName (String)

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method (entryName, args)

ShowAlertFromDictionary Method (entryName, args)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> ShowAlertFromDictionary(String, array<Object>[]())
Shows the alert. The text is taken from the dictionary.
Declaration Syntax
C#
protected void ShowAlertFromDictionary(
    string entryName,
    params Object[] args
)
Parameters
entryName (String)
Name of the entry.
args (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


SubmitMessage Property

SubmitMessage Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> SubmitMessage
The submit message.
Declaration Syntax
C#
public virtual string SubmitMessage{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersControlName Field

SubscribersControlName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> SubscribersControlName
Declaration Syntax
C#
public static readonly string SubscribersControlName

Assembly: MSS.Modules (Module: MSS.Modules)


Title Property

Title Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> Title
Gets the title.
Declaration Syntax
C#
public string Title{ get;}
Value
The title.

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> TitleKey
Gets the title key.
Declaration Syntax
C#
protected abstract string TitleKey{ get;}
Value
The title key.

Assembly: MSS.Modules (Module: MSS.Modules)


SelectItem Class

SelectItem Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SelectItem
Dialog on which a user selects an item to be attached to a letter.
Declaration Syntax
C#
public class SelectItem : DialogForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectItemSelectItemNew()() |
 | Cancel()() | (Inherited from DialogForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | InternalLinkDataContext |
 | InternalLinkTreeview |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OK()() | (Inherited from DialogForm.)
 | OnCancel(Object, EventArgs) | (Inherited from DialogForm.)
 | OnLoad(EventArgs) | (Overrides DialogForm.OnLoad(EventArgs).)
 | OnOK(Object, EventArgs) | (Overrides DialogForm.OnOK(Object, EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | ServerProperties()() | (Inherited from BaseForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | DialogForm
 |  |  | SelectItem

Assembly: MSS.Modules (Module: MSS.Modules)


SelectItem Constructor

SelectItem Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SelectItem >> SelectItemSelectItemNew()()
Declaration Syntax
C#
public SelectItem()

Assembly: MSS.Modules (Module: MSS.Modules)


InternalLinkDataContext Field

InternalLinkDataContext Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SelectItem >> InternalLinkDataContext
Declaration Syntax
C#
protected DataContext InternalLinkDataContext

Assembly: MSS.Modules (Module: MSS.Modules)


InternalLinkTreeview Field

InternalLinkTreeview Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SelectItem >> InternalLinkTreeview
Declaration Syntax
C#
protected DataTreeview InternalLinkTreeview

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SelectItem >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnOK Method (sender, args)

OnOK Method (sender, args)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SelectItem >> OnOK(Object, EventArgs)
Declaration Syntax
C#
protected override void OnOK(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


SendMessage Class

SendMessage Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage
Sends a message to the subscribers.
Declaration Syntax
C#
public class SendMessage : NewsletterControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SendMessageSendMessageNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | brdMailingLists |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from NewsletterControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from NewsletterControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from NewsletterControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from NewsletterControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides NewsletterControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides NewsletterControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides NewsletterControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides NewsletterControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides NewsletterControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides NewsletterControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides NewsletterControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides NewsletterControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey | (Inherited from NewsletterControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from NewsletterControl.)
 | OnItemSelect(Message) | Handles the "Item:Select" event
 | OnLoad(EventArgs) | (Overrides NewsletterControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSendMessage(Message) |
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from NewsletterControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from NewsletterControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | ShowSetLinkDialog(ClientPipelineArgs) |
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | The submit message. (Inherited from NewsletterControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from NewsletterControl.)
 | TitleKey | (Overrides NewsletterControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | txtFromEmail |
 | txtItemName |
 | txtMessage |
 | txtSubject |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | NewsletterControl
 |  |  |  |  |  | SendMessage

Assembly: MSS.Modules (Module: MSS.Modules)


SendMessage Constructor

SendMessage Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> SendMessageSendMessageNew()()
Declaration Syntax
C#
public SendMessage()

Assembly: MSS.Modules (Module: MSS.Modules)


brdMailingLists Field

brdMailingLists Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> brdMailingLists
Declaration Syntax
C#
protected Border brdMailingLists

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


OnItemSelect Method (msg)

OnItemSelect Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> OnItemSelect(Message)
Handles the "Item:Select" event
Declaration Syntax
C#
[HandleMessageAttribute("Item:Select")]
public void OnItemSelect(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSendMessage Method (msg)

OnSendMessage Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> OnSendMessage(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:SendMessage")]
public void OnSendMessage(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


ShowSetLinkDialog Method (args)

ShowSetLinkDialog Method (args)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> ShowSetLinkDialog(ClientPipelineArgs)
Declaration Syntax
C#
protected void ShowSetLinkDialog(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


txtFromEmail Field

txtFromEmail Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> txtFromEmail
Declaration Syntax
C#
protected Edit txtFromEmail

Assembly: MSS.Modules (Module: MSS.Modules)


txtItemName Field

txtItemName Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> txtItemName
Declaration Syntax
C#
protected Edit txtItemName

Assembly: MSS.Modules (Module: MSS.Modules)


txtMessage Field

txtMessage Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> txtMessage
Declaration Syntax
C#
protected Memo txtMessage

Assembly: MSS.Modules (Module: MSS.Modules)


txtSubject Field

txtSubject Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> txtSubject
Declaration Syntax
C#
protected Edit txtSubject

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersList Class

SubscribersList Class
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList
Subscribers management panel.
Declaration Syntax
C#
public class SubscribersList : NewsletterControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscribersListSubscribersListNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from NewsletterControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateNewTask(Message) | Handles the "Tasks:Create" event.
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DeleteTask(Message) | Handles the "Tasks:Deleted" event.
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from NewsletterControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EditCurrentTask(Message) | Handles the Tasks:Edit event.
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from NewsletterControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from NewsletterControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides NewsletterControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides NewsletterControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides NewsletterControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides NewsletterControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides NewsletterControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides NewsletterControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides NewsletterControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides NewsletterControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | lbxSubsLists |
 | LicenseKey | (Inherited from NewsletterControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from NewsletterControl.)
 | OnLoad(EventArgs) | (Inherited from NewsletterControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from NewsletterControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from NewsletterControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary. (Inherited from NewsletterControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | The submit message. (Inherited from NewsletterControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from NewsletterControl.)
 | TitleKey | (Overrides NewsletterControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | NewsletterControl
 |  |  |  |  |  | SubscribersList

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersList Constructor

SubscribersList Constructor
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> SubscribersListSubscribersListNew()()
Declaration Syntax
C#
public SubscribersList()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateNewTask Method (msg)

CreateNewTask Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> CreateNewTask(Message)
Handles the "Tasks:Create" event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Create")]
public void CreateNewTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


DeleteTask Method (msg)

DeleteTask Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> DeleteTask(Message)
Handles the "Tasks:Deleted" event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Delete")]
public void DeleteTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


EditCurrentTask Method (msg)

EditCurrentTask Method (msg)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> EditCurrentTask(Message)
Handles the Tasks:Edit event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Edit")]
public void EditCurrentTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


lbxSubsLists Field

lbxSubsLists Field
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> lbxSubsLists
Declaration Syntax
C#
protected Listbox lbxSubsLists

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.NewsLetter.Layouts Namespace

MSS.Modules.NewsLetter.Layouts Namespace
Namespaces >> MSS.Modules.NewsLetter.Layouts
Declaration Syntax
C#
namespace MSS.Modules.NewsLetter.Layouts
Types
All Types Classes
Icon | Type | Description
 | Subscribe | Subscribe application.


Subscribe Class

Subscribe Class
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe
Subscribe application.
Declaration Syntax
C#
public class Subscribe : ModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscribeSubscribeNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnShowSubscriptions |
 | btnSubscribe |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root path. (Overrides ModuleControl.DictionaryRoot.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | divCheckBoxes |
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblEmail |
 | lblLists |
 | lblName |
 | lblRequiredFields |
 | LicenseKey | Gets a license key. (Overrides ModuleControl.LicenseKey.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | Mailinglistsubscribeform |
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Msg |
 | MssFields |
 | MssNavigation |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides ModuleControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtEmail |
 | txtName |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valEmailreg |
 | valEmailReq |
 | ValidationSummary1 |
 | valNameReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | Subscribe

Assembly: MSS.Modules (Module: MSS.Modules)


Subscribe Constructor

Subscribe Constructor
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> SubscribeSubscribeNew()()
Declaration Syntax
C#
public Subscribe()

Assembly: MSS.Modules (Module: MSS.Modules)


btnShowSubscriptions Field

btnShowSubscriptions Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> btnShowSubscriptions
Declaration Syntax
C#
protected Button btnShowSubscriptions

Assembly: MSS.Modules (Module: MSS.Modules)


btnSubscribe Field

btnSubscribe Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> btnSubscribe
Declaration Syntax
C#
protected Button btnSubscribe

Assembly: MSS.Modules (Module: MSS.Modules)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> DictionaryRoot
Gets a dictionary root path.
Declaration Syntax
C#
protected override string DictionaryRoot{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


divCheckBoxes Field

divCheckBoxes Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> divCheckBoxes
Declaration Syntax
C#
protected HtmlGenericControl divCheckBoxes

Assembly: MSS.Modules (Module: MSS.Modules)


lblEmail Field

lblEmail Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> lblEmail
Declaration Syntax
C#
protected Label lblEmail

Assembly: MSS.Modules (Module: MSS.Modules)


lblLists Field

lblLists Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> lblLists
Declaration Syntax
C#
protected Label lblLists

Assembly: MSS.Modules (Module: MSS.Modules)


lblName Field

lblName Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> lblName
Declaration Syntax
C#
protected Label lblName

Assembly: MSS.Modules (Module: MSS.Modules)


lblRequiredFields Field

lblRequiredFields Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> lblRequiredFields
Declaration Syntax
C#
protected Label lblRequiredFields

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> LicenseKey
Gets a license key.
Declaration Syntax
C#
public override string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Mailinglistsubscribeform Field

Mailinglistsubscribeform Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> Mailinglistsubscribeform
Declaration Syntax
C#
protected Form Mailinglistsubscribeform

Assembly: MSS.Modules (Module: MSS.Modules)


Msg Field

Msg Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> Msg
Declaration Syntax
C#
protected Label Msg

Assembly: MSS.Modules (Module: MSS.Modules)


MssFields Field

MssFields Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> MssFields
Declaration Syntax
C#
protected HtmlGenericControl MssFields

Assembly: MSS.Modules (Module: MSS.Modules)


MssNavigation Field

MssNavigation Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> MssNavigation
Declaration Syntax
C#
protected HtmlGenericControl MssNavigation

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


txtEmail Field

txtEmail Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> txtEmail
Declaration Syntax
C#
protected TextBox txtEmail

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> txtName
Declaration Syntax
C#
protected TextBox txtName

Assembly: MSS.Modules (Module: MSS.Modules)


valEmailreg Field

valEmailreg Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> valEmailreg
Declaration Syntax
C#
protected RegularExpressionValidator valEmailreg

Assembly: MSS.Modules (Module: MSS.Modules)


valEmailReq Field

valEmailReq Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> valEmailReq
Declaration Syntax
C#
protected RequiredFieldValidator valEmailReq

Assembly: MSS.Modules (Module: MSS.Modules)


ValidationSummary1 Field

ValidationSummary1 Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> ValidationSummary1
Declaration Syntax
C#
protected ValidationSummary ValidationSummary1

Assembly: MSS.Modules (Module: MSS.Modules)


valNameReq Field

valNameReq Field
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> valNameReq
Declaration Syntax
C#
protected RequiredFieldValidator valNameReq

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.PictureSeries Namespace

MSS.Modules.PictureSeries Namespace
Namespaces >> MSS.Modules.PictureSeries
Declaration Syntax
C#
namespace MSS.Modules.PictureSeries
Types
All Types Classes
Icon | Type | Description
 | ItemEventHandler | Picture series item event handler. On the item:deleted event for the picture series item also deletes items from the media library.
 | MultiUploadServer | Server multiple file Upload.
 | PictureSeries | PictureSeries module manager.


ItemEventHandler Class

ItemEventHandler Class
Namespaces >> MSS.Modules.PictureSeries >> ItemEventHandler
Picture series item event handler. On the item:deleted event for the picture series item also deletes items from the media library.
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandlerItemEventHandlerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler

Assembly: MSS.Modules (Module: MSS.Modules)


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces >> MSS.Modules.PictureSeries >> ItemEventHandler >> ItemEventHandlerItemEventHandlerNew()()
Declaration Syntax
C#
public ItemEventHandler()

Assembly: MSS.Modules (Module: MSS.Modules)


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces >> MSS.Modules.PictureSeries >> ItemEventHandler >> OnItemDeleted(Object, EventArgs)
Declaration Syntax
C#
public void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
args (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


MultiUploadServer Class

MultiUploadServer Class
Namespaces >> MSS.Modules.PictureSeries >> MultiUploadServer
Server multiple file Upload.
Declaration Syntax
C#
[WebServiceAttribute(Namespace = "http://sitecore.net/multiuploadserver/")]
public class MultiUploadServer : WebService
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiUploadServerMultiUploadServerNew()() | Initializes a new instance of the MultiUploadServer class.
 | Application | Gets the application object for the current HTTP request. (Inherited from WebService.)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Context | Gets the ASP.NET HttpContext for the current request, which encapsulates all HTTP-specific context used by the HTTP server to process Web requests. (Inherited from WebService.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DirectoryExists(String) | Returns whether a directory exists.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides MarshalByValueComponent.Dispose(Boolean).)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | FileExist(String, String) | Returns whether a file exists.
 | Finalize()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Server | Gets the HttpServerUtility for the current request. (Inherited from WebService.)
 | Session | Gets the HttpSessionState instance for the current request. (Inherited from WebService.)
 | Site | Gets or sets the site of the component. (Inherited from MarshalByValueComponent.)
 | SoapVersion | Gets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from WebService.)
 | ToString()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | UploadFile(String, array<Byte>[](), String) | Uploads the file.
 | User | Gets the ASP.NET server User object. Can be used to authenticate whether a user is authorized to execute the request. (Inherited from WebService.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | WebService
 |  |  | MultiUploadServer

Assembly: MSS.Modules (Module: MSS.Modules)


MultiUploadServer Constructor

MultiUploadServer Constructor
Namespaces >> MSS.Modules.PictureSeries >> MultiUploadServer >> MultiUploadServerMultiUploadServerNew()()
Initializes a new instance of the MultiUploadServer class.
Declaration Syntax
C#
public MultiUploadServer()

Assembly: MSS.Modules (Module: MSS.Modules)


DirectoryExists Method (targetDirectory)

DirectoryExists Method (targetDirectory)
Namespaces >> MSS.Modules.PictureSeries >> MultiUploadServer >> DirectoryExists(String)
Returns whether a directory exists.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public bool DirectoryExists(
    string targetDirectory
)
Parameters
targetDirectory (String)
The target directory.
Return Value
True if a directory exists; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces >> MSS.Modules.PictureSeries >> MultiUploadServer >> Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C#
protected override void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)

Assembly: MSS.Modules (Module: MSS.Modules)


FileExist Method (filename, targetDirectory)

FileExist Method (filename, targetDirectory)
Namespaces >> MSS.Modules.PictureSeries >> MultiUploadServer >> FileExist(String, String)
Returns whether a file exists.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public bool FileExist(
    string filename,
    string targetDirectory
)
Parameters
filename (String)
The filename.
targetDirectory (String)
The target directory.
Return Value
True if a file exists; otherwise, false.

Assembly: MSS.Modules (Module: MSS.Modules)


UploadFile Method (filename, data, targetDirectory)

UploadFile Method (filename, data, targetDirectory)
Namespaces >> MSS.Modules.PictureSeries >> MultiUploadServer >> UploadFile(String, array<Byte>[](), String)
Uploads the file.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public string UploadFile(
    string filename,
    byte[] data,
    string targetDirectory
)
Parameters
filename (String)
The filename.
data (array< Byte >[]())
The data.
targetDirectory (String)
The target directory.
Return Value

Assembly: MSS.Modules (Module: MSS.Modules)


PictureSeries Class

PictureSeries Class
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries
PictureSeries module manager.
Declaration Syntax
C#
public class PictureSeries
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PictureSeriesPictureSeriesNew()() | Initialize Pictureseries from the current Siteinfo object and module settings.
 | PictureSeriesPictureSeriesNew(SiteContext) | Initialize Pictureseries from a given Siteinfo object and module settings.
 | Delete(Item, Item, SiteContext) |
 | DirectoryExists(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileExist(String, String) |
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UploadFile(String, array<Byte>[](), String) |
Inheritance Hierarchy
Object
PictureSeries

Assembly: MSS.Modules (Module: MSS.Modules)


PictureSeries Constructor

PictureSeries Constructor
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries >> PictureSeriesPictureSeriesNew()()
Members
Icon | Member | Description
 | PictureSeriesPictureSeriesNew()() | Initialize Pictureseries from the current Siteinfo object and module settings.
 | PictureSeriesPictureSeriesNew(SiteContext) | Initialize Pictureseries from a given Siteinfo object and module settings.

Assembly: MSS.Modules (Module: MSS.Modules)


PictureSeries Constructor

PictureSeries Constructor
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries >> PictureSeriesPictureSeriesNew()()
Initialize Pictureseries from the current Siteinfo object and module settings.
Declaration Syntax
C#
public PictureSeries()

Assembly: MSS.Modules (Module: MSS.Modules)


PictureSeries Constructor (siteContext)

PictureSeries Constructor (siteContext)
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries >> PictureSeriesPictureSeriesNew(SiteContext)
Initialize Pictureseries from a given Siteinfo object and module settings.
Declaration Syntax
C#
public PictureSeries(
    SiteContext siteContext
)
Parameters
siteContext (SiteContext)
The site context.

Assembly: MSS.Modules (Module: MSS.Modules)


Delete Method (itm, parent, siteContext)

Delete Method (itm, parent, siteContext)
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries >> Delete(Item, Item, SiteContext)
Declaration Syntax
C#
public void Delete(
    Item itm,
    Item parent,
    SiteContext siteContext
)
Parameters
itm (Item)
parent (Item)
siteContext (SiteContext)

Assembly: MSS.Modules (Module: MSS.Modules)


DirectoryExists Method (targetDirectory)

DirectoryExists Method (targetDirectory)
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries >> DirectoryExists(String)
Declaration Syntax
C#
public bool DirectoryExists(
    string targetDirectory
)
Parameters
targetDirectory (String)

Assembly: MSS.Modules (Module: MSS.Modules)


FileExist Method (fileName, targetDirectory)

FileExist Method (fileName, targetDirectory)
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries >> FileExist(String, String)
Declaration Syntax
C#
public bool FileExist(
    string fileName,
    string targetDirectory
)
Parameters
fileName (String)
targetDirectory (String)

Assembly: MSS.Modules (Module: MSS.Modules)


UploadFile Method (filename, data, targetDirectory)

UploadFile Method (filename, data, targetDirectory)
Namespaces >> MSS.Modules.PictureSeries >> PictureSeries >> UploadFile(String, array<Byte>[](), String)
Declaration Syntax
C#
public string UploadFile(
    string filename,
    byte[] data,
    string targetDirectory
)
Parameters
filename (String)
data (array< Byte >[]())
targetDirectory (String)

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.PictureSeries.UserControls Namespace

MSS.Modules.PictureSeries.UserControls Namespace
Namespaces >> MSS.Modules.PictureSeries.UserControls
Declaration Syntax
C#
namespace MSS.Modules.PictureSeries.UserControls
Types
All Types Classes
Icon | Type | Description
 | Picture | Renders a picture series.
 | PictureSeries | Displays a series of pictures.


Picture Class

Picture Class
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture
Renders a picture series.
Declaration Syntax
C#
public class Picture : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PicturePictureNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MSS_Modules_Pictureseries_Picture |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | Picture

Assembly: MSS.Modules (Module: MSS.Modules)


Picture Constructor

Picture Constructor
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> PicturePictureNew()()
Declaration Syntax
C#
public Picture()

Assembly: MSS.Modules (Module: MSS.Modules)


MSS_Modules_Pictureseries_Picture Field

MSS_Modules_Pictureseries_Picture Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> MSS_Modules_Pictureseries_Picture
Declaration Syntax
C#
protected XslFile MSS_Modules_Pictureseries_Picture

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


PictureSeries Class

PictureSeries Class
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries
Displays a series of pictures.
Declaration Syntax
C#
public class PictureSeries : ModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PictureSeriesPictureSeriesNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnUpload |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root item. (Overrides ModuleControl.DictionaryRoot.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblName |
 | lblRequiredFields |
 | LicenseKey | Gets a license key. (Overrides ModuleControl.LicenseKey.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | msgNameIncorrect |
 | msgNameMissing |
 | MSS_Modules_Pictureseries |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Inherited from ModuleControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PictureseriesForm |
 | pnlUpload |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtName |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | validationSummary |
 | valNameReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | PictureSeries

Assembly: MSS.Modules (Module: MSS.Modules)


PictureSeries Constructor

PictureSeries Constructor
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> PictureSeriesPictureSeriesNew()()
Declaration Syntax
C#
public PictureSeries()

Assembly: MSS.Modules (Module: MSS.Modules)


btnUpload Field

btnUpload Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> btnUpload
Declaration Syntax
C#
protected Button btnUpload

Assembly: MSS.Modules (Module: MSS.Modules)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> DictionaryRoot
Gets a dictionary root item.
Declaration Syntax
C#
protected override string DictionaryRoot{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


lblName Field

lblName Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> lblName
Declaration Syntax
C#
protected Label lblName

Assembly: MSS.Modules (Module: MSS.Modules)


lblRequiredFields Field

lblRequiredFields Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> lblRequiredFields
Declaration Syntax
C#
protected Label lblRequiredFields

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> LicenseKey
Gets a license key.
Declaration Syntax
C#
public override string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


msgNameIncorrect Field

msgNameIncorrect Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> msgNameIncorrect
Declaration Syntax
C#
protected Label msgNameIncorrect

Assembly: MSS.Modules (Module: MSS.Modules)


msgNameMissing Field

msgNameMissing Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> msgNameMissing
Declaration Syntax
C#
protected Label msgNameMissing

Assembly: MSS.Modules (Module: MSS.Modules)


MSS_Modules_Pictureseries Field

MSS_Modules_Pictureseries Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> MSS_Modules_Pictureseries
Declaration Syntax
C#
protected XslFile MSS_Modules_Pictureseries

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


PictureseriesForm Field

PictureseriesForm Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> PictureseriesForm
Declaration Syntax
C#
protected Form PictureseriesForm

Assembly: MSS.Modules (Module: MSS.Modules)


pnlUpload Field

pnlUpload Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> pnlUpload
Declaration Syntax
C#
protected Panel pnlUpload

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> txtName
Declaration Syntax
C#
protected TextBox txtName

Assembly: MSS.Modules (Module: MSS.Modules)


validationSummary Field

validationSummary Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> validationSummary
Declaration Syntax
C#
protected ValidationSummary validationSummary

Assembly: MSS.Modules (Module: MSS.Modules)


valNameReq Field

valNameReq Field
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> valNameReq
Declaration Syntax
C#
protected RequiredFieldValidator valNameReq

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.SMS Namespace

MSS.Modules.SMS Namespace
Namespaces >> MSS.Modules.SMS
Declaration Syntax
C#
namespace MSS.Modules.SMS
Types
All Types Classes
Icon | Type | Description
 | Definitions | Sms modules definitions.


Definitions Class

Definitions Class
Namespaces >> MSS.Modules.SMS >> Definitions
Sms modules definitions.
Declaration Syntax
C#
public class Definitions : SubscriptionDefinitions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefinitionsDefinitionsNew()() |
 | AdminMaster |
 | AdminPath |
 | AdminWeb |
 | ConnectionString | (Overrides SubscriptionDefinitions.ConnectionString.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupDescriptionField | (Overrides SubscriptionDefinitions.GroupDescriptionField.)
 | GroupMaster | (Overrides SubscriptionDefinitions.GroupMaster.)
 | GroupsMaster | (Overrides SubscriptionDefinitions.GroupsMaster.)
 | GroupsPath | (Overrides SubscriptionDefinitions.GroupsPath.)
 | GroupsWeb | (Overrides SubscriptionDefinitions.GroupsWeb.)
 | GroupTemplate | (Overrides SubscriptionDefinitions.GroupTemplate.)
 | GroupTitleField | (Overrides SubscriptionDefinitions.GroupTitleField.)
 | Instance |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleMaster | (Overrides SubscriptionDefinitions.ModuleMaster.)
 | ModuleRootPath | (Overrides SubscriptionDefinitions.ModuleRootPath.)
 | ModuleWeb | (Overrides SubscriptionDefinitions.ModuleWeb.)
 | SubscribersTableName | (Overrides SubscriptionDefinitions.SubscribersTableName.)
 | SubscriptionsTableName | (Overrides SubscriptionDefinitions.SubscriptionsTableName.)
 | SubsInfoFieldName | (Overrides SubscriptionDefinitions.SubsInfoFieldName.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SubscriptionDefinitions
 |  | Definitions

Assembly: MSS.Modules (Module: MSS.Modules)


Definitions Constructor

Definitions Constructor
Namespaces >> MSS.Modules.SMS >> Definitions >> DefinitionsDefinitionsNew()()
Declaration Syntax
C#
public Definitions()

Assembly: MSS.Modules (Module: MSS.Modules)


AdminMaster Property

AdminMaster Property
Namespaces >> MSS.Modules.SMS >> Definitions >> AdminMaster
Declaration Syntax
C#
public static Item AdminMaster{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


AdminPath Property

AdminPath Property
Namespaces >> MSS.Modules.SMS >> Definitions >> AdminPath
Declaration Syntax
C#
public static string AdminPath{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


AdminWeb Property

AdminWeb Property
Namespaces >> MSS.Modules.SMS >> Definitions >> AdminWeb
Declaration Syntax
C#
public static Item AdminWeb{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ConnectionString Property

ConnectionString Property
Namespaces >> MSS.Modules.SMS >> Definitions >> ConnectionString
Declaration Syntax
C#
public override string ConnectionString{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupDescriptionField Property

GroupDescriptionField Property
Namespaces >> MSS.Modules.SMS >> Definitions >> GroupDescriptionField
Declaration Syntax
C#
public override string GroupDescriptionField{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupMaster Property

GroupMaster Property
Namespaces >> MSS.Modules.SMS >> Definitions >> GroupMaster
Declaration Syntax
C#
public override string GroupMaster{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsMaster Property

GroupsMaster Property
Namespaces >> MSS.Modules.SMS >> Definitions >> GroupsMaster
Declaration Syntax
C#
public override Item GroupsMaster{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsPath Property

GroupsPath Property
Namespaces >> MSS.Modules.SMS >> Definitions >> GroupsPath
Declaration Syntax
C#
public override string GroupsPath{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupsWeb Property

GroupsWeb Property
Namespaces >> MSS.Modules.SMS >> Definitions >> GroupsWeb
Declaration Syntax
C#
public override Item GroupsWeb{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupTemplate Property

GroupTemplate Property
Namespaces >> MSS.Modules.SMS >> Definitions >> GroupTemplate
Declaration Syntax
C#
public override string GroupTemplate{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


GroupTitleField Property

GroupTitleField Property
Namespaces >> MSS.Modules.SMS >> Definitions >> GroupTitleField
Declaration Syntax
C#
public override string GroupTitleField{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Instance Property

Instance Property
Namespaces >> MSS.Modules.SMS >> Definitions >> Instance
Declaration Syntax
C#
public static Definitions Instance{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleMaster Property

ModuleMaster Property
Namespaces >> MSS.Modules.SMS >> Definitions >> ModuleMaster
Declaration Syntax
C#
public override Item ModuleMaster{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleRootPath Property

ModuleRootPath Property
Namespaces >> MSS.Modules.SMS >> Definitions >> ModuleRootPath
Declaration Syntax
C#
public override string ModuleRootPath{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ModuleWeb Property

ModuleWeb Property
Namespaces >> MSS.Modules.SMS >> Definitions >> ModuleWeb
Declaration Syntax
C#
public override Item ModuleWeb{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersTableName Property

SubscribersTableName Property
Namespaces >> MSS.Modules.SMS >> Definitions >> SubscribersTableName
Declaration Syntax
C#
public override string SubscribersTableName{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


SubscriptionsTableName Property

SubscriptionsTableName Property
Namespaces >> MSS.Modules.SMS >> Definitions >> SubscriptionsTableName
Declaration Syntax
C#
public override string SubscriptionsTableName{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


SubsInfoFieldName Property

SubsInfoFieldName Property
Namespaces >> MSS.Modules.SMS >> Definitions >> SubsInfoFieldName
Declaration Syntax
C#
public override string SubsInfoFieldName{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.SMS.CodeBeside Namespace

MSS.Modules.SMS.CodeBeside Namespace
Namespaces >> MSS.Modules.SMS.CodeBeside
Declaration Syntax
C#
namespace MSS.Modules.SMS.CodeBeside
Types
All Types Classes Delegates
Icon | Type | Description
 | SmsControl..::ChangePageDelegate |
 | EditList | Gets the name of the subscriber’s info field.
 | EditSubscriber | Allows editing of a subscriber.
 | SendMessage | Send sms message form.
 | SMS | Sms module main form.
 | SmsControl | Represents a page in sms administration.
 | SmsList | Allows to user manage sms lists.
 | SubscribersList | Sms subscribers management panel.


SmsControl.ChangePageDelegate Delegate

SmsControl..::ChangePageDelegate Delegate
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> SmsControl..::ChangePageDelegate
Declaration Syntax
C#
public delegate void ChangePageDelegate(
    string page,
    Object[] parameters
)
Parameters
page (String)
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


EditList Class

EditList Class
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList
Gets the name of the subscriber’s info field.
Declaration Syntax
C#
public class EditList : SmsControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditListEditListNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | brdGroups |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from SmsControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from SmsControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetSelectedGroups()() |
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from SmsControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | Determines whether module has a license. (Inherited from SmsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides SmsControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides SmsControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides SmsControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides SmsControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides SmsControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides SmsControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides SmsControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides SmsControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey | Gets a license key for module. (Inherited from SmsControl.)
 | litDescription |
 | litName |
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClose(Message) |
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from SmsControl.)
 | OnLoad(EventArgs) | (Inherited from SmsControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSave(Message) |
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | rbnAccessToAll |
 | rbnRestrictedAccess |
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from SmsControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from SmsControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetFreeAccess(Message) |
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetRestrictAccess(Message) |
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | Gets a default submit message. (Inherited from SmsControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | tblAccess |
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from SmsControl.)
 | TitleKey | Gets the title key. (Overrides SmsControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | Translate(String) | Translates the text. (Inherited from SmsControl.)
 | txtDescription |
 | txtName |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SmsControl
 |  |  |  |  |  | EditList

Assembly: MSS.Modules (Module: MSS.Modules)


EditList Constructor

EditList Constructor
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> EditListEditListNew()()
Declaration Syntax
C#
public EditList()

Assembly: MSS.Modules (Module: MSS.Modules)


brdGroups Field

brdGroups Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> brdGroups
Declaration Syntax
C#
protected Border brdGroups

Assembly: MSS.Modules (Module: MSS.Modules)


GetSelectedGroups Method

GetSelectedGroups Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> GetSelectedGroups()()
Declaration Syntax
C#
protected string[] GetSelectedGroups()

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


litDescription Field

litDescription Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> litDescription
Declaration Syntax
C#
protected Literal litDescription

Assembly: MSS.Modules (Module: MSS.Modules)


litName Field

litName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> litName
Declaration Syntax
C#
protected Literal litName

Assembly: MSS.Modules (Module: MSS.Modules)


OnClose Method (msg)

OnClose Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> OnClose(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:CloseEdit")]
public void OnClose(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSave Method (msg)

OnSave Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> OnSave(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Save")]
public void OnSave(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


rbnAccessToAll Field

rbnAccessToAll Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> rbnAccessToAll
Declaration Syntax
C#
protected Radiobutton rbnAccessToAll

Assembly: MSS.Modules (Module: MSS.Modules)


rbnRestrictedAccess Field

rbnRestrictedAccess Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> rbnRestrictedAccess
Declaration Syntax
C#
protected Radiobutton rbnRestrictedAccess

Assembly: MSS.Modules (Module: MSS.Modules)


SetFreeAccess Method (msg)

SetFreeAccess Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> SetFreeAccess(Message)
Declaration Syntax
C#
[HandleMessageAttribute("SMSListEdit:SetFreeAccess")]
public void SetFreeAccess(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


SetRestrictAccess Method (msg)

SetRestrictAccess Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> SetRestrictAccess(Message)
Declaration Syntax
C#
[HandleMessageAttribute("SMSListEdit:SetRestrictedAccess")]
public void SetRestrictAccess(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


tblAccess Field

tblAccess Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> tblAccess
Declaration Syntax
C#
protected GridPanel tblAccess

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> TitleKey
Gets the title key.
Declaration Syntax
C#
protected override string TitleKey{ get;}
Value
The title key.

Assembly: MSS.Modules (Module: MSS.Modules)


txtDescription Field

txtDescription Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> txtDescription
Declaration Syntax
C#
protected Memo txtDescription

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> txtName
Declaration Syntax
C#
protected Edit txtName

Assembly: MSS.Modules (Module: MSS.Modules)


EditSubscriber Class

EditSubscriber Class
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber
Allows editing of a subscriber.
Declaration Syntax
C#
public class EditSubscriber : SmsControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditSubscriberEditSubscriberNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | brdSubscriptions |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from SmsControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from SmsControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from SmsControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | Determines whether module has a license. (Inherited from SmsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides SmsControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides SmsControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides SmsControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides SmsControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides SmsControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides SmsControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides SmsControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides SmsControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey | Gets a license key for module. (Inherited from SmsControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClose(Message) | Handles the "Task:CloseEdit" event
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from SmsControl.)
 | OnLoad(EventArgs) | (Inherited from SmsControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSave(Message) | Handles the "Task:Save" event
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from SmsControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from SmsControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | Gets a default submit message. (Inherited from SmsControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from SmsControl.)
 | TitleKey | Gets the title key. (Overrides SmsControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | Translate(String) | Translates the text. (Inherited from SmsControl.)
 | txtName |
 | txtTelNo |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SmsControl
 |  |  |  |  |  | EditSubscriber

Assembly: MSS.Modules (Module: MSS.Modules)


EditSubscriber Constructor

EditSubscriber Constructor
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> EditSubscriberEditSubscriberNew()()
Declaration Syntax
C#
public EditSubscriber()

Assembly: MSS.Modules (Module: MSS.Modules)


brdSubscriptions Field

brdSubscriptions Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> brdSubscriptions
Declaration Syntax
C#
protected Border brdSubscriptions

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


OnClose Method (msg)

OnClose Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> OnClose(Message)
Handles the "Task:CloseEdit" event
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:CloseEdit")]
public void OnClose(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSave Method (msg)

OnSave Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> OnSave(Message)
Handles the "Task:Save" event
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Save")]
public void OnSave(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> TitleKey
Gets the title key.
Declaration Syntax
C#
protected override string TitleKey{ get;}
Value
The title key.

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> txtName
Declaration Syntax
C#
protected Edit txtName

Assembly: MSS.Modules (Module: MSS.Modules)


txtTelNo Field

txtTelNo Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> txtTelNo
Declaration Syntax
C#
protected Edit txtTelNo

Assembly: MSS.Modules (Module: MSS.Modules)


SendMessage Class

SendMessage Class
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage
Send sms message form.
Declaration Syntax
C#
public class SendMessage : SmsControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SendMessageSendMessageNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | brdMailingLists |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from SmsControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from SmsControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from SmsControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | Determines whether module has a license. (Inherited from SmsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides SmsControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides SmsControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides SmsControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides SmsControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides SmsControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides SmsControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides SmsControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides SmsControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey | Gets a license key for module. (Inherited from SmsControl.)
 | litSendingResult |
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from SmsControl.)
 | OnLoad(EventArgs) | (Overrides SmsControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSendMessage(Message) |
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from SmsControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from SmsControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | Gets a default submit message. (Inherited from SmsControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from SmsControl.)
 | TitleKey | (Overrides SmsControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | Translate(String) | Translates the text. (Inherited from SmsControl.)
 | txtMessage |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SmsControl
 |  |  |  |  |  | SendMessage

Assembly: MSS.Modules (Module: MSS.Modules)


SendMessage Constructor

SendMessage Constructor
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> SendMessageSendMessageNew()()
Declaration Syntax
C#
public SendMessage()

Assembly: MSS.Modules (Module: MSS.Modules)


brdMailingLists Field

brdMailingLists Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> brdMailingLists
Declaration Syntax
C#
protected Border brdMailingLists

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


litSendingResult Field

litSendingResult Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> litSendingResult
Declaration Syntax
C#
protected Literal litSendingResult

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSendMessage Method (msg)

OnSendMessage Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> OnSendMessage(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:SendMessage")]
public void OnSendMessage(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


txtMessage Field

txtMessage Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> txtMessage
Declaration Syntax
C#
protected Memo txtMessage

Assembly: MSS.Modules (Module: MSS.Modules)


SMS Class

SMS Class
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS
Sms module main form.
Declaration Syntax
C#
public class SMS : BaseForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMSSMSNew()() |
 | BindChangePageCallback(SmsControl) |
 | brdCenter |
 | btnList |
 | btnMessage |
 | btnSubscribers |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | grdMain |
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | litFormTitle |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnClose(Message) |
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides BaseForm.OnPreRender(EventArgs).)
 | OnSendMessage(Message) |
 | OnShowMailingLists(Message) |
 | OnShowSubscribers(Message) |
 | OnStatistics(Message) |
 | RefreshContols()() |
 | ServerProperties()() | (Inherited from BaseForm.)
 | SetControl(String, array<Object>[]()) |
 | tkbCreateEditDelete |
 | tkbMain |
 | tkbMessage |
 | tkbSaveClose |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | SMS

Assembly: MSS.Modules (Module: MSS.Modules)


SMS Constructor

SMS Constructor
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> SMSSMSNew()()
Declaration Syntax
C#
public SMS()

Assembly: MSS.Modules (Module: MSS.Modules)


BindChangePageCallback Method (smsControl)

BindChangePageCallback Method (smsControl)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> BindChangePageCallback(SmsControl)
Declaration Syntax
C#
protected void BindChangePageCallback(
    SmsControl smsControl
)
Parameters
smsControl (SmsControl)

Assembly: MSS.Modules (Module: MSS.Modules)


brdCenter Field

brdCenter Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> brdCenter
Declaration Syntax
C#
protected Border brdCenter

Assembly: MSS.Modules (Module: MSS.Modules)


btnList Field

btnList Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> btnList
Declaration Syntax
C#
protected TaskboxItem btnList

Assembly: MSS.Modules (Module: MSS.Modules)


btnMessage Field

btnMessage Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> btnMessage
Declaration Syntax
C#
protected TaskboxItem btnMessage

Assembly: MSS.Modules (Module: MSS.Modules)


btnSubscribers Field

btnSubscribers Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> btnSubscribers
Declaration Syntax
C#
protected TaskboxItem btnSubscribers

Assembly: MSS.Modules (Module: MSS.Modules)


grdMain Field

grdMain Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> grdMain
Declaration Syntax
C#
protected GridPanel grdMain

Assembly: MSS.Modules (Module: MSS.Modules)


litFormTitle Field

litFormTitle Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> litFormTitle
Declaration Syntax
C#
protected Literal litFormTitle

Assembly: MSS.Modules (Module: MSS.Modules)


OnClose Method (msg)

OnClose Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> OnClose(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:Close")]
public void OnClose(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnSendMessage Method (msg)

OnSendMessage Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> OnSendMessage(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:Message")]
public void OnSendMessage(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnShowMailingLists Method (msg)

OnShowMailingLists Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> OnShowMailingLists(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:List")]
public void OnShowMailingLists(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnShowSubscribers Method (msg)

OnShowSubscribers Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> OnShowSubscribers(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:Subscribers")]
public void OnShowSubscribers(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


OnStatistics Method (msg)

OnStatistics Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> OnStatistics(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Task:Statistics")]
public void OnStatistics(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


RefreshContols Method

RefreshContols Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> RefreshContols()()
Declaration Syntax
C#
protected void RefreshContols()

Assembly: MSS.Modules (Module: MSS.Modules)


SetControl Method (controlName, parameters)

SetControl Method (controlName, parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> SetControl(String, array<Object>[]())
Declaration Syntax
C#
protected void SetControl(
    string controlName,
    Object[] parameters
)
Parameters
controlName (String)
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


tkbCreateEditDelete Field

tkbCreateEditDelete Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> tkbCreateEditDelete
Declaration Syntax
C#
protected TaskBoxEx tkbCreateEditDelete

Assembly: MSS.Modules (Module: MSS.Modules)


tkbMain Field

tkbMain Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> tkbMain
Declaration Syntax
C#
protected TaskBoxEx tkbMain

Assembly: MSS.Modules (Module: MSS.Modules)


tkbMessage Field

tkbMessage Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> tkbMessage
Declaration Syntax
C#
protected TaskBoxEx tkbMessage

Assembly: MSS.Modules (Module: MSS.Modules)


tkbSaveClose Field

tkbSaveClose Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SMS >> tkbSaveClose
Declaration Syntax
C#
protected TaskBoxEx tkbSaveClose

Assembly: MSS.Modules (Module: MSS.Modules)


SmsControl Class

SmsControl Class
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl
Represents a page in sms administration.
Declaration Syntax
C#
public abstract class SmsControl : XmlControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmsControlSmsControlNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page.
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EditListControlName |
 | EditSubscriberControlName |
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Overrides XmlControl.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | Determines whether module has a license.
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | Initializes control.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | Gets a value indicating whether the creare, edit, delete toolbar is visible
 | IsVisibleMainToolbar | Gets a value indicating whether the main toolbar is visible.
 | IsVisibleMessageButton | Gets a value indicating whether message button is visible.
 | IsVisibleMessageToolbar | Gets a value indicating whether the message toolbar is visible.
 | IsVisibleSaveCloseToolbar | Gets a value indicating whether the save close toolbar is visible.
 | IsVisibleSubscribersButton | Gets a value indicating whether the subscribers button is visible.
 | IsVisibleSubscribitionsButton | Gets a value indicating whether the subscriptions button is visible.
 | Item(String) | (Inherited from XmlControl.)
 | LicenseKey | Gets a license key for module.
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MessageControlName |
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() |
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties |
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message.
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SmsListControlName |
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | Gets a default submit message.
 | SubscribersControlName |
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title.
 | TitleKey | Gets the title key.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | Translate(String) | Translates the text.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SmsControl
 |  |  |  |  |  | SmsList
 |  |  |  |  |  | SendMessage
 |  |  |  |  |  | SubscribersList
 |  |  |  |  |  | EditSubscriber
 |  |  |  |  |  | EditList

Assembly: MSS.Modules (Module: MSS.Modules)


SmsControl Constructor

SmsControl Constructor
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> SmsControlSmsControlNew()()
Declaration Syntax
C#
protected SmsControl()

Assembly: MSS.Modules (Module: MSS.Modules)


ChangePage Event

ChangePage Event
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> ChangePage
Declaration Syntax
C#
public event SmsControl.SmsControl..::ChangePageDelegate ChangePage

Assembly: MSS.Modules (Module: MSS.Modules)


DoChangePage Method (page, parameters)

DoChangePage Method (page, parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> DoChangePage(String, array<Object>[]())
Changes a page.
Declaration Syntax
C#
protected void DoChangePage(
    string page,
    Object[] parameters
)
Parameters
page (String)
The page.
parameters (array< Object >[]())
The parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


EditListControlName Field

EditListControlName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> EditListControlName
Declaration Syntax
C#
public static readonly string EditListControlName

Assembly: MSS.Modules (Module: MSS.Modules)


EditSubscriberControlName Field

EditSubscriberControlName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> EditSubscriberControlName
Declaration Syntax
C#
public static readonly string EditSubscriberControlName

Assembly: MSS.Modules (Module: MSS.Modules)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> HandleMessage(Message)
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> HasLicense()()
Determines whether module has a license.
Declaration Syntax
C#
public bool HasLicense()
Return Value
True, if module has a license. Otherwise false.

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> Initialize(array<Object>[]())
Initializes control.
Declaration Syntax
C#
public abstract void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())
The parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> IsVisibleCreareEditDeleteToolbar
Gets a value indicating whether the creare, edit, delete toolbar is visible
Declaration Syntax
C#
public abstract bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> IsVisibleMainToolbar
Gets a value indicating whether the main toolbar is visible.
Declaration Syntax
C#
public abstract bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> IsVisibleMessageButton
Gets a value indicating whether message button is visible.
Declaration Syntax
C#
public abstract bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> IsVisibleMessageToolbar
Gets a value indicating whether the message toolbar is visible.
Declaration Syntax
C#
public abstract bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> IsVisibleSaveCloseToolbar
Gets a value indicating whether the save close toolbar is visible.
Declaration Syntax
C#
public abstract bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> IsVisibleSubscribersButton
Gets a value indicating whether the subscribers button is visible.
Declaration Syntax
C#
public abstract bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> IsVisibleSubscribitionsButton
Gets a value indicating whether the subscriptions button is visible.
Declaration Syntax
C#
public abstract bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> LicenseKey
Gets a license key for module.
Declaration Syntax
C#
public string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


MessageControlName Field

MessageControlName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> MessageControlName
Declaration Syntax
C#
public static readonly string MessageControlName

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


RegisterOnSubmitStatement Method

RegisterOnSubmitStatement Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> RegisterOnSubmitStatement()()
Declaration Syntax
C#
protected void RegisterOnSubmitStatement()

Assembly: MSS.Modules (Module: MSS.Modules)


ServerProperties Property

ServerProperties Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> ServerProperties
Declaration Syntax
C#
protected StateBag ServerProperties{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlert Method (text)

ShowAlert Method (text)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> ShowAlert(String)
Shows the alert message.
Declaration Syntax
C#
protected void ShowAlert(
    string text
)
Parameters
text (String)
The text.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method (entryName)

ShowAlertFromDictionary Method (entryName)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> ShowAlertFromDictionary(String)
Shows the alert message. The text is taken from the dictionary.
Declaration Syntax
C#
protected void ShowAlertFromDictionary(
    string entryName
)
Parameters
entryName (String)
Name of the entry.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method (entryName, args)

ShowAlertFromDictionary Method (entryName, args)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> ShowAlertFromDictionary(String, array<Object>[]())
Shows the alert message. The text is taken from the dictionary.
Declaration Syntax
C#
protected void ShowAlertFromDictionary(
    string entryName,
    params Object[] args
)
Parameters
entryName (String)
Name of the entry.
args (array< Object >[]())
The argumentss.

Assembly: MSS.Modules (Module: MSS.Modules)


SmsListControlName Field

SmsListControlName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> SmsListControlName
Declaration Syntax
C#
public static readonly string SmsListControlName

Assembly: MSS.Modules (Module: MSS.Modules)


SubmitMessage Property

SubmitMessage Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> SubmitMessage
Gets a default submit message.
Declaration Syntax
C#
public virtual string SubmitMessage{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersControlName Field

SubscribersControlName Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> SubscribersControlName
Declaration Syntax
C#
public static readonly string SubscribersControlName

Assembly: MSS.Modules (Module: MSS.Modules)


Title Property

Title Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> Title
Gets the title.
Declaration Syntax
C#
public string Title{ get;}
Value
The title.

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> TitleKey
Gets the title key.
Declaration Syntax
C#
protected abstract string TitleKey{ get;}
Value
The title key.

Assembly: MSS.Modules (Module: MSS.Modules)


Translate Method (dicKey)

Translate Method (dicKey)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> Translate(String)
Translates the text.
Declaration Syntax
C#
protected string Translate(
    string dicKey
)
Parameters
dicKey (String)
The dictionary key.
Return Value

Assembly: MSS.Modules (Module: MSS.Modules)


SmsList Class

SmsList Class
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList
Allows to user manage sms lists.
Declaration Syntax
C#
public class SmsList : SmsControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmsListSmsListNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from SmsControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateNewTask(Message) | Handles the "Tasks:Create" event.
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DeleteTask(Message) | Handles the "Tasks:Delete" event.
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from SmsControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EditCurrentTask(Message) | Handles the "Tasks:Edit" event.
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from SmsControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | Determines whether module has a license. (Inherited from SmsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides SmsControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides SmsControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides SmsControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides SmsControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides SmsControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides SmsControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides SmsControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides SmsControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | lbxLists |
 | LicenseKey | Gets a license key for module. (Inherited from SmsControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from SmsControl.)
 | OnLoad(EventArgs) | (Inherited from SmsControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from SmsControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from SmsControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | Gets a default submit message. (Inherited from SmsControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from SmsControl.)
 | TitleKey | (Overrides SmsControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | Translate(String) | Translates the text. (Inherited from SmsControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SmsControl
 |  |  |  |  |  | SmsList

Assembly: MSS.Modules (Module: MSS.Modules)


SmsList Constructor

SmsList Constructor
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> SmsListSmsListNew()()
Declaration Syntax
C#
public SmsList()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateNewTask Method (msg)

CreateNewTask Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> CreateNewTask(Message)
Handles the "Tasks:Create" event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Create")]
public void CreateNewTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


DeleteTask Method (msg)

DeleteTask Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> DeleteTask(Message)
Handles the "Tasks:Delete" event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Delete")]
public void DeleteTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


EditCurrentTask Method (msg)

EditCurrentTask Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> EditCurrentTask(Message)
Handles the "Tasks:Edit" event.
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Edit")]
public void EditCurrentTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


lbxLists Field

lbxLists Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> lbxLists
Declaration Syntax
C#
protected Listbox lbxLists

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersList Class

SubscribersList Class
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList
Sms subscribers management panel.
Declaration Syntax
C#
public class SubscribersList : SmsControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscribersListSubscribersListNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChangePage | (Inherited from SmsControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateNewTask(Message) | Handles the "Tasks:Create" event
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DeleteTask(Message) | Handles the "Tasks:Delete" event
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoChangePage(String, array<Object>[]()) | Changes a page. (Inherited from SmsControl.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EditCurrentTask(Message) | Handles the "Tasks:Edit" event
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from SmsControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | Determines whether module has a license. (Inherited from SmsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize(array<Object>[]()) | (Overrides SmsControl.Initialize(array<Object>[]()).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | IsVisibleCreareEditDeleteToolbar | (Overrides SmsControl.IsVisibleCreareEditDeleteToolbar.)
 | IsVisibleMainToolbar | (Overrides SmsControl.IsVisibleMainToolbar.)
 | IsVisibleMessageButton | (Overrides SmsControl.IsVisibleMessageButton.)
 | IsVisibleMessageToolbar | (Overrides SmsControl.IsVisibleMessageToolbar.)
 | IsVisibleSaveCloseToolbar | (Overrides SmsControl.IsVisibleSaveCloseToolbar.)
 | IsVisibleSubscribersButton | (Overrides SmsControl.IsVisibleSubscribersButton.)
 | IsVisibleSubscribitionsButton | (Overrides SmsControl.IsVisibleSubscribitionsButton.)
 | Item(String) | (Inherited from XmlControl.)
 | lbxSubsLists |
 | LicenseKey | Gets a license key for module. (Inherited from SmsControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Inherited from SmsControl.)
 | OnLoad(EventArgs) | (Inherited from SmsControl.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RegisterOnSubmitStatement()() | (Inherited from SmsControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties | (Inherited from SmsControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary. (Inherited from SmsControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | SubmitMessage | Gets a default submit message. (Inherited from SmsControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Gets the title. (Inherited from SmsControl.)
 | TitleKey | (Overrides SmsControl.TitleKey.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | Translate(String) | Translates the text. (Inherited from SmsControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SmsControl
 |  |  |  |  |  | SubscribersList

Assembly: MSS.Modules (Module: MSS.Modules)


SubscribersList Constructor

SubscribersList Constructor
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> SubscribersListSubscribersListNew()()
Declaration Syntax
C#
public SubscribersList()

Assembly: MSS.Modules (Module: MSS.Modules)


CreateNewTask Method (msg)

CreateNewTask Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> CreateNewTask(Message)
Handles the "Tasks:Create" event
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Create")]
public void CreateNewTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


DeleteTask Method (msg)

DeleteTask Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> DeleteTask(Message)
Handles the "Tasks:Delete" event
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Delete")]
public void DeleteTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


EditCurrentTask Method (msg)

EditCurrentTask Method (msg)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> EditCurrentTask(Message)
Handles the "Tasks:Edit" event
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Edit")]
public void EditCurrentTask(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.Modules (Module: MSS.Modules)


Initialize Method (parameters)

Initialize Method (parameters)
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> Initialize(array<Object>[]())
Declaration Syntax
C#
public override void Initialize(
    Object[] parameters
)
Parameters
parameters (array< Object >[]())

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleCreareEditDeleteToolbar Property

IsVisibleCreareEditDeleteToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> IsVisibleCreareEditDeleteToolbar
Declaration Syntax
C#
public override bool IsVisibleCreareEditDeleteToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMainToolbar Property

IsVisibleMainToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> IsVisibleMainToolbar
Declaration Syntax
C#
public override bool IsVisibleMainToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageButton Property

IsVisibleMessageButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> IsVisibleMessageButton
Declaration Syntax
C#
public override bool IsVisibleMessageButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleMessageToolbar Property

IsVisibleMessageToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> IsVisibleMessageToolbar
Declaration Syntax
C#
public override bool IsVisibleMessageToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSaveCloseToolbar Property

IsVisibleSaveCloseToolbar Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> IsVisibleSaveCloseToolbar
Declaration Syntax
C#
public override bool IsVisibleSaveCloseToolbar{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribersButton Property

IsVisibleSubscribersButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> IsVisibleSubscribersButton
Declaration Syntax
C#
public override bool IsVisibleSubscribersButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


IsVisibleSubscribitionsButton Property

IsVisibleSubscribitionsButton Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> IsVisibleSubscribitionsButton
Declaration Syntax
C#
public override bool IsVisibleSubscribitionsButton{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


lbxSubsLists Field

lbxSubsLists Field
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> lbxSubsLists
Declaration Syntax
C#
protected Listbox lbxSubsLists

Assembly: MSS.Modules (Module: MSS.Modules)


TitleKey Property

TitleKey Property
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> TitleKey
Declaration Syntax
C#
protected override string TitleKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.SMS.Layouts Namespace

MSS.Modules.SMS.Layouts Namespace
Namespaces >> MSS.Modules.SMS.Layouts
Declaration Syntax
C#
namespace MSS.Modules.SMS.Layouts
Types
All Types Classes
Icon | Type | Description
 | Subscribe | Allows to user to subscribe to sms subscription.


Subscribe Class

Subscribe Class
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe
Allows to user to subscribe to sms subscription.
Declaration Syntax
C#
public class Subscribe : ModuleControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubscribeSubscribeNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnShowSubscriptions |
 | btnSubscribe |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryRoot | Gets a dictionary root path. (Overrides ModuleControl.DictionaryRoot.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | divCheckBoxes |
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HasLicense()() | (Inherited from ModuleControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblLists |
 | lblName |
 | lblRequiredFields |
 | lblTel |
 | LicenseKey | Gets a license key. (Overrides ModuleControl.LicenseKey.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | Mailinglistsubscribeform |
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Msg |
 | MssFields |
 | MssNavigation |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoLicenseDictionaryKey | Gets a no license dictionary key. (Inherited from ModuleControl.)
 | NoLicenseText | Gets a no license text. (Inherited from ModuleControl.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides ModuleControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | ShowNoLicense()() | (Inherited from ModuleControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtName |
 | txtTel |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationSummary1 |
 | valNameReq |
 | valTelreg |
 | valTelReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  |  | Subscribe

Assembly: MSS.Modules (Module: MSS.Modules)


Subscribe Constructor

Subscribe Constructor
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> SubscribeSubscribeNew()()
Declaration Syntax
C#
public Subscribe()

Assembly: MSS.Modules (Module: MSS.Modules)


btnShowSubscriptions Field

btnShowSubscriptions Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> btnShowSubscriptions
Declaration Syntax
C#
protected Button btnShowSubscriptions

Assembly: MSS.Modules (Module: MSS.Modules)


btnSubscribe Field

btnSubscribe Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> btnSubscribe
Declaration Syntax
C#
protected Button btnSubscribe

Assembly: MSS.Modules (Module: MSS.Modules)


DictionaryRoot Property

DictionaryRoot Property
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> DictionaryRoot
Gets a dictionary root path.
Declaration Syntax
C#
protected override string DictionaryRoot{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


divCheckBoxes Field

divCheckBoxes Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> divCheckBoxes
Declaration Syntax
C#
protected HtmlGenericControl divCheckBoxes

Assembly: MSS.Modules (Module: MSS.Modules)


lblLists Field

lblLists Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> lblLists
Declaration Syntax
C#
protected Label lblLists

Assembly: MSS.Modules (Module: MSS.Modules)


lblName Field

lblName Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> lblName
Declaration Syntax
C#
protected Label lblName

Assembly: MSS.Modules (Module: MSS.Modules)


lblRequiredFields Field

lblRequiredFields Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> lblRequiredFields
Declaration Syntax
C#
protected Label lblRequiredFields

Assembly: MSS.Modules (Module: MSS.Modules)


lblTel Field

lblTel Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> lblTel
Declaration Syntax
C#
protected Label lblTel

Assembly: MSS.Modules (Module: MSS.Modules)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> LicenseKey
Gets a license key.
Declaration Syntax
C#
public override string LicenseKey{ get;}

Assembly: MSS.Modules (Module: MSS.Modules)


Mailinglistsubscribeform Field

Mailinglistsubscribeform Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> Mailinglistsubscribeform
Declaration Syntax
C#
protected Form Mailinglistsubscribeform

Assembly: MSS.Modules (Module: MSS.Modules)


Msg Field

Msg Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> Msg
Declaration Syntax
C#
protected Label Msg

Assembly: MSS.Modules (Module: MSS.Modules)


MssFields Field

MssFields Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> MssFields
Declaration Syntax
C#
protected HtmlGenericControl MssFields

Assembly: MSS.Modules (Module: MSS.Modules)


MssNavigation Field

MssNavigation Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> MssNavigation
Declaration Syntax
C#
protected HtmlGenericControl MssNavigation

Assembly: MSS.Modules (Module: MSS.Modules)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


txtName Field

txtName Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> txtName
Declaration Syntax
C#
protected TextBox txtName

Assembly: MSS.Modules (Module: MSS.Modules)


txtTel Field

txtTel Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> txtTel
Declaration Syntax
C#
protected TextBox txtTel

Assembly: MSS.Modules (Module: MSS.Modules)


ValidationSummary1 Field

ValidationSummary1 Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> ValidationSummary1
Declaration Syntax
C#
protected ValidationSummary ValidationSummary1

Assembly: MSS.Modules (Module: MSS.Modules)


valNameReq Field

valNameReq Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> valNameReq
Declaration Syntax
C#
protected RequiredFieldValidator valNameReq

Assembly: MSS.Modules (Module: MSS.Modules)


valTelreg Field

valTelreg Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> valTelreg
Declaration Syntax
C#
protected RegularExpressionValidator valTelreg

Assembly: MSS.Modules (Module: MSS.Modules)


valTelReq Field

valTelReq Field
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> valTelReq
Declaration Syntax
C#
protected RequiredFieldValidator valTelReq

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Modules.SMS.Pages Namespace

MSS.Modules.SMS.Pages Namespace
Namespaces >> MSS.Modules.SMS.Pages
Declaration Syntax
C#
namespace MSS.Modules.SMS.Pages
Types
All Types Classes
Icon | Type | Description
 | Statistics1 | Sms statistics page.


Statistics1 Class

Statistics1 Class
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1
Sms statistics page.
Declaration Syntax
C#
public class Statistics1 : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Statistics1Statistics1New()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Panel1 |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | password |
 | pnlScripting |
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | username |
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Statistics1

Assembly: MSS.Modules (Module: MSS.Modules)


Statistics1 Constructor

Statistics1 Constructor
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> Statistics1Statistics1New()()
Declaration Syntax
C#
public Statistics1()

Assembly: MSS.Modules (Module: MSS.Modules)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Modules (Module: MSS.Modules)


Panel1 Field

Panel1 Field
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> Panel1
Declaration Syntax
C#
protected Panel Panel1

Assembly: MSS.Modules (Module: MSS.Modules)


password Field

password Field
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> password
Declaration Syntax
C#
protected HtmlInputText password

Assembly: MSS.Modules (Module: MSS.Modules)


pnlScripting Field

pnlScripting Field
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> pnlScripting
Declaration Syntax
C#
protected Panel pnlScripting

Assembly: MSS.Modules (Module: MSS.Modules)


username Field

username Field
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> username
Declaration Syntax
C#
protected HtmlInputText username

Assembly: MSS.Modules (Module: MSS.Modules)


MSS.Packages Namespace

MSS.Packages Namespace
Namespaces >> MSS.Packages
Declaration Syntax
C#
namespace MSS.Packages
Types
All Types Classes
Icon | Type | Description
 | PackageManager | Mss package manager


PackageManager Class

PackageManager Class
Namespaces >> MSS.Packages >> PackageManager
Mss package manager
Declaration Syntax
C#
public class PackageManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PackageManagerPackageManagerNew()() |
 | AddItemsToPackage(array<Item>[](), Boolean, SourceCollection<(Of <PackageEntry>)>) | Adds the items to package.
 | AddSecurityItems(SiteContext, SourceCollection<(Of <PackageEntry>)>) | Adds the site's security items to the package.
 | BackupFolder | Gets the path to the backup folder.
 | BackupSite(SiteContext, String) | Starts the site backup.
 | CreateSitePackage(SiteContext, String) | Creates site specific package.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBackupFileName(String) | Gets the name of the backup file.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstallPackage(String) | Installs the package.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RestoreSite(String) | Restores the site.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PackageManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


PackageManager Constructor

PackageManager Constructor
Namespaces >> MSS.Packages >> PackageManager >> PackageManagerPackageManagerNew()()
Declaration Syntax
C#
public PackageManager()

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddItemsToPackage Method (items, deep, sources)

AddItemsToPackage Method (items, deep, sources)
Namespaces >> MSS.Packages >> PackageManager >> AddItemsToPackage(array<Item>[](), Boolean, SourceCollection<(Of <PackageEntry>)>)
Adds the items to package.
Declaration Syntax
C#
protected static void AddItemsToPackage(
    Item[] items,
    bool deep,
    SourceCollection<PackageEntry> sources
)
Parameters
items (array<Item>[]())
The items.
deep (Boolean)
If set to true then deep; otherwise, false.
sources (SourceCollection<(Of <PackageEntry>)>)
The sources.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddSecurityItems Method (siteContext, sources)

AddSecurityItems Method (siteContext, sources)
Namespaces >> MSS.Packages >> PackageManager >> AddSecurityItems(SiteContext, SourceCollection<(Of <PackageEntry>)>)
Adds the site's security items to the package.
Declaration Syntax
C#
protected static void AddSecurityItems(
    SiteContext siteContext,
    SourceCollection<PackageEntry> sources
)
Parameters
siteContext (SiteContext)
The site context.
sources (SourceCollection<(Of <PackageEntry>)>)
The sources.

Assembly: MSS.Kernel (Module: MSS.Kernel)


BackupFolder Property

BackupFolder Property
Namespaces >> MSS.Packages >> PackageManager >> BackupFolder
Gets the path to the backup folder.
Declaration Syntax
C#
public static string BackupFolder{ get;}
Value
The backup folder.

Assembly: MSS.Kernel (Module: MSS.Kernel)


BackupSite Method (site, backupName)

BackupSite Method (site, backupName)
Namespaces >> MSS.Packages >> PackageManager >> BackupSite(SiteContext, String)
Starts the site backup.
Declaration Syntax
C#
public static void BackupSite(
    SiteContext site,
    string backupName
)
Parameters
site (SiteContext)
The site.
backupName (String)
Name of the backup file.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSitePackage Method (site, fileName)

CreateSitePackage Method (site, fileName)
Namespaces >> MSS.Packages >> PackageManager >> CreateSitePackage(SiteContext, String)
Creates site specific package.
Declaration Syntax
C#
public static void CreateSitePackage(
    SiteContext site,
    string fileName
)
Parameters
site (SiteContext)
The site.
fileName (String)
The package file name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetBackupFileName Method (backupName)

GetBackupFileName Method (backupName)
Namespaces >> MSS.Packages >> PackageManager >> GetBackupFileName(String)
Gets the name of the backup file.
Declaration Syntax
C#
public static string GetBackupFileName(
    string backupName
)
Parameters
backupName (String)
Name of the backup.

Assembly: MSS.Kernel (Module: MSS.Kernel)


InstallPackage Method (filename)

InstallPackage Method (filename)
Namespaces >> MSS.Packages >> PackageManager >> InstallPackage(String)
Installs the package.
Declaration Syntax
C#
public static void InstallPackage(
    string filename
)
Parameters
filename (String)
The package file name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RestoreSite Method (backupName)

RestoreSite Method (backupName)
Namespaces >> MSS.Packages >> PackageManager >> RestoreSite(String)
Restores the site.
Declaration Syntax
C#
public static void RestoreSite(
    string backupName
)
Parameters
backupName (String)
Name of the backup.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Pipelines.Initialize Namespace

MSS.Pipelines.Initialize Namespace
Namespaces >> MSS.Pipelines.Initialize
Declaration Syntax
C#
namespace MSS.Pipelines.Initialize
Types
All Types Classes
Icon | Type | Description
 | InitializeSites |


InitializeSites Class

InitializeSites Class
Namespaces >> MSS.Pipelines.Initialize >> InitializeSites
Declaration Syntax
C#
public class InitializeSites
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializeSitesInitializeSitesNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InitializeSites

Assembly: MSS.Kernel (Module: MSS.Kernel)


InitializeSites Constructor

InitializeSites Constructor
Namespaces >> MSS.Pipelines.Initialize >> InitializeSites >> InitializeSitesInitializeSitesNew()()
Declaration Syntax
C#
public InitializeSites()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Process Method (args)

Process Method (args)
Namespaces >> MSS.Pipelines.Initialize >> InitializeSites >> Process(PipelineArgs)
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Publishing Namespace

MSS.Publishing Namespace
Namespaces >> MSS.Publishing
Declaration Syntax
C#
namespace MSS.Publishing
Types
All Types Classes
Icon | Type | Description
 | HtmlCacheClearer | Clears the html cache on the "publish:end" event.
 | PublishingWatcher | This class hides or shows items related to publishing while the parameter SingleDatabase is being changed. The items are buttons, fields and menu items.
 | Visibility | Item visibility.


HtmlCacheClearer Class

HtmlCacheClearer Class
Namespaces >> MSS.Publishing >> HtmlCacheClearer
Clears the html cache on the "publish:end" event.
Declaration Syntax
C#
public class HtmlCacheClearer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HtmlCacheClearerHtmlCacheClearerNew()() |
 | ClearHtmlCache(Object, EventArgs) | Clears the HTML cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HtmlCacheClearer

Assembly: MSS.Kernel (Module: MSS.Kernel)


HtmlCacheClearer Constructor

HtmlCacheClearer Constructor
Namespaces >> MSS.Publishing >> HtmlCacheClearer >> HtmlCacheClearerHtmlCacheClearerNew()()
Declaration Syntax
C#
public HtmlCacheClearer()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearHtmlCache Method (sender, e)

ClearHtmlCache Method (sender, e)
Namespaces >> MSS.Publishing >> HtmlCacheClearer >> ClearHtmlCache(Object, EventArgs)
Clears the HTML cache.
Declaration Syntax
C#
protected void ClearHtmlCache(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The sender.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


PublishingWatcher Class

PublishingWatcher Class
Namespaces >> MSS.Publishing >> PublishingWatcher
This class hides or shows items related to publishing while the parameter SingleDatabase is being changed. The items are buttons, fields and menu items.
Declaration Syntax
C#
public class PublishingWatcher
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PublishingWatcherPublishingWatcherNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PublishingWatcher

Assembly: MSS.Kernel (Module: MSS.Kernel)


PublishingWatcher Constructor

PublishingWatcher Constructor
Namespaces >> MSS.Publishing >> PublishingWatcher >> PublishingWatcherPublishingWatcherNew()()
Declaration Syntax
C#
public PublishingWatcher()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Process Method (args)

Process Method (args)
Namespaces >> MSS.Publishing >> PublishingWatcher >> Process(PipelineArgs)
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Visibility Class

Visibility Class
Namespaces >> MSS.Publishing >> Visibility
Item visibility.
Declaration Syntax
C#
public class Visibility
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | VisibilityVisibilityNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible(Item) | Determines whether the specified item is visible.
 | IsWebEditMode()() | Determines whether the site is in WebEdit mode.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Visibility

Assembly: MSS.Kernel (Module: MSS.Kernel)


Visibility Constructor

Visibility Constructor
Namespaces >> MSS.Publishing >> Visibility >> VisibilityVisibilityNew()()
Declaration Syntax
C#
public Visibility()

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsVisible Method (item)

IsVisible Method (item)
Namespaces >> MSS.Publishing >> Visibility >> IsVisible(Item)
Determines whether the specified item is visible.
Declaration Syntax
C#
public static bool IsVisible(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified item is visible; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsWebEditMode Method

IsWebEditMode Method
Namespaces >> MSS.Publishing >> Visibility >> IsWebEditMode()()
Determines whether the site is in WebEdit mode.
Declaration Syntax
C#
public static bool IsWebEditMode()
Return Value
True if site is in web edit mode; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Search Namespace

MSS.Search Namespace
Namespaces >> MSS.Search
Declaration Syntax
C#
namespace MSS.Search
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | IHighlighter | Text highlighter
 | ISearch | Determines the mms searcher.
 | ISearchResult | Provides an interface which contains search results.
 | ResultOption | Result options
 | SearchOption | Search options.
 | SearchResult | Search result.


IHighlighter Interface

IHighlighter Interface
Namespaces >> MSS.Search >> IHighlighter
Text highlighter
Declaration Syntax
C#
public interface IHighlighter
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetBestFragment(String) | Gets the best fragment from the text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetBestFragment Method (text)

GetBestFragment Method (text)
Namespaces >> MSS.Search >> IHighlighter >> GetBestFragment(String)
Gets the best fragment from the text.
Declaration Syntax
C#
string GetBestFragment(
    string text
)
Parameters
text (String)
The text.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


ISearch Interface

ISearch Interface
Namespaces >> MSS.Search >> ISearch
Determines the mms searcher.
Declaration Syntax
C#
public interface ISearch
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetHighlighter(String, Int32, Int32, String, String) | Gets the text highlighter.
 | RebuildIndexDatabase(SiteContext) | Rebuilds the index database.
 | Search(String) |
 | Search(String, Int32, Int32, String) |
 | Search(String, SearchOption, ResultOption, Int32, Int32, String) |
 | SearchEngine |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHighlighter Method (searchText, maxTextLength, maxNumFragments, separator, cssClass)

GetHighlighter Method (searchText, maxTextLength, maxNumFragments, separator, cssClass)
Namespaces >> MSS.Search >> ISearch >> GetHighlighter(String, Int32, Int32, String, String)
Gets the text highlighter.
Declaration Syntax
C#
IHighlighter GetHighlighter(
    string searchText,
    int maxTextLength,
    int maxNumFragments,
    string separator,
    string cssClass
)
Parameters
searchText (String)
The search text.
maxTextLength (Int32)
Maximum length of the text.
maxNumFragments (Int32)
The max number of fragments.
separator (String)
The separator.
cssClass (String)
The CSS class.
Return Value
The IHighlighter instance.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RebuildIndexDatabase Method (site)

RebuildIndexDatabase Method (site)
Namespaces >> MSS.Search >> ISearch >> RebuildIndexDatabase(SiteContext)
Rebuilds the index database.
Declaration Syntax
C#
void RebuildIndexDatabase(
    SiteContext site
)
Parameters
site (SiteContext)
The site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Search Method

Search Method
Namespaces >> MSS.Search >> ISearch >> Search()()
Members
Icon | Member | Description
 | Search(String) |
 | Search(String, Int32, Int32, String) |
 | Search(String, SearchOption, ResultOption, Int32, Int32, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Search Method (searchText)

Search Method (searchText)
Namespaces >> MSS.Search >> ISearch >> Search(String)
Declaration Syntax
C#
ISearchResult Search(
    string searchText
)
Parameters
searchText (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Search Method (searchText, option, resultOption, offset, count, templates)

Search Method (searchText, option, resultOption, offset, count, templates)
Namespaces >> MSS.Search >> ISearch >> Search(String, SearchOption, ResultOption, Int32, Int32, String)
Declaration Syntax
C#
ISearchResult Search(
    string searchText,
    SearchOption option,
    ResultOption resultOption,
    int offset,
    int count,
    string templates
)
Parameters
searchText (String)
option (SearchOption)
resultOption (ResultOption)
offset (Int32)
count (Int32)
templates (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Search Method (searchText, offset, count, templates)

Search Method (searchText, offset, count, templates)
Namespaces >> MSS.Search >> ISearch >> Search(String, Int32, Int32, String)
Declaration Syntax
C#
ISearchResult Search(
    string searchText,
    int offset,
    int count,
    string templates
)
Parameters
searchText (String)
offset (Int32)
count (Int32)
templates (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SearchEngine Property

SearchEngine Property
Namespaces >> MSS.Search >> ISearch >> SearchEngine
Declaration Syntax
C#
string SearchEngine{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


ISearchResult Interface

ISearchResult Interface
Namespaces >> MSS.Search >> ISearchResult
Provides an interface which contains search results.
Declaration Syntax
C#
public interface ISearchResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Count | Gets the max count in the search result.
 | GetXmlDocument()() | Gets the XML document which contains search results.
 | GetXmlDocument(IHighlighter) | Gets the XML document which contains search results.
 | Offset | Gets the search offset.
 | QueryText | Gets the search query text.
 | Result | Gets the search result.
 | TotalHits | Gets the total hits for the search.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Count Property

Count Property
Namespaces >> MSS.Search >> ISearchResult >> Count
Gets the max count in the search result.
Declaration Syntax
C#
int Count{ get;}
Value
The count.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetXmlDocument Method

GetXmlDocument Method
Namespaces >> MSS.Search >> ISearchResult >> GetXmlDocument()()
Members
Icon | Member | Description
 | GetXmlDocument()() | Gets the XML document which contains search results.
 | GetXmlDocument(IHighlighter) | Gets the XML document which contains search results.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetXmlDocument Method

GetXmlDocument Method
Namespaces >> MSS.Search >> ISearchResult >> GetXmlDocument()()
Gets the XML document which contains search results.
Declaration Syntax
C#
XmlDocument GetXmlDocument()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetXmlDocument Method (highlighter)

GetXmlDocument Method (highlighter)
Namespaces >> MSS.Search >> ISearchResult >> GetXmlDocument(IHighlighter)
Gets the XML document which contains search results.
Declaration Syntax
C#
XmlDocument GetXmlDocument(
    IHighlighter highlighter
)
Parameters
highlighter (IHighlighter)
The highlighter.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Offset Property

Offset Property
Namespaces >> MSS.Search >> ISearchResult >> Offset
Gets the search offset.
Declaration Syntax
C#
int Offset{ get;}
Value
The offset.

Assembly: MSS.Kernel (Module: MSS.Kernel)


QueryText Property

QueryText Property
Namespaces >> MSS.Search >> ISearchResult >> QueryText
Gets the search query text.
Declaration Syntax
C#
string QueryText{ get;}
Value
The query text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Result Property

Result Property
Namespaces >> MSS.Search >> ISearchResult >> Result
Gets the search result.
Declaration Syntax
C#
XmlDocument Result{ get;}
Value
The result.

Assembly: MSS.Kernel (Module: MSS.Kernel)


TotalHits Property

TotalHits Property
Namespaces >> MSS.Search >> ISearchResult >> TotalHits
Gets the total hits for the search.
Declaration Syntax
C#
int TotalHits{ get;}
Value
The total hits.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ResultOption Enumeration

ResultOption Enumeration
Namespaces >> MSS.Search >> ResultOption
Result options
Declaration Syntax
C#
public enum ResultOption
Members
Member | Description
AllItems |
ItemsOfCurLanguage |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SearchOption Enumeration

SearchOption Enumeration
Namespaces >> MSS.Search >> SearchOption
Search options.
Declaration Syntax
C#
public enum SearchOption
Members
Member | Description
ExactPhrase |
WildCards |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SearchResult Class

SearchResult Class
Namespaces >> MSS.Search >> SearchResult
Search result.
Declaration Syntax
C#
public class SearchResult : ISearchResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultSearchResultNew()() |
 | AddItem(Item) | Adds an item to the result
 | Count | Gets or sets the count.
 | EmptyResult(String) | Create empty search result.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXmlDocument(IHighlighter) | Creates an Xml document from the search result using the highlighter.
 | GetXmlDocument()() | Creates an Xml document from the search result.
 | Items | Gets the items.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets or sets the offset.
 | QueryText | Gets or sets the query text.
 | Result | Gets th result.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalHits | Gets or sets the total hits.
Inheritance Hierarchy
Object
SearchResult

Assembly: MSS.Kernel (Module: MSS.Kernel)


SearchResult Constructor

SearchResult Constructor
Namespaces >> MSS.Search >> SearchResult >> SearchResultSearchResultNew()()
Declaration Syntax
C#
public SearchResult()

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddItem Method (item)

AddItem Method (item)
Namespaces >> MSS.Search >> SearchResult >> AddItem(Item)
Adds an item to the result
Declaration Syntax
C#
public void AddItem(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Count Property

Count Property
Namespaces >> MSS.Search >> SearchResult >> Count
Gets or sets the count.
Declaration Syntax
C#
public int Count{ get; set;}
Value
The count.

Assembly: MSS.Kernel (Module: MSS.Kernel)


EmptyResult Method (searchText)

EmptyResult Method (searchText)
Namespaces >> MSS.Search >> SearchResult >> EmptyResult(String)
Create empty search result.
Declaration Syntax
C#
public static SearchResult EmptyResult(
    string searchText
)
Parameters
searchText (String)
The search text.
Return Value
The empty search result.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetXmlDocument Method

GetXmlDocument Method
Namespaces >> MSS.Search >> SearchResult >> GetXmlDocument()()
Members
Icon | Member | Description
 | GetXmlDocument(IHighlighter) | Creates an Xml document from the search result using the highlighter.
 | GetXmlDocument()() | Creates an Xml document from the search result.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetXmlDocument Method

GetXmlDocument Method
Namespaces >> MSS.Search >> SearchResult >> GetXmlDocument()()
Creates an Xml document from the search result.
Declaration Syntax
C#
public XmlDocument GetXmlDocument()
Return Value
The Xml document.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetXmlDocument Method (highlighter)

GetXmlDocument Method (highlighter)
Namespaces >> MSS.Search >> SearchResult >> GetXmlDocument(IHighlighter)
Creates an Xml document from the search result using the highlighter.
Declaration Syntax
C#
public XmlDocument GetXmlDocument(
    IHighlighter highlighter
)
Parameters
highlighter (IHighlighter)
The highlighter.
Return Value
The Xml document.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Items Property

Items Property
Namespaces >> MSS.Search >> SearchResult >> Items
Gets the items.
Declaration Syntax
C#
public Item[] Items{ get;}
Value
The items.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Offset Property

Offset Property
Namespaces >> MSS.Search >> SearchResult >> Offset
Gets or sets the offset.
Declaration Syntax
C#
public int Offset{ get; set;}
Value
The offset.

Assembly: MSS.Kernel (Module: MSS.Kernel)


QueryText Property

QueryText Property
Namespaces >> MSS.Search >> SearchResult >> QueryText
Gets or sets the query text.
Declaration Syntax
C#
public string QueryText{ get; set;}
Value
The query text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Result Property

Result Property
Namespaces >> MSS.Search >> SearchResult >> Result
Gets th result.
Declaration Syntax
C#
public XmlDocument Result{ get;}
Value
The result.

Assembly: MSS.Kernel (Module: MSS.Kernel)


TotalHits Property

TotalHits Property
Namespaces >> MSS.Search >> SearchResult >> TotalHits
Gets or sets the total hits.
Declaration Syntax
C#
public int TotalHits{ get;}
Value
The total hits.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Security Namespace

MSS.Security Namespace
Namespaces >> MSS.Security
Declaration Syntax
C#
namespace MSS.Security
Types
All Types Classes
Icon | Type | Description
 | MSSRoleProvider | Expands functionality of the SitecoreRoleProvider class
 | MSSRoleProvider..::Optimization | To implement optimization.
 | Rights | Represents mss security rights.
 | SecurityDomain | Summary: This domain adds protection to first-level site's items to the standard domain.


MSSRoleProvider Class

MSSRoleProvider Class
Namespaces >> MSS.Security >> MSSRoleProvider
Expands functionality of the SitecoreRoleProvider class
Declaration Syntax
C#
public class MSSRoleProvider : SitecoreRoleProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSSRoleProviderMSSRoleProviderNew(Domain) |
 | AdditionalRolesAreEqual(array<ID>[](), array<ID>[]()) | Checks the additional roles.
 | AddUsersToRoles(array<String>[](), array<String>[]()) | Adds the users to roles. (Overrides SitecoreRoleProvider.AddUsersToRoles(array<String>[](), array<String>[]()).)
 | ApplicationName()() | (Inherited from SitecoreRoleProvider.)
 | AssignRoleToRole(String, String) | Assigns one role to another.
 | ClearAssigments(Item, String, Boolean) | Clears the assignments.
 | ClearAssigments(Item, RoleItem, Boolean) | Clears the assignments.
 | CopyAssigments(Item, String, String) | Copies the assignments from one role to another.
 | CopyAssigments(Item, RoleItem, RoleItem) | Copies the assignments from one role to another.
 | CopyAssigments(Item, String, String, Boolean) | Copies the assignments from one role to another.
 | CopyAssigments(Item, RoleItem, RoleItem, Boolean) | Copies the assignments from one role to another.
 | CreateRole(String) | Creates a new role. (Overrides SitecoreRoleProvider.CreateRole(String).)
 | CreateRole(String, Item) | Creates a new role. (Overrides SitecoreRoleProvider.CreateRole(String, Item).)
 | DeleteRole(String, Boolean) | Removes a role. (Overrides SitecoreRoleProvider.DeleteRole(String, Boolean).)
 | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindUsersInRole(String, String) | Finds a user in a specific role. (Overrides SitecoreRoleProvider.FindUsersInRole(String, String).)
 | GetAdditionalRoles(String) | Gets the additional roles.
 | GetAdditionalRoles(RoleItem) | Gets the additional roles.
 | GetAllRoles()() | Gets a list of all the roles. (Overrides SitecoreRoleProvider.GetAllRoles()().)
 | GetAllUsers(String) | Gets all users.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRolesForUser(String) | Gets the roles for user. (Overrides SitecoreRoleProvider.GetRolesForUser(String).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsersInRole(String) | Gets a list of users. (Overrides SitecoreRoleProvider.GetUsersInRole(String).)
 | Initialize(String, NameValueCollection) | (Inherited from SitecoreRoleProvider.)
 | IsAdditionalRole(String) | Determines whether the specified role name is an additional role.
 | IsUserInRole(String, String) | Determines whether the specified user is in the specified role. (Overrides SitecoreRoleProvider.IsUserInRole(String, String).)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
 | RemoveRoleFromRole(String, String) | Removes a child role from its base role.
 | RemoveUsersFromRoles(array<String>[](), array<String>[]()) | Removes the users from roles. (Overrides SitecoreRoleProvider.RemoveUsersFromRoles(array<String>[](), array<String>[]()).)
 | RoleExists(String) | Gets a value indicating whether the specified role already exists. (Overrides SitecoreRoleProvider.RoleExists(String).)
 | SetRights(Item, RoleItem, ItemRights) | Sets the rights by role.
 | SetRights(Item, UserItem, ItemRights) | Sets the rights by user.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ProviderBase
 |  | RoleProvider
 |  |  | SitecoreRoleProvider
 |  |  |  | MSSRoleProvider

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSSRoleProvider Constructor (domain)

MSSRoleProvider Constructor (domain)
Namespaces >> MSS.Security >> MSSRoleProvider >> MSSRoleProviderMSSRoleProviderNew(Domain)
Declaration Syntax
C#
public MSSRoleProvider(
    Domain domain
)
Parameters
domain (Domain)

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdditionalRolesAreEqual Method (ids1, ids2)

AdditionalRolesAreEqual Method (ids1, ids2)
Namespaces >> MSS.Security >> MSSRoleProvider >> AdditionalRolesAreEqual(array<ID>[](), array<ID>[]())
Checks the additional roles.
Declaration Syntax
C#
public static bool AdditionalRolesAreEqual(
    ID[] ids1,
    ID[] ids2
)
Parameters
ids1 (array<ID>[]())
The ids1.
ids2 (array<ID>[]())
The ids2.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddUsersToRoles Method (userNames, roleNames)

AddUsersToRoles Method (userNames, roleNames)
Namespaces >> MSS.Security >> MSSRoleProvider >> AddUsersToRoles(array<String>[](), array<String>[]())
Adds the users to roles.
Declaration Syntax
C#
public override void AddUsersToRoles(
    string[] userNames,
    string[] roleNames
)
Parameters
userNames (array< String >[]())
The user names.
roleNames (array< String >[]())
The role names.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AssignRoleToRole Method (roleToAssign, targetRole)

AssignRoleToRole Method (roleToAssign, targetRole)
Namespaces >> MSS.Security >> MSSRoleProvider >> AssignRoleToRole(String, String)
Assigns one role to another.
Declaration Syntax
C#
public void AssignRoleToRole(
    string roleToAssign,
    string targetRole
)
Parameters
roleToAssign (String)
The role to assign.
targetRole (String)
The target role.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAssigments Method

ClearAssigments Method
Namespaces >> MSS.Security >> MSSRoleProvider >> ClearAssigments()()
Members
Icon | Member | Description
 | ClearAssigments(Item, String, Boolean) | Clears the assignments.
 | ClearAssigments(Item, RoleItem, Boolean) | Clears the assignments.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAssigments Method (item, role, leaveReadRight)

ClearAssigments Method (item, role, leaveReadRight)
Namespaces >> MSS.Security >> MSSRoleProvider >> ClearAssigments(Item, RoleItem, Boolean)
Clears the assignments.
Declaration Syntax
C#
public void ClearAssigments(
    Item item,
    RoleItem role,
    bool leaveReadRight
)
Parameters
item (Item)
The item.
role (RoleItem)
The role.
leaveReadRight (Boolean)
if set to true [leave read right].

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAssigments Method (item, roleName, leaveReadRight)

ClearAssigments Method (item, roleName, leaveReadRight)
Namespaces >> MSS.Security >> MSSRoleProvider >> ClearAssigments(Item, String, Boolean)
Clears the assignments.
Declaration Syntax
C#
public void ClearAssigments(
    Item item,
    string roleName,
    bool leaveReadRight
)
Parameters
item (Item)
The item.
roleName (String)
Name of the role.
leaveReadRight (Boolean)
if set to true [leave read right].

Assembly: MSS.Kernel (Module: MSS.Kernel)


CopyAssigments Method

CopyAssigments Method
Namespaces >> MSS.Security >> MSSRoleProvider >> CopyAssigments()()
Members
Icon | Member | Description
 | CopyAssigments(Item, String, String) | Copies the assignments from one role to another.
 | CopyAssigments(Item, RoleItem, RoleItem) | Copies the assignments from one role to another.
 | CopyAssigments(Item, String, String, Boolean) | Copies the assignments from one role to another.
 | CopyAssigments(Item, RoleItem, RoleItem, Boolean) | Copies the assignments from one role to another.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CopyAssigments Method (item, roleFrom, roleTo)

CopyAssigments Method (item, roleFrom, roleTo)
Namespaces >> MSS.Security >> MSSRoleProvider >> CopyAssigments(Item, RoleItem, RoleItem)
Copies the assignments from one role to another.
Declaration Syntax
C#
public void CopyAssigments(
    Item item,
    RoleItem roleFrom,
    RoleItem roleTo
)
Parameters
item (Item)
The item.
roleFrom (RoleItem)
The role from.
roleTo (RoleItem)
The role to.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CopyAssigments Method (item, roleFrom, roleTo, mergeReadRight)

CopyAssigments Method (item, roleFrom, roleTo, mergeReadRight)
Namespaces >> MSS.Security >> MSSRoleProvider >> CopyAssigments(Item, RoleItem, RoleItem, Boolean)
Copies the assignments from one role to another.
Declaration Syntax
C#
public void CopyAssigments(
    Item item,
    RoleItem roleFrom,
    RoleItem roleTo,
    bool mergeReadRight
)
Parameters
item (Item)
The item.
roleFrom (RoleItem)
The role from.
roleTo (RoleItem)
The role to.
mergeReadRight (Boolean)
if set to true [merge read right].

Assembly: MSS.Kernel (Module: MSS.Kernel)


CopyAssigments Method (item, roleFrom, roleTo)

CopyAssigments Method (item, roleFrom, roleTo)
Namespaces >> MSS.Security >> MSSRoleProvider >> CopyAssigments(Item, String, String)
Copies the assignments from one role to another.
Declaration Syntax
C#
public void CopyAssigments(
    Item item,
    string roleFrom,
    string roleTo
)
Parameters
item (Item)
The item.
roleFrom (String)
The role from.
roleTo (String)
The role to.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CopyAssigments Method (item, roleFrom, roleTo, mergeReadRight)

CopyAssigments Method (item, roleFrom, roleTo, mergeReadRight)
Namespaces >> MSS.Security >> MSSRoleProvider >> CopyAssigments(Item, String, String, Boolean)
Copies the assignments from one role to another.
Declaration Syntax
C#
public void CopyAssigments(
    Item item,
    string roleFrom,
    string roleTo,
    bool mergeReadRight
)
Parameters
item (Item)
The item.
roleFrom (String)
The role from.
roleTo (String)
The role to.
mergeReadRight (Boolean)
if set to true [merge read right].

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateRole Method

CreateRole Method
Namespaces >> MSS.Security >> MSSRoleProvider >> CreateRole()()
Members
Icon | Member | Description
 | CreateRole(String) | Creates a new role. (Overrides SitecoreRoleProvider.CreateRole(String).)
 | CreateRole(String, Item) | Creates a new role. (Overrides SitecoreRoleProvider.CreateRole(String, Item).)

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateRole Method (roleName)

CreateRole Method (roleName)
Namespaces >> MSS.Security >> MSSRoleProvider >> CreateRole(String)
Creates a new role.
Declaration Syntax
C#
public override void CreateRole(
    string roleName
)
Parameters
roleName (String)
The name of the role to create.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateRole Method (roleName, parentNode)

CreateRole Method (roleName, parentNode)
Namespaces >> MSS.Security >> MSSRoleProvider >> CreateRole(String, Item)
Creates a new role.
Declaration Syntax
C#
public override void CreateRole(
    string roleName,
    Item parentNode
)
Parameters
roleName (String)
Name of the role.
parentNode (Item)
The parent node.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteRole Method (roleName, throwOnPopulatedRole)

DeleteRole Method (roleName, throwOnPopulatedRole)
Namespaces >> MSS.Security >> MSSRoleProvider >> DeleteRole(String, Boolean)
Removes a role.
Declaration Syntax
C#
public override bool DeleteRole(
    string roleName,
    bool throwOnPopulatedRole
)
Parameters
roleName (String)
The name of the role to delete.
throwOnPopulatedRole (Boolean)
If true, throw an exception if the role name has one or more members and do not delete the role name.
Return Value
True if the role was successfully deleted; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindUsersInRole Method (roleName, userNameToMatch)

FindUsersInRole Method (roleName, userNameToMatch)
Namespaces >> MSS.Security >> MSSRoleProvider >> FindUsersInRole(String, String)
Finds a user in a specific role.
Declaration Syntax
C#
public override string[] FindUsersInRole(
    string roleName,
    string userNameToMatch
)
Parameters
roleName (String)
Name of the role.
userNameToMatch (String)
The user name to match.
Return Value
The users ID

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAdditionalRoles Method

GetAdditionalRoles Method
Namespaces >> MSS.Security >> MSSRoleProvider >> GetAdditionalRoles()()
Members
Icon | Member | Description
 | GetAdditionalRoles(String) | Gets the additional roles.
 | GetAdditionalRoles(RoleItem) | Gets the additional roles.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAdditionalRoles Method (roleItem)

GetAdditionalRoles Method (roleItem)
Namespaces >> MSS.Security >> MSSRoleProvider >> GetAdditionalRoles(RoleItem)
Gets the additional roles.
Declaration Syntax
C#
public string[] GetAdditionalRoles(
    RoleItem roleItem
)
Parameters
roleItem (RoleItem)
The role item.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAdditionalRoles Method (roleName)

GetAdditionalRoles Method (roleName)
Namespaces >> MSS.Security >> MSSRoleProvider >> GetAdditionalRoles(String)
Gets the additional roles.
Declaration Syntax
C#
public string[] GetAdditionalRoles(
    string roleName
)
Parameters
roleName (String)
Name of the role.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAllRoles Method

GetAllRoles Method
Namespaces >> MSS.Security >> MSSRoleProvider >> GetAllRoles()()
Gets a list of all the roles.
Declaration Syntax
C#
public override string[] GetAllRoles()
Return Value
A string array containing the names of all the roles stored in the data source for the configured application name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAllUsers Method (namePrefix)

GetAllUsers Method (namePrefix)
Namespaces >> MSS.Security >> MSSRoleProvider >> GetAllUsers(String)
Gets all users.
Declaration Syntax
C#
public List<UserItem> GetAllUsers(
    string namePrefix
)
Parameters
namePrefix (String)
Return Value
A list of all users.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetRolesForUser Method (userName)

GetRolesForUser Method (userName)
Namespaces >> MSS.Security >> MSSRoleProvider >> GetRolesForUser(String)
Gets the roles for user.
Declaration Syntax
C#
public override string[] GetRolesForUser(
    string userName
)
Parameters
userName (String)
Name of the user.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetUsersInRole Method (roleName)

GetUsersInRole Method (roleName)
Namespaces >> MSS.Security >> MSSRoleProvider >> GetUsersInRole(String)
Gets a list of users.
Declaration Syntax
C#
public override string[] GetUsersInRole(
    string roleName
)
Parameters
roleName (String)
The name of the role to get the list of users for.
Return Value
A string array containing the names of all the users who are members of the specified role for the configured application name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAdditionalRole Method (roleName)

IsAdditionalRole Method (roleName)
Namespaces >> MSS.Security >> MSSRoleProvider >> IsAdditionalRole(String)
Determines whether the specified role name is an additional role.
Declaration Syntax
C#
public static bool IsAdditionalRole(
    string roleName
)
Parameters
roleName (String)
Name of the role.
Return Value
True if the specified role name is an additional role; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsUserInRole Method (userName, roleName)

IsUserInRole Method (userName, roleName)
Namespaces >> MSS.Security >> MSSRoleProvider >> IsUserInRole(String, String)
Determines whether the specified user is in the specified role.
Declaration Syntax
C#
public override bool IsUserInRole(
    string userName,
    string roleName
)
Parameters
userName (String)
Name of the user.
roleName (String)
Name of the role.
Return Value
True if the specified user is in the specified role; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveRoleFromRole Method (oldBaseRole, childRole)

RemoveRoleFromRole Method (oldBaseRole, childRole)
Namespaces >> MSS.Security >> MSSRoleProvider >> RemoveRoleFromRole(String, String)
Removes a child role from its base role.
Declaration Syntax
C#
public void RemoveRoleFromRole(
    string oldBaseRole,
    string childRole
)
Parameters
oldBaseRole (String)
The old base role.
childRole (String)
The child role.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveUsersFromRoles Method (userNames, roleNames)

RemoveUsersFromRoles Method (userNames, roleNames)
Namespaces >> MSS.Security >> MSSRoleProvider >> RemoveUsersFromRoles(array<String>[](), array<String>[]())
Removes the users from roles.
Declaration Syntax
C#
public override void RemoveUsersFromRoles(
    string[] userNames,
    string[] roleNames
)
Parameters
userNames (array< String >[]())
The user names.
roleNames (array< String >[]())
The role names.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RoleExists Method (roleName)

RoleExists Method (roleName)
Namespaces >> MSS.Security >> MSSRoleProvider >> RoleExists(String)
Gets a value indicating whether the specified role already exists.
Declaration Syntax
C#
public override bool RoleExists(
    string roleName
)
Parameters
roleName (String)
The name of the role to search for in the data source.
Return Value
True if the role name already exists in the data source for the configured application name; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetRights Method

SetRights Method
Namespaces >> MSS.Security >> MSSRoleProvider >> SetRights()()
Members
Icon | Member | Description
 | SetRights(Item, RoleItem, ItemRights) | Sets the rights by role.
 | SetRights(Item, UserItem, ItemRights) | Sets the rights by user.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetRights Method (item, role, rights)

SetRights Method (item, role, rights)
Namespaces >> MSS.Security >> MSSRoleProvider >> SetRights(Item, RoleItem, ItemRights)
Sets the rights by role.
Declaration Syntax
C#
public static void SetRights(
    Item item,
    RoleItem role,
    ItemRights rights
)
Parameters
item (Item)
The item.
role (RoleItem)
The role.
rights (ItemRights)
The rights.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetRights Method (item, user, rights)

SetRights Method (item, user, rights)
Namespaces >> MSS.Security >> MSSRoleProvider >> SetRights(Item, UserItem, ItemRights)
Sets the rights by user.
Declaration Syntax
C#
public static void SetRights(
    Item item,
    UserItem user,
    ItemRights rights
)
Parameters
item (Item)
The item.
user (UserItem)
The user.
rights (ItemRights)
The rights.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSSRoleProvider.Optimization Class

MSSRoleProvider..::Optimization Class
Namespaces >> MSS.Security >> MSSRoleProvider >> MSSRoleProvider..::Optimization
To implement optimization.
Declaration Syntax
C#
public class Optimization : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSSRoleProvider..::OptimizationMSSRoleProvider..::OptimizationNew()() | Initializes a new instance of the MSSRoleProvider..::Optimization class.
 | Dispose()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OptimizationIsEnabled |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MSSRoleProvider..::Optimization

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSSRoleProvider.Optimization Constructor

MSSRoleProvider..::Optimization Constructor
Namespaces >> MSS.Security >> MSSRoleProvider..::Optimization >> MSSRoleProvider..::OptimizationMSSRoleProvider..::OptimizationNew()()
Initializes a new instance of the MSSRoleProvider..::Optimization class.
Declaration Syntax
C#
public Optimization()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Dispose Method

Dispose Method
Namespaces >> MSS.Security >> MSSRoleProvider..::Optimization >> Dispose()()
Declaration Syntax
C#
public void Dispose()

Assembly: MSS.Kernel (Module: MSS.Kernel)


OptimizationIsEnabled Property

OptimizationIsEnabled Property
Namespaces >> MSS.Security >> MSSRoleProvider..::Optimization >> OptimizationIsEnabled
Declaration Syntax
C#
public static bool OptimizationIsEnabled{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Rights Class

Rights Class
Namespaces >> MSS.Security >> Rights
Represents mss security rights.
Declaration Syntax
C#
public static class Rights
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanSeeBackend |
 | ContentEditing |
 | ManageSecurity |
 | ManageWizard |
Inheritance Hierarchy
Object
Rights

Assembly: MSS.Kernel (Module: MSS.Kernel)


CanSeeBackend Field

CanSeeBackend Field
Namespaces >> MSS.Security >> Rights >> CanSeeBackend
Declaration Syntax
C#
public static readonly string CanSeeBackend

Assembly: MSS.Kernel (Module: MSS.Kernel)


ContentEditing Field

ContentEditing Field
Namespaces >> MSS.Security >> Rights >> ContentEditing
Declaration Syntax
C#
public static readonly string ContentEditing

Assembly: MSS.Kernel (Module: MSS.Kernel)


ManageSecurity Field

ManageSecurity Field
Namespaces >> MSS.Security >> Rights >> ManageSecurity
Declaration Syntax
C#
public static readonly string ManageSecurity

Assembly: MSS.Kernel (Module: MSS.Kernel)


ManageWizard Field

ManageWizard Field
Namespaces >> MSS.Security >> Rights >> ManageWizard
Declaration Syntax
C#
public static readonly string ManageWizard

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityDomain Class

SecurityDomain Class
Namespaces >> MSS.Security >> SecurityDomain
Summary: This domain adds protection to first-level site's items to the standard domain.
Declaration Syntax
C#
public class SecurityDomain : Domain
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityDomainSecurityDomainNew(String, String) | Initializes a new instance of the SecurityDomain class.
 | AddRole(Item, String) | (Inherited from Domain.)
 | AddUser(Item, String) | (Inherited from Domain.)
 | Appearance()() | (Inherited from Domain.)
 | BuildVirtualUser(ID, String) | (Inherited from Domain.)
 | CurrentUser()() | (Inherited from Domain.)
 | Database()() | (Inherited from Domain.)
 | DeleteUser(String) | (Inherited from Domain.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindUserIds(String) | (Inherited from Domain.)
 | GetAnonymousUser()() | (Inherited from Domain.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRole(String) | (Overrides Domain.GetRole(String).)
 | GetRole(ID) | (Inherited from Domain.)
 | GetRoles()() | (Inherited from Domain.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(String) | (Overrides Domain.GetUser(String).)
 | GetUser(ID) | (Inherited from Domain.)
 | IsAllowed(ItemOperation, Item, UserItem) | Determines whether the specified operation is allowed. (Overrides Domain.IsAllowed(ItemOperation, Item, UserItem).)
 | IsAllowed(ItemOperation, Item, RoleItem) | (Inherited from Domain.)
 | IsAnonymous(ID) | (Inherited from Domain.)
 | IsEveryone(ID) | (Inherited from Domain.)
 | IsLoggedIn()() | (Inherited from Domain.)
 | Login(Credentials) | (Inherited from Domain.)
 | Login(UserItem) | (Inherited from Domain.)
 | Login(String, String) | (Inherited from Domain.)
 | Logout()() | (Inherited from Domain.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Domain.)
 | RoleProvider()() | (Inherited from Domain.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserExists(String) | (Inherited from Domain.)
Inheritance Hierarchy
Object
 | Domain
 |  | SecurityDomain

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityDomain Constructor (domainName, databaseName)

SecurityDomain Constructor (domainName, databaseName)
Namespaces >> MSS.Security >> SecurityDomain >> SecurityDomainSecurityDomainNew(String, String)
Initializes a new instance of the SecurityDomain class.
Declaration Syntax
C#
public SecurityDomain(
    string domainName,
    string databaseName
)
Parameters
domainName (String)
The domain name.
databaseName (String)
The database name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetRole Method (roleName)

GetRole Method (roleName)
Namespaces >> MSS.Security >> SecurityDomain >> GetRole(String)
Declaration Syntax
C#
public override RoleItem GetRole(
    string roleName
)
Parameters
roleName (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetUser Method (userName)

GetUser Method (userName)
Namespaces >> MSS.Security >> SecurityDomain >> GetUser(String)
Declaration Syntax
C#
public override UserItem GetUser(
    string userName
)
Parameters
userName (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAllowed Method (operation, item, user)

IsAllowed Method (operation, item, user)
Namespaces >> MSS.Security >> SecurityDomain >> IsAllowed(ItemOperation, Item, UserItem)
Determines whether the specified operation is allowed.
Declaration Syntax
C#
public override bool IsAllowed(
    ItemOperation operation,
    Item item,
    UserItem user
)
Parameters
operation (ItemOperation)
The operation.
item (Item)
The item.
user (UserItem)
The user.
Return Value
true if the specified operation is allowed; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Security.Groups Namespace

MSS.Security.Groups Namespace
Namespaces >> MSS.Security.Groups
Declaration Syntax
C#
namespace MSS.Security.Groups
Types
All Types Classes
Icon | Type | Description
 | Group | Security group application.
 | GroupTemplate | Represents the template of a group which is used to create new groups.


Group Class

Group Class
Namespaces >> MSS.Security.Groups >> Group
Security group application.
Declaration Syntax
C#
public class Group
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AdditionalRoles | Gets the list of the additional roles.
 | AddRights(Item, Boolean) | Add rights to read or to modify (To be used in the mss's security field).
 | CanRead(Item) | Check whether group has a read to read an item
 | CanWrite(Item) | Check whether group has write access to an item.
 | ClearAssigment(Item) | Remove all security assignments on an item for the current group.
 | Editable | Gets a value indicating whether this group can be edited.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupTemplateName | Return the name of the related group template.
 | HasAdditionalRoles | True, if group has at least one additional role
 | Icon | Gets the group item the icon.
 | InnerRoleItem | Gets the RoleItem which is related to the current group.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the group name.
 | OperationIsAllowed(Item, ItemOperation) | Checks whether the operation is allowed for the current group.
 | RemoveReadRight(Item) | Remove all rights to the item for the current group (Inherited rights will stay).
 | RemoveRights(Item, ItemRights) | Remove rights to the item for the current group.
 | RemoveWriteRight(Item) | Remove all rights except for “read-write” to the item and set write access to “deny”.
 | Rename(String) | Change the name of the group.
 | SiteContext | Gets the site context.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserIsAssigned(String) | Shows if a user belongs to current group
 | Users | Gets the users.
Inheritance Hierarchy
Object
Group

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdditionalRoles Property

AdditionalRoles Property
Namespaces >> MSS.Security.Groups >> Group >> AdditionalRoles
Gets the list of the additional roles.
Declaration Syntax
C#
public ID[] AdditionalRoles{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddRights Method (item, writable)

AddRights Method (item, writable)
Namespaces >> MSS.Security.Groups >> Group >> AddRights(Item, Boolean)
Add rights to read or to modify (To be used in the mss's security field).
Declaration Syntax
C#
public void AddRights(
    Item item,
    bool writable
)
Parameters
item (Item)
The Item.
writable (Boolean)
True.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CanRead Method (item)

CanRead Method (item)
Namespaces >> MSS.Security.Groups >> Group >> CanRead(Item)
Check whether group has a read to read an item
Declaration Syntax
C#
public bool CanRead(
    Item item
)
Parameters
item (Item)
Item
Return Value
True, if allowed, false otherwise

Assembly: MSS.Kernel (Module: MSS.Kernel)


CanWrite Method (item)

CanWrite Method (item)
Namespaces >> MSS.Security.Groups >> Group >> CanWrite(Item)
Check whether group has write access to an item.
Declaration Syntax
C#
public bool CanWrite(
    Item item
)
Parameters
item (Item)
The Item.
Return Value
True, if allowed, otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearAssigment Method (item)

ClearAssigment Method (item)
Namespaces >> MSS.Security.Groups >> Group >> ClearAssigment(Item)
Remove all security assignments on an item for the current group.
Declaration Syntax
C#
public void ClearAssigment(
    Item item
)
Parameters
item (Item)
The Item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Editable Property

Editable Property
Namespaces >> MSS.Security.Groups >> Group >> Editable
Gets a value indicating whether this group can be edited.
Declaration Syntax
C#
public bool Editable{ get;}
Value
True if the group can be edited; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GroupTemplateName Property

GroupTemplateName Property
Namespaces >> MSS.Security.Groups >> Group >> GroupTemplateName
Return the name of the related group template.
Declaration Syntax
C#
public string GroupTemplateName{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


HasAdditionalRoles Property

HasAdditionalRoles Property
Namespaces >> MSS.Security.Groups >> Group >> HasAdditionalRoles
True, if group has at least one additional role
Declaration Syntax
C#
public bool HasAdditionalRoles{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Icon Property

Icon Property
Namespaces >> MSS.Security.Groups >> Group >> Icon
Gets the group item the icon.
Declaration Syntax
C#
public string Icon{ get;}
Value
The icon.

Assembly: MSS.Kernel (Module: MSS.Kernel)


InnerRoleItem Property

InnerRoleItem Property
Namespaces >> MSS.Security.Groups >> Group >> InnerRoleItem
Gets the RoleItem which is related to the current group.
Declaration Syntax
C#
public RoleItem InnerRoleItem{ get;}
Value
The RoleItem.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Name Property

Name Property
Namespaces >> MSS.Security.Groups >> Group >> Name
Gets the group name.
Declaration Syntax
C#
public string Name{ get;}
Value
The Group name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


OperationIsAllowed Method (item, operation)

OperationIsAllowed Method (item, operation)
Namespaces >> MSS.Security.Groups >> Group >> OperationIsAllowed(Item, ItemOperation)
Checks whether the operation is allowed for the current group.
Declaration Syntax
C#
public bool OperationIsAllowed(
    Item item,
    ItemOperation operation
)
Parameters
item (Item)
The Item.
operation (ItemOperation)
Operation.
Return Value
True, if allowed, otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveReadRight Method (item)

RemoveReadRight Method (item)
Namespaces >> MSS.Security.Groups >> Group >> RemoveReadRight(Item)
Remove all rights to the item for the current group (Inherited rights will stay).
Declaration Syntax
C#
public void RemoveReadRight(
    Item item
)
Parameters
item (Item)
The Item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveRights Method (item, rights)

RemoveRights Method (item, rights)
Namespaces >> MSS.Security.Groups >> Group >> RemoveRights(Item, ItemRights)
Remove rights to the item for the current group.
Declaration Syntax
C#
public void RemoveRights(
    Item item,
    ItemRights rights
)
Parameters
item (Item)
The Item.
rights (ItemRights)
Rights to be removed.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveWriteRight Method (item)

RemoveWriteRight Method (item)
Namespaces >> MSS.Security.Groups >> Group >> RemoveWriteRight(Item)
Remove all rights except for “read-write” to the item and set write access to “deny”.
Declaration Syntax
C#
public void RemoveWriteRight(
    Item item
)
Parameters
item (Item)
The Item

Assembly: MSS.Kernel (Module: MSS.Kernel)


Rename Method (newName)

Rename Method (newName)
Namespaces >> MSS.Security.Groups >> Group >> Rename(String)
Change the name of the group.
Declaration Syntax
C#
public void Rename(
    string newName
)
Parameters
newName (String)
The group’s new name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContext Property

SiteContext Property
Namespaces >> MSS.Security.Groups >> Group >> SiteContext
Gets the site context.
Declaration Syntax
C#
public SiteContext SiteContext{ get;}
Value
The site context.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserIsAssigned Method (name)

UserIsAssigned Method (name)
Namespaces >> MSS.Security.Groups >> Group >> UserIsAssigned(String)
Shows if a user belongs to current group
Declaration Syntax
C#
public bool UserIsAssigned(
    string name
)
Parameters
name (String)
The name of a user
Return Value
True, if the user belongs to the group, otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Users Property

Users Property
Namespaces >> MSS.Security.Groups >> Group >> Users
Gets the users.
Declaration Syntax
C#
public User[] Users{ get;}
Value
The users.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GroupTemplate Class

GroupTemplate Class
Namespaces >> MSS.Security.Groups >> GroupTemplate
Represents the template of a group which is used to create new groups.
Declaration Syntax
C#
public class GroupTemplate : EntityBase
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AdditionalRoles | Gets the additional roles.
 | AlternativeName | Gets the group's alternative name.
 | CanBeDuplicated | Defines whether more than one group can have that GroupTemplate for one site.
 | CopyRightsFrom | Gets the group from which the rights for a new group will be duplicated.
 | Database | Gets the database. (Inherited from EntityBase.)
 | Editable | Gets a value indicating whether this Group is editable.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalUsers | Gets the global users.
 | Icon | Gets group item the icon.
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the group name.
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | GroupTemplate

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdditionalRoles Property

AdditionalRoles Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> AdditionalRoles
Gets the additional roles.
Declaration Syntax
C#
public ID[] AdditionalRoles{ get;}
Value
The additional roles.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AlternativeName Property

AlternativeName Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> AlternativeName
Gets the group's alternative name.
Declaration Syntax
C#
public string AlternativeName{ get;}
Value
The group’s alternative name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CanBeDuplicated Property

CanBeDuplicated Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> CanBeDuplicated
Defines whether more than one group can have that GroupTemplate for one site.
Declaration Syntax
C#
public bool CanBeDuplicated{ get;}
Value
True, if more than one group can have that GroupTemplate for one site; otherwise false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CopyRightsFrom Property

CopyRightsFrom Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> CopyRightsFrom
Gets the group from which the rights for a new group will be duplicated.
Declaration Syntax
C#
public ID CopyRightsFrom{ get;}
Value
The ID of the group from which the rights for a new group will be duplicated. Can be equal to ID.Null.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Editable Property

Editable Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> Editable
Gets a value indicating whether this Group is editable.
Declaration Syntax
C#
public bool Editable{ get;}
Value
True if the Group editable; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalUsers Property

GlobalUsers Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> GlobalUsers
Gets the global users.
Declaration Syntax
C#
public ID[] GlobalUsers{ get;}
Value
The global users.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Icon Property

Icon Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> Icon
Gets group item the icon.
Declaration Syntax
C#
public string Icon{ get;}
Value
The icon.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Name Property

Name Property
Namespaces >> MSS.Security.Groups >> GroupTemplate >> Name
Gets the group name.
Declaration Syntax
C#
public string Name{ get;}
Value
The Group name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Security.Users Namespace

MSS.Security.Users Namespace
Namespaces >> MSS.Security.Users
Declaration Syntax
C#
namespace MSS.Security.Users
Types
All Types Classes Enumerations
Icon | Type | Description
 | User..::LoginResult | The result of logging in to the MSS.
 | User..::LoginResult..::ResultCode | Login result codes enumeration.
 | User | Sitecore user application.


User.LoginResult Class

User..::LoginResult Class
Namespaces >> MSS.Security.Users >> User >> User..::LoginResult
The result of logging in to the MSS.
Declaration Syntax
C#
public class LoginResult
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | User..::LoginResultUser..::LoginResultNew(User..::LoginResult..::ResultCode, Nullable<(Of <DomainAccessResult>)>) | Initializes a new instance of the User..::LoginResult class.
 | User..::LoginResultUser..::LoginResultNew(DomainAccessResult) | Initializes a new instance of the User..::LoginResult class.
 | DomainAccessResult |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDescription()() | Gets the description of ResultCode which should be showed on the frontend site.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
User..::LoginResult

Assembly: MSS.Kernel (Module: MSS.Kernel)


User.LoginResult Constructor

User..::LoginResult Constructor
Namespaces >> MSS.Security.Users >> User..::LoginResult >> User..::LoginResultUser..::LoginResultNew()()
Members
Icon | Member | Description
 | User..::LoginResultUser..::LoginResultNew(User..::LoginResult..::ResultCode, Nullable<(Of <DomainAccessResult>)>) | Initializes a new instance of the User..::LoginResult class.
 | User..::LoginResultUser..::LoginResultNew(DomainAccessResult) | Initializes a new instance of the User..::LoginResult class.

Assembly: MSS.Kernel (Module: MSS.Kernel)


User.LoginResult Constructor (result, domainAccessResult)

User..::LoginResult Constructor (result, domainAccessResult)
Namespaces >> MSS.Security.Users >> User..::LoginResult >> User..::LoginResultUser..::LoginResultNew(User..::LoginResult..::ResultCode, Nullable<(Of <DomainAccessResult>)>)
Initializes a new instance of the User..::LoginResult class.
Declaration Syntax
C#
public LoginResult(
    User.User..::LoginResult.User..::LoginResult..::ResultCode result,
    Nullable<DomainAccessResult> domainAccessResult
)
Parameters
result (User..::LoginResult..::ResultCode)
The result.
domainAccessResult (Nullable <(Of <DomainAccessResult>)>)
The domain access result.

Assembly: MSS.Kernel (Module: MSS.Kernel)


User.LoginResult Constructor (domainAccessResult)

User..::LoginResult Constructor (domainAccessResult)
Namespaces >> MSS.Security.Users >> User..::LoginResult >> User..::LoginResultUser..::LoginResultNew(DomainAccessResult)
Initializes a new instance of the User..::LoginResult class.
Declaration Syntax
C#
public LoginResult(
    DomainAccessResult domainAccessResult
)
Parameters
domainAccessResult (DomainAccessResult)
The domain access result.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DomainAccessResult Field

DomainAccessResult Field
Namespaces >> MSS.Security.Users >> User..::LoginResult >> DomainAccessResult
Declaration Syntax
C#
public readonly Nullable<DomainAccessResult> DomainAccessResult

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetDescription Method

GetDescription Method
Namespaces >> MSS.Security.Users >> User..::LoginResult >> GetDescription()()
Gets the description of ResultCode which should be showed on the frontend site.
Declaration Syntax
C#
public string GetDescription()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Result Field

Result Field
Namespaces >> MSS.Security.Users >> User..::LoginResult >> Result
Declaration Syntax
C#
public readonly User.User..::LoginResult.User..::LoginResult..::ResultCode Result

Assembly: MSS.Kernel (Module: MSS.Kernel)


User.LoginResult.ResultCode Enumeration

User..::LoginResult..::ResultCode Enumeration
Namespaces >> MSS.Security.Users >> User..::LoginResult >> User..::LoginResult..::ResultCode
Login result codes enumeration.
Declaration Syntax
C#
public enum ResultCode
Members
Member | Description
Failed |
Success |
NotEnoughRights |

Assembly: MSS.Kernel (Module: MSS.Kernel)


User Class

User Class
Namespaces >> MSS.Security.Users >> User
Sitecore user application.
Declaration Syntax
C#
public class User
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ChangePassword(String) | Changes the user password.
 | Editable |
 | Email | Gets or sets the users email.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Fullname | Gets or sets the users full name.
 | GetGlobalUsers()() | Gets the list of the global users .
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalName(String, String%) | Gets user's local name.
 | GetSiteId(String) | If userName belongs to a site this method will return site's siteId otherwise they will return null value
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerUserItem | Gets the inner user item.
 | IsLocalUser | Indicated whether the user is a local user
 | LocalName | Gets the local name of the user.
 | Login(UserItem) | Logs the user in to the specified user.
 | Login(String, String) | Logs the user in to the site using a user name and a password.
 | LoginToSite(String, String, Domain) | Logs the user in to the domain. If we are in the front end and user hasn't rights to read the context site the user won't be logged in.
 | Logout(Domain) | Logs the user out of the specified domain.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()() | (Overrides Object.ToString()().)
 | UserIsGlobal(String) | Indicates whether we are working with global user
 | UserIsLocalUser(String) | Indicates whether the user belongs to a site.
Inheritance Hierarchy
Object
User

Assembly: MSS.Kernel (Module: MSS.Kernel)


ChangePassword Method (password)

ChangePassword Method (password)
Namespaces >> MSS.Security.Users >> User >> ChangePassword(String)
Changes the user password.
Declaration Syntax
C#
public void ChangePassword(
    string password
)
Parameters
password (String)
The password.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Editable Property

Editable Property
Namespaces >> MSS.Security.Users >> User >> Editable
Declaration Syntax
C#
public bool Editable{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Email Property

Email Property
Namespaces >> MSS.Security.Users >> User >> Email
Gets or sets the users email.
Declaration Syntax
C#
public string Email{ get; set;}
Value
The users email.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Fullname Property

Fullname Property
Namespaces >> MSS.Security.Users >> User >> Fullname
Gets or sets the users full name.
Declaration Syntax
C#
public string Fullname{ get; set;}
Value
The users full name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalUsers Method

GetGlobalUsers Method
Namespaces >> MSS.Security.Users >> User >> GetGlobalUsers()()
Gets the list of the global users .
Declaration Syntax
C#
public static string[] GetGlobalUsers()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalName Method (name, localName)

GetLocalName Method (name, localName)
Namespaces >> MSS.Security.Users >> User >> GetLocalName(String, String%)
Gets user's local name.
Declaration Syntax
C#
public static bool GetLocalName(
    string name,
    ref string localName
)
Parameters
name (String)
User name
localName (String %)
Local name
Return Value
False if user doesn't belong to any site

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteId Method (userName)

GetSiteId Method (userName)
Namespaces >> MSS.Security.Users >> User >> GetSiteId(String)
If userName belongs to a site this method will return site's siteId otherwise they will return null value
Declaration Syntax
C#
public static string GetSiteId(
    string userName
)
Parameters
userName (String)
User name
Return Value
SiteId, or null in the case if user isn't a local user

Assembly: MSS.Kernel (Module: MSS.Kernel)


InnerUserItem Property

InnerUserItem Property
Namespaces >> MSS.Security.Users >> User >> InnerUserItem
Gets the inner user item.
Declaration Syntax
C#
public UserItem InnerUserItem{ get;}
Value
The inner user item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalUser Property

IsLocalUser Property
Namespaces >> MSS.Security.Users >> User >> IsLocalUser
Indicated whether the user is a local user
Declaration Syntax
C#
public bool IsLocalUser{ get;}
Value
true if the user is local user; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LocalName Property

LocalName Property
Namespaces >> MSS.Security.Users >> User >> LocalName
Gets the local name of the user.
Declaration Syntax
C#
public string LocalName{ get;}
Value
The name local name of the user.
Exceptions
Exception | Condition
ApplicationException | If user isn't a local user

Assembly: MSS.Kernel (Module: MSS.Kernel)


Login Method

Login Method
Namespaces >> MSS.Security.Users >> User >> Login()()
Members
Icon | Member | Description
 | Login(UserItem) | Logs the user in to the specified user.
 | Login(String, String) | Logs the user in to the site using a user name and a password.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Login Method (user)

Login Method (user)
Namespaces >> MSS.Security.Users >> User >> Login(UserItem)
Logs the user in to the specified user.
Declaration Syntax
C#
public static DomainAccessResult Login(
    UserItem user
)
Parameters
user (UserItem)
The user.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Login Method (userName, password)

Login Method (userName, password)
Namespaces >> MSS.Security.Users >> User >> Login(String, String)
Logs the user in to the site using a user name and a password.
Declaration Syntax
C#
public static DomainAccessResult Login(
    string userName,
    string password
)
Parameters
userName (String)
Name of the user.
password (String)
The password.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoginToSite Method (userName, password, domain)

LoginToSite Method (userName, password, domain)
Namespaces >> MSS.Security.Users >> User >> LoginToSite(String, String, Domain)
Logs the user in to the domain. If we are in the front end and user hasn't rights to read the context site the user won't be logged in.
Declaration Syntax
C#
public static User.User..::LoginResult LoginToSite(
    string userName,
    string password,
    Domain domain
)
Parameters
userName (String)
User name
password (String)
Password
domain (Domain)
Security domain

Assembly: MSS.Kernel (Module: MSS.Kernel)


Logout Method (domain)

Logout Method (domain)
Namespaces >> MSS.Security.Users >> User >> Logout(Domain)
Logs the user out of the specified domain.
Declaration Syntax
C#
public static DomainAccessResult Logout(
    Domain domain
)
Parameters
domain (Domain)
The domain.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Name Property

Name Property
Namespaces >> MSS.Security.Users >> User >> Name
Gets the name.
Declaration Syntax
C#
public string Name{ get;}
Value
The name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToString Method

ToString Method
Namespaces >> MSS.Security.Users >> User >> ToString()()
Declaration Syntax
C#
public override string ToString()

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserIsGlobal Method (userName)

UserIsGlobal Method (userName)
Namespaces >> MSS.Security.Users >> User >> UserIsGlobal(String)
Indicates whether we are working with global user
Declaration Syntax
C#
public static bool UserIsGlobal(
    string userName
)
Parameters
userName (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserIsLocalUser Method (userName)

UserIsLocalUser Method (userName)
Namespaces >> MSS.Security.Users >> User >> UserIsLocalUser(String)
Indicates whether the user belongs to a site.
Declaration Syntax
C#
public static bool UserIsLocalUser(
    string userName
)
Parameters
userName (String)
User name
Return Value
True, if user belongs to site; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Servers Namespace

MSS.Servers Namespace
Namespaces >> MSS.Servers
Declaration Syntax
C#
namespace MSS.Servers
Types
All Types Classes
Icon | Type | Description
 | Server | Represents a server
 | ServerManager | Manages the servers along with the current running server


Server Class

Server Class
Namespaces >> MSS.Servers >> Server
Represents a server
Declaration Syntax
C#
public class Server
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServerServerNew(String) | Initializes a new instance of the Server class.
 | CacheManager | Gets the cache manager.
 | Database | Gets the MSS database utility.
 | Device | Gets the device.
 | Domain | Gets the domain
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalDictionary | Gets the global dictionary.
 | IISManager | Gets the IIS manager.
 | LicenseManager | Gets the license manager.
 | Load()() | Loads the server.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleManager | Gets the module manager.
 | Name | Gets the server name.
 | SecurityDomainName | Gets the name of the security domain.
 | Settings | Gets the settings.
 | Sites | Gets the site context manager.
 | SiteTypes | Gets the site types.
 | SkinPackages | Gets the skin package manager.
 | SystemDictionary | Gets the system dictionary.
 | ToString()() | Returns a String that represents the current Object. (Overrides Object.ToString()().)
 | UpdateIISBindings()() | Updates the IIS bindings.
Inheritance Hierarchy
Object
Server

Assembly: MSS.Kernel (Module: MSS.Kernel)


Server Constructor (name)

Server Constructor (name)
Namespaces >> MSS.Servers >> Server >> ServerServerNew(String)
Initializes a new instance of the Server class.
Declaration Syntax
C#
public Server(
    string name
)
Parameters
name (String)
The name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CacheManager Property

CacheManager Property
Namespaces >> MSS.Servers >> Server >> CacheManager
Gets the cache manager.
Declaration Syntax
C#
public CacheManager<ID> CacheManager{ get;}
Value
The cache manager.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Database Property

Database Property
Namespaces >> MSS.Servers >> Server >> Database
Gets the MSS database utility.
Declaration Syntax
C#
public Database Database{ get;}
Value
The MSS database utility.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Device Property

Device Property
Namespaces >> MSS.Servers >> Server >> Device
Gets the device.
Declaration Syntax
C#
public DeviceItem Device{ get;}
Value
The device.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Domain Property

Domain Property
Namespaces >> MSS.Servers >> Server >> Domain
Gets the domain
Declaration Syntax
C#
public Domain Domain{ get;}
Value
Sitecore domain.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalDictionary Property

GlobalDictionary Property
Namespaces >> MSS.Servers >> Server >> GlobalDictionary
Gets the global dictionary.
Declaration Syntax
C#
public Dictionary GlobalDictionary{ get;}
Value
The global dictionary.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IISManager Property

IISManager Property
Namespaces >> MSS.Servers >> Server >> IISManager
Gets the IIS manager.
Declaration Syntax
C#
public IISManager IISManager{ get;}
Value
The IIS manager.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LicenseManager Property

LicenseManager Property
Namespaces >> MSS.Servers >> Server >> LicenseManager
Gets the license manager.
Declaration Syntax
C#
public LicenseManager LicenseManager{ get;}
Value
The license manager.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Load Method

Load Method
Namespaces >> MSS.Servers >> Server >> Load()()
Loads the server.
Declaration Syntax
C#
public void Load()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModuleManager Property

ModuleManager Property
Namespaces >> MSS.Servers >> Server >> ModuleManager
Gets the module manager.
Declaration Syntax
C#
public ModuleManager ModuleManager{ get;}
Value
The module manager.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Name Property

Name Property
Namespaces >> MSS.Servers >> Server >> Name
Gets the server name.
Declaration Syntax
C#
public string Name{ get;}
Value
The server name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityDomainName Property

SecurityDomainName Property
Namespaces >> MSS.Servers >> Server >> SecurityDomainName
Gets the name of the security domain.
Declaration Syntax
C#
public static string SecurityDomainName{ get;}
Value
The name of the security domain.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Settings Property

Settings Property
Namespaces >> MSS.Servers >> Server >> Settings
Gets the settings.
Declaration Syntax
C#
public Settings Settings{ get;}
Value
The settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Sites Property

Sites Property
Namespaces >> MSS.Servers >> Server >> Sites
Gets the site context manager.
Declaration Syntax
C#
public SiteContextManager Sites{ get;}
Value
The site context manager.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypes Property

SiteTypes Property
Namespaces >> MSS.Servers >> Server >> SiteTypes
Gets the site types.
Declaration Syntax
C#
public SiteTypeManager SiteTypes{ get;}
Value
The site types.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackages Property

SkinPackages Property
Namespaces >> MSS.Servers >> Server >> SkinPackages
Gets the skin package manager.
Declaration Syntax
C#
public SkinPackageManager SkinPackages{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SystemDictionary Property

SystemDictionary Property
Namespaces >> MSS.Servers >> Server >> SystemDictionary
Gets the system dictionary.
Declaration Syntax
C#
public Dictionary SystemDictionary{ get;}
Value
The system dictionary.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToString Method

ToString Method
Namespaces >> MSS.Servers >> Server >> ToString()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UpdateIISBindings Method

UpdateIISBindings Method
Namespaces >> MSS.Servers >> Server >> UpdateIISBindings()()
Updates the IIS bindings.
Declaration Syntax
C#
public void UpdateIISBindings()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ServerManager Class

ServerManager Class
Namespaces >> MSS.Servers >> ServerManager
Manages the servers along with the current running server
Declaration Syntax
C#
public class ServerManager : Singleton<ServerManager>, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServerManagerServerManagerNew()() |
 | Current | Gets the current server.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()() | Returns an enumerator that iterates through a collection.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([String])] | Gets the Server with the specified name.
 | Load()() | Loads the servers.
 | Local | Gets the local server.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Singleton <(Of <ServerManager>)>
 |  | ServerManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


ServerManager Constructor

ServerManager Constructor
Namespaces >> MSS.Servers >> ServerManager >> ServerManagerServerManagerNew()()
Declaration Syntax
C#
protected ServerManager()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Current Property

Current Property
Namespaces >> MSS.Servers >> ServerManager >> Current
Gets the current server.
Declaration Syntax
C#
public Server Current{ get;}
Value
The current server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEnumerator Method

GetEnumerator Method
Namespaces >> MSS.Servers >> ServerManager >> GetEnumerator()()
Returns an enumerator that iterates through a collection.
Declaration Syntax
C#
public IEnumerator GetEnumerator()
Return Value
An IEnumerator object that can be used to iterate through the collection.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property (name)

Item Property (name)
Namespaces >> MSS.Servers >> ServerManager >> Item[([String])]
Gets the Server with the specified name.
Declaration Syntax
C#
public Server this[
    string name
]{ get;}
Parameters
name (String)
Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Load Method

Load Method
Namespaces >> MSS.Servers >> ServerManager >> Load()()
Loads the servers.
Declaration Syntax
C#
public void Load()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Local Property

Local Property
Namespaces >> MSS.Servers >> ServerManager >> Local
Gets the local server.
Declaration Syntax
C#
public Server Local{ get;}
Value
The local.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Services Namespace

MSS.Services Namespace
Namespaces >> MSS.Services
Declaration Syntax
C#
namespace MSS.Services
Types
All Types Classes
Icon | Type | Description
 | MaintenanceService | Maintenance service.


MaintenanceService Class

MaintenanceService Class
Namespaces >> MSS.Services >> MaintenanceService
Maintenance service.
Declaration Syntax
C#
[WebServiceAttribute]
public class MaintenanceService : WebService
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaintenanceServiceMaintenanceServiceNew()() |
 | Application | Gets the application object for the current HTTP request. (Inherited from WebService.)
 | BackupSite(String, String, Credentials) | Site backup application.
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Context | Gets the ASP.NET HttpContext for the current request, which encapsulates all HTTP-specific context used by the HTTP server to process Web requests. (Inherited from WebService.)
 | CreateSite(String, String, String, String, String, String, Boolean, Credentials) | Creates the site.
 | DeleteSite(String, Credentials) | Deletes the site.
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | Dispose()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | Finalize()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | GeneratePackage(String, String, Credentials) | Generates the package.
 | GetAvailablePackages(Credentials) | Gets the available packages.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetSites(String, Credentials) | Gets the sites keys.
 | GetSiteStatus(String, Credentials) | Gets the site status.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstallPackage(String, Credentials) | Installs the package.
 | InstallPackage(String, BehaviourOptions, BehaviourOptions, Credentials) | Installs the package.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RestoreSite(String, Credentials) | Restores the site.
 | Server | Gets the HttpServerUtility for the current request. (Inherited from WebService.)
 | Session | Gets the HttpSessionState instance for the current request. (Inherited from WebService.)
 | SetSiteStatus(String, SiteContext..::SiteStatus, Credentials) | Sets the site status.
 | Site | Gets or sets the site of the component. (Inherited from MarshalByValueComponent.)
 | SiteExist(String, Credentials) | Returns whether Sites exist.
 | SoapVersion | Gets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from WebService.)
 | ToString()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | User | Gets the ASP.NET server User object. Can be used to authenticate whether a user is authorized to execute the request. (Inherited from WebService.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | WebService
 |  |  | MaintenanceService

Assembly: MSS.Services (Module: MSS.Services)


MaintenanceService Constructor

MaintenanceService Constructor
Namespaces >> MSS.Services >> MaintenanceService >> MaintenanceServiceMaintenanceServiceNew()()
Declaration Syntax
C#
public MaintenanceService()

Assembly: MSS.Services (Module: MSS.Services)


BackupSite Method (siteID, backupName, credentials)

BackupSite Method (siteID, backupName, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> BackupSite(String, String, Credentials)
Site backup application.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public void BackupSite(
    string siteID,
    string backupName,
    Credentials credentials
)
Parameters
siteID (String)
The site ID.
backupName (String)
Name of the backup.
credentials (Credentials)
The credentials.

Assembly: MSS.Services (Module: MSS.Services)


CreateSite Method (siteTypeID, siteID, hostName, administratorInitials, administratorEmail, defaultLanguage, waitForPublish, credentials)

CreateSite Method (siteTypeID, siteID, hostName, administratorInitials, administratorEmail, defaultLanguage, waitForPublish, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> CreateSite(String, String, String, String, String, String, Boolean, Credentials)
Creates the site.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public string CreateSite(
    string siteTypeID,
    string siteID,
    string hostName,
    string administratorInitials,
    string administratorEmail,
    string defaultLanguage,
    bool waitForPublish,
    Credentials credentials
)
Parameters
siteTypeID (String)
The site type ID.
siteID (String)
The site ID.
hostName (String)
Name of the host.
administratorInitials (String)
The administrator's initials.
administratorEmail (String)
The administrator's email.
defaultLanguage (String)
The default language.
waitForPublish (Boolean)
if set to true [wait for publish].
credentials (Credentials)
The credentials.

Assembly: MSS.Services (Module: MSS.Services)


DeleteSite Method (siteID, credentials)

DeleteSite Method (siteID, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> DeleteSite(String, Credentials)
Deletes the site.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public void DeleteSite(
    string siteID,
    Credentials credentials
)
Parameters
siteID (String)
The site ID.
credentials (Credentials)
The credentials.

Assembly: MSS.Services (Module: MSS.Services)


GeneratePackage Method (solutionFile, packageFile, credentials)

GeneratePackage Method (solutionFile, packageFile, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> GeneratePackage(String, String, Credentials)
Generates the package.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public void GeneratePackage(
    string solutionFile,
    string packageFile,
    Credentials credentials
)
Parameters
solutionFile (String)
The solution file.
packageFile (String)
The package file.
credentials (Credentials)
The credentials.

Assembly: MSS.Services (Module: MSS.Services)


GetAvailablePackages Method (credentials)

GetAvailablePackages Method (credentials)
Namespaces >> MSS.Services >> MaintenanceService >> GetAvailablePackages(Credentials)
Gets the available packages.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public string[] GetAvailablePackages(
    Credentials credentials
)
Parameters
credentials (Credentials)
The credentials.
Return Value
The available packages.

Assembly: MSS.Services (Module: MSS.Services)


GetSites Method (databaseName, credentials)

GetSites Method (databaseName, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> GetSites(String, Credentials)
Gets the sites keys.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public string[] GetSites(
    string databaseName,
    Credentials credentials
)
Parameters
databaseName (String)
Name of the database.
credentials (Credentials)
The credentials.
Return Value
The sites keys.

Assembly: MSS.Services (Module: MSS.Services)


GetSiteStatus Method (siteID, credentials)

GetSiteStatus Method (siteID, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> GetSiteStatus(String, Credentials)
Gets the site status.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public SiteContext.SiteContext..::SiteStatus GetSiteStatus(
    string siteID,
    Credentials credentials
)
Parameters
siteID (String)
The site ID.
credentials (Credentials)
The credentials.
Return Value
The site status.

Assembly: MSS.Services (Module: MSS.Services)


InstallPackage Method

InstallPackage Method
Namespaces >> MSS.Services >> MaintenanceService >> InstallPackage()()
Members
Icon | Member | Description
 | InstallPackage(String, Credentials) | Installs the package.
 | InstallPackage(String, BehaviourOptions, BehaviourOptions, Credentials) | Installs the package.

Assembly: MSS.Services (Module: MSS.Services)


InstallPackage Method (packageFileName, behaviorItemOption, behaviorFileOption, credentials)

InstallPackage Method (packageFileName, behaviorItemOption, behaviorFileOption, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> InstallPackage(String, BehaviourOptions, BehaviourOptions, Credentials)
Installs the package.
Declaration Syntax
C#
public string InstallPackage(
    string packageFileName,
    BehaviourOptions behaviorItemOption,
    BehaviourOptions behaviorFileOption,
    Credentials credentials
)
Parameters
packageFileName (String)
Name of the package file.
behaviorItemOption (BehaviourOptions)
The behaviour item option.
behaviorFileOption (BehaviourOptions)
The behaviour file option.
credentials (Credentials)
The credentials.
Return Value

Assembly: MSS.Services (Module: MSS.Services)


InstallPackage Method (packageFileName, credentials)

InstallPackage Method (packageFileName, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> InstallPackage(String, Credentials)
Installs the package.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public string InstallPackage(
    string packageFileName,
    Credentials credentials
)
Parameters
packageFileName (String)
Name of the package file.
credentials (Credentials)
The credentials.
Return Value

Assembly: MSS.Services (Module: MSS.Services)


RestoreSite Method (backupName, credentials)

RestoreSite Method (backupName, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> RestoreSite(String, Credentials)
Restores the site.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public void RestoreSite(
    string backupName,
    Credentials credentials
)
Parameters
backupName (String)
Name of the backup.
credentials (Credentials)
The credentials.

Assembly: MSS.Services (Module: MSS.Services)


SetSiteStatus Method (siteID, status, credentials)

SetSiteStatus Method (siteID, status, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> SetSiteStatus(String, SiteContext..::SiteStatus, Credentials)
Sets the site status.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public void SetSiteStatus(
    string siteID,
    SiteContext.SiteContext..::SiteStatus status,
    Credentials credentials
)
Parameters
siteID (String)
The site ID.
status (SiteContext..::SiteStatus)
The status.
credentials (Credentials)
The credentials.

Assembly: MSS.Services (Module: MSS.Services)


SiteExist Method (siteID, credentials)

SiteExist Method (siteID, credentials)
Namespaces >> MSS.Services >> MaintenanceService >> SiteExist(String, Credentials)
Returns whether Sites exist.
Declaration Syntax
C#
[WebMethodAttribute(EnableSession = true)]
public bool SiteExist(
    string siteID,
    Credentials credentials
)
Parameters
siteID (String)
The site ID.
credentials (Credentials)
The credentials.
Return Value
True if the site exists; otherwise, false.

Assembly: MSS.Services (Module: MSS.Services)


MSS.Services.Installer Namespace

MSS.Services.Installer Namespace
Namespaces >> MSS.Services.Installer
Declaration Syntax
C#
namespace MSS.Services.Installer
Types
All Types Classes
Icon | Type | Description
 | Installer | Installer helper class


Installer Class

Installer Class
Namespaces >> MSS.Services.Installer >> Installer
Installer helper class
Declaration Syntax
C#
public class Installer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InstallerInstallerNew()() |
 | CreateDefaultWorkingContext()() | Creates the default working context.
 | CreateInstallerSink()() | Creates the installer sink.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GeneratePackage(String, String, Credentials) | Generates the package.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstallPackage(String) | Installs the package.
 | InstallPackage(String, BehaviourOptions, BehaviourOptions) | Installs the package.
 | InstallPackage(String, IProcessingContext, BehaviourOptions, BehaviourOptions) | Installs the package.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Installer

Assembly: MSS.Services (Module: MSS.Services)


Installer Constructor

Installer Constructor
Namespaces >> MSS.Services.Installer >> Installer >> InstallerInstallerNew()()
Declaration Syntax
C#
public Installer()

Assembly: MSS.Services (Module: MSS.Services)


CreateDefaultWorkingContext Method

CreateDefaultWorkingContext Method
Namespaces >> MSS.Services.Installer >> Installer >> CreateDefaultWorkingContext()()
Creates the default working context.
Declaration Syntax
C#
public static IProcessingContext CreateDefaultWorkingContext()
Return Value

Assembly: MSS.Services (Module: MSS.Services)


CreateInstallerSink Method

CreateInstallerSink Method
Namespaces >> MSS.Services.Installer >> Installer >> CreateInstallerSink()()
Creates the installer sink.
Declaration Syntax
C#
public static ISink<PackageEntry> CreateInstallerSink()
Return Value

Assembly: MSS.Services (Module: MSS.Services)


GeneratePackage Method (solutionFile, packageFile, credentials)

GeneratePackage Method (solutionFile, packageFile, credentials)
Namespaces >> MSS.Services.Installer >> Installer >> GeneratePackage(String, String, Credentials)
Generates the package.
Declaration Syntax
C#
public void GeneratePackage(
    string solutionFile,
    string packageFile,
    Credentials credentials
)
Parameters
solutionFile (String)
The solution file.
packageFile (String)
The package file.
credentials (Credentials)
The credentials.

Assembly: MSS.Services (Module: MSS.Services)


InstallPackage Method

InstallPackage Method
Namespaces >> MSS.Services.Installer >> Installer >> InstallPackage()()
Members
Icon | Member | Description
 | InstallPackage(String) | Installs the package.
 | InstallPackage(String, BehaviourOptions, BehaviourOptions) | Installs the package.
 | InstallPackage(String, IProcessingContext, BehaviourOptions, BehaviourOptions) | Installs the package.

Assembly: MSS.Services (Module: MSS.Services)


InstallPackage Method (path)

InstallPackage Method (path)
Namespaces >> MSS.Services.Installer >> Installer >> InstallPackage(String)
Installs the package.
Declaration Syntax
C#
public string InstallPackage(
    string path
)
Parameters
path (String)
The path.
Return Value

Assembly: MSS.Services (Module: MSS.Services)


InstallPackage Method (path, context, defaultItemOptions, defaultFileOptions)

InstallPackage Method (path, context, defaultItemOptions, defaultFileOptions)
Namespaces >> MSS.Services.Installer >> Installer >> InstallPackage(String, IProcessingContext, BehaviourOptions, BehaviourOptions)
Installs the package.
Declaration Syntax
C#
public string InstallPackage(
    string path,
    IProcessingContext context,
    BehaviourOptions defaultItemOptions,
    BehaviourOptions defaultFileOptions
)
Parameters
path (String)
The path.
context (IProcessingContext)
The context.
defaultItemOptions (BehaviourOptions)
The default item options.
defaultFileOptions (BehaviourOptions)
The default file options.
Return Value

Assembly: MSS.Services (Module: MSS.Services)


InstallPackage Method (path, defaultItemOptions, defaultFileOptions)

InstallPackage Method (path, defaultItemOptions, defaultFileOptions)
Namespaces >> MSS.Services.Installer >> Installer >> InstallPackage(String, BehaviourOptions, BehaviourOptions)
Installs the package.
Declaration Syntax
C#
public string InstallPackage(
    string path,
    BehaviourOptions defaultItemOptions,
    BehaviourOptions defaultFileOptions
)
Parameters
path (String)
The path.
defaultItemOptions (BehaviourOptions)
The default item options.
defaultFileOptions (BehaviourOptions)
The default file options.
Return Value

Assembly: MSS.Services (Module: MSS.Services)


MSS.Services.Installer.Output Namespace

MSS.Services.Installer.Output Namespace
Namespaces >> MSS.Services.Installer.Output
Declaration Syntax
C#
namespace MSS.Services.Installer.Output
Types
All Types Classes
Icon | Type | Description
 | StringTaskOutput | Redirect task output to string


StringTaskOutput Class

StringTaskOutput Class
Namespaces >> MSS.Services.Installer.Output >> StringTaskOutput
Redirect task output to string
Declaration Syntax
C#
public class StringTaskOutput : ITaskOutput
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringTaskOutputStringTaskOutputNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OutputStream | Gets the task output.
 | PutMessage(String, array<Object>[]()) | Puts the message.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StringTaskOutput

Assembly: MSS.Services (Module: MSS.Services)


StringTaskOutput Constructor

StringTaskOutput Constructor
Namespaces >> MSS.Services.Installer.Output >> StringTaskOutput >> StringTaskOutputStringTaskOutputNew()()
Declaration Syntax
C#
public StringTaskOutput()

Assembly: MSS.Services (Module: MSS.Services)


OutputStream Property

OutputStream Property
Namespaces >> MSS.Services.Installer.Output >> StringTaskOutput >> OutputStream
Gets the task output.
Declaration Syntax
C#
public string OutputStream{ get;}
Value
The output stream.

Assembly: MSS.Services (Module: MSS.Services)


PutMessage Method (message, args)

PutMessage Method (message, args)
Namespaces >> MSS.Services.Installer.Output >> StringTaskOutput >> PutMessage(String, array<Object>[]())
Puts the message.
Declaration Syntax
C#
public void PutMessage(
    string message,
    params Object[] args
)
Parameters
message (String)
The message.
args (array< Object >[]())
The arguments.

Assembly: MSS.Services (Module: MSS.Services)


MSS.Services.Utils Namespace

MSS.Services.Utils Namespace
Namespaces >> MSS.Services.Utils
Declaration Syntax
C#
namespace MSS.Services.Utils
Types
All Types Classes
Icon | Type | Description
 | SecurityUtils | Security utilities.
 | ServiceUtils | Maintenance service utilities.


SecurityUtils Class

SecurityUtils Class
Namespaces >> MSS.Services.Utils >> SecurityUtils
Security utilities.
Declaration Syntax
C#
public static class SecurityUtils
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetVirtualUser()() | Gets the virtual user.
 | ValidateUser(Credentials) | Validates the user.
Inheritance Hierarchy
Object
SecurityUtils

Assembly: MSS.Services (Module: MSS.Services)


GetVirtualUser Method

GetVirtualUser Method
Namespaces >> MSS.Services.Utils >> SecurityUtils >> GetVirtualUser()()
Gets the virtual user.
Declaration Syntax
C#
public static UserItem GetVirtualUser()
Return Value
The virtual user.

Assembly: MSS.Services (Module: MSS.Services)


ValidateUser Method (credentials)

ValidateUser Method (credentials)
Namespaces >> MSS.Services.Utils >> SecurityUtils >> ValidateUser(Credentials)
Validates the user.
Declaration Syntax
C#
public static UserItem ValidateUser(
    Credentials credentials
)
Parameters
credentials (Credentials)
The credentials.
Return Value

Assembly: MSS.Services (Module: MSS.Services)


ServiceUtils Class

ServiceUtils Class
Namespaces >> MSS.Services.Utils >> ServiceUtils
Maintenance service utilities.
Declaration Syntax
C#
public static class ServiceUtils
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildSoapException(Exception) | Builds the SOAP exception.
Inheritance Hierarchy
Object
ServiceUtils

Assembly: MSS.Services (Module: MSS.Services)


BuildSoapException Method (ex)

BuildSoapException Method (ex)
Namespaces >> MSS.Services.Utils >> ServiceUtils >> BuildSoapException(Exception)
Builds the SOAP exception.
Declaration Syntax
C#
public static SoapException BuildSoapException(
    Exception ex
)
Parameters
ex (Exception)
The ex.
Return Value

Assembly: MSS.Services (Module: MSS.Services)


MSS.SettingsCollections Namespace

MSS.SettingsCollections Namespace
Namespaces >> MSS.SettingsCollections
Declaration Syntax
C#
namespace MSS.SettingsCollections
Types
All Types Classes
Icon | Type | Description
 | SettingsCollection | A collection of settings stored in the Sitecore content. This is used to store wizard settings, module settings and system settings pertaining to a site. The settings can be stored at multiple locations in the content. In the site context, site-type context or system context.


SettingsCollection Class

SettingsCollection Class
Namespaces >> MSS.SettingsCollections >> SettingsCollection
A collection of settings stored in the Sitecore content. This is used to store wizard settings, module settings and system settings pertaining to a site. The settings can be stored at multiple locations in the content. In the site context, site-type context or system context.
Declaration Syntax
C#
[SerializableAttribute]
public class SettingsCollection : ICacheable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()() | Clears all settings.
 | ClearSection(String) | Clears the section.
 | Clone()() | Makes a deep clone of the instance
 | Data | Obsolete.
 | Dirty | Gets a value indicating whether some settings have been changed but setting collection hasn't been saved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetData()() | Obsolete.
 | GetData(String) |
 | GetEntry(String) | Gets the setting collection by key.
 | GetEntry(String, String) | Gets a dictionary entry.
 | GetGlobalSettings(String) | Gets the global settings item.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalSettings()() | Gets the local settings item.
 | GetLocalSettings(String) | Gets the local settings item using a specific path.
 | GetSection(String) | Gets a section.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeSettings()() | Gets the type settings.
 | GetTypeSettings(String) | Gets the type settings item using a specific path.
 | Init()() | Initialises the SettingsCollection.
 | Init(String) | Initialises the SettingsCollection.
 | Item[([String])] | Gets or sets the String with the specified key.
 | LoadAbsoluteSettings(String) | Loads the absolute settings.
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings.
 | Loaded | Gets a value indicating whether the SettingCollection is loaded.
 | LoadSettings()() | Loads the settings.
 | LoadSettings(String) | Loads the settings.
 | LoadSettings(Item) | Loads the settings.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveSettings(Boolean) | Saves the settings.
 | SaveSettings(String) | Saves the settings using a specific path.
 | SaveSettings(String, Boolean) | Saves the settings.
 | SaveSettings(Item) | Saves the settings to the item.
 | SetData(StringDictionary) |
 | SetData(SettingsCollection) |
 | SetSection(String, StringDictionary) |
 | SetSetting(String, String, String) | Sets the setting.
 | Setting(String) | Gets the setting by a key.
 | Setting(String, String) | Gets the setting from a section by a key.
 | Setting(String, String, String) | Gets the setting from a section by a key.
 | ToInt(String) | Gets the int setting by a key.
 | ToInt(String, Int32) | Gets the int setting by a key.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updatedata(String) | Updatedatas the settings.
Inheritance Hierarchy
Object
 | SettingsCollection
 |  | SystemSettings
 |  | WizardSettings
 |  | ModuleSettings

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clear Method

Clear Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Clear()()
Clears all settings.
Declaration Syntax
C#
public virtual void Clear()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ClearSection Method (Section)

ClearSection Method (Section)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> ClearSection(String)
Clears the section.
Declaration Syntax
C#
public virtual void ClearSection(
    string Section
)
Parameters
Section (String)
The section.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Clone()()
Makes a deep clone of the instance
Declaration Syntax
C#
public virtual SettingsCollection Clone()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Data Property

Data Property
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Data
Declaration Syntax
C#
[ObsoleteAttribute("The property will be removed.")]
public virtual StringDictionary Data{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Dirty Property

Dirty Property
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Dirty
Gets a value indicating whether some settings have been changed but setting collection hasn't been saved.
Declaration Syntax
C#
public virtual bool Dirty{ get;}
Value
True if some settings have been changed but SettingCollection hasn't been saved; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetData Method

GetData Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetData()()
Members
Icon | Member | Description
 | GetData()() | Obsolete.
 | GetData(String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetData Method

GetData Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetData()()
Declaration Syntax
C#
[ObsoleteAttribute("The method will be removed.")]
public virtual StringDictionary GetData()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetData Method (Section)

GetData Method (Section)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetData(String)
Declaration Syntax
C#
public virtual StringDictionary GetData(
    string Section
)
Parameters
Section (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntry Method

GetEntry Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetEntry()()
Members
Icon | Member | Description
 | GetEntry(String) | Gets the setting collection by key.
 | GetEntry(String, String) | Gets a dictionary entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntry Method (Key)

GetEntry Method (Key)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetEntry(String)
Gets the setting collection by key.
Declaration Syntax
C#
protected virtual StringDictionary GetEntry(
    string Key
)
Parameters
Key (String)
The key.
Return Value
Setting collection which contain the specified key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntry Method (Section, Key)

GetEntry Method (Section, Key)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetEntry(String, String)
Gets a dictionary entry.
Declaration Syntax
C#
protected virtual StringDictionary GetEntry(
    string Section,
    string Key
)
Parameters
Section (String)
The section.
Key (String)
The key.
Return Value
Setting collection which contain the specified key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalSettings Method (Path)

GetGlobalSettings Method (Path)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetGlobalSettings(String)
Gets the global settings item.
Declaration Syntax
C#
protected virtual Item GetGlobalSettings(
    string Path
)
Parameters
Path (String)
The path.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalSettings Method

GetLocalSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetLocalSettings()()
Members
Icon | Member | Description
 | GetLocalSettings()() | Gets the local settings item.
 | GetLocalSettings(String) | Gets the local settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalSettings Method

GetLocalSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetLocalSettings()()
Gets the local settings item.
Declaration Syntax
C#
protected virtual Item GetLocalSettings()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalSettings Method (path)

GetLocalSettings Method (path)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetLocalSettings(String)
Gets the local settings item using a specific path.
Declaration Syntax
C#
protected virtual Item GetLocalSettings(
    string path
)
Parameters
path (String)
The path.
Return Value
The local settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSection Method (Section)

GetSection Method (Section)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetSection(String)
Gets a section.
Declaration Syntax
C#
protected virtual StringDictionary GetSection(
    string Section
)
Parameters
Section (String)
The section.
Return Value
The section.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTypeSettings Method

GetTypeSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetTypeSettings()()
Members
Icon | Member | Description
 | GetTypeSettings()() | Gets the type settings.
 | GetTypeSettings(String) | Gets the type settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTypeSettings Method

GetTypeSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetTypeSettings()()
Gets the type settings.
Declaration Syntax
C#
protected virtual Item GetTypeSettings()
Return Value
The type settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetTypeSettings Method (path)

GetTypeSettings Method (path)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> GetTypeSettings(String)
Gets the type settings item using a specific path.
Declaration Syntax
C#
protected virtual Item GetTypeSettings(
    string path
)
Parameters
path (String)
The path.
Return Value
The type settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Init Method

Init Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Init()()
Members
Icon | Member | Description
 | Init()() | Initialises the SettingsCollection.
 | Init(String) | Initialises the SettingsCollection.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Init Method

Init Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Init()()
Initialises the SettingsCollection.
Declaration Syntax
C#
public virtual void Init()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Init Method (Path)

Init Method (Path)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Init(String)
Initialises the SettingsCollection.
Declaration Syntax
C#
public virtual void Init(
    string Path
)
Parameters
Path (String)
The path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property (Key)

Item Property (Key)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Item[([String])]
Gets or sets the String with the specified key.
Declaration Syntax
C#
public virtual string this[
    string Key
]{ get; set;}
Parameters
Key (String)
Value
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadAbsoluteSettings Method

LoadAbsoluteSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> LoadAbsoluteSettings()()
Members
Icon | Member | Description
 | LoadAbsoluteSettings(String) | Loads the absolute settings.
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadAbsoluteSettings Method (path)

LoadAbsoluteSettings Method (path)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> LoadAbsoluteSettings(String)
Loads the absolute settings.
Declaration Syntax
C#
public virtual void LoadAbsoluteSettings(
    string path
)
Parameters
path (String)
A full path to the item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadAbsoluteSettings Method (Section, Path, OverwriteBlank)

LoadAbsoluteSettings Method (Section, Path, OverwriteBlank)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> LoadAbsoluteSettings(String, String, Boolean)
Loads the absolute settings.
Declaration Syntax
C#
public virtual void LoadAbsoluteSettings(
    string Section,
    string Path,
    bool OverwriteBlank
)
Parameters
Section (String)
The section.
Path (String)
The path.
OverwriteBlank (Boolean)
if set to true overwrite blank setting.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Loaded Property

Loaded Property
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Loaded
Gets a value indicating whether the SettingCollection is loaded.
Declaration Syntax
C#
public virtual bool Loaded{ get;}
Value
true if loaded; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadSettings Method

LoadSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> LoadSettings()()
Members
Icon | Member | Description
 | LoadSettings()() | Loads the settings.
 | LoadSettings(String) | Loads the settings.
 | LoadSettings(Item) | Loads the settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadSettings Method

LoadSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> LoadSettings()()
Loads the settings.
Declaration Syntax
C#
public virtual void LoadSettings()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadSettings Method (item)

LoadSettings Method (item)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> LoadSettings(Item)
Loads the settings.
Declaration Syntax
C#
public virtual void LoadSettings(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadSettings Method (path)

LoadSettings Method (path)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> LoadSettings(String)
Loads the settings.
Declaration Syntax
C#
public virtual void LoadSettings(
    string path
)
Parameters
path (String)
The path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SaveSettings Method

SaveSettings Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SaveSettings()()
Members
Icon | Member | Description
 | SaveSettings(Boolean) | Saves the settings.
 | SaveSettings(String) | Saves the settings using a specific path.
 | SaveSettings(String, Boolean) | Saves the settings.
 | SaveSettings(Item) | Saves the settings to the item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SaveSettings Method (item)

SaveSettings Method (item)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SaveSettings(Item)
Saves the settings to the item.
Declaration Syntax
C#
public virtual void SaveSettings(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SaveSettings Method (Local)

SaveSettings Method (Local)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SaveSettings(Boolean)
Saves the settings.
Declaration Syntax
C#
public virtual void SaveSettings(
    bool Local
)
Parameters
Local (Boolean)
if set to true [local].

Assembly: MSS.Kernel (Module: MSS.Kernel)


SaveSettings Method (Path)

SaveSettings Method (Path)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SaveSettings(String)
Saves the settings using a specific path.
Declaration Syntax
C#
public virtual void SaveSettings(
    string Path
)
Parameters
Path (String)
The path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SaveSettings Method (Path, Local)

SaveSettings Method (Path, Local)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SaveSettings(String, Boolean)
Saves the settings.
Declaration Syntax
C#
public virtual void SaveSettings(
    string Path,
    bool Local
)
Parameters
Path (String)
The path.
Local (Boolean)
if set to true [local].

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetData Method

SetData Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SetData()()
Members
Icon | Member | Description
 | SetData(StringDictionary) |
 | SetData(SettingsCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetData Method (sc)

SetData Method (sc)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SetData(SettingsCollection)
Declaration Syntax
C#
public virtual void SetData(
    SettingsCollection sc
)
Parameters
sc (SettingsCollection)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetData Method (data)

SetData Method (data)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SetData(StringDictionary)
Declaration Syntax
C#
public virtual void SetData(
    StringDictionary data
)
Parameters
data (StringDictionary)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetSection Method (Section, Data)

SetSection Method (Section, Data)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SetSection(String, StringDictionary)
Declaration Syntax
C#
public virtual void SetSection(
    string Section,
    StringDictionary Data
)
Parameters
Section (String)
Data (StringDictionary)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetSetting Method (Section, Key, Value)

SetSetting Method (Section, Key, Value)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> SetSetting(String, String, String)
Sets the setting.
Declaration Syntax
C#
public virtual void SetSetting(
    string Section,
    string Key,
    string Value
)
Parameters
Section (String)
The section.
Key (String)
The key.
Value (String)
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Setting Method

Setting Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Setting()()
Members
Icon | Member | Description
 | Setting(String) | Gets the setting by a key.
 | Setting(String, String) | Gets the setting from a section by a key.
 | Setting(String, String, String) | Gets the setting from a section by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Setting Method (Key)

Setting Method (Key)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Setting(String)
Gets the setting by a key.
Declaration Syntax
C#
public virtual string Setting(
    string Key
)
Parameters
Key (String)
The key.
Return Value
The settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Setting Method (Section, Key)

Setting Method (Section, Key)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Setting(String, String)
Gets the setting from a section by a key.
Declaration Syntax
C#
public virtual string Setting(
    string Section,
    string Key
)
Parameters
Section (String)
The section.
Key (String)
The key.
Return Value
The settings

Assembly: MSS.Kernel (Module: MSS.Kernel)


Setting Method (Section, Key, Default)

Setting Method (Section, Key, Default)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Setting(String, String, String)
Gets the setting from a section by a key.
Declaration Syntax
C#
public virtual string Setting(
    string Section,
    string Key,
    string Default
)
Parameters
Section (String)
The section.
Key (String)
The key.
Default (String)
The default value.
Return Value
The settings

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToInt Method

ToInt Method
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> ToInt()()
Members
Icon | Member | Description
 | ToInt(String) | Gets the int setting by a key.
 | ToInt(String, Int32) | Gets the int setting by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToInt Method (key)

ToInt Method (key)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> ToInt(String)
Gets the int setting by a key.
Declaration Syntax
C#
public virtual int ToInt(
    string key
)
Parameters
key (String)
The key.
Return Value
The settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToInt Method (key, defaultvalue)

ToInt Method (key, defaultvalue)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> ToInt(String, Int32)
Gets the int setting by a key.
Declaration Syntax
C#
public virtual int ToInt(
    string key,
    int defaultvalue
)
Parameters
key (String)
The key.
defaultvalue (Int32)
The defaultvalue.
Return Value
The settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Updatedata Method (ContentPath)

Updatedata Method (ContentPath)
Namespaces >> MSS.SettingsCollections >> SettingsCollection >> Updatedata(String)
Updatedatas the settings.
Declaration Syntax
C#
public virtual void Updatedata(
    string ContentPath
)
Parameters
ContentPath (String)
The content path to the item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.SitecoreExtensions.FieldControls Namespace

MSS.SitecoreExtensions.FieldControls Namespace
Namespaces >> MSS.SitecoreExtensions.FieldControls
Declaration Syntax
C#
namespace MSS.SitecoreExtensions.FieldControls
Types
All Types Classes
Icon | Type | Description
 | AvailableModules | Displays a list of available modules.
 | AvailableSpots | Displays a list of available spots.
 | Frame | Frame field control. Extends the functionality of the sitecore IFrame.
 | Image | Change functionality of Sitecore.Shell.Applications.ContentEditor.Image class.
 | LanguageLookup | Displays list of the available languages.
 | Lookup | If source is found then rewrite source to item path.
 | ModulesMultiList | Display modules list.
 | MssMultiList | Extends MultiList control functionality. Reads next source databaseName:/itemPath
 | MssRolesMultiList | Represents a multi-list which is filled by roles which are either the Sitecore client roles or mss global roles.
 | MssSiteLookup | Represents a lookup for an item which is under the site root.
 | MultiList | Displays list of available items. Selected items are saved as “item1ID|item2ID|...|itemID”.
 | MultiListValue | Saves selected items as item name.
 | ReadOnlyItemPath | Displays a read-only text box containing the item path.


AvailableModules Class

AvailableModules Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules
Displays a list of available modules.
Declaration Syntax
C#
public class AvailableModules : MultiList
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AvailableModulesAvailableModulesNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | CurrentItem | Gets the current item. (Inherited from MultiList.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from MultiList.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemValue(Item) | Gets the item value. (Inherited from MultiList.)
 | GetSourceItems()() | Gets the source items. (Overrides MultiList.GetSourceItems()().)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | Gets the control value. (Inherited from MultiList.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from MultiList.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsAvailible(Module) | Determines whether the module is available.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID. (Inherited from MultiList.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from MultiList.)
 | OnPreRender(EventArgs) | (Inherited from MultiList.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether control is read-only. (Inherited from MultiList.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from MultiList.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | Sets the control value. (Inherited from MultiList.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the control source. (Inherited from MultiList.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MultiList
 |  |  |  |  |  |  | AvailableModules
 |  |  |  |  |  |  |  | AvailableSpots

Assembly: MSS.Kernel (Module: MSS.Kernel)


AvailableModules Constructor

AvailableModules Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> AvailableModulesAvailableModulesNew()()
Declaration Syntax
C#
public AvailableModules()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSourceItems Method

GetSourceItems Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> GetSourceItems()()
Gets the source items.
Declaration Syntax
C#
public override Item[] GetSourceItems()
Return Value
The source items.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAvailible Method (module)

IsAvailible Method (module)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> IsAvailible(Module)
Determines whether the module is available.
Declaration Syntax
C#
protected virtual bool IsAvailible(
    Module module
)
Parameters
module (Module)
The module
Return Value
True, if the module is available; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AvailableSpots Class

AvailableSpots Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots
Displays a list of available spots.
Declaration Syntax
C#
public class AvailableSpots : AvailableModules
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AvailableSpotsAvailableSpotsNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | CurrentItem | Gets the current item. (Inherited from MultiList.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from MultiList.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemValue(Item) | Gets the item value. (Inherited from MultiList.)
 | GetSourceItems()() | Gets the source items. (Inherited from AvailableModules.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | Gets the control value. (Inherited from MultiList.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from MultiList.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsAvailible(Module) | (Overrides AvailableModules.IsAvailible(Module).)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID. (Inherited from MultiList.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from MultiList.)
 | OnPreRender(EventArgs) | (Inherited from MultiList.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether control is read-only. (Inherited from MultiList.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from MultiList.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | Sets the control value. (Inherited from MultiList.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the control source. (Inherited from MultiList.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MultiList
 |  |  |  |  |  |  | AvailableModules
 |  |  |  |  |  |  |  | AvailableSpots

Assembly: MSS.Kernel (Module: MSS.Kernel)


AvailableSpots Constructor

AvailableSpots Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> AvailableSpotsAvailableSpotsNew()()
Declaration Syntax
C#
public AvailableSpots()

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAvailible Method (module)

IsAvailible Method (module)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> IsAvailible(Module)
Declaration Syntax
C#
protected override bool IsAvailible(
    Module module
)
Parameters
module (Module)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Frame Class

Frame Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame
Frame field control. Extends the functionality of the sitecore IFrame.
Declaration Syntax
C#
public class Frame : IFrame
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrameFrameNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AllowTransparency()() | (Inherited from Frame.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | ContentDbQueryParameter |
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides Frame.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height()() | (Inherited from Frame.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID()() | (Inherited from IFrame.)
 | ItemLanguage()() | (Inherited from IFrame.)
 | ItemVersion()() | (Inherited from IFrame.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from IFrame.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from IFrame.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | Scrolling()() | (Inherited from Frame.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from IFrame.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetSource(String, String) | (Inherited from Frame.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source()() | (Inherited from IFrame.)
 | SourceUri()() | (Inherited from Frame.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified()() | (Inherited from IFrame.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width()() | (Inherited from Frame.)
 | XmlControl()() | (Inherited from Frame.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Frame
 |  |  |  |  |  |  | IFrame
 |  |  |  |  |  |  |  | Frame

Assembly: MSS.Kernel (Module: MSS.Kernel)


Frame Constructor

Frame Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> FrameFrameNew()()
Declaration Syntax
C#
public Frame()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ContentDbQueryParameter Field

ContentDbQueryParameter Field
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> ContentDbQueryParameter
Declaration Syntax
C#
public static readonly string ContentDbQueryParameter

Assembly: MSS.Kernel (Module: MSS.Kernel)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Image Class

Image Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image
Change functionality of Sitecore.Shell.Applications.ContentEditor.Image class.
Declaration Syntax
C#
public class Image : Image
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageImageNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | Browse()() | (Inherited from Image.)
 | BrowseImage(ClientPipelineArgs) |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | CallUpdate()() | Calls update from the base class
 | Change()() | (Inherited from Input.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateNewValue()() | Creates the new value.
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoChange(Message) | (Inherited from Image.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from Image.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | (Inherited from Image.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Image.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Hidden()() | (Inherited from Edit.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemLanguage()() | (Inherited from Image.)
 | ItemVersion()() | (Inherited from Image.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Edit.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange()() | (Inherited from Input.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | (Inherited from Image.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenBrowseImageDialog()() | Opens the browse image dialog. Add ad = 1 to query string to start advanced mode.
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Password()() | (Inherited from Edit.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly()() | (Inherited from Input.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from Image.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | (Inherited from Image.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | ShowProperties(ClientPipelineArgs) | (Inherited from Image.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source()() | (Inherited from Image.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified()() | (Inherited from Input.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Edit.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | XmlValue | Gets or sets the XML value.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Input
 |  |  |  |  |  |  | Edit
 |  |  |  |  |  |  |  | Image
 |  |  |  |  |  |  |  |  | Image

Assembly: MSS.Kernel (Module: MSS.Kernel)


Image Constructor

Image Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> ImageImageNew()()
Declaration Syntax
C#
public Image()

Assembly: MSS.Kernel (Module: MSS.Kernel)


BrowseImage Method (args)

BrowseImage Method (args)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> BrowseImage(ClientPipelineArgs)
Declaration Syntax
C#
protected virtual void BrowseImage(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


CallUpdate Method

CallUpdate Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> CallUpdate()()
Calls update from the base class
Declaration Syntax
C#
protected void CallUpdate()

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateNewValue Method

CreateNewValue Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> CreateNewValue()()
Creates the new value.
Declaration Syntax
C#
protected virtual XmlValue CreateNewValue()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


OpenBrowseImageDialog Method

OpenBrowseImageDialog Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> OpenBrowseImageDialog()()
Opens the browse image dialog. Add ad = 1 to query string to start advanced mode.
Declaration Syntax
C#
protected void OpenBrowseImageDialog()

Assembly: MSS.Kernel (Module: MSS.Kernel)


XmlValue Property

XmlValue Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> XmlValue
Gets or sets the XML value.
Declaration Syntax
C#
protected XmlValue XmlValue{ get; set;}
Value
The XML value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LanguageLookup Class

LanguageLookup Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup
Displays list of the available languages.
Declaration Syntax
C#
public class LanguageLookup : ValueLookup
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageLookupLanguageLookupNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | Change()() | (Inherited from Listbox.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click()() | (Inherited from Listbox.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DblClick()() | (Inherited from Listbox.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoChange(Message) | (Inherited from Listbox.)
 | DoClick(Message) | (Inherited from Listbox.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDblClick(Message) | (Inherited from Listbox.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from Listbox.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldName()() | (Inherited from Lookup.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemHeader(Item) | Gets the item header.
 | GetItems(Item) | (Inherited from Lookup.)
 | GetItemValue(Item) | (Inherited from ValueLookup.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsSelected(Item) | (Inherited from ValueLookup.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID()() | (Inherited from Lookup.)
 | Items()() | (Inherited from Listbox.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Listbox.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Multiple()() | (Inherited from Listbox.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnChange()() | (Inherited from Listbox.)
 | OnClick()() | (Inherited from Listbox.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDblClick()() | (Inherited from Listbox.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides Lookup.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from Lookup.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | Selected()() | (Inherited from Listbox.)
 | SelectedItem()() | (Inherited from Listbox.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from Listbox.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | Size()() | (Inherited from Listbox.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source()() | (Inherited from Lookup.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackModified()() | (Inherited from Listbox.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UseIDPaths()() | (Inherited from Lookup.)
 | Value()() | (Inherited from Listbox.)
 | ValueName()() | (Inherited from ValueLookup.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listbox
 |  |  |  |  |  |  | Combobox
 |  |  |  |  |  |  |  | Lookup
 |  |  |  |  |  |  |  |  | ValueLookup
 |  |  |  |  |  |  |  |  |  | LanguageLookup

Assembly: MSS.Kernel (Module: MSS.Kernel)


LanguageLookup Constructor

LanguageLookup Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> LanguageLookupLanguageLookupNew()()
Declaration Syntax
C#
public LanguageLookup()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetItemHeader Method (item)

GetItemHeader Method (item)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> GetItemHeader(Item)
Gets the item header.
Declaration Syntax
C#
protected virtual string GetItemHeader(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The item header.

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Lookup Class

Lookup Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup
If source is found then rewrite source to item path.
Declaration Syntax
C#
public class Lookup : LookupEx
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupLookupNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from LookupEx.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldName()() | (Inherited from LookupEx.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemHeader(Item) | (Inherited from LookupEx.)
 | GetItems(Item) | (Inherited from LookupEx.)
 | GetItemValue(Item) | (Inherited from LookupEx.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsSelected(Item) | (Inherited from LookupEx.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID()() | (Inherited from LookupEx.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from LookupEx.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from LookupEx.)
 | OnPreRender(EventArgs) | (Inherited from LookupEx.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the source.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | LookupEx
 |  |  |  |  |  |  | Lookup

Assembly: MSS.Kernel (Module: MSS.Kernel)


Lookup Constructor

Lookup Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> LookupLookupNew()()
Declaration Syntax
C#
public Lookup()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Source Property

Source Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> Source
Gets or sets the source.
Declaration Syntax
C#
public string Source{ get; set;}
Value
The source.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModulesMultiList Class

ModulesMultiList Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList
Display modules list.
Declaration Syntax
C#
public class ModulesMultiList : MultiList
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModulesMultiListModulesMultiListNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | CurrentItem | Gets the current item. (Inherited from MultiList.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from MultiList.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemValue(Item) | Gets the item value. (Inherited from MultiList.)
 | GetSourceItems()() | Gets the source items. (Overrides MultiList.GetSourceItems()().)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | Gets the control value. (Inherited from MultiList.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from MultiList.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID. (Inherited from MultiList.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from MultiList.)
 | OnPreRender(EventArgs) | (Inherited from MultiList.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether control is read-only. (Inherited from MultiList.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from MultiList.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | Sets the control value. (Inherited from MultiList.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the control source. (Inherited from MultiList.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MultiList
 |  |  |  |  |  |  | ModulesMultiList

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModulesMultiList Constructor

ModulesMultiList Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> ModulesMultiListModulesMultiListNew()()
Declaration Syntax
C#
public ModulesMultiList()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSourceItems Method

GetSourceItems Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> GetSourceItems()()
Gets the source items.
Declaration Syntax
C#
public override Item[] GetSourceItems()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


MssMultiList Class

MssMultiList Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList
Extends MultiList control functionality. Reads next source databaseName:/itemPath
Declaration Syntax
C#
public class MssMultiList : MultiList
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MssMultiListMssMultiListNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | CurrentItem | Gets the current item. (Inherited from MultiList.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from MultiList.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemValue(Item) | Gets the item value. (Inherited from MultiList.)
 | GetSourceItems()() | Gets the source items. (Overrides MultiList.GetSourceItems()().)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | Gets the control value. (Inherited from MultiList.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from MultiList.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID. (Inherited from MultiList.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from MultiList.)
 | OnPreRender(EventArgs) | (Inherited from MultiList.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether control is read-only. (Inherited from MultiList.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from MultiList.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | Sets the control value. (Inherited from MultiList.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the control source. (Inherited from MultiList.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MultiList
 |  |  |  |  |  |  | MssMultiList

Assembly: MSS.Kernel (Module: MSS.Kernel)


MssMultiList Constructor

MssMultiList Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> MssMultiListMssMultiListNew()()
Declaration Syntax
C#
public MssMultiList()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSourceItems Method

GetSourceItems Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> GetSourceItems()()
Gets the source items.
Declaration Syntax
C#
public override Item[] GetSourceItems()
Return Value
The source items.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MssRolesMultiList Class

MssRolesMultiList Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList
Represents a multi-list which is filled by roles which are either the Sitecore client roles or mss global roles.
Declaration Syntax
C#
public class MssRolesMultiList : MultiList
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MssRolesMultiListMssRolesMultiListNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | CurrentItem | Gets the current item. (Inherited from MultiList.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from MultiList.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemValue(Item) | Gets the item value. (Inherited from MultiList.)
 | GetSourceItems()() | Gets the source items. (Overrides MultiList.GetSourceItems()().)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | Gets the control value. (Inherited from MultiList.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from MultiList.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID. (Inherited from MultiList.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from MultiList.)
 | OnPreRender(EventArgs) | (Inherited from MultiList.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether control is read-only. (Inherited from MultiList.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from MultiList.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | Sets the control value. (Inherited from MultiList.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the control source. (Inherited from MultiList.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MultiList
 |  |  |  |  |  |  | MssRolesMultiList

Assembly: MSS.Kernel (Module: MSS.Kernel)


MssRolesMultiList Constructor

MssRolesMultiList Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> MssRolesMultiListMssRolesMultiListNew()()
Declaration Syntax
C#
public MssRolesMultiList()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSourceItems Method

GetSourceItems Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> GetSourceItems()()
Gets the source items.
Declaration Syntax
C#
public override Item[] GetSourceItems()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


MssSiteLookup Class

MssSiteLookup Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup
Represents a lookup for an item which is under the site root.
Declaration Syntax
C#
public class MssSiteLookup : LookupEx
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MssSiteLookupMssSiteLookupNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from LookupEx.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldName()() | (Inherited from LookupEx.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemHeader(Item) | (Inherited from LookupEx.)
 | GetItems(Item) | (Inherited from LookupEx.)
 | GetItemValue(Item) | (Inherited from LookupEx.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsSelected(Item) | (Inherited from LookupEx.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID |
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from LookupEx.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from LookupEx.)
 | OnPreRender(EventArgs) | (Inherited from LookupEx.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source |
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateDerivedSource()() |
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | LookupEx
 |  |  |  |  |  |  | MssSiteLookup

Assembly: MSS.Kernel (Module: MSS.Kernel)


MssSiteLookup Constructor

MssSiteLookup Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> MssSiteLookupMssSiteLookupNew()()
Declaration Syntax
C#
public MssSiteLookup()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ItemID Property

ItemID Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> ItemID
Declaration Syntax
C#
public string ItemID{ get; set;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Source Property

Source Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> Source
Declaration Syntax
C#
public string Source{ get; set;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


UpdateDerivedSource Method

UpdateDerivedSource Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> UpdateDerivedSource()()
Declaration Syntax
C#
protected void UpdateDerivedSource()

Assembly: MSS.Kernel (Module: MSS.Kernel)


MultiList Class

MultiList Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList
Displays list of available items. Selected items are saved as “item1ID|item2ID|...|itemID”.
Declaration Syntax
C#
public class MultiList : Control, IContentField
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiListMultiListNew()() | Initializes a new instance of the MultiList class.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | CurrentItem | Gets the current item.
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemValue(Item) | Gets the item value.
 | GetSourceItems()() | Gets the source items.
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | Gets the control value.
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Overrides Control.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID.
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether control is read-only.
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() |
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | Sets the control value.
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the control source.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MultiList
 |  |  |  |  |  |  | ModulesMultiList
 |  |  |  |  |  |  | MssRolesMultiList
 |  |  |  |  |  |  | MssMultiList
 |  |  |  |  |  |  | AvailableModules
 |  |  |  |  |  |  | MultiListValue

Assembly: MSS.Kernel (Module: MSS.Kernel)


MultiList Constructor

MultiList Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> MultiListMultiListNew()()
Initializes a new instance of the MultiList class.
Declaration Syntax
C#
public MultiList()

Assembly: MSS.Kernel (Module: MSS.Kernel)


CurrentItem Property

CurrentItem Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> CurrentItem
Gets the current item.
Declaration Syntax
C#
public Item CurrentItem{ get;}
Value
The current item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetItemValue Method (item)

GetItemValue Method (item)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> GetItemValue(Item)
Gets the item value.
Declaration Syntax
C#
public virtual string GetItemValue(
    Item item
)
Parameters
item (Item)
The item.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSourceItems Method

GetSourceItems Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> GetSourceItems()()
Gets the source items.
Declaration Syntax
C#
public virtual Item[] GetSourceItems()
Return Value
The source items.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetValue Method

GetValue Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> GetValue()()
Gets the control value.
Declaration Syntax
C#
public string GetValue()
Return Value
The value of the field.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> HandleMessage(Message)
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)

Assembly: MSS.Kernel (Module: MSS.Kernel)


ItemID Property

ItemID Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> ItemID
Gets or sets the item ID.
Declaration Syntax
C#
public string ItemID{ get; set;}
Value
The item ID.

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


ReadOnly Property

ReadOnly Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> ReadOnly
Gets or sets a value indicating whether control is read-only.
Declaration Syntax
C#
public bool ReadOnly{ get; set;}
Value
true if [read only]; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetModified Method

SetModified Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> SetModified()()
Declaration Syntax
C#
protected void SetModified()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetValue Method (value)

SetValue Method (value)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> SetValue(String)
Sets the control value.
Declaration Syntax
C#
public void SetValue(
    string value
)
Parameters
value (String)
The value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Source Property

Source Property
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> Source
Gets or sets the control source.
Declaration Syntax
C#
public string Source{ get; set;}
Value
The control source.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MultiListValue Class

MultiListValue Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue
Saves selected items as item name.
Declaration Syntax
C#
public class MultiListValue : MultiList
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiListValueMultiListValueNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | CurrentItem | Gets the current item. (Inherited from MultiList.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from MultiList.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetItemValue(Item) | Returns item's value. (Overrides MultiList.GetItemValue(Item).)
 | GetSourceItems()() | Gets the source items. (Inherited from MultiList.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue()() | Gets the control value. (Inherited from MultiList.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from MultiList.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemID | Gets or sets the item ID. (Inherited from MultiList.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from MultiList.)
 | OnPreRender(EventArgs) | (Inherited from MultiList.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | ReadOnly | Gets or sets a value indicating whether control is read-only. (Inherited from MultiList.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetModified()() | (Inherited from MultiList.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetValue(String) | Sets the control value. (Inherited from MultiList.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Source | Gets or sets the control source. (Inherited from MultiList.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | MultiList
 |  |  |  |  |  |  | MultiListValue

Assembly: MSS.Kernel (Module: MSS.Kernel)


MultiListValue Constructor

MultiListValue Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> MultiListValueMultiListValueNew()()
Declaration Syntax
C#
public MultiListValue()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetItemValue Method (item)

GetItemValue Method (item)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> GetItemValue(Item)
Returns item's value.
Declaration Syntax
C#
public override string GetItemValue(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The Item’s value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ReadOnlyItemPath Class

ReadOnlyItemPath Class
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath
Displays a read-only text box containing the item path.
Declaration Syntax
C#
public class ReadOnlyItemPath : Control
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReadOnlyItemPathReadOnlyItemPathNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | ReadOnlyItemPath

Assembly: MSS.Kernel (Module: MSS.Kernel)


ReadOnlyItemPath Constructor

ReadOnlyItemPath Constructor
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> ReadOnlyItemPathReadOnlyItemPathNew()()
Declaration Syntax
C#
public ReadOnlyItemPath()

Assembly: MSS.Kernel (Module: MSS.Kernel)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.SitecoreExtensions.Pages Namespace

MSS.SitecoreExtensions.Pages Namespace
Namespaces >> MSS.SitecoreExtensions.Pages
Declaration Syntax
C#
namespace MSS.SitecoreExtensions.Pages
Types
All Types Classes
Icon | Type | Description
 | Error |
 | PageNotFound |


Error Class

Error Class
Namespaces >> MSS.SitecoreExtensions.Pages >> Error
Declaration Syntax
C#
public class Error : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorErrorNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorDetails |
 | ErrorMorePanel |
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | GoToPreviousPage |
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LastException |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NotificationHasSent |
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SendNotification |
 | SendNotification_Click(Object, EventArgs) |
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | Error

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


Error Constructor

Error Constructor
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> ErrorErrorNew()()
Declaration Syntax
C#
public Error()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


ErrorDetails Field

ErrorDetails Field
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> ErrorDetails
Declaration Syntax
C#
protected Label ErrorDetails

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


ErrorMorePanel Field

ErrorMorePanel Field
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> ErrorMorePanel
Declaration Syntax
C#
protected Control ErrorMorePanel

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


GoToPreviousPage Field

GoToPreviousPage Field
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> GoToPreviousPage
Declaration Syntax
C#
protected LinkButton GoToPreviousPage

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


LastException Property

LastException Property
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> LastException
Declaration Syntax
C#
public Exception LastException{ get;}

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


NotificationHasSent Field

NotificationHasSent Field
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> NotificationHasSent
Declaration Syntax
C#
protected Label NotificationHasSent

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


SendNotification Field

SendNotification Field
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> SendNotification
Declaration Syntax
C#
protected LinkButton SendNotification

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


SendNotification_Click Method (sender, e)

SendNotification_Click Method (sender, e)
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> SendNotification_Click(Object, EventArgs)
Declaration Syntax
C#
protected void SendNotification_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


PageNotFound Class

PageNotFound Class
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound
Declaration Syntax
C#
public class PageNotFound : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageNotFoundPageNotFoundNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequestedUrl |
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | UserName |
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | PageNotFound

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


PageNotFound Constructor

PageNotFound Constructor
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> PageNotFoundPageNotFoundNew()()
Declaration Syntax
C#
public PageNotFound()

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


RequestedUrl Field

RequestedUrl Field
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> RequestedUrl
Declaration Syntax
C#
protected PlaceHolder RequestedUrl

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


UserName Field

UserName Field
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> UserName
Declaration Syntax
C#
protected PlaceHolder UserName

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


MSS.SitecoreExtensions.Pipelines Namespace

MSS.SitecoreExtensions.Pipelines Namespace
Namespaces >> MSS.SitecoreExtensions.Pipelines
Declaration Syntax
C#
namespace MSS.SitecoreExtensions.Pipelines
Types
All Types Classes
Icon | Type | Description
 | ItemResolver | Resolves context item
 | Login | This class is used to deny login in to the backend for users who have not got the corresponding rights.
 | SecurityResolver | Checks whether a user is an mss local user and he has rights to login to the backend
 | SiteResolver | Synchronizes access to the sites during the site resolving process.


ItemResolver Class

ItemResolver Class
Namespaces >> MSS.SitecoreExtensions.Pipelines >> ItemResolver
Resolves context item
Declaration Syntax
C#
public class ItemResolver : ItemResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemResolverItemResolverNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ItemResolver
 |  | ItemResolver

Assembly: MSS.Kernel (Module: MSS.Kernel)


ItemResolver Constructor

ItemResolver Constructor
Namespaces >> MSS.SitecoreExtensions.Pipelines >> ItemResolver >> ItemResolverItemResolverNew()()
Declaration Syntax
C#
public ItemResolver()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Process Method (args)

Process Method (args)
Namespaces >> MSS.SitecoreExtensions.Pipelines >> ItemResolver >> Process(HttpRequestArgs)
Declaration Syntax
C#
public void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Login Class

Login Class
Namespaces >> MSS.SitecoreExtensions.Pipelines >> Login
This class is used to deny login in to the backend for users who have not got the corresponding rights.
Declaration Syntax
C#
public class Login
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoginLoginNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(LoginArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Login

Assembly: MSS.Kernel (Module: MSS.Kernel)


Login Constructor

Login Constructor
Namespaces >> MSS.SitecoreExtensions.Pipelines >> Login >> LoginLoginNew()()
Declaration Syntax
C#
public Login()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Process Method (args)

Process Method (args)
Namespaces >> MSS.SitecoreExtensions.Pipelines >> Login >> Process(LoginArgs)
Declaration Syntax
C#
public void Process(
    LoginArgs args
)
Parameters
args (LoginArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityResolver Class

SecurityResolver Class
Namespaces >> MSS.SitecoreExtensions.Pipelines >> SecurityResolver
Checks whether a user is an mss local user and he has rights to login to the backend
Declaration Syntax
C#
public class SecurityResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SecurityResolverSecurityResolverNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SecurityResolver

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityResolver Constructor

SecurityResolver Constructor
Namespaces >> MSS.SitecoreExtensions.Pipelines >> SecurityResolver >> SecurityResolverSecurityResolverNew()()
Declaration Syntax
C#
public SecurityResolver()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Process Method (args)

Process Method (args)
Namespaces >> MSS.SitecoreExtensions.Pipelines >> SecurityResolver >> Process(HttpRequestArgs)
Declaration Syntax
C#
public void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteResolver Class

SiteResolver Class
Namespaces >> MSS.SitecoreExtensions.Pipelines >> SiteResolver
Synchronizes access to the sites during the site resolving process.
Declaration Syntax
C#
public class SiteResolver : SiteResolver
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteResolverSiteResolverNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(HttpRequestArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SiteResolver
 |  | SiteResolver

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteResolver Constructor

SiteResolver Constructor
Namespaces >> MSS.SitecoreExtensions.Pipelines >> SiteResolver >> SiteResolverSiteResolverNew()()
Declaration Syntax
C#
public SiteResolver()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Process Method (args)

Process Method (args)
Namespaces >> MSS.SitecoreExtensions.Pipelines >> SiteResolver >> Process(HttpRequestArgs)
Declaration Syntax
C#
public void Process(
    HttpRequestArgs args
)
Parameters
args (HttpRequestArgs)

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.AdministrationMenus Namespace

MSS.Sites.AdministrationMenus Namespace
Namespaces >> MSS.Sites.AdministrationMenus
Declaration Syntax
C#
namespace MSS.Sites.AdministrationMenus
Types
All Types Classes
Icon | Type | Description
 | AdministrationMenu | Site administration menu.
 | AdministrationMenuManager | Returns the SiteAdministration menu for the SiteType.


AdministrationMenu Class

AdministrationMenu Class
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenu
Site administration menu.
Declaration Syntax
C#
public class AdministrationMenu : Entity
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdministrationMenuAdministrationMenuNew(ID, Server) | Initializes a new instance of the AdministrationMenu class.
 | AdministrationMenuAdministrationMenuNew(ID, Server, Database) | Initializes a new instance of the AdministrationMenu class for s specific database.
 | Clone()() | Clones this instance of AdministrationMenu. (Overrides Entity.Clone()().)
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | AdministrationMenu

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdministrationMenu Constructor

AdministrationMenu Constructor
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenu >> AdministrationMenuAdministrationMenuNew()()
Members
Icon | Member | Description
 | AdministrationMenuAdministrationMenuNew(ID, Server) | Initializes a new instance of the AdministrationMenu class.
 | AdministrationMenuAdministrationMenuNew(ID, Server, Database) | Initializes a new instance of the AdministrationMenu class for s specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdministrationMenu Constructor (menuID, server)

AdministrationMenu Constructor (menuID, server)
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenu >> AdministrationMenuAdministrationMenuNew(ID, Server)
Initializes a new instance of the AdministrationMenu class.
Declaration Syntax
C#
public AdministrationMenu(
    ID menuID,
    Server server
)
Parameters
menuID (ID)
The menu ID.
server (Server)
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdministrationMenu Constructor (menuID, server, database)

AdministrationMenu Constructor (menuID, server, database)
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenu >> AdministrationMenuAdministrationMenuNew(ID, Server, Database)
Initializes a new instance of the AdministrationMenu class for s specific database.
Declaration Syntax
C#
public AdministrationMenu(
    ID menuID,
    Server server,
    Database database
)
Parameters
menuID (ID)
The menu ID.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenu >> Clone()()
Clones this instance of AdministrationMenu.
Declaration Syntax
C#
public override Entity Clone()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdministrationMenuManager Class

AdministrationMenuManager Class
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenuManager
Returns the SiteAdministration menu for the SiteType.
Declaration Syntax
C#
public class AdministrationMenuManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AdministrationMenuManagerAdministrationMenuManagerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMenuRoot(SiteType) | Gets the menu root.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AdministrationMenuManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdministrationMenuManager Constructor

AdministrationMenuManager Constructor
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenuManager >> AdministrationMenuManagerAdministrationMenuManagerNew()()
Declaration Syntax
C#
public AdministrationMenuManager()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetMenuRoot Method (type)

GetMenuRoot Method (type)
Namespaces >> MSS.Sites.AdministrationMenus >> AdministrationMenuManager >> GetMenuRoot(SiteType)
Gets the menu root.
Declaration Syntax
C#
public static AdministrationMenu GetMenuRoot(
    SiteType type
)
Parameters
type (SiteType)
The type.
Return Value
The menu root.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.Contexts Namespace

MSS.Sites.Contexts Namespace
Namespaces >> MSS.Sites.Contexts
Declaration Syntax
C#
namespace MSS.Sites.Contexts
Types
All Types Classes Enumerations
Icon | Type | Description
 | SiteContextBuilder..::CreationReport | Used for creating a html report about site creation operation.
 | Database | Utility class for easy and explicit access to the “web” and “master” databases.
 | Definitions | Local paths to defined site items
 | ItemEventHandler | Resets sites contexts if there are changes in the site's root items.
 | SiteContext | Provides runtime information about the running website
 | SiteContextBuilder | This class is used to create a new site
 | SiteContextManager | Provides functionality for work with sites
 | SiteContext..::SiteStatus | Provides status information for the current site


SiteContextBuilder.CreationReport Class

SiteContextBuilder..::CreationReport Class
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder >> SiteContextBuilder..::CreationReport
Used for creating a html report about site creation operation.
Declaration Syntax
C#
public class CreationReport
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteContextBuilder..::CreationReportSiteContextBuilder..::CreationReportNew()() |
 | AddReportLine(String) | Adds the report line.
 | AddReportLine(String, Object) | Adds the report line.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Success | Gets or sets a value indicating whether the site creation operation was successful.
 | ToString()() | (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
SiteContextBuilder..::CreationReport

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextBuilder.CreationReport Constructor

SiteContextBuilder..::CreationReport Constructor
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder..::CreationReport >> SiteContextBuilder..::CreationReportSiteContextBuilder..::CreationReportNew()()
Declaration Syntax
C#
public CreationReport()

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddReportLine Method

AddReportLine Method
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder..::CreationReport >> AddReportLine()()
Members
Icon | Member | Description
 | AddReportLine(String) | Adds the report line.
 | AddReportLine(String, Object) | Adds the report line.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddReportLine Method (text)

AddReportLine Method (text)
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder..::CreationReport >> AddReportLine(String)
Adds the report line.
Declaration Syntax
C#
public void AddReportLine(
    string text
)
Parameters
text (String)
The text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddReportLine Method (text, Section)

AddReportLine Method (text, Section)
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder..::CreationReport >> AddReportLine(String, Object)
Adds the report line.
Declaration Syntax
C#
public void AddReportLine(
    string text,
    Object Section
)
Parameters
text (String)
The text.
Section (Object)
The section.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Success Property

Success Property
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder..::CreationReport >> Success
Gets or sets a value indicating whether the site creation operation was successful.
Declaration Syntax
C#
public bool Success{ get; set;}
Value
True if successful; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToString Method

ToString Method
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder..::CreationReport >> ToString()()
Declaration Syntax
C#
public override string ToString()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Database Class

Database Class
Namespaces >> MSS.Sites.Contexts >> Database
Utility class for easy and explicit access to the “web” and “master” databases.
Declaration Syntax
C#
public class Database
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Content | Gets the content database.
 | Core | Return the “core” database.
 | Current | Returns "web" database for normal moder, and "master" for webedit and xaml pages
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabase(String) | Gets the sitecore database by name.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SiteDatabase | Return the database for the site.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Database

Assembly: MSS.Kernel (Module: MSS.Kernel)


Content Property

Content Property
Namespaces >> MSS.Sites.Contexts >> Database >> Content
Gets the content database.
Declaration Syntax
C#
public Database Content{ get;}
Value
The content.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Core Property

Core Property
Namespaces >> MSS.Sites.Contexts >> Database >> Core
Return the “core” database.
Declaration Syntax
C#
public Database Core{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Current Property

Current Property
Namespaces >> MSS.Sites.Contexts >> Database >> Current
Returns "web" database for normal moder, and "master" for webedit and xaml pages
Declaration Syntax
C#
public Database Current{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetDatabase Method (name)

GetDatabase Method (name)
Namespaces >> MSS.Sites.Contexts >> Database >> GetDatabase(String)
Gets the sitecore database by name.
Declaration Syntax
C#
public Database GetDatabase(
    string name
)
Parameters
name (String)
The name.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteDatabase Property

SiteDatabase Property
Namespaces >> MSS.Sites.Contexts >> Database >> SiteDatabase
Return the database for the site.
Declaration Syntax
C#
public Database SiteDatabase{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Definitions Class

Definitions Class
Namespaces >> MSS.Sites.Contexts >> Definitions
Local paths to defined site items
Declaration Syntax
C#
public class Definitions
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AliasesPath |
 | DictionaryPath |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalDocumentPath | The path from the given site's root node to the global document
 | HomeItem |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleSettingsPath |
 | MssItemPath |
 | SettingsPath |
 | SiteDataFolderPath |
 | SitesFolderPath |
 | SiteUploadFolderPath |
 | SystemPath |
 | SystemSettingsPath |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WebSitesPath |
 | WizardSettingsPath |
Inheritance Hierarchy
Object
Definitions

Assembly: MSS.Kernel (Module: MSS.Kernel)


AliasesPath Property

AliasesPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> AliasesPath
Declaration Syntax
C#
public static string AliasesPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> DictionaryPath
Declaration Syntax
C#
public static string DictionaryPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalDocumentPath Property

GlobalDocumentPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> GlobalDocumentPath
The path from the given site's root node to the global document
Declaration Syntax
C#
public static string GlobalDocumentPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


HomeItem Property

HomeItem Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> HomeItem
Declaration Syntax
C#
public static string HomeItem{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModuleSettingsPath Property

ModuleSettingsPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> ModuleSettingsPath
Declaration Syntax
C#
public static string ModuleSettingsPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


MssItemPath Property

MssItemPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> MssItemPath
Declaration Syntax
C#
public static string MssItemPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SettingsPath Property

SettingsPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> SettingsPath
Declaration Syntax
C#
public static string SettingsPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteDataFolderPath Property

SiteDataFolderPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> SiteDataFolderPath
Declaration Syntax
C#
public static string SiteDataFolderPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SitesFolderPath Property

SitesFolderPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> SitesFolderPath
Declaration Syntax
C#
public static string SitesFolderPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteUploadFolderPath Property

SiteUploadFolderPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> SiteUploadFolderPath
Declaration Syntax
C#
public static string SiteUploadFolderPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SystemPath Property

SystemPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> SystemPath
Declaration Syntax
C#
public static string SystemPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SystemSettingsPath Property

SystemSettingsPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> SystemSettingsPath
Declaration Syntax
C#
public static string SystemSettingsPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


WebSitesPath Property

WebSitesPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> WebSitesPath
Declaration Syntax
C#
public static string WebSitesPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


WizardSettingsPath Property

WizardSettingsPath Property
Namespaces >> MSS.Sites.Contexts >> Definitions >> WizardSettingsPath
Declaration Syntax
C#
public static string WizardSettingsPath{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


ItemEventHandler Class

ItemEventHandler Class
Namespaces >> MSS.Sites.Contexts >> ItemEventHandler
Resets sites contexts if there are changes in the site's root items.
Declaration Syntax
C#
public class ItemEventHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ItemEventHandlerItemEventHandlerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnItemDeleted(Object, EventArgs) | Handle “item:deleted” event.
 | OnItemSaved(Object, EventArgs) | Handle item:saved event.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ItemEventHandler

Assembly: MSS.Kernel (Module: MSS.Kernel)


ItemEventHandler Constructor

ItemEventHandler Constructor
Namespaces >> MSS.Sites.Contexts >> ItemEventHandler >> ItemEventHandlerItemEventHandlerNew()()
Declaration Syntax
C#
public ItemEventHandler()

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnItemDeleted Method (sender, args)

OnItemDeleted Method (sender, args)
Namespaces >> MSS.Sites.Contexts >> ItemEventHandler >> OnItemDeleted(Object, EventArgs)
Handle “item:deleted” event.
Declaration Syntax
C#
public void OnItemDeleted(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


OnItemSaved Method (sender, args)

OnItemSaved Method (sender, args)
Namespaces >> MSS.Sites.Contexts >> ItemEventHandler >> OnItemSaved(Object, EventArgs)
Handle item:saved event.
Declaration Syntax
C#
public void OnItemSaved(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The sender.
args (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContext Class

SiteContext Class
Namespaces >> MSS.Sites.Contexts >> SiteContext
Provides runtime information about the running website
Declaration Syntax
C#
public class SiteContext : Entity, ICacheable
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdminFieldKey |
 | Clone()() | Clones this instance. (Overrides Entity.Clone()().)
 | Database | Gets the database. (Inherited from EntityBase.)
 | DataFolder | Gets the data folder on disk where the individual sites stores their data
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Dictionary | Gets the dictionary manager.
 | EmailFieldKey |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAliases()() | Gets the alias items.
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetGlobalChildItem(String) | Gets the global child item.
 | GetGlobalChildItem(Database, String) | Gets the global child item using a specific database.
 | GetGlobalItem()() | Gets the global item.
 | GetGlobalItem(Database) | Gets the global item using a specific database.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHomeItem()() | Gets the home item.
 | GetRootItem()() | Gets the root item.
 | GetRootItem(Database) | Gets the root item from the database.
 | GetSiteStatus(String) | Gets the site status.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalItemId | Gets the global item id.
 | HomeItem | Gets the home item of the site.
 | HomeUrl | Gets the home URL.
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | IsContentDocument(Item) | Determines whether the specified item is a content document.
 | IsContentDocument(String) | Determines whether the specified item is a content document.
 | IsLocalDocument(XPathNodeIterator) | Determines whether the specified iterator is a local document.
 | IsLocalDocument(Item) | Determines whether the specified iterator is a local document.
 | IsLocalDocument(String) | Determines whether the specified iterator is a local document.
 | IsLocalFile(FileInfo) | Returns true if the given file belongs to the current website.
 | IsLocalPath(String) | Returns true if the given path belongs to the current website.
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | LanguageFieldKey |
 | LocalDictionary | Gets the local dictionary.
 | MediaLibrary | Gets the media library.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModulesSettings | Gets the modules settings.
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Publish(Boolean) | Publishes the site's content.
 | RootItem | Gets the root of the site.
 | Security | Gets the security.
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | Settings | Gets the site settings.
 | SiteAddress | Gets or sets the site address i.e. the hostname or server name.
 | SiteData | Gets or sets the site data.
 | SiteId | Gets the site id.
 | SiteIsNotDeleted()() | Indicates if the site has NOT been deleted.
 | SiteType | Gets the type of the site.
 | SiteTypeField |
 | Status | Gets or sets the status. Uses the master database to read and write to.
 | StatusField |
 | SuspendPublish | Summary: If true prevents publishing on the local website, otherwise publishing will occur e.g. when a new user/group is created, an extranet user/group is created in Sitecore and has to be published. Creating a lot of users/groups will have bad performance issues if each has to be published individually.
 | ToString()() | (Overrides Object.ToString()().)
 | UpdateData(String) | Updates the data i.e. dictionary items and site settings, if the path is part of the current website.
 | UploadFolder | Gets the upload folder
 | UrlField |
 | Wizard | Gets the wizard for the current site.
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | SiteContext

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdminFieldKey Field

AdminFieldKey Field
Namespaces >> MSS.Sites.Contexts >> SiteContext >> AdminFieldKey
Declaration Syntax
C#
public static readonly string AdminFieldKey

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> Clone()()
Clones this instance.
Declaration Syntax
C#
public override Entity Clone()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataFolder Property

DataFolder Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> DataFolder
Gets the data folder on disk where the individual sites stores their data
Declaration Syntax
C#
public string DataFolder{ get;}
Value
The data folder.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Dictionary Property

Dictionary Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> Dictionary
Gets the dictionary manager.
Declaration Syntax
C#
public DictionaryManager Dictionary{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


EmailFieldKey Field

EmailFieldKey Field
Namespaces >> MSS.Sites.Contexts >> SiteContext >> EmailFieldKey
Declaration Syntax
C#
public static readonly string EmailFieldKey

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAliases Method

GetAliases Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetAliases()()
Gets the alias items.
Declaration Syntax
C#
public virtual Item[] GetAliases()
Return Value
The alias items.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalChildItem Method

GetGlobalChildItem Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetGlobalChildItem()()
Members
Icon | Member | Description
 | GetGlobalChildItem(String) | Gets the global child item.
 | GetGlobalChildItem(Database, String) | Gets the global child item using a specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalChildItem Method (database, childName)

GetGlobalChildItem Method (database, childName)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetGlobalChildItem(Database, String)
Gets the global child item using a specific database.
Declaration Syntax
C#
public virtual Item GetGlobalChildItem(
    Database database,
    string childName
)
Parameters
database (Database)
The database.
childName (String)
Name of the child.
Return Value
The global child item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalChildItem Method (childName)

GetGlobalChildItem Method (childName)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetGlobalChildItem(String)
Gets the global child item.
Declaration Syntax
C#
public virtual Item GetGlobalChildItem(
    string childName
)
Parameters
childName (String)
Name of the child.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalItem Method

GetGlobalItem Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetGlobalItem()()
Members
Icon | Member | Description
 | GetGlobalItem()() | Gets the global item.
 | GetGlobalItem(Database) | Gets the global item using a specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalItem Method

GetGlobalItem Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetGlobalItem()()
Gets the global item.
Declaration Syntax
C#
public virtual Item GetGlobalItem()
Return Value
The global item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalItem Method (database)

GetGlobalItem Method (database)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetGlobalItem(Database)
Gets the global item using a specific database.
Declaration Syntax
C#
public virtual Item GetGlobalItem(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The global item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetHomeItem Method

GetHomeItem Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetHomeItem()()
Gets the home item.
Declaration Syntax
C#
public Item GetHomeItem()
Return Value
The home item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetRootItem Method

GetRootItem Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetRootItem()()
Members
Icon | Member | Description
 | GetRootItem()() | Gets the root item.
 | GetRootItem(Database) | Gets the root item from the database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetRootItem Method

GetRootItem Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetRootItem()()
Gets the root item.
Declaration Syntax
C#
public Item GetRootItem()
Return Value
The root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetRootItem Method (database)

GetRootItem Method (database)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetRootItem(Database)
Gets the root item from the database.
Declaration Syntax
C#
public Item GetRootItem(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteStatus Method (statusId)

GetSiteStatus Method (statusId)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GetSiteStatus(String)
Gets the site status.
Declaration Syntax
C#
public static SiteContext.SiteContext..::SiteStatus GetSiteStatus(
    string statusId
)
Parameters
statusId (String)
The status id.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalItemId Property

GlobalItemId Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> GlobalItemId
Gets the global item id.
Declaration Syntax
C#
public virtual ID GlobalItemId{ get;}
Value
The global item id.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HomeItem Property

HomeItem Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> HomeItem
Gets the home item of the site.
Declaration Syntax
C#
public Item HomeItem{ get;}
Value
The site home.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HomeUrl Property

HomeUrl Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> HomeUrl
Gets the home URL.
Declaration Syntax
C#
public string HomeUrl{ get;}
Value
The home URL.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsContentDocument Method

IsContentDocument Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsContentDocument()()
Members
Icon | Member | Description
 | IsContentDocument(Item) | Determines whether the specified item is a content document.
 | IsContentDocument(String) | Determines whether the specified item is a content document.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsContentDocument Method (item)

IsContentDocument Method (item)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsContentDocument(Item)
Determines whether the specified item is a content document.
Declaration Syntax
C#
public bool IsContentDocument(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified item is a content document; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsContentDocument Method (path)

IsContentDocument Method (path)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsContentDocument(String)
Determines whether the specified item is a content document.
Declaration Syntax
C#
public bool IsContentDocument(
    string path
)
Parameters
path (String)
The path.
Return Value
True if the specified item is a content document; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalDocument Method

IsLocalDocument Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsLocalDocument()()
Members
Icon | Member | Description
 | IsLocalDocument(XPathNodeIterator) | Determines whether the specified iterator is a local document.
 | IsLocalDocument(Item) | Determines whether the specified iterator is a local document.
 | IsLocalDocument(String) | Determines whether the specified iterator is a local document.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalDocument Method (item)

IsLocalDocument Method (item)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsLocalDocument(Item)
Determines whether the specified iterator is a local document.
Declaration Syntax
C#
public bool IsLocalDocument(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified iteratir is a local document; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalDocument Method (itemPath)

IsLocalDocument Method (itemPath)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsLocalDocument(String)
Determines whether the specified iterator is a local document.
Declaration Syntax
C#
public bool IsLocalDocument(
    string itemPath
)
Parameters
itemPath (String)
The item path.
Return Value
True if the specified iteratir is a local document; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalDocument Method (itr)

IsLocalDocument Method (itr)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsLocalDocument(XPathNodeIterator)
Determines whether the specified iterator is a local document.
Declaration Syntax
C#
public bool IsLocalDocument(
    XPathNodeIterator itr
)
Parameters
itr (XPathNodeIterator)
The iterator.
Return Value
True if the specified iteratir is a local document; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalFile Method (file)

IsLocalFile Method (file)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsLocalFile(FileInfo)
Returns true if the given file belongs to the current website.
Declaration Syntax
C#
public bool IsLocalFile(
    FileInfo file
)
Parameters
file (FileInfo)
File to test.
Return Value
True if the given path is local, otherwise false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLocalPath Method (path)

IsLocalPath Method (path)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> IsLocalPath(String)
Returns true if the given path belongs to the current website.
Declaration Syntax
C#
public bool IsLocalPath(
    string path
)
Parameters
path (String)
path to test.
Return Value
True if the given path is local, otherwise false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LanguageFieldKey Field

LanguageFieldKey Field
Namespaces >> MSS.Sites.Contexts >> SiteContext >> LanguageFieldKey
Declaration Syntax
C#
public static readonly string LanguageFieldKey

Assembly: MSS.Kernel (Module: MSS.Kernel)


LocalDictionary Property

LocalDictionary Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> LocalDictionary
Gets the local dictionary.
Declaration Syntax
C#
public Dictionary LocalDictionary{ get;}
Value
The local dictionary.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MediaLibrary Property

MediaLibrary Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> MediaLibrary
Gets the media library.
Declaration Syntax
C#
public MediaLibraryContext MediaLibrary{ get;}
Value
The media library.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModulesSettings Property

ModulesSettings Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> ModulesSettings
Gets the modules settings.
Declaration Syntax
C#
public SettingsCollection ModulesSettings{ get;}
Value
The modules settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Publish Method (wait)

Publish Method (wait)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> Publish(Boolean)
Publishes the site's content.
Declaration Syntax
C#
public void Publish(
    bool wait
)
Parameters
wait (Boolean)
If True with waiting for end of publish

Assembly: MSS.Kernel (Module: MSS.Kernel)


RootItem Property

RootItem Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> RootItem
Gets the root of the site.
Declaration Syntax
C#
public Item RootItem{ get;}
Value
The site root.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Security Property

Security Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> Security
Gets the security.
Declaration Syntax
C#
public SecurityManager Security{ get;}
Value
The security.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Settings Property

Settings Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> Settings
Gets the site settings.
Declaration Syntax
C#
public SettingsCollection Settings{ get;}
Value
The site settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteAddress Property

SiteAddress Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SiteAddress
Gets or sets the site address i.e. the hostname or server name.
Declaration Syntax
C#
public string SiteAddress{ get; set;}
Value
The site address.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteData Property

SiteData Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SiteData
Gets or sets the site data.
Declaration Syntax
C#
public SettingsCollection SiteData{ get;}
Value
The site data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteId Property

SiteId Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SiteId
Gets the site id.
Declaration Syntax
C#
public string SiteId{ get;}
Value
The site id.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteIsNotDeleted Method

SiteIsNotDeleted Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SiteIsNotDeleted()()
Indicates if the site has NOT been deleted.
Declaration Syntax
C#
public bool SiteIsNotDeleted()
Return Value
True if NOT deleted; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteType Property

SiteType Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SiteType
Gets the type of the site.
Declaration Syntax
C#
public SiteType SiteType{ get;}
Value
The type of the site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeField Field

SiteTypeField Field
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SiteTypeField
Declaration Syntax
C#
public static readonly string SiteTypeField

Assembly: MSS.Kernel (Module: MSS.Kernel)


Status Property

Status Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> Status
Gets or sets the status. Uses the master database to read and write to.
Declaration Syntax
C#
public SiteContext.SiteContext..::SiteStatus Status{ get; set;}
Value
The status.

Assembly: MSS.Kernel (Module: MSS.Kernel)


StatusField Field

StatusField Field
Namespaces >> MSS.Sites.Contexts >> SiteContext >> StatusField
Declaration Syntax
C#
public static readonly string StatusField

Assembly: MSS.Kernel (Module: MSS.Kernel)


SuspendPublish Property

SuspendPublish Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SuspendPublish
Summary: If true prevents publishing on the local website, otherwise publishing will occur e.g. when a new user/group is created, an extranet user/group is created in Sitecore and has to be published. Creating a lot of users/groups will have bad performance issues if each has to be published individually.
Declaration Syntax
C#
public bool SuspendPublish{ get; set;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToString Method

ToString Method
Namespaces >> MSS.Sites.Contexts >> SiteContext >> ToString()()
Declaration Syntax
C#
public override string ToString()

Assembly: MSS.Kernel (Module: MSS.Kernel)


UpdateData Method (path)

UpdateData Method (path)
Namespaces >> MSS.Sites.Contexts >> SiteContext >> UpdateData(String)
Updates the data i.e. dictionary items and site settings, if the path is part of the current website.
Declaration Syntax
C#
public void UpdateData(
    string path
)
Parameters
path (String)
The path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UploadFolder Property

UploadFolder Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> UploadFolder
Gets the upload folder
Declaration Syntax
C#
public string UploadFolder{ get;}
Value
The upload folder.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UrlField Field

UrlField Field
Namespaces >> MSS.Sites.Contexts >> SiteContext >> UrlField
Declaration Syntax
C#
public static readonly string UrlField

Assembly: MSS.Kernel (Module: MSS.Kernel)


Wizard Property

Wizard Property
Namespaces >> MSS.Sites.Contexts >> SiteContext >> Wizard
Gets the wizard for the current site.
Declaration Syntax
C#
public Wizard Wizard{ get;}
Value
The wizard.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextBuilder Class

SiteContextBuilder Class
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder
This class is used to create a new site
Declaration Syntax
C#
public class SiteContextBuilder
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateSite(String, String, String, String, String, String, Boolean) | Creates the site.
 | CreateSite(String, String, String, String, String, String, Boolean, SiteContextBuilder..::CreationReport) | Creates the site.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SiteContextBuilder

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSite Method

CreateSite Method
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder >> CreateSite()()
Members
Icon | Member | Description
 | CreateSite(String, String, String, String, String, String, Boolean) | Creates the site.
 | CreateSite(String, String, String, String, String, String, Boolean, SiteContextBuilder..::CreationReport) | Creates the site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing)

CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing)
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder >> CreateSite(String, String, String, String, String, String, Boolean)
Creates the site.
Declaration Syntax
C#
public SiteContextBuilder.SiteContextBuilder..::CreationReport CreateSite(
    string siteType,
    string siteID,
    string url,
    string administratorInitials,
    string administratorEmail,
    string defaultLanguage,
    bool waitWhilePulishing
)
Parameters
siteType (String)
Type of the site.
siteID (String)
The site ID.
url (String)
The URL.
administratorInitials (String)
The administrator's initials.
administratorEmail (String)
The administrator's email.
defaultLanguage (String)
The default language.
waitWhilePulishing (Boolean)
Specifies should we wait while publishing is done.
Return Value
Process report.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing, report)

CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing, report)
Namespaces >> MSS.Sites.Contexts >> SiteContextBuilder >> CreateSite(String, String, String, String, String, String, Boolean, SiteContextBuilder..::CreationReport)
Creates the site.
Declaration Syntax
C#
public void CreateSite(
    string siteType,
    string siteID,
    string url,
    string administratorInitials,
    string administratorEmail,
    string defaultLanguage,
    bool waitWhilePulishing,
    SiteContextBuilder.SiteContextBuilder..::CreationReport report
)
Parameters
siteType (String)
Type of the site.
siteID (String)
The site ID.
url (String)
The URL.
administratorInitials (String)
The administrator's initials.
administratorEmail (String)
The administrator's email.
defaultLanguage (String)
The default language.
waitWhilePulishing (Boolean)
Specifies should we wait while publishing is done.
report (SiteContextBuilder..::CreationReport)
Report, cannot be null
Return Value
Process report.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextManager Class

SiteContextManager Class
Namespaces >> MSS.Sites.Contexts >> SiteContextManager
Provides functionality for work with sites
Declaration Syntax
C#
public class SiteContextManager : Manager<SiteContext>, ILicensed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(ID, TValue) | Adds the value using a specified entity. (Inherited from Manager<(Of <TValue>)>.)
 | AddSitecoreSite(Item) | Adds the Sitecore site.
 | AddSitecoreSite(Item, Int32) | Adds the site to the sitecore site context factory.
 | ClearCache(Database) | Clears the database cache. (Inherited from Manager<(Of <TValue>)>.)
 | ConfigWatcher_ConfigChanged(Object, ConfigChangedEventArgs) | Handles the ConfigChanged event of ConfigWatcher.
 | CreateEntity(Item) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity. (Inherited from Manager<(Of <TValue>)>.)
 | CreateEntity(ID, Database) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity. (Inherited from Manager<(Of <TValue>)>.)
 | CreateNewEntity(ID, Database) | Creates the new entity. (Overrides Manager <(Of < SiteContext >)>.CreateNewEntity(ID, Database).)
 | CreateSite(String, String, String, String, String, String, Boolean) | Creates the site.
 | CreateSite(String, String, String, String, String, String, Boolean, SiteContextBuilder..::CreationReport) | Creates the site.
 | CreateSiteContext(Item) |
 | Current | Gets the current site.
 | DeleteSite(String) | Deletes the site.
 | DeleteSiteItems(Database, String) | Deletes the site items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCache(Database) | Gets the cache. (Inherited from Manager<(Of <TValue>)>.)
 | GetCurrentSite()() | Retrieves the current site based on the domain of the current URL.
 | GetCurrentSite(Database) | Retrieves the current site based on the domain of the current URL.
 | GetEntities(Database) | Gets the entities using a specified database. (Inherited from Manager<(Of <TValue>)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSite(Item) | Gets the Site context for any item.
 | GetSite(ID, Database) | Gets the Site context for any item.
 | GetSiteByHostname(String) | Retrieves the site based on the domain for the given hostname
 | GetSiteByHostname(String, Database) | Retrieves the current site based on the domain and the database for the given hostname
 | GetSiteBySiteName(String, Database) | Gets the Site context by site name..
 | GetSitecoreSiteName(SiteContext) | Gets the name of the sitecore site.
 | GetSitecoreSiteName(Item) | Gets the name of the sitecore site.
 | GetSiteRootItem(ID) | Gets the site root item using the child ID.
 | GetSiteRootItem(ID, Database) | Gets the site root item from a specific database.
 | GetSiteRootItem(Item) | Gets the site root item using the child item.
 | GetSiteRootItem(String, Database) | Gets the root item of the site in question.
 | GetSiteRootItemByStieName(String, Database) | Gets site root item by site name.
 | GetSiteRootItems(Database) | Gets the available site root items for database.
 | GetSites(Database) | Gets the sites from the database.
 | GetSitesCount(Database) | Gets current site count.
 | GetSitesMaxCount()() | Gets max site allowed by license.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasLicense()() | Determines whether a SiteContextManager has a license for new site create.
 | Initialize()() | Initializes SiteContextManager.
 | InitializeSites()() | Reads all sites and initializes the site-manager.
 | IsFrontend | Returns true if the current request is directed to the frontend; otherwise, false.
 | IsHostname(String) | Determines whether the specified hostname is valid.
 | IsHostnameFree(String) | Determines whether the specified hostname is free.
 | IsSiteExists(String, Database) |
 | Item[([ID, Database])] | Gets the value with the specified key. (Inherited from Manager<(Of <TValue>)>.)
 | LicenseKey | Gets a sites license key.
 | Load()() | Loads the sitecore context manager. (Overrides Manager <(Of < SiteContext >)>.Load()().)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReloadSite(ID, Database) | Reloads the site.
 | Remove(ID, Database) | Removes entity value using a specified database. (Inherited from Manager<(Of <TValue>)>.)
 | RemoveEntityFromCache(ID, Database) | Removes the entity from the cache. (Inherited from Manager<(Of <TValue>)>.)
 | ResetSites()() | Resets the site list and reloads it.
 | Server | Gets the server.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Manager <(Of < SiteContext >)>
 |  | SiteContextManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddSitecoreSite Method

AddSitecoreSite Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> AddSitecoreSite()()
Members
Icon | Member | Description
 | AddSitecoreSite(Item) | Adds the Sitecore site.
 | AddSitecoreSite(Item, Int32) | Adds the site to the sitecore site context factory.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddSitecoreSite Method (siteItem)

AddSitecoreSite Method (siteItem)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> AddSitecoreSite(Item)
Adds the Sitecore site.
Declaration Syntax
C#
public static void AddSitecoreSite(
    Item siteItem
)
Parameters
siteItem (Item)
The site item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddSitecoreSite Method (siteItem, index)

AddSitecoreSite Method (siteItem, index)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> AddSitecoreSite(Item, Int32)
Adds the site to the sitecore site context factory.
Declaration Syntax
C#
public static bool AddSitecoreSite(
    Item siteItem,
    int index
)
Parameters
siteItem (Item)
The site item.
index (Int32)
The index.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ConfigWatcher_ConfigChanged Method (sender, e)

ConfigWatcher_ConfigChanged Method (sender, e)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> ConfigWatcher_ConfigChanged(Object, ConfigChangedEventArgs)
Handles the ConfigChanged event of ConfigWatcher.
Declaration Syntax
C#
public static void ConfigWatcher_ConfigChanged(
    Object sender,
    ConfigChangedEventArgs e
)
Parameters
sender (Object)
The source of the event.
e (ConfigChangedEventArgs)
The ConfigChangedEventArgs instance containing the event data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateNewEntity Method (id, database)

CreateNewEntity Method (id, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> CreateNewEntity(ID, Database)
Creates the new entity.
Declaration Syntax
C#
protected override SiteContext CreateNewEntity(
    ID id,
    Database database
)
Parameters
id (ID)
The id.
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSite Method

CreateSite Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> CreateSite()()
Members
Icon | Member | Description
 | CreateSite(String, String, String, String, String, String, Boolean) | Creates the site.
 | CreateSite(String, String, String, String, String, String, Boolean, SiteContextBuilder..::CreationReport) | Creates the site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing)

CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> CreateSite(String, String, String, String, String, String, Boolean)
Creates the site.
Declaration Syntax
C#
public SiteContextBuilder.SiteContextBuilder..::CreationReport CreateSite(
    string siteType,
    string siteID,
    string url,
    string administratorInitials,
    string administratorEmail,
    string defaultLanguage,
    bool waitWhilePulishing
)
Parameters
siteType (String)
Type of the site.
siteID (String)
The site ID.
url (String)
The URL.
administratorInitials (String)
The administrators initials.
administratorEmail (String)
The administrators email.
defaultLanguage (String)
The default language.
waitWhilePulishing (Boolean)
If “wait while publishing” has been set then true; otherwise, false.
Return Value
The site creation report.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing, report)

CreateSite Method (siteType, siteID, url, administratorInitials, administratorEmail, defaultLanguage, waitWhilePulishing, report)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> CreateSite(String, String, String, String, String, String, Boolean, SiteContextBuilder..::CreationReport)
Creates the site.
Declaration Syntax
C#
public void CreateSite(
    string siteType,
    string siteID,
    string url,
    string administratorInitials,
    string administratorEmail,
    string defaultLanguage,
    bool waitWhilePulishing,
    SiteContextBuilder.SiteContextBuilder..::CreationReport report
)
Parameters
siteType (String)
Type of the site.
siteID (String)
The site ID.
url (String)
The URL.
administratorInitials (String)
The administrator's initials.
administratorEmail (String)
The administrator's email.
defaultLanguage (String)
The default language.
waitWhilePulishing (Boolean)
If “wait while publishing” has been set then true; otherwise, false.
report (SiteContextBuilder..::CreationReport)
The report.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSiteContext Method (siteContextRoot)

CreateSiteContext Method (siteContextRoot)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> CreateSiteContext(Item)
Declaration Syntax
C#
protected SiteContext CreateSiteContext(
    Item siteContextRoot
)
Parameters
siteContextRoot (Item)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Current Property

Current Property
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> Current
Gets the current site.
Declaration Syntax
C#
public SiteContext Current{ get;}
Value
The current site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteSite Method (key)

DeleteSite Method (key)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> DeleteSite(String)
Deletes the site.
Declaration Syntax
C#
public void DeleteSite(
    string key
)
Parameters
key (String)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteSiteItems Method (database, key)

DeleteSiteItems Method (database, key)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> DeleteSiteItems(Database, String)
Deletes the site items.
Declaration Syntax
C#
public void DeleteSiteItems(
    Database database,
    string key
)
Parameters
database (Database)
The database.
key (String)
The key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCurrentSite Method

GetCurrentSite Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetCurrentSite()()
Members
Icon | Member | Description
 | GetCurrentSite()() | Retrieves the current site based on the domain of the current URL.
 | GetCurrentSite(Database) | Retrieves the current site based on the domain of the current URL.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCurrentSite Method

GetCurrentSite Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetCurrentSite()()
Retrieves the current site based on the domain of the current URL.
Declaration Syntax
C#
public SiteContext GetCurrentSite()
Return Value
A SiteContext instance.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCurrentSite Method (database)

GetCurrentSite Method (database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetCurrentSite(Database)
Retrieves the current site based on the domain of the current URL.
Declaration Syntax
C#
public SiteContext GetCurrentSite(
    Database database
)
Parameters
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSite Method

GetSite Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSite()()
Members
Icon | Member | Description
 | GetSite(Item) | Gets the Site context for any item.
 | GetSite(ID, Database) | Gets the Site context for any item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSite Method (childID, database)

GetSite Method (childID, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSite(ID, Database)
Gets the Site context for any item.
Declaration Syntax
C#
public SiteContext GetSite(
    ID childID,
    Database database
)
Parameters
childID (ID)
The child ID.
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSite Method (item)

GetSite Method (item)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSite(Item)
Gets the Site context for any item.
Declaration Syntax
C#
public SiteContext GetSite(
    Item item
)
Parameters
item (Item)
The item.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteByHostname Method

GetSiteByHostname Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteByHostname()()
Members
Icon | Member | Description
 | GetSiteByHostname(String) | Retrieves the site based on the domain for the given hostname
 | GetSiteByHostname(String, Database) | Retrieves the current site based on the domain and the database for the given hostname

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteByHostname Method (hostname)

GetSiteByHostname Method (hostname)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteByHostname(String)
Retrieves the site based on the domain for the given hostname
Declaration Syntax
C#
public SiteContext GetSiteByHostname(
    string hostname
)
Parameters
hostname (String)
Return Value
A SiteContext instance

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteByHostname Method (hostname, database)

GetSiteByHostname Method (hostname, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteByHostname(String, Database)
Retrieves the current site based on the domain and the database for the given hostname
Declaration Syntax
C#
public SiteContext GetSiteByHostname(
    string hostname,
    Database database
)
Parameters
hostname (String)
The hostname.
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteBySiteName Method (siteName, database)

GetSiteBySiteName Method (siteName, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteBySiteName(String, Database)
Gets the Site context by site name..
Declaration Syntax
C#
public SiteContext GetSiteBySiteName(
    string siteName,
    Database database
)
Parameters
siteName (String)
Name of the site.
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSitecoreSiteName Method

GetSitecoreSiteName Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSitecoreSiteName()()
Members
Icon | Member | Description
 | GetSitecoreSiteName(SiteContext) | Gets the name of the sitecore site.
 | GetSitecoreSiteName(Item) | Gets the name of the sitecore site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSitecoreSiteName Method (site)

GetSitecoreSiteName Method (site)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSitecoreSiteName(SiteContext)
Gets the name of the sitecore site.
Declaration Syntax
C#
public static string GetSitecoreSiteName(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The Sitecore site name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSitecoreSiteName Method (siteRootItem)

GetSitecoreSiteName Method (siteRootItem)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSitecoreSiteName(Item)
Gets the name of the sitecore site.
Declaration Syntax
C#
public static string GetSitecoreSiteName(
    Item siteRootItem
)
Parameters
siteRootItem (Item)
The site root item.
Return Value
The Sitecore site name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootItem Method

GetSiteRootItem Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteRootItem()()
Members
Icon | Member | Description
 | GetSiteRootItem(ID) | Gets the site root item using the child ID.
 | GetSiteRootItem(ID, Database) | Gets the site root item from a specific database.
 | GetSiteRootItem(Item) | Gets the site root item using the child item.
 | GetSiteRootItem(String, Database) | Gets the root item of the site in question.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootItem Method (childID)

GetSiteRootItem Method (childID)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteRootItem(ID)
Gets the site root item using the child ID.
Declaration Syntax
C#
public Item GetSiteRootItem(
    ID childID
)
Parameters
childID (ID)
The child ID.
Return Value
The site root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootItem Method (childID, database)

GetSiteRootItem Method (childID, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteRootItem(ID, Database)
Gets the site root item from a specific database.
Declaration Syntax
C#
public Item GetSiteRootItem(
    ID childID,
    Database database
)
Parameters
childID (ID)
The child ID.
database (Database)
The database.
Return Value
The site root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootItem Method (child)

GetSiteRootItem Method (child)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteRootItem(Item)
Gets the site root item using the child item.
Declaration Syntax
C#
public Item GetSiteRootItem(
    Item child
)
Parameters
child (Item)
The child item.
Return Value
The site root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootItem Method (hostname, database)

GetSiteRootItem Method (hostname, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteRootItem(String, Database)
Gets the root item of the site in question.
Declaration Syntax
C#
public Item GetSiteRootItem(
    string hostname,
    Database database
)
Parameters
hostname (String)
The hostname.
database (Database)
The database.
Return Value
The site root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootItemByStieName Method (siteName, database)

GetSiteRootItemByStieName Method (siteName, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteRootItemByStieName(String, Database)
Gets site root item by site name.
Declaration Syntax
C#
public Item GetSiteRootItemByStieName(
    string siteName,
    Database database
)
Parameters
siteName (String)
Name of the site.
database (Database)
The database.
Return Value
The site root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootItems Method (database)

GetSiteRootItems Method (database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSiteRootItems(Database)
Gets the available site root items for database.
Declaration Syntax
C#
public static Item[] GetSiteRootItems(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The site root items.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSites Method (database)

GetSites Method (database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSites(Database)
Gets the sites from the database.
Declaration Syntax
C#
public List<SiteContext> GetSites(
    Database database
)
Parameters
database (Database)
The database.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSitesCount Method (database)

GetSitesCount Method (database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSitesCount(Database)
Gets current site count.
Declaration Syntax
C#
public int GetSitesCount(
    Database database
)
Parameters
database (Database)
Thef database
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSitesMaxCount Method

GetSitesMaxCount Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> GetSitesMaxCount()()
Gets max site allowed by license.
Declaration Syntax
C#
public int GetSitesMaxCount()
Return Value
Max sites count.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HasLicense Method

HasLicense Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> HasLicense()()
Determines whether a SiteContextManager has a license for new site create.
Declaration Syntax
C#
public bool HasLicense()
Return Value
True is number of created sites less than awailable by license. Otherwise false

Assembly: MSS.Kernel (Module: MSS.Kernel)


Initialize Method

Initialize Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> Initialize()()
Initializes SiteContextManager.
Declaration Syntax
C#
public static void Initialize()

Assembly: MSS.Kernel (Module: MSS.Kernel)


InitializeSites Method

InitializeSites Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> InitializeSites()()
Reads all sites and initializes the site-manager.
Declaration Syntax
C#
public static void InitializeSites()

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsFrontend Property

IsFrontend Property
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> IsFrontend
Returns true if the current request is directed to the frontend; otherwise, false.
Declaration Syntax
C#
public bool IsFrontend{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsHostname Method (hostname)

IsHostname Method (hostname)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> IsHostname(String)
Determines whether the specified hostname is valid.
Declaration Syntax
C#
public static bool IsHostname(
    string hostname
)
Parameters
hostname (String)
The hostname.
Return Value
True if the hostname is valid; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsHostnameFree Method (hostname)

IsHostnameFree Method (hostname)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> IsHostnameFree(String)
Determines whether the specified hostname is free.
Declaration Syntax
C#
public static bool IsHostnameFree(
    string hostname
)
Parameters
hostname (String)
The hostname.
Return Value
True if the hostname is free; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsSiteExists Method (siteName, database)

IsSiteExists Method (siteName, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> IsSiteExists(String, Database)
Declaration Syntax
C#
public bool IsSiteExists(
    string siteName,
    Database database
)
Parameters
siteName (String)
database (Database)

Assembly: MSS.Kernel (Module: MSS.Kernel)


LicenseKey Property

LicenseKey Property
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> LicenseKey
Gets a sites license key.
Declaration Syntax
C#
public string LicenseKey{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


Load Method

Load Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> Load()()
Loads the sitecore context manager.
Declaration Syntax
C#
public override void Load()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ReloadSite Method (siteID, database)

ReloadSite Method (siteID, database)
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> ReloadSite(ID, Database)
Reloads the site.
Declaration Syntax
C#
public void ReloadSite(
    ID siteID,
    Database database
)
Parameters
siteID (ID)
The site ID.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ResetSites Method

ResetSites Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> ResetSites()()
Resets the site list and reloads it.
Declaration Syntax
C#
public static void ResetSites()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Server Property

Server Property
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> Server
Gets the server.
Declaration Syntax
C#
public Server Server{ get;}
Value
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContext.SiteStatus Enumeration

SiteContext..::SiteStatus Enumeration
Namespaces >> MSS.Sites.Contexts >> SiteContext >> SiteContext..::SiteStatus
Provides status information for the current site
Declaration Syntax
C#
public enum SiteStatus
Members
Member | Description
UnInitialized |
Running |
Stopped |
Updated |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.Contexts.MediaLibrary Namespace

MSS.Sites.Contexts.MediaLibrary Namespace
Namespaces >> MSS.Sites.Contexts.MediaLibrary
Declaration Syntax
C#
namespace MSS.Sites.Contexts.MediaLibrary
Types
All Types Classes
Icon | Type | Description
 | MediaLibraryContext | Represents the media library of the site.


MediaLibraryContext Class

MediaLibraryContext Class
Namespaces >> MSS.Sites.Contexts.MediaLibrary >> MediaLibraryContext
Represents the media library of the site.
Declaration Syntax
C#
public class MediaLibraryContext : Entity
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaLibraryContextMediaLibraryContextNew(ID, Server, Database) | Initializes a new instance of the MediaLibraryContext class.
 | Clone()() | Clones the entity. (Overrides Entity.Clone()().)
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Upload | Return the 'upload' folder which is in the site's media folder. It will be created if it doesn't exist.
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | MediaLibraryContext

Assembly: MSS.Kernel (Module: MSS.Kernel)


MediaLibraryContext Constructor (id, server, database)

MediaLibraryContext Constructor (id, server, database)
Namespaces >> MSS.Sites.Contexts.MediaLibrary >> MediaLibraryContext >> MediaLibraryContextMediaLibraryContextNew(ID, Server, Database)
Initializes a new instance of the MediaLibraryContext class.
Declaration Syntax
C#
public MediaLibraryContext(
    ID id,
    Server server,
    Database database
)
Parameters
id (ID)
The ID.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Sites.Contexts.MediaLibrary >> MediaLibraryContext >> Clone()()
Clones the entity.
Declaration Syntax
C#
public override Entity Clone()
Return Value
Thfe cloned entity.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Upload Property

Upload Property
Namespaces >> MSS.Sites.Contexts.MediaLibrary >> MediaLibraryContext >> Upload
Return the 'upload' folder which is in the site's media folder. It will be created if it doesn't exist.
Declaration Syntax
C#
public virtual Item Upload{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.Contexts.Settings Namespace

MSS.Sites.Contexts.Settings Namespace
Namespaces >> MSS.Sites.Contexts.Settings
Declaration Syntax
C#
namespace MSS.Sites.Contexts.Settings
Types
All Types Classes
Icon | Type | Description
 | SystemSettings | System settings.
 | WizardSettings | Inherits settings functionality from the base class.


SystemSettings Class

SystemSettings Class
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings
System settings.
Declaration Syntax
C#
[SerializableAttribute]
public class SystemSettings : SettingsCollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()() | Clears all settings. (Inherited from SettingsCollection.)
 | ClearSection(String) | Clears the section. (Inherited from SettingsCollection.)
 | Clone()() | Makes a deep clone of the instance (Inherited from SettingsCollection.)
 | Data | Obsolete. (Inherited from SettingsCollection.)
 | Dirty | Gets a value indicating whether some settings have been changed but setting collection hasn't been saved. (Inherited from SettingsCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetData()() | Obsolete. (Inherited from SettingsCollection.)
 | GetData(String) | (Inherited from SettingsCollection.)
 | GetEntry(String) | Gets the setting collection by key. (Inherited from SettingsCollection.)
 | GetEntry(String, String) | Gets a dictionary entry. (Inherited from SettingsCollection.)
 | GetGlobalSettings(String) | Gets the global settings item. (Inherited from SettingsCollection.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalSettings()() | Gets the local settings item. (Inherited from SettingsCollection.)
 | GetLocalSettings(String) | Gets the local settings item using a specific path. (Inherited from SettingsCollection.)
 | GetSection(String) | Gets a section. (Inherited from SettingsCollection.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeSettings()() | Gets the type settings. (Inherited from SettingsCollection.)
 | GetTypeSettings(String) | Gets the type settings item using a specific path. (Inherited from SettingsCollection.)
 | Init()() | Initialises the SettingsCollection. (Inherited from SettingsCollection.)
 | Init(String) | Initialises the SettingsCollection. (Inherited from SettingsCollection.)
 | Item[([String])] | Gets or sets the String with the specified key. (Inherited from SettingsCollection.)
 | LoadAbsoluteSettings(String) | Loads the absolute settings. (Inherited from SettingsCollection.)
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings. (Inherited from SettingsCollection.)
 | Loaded | Gets a value indicating whether the SettingCollection is loaded. (Inherited from SettingsCollection.)
 | LoadSettings()() | Loads the settings. (Inherited from SettingsCollection.)
 | LoadSettings(String) | Loads the settings. (Inherited from SettingsCollection.)
 | LoadSettings(Item) | Loads the settings. (Inherited from SettingsCollection.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveSettings(Boolean) | Saves the settings. (Inherited from SettingsCollection.)
 | SaveSettings(String) | Saves the settings using a specific path. (Inherited from SettingsCollection.)
 | SaveSettings(String, Boolean) | Saves the settings. (Inherited from SettingsCollection.)
 | SaveSettings(Item) | Saves the settings to the item. (Inherited from SettingsCollection.)
 | SetData(StringDictionary) | (Inherited from SettingsCollection.)
 | SetData(SettingsCollection) | (Inherited from SettingsCollection.)
 | SetSection(String, StringDictionary) | (Inherited from SettingsCollection.)
 | SetSetting(String, String, String) | Sets the setting. (Inherited from SettingsCollection.)
 | Setting(String) | Gets the setting by a key. (Inherited from SettingsCollection.)
 | Setting(String, String) | Gets the setting from a section by a key. (Inherited from SettingsCollection.)
 | Setting(String, String, String) | Gets the setting from a section by a key. (Inherited from SettingsCollection.)
 | ToInt(String) | Gets the int setting by a key. (Inherited from SettingsCollection.)
 | ToInt(String, Int32) | Gets the int setting by a key. (Inherited from SettingsCollection.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updatedata(String) | Updatedatas the settings. (Inherited from SettingsCollection.)
Inheritance Hierarchy
Object
 | SettingsCollection
 |  | SystemSettings

Assembly: MSS.Kernel (Module: MSS.Kernel)


WizardSettings Class

WizardSettings Class
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings
Inherits settings functionality from the base class.
Declaration Syntax
C#
[SerializableAttribute]
public class WizardSettings : SettingsCollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()() | Clears all settings. (Inherited from SettingsCollection.)
 | ClearSection(String) | Clears the section. (Inherited from SettingsCollection.)
 | Clone()() | Makes a deep clone of the instance (Inherited from SettingsCollection.)
 | Data | Obsolete. (Inherited from SettingsCollection.)
 | Dirty | Gets a value indicating whether some settings have been changed but setting collection hasn't been saved. (Inherited from SettingsCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetData()() | Obsolete. (Inherited from SettingsCollection.)
 | GetData(String) | (Inherited from SettingsCollection.)
 | GetEntry(String) | Gets the setting collection by key. (Inherited from SettingsCollection.)
 | GetEntry(String, String) | Gets a dictionary entry. (Inherited from SettingsCollection.)
 | GetGlobalSettings(String) | Gets the global settings item. (Inherited from SettingsCollection.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalSettings()() | Gets the local settings item. (Inherited from SettingsCollection.)
 | GetLocalSettings(String) | Gets the local settings item using a specific path. (Inherited from SettingsCollection.)
 | GetSection(String) | Gets a section. (Inherited from SettingsCollection.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeSettings()() | Gets the type settings. (Inherited from SettingsCollection.)
 | GetTypeSettings(String) | Gets the type settings item using a specific path. (Inherited from SettingsCollection.)
 | Init()() | Initialises the SettingsCollection. (Inherited from SettingsCollection.)
 | Init(String) | Initialises the SettingsCollection. (Inherited from SettingsCollection.)
 | Item[([String])] | Gets or sets the String with the specified key. (Inherited from SettingsCollection.)
 | LoadAbsoluteSettings(String) | Loads the absolute settings. (Inherited from SettingsCollection.)
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings. (Inherited from SettingsCollection.)
 | Loaded | Gets a value indicating whether the SettingCollection is loaded. (Inherited from SettingsCollection.)
 | LoadSettings()() | Loads the settings. (Inherited from SettingsCollection.)
 | LoadSettings(String) | Loads the settings. (Inherited from SettingsCollection.)
 | LoadSettings(Item) | Loads the settings. (Inherited from SettingsCollection.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveSettings(Boolean) | Saves the settings. (Inherited from SettingsCollection.)
 | SaveSettings(String) | Saves the settings using a specific path. (Inherited from SettingsCollection.)
 | SaveSettings(String, Boolean) | Saves the settings. (Inherited from SettingsCollection.)
 | SaveSettings(Item) | Saves the settings to the item. (Inherited from SettingsCollection.)
 | SetData(StringDictionary) | (Inherited from SettingsCollection.)
 | SetData(SettingsCollection) | (Inherited from SettingsCollection.)
 | SetSection(String, StringDictionary) | (Inherited from SettingsCollection.)
 | SetSetting(String, String, String) | Sets the setting. (Inherited from SettingsCollection.)
 | Setting(String) | Gets the setting by a key. (Inherited from SettingsCollection.)
 | Setting(String, String) | Gets the setting from a section by a key. (Inherited from SettingsCollection.)
 | Setting(String, String, String) | Gets the setting from a section by a key. (Inherited from SettingsCollection.)
 | ToInt(String) | Gets the int setting by a key. (Inherited from SettingsCollection.)
 | ToInt(String, Int32) | Gets the int setting by a key. (Inherited from SettingsCollection.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updatedata(String) | Updatedatas the settings. (Inherited from SettingsCollection.)
Inheritance Hierarchy
Object
 | SettingsCollection
 |  | WizardSettings

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.GlobalMenus Namespace

MSS.Sites.GlobalMenus Namespace
Namespaces >> MSS.Sites.GlobalMenus
Declaration Syntax
C#
namespace MSS.Sites.GlobalMenus
Types
All Types Classes
Icon | Type | Description
 | GlobalMenu | Site global menu. Site type can have global menu. All sites add global menu to the site menu.
 | GlobalMenuManager | Manages global menus.


GlobalMenu Class

GlobalMenu Class
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenu
Site global menu. Site type can have global menu. All sites add global menu to the site menu.
Declaration Syntax
C#
public class GlobalMenu : Entity
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GlobalMenuGlobalMenuNew(ID, Server) |
 | GlobalMenuGlobalMenuNew(ID, Server, Database) |
 | Clone()() | Clones this instance. (Overrides Entity.Clone()().)
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | RootItem | Gets the global menu root item.
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | GlobalMenu

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalMenu Constructor

GlobalMenu Constructor
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenu >> GlobalMenuGlobalMenuNew()()
Members
Icon | Member | Description
 | GlobalMenuGlobalMenuNew(ID, Server) |
 | GlobalMenuGlobalMenuNew(ID, Server, Database) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalMenu Constructor (menuID, server)

GlobalMenu Constructor (menuID, server)
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenu >> GlobalMenuGlobalMenuNew(ID, Server)
Declaration Syntax
C#
public GlobalMenu(
    ID menuID,
    Server server
)
Parameters
menuID (ID)
server (Server)

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalMenu Constructor (menuID, server, database)

GlobalMenu Constructor (menuID, server, database)
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenu >> GlobalMenuGlobalMenuNew(ID, Server, Database)
Declaration Syntax
C#
public GlobalMenu(
    ID menuID,
    Server server,
    Database database
)
Parameters
menuID (ID)
server (Server)
database (Database)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenu >> Clone()()
Clones this instance.
Declaration Syntax
C#
public override Entity Clone()
Return Value
The cloned instance.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RootItem Property

RootItem Property
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenu >> RootItem
Gets the global menu root item.
Declaration Syntax
C#
public Item RootItem{ get;}
Value
The root item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalMenuManager Class

GlobalMenuManager Class
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenuManager
Manages global menus.
Declaration Syntax
C#
public class GlobalMenuManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GlobalMenuManagerGlobalMenuManagerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMenuRoot(SiteType) | Gets the global menu root.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GlobalMenuManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalMenuManager Constructor

GlobalMenuManager Constructor
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenuManager >> GlobalMenuManagerGlobalMenuManagerNew()()
Declaration Syntax
C#
public GlobalMenuManager()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetMenuRoot Method (type)

GetMenuRoot Method (type)
Namespaces >> MSS.Sites.GlobalMenus >> GlobalMenuManager >> GetMenuRoot(SiteType)
Gets the global menu root.
Declaration Syntax
C#
public static GlobalMenu GetMenuRoot(
    SiteType type
)
Parameters
type (SiteType)
The type.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.Security Namespace

MSS.Sites.Security Namespace
Namespaces >> MSS.Sites.Security
Declaration Syntax
C#
namespace MSS.Sites.Security
Types
All Types Classes
Icon | Type | Description
 | SecurityManager | Provides functionality for work with some users and groups of an mss site.


SecurityManager Class

SecurityManager Class
Namespaces >> MSS.Sites.Security >> SecurityManager
Provides functionality for work with some users and groups of an mss site.
Declaration Syntax
C#
public class SecurityManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AssignUsersToGroup(array<String>[](), String) | Assigns the users to a specific group.
 | AssignUserToGroups(String, array<String>[]()) | Assigns the user to a list of specified groups.
 | ChangeGroupTemplateForGroup(Group%, GroupTemplate) | Changes rights and additional roles for a group according to the new GroupTemplate.
 | CreateGroup(String, GroupTemplate) | Creates a group using a specified GroupTempate.
 | CreateUser(String, String, String, String) | Creates the user.
 | CurrentUser | Gets the current user.
 | DeleteGroup(String) | Removes a group.
 | DeleteSiteSecurity()() | Deletes site security.
 | DeleteUser(String) | Deletes the user with the specific name that belongs to the site
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllUsers()() | Gets all users of the site.
 | GetGroup(String) | Returns a group using a specified name.
 | GetGroups()() | Returns all groups for the site.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(String) | Gets the user with the specific name that belongs to the site.
 | GroupHasRight(Group, String) | Indicates whether a specific group has MSS security rights defined.
 | GroupIsExists(String) | Indicates whether a group exists
 | IsAllowed(ItemOperation, Item) | Determines whether the specified operation is allowed.
 | IsLoggedIn | Gets a value indicating whether there is a user who is logged in.
 | IsRestrictAccess(Item) | Indicates whether the item has restricted access rights.
 | Login(String, String) | Logs the specified user in to the security manager.
 | Logout()() | Logs the user out of the security manager.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveRestrictAccess(Item) | Removes restricted access from the item.
 | RoleHasRight(RoleItem, String) | Indicates whether a specific role has Sitecore security rights defined.
 | SetRestrictAccess(Item) | Sets “restricted” to the item by un-checking the security inheritance for the item and adding rights to roles that have the "ManageSecurity" right.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserHasRight(String) | Indicates whether the current user has a rights defined.
 | UserHasRight(UserItem, String) | Indicates whether a specific user has Sitecore security rights defined.
 | UserHasRight(User, String) | Indicates whether a specific user has MSS security rights defined.
 | UserIsExists(String) | Indicated whether there is a user with the specific name that belongs to the site.
Inheritance Hierarchy
Object
SecurityManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


AssignUsersToGroup Method (usersNames, groupName)

AssignUsersToGroup Method (usersNames, groupName)
Namespaces >> MSS.Sites.Security >> SecurityManager >> AssignUsersToGroup(array<String>[](), String)
Assigns the users to a specific group.
Declaration Syntax
C#
public void AssignUsersToGroup(
    string[] usersNames,
    string groupName
)
Parameters
usersNames (array< String >[]())
The users names.
groupName (String)
Name of the group.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AssignUserToGroups Method (userName, groupsNames)

AssignUserToGroups Method (userName, groupsNames)
Namespaces >> MSS.Sites.Security >> SecurityManager >> AssignUserToGroups(String, array<String>[]())
Assigns the user to a list of specified groups.
Declaration Syntax
C#
public void AssignUserToGroups(
    string userName,
    string[] groupsNames
)
Parameters
userName (String)
Name of the user.
groupsNames (array< String >[]())
The groups names.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ChangeGroupTemplateForGroup Method (group, newGroupTemplate)

ChangeGroupTemplateForGroup Method (group, newGroupTemplate)
Namespaces >> MSS.Sites.Security >> SecurityManager >> ChangeGroupTemplateForGroup(Group%, GroupTemplate)
Changes rights and additional roles for a group according to the new GroupTemplate.
Declaration Syntax
C#
public void ChangeGroupTemplateForGroup(
    ref Group group,
    GroupTemplate newGroupTemplate
)
Parameters
group (Group %)
Group
newGroupTemplate (GroupTemplate)
Group template

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateGroup Method (name, groupTemplate)

CreateGroup Method (name, groupTemplate)
Namespaces >> MSS.Sites.Security >> SecurityManager >> CreateGroup(String, GroupTemplate)
Creates a group using a specified GroupTempate.
Declaration Syntax
C#
public void CreateGroup(
    string name,
    GroupTemplate groupTemplate
)
Parameters
name (String)
Group name.
groupTemplate (GroupTemplate)
Group template.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateUser Method (name, fullName, password, email)

CreateUser Method (name, fullName, password, email)
Namespaces >> MSS.Sites.Security >> SecurityManager >> CreateUser(String, String, String, String)
Creates the user.
Declaration Syntax
C#
public void CreateUser(
    string name,
    string fullName,
    string password,
    string email
)
Parameters
name (String)
The user name.
fullName (String)
The full name.
password (String)
The password.
email (String)
The email address.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CurrentUser Property

CurrentUser Property
Namespaces >> MSS.Sites.Security >> SecurityManager >> CurrentUser
Gets the current user.
Declaration Syntax
C#
public User CurrentUser{ get;}
Value
The current user.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteGroup Method (name)

DeleteGroup Method (name)
Namespaces >> MSS.Sites.Security >> SecurityManager >> DeleteGroup(String)
Removes a group.
Declaration Syntax
C#
public void DeleteGroup(
    string name
)
Parameters
name (String)
Group name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteSiteSecurity Method

DeleteSiteSecurity Method
Namespaces >> MSS.Sites.Security >> SecurityManager >> DeleteSiteSecurity()()
Deletes site security.
Declaration Syntax
C#
public void DeleteSiteSecurity()

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteUser Method (name)

DeleteUser Method (name)
Namespaces >> MSS.Sites.Security >> SecurityManager >> DeleteUser(String)
Deletes the user with the specific name that belongs to the site
Declaration Syntax
C#
public void DeleteUser(
    string name
)
Parameters
name (String)
The user name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAllUsers Method

GetAllUsers Method
Namespaces >> MSS.Sites.Security >> SecurityManager >> GetAllUsers()()
Gets all users of the site.
Declaration Syntax
C#
public User[] GetAllUsers()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGroup Method (groupName)

GetGroup Method (groupName)
Namespaces >> MSS.Sites.Security >> SecurityManager >> GetGroup(String)
Returns a group using a specified name.
Declaration Syntax
C#
public Group GetGroup(
    string groupName
)
Parameters
groupName (String)
Group's name.
Return Value
Group.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGroups Method

GetGroups Method
Namespaces >> MSS.Sites.Security >> SecurityManager >> GetGroups()()
Returns all groups for the site.
Declaration Syntax
C#
public Group[] GetGroups()
Return Value
Groups of site's

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetUser Method (name)

GetUser Method (name)
Namespaces >> MSS.Sites.Security >> SecurityManager >> GetUser(String)
Gets the user with the specific name that belongs to the site.
Declaration Syntax
C#
public User GetUser(
    string name
)
Parameters
name (String)
The user name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GroupHasRight Method (group, rightName)

GroupHasRight Method (group, rightName)
Namespaces >> MSS.Sites.Security >> SecurityManager >> GroupHasRight(Group, String)
Indicates whether a specific group has MSS security rights defined.
Declaration Syntax
C#
public static bool GroupHasRight(
    Group group,
    string rightName
)
Parameters
group (Group)
Group.
rightName (String)
The right name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GroupIsExists Method (name)

GroupIsExists Method (name)
Namespaces >> MSS.Sites.Security >> SecurityManager >> GroupIsExists(String)
Indicates whether a group exists
Declaration Syntax
C#
public bool GroupIsExists(
    string name
)
Parameters
name (String)
Group name

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAllowed Method (operation, item)

IsAllowed Method (operation, item)
Namespaces >> MSS.Sites.Security >> SecurityManager >> IsAllowed(ItemOperation, Item)
Determines whether the specified operation is allowed.
Declaration Syntax
C#
public bool IsAllowed(
    ItemOperation operation,
    Item item
)
Parameters
operation (ItemOperation)
The operation.
item (Item)
The item.
Return Value
true if the specified operation is allowed; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsLoggedIn Property

IsLoggedIn Property
Namespaces >> MSS.Sites.Security >> SecurityManager >> IsLoggedIn
Gets a value indicating whether there is a user who is logged in.
Declaration Syntax
C#
public bool IsLoggedIn{ get;}
Value
True if there's user who is logged in; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsRestrictAccess Method (item)

IsRestrictAccess Method (item)
Namespaces >> MSS.Sites.Security >> SecurityManager >> IsRestrictAccess(Item)
Indicates whether the item has restricted access rights.
Declaration Syntax
C#
public bool IsRestrictAccess(
    Item item
)
Parameters
item (Item)
The Item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Login Method (userName, password)

Login Method (userName, password)
Namespaces >> MSS.Sites.Security >> SecurityManager >> Login(String, String)
Logs the specified user in to the security manager.
Declaration Syntax
C#
public User.User..::LoginResult Login(
    string userName,
    string password
)
Parameters
userName (String)
Name of the user.
password (String)
The password.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Logout Method

Logout Method
Namespaces >> MSS.Sites.Security >> SecurityManager >> Logout()()
Logs the user out of the security manager.
Declaration Syntax
C#
public DomainAccessResult Logout()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


RemoveRestrictAccess Method (item)

RemoveRestrictAccess Method (item)
Namespaces >> MSS.Sites.Security >> SecurityManager >> RemoveRestrictAccess(Item)
Removes restricted access from the item.
Declaration Syntax
C#
public void RemoveRestrictAccess(
    Item item
)
Parameters
item (Item)
The Item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RoleHasRight Method (role, rightName)

RoleHasRight Method (role, rightName)
Namespaces >> MSS.Sites.Security >> SecurityManager >> RoleHasRight(RoleItem, String)
Indicates whether a specific role has Sitecore security rights defined.
Declaration Syntax
C#
public static bool RoleHasRight(
    RoleItem role,
    string rightName
)
Parameters
role (RoleItem)
Role.
rightName (String)
The right name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetRestrictAccess Method (item)

SetRestrictAccess Method (item)
Namespaces >> MSS.Sites.Security >> SecurityManager >> SetRestrictAccess(Item)
Sets “restricted” to the item by un-checking the security inheritance for the item and adding rights to roles that have the "ManageSecurity" right.
Declaration Syntax
C#
public void SetRestrictAccess(
    Item item
)
Parameters
item (Item)
The Item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserHasRight Method

UserHasRight Method
Namespaces >> MSS.Sites.Security >> SecurityManager >> UserHasRight()()
Members
Icon | Member | Description
 | UserHasRight(String) | Indicates whether the current user has a rights defined.
 | UserHasRight(UserItem, String) | Indicates whether a specific user has Sitecore security rights defined.
 | UserHasRight(User, String) | Indicates whether a specific user has MSS security rights defined.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserHasRight Method (user, rightName)

UserHasRight Method (user, rightName)
Namespaces >> MSS.Sites.Security >> SecurityManager >> UserHasRight(User, String)
Indicates whether a specific user has MSS security rights defined.
Declaration Syntax
C#
public static bool UserHasRight(
    User user,
    string rightName
)
Parameters
user (User)
The user.
rightName (String)
The right name.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserHasRight Method (user, rightName)

UserHasRight Method (user, rightName)
Namespaces >> MSS.Sites.Security >> SecurityManager >> UserHasRight(UserItem, String)
Indicates whether a specific user has Sitecore security rights defined.
Declaration Syntax
C#
public static bool UserHasRight(
    UserItem user,
    string rightName
)
Parameters
user (UserItem)
User.
rightName (String)
The right name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserHasRight Method (rightName)

UserHasRight Method (rightName)
Namespaces >> MSS.Sites.Security >> SecurityManager >> UserHasRight(String)
Indicates whether the current user has a rights defined.
Declaration Syntax
C#
public static bool UserHasRight(
    string rightName
)
Parameters
rightName (String)
The right name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserIsExists Method (name)

UserIsExists Method (name)
Namespaces >> MSS.Sites.Security >> SecurityManager >> UserIsExists(String)
Indicated whether there is a user with the specific name that belongs to the site.
Declaration Syntax
C#
public bool UserIsExists(
    string name
)
Parameters
name (String)
The user name.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.Settings Namespace

MSS.Sites.Settings Namespace
Namespaces >> MSS.Sites.Settings
Declaration Syntax
C#
namespace MSS.Sites.Settings
Types
All Types Classes
Icon | Type | Description
 | ModuleSettings | Modules settings


ModuleSettings Class

ModuleSettings Class
Namespaces >> MSS.Sites.Settings >> ModuleSettings
Modules settings
Declaration Syntax
C#
[SerializableAttribute]
public class ModuleSettings : SettingsCollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()() | Clears all settings. (Inherited from SettingsCollection.)
 | ClearSection(String) | Clears the section. (Inherited from SettingsCollection.)
 | Clone()() | Makes a deep clone of the instance (Inherited from SettingsCollection.)
 | Data | Obsolete. (Inherited from SettingsCollection.)
 | Dirty | Gets a value indicating whether some settings have been changed but setting collection hasn't been saved. (Inherited from SettingsCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetData()() | Obsolete. (Inherited from SettingsCollection.)
 | GetData(String) | (Inherited from SettingsCollection.)
 | GetEntry(String) | Gets the setting collection by key. (Inherited from SettingsCollection.)
 | GetEntry(String, String) | Gets a dictionary entry. (Inherited from SettingsCollection.)
 | GetGlobalSettings(String) | Gets the global settings item. (Inherited from SettingsCollection.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalSettings()() | Gets the local settings item. (Inherited from SettingsCollection.)
 | GetLocalSettings(String) | Gets the local settings item using a specific path. (Inherited from SettingsCollection.)
 | GetSection(String) | Gets a section. (Inherited from SettingsCollection.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeSettings()() | Gets the type settings. (Inherited from SettingsCollection.)
 | GetTypeSettings(String) | Gets the type settings item using a specific path. (Inherited from SettingsCollection.)
 | Init()() | Initialises the SettingsCollection. (Inherited from SettingsCollection.)
 | Init(String) | Initialises the SettingsCollection. (Inherited from SettingsCollection.)
 | Item[([String])] | Gets or sets the String with the specified key. (Inherited from SettingsCollection.)
 | LoadAbsoluteSettings(String) | Loads the absolute settings. (Inherited from SettingsCollection.)
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings. (Inherited from SettingsCollection.)
 | Loaded | Gets a value indicating whether the SettingCollection is loaded. (Inherited from SettingsCollection.)
 | LoadSettings()() | Loads the settings. (Inherited from SettingsCollection.)
 | LoadSettings(String) | Loads the settings. (Inherited from SettingsCollection.)
 | LoadSettings(Item) | Loads the settings. (Inherited from SettingsCollection.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveSettings(Boolean) | Saves the settings. (Inherited from SettingsCollection.)
 | SaveSettings(String) | Saves the settings using a specific path. (Inherited from SettingsCollection.)
 | SaveSettings(String, Boolean) | Saves the settings. (Inherited from SettingsCollection.)
 | SaveSettings(Item) | Saves the settings to the item. (Inherited from SettingsCollection.)
 | SetData(StringDictionary) | (Inherited from SettingsCollection.)
 | SetData(SettingsCollection) | (Inherited from SettingsCollection.)
 | SetSection(String, StringDictionary) | (Inherited from SettingsCollection.)
 | SetSetting(String, String, String) | Sets the setting. (Inherited from SettingsCollection.)
 | Setting(String) | Gets the setting by a key. (Inherited from SettingsCollection.)
 | Setting(String, String) | Gets the setting from a section by a key. (Inherited from SettingsCollection.)
 | Setting(String, String, String) | Gets the setting from a section by a key. (Inherited from SettingsCollection.)
 | ToInt(String) | Gets the int setting by a key. (Inherited from SettingsCollection.)
 | ToInt(String, Int32) | Gets the int setting by a key. (Inherited from SettingsCollection.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updatedata(String) | Updatedatas the settings. (Inherited from SettingsCollection.)
Inheritance Hierarchy
Object
 | SettingsCollection
 |  | ModuleSettings

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.Types Namespace

MSS.Sites.Types Namespace
Namespaces >> MSS.Sites.Types
Declaration Syntax
C#
namespace MSS.Sites.Types
Types
All Types Classes
Icon | Type | Description
 | Definitions |
 | SiteType | Site type application.
 | SiteTypeManager | Handles a collection of site types


Definitions Class

Definitions Class
Namespaces >> MSS.Sites.Types >> Definitions
Declaration Syntax
C#
public class Definitions
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefinitionsDefinitionsNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldAdminMenu |
 | FieldGlobalMenu |
 | FieldKey |
 | FieldPrefixes |
 | FieldSiteModules |
 | FieldSiteTemplate |
 | FieldSiteWizard |
 | FieldTitle |
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Definitions

Assembly: MSS.Kernel (Module: MSS.Kernel)


Definitions Constructor

Definitions Constructor
Namespaces >> MSS.Sites.Types >> Definitions >> DefinitionsDefinitionsNew()()
Declaration Syntax
C#
public Definitions()

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldAdminMenu Field

FieldAdminMenu Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldAdminMenu
Declaration Syntax
C#
public const string FieldAdminMenu

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldGlobalMenu Field

FieldGlobalMenu Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldGlobalMenu
Declaration Syntax
C#
public const string FieldGlobalMenu

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldKey Field

FieldKey Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldKey
Declaration Syntax
C#
public const string FieldKey

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldPrefixes Field

FieldPrefixes Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldPrefixes
Declaration Syntax
C#
public const string FieldPrefixes

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldSiteModules Field

FieldSiteModules Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldSiteModules
Declaration Syntax
C#
public const string FieldSiteModules

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldSiteTemplate Field

FieldSiteTemplate Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldSiteTemplate
Declaration Syntax
C#
public const string FieldSiteTemplate

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldSiteWizard Field

FieldSiteWizard Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldSiteWizard
Declaration Syntax
C#
public const string FieldSiteWizard

Assembly: MSS.Kernel (Module: MSS.Kernel)


FieldTitle Field

FieldTitle Field
Namespaces >> MSS.Sites.Types >> Definitions >> FieldTitle
Declaration Syntax
C#
public const string FieldTitle

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteType Class

SiteType Class
Namespaces >> MSS.Sites.Types >> SiteType
Site type application.
Declaration Syntax
C#
public class SiteType : Entity, ICacheable
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdministrationMenu | Gets the administration menus for the site type.
 | Clone()() | (Overrides Entity.Clone()().)
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Dictionary | Gets the site type dictionary.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalMenu | Gets the global menu for the site type.
 | Groups | Gets the groups for the Site type.
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modules | Gets the module.
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | SecurityGroupRelativePath |
 | SecurityUserRelativePath |
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | Title | Gets or sets the title.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wizard | Gets the site type wizard.
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | SiteType

Assembly: MSS.Kernel (Module: MSS.Kernel)


AdministrationMenu Property

AdministrationMenu Property
Namespaces >> MSS.Sites.Types >> SiteType >> AdministrationMenu
Gets the administration menus for the site type.
Declaration Syntax
C#
public AdministrationMenu AdministrationMenu{ get;}
Value
The administration menus.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Sites.Types >> SiteType >> Clone()()
Declaration Syntax
C#
public override Entity Clone()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Dictionary Property

Dictionary Property
Namespaces >> MSS.Sites.Types >> SiteType >> Dictionary
Gets the site type dictionary.
Declaration Syntax
C#
public Dictionary Dictionary{ get;}
Value
The dictionary.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GlobalMenu Property

GlobalMenu Property
Namespaces >> MSS.Sites.Types >> SiteType >> GlobalMenu
Gets the global menu for the site type.
Declaration Syntax
C#
public GlobalMenu GlobalMenu{ get;}
Value
The global menu.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Groups Property

Groups Property
Namespaces >> MSS.Sites.Types >> SiteType >> Groups
Gets the groups for the Site type.
Declaration Syntax
C#
public List<GroupTemplate> Groups{ get;}
Value
The groups.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Modules Property

Modules Property
Namespaces >> MSS.Sites.Types >> SiteType >> Modules
Gets the module.
Declaration Syntax
C#
public Module[] Modules{ get;}
Value
The module.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityGroupRelativePath Field

SecurityGroupRelativePath Field
Namespaces >> MSS.Sites.Types >> SiteType >> SecurityGroupRelativePath
Declaration Syntax
C#
public static readonly string SecurityGroupRelativePath

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityUserRelativePath Field

SecurityUserRelativePath Field
Namespaces >> MSS.Sites.Types >> SiteType >> SecurityUserRelativePath
Declaration Syntax
C#
public static readonly string SecurityUserRelativePath

Assembly: MSS.Kernel (Module: MSS.Kernel)


Title Property

Title Property
Namespaces >> MSS.Sites.Types >> SiteType >> Title
Gets or sets the title.
Declaration Syntax
C#
public string Title{ get; set;}
Value
The title.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Wizard Property

Wizard Property
Namespaces >> MSS.Sites.Types >> SiteType >> Wizard
Gets the site type wizard.
Declaration Syntax
C#
public Wizard Wizard{ get;}
Value
The wizard.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeManager Class

SiteTypeManager Class
Namespaces >> MSS.Sites.Types >> SiteTypeManager
Handles a collection of site types
Declaration Syntax
C#
public class SiteTypeManager : Manager<SiteType>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(ID, TValue) | Adds the value using a specified entity. (Inherited from Manager<(Of <TValue>)>.)
 | ClearCache(Database) | Clears the database cache. (Inherited from Manager<(Of <TValue>)>.)
 | CreateEntity(Item) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity. (Inherited from Manager<(Of <TValue>)>.)
 | CreateEntity(ID, Database) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity. (Inherited from Manager<(Of <TValue>)>.)
 | CreateNewEntity(ID, Database) | Creates a new site type. (Overrides Manager <(Of < SiteType >)>.CreateNewEntity(ID, Database).)
 | CreateSiteType(ID, Database) | Creates a new site type.
 | CreateSiteType(Item) | Creates a new site type.
 | DeleteSiteType(ID) | Deletes the site type by its ID.
 | DuplicateSiteType(ID, String) | Duplicates the site type.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCache(Database) | Gets the cache. (Inherited from Manager<(Of <TValue>)>.)
 | GetEntities(Database) | Gets the entities using a specified database. (Inherited from Manager<(Of <TValue>)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSiteType(String, Database) | Gets the site type with the specified name, which belongs to the specific database.
 | GetSiteType(ID, Database) | Gets the site types that belongs to a specific database.
 | GetSiteTypes()() | Gets the site types.
 | GetSiteTypes(Database) | Gets the site types that belongs to the specific database
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([String, Database])] | Gets the SiteType with a specified name and which belongs to a specific database.
 | Item[([ID, Database])] | Gets the value with the specified key. (Inherited from Manager<(Of <TValue>)>.)
 | Load()() | Loads this instance. (Overrides Manager <(Of < SiteType >)>.Load()().)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(ID, Database) | Removes entity value using a specified database. (Inherited from Manager<(Of <TValue>)>.)
 | RemoveEntityFromCache(ID, Database) | Removes the entity from the cache. (Inherited from Manager<(Of <TValue>)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Manager <(Of < SiteType >)>
 |  | SiteTypeManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateNewEntity Method (id, database)

CreateNewEntity Method (id, database)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> CreateNewEntity(ID, Database)
Creates a new site type.
Declaration Syntax
C#
protected override SiteType CreateNewEntity(
    ID id,
    Database database
)
Parameters
id (ID)
The id.
database (Database)
The database.
Return Value
The site type.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSiteType Method

CreateSiteType Method
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> CreateSiteType()()
Members
Icon | Member | Description
 | CreateSiteType(ID, Database) | Creates a new site type.
 | CreateSiteType(Item) | Creates a new site type.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSiteType Method (id, database)

CreateSiteType Method (id, database)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> CreateSiteType(ID, Database)
Creates a new site type.
Declaration Syntax
C#
protected SiteType CreateSiteType(
    ID id,
    Database database
)
Parameters
id (ID)
The id.
database (Database)
The database.
Return Value
The site type.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateSiteType Method (item)

CreateSiteType Method (item)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> CreateSiteType(Item)
Creates a new site type.
Declaration Syntax
C#
protected SiteType CreateSiteType(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The site type.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DeleteSiteType Method (typeID)

DeleteSiteType Method (typeID)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> DeleteSiteType(ID)
Deletes the site type by its ID.
Declaration Syntax
C#
public void DeleteSiteType(
    ID typeID
)
Parameters
typeID (ID)
The site type ID.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DuplicateSiteType Method (typeID, newName)

DuplicateSiteType Method (typeID, newName)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> DuplicateSiteType(ID, String)
Duplicates the site type.
Declaration Syntax
C#
public void DuplicateSiteType(
    ID typeID,
    string newName
)
Parameters
typeID (ID)
ID of item that represents site type
newName (String)
New name

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteType Method

GetSiteType Method
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> GetSiteType()()
Members
Icon | Member | Description
 | GetSiteType(String, Database) | Gets the site type with the specified name, which belongs to the specific database.
 | GetSiteType(ID, Database) | Gets the site types that belongs to a specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteType Method (typeID, database)

GetSiteType Method (typeID, database)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> GetSiteType(ID, Database)
Gets the site types that belongs to a specific database.
Declaration Syntax
C#
public SiteType GetSiteType(
    ID typeID,
    Database database
)
Parameters
typeID (ID)
The type ID.
database (Database)
The database.
Return Value
The site type.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteType Method (typeName, database)

GetSiteType Method (typeName, database)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> GetSiteType(String, Database)
Gets the site type with the specified name, which belongs to the specific database.
Declaration Syntax
C#
public SiteType GetSiteType(
    string typeName,
    Database database
)
Parameters
typeName (String)
Name of the type.
database (Database)
The database.
Return Value
The site type.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteTypes Method

GetSiteTypes Method
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> GetSiteTypes()()
Members
Icon | Member | Description
 | GetSiteTypes()() | Gets the site types.
 | GetSiteTypes(Database) | Gets the site types that belongs to the specific database

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteTypes Method

GetSiteTypes Method
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> GetSiteTypes()()
Gets the site types.
Declaration Syntax
C#
public List<SiteType> GetSiteTypes()
Return Value
Return Value
The site types collection.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteTypes Method (database)

GetSiteTypes Method (database)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> GetSiteTypes(Database)
Gets the site types that belongs to the specific database
Declaration Syntax
C#
public List<SiteType> GetSiteTypes(
    Database database
)
Parameters
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Item Property (name, database)

Item Property (name, database)
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> Item[([String, Database])]
Gets the SiteType with a specified name and which belongs to a specific database.
Declaration Syntax
C#
public SiteType this[
    string name,
    Database database
]{ get;}
Parameters
name (String)
database (Database)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Load Method

Load Method
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> Load()()
Loads this instance.
Declaration Syntax
C#
public override void Load()

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Sites.Wizards Namespace

MSS.Sites.Wizards Namespace
Namespaces >> MSS.Sites.Wizards
Declaration Syntax
C#
namespace MSS.Sites.Wizards
Types
All Types Classes Interfaces
Icon | Type | Description
 | ICssFactory | Defines methods for the css factory
 | Wizard | Handles the wizard setup located in the content at /Sitecore box/Site Creation/Wizards for administrative purposes, when handling the Wizards Id in the MSA.
 | WizardManager | Creates a wizard for the SiteType


ICssFactory Interface

ICssFactory Interface
Namespaces >> MSS.Sites.Wizards >> ICssFactory
Defines methods for the css factory
Declaration Syntax
C#
public interface ICssFactory
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetCss(SiteContext) | Gets the CSS.
 | ResetCache(SiteContext) | Resets the css cache.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetCss Method (site)

GetCss Method (site)
Namespaces >> MSS.Sites.Wizards >> ICssFactory >> GetCss(SiteContext)
Gets the CSS.
Declaration Syntax
C#
string GetCss(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


ResetCache Method (site)

ResetCache Method (site)
Namespaces >> MSS.Sites.Wizards >> ICssFactory >> ResetCache(SiteContext)
Resets the css cache.
Declaration Syntax
C#
void ResetCache(
    SiteContext site
)
Parameters
site (SiteContext)
The site.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Wizard Class

Wizard Class
Namespaces >> MSS.Sites.Wizards >> Wizard
Handles the wizard setup located in the content at /Sitecore box/Site Creation/Wizards for administrative purposes, when handling the Wizards Id in the MSA.
Declaration Syntax
C#
public class Wizard : Entity
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WizardWizardNew(ID, Server) | Initializes a new instance of the Wizard class.
 | WizardWizardNew(ID, Server, Database) | Initializes a new instance of the Wizard class.
 | Clone()() | Clones the entity. (Overrides Entity.Clone()().)
 | CssFactory | Gets the CSS factory.
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | Languages | Gets the languages.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modules |
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WizardPages | Gets the wizard pages.
 | WizardPagesIterator | Gets the wizard pages iterator.
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | Wizard

Assembly: MSS.Kernel (Module: MSS.Kernel)


Wizard Constructor

Wizard Constructor
Namespaces >> MSS.Sites.Wizards >> Wizard >> WizardWizardNew()()
Members
Icon | Member | Description
 | WizardWizardNew(ID, Server) | Initializes a new instance of the Wizard class.
 | WizardWizardNew(ID, Server, Database) | Initializes a new instance of the Wizard class.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Wizard Constructor (itemID, server)

Wizard Constructor (itemID, server)
Namespaces >> MSS.Sites.Wizards >> Wizard >> WizardWizardNew(ID, Server)
Initializes a new instance of the Wizard class.
Declaration Syntax
C#
public Wizard(
    ID itemID,
    Server server
)
Parameters
itemID (ID)
The item ID.
server (Server)
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Wizard Constructor (itemID, server, database)

Wizard Constructor (itemID, server, database)
Namespaces >> MSS.Sites.Wizards >> Wizard >> WizardWizardNew(ID, Server, Database)
Initializes a new instance of the Wizard class.
Declaration Syntax
C#
public Wizard(
    ID itemID,
    Server server,
    Database database
)
Parameters
itemID (ID)
The item ID.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Sites.Wizards >> Wizard >> Clone()()
Clones the entity.
Declaration Syntax
C#
public override Entity Clone()
Return Value
The cloned entity.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CssFactory Property

CssFactory Property
Namespaces >> MSS.Sites.Wizards >> Wizard >> CssFactory
Gets the CSS factory.
Declaration Syntax
C#
public ICssFactory CssFactory{ get;}
Value
The CSS factory.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Languages Property

Languages Property
Namespaces >> MSS.Sites.Wizards >> Wizard >> Languages
Gets the languages.
Declaration Syntax
C#
public string Languages{ get;}
Value
The languages.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Modules Field

Modules Field
Namespaces >> MSS.Sites.Wizards >> Wizard >> Modules
Declaration Syntax
C#
public static readonly string Modules

Assembly: MSS.Kernel (Module: MSS.Kernel)


WizardPages Property

WizardPages Property
Namespaces >> MSS.Sites.Wizards >> Wizard >> WizardPages
Gets the wizard pages.
Declaration Syntax
C#
public Item[] WizardPages{ get;}
Value
The wizard pages.

Assembly: MSS.Kernel (Module: MSS.Kernel)


WizardPagesIterator Property

WizardPagesIterator Property
Namespaces >> MSS.Sites.Wizards >> Wizard >> WizardPagesIterator
Gets the wizard pages iterator.
Declaration Syntax
C#
public XPathNodeIterator WizardPagesIterator{ get;}
Value
The wizard pages iterator.

Assembly: MSS.Kernel (Module: MSS.Kernel)


WizardManager Class

WizardManager Class
Namespaces >> MSS.Sites.Wizards >> WizardManager
Creates a wizard for the SiteType
Declaration Syntax
C#
public class WizardManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WizardManagerWizardManagerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWizard(SiteType) | Gets the wizard for site type.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WizardManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


WizardManager Constructor

WizardManager Constructor
Namespaces >> MSS.Sites.Wizards >> WizardManager >> WizardManagerWizardManagerNew()()
Declaration Syntax
C#
public WizardManager()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetWizard Method (siteType)

GetWizard Method (siteType)
Namespaces >> MSS.Sites.Wizards >> WizardManager >> GetWizard(SiteType)
Gets the wizard for site type.
Declaration Syntax
C#
public static Wizard GetWizard(
    SiteType siteType
)
Parameters
siteType (SiteType)
Type of the site.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Skinpackages Namespace

MSS.Skinpackages Namespace
Namespaces >> MSS.Skinpackages
Declaration Syntax
C#
namespace MSS.Skinpackages
Types
All Types Classes
Icon | Type | Description
 | Skin | Site skin packages application.
 | SkinButtonImageFile | Skin button.
 | SkinImageFile | Skin image
 | SkinPackage | MSS skin package application.
 | SkinPackageItem | Skin package.
 | SkinPackageManager | Provides functionality for working with skins and skin packages.


Skin Class

Skin Class
Namespaces >> MSS.Skinpackages >> Skin
Site skin packages application.
Declaration Syntax
C#
public class Skin : Entity
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkinSkinNew(SkinPackage, ID, Server) | Initializes a new instance of the Skin class.
 | SkinSkinNew(SkinPackage, ID, Server, Database) | Initializes a new instance of the Skin class for a specific database.
 | Clone()() | Clones this instance of the skin. (Overrides Entity.Clone()().)
 | Database | Gets the database. (Inherited from EntityBase.)
 | Delete()() | Deletes an entity. (Inherited from Entity.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Entity) | Moves an entity to the specified destination. (Inherited from Entity.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | PreviewFile | Gets the preview file.
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | Title | Gets the skin title.
 | ToString()() | Returns a String that represents the current Object. (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | EntityBase
 |  | Entity
 |  |  | Skin

Assembly: MSS.Kernel (Module: MSS.Kernel)


Skin Constructor

Skin Constructor
Namespaces >> MSS.Skinpackages >> Skin >> SkinSkinNew()()
Members
Icon | Member | Description
 | SkinSkinNew(SkinPackage, ID, Server) | Initializes a new instance of the Skin class.
 | SkinSkinNew(SkinPackage, ID, Server, Database) | Initializes a new instance of the Skin class for a specific database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Skin Constructor (skinPackage, id, server)

Skin Constructor (skinPackage, id, server)
Namespaces >> MSS.Skinpackages >> Skin >> SkinSkinNew(SkinPackage, ID, Server)
Initializes a new instance of the Skin class.
Declaration Syntax
C#
public Skin(
    SkinPackage skinPackage,
    ID id,
    Server server
)
Parameters
skinPackage (SkinPackage)
The skin package.
id (ID)
The id.
server (Server)
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Skin Constructor (skinPackage, id, server, database)

Skin Constructor (skinPackage, id, server, database)
Namespaces >> MSS.Skinpackages >> Skin >> SkinSkinNew(SkinPackage, ID, Server, Database)
Initializes a new instance of the Skin class for a specific database.
Declaration Syntax
C#
public Skin(
    SkinPackage skinPackage,
    ID id,
    Server server,
    Database database
)
Parameters
skinPackage (SkinPackage)
The skin package.
id (ID)
The id.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Clone Method

Clone Method
Namespaces >> MSS.Skinpackages >> Skin >> Clone()()
Clones this instance of the skin.
Declaration Syntax
C#
public override Entity Clone()
Return Value
The new skin.

Assembly: MSS.Kernel (Module: MSS.Kernel)


PreviewFile Property

PreviewFile Property
Namespaces >> MSS.Skinpackages >> Skin >> PreviewFile
Gets the preview file.
Declaration Syntax
C#
public string PreviewFile{ get;}
Value
The preview file.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Title Property

Title Property
Namespaces >> MSS.Skinpackages >> Skin >> Title
Gets the skin title.
Declaration Syntax
C#
public string Title{ get;}
Value
The scin title.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToString Method

ToString Method
Namespaces >> MSS.Skinpackages >> Skin >> ToString()()
Returns a String that represents the current Object.
Declaration Syntax
C#
public override string ToString()
Return Value
A String that represents the current Object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinButtonImageFile Class

SkinButtonImageFile Class
Namespaces >> MSS.Skinpackages >> SkinButtonImageFile
Skin button.
Declaration Syntax
C#
public class SkinButtonImageFile : SkinImageFile
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkinButtonImageFileSkinButtonImageFileNew(ID, Server) | Initializes a new instance of the SkinButtonImageFile class.
 | SkinButtonImageFileSkinButtonImageFileNew(ID, Server, Database) | Initializes a new instance of the SkinButtonImageFile class.
 | Database | Gets the database. (Inherited from EntityBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Summary: Gets the file path. (Inherited from SkinImageFile.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | PreviewFilePath | Summary: Gets the preview file path. (Inherited from SkinImageFile.)
 | SelectedFilePath | Gets the selected file path.
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | Title | Gets the package title. (Inherited from SkinPackageItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | SkinPackageItem
 |  |  | SkinImageFile
 |  |  |  | SkinButtonImageFile

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinButtonImageFile Constructor

SkinButtonImageFile Constructor
Namespaces >> MSS.Skinpackages >> SkinButtonImageFile >> SkinButtonImageFileSkinButtonImageFileNew()()
Members
Icon | Member | Description
 | SkinButtonImageFileSkinButtonImageFileNew(ID, Server) | Initializes a new instance of the SkinButtonImageFile class.
 | SkinButtonImageFileSkinButtonImageFileNew(ID, Server, Database) | Initializes a new instance of the SkinButtonImageFile class.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinButtonImageFile Constructor (itemId, server)

SkinButtonImageFile Constructor (itemId, server)
Namespaces >> MSS.Skinpackages >> SkinButtonImageFile >> SkinButtonImageFileSkinButtonImageFileNew(ID, Server)
Initializes a new instance of the SkinButtonImageFile class.
Declaration Syntax
C#
public SkinButtonImageFile(
    ID itemId,
    Server server
)
Parameters
itemId (ID)
The item id.
server (Server)
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinButtonImageFile Constructor (itemId, server, database)

SkinButtonImageFile Constructor (itemId, server, database)
Namespaces >> MSS.Skinpackages >> SkinButtonImageFile >> SkinButtonImageFileSkinButtonImageFileNew(ID, Server, Database)
Initializes a new instance of the SkinButtonImageFile class.
Declaration Syntax
C#
public SkinButtonImageFile(
    ID itemId,
    Server server,
    Database database
)
Parameters
itemId (ID)
The item id.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SelectedFilePath Property

SelectedFilePath Property
Namespaces >> MSS.Skinpackages >> SkinButtonImageFile >> SelectedFilePath
Gets the selected file path.
Declaration Syntax
C#
public string SelectedFilePath{ get;}
Value
The selected file path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinImageFile Class

SkinImageFile Class
Namespaces >> MSS.Skinpackages >> SkinImageFile
Skin image
Declaration Syntax
C#
public class SkinImageFile : SkinPackageItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkinImageFileSkinImageFileNew(ID, Server) |
 | SkinImageFileSkinImageFileNew(ID, Server, Database) |
 | Database | Gets the database. (Inherited from EntityBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Summary: Gets the file path.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | PreviewFilePath | Summary: Gets the preview file path.
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | Title | Gets the package title. (Inherited from SkinPackageItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | SkinPackageItem
 |  |  | SkinImageFile
 |  |  |  | SkinButtonImageFile

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinImageFile Constructor

SkinImageFile Constructor
Namespaces >> MSS.Skinpackages >> SkinImageFile >> SkinImageFileSkinImageFileNew()()
Members
Icon | Member | Description
 | SkinImageFileSkinImageFileNew(ID, Server) |
 | SkinImageFileSkinImageFileNew(ID, Server, Database) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinImageFile Constructor (itemId, server)

SkinImageFile Constructor (itemId, server)
Namespaces >> MSS.Skinpackages >> SkinImageFile >> SkinImageFileSkinImageFileNew(ID, Server)
Declaration Syntax
C#
public SkinImageFile(
    ID itemId,
    Server server
)
Parameters
itemId (ID)
server (Server)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinImageFile Constructor (itemId, server, database)

SkinImageFile Constructor (itemId, server, database)
Namespaces >> MSS.Skinpackages >> SkinImageFile >> SkinImageFileSkinImageFileNew(ID, Server, Database)
Declaration Syntax
C#
public SkinImageFile(
    ID itemId,
    Server server,
    Database database
)
Parameters
itemId (ID)
server (Server)
database (Database)

Assembly: MSS.Kernel (Module: MSS.Kernel)


FilePath Property

FilePath Property
Namespaces >> MSS.Skinpackages >> SkinImageFile >> FilePath
Summary: Gets the file path.
Declaration Syntax
C#
public string FilePath{ get;}
Value
The file path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


PreviewFilePath Property

PreviewFilePath Property
Namespaces >> MSS.Skinpackages >> SkinImageFile >> PreviewFilePath
Summary: Gets the preview file path.
Declaration Syntax
C#
public string PreviewFilePath{ get;}
Value
The preview file path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackage Class

SkinPackage Class
Namespaces >> MSS.Skinpackages >> SkinPackage
MSS skin package application.
Declaration Syntax
C#
public class SkinPackage : EntityBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkinPackageSkinPackageNew(ID, Server) | Initializes a new instance of the SkinPackage class.
 | SkinPackageSkinPackageNew(ID, Server, Database) | Initializes a new instance of the SkinPackage class.
 | Backgrounds | Gets the backgrounds.
 | BottomBars | Gets the bottom bars.
 | Buttons | Gets the buttons.
 | ColumnBars | Gets the column bars.
 | ContentBars | Gets the content bars.
 | Database | Gets the database. (Inherited from EntityBase.)
 | DefaultLanguage | Gets or sets the default language.
 | DefaultSkin | Gets or sets the default skin.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllSkins()() | Gets all skins.
 | GetButton(String, String) | Gets the button.
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPalette(String, String) | Gets the color palette.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Group | Gets or sets the group.
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Identities | Gets the identities.
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | SkinIdFieldName |
 | SkinPackageIdFieldName |
 | Skins | Gets all skins.
 | StyleSheet | Gets or sets the style sheet.
 | Title | Gets or sets the title.
 | TopBars | Gets the top bars.
 | Tops | Gets the tops.
 | ToString()() | (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | EntityBase
 |  | SkinPackage

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackage Constructor

SkinPackage Constructor
Namespaces >> MSS.Skinpackages >> SkinPackage >> SkinPackageSkinPackageNew()()
Members
Icon | Member | Description
 | SkinPackageSkinPackageNew(ID, Server) | Initializes a new instance of the SkinPackage class.
 | SkinPackageSkinPackageNew(ID, Server, Database) | Initializes a new instance of the SkinPackage class.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackage Constructor (id, server)

SkinPackage Constructor (id, server)
Namespaces >> MSS.Skinpackages >> SkinPackage >> SkinPackageSkinPackageNew(ID, Server)
Initializes a new instance of the SkinPackage class.
Declaration Syntax
C#
public SkinPackage(
    ID id,
    Server server
)
Parameters
id (ID)
The id.
server (Server)
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackage Constructor (id, server, database)

SkinPackage Constructor (id, server, database)
Namespaces >> MSS.Skinpackages >> SkinPackage >> SkinPackageSkinPackageNew(ID, Server, Database)
Initializes a new instance of the SkinPackage class.
Declaration Syntax
C#
public SkinPackage(
    ID id,
    Server server,
    Database database
)
Parameters
id (ID)
The id.
server (Server)
The server.
database (Database)
The database.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Backgrounds Property

Backgrounds Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> Backgrounds
Gets the backgrounds.
Declaration Syntax
C#
public SkinImageFile[] Backgrounds{ get;}
Value
The backgrounds.

Assembly: MSS.Kernel (Module: MSS.Kernel)


BottomBars Property

BottomBars Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> BottomBars
Gets the bottom bars.
Declaration Syntax
C#
public SkinImageFile[] BottomBars{ get;}
Value
The bottom bars.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Buttons Property

Buttons Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> Buttons
Gets the buttons.
Declaration Syntax
C#
public SkinImageFile[] Buttons{ get;}
Value
The buttons.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ColumnBars Property

ColumnBars Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> ColumnBars
Gets the column bars.
Declaration Syntax
C#
public SkinImageFile[] ColumnBars{ get;}
Value
The column bars.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ContentBars Property

ContentBars Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> ContentBars
Gets the content bars.
Declaration Syntax
C#
public SkinImageFile[] ContentBars{ get;}
Value
The content bars.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DefaultLanguage Property

DefaultLanguage Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> DefaultLanguage
Gets or sets the default language.
Declaration Syntax
C#
public string DefaultLanguage{ get; set;}
Value
The default language.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DefaultSkin Property

DefaultSkin Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> DefaultSkin
Gets or sets the default skin.
Declaration Syntax
C#
public Skin DefaultSkin{ get; set;}
Value
The default skin.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAllSkins Method

GetAllSkins Method
Namespaces >> MSS.Skinpackages >> SkinPackage >> GetAllSkins()()
Gets all skins.
Declaration Syntax
C#
public Skin[] GetAllSkins()
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetButton Method (buttonSetId, buttonName)

GetButton Method (buttonSetId, buttonName)
Namespaces >> MSS.Skinpackages >> SkinPackage >> GetButton(String, String)
Gets the button.
Declaration Syntax
C#
public SkinButtonImageFile GetButton(
    string buttonSetId,
    string buttonName
)
Parameters
buttonSetId (String)
The button set id.
buttonName (String)
Name of the button.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetPalette Method (paletteGroupName, paletteName)

GetPalette Method (paletteGroupName, paletteName)
Namespaces >> MSS.Skinpackages >> SkinPackage >> GetPalette(String, String)
Gets the color palette.
Declaration Syntax
C#
public SkinImageFile GetPalette(
    string paletteGroupName,
    string paletteName
)
Parameters
paletteGroupName (String)
Name of the palette group.
paletteName (String)
Name of the palette.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Group Property

Group Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> Group
Gets or sets the group.
Declaration Syntax
C#
public string Group{ get; set;}
Value
The group.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Identities Property

Identities Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> Identities
Gets the identities.
Declaration Syntax
C#
public SkinImageFile[] Identities{ get;}
Value
The identities.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinIdFieldName Field

SkinIdFieldName Field
Namespaces >> MSS.Skinpackages >> SkinPackage >> SkinIdFieldName
Declaration Syntax
C#
public static readonly string SkinIdFieldName

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackageIdFieldName Field

SkinPackageIdFieldName Field
Namespaces >> MSS.Skinpackages >> SkinPackage >> SkinPackageIdFieldName
Declaration Syntax
C#
public static readonly string SkinPackageIdFieldName

Assembly: MSS.Kernel (Module: MSS.Kernel)


Skins Property

Skins Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> Skins
Gets all skins.
Declaration Syntax
C#
public Skin[] Skins{ get;}
Value
The skins.

Assembly: MSS.Kernel (Module: MSS.Kernel)


StyleSheet Property

StyleSheet Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> StyleSheet
Gets or sets the style sheet.
Declaration Syntax
C#
public string StyleSheet{ get; set;}
Value
The style sheet.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Title Property

Title Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> Title
Gets or sets the title.
Declaration Syntax
C#
public string Title{ get; set;}
Value
The title.

Assembly: MSS.Kernel (Module: MSS.Kernel)


TopBars Property

TopBars Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> TopBars
Gets the top bars.
Declaration Syntax
C#
public SkinImageFile[] TopBars{ get;}
Value
The top bars.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Tops Property

Tops Property
Namespaces >> MSS.Skinpackages >> SkinPackage >> Tops
Gets the tops.
Declaration Syntax
C#
public SkinImageFile[] Tops{ get;}
Value
The tops.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToString Method

ToString Method
Namespaces >> MSS.Skinpackages >> SkinPackage >> ToString()()
Declaration Syntax
C#
public override string ToString()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackageItem Class

SkinPackageItem Class
Namespaces >> MSS.Skinpackages >> SkinPackageItem
Skin package.
Declaration Syntax
C#
public class SkinPackageItem : EntityBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkinPackageItemSkinPackageItemNew(ID, Server) |
 | SkinPackageItemSkinPackageItemNew(ID, Server, Database) |
 | Database | Gets the database. (Inherited from EntityBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldValue(String) | Returns the value of the field with name fieldname. (Inherited from EntityBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the sitecore item ID. (Inherited from EntityBase.)
 | Item | Gets the item. (Inherited from EntityBase.)
 | Key | Gets the entity key. (Inherited from EntityBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the entity path. (Inherited from EntityBase.)
 | Server | Gets the server. (Inherited from EntityBase.)
 | SetFieldValue(String, String) | Sets the field value. (Inherited from EntityBase.)
 | Title | Gets the package title.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EntityBase
 |  | SkinPackageItem
 |  |  | SkinImageFile

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackageItem Constructor

SkinPackageItem Constructor
Namespaces >> MSS.Skinpackages >> SkinPackageItem >> SkinPackageItemSkinPackageItemNew()()
Members
Icon | Member | Description
 | SkinPackageItemSkinPackageItemNew(ID, Server) |
 | SkinPackageItemSkinPackageItemNew(ID, Server, Database) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackageItem Constructor (itemID, server)

SkinPackageItem Constructor (itemID, server)
Namespaces >> MSS.Skinpackages >> SkinPackageItem >> SkinPackageItemSkinPackageItemNew(ID, Server)
Declaration Syntax
C#
public SkinPackageItem(
    ID itemID,
    Server server
)
Parameters
itemID (ID)
server (Server)

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackageItem Constructor (itemID, server, database)

SkinPackageItem Constructor (itemID, server, database)
Namespaces >> MSS.Skinpackages >> SkinPackageItem >> SkinPackageItemSkinPackageItemNew(ID, Server, Database)
Declaration Syntax
C#
public SkinPackageItem(
    ID itemID,
    Server server,
    Database database
)
Parameters
itemID (ID)
server (Server)
database (Database)

Assembly: MSS.Kernel (Module: MSS.Kernel)


Title Property

Title Property
Namespaces >> MSS.Skinpackages >> SkinPackageItem >> Title
Gets the package title.
Declaration Syntax
C#
public string Title{ get;}
Value
The title.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackageManager Class

SkinPackageManager Class
Namespaces >> MSS.Skinpackages >> SkinPackageManager
Provides functionality for working with skins and skin packages.
Declaration Syntax
C#
public class SkinPackageManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SkinPackageManagerSkinPackageManagerNew(Server) | Initializes a new instance of the SkinPackageManager class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllSkinPackages(Database) | Gets all skins.
 | GetGroupNames(Database) | Gets the group names.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSkinPackage(SiteContext) | Get skin for site.
 | GetSkinPackage(SiteContext, Database) | Gets the skin package for site.
 | GetSkinPackage(ID, Database) | Gets the skin package.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetSkin(SiteContext, Skin) | Sets the skin.
 | SetSkinPackage(SiteContext, SkinPackage) | Sets the skin package.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SkinPackageManager

Assembly: MSS.Kernel (Module: MSS.Kernel)


SkinPackageManager Constructor (server)

SkinPackageManager Constructor (server)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> SkinPackageManagerSkinPackageManagerNew(Server)
Initializes a new instance of the SkinPackageManager class.
Declaration Syntax
C#
public SkinPackageManager(
    Server server
)
Parameters
server (Server)
The server.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetAllSkinPackages Method (database)

GetAllSkinPackages Method (database)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> GetAllSkinPackages(Database)
Gets all skins.
Declaration Syntax
C#
public SkinPackage[] GetAllSkinPackages(
    Database database
)
Parameters
database (Database)
Return Value
All skins.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGroupNames Method (database)

GetGroupNames Method (database)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> GetGroupNames(Database)
Gets the group names.
Declaration Syntax
C#
public string[] GetGroupNames(
    Database database
)
Parameters
database (Database)
The database.
Return Value
The group names.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSkinPackage Method

GetSkinPackage Method
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> GetSkinPackage()()
Members
Icon | Member | Description
 | GetSkinPackage(SiteContext) | Get skin for site.
 | GetSkinPackage(SiteContext, Database) | Gets the skin package for site.
 | GetSkinPackage(ID, Database) | Gets the skin package.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSkinPackage Method (site)

GetSkinPackage Method (site)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> GetSkinPackage(SiteContext)
Get skin for site.
Declaration Syntax
C#
public SkinPackage GetSkinPackage(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The skin package.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSkinPackage Method (site, database)

GetSkinPackage Method (site, database)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> GetSkinPackage(SiteContext, Database)
Gets the skin package for site.
Declaration Syntax
C#
public SkinPackage GetSkinPackage(
    SiteContext site,
    Database database
)
Parameters
site (SiteContext)
The site.
database (Database)
The database.
Return Value
The skin package.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSkinPackage Method (skinPackageId, database)

GetSkinPackage Method (skinPackageId, database)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> GetSkinPackage(ID, Database)
Gets the skin package.
Declaration Syntax
C#
public SkinPackage GetSkinPackage(
    ID skinPackageId,
    Database database
)
Parameters
skinPackageId (ID)
The skin package id.
database (Database)
The database.
Return Value
The skin package.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetSkin Method (site, skin)

SetSkin Method (site, skin)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> SetSkin(SiteContext, Skin)
Sets the skin.
Declaration Syntax
C#
public void SetSkin(
    SiteContext site,
    Skin skin
)
Parameters
site (SiteContext)
The site.
skin (Skin)
The skin.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetSkinPackage Method (site, skinPackage)

SetSkinPackage Method (site, skinPackage)
Namespaces >> MSS.Skinpackages >> SkinPackageManager >> SetSkinPackage(SiteContext, SkinPackage)
Sets the skin package.
Declaration Syntax
C#
public void SetSkinPackage(
    SiteContext site,
    SkinPackage skinPackage
)
Parameters
site (SiteContext)
The site.
skinPackage (SkinPackage)
The skin package.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.StatCenter.Codebeside Namespace

MSS.StatCenter.Codebeside Namespace
Namespaces >> MSS.StatCenter.Codebeside
Declaration Syntax
C#
namespace MSS.StatCenter.Codebeside
Types
All Types Classes
Icon | Type | Description
 | ContentTree | Extends ContentTree to show a site root as a tree root.
 | MainForm | Stat center main form
 | StatCenterGlobalMenu | StatCenter global menu.
 | StatCenterInfo | Stat center info form
 | StatCenterLatestVisitors | Displays a list of visitors.
 | StatCenterPage | Displays page statistics.
 | StatCenterSearch | StatCenter search toolbar.


ContentTree Class

ContentTree Class
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree
Extends ContentTree to show a site root as a tree root.
Declaration Syntax
C#
public class ContentTree : ContentTreeXmlControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContentTreeContentTreeNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from ContentTreeXmlControl.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Overrides ContentTreeXmlControl.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemoraryDataContext |
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | Treeview()() | (Inherited from ContentTreeXmlControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | ContentTreeXmlControl
 |  |  |  |  |  | ContentTree

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


ContentTree Constructor

ContentTree Constructor
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> ContentTreeContentTreeNew()()
Declaration Syntax
C#
public ContentTree()

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


OnLoad Method (args)

OnLoad Method (args)
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs args
)
Parameters
args (EventArgs)

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


TemoraryDataContext Field

TemoraryDataContext Field
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> TemoraryDataContext
Declaration Syntax
C#
protected DataContext TemoraryDataContext

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


MainForm Class

MainForm Class
Namespaces >> MSS.StatCenter.Codebeside >> MainForm
Stat center main form
Declaration Syntax
C#
public class MainForm : StatCenterForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MainFormMainFormNew()() | Initializes a new instance of the MainForm class.
 | AlertProcessor(ClientPipelineArgs) | (Inherited from StatCenterForm.)
 | ChangePage(Message) | (Inherited from StatCenterForm.)
 | Close(Message) | (Inherited from StatCenterForm.)
 | Content(Message) | (Inherited from StatCenterForm.)
 | ContentArea()() | (Inherited from StatCenterForm.)
 | ContentGridPanel()() | (Inherited from StatCenterForm.)
 | ContentMenu()() | (Inherited from StatCenterForm.)
 | ContentSplitter |
 | ContentTree()() | (Inherited from StatCenterForm.)
 | ContentTreeContextMenu()() | (Inherited from StatCenterForm.)
 | DialogProcessor(ClientPipelineArgs) | (Inherited from StatCenterForm.)
 | DropDownMenu()() | (Inherited from StatCenterForm.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetContextMenu()() | (Inherited from StatCenterForm.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GlobalDBAdministrationSubMenu(String) | (Inherited from StatCenterForm.)
 | GlobalStatisticsSubMenu(String) | (Inherited from StatCenterForm.)
 | GoTo(Message) | (Inherited from StatCenterForm.)
 | GoToPage(Message) | Goes to the selected page.
 | HandleDropDownMenu(Control, String) | (Inherited from StatCenterForm.)
 | HandleDropDownMenu(Control, String, Boolean) | (Inherited from StatCenterForm.)
 | HandleIconMenu(Control, String) | (Inherited from StatCenterForm.)
 | HandleIconMenu(Control, String, Boolean) | (Inherited from StatCenterForm.)
 | HandleMessage(Message) | (Overrides StatCenterForm.HandleMessage(Message).)
 | IconBack()() | (Inherited from StatCenterForm.)
 | IconForward()() | (Inherited from StatCenterForm.)
 | IconGlobal()() | (Inherited from StatCenterForm.)
 | IconMenu()() | (Inherited from StatCenterForm.)
 | IconOptions()() | (Inherited from StatCenterForm.)
 | IconPage()() | (Inherited from StatCenterForm.)
 | IconRefresh()() | (Inherited from StatCenterForm.)
 | IconSearch()() | (Inherited from StatCenterForm.)
 | IconVisitors()() | (Inherited from StatCenterForm.)
 | Ignore(Message) | (Inherited from StatCenterForm.)
 | IgnoreProcessor(ClientPipelineArgs) | (Inherited from StatCenterForm.)
 | IlligalCharactersProcessor(ClientPipelineArgs) | (Inherited from StatCenterForm.)
 | ItemList()() | (Inherited from StatCenterForm.)
 | ListViewContextMenu(String) | (Inherited from StatCenterForm.)
 | litErrorText |
 | litFormTitle |
 | MainGridPanel()() | (Inherited from StatCenterForm.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Navigate(Message) | (Inherited from StatCenterForm.)
 | Node()() | (Inherited from StatCenterForm.)
 | OnLoad(EventArgs) | (Overrides StatCenterForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides StatCenterForm.OnPreRender(EventArgs).)
 | PageStatisticsSubMenu(String) | (Inherited from StatCenterForm.)
 | Refresh(Message) | (Inherited from StatCenterForm.)
 | SearchSubMenu(String) | (Inherited from StatCenterForm.)
 | ServerProperties()() | (Inherited from BaseForm.)
 | Status()() | (Inherited from StatCenterForm.)
 | StatusBar()() | (Inherited from StatCenterForm.)
 | Tag(Message) | (Inherited from StatCenterForm.)
 | TagProcessor(ClientPipelineArgs) | (Inherited from StatCenterForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TreeView()() | (Inherited from StatCenterForm.)
 | UpdateTreeview(Message) | Updates the tree view.
 | User()() | (Inherited from StatCenterForm.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | StatCenterForm
 |  |  | MainForm

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


MainForm Constructor

MainForm Constructor
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> MainFormMainFormNew()()
Initializes a new instance of the MainForm class.
Declaration Syntax
C#
public MainForm()

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


ContentSplitter Field

ContentSplitter Field
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> ContentSplitter
Declaration Syntax
C#
protected VSplitterXmlControl ContentSplitter

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GoToPage Method (message)

GoToPage Method (message)
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> GoToPage(Message)
Goes to the selected page.
Declaration Syntax
C#
public void GoToPage(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> HandleMessage(Message)
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


litErrorText Field

litErrorText Field
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> litErrorText
Declaration Syntax
C#
protected Literal litErrorText

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


litFormTitle Field

litFormTitle Field
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> litFormTitle
Declaration Syntax
C#
protected Literal litFormTitle

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


OnLoad Method (args)

OnLoad Method (args)
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs args
)
Parameters
args (EventArgs)

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


OnPreRender Method (args)

OnPreRender Method (args)
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs args
)
Parameters
args (EventArgs)

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


UpdateTreeview Method (message)

UpdateTreeview Method (message)
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> UpdateTreeview(Message)
Updates the tree view.
Declaration Syntax
C#
public void UpdateTreeview(
    Message message
)
Parameters
message (Message)
The message.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterGlobalMenu Class

StatCenterGlobalMenu Class
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu
StatCenter global menu.
Declaration Syntax
C#
public class StatCenterGlobalMenu : GlobalMenu
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatCenterGlobalMenuStatCenterGlobalMenuNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | endDate()() | (Inherited from GlobalMenu.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FromdateText()() | (Inherited from GlobalMenu.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from GlobalMenu.)
 | OnPreRender(EventArgs) | (Inherited from GlobalMenu.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | pageback()() | (Inherited from GlobalMenu.)
 | pageforward()() | (Inherited from GlobalMenu.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | startDate()() | (Inherited from GlobalMenu.)
 | Status()() | (Inherited from GlobalMenu.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TodateText()() | (Inherited from GlobalMenu.)
 | ToolMenu()() | (Inherited from GlobalMenu.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewText()() | (Inherited from GlobalMenu.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | GlobalMenu
 |  |  |  |  |  | StatCenterGlobalMenu

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterGlobalMenu Constructor

StatCenterGlobalMenu Constructor
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu >> StatCenterGlobalMenuStatCenterGlobalMenuNew()()
Declaration Syntax
C#
public StatCenterGlobalMenu()

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterInfo Class

StatCenterInfo Class
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo
Stat center info form
Declaration Syntax
C#
public class StatCenterInfo : InfoMenu
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatCenterInfoStatCenterInfoNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Status()() | (Inherited from InfoMenu.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | UserInfo()() | (Inherited from InfoMenu.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | InfoMenu
 |  |  |  |  |  | StatCenterInfo

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterInfo Constructor

StatCenterInfo Constructor
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo >> StatCenterInfoStatCenterInfoNew()()
Declaration Syntax
C#
public StatCenterInfo()

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterLatestVisitors Class

StatCenterLatestVisitors Class
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors
Displays a list of visitors.
Declaration Syntax
C#
public class StatCenterLatestVisitors : LatestVisitorsMenu
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatCenterLatestVisitorsStatCenterLatestVisitorsNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FromdateText()() | (Inherited from LatestVisitorsMenu.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from LatestVisitorsMenu.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | pageback()() | (Inherited from LatestVisitorsMenu.)
 | pageforward()() | (Inherited from LatestVisitorsMenu.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | startDate()() | (Inherited from LatestVisitorsMenu.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | LatestVisitorsMenu
 |  |  |  |  |  | StatCenterLatestVisitors

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterLatestVisitors Constructor

StatCenterLatestVisitors Constructor
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors >> StatCenterLatestVisitorsStatCenterLatestVisitorsNew()()
Declaration Syntax
C#
public StatCenterLatestVisitors()

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterPage Class

StatCenterPage Class
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage
Displays page statistics.
Declaration Syntax
C#
public class StatCenterPage : PageMenu
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatCenterPageStatCenterPageNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndDate()() | (Inherited from PageMenu.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FromdateText()() | (Inherited from PageMenu.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from PageMenu.)
 | OnPreRender(EventArgs) | (Inherited from PageMenu.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | pageback()() | (Inherited from PageMenu.)
 | pageforward()() | (Inherited from PageMenu.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | StartDate()() | (Inherited from PageMenu.)
 | Status()() | (Inherited from PageMenu.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TodateText()() | (Inherited from PageMenu.)
 | ToolMenu()() | (Inherited from PageMenu.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewText()() | (Inherited from PageMenu.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | PageMenu
 |  |  |  |  |  | StatCenterPage

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterPage Constructor

StatCenterPage Constructor
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage >> StatCenterPageStatCenterPageNew()()
Declaration Syntax
C#
public StatCenterPage()

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterSearch Class

StatCenterSearch Class
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch
StatCenter search toolbar.
Declaration Syntax
C#
public class StatCenterSearch : SearchMenu
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatCenterSearchStatCenterSearchNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from XmlControl.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from SearchMenu.)
 | OnPreRender(EventArgs) | (Inherited from SearchMenu.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | pageback()() | (Inherited from SearchMenu.)
 | pageforward()() | (Inherited from SearchMenu.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SearchAfter()() | (Inherited from SearchMenu.)
 | SearchafterText()() | (Inherited from SearchMenu.)
 | SearchbyText()() | (Inherited from SearchMenu.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolMenu()() | (Inherited from SearchMenu.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewText()() | (Inherited from SearchMenu.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | SearchMenu
 |  |  |  |  |  | StatCenterSearch

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


StatCenterSearch Constructor

StatCenterSearch Constructor
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch >> StatCenterSearchStatCenterSearchNew()()
Declaration Syntax
C#
public StatCenterSearch()

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


MSS.Testing Namespace

MSS.Testing Namespace
Namespaces >> MSS.Testing
Declaration Syntax
C#
namespace MSS.Testing
Types
All Types Classes
Icon | Type | Description
 | CachemanagerTester |
 | LogTester |
 | ModuleManagerTester |
 | PackageManagerTester |
 | SecurityManagerTester |
 | SiteContextManagerTester |
 | SiteContextTester |
 | SiteTypeManagerTester |
 | SiteTypeTester |
 | TimerTester |
 | UserTester |


CachemanagerTester Class

CachemanagerTester Class
Namespaces >> MSS.Testing >> CachemanagerTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class CachemanagerTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CachemanagerTesterCachemanagerTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Test1()() |
 | Test2()() |
 | Test3()() |
 | TestSetUp()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CachemanagerTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


CachemanagerTester Constructor

CachemanagerTester Constructor
Namespaces >> MSS.Testing >> CachemanagerTester >> CachemanagerTesterCachemanagerTesterNew()()
Declaration Syntax
C#
public CachemanagerTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Test1 Method

Test1 Method
Namespaces >> MSS.Testing >> CachemanagerTester >> Test1()()
Declaration Syntax
C#
[TestAttribute(Description = "Add, remove, clear cache")]
public void Test1()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Test2 Method

Test2 Method
Namespaces >> MSS.Testing >> CachemanagerTester >> Test2()()
Declaration Syntax
C#
[TestAttribute(Description = "Add, remove, clear database cache")]
public void Test2()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Test3 Method

Test3 Method
Namespaces >> MSS.Testing >> CachemanagerTester >> Test3()()
Declaration Syntax
C#
[TestAttribute(Description = "Add, remove data to cache")]
public void Test3()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestSetUp Method

TestSetUp Method
Namespaces >> MSS.Testing >> CachemanagerTester >> TestSetUp()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void TestSetUp()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LogTester Class

LogTester Class
Namespaces >> MSS.Testing >> LogTester
Declaration Syntax
C#
[TestFixtureAttribute(Description = "Test mss log file")]
public class LogTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LogTesterLogTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogTest()() |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LogTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


LogTester Constructor

LogTester Constructor
Namespaces >> MSS.Testing >> LogTester >> LogTesterLogTesterNew()()
Declaration Syntax
C#
public LogTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LogTest Method

LogTest Method
Namespaces >> MSS.Testing >> LogTester >> LogTest()()
Declaration Syntax
C#
[TestAttribute(Description = "Write messages to log file")]
public void LogTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModuleManagerTester Class

ModuleManagerTester Class
Namespaces >> MSS.Testing >> ModuleManagerTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class ModuleManagerTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ModuleManagerTesterModuleManagerTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetModulesTester()() |
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAvailableTester()() |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestFixtureSetUp()() |
 | TestFixtureTearDown()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ModuleManagerTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


ModuleManagerTester Constructor

ModuleManagerTester Constructor
Namespaces >> MSS.Testing >> ModuleManagerTester >> ModuleManagerTesterModuleManagerTesterNew()()
Declaration Syntax
C#
public ModuleManagerTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetModulesTester Method

GetModulesTester Method
Namespaces >> MSS.Testing >> ModuleManagerTester >> GetModulesTester()()
Declaration Syntax
C#
[TestAttribute]
public void GetModulesTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


IsAvailableTester Method

IsAvailableTester Method
Namespaces >> MSS.Testing >> ModuleManagerTester >> IsAvailableTester()()
Declaration Syntax
C#
[TestAttribute]
public void IsAvailableTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestFixtureSetUp Method

TestFixtureSetUp Method
Namespaces >> MSS.Testing >> ModuleManagerTester >> TestFixtureSetUp()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void TestFixtureSetUp()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestFixtureTearDown Method

TestFixtureTearDown Method
Namespaces >> MSS.Testing >> ModuleManagerTester >> TestFixtureTearDown()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void TestFixtureTearDown()

Assembly: MSS.Kernel (Module: MSS.Kernel)


PackageManagerTester Class

PackageManagerTester Class
Namespaces >> MSS.Testing >> PackageManagerTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class PackageManagerTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PackageManagerTesterPackageManagerTesterNew()() |
 | CreatePackageTest()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestFixtureSetUp()() |
 | TestFixtureTearDown()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PackageManagerTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


PackageManagerTester Constructor

PackageManagerTester Constructor
Namespaces >> MSS.Testing >> PackageManagerTester >> PackageManagerTesterPackageManagerTesterNew()()
Declaration Syntax
C#
public PackageManagerTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreatePackageTest Method

CreatePackageTest Method
Namespaces >> MSS.Testing >> PackageManagerTester >> CreatePackageTest()()
Declaration Syntax
C#
[TestAttribute]
public void CreatePackageTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestFixtureSetUp Method

TestFixtureSetUp Method
Namespaces >> MSS.Testing >> PackageManagerTester >> TestFixtureSetUp()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void TestFixtureSetUp()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestFixtureTearDown Method

TestFixtureTearDown Method
Namespaces >> MSS.Testing >> PackageManagerTester >> TestFixtureTearDown()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void TestFixtureTearDown()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityManagerTester Class

SecurityManagerTester Class
Namespaces >> MSS.Testing >> SecurityManagerTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class SecurityManagerTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SecurityManagerTesterSecurityManagerTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupAccessTest()() |
 | GroupCreationTest()() |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RestrictedAccessTest()() |
 | SetUp()() |
 | SetUpGlobal()() |
 | TearDown()() |
 | TearDownGlobal()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserAccessTest()() |
 | UserCreationTest()() |
Inheritance Hierarchy
Object
SecurityManagerTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


SecurityManagerTester Constructor

SecurityManagerTester Constructor
Namespaces >> MSS.Testing >> SecurityManagerTester >> SecurityManagerTesterSecurityManagerTesterNew()()
Declaration Syntax
C#
public SecurityManagerTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GroupAccessTest Method

GroupAccessTest Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> GroupAccessTest()()
Declaration Syntax
C#
[TestAttribute]
public void GroupAccessTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GroupCreationTest Method

GroupCreationTest Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> GroupCreationTest()()
Declaration Syntax
C#
[TestAttribute]
public void GroupCreationTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


RestrictedAccessTest Method

RestrictedAccessTest Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> RestrictedAccessTest()()
Declaration Syntax
C#
[TestAttribute]
public void RestrictedAccessTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetUp Method

SetUp Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> SetUp()()
Declaration Syntax
C#
[SetUpAttribute]
public void SetUp()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetUpGlobal Method

SetUpGlobal Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> SetUpGlobal()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void SetUpGlobal()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TearDown Method

TearDown Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> TearDown()()
Declaration Syntax
C#
[TearDownAttribute]
public void TearDown()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TearDownGlobal Method

TearDownGlobal Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> TearDownGlobal()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void TearDownGlobal()

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserAccessTest Method

UserAccessTest Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> UserAccessTest()()
Declaration Syntax
C#
[TestAttribute]
public void UserAccessTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserCreationTest Method

UserCreationTest Method
Namespaces >> MSS.Testing >> SecurityManagerTester >> UserCreationTest()()
Declaration Syntax
C#
[TestAttribute]
public void UserCreationTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextManagerTester Class

SiteContextManagerTester Class
Namespaces >> MSS.Testing >> SiteContextManagerTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class SiteContextManagerTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteContextManagerTesterSiteContextManagerTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSiteRootTester()() |
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Setup()() |
 | SiteCreateDeleteTest()() |
 | TearDowm()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SiteContextManagerTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextManagerTester Constructor

SiteContextManagerTester Constructor
Namespaces >> MSS.Testing >> SiteContextManagerTester >> SiteContextManagerTesterSiteContextManagerTesterNew()()
Declaration Syntax
C#
public SiteContextManagerTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteRootTester Method

GetSiteRootTester Method
Namespaces >> MSS.Testing >> SiteContextManagerTester >> GetSiteRootTester()()
Declaration Syntax
C#
[TestAttribute]
public void GetSiteRootTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Setup Method

Setup Method
Namespaces >> MSS.Testing >> SiteContextManagerTester >> Setup()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void Setup()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteCreateDeleteTest Method

SiteCreateDeleteTest Method
Namespaces >> MSS.Testing >> SiteContextManagerTester >> SiteCreateDeleteTest()()
Declaration Syntax
C#
[TestAttribute]
public void SiteCreateDeleteTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TearDowm Method

TearDowm Method
Namespaces >> MSS.Testing >> SiteContextManagerTester >> TearDowm()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void TearDowm()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextTester Class

SiteContextTester Class
Namespaces >> MSS.Testing >> SiteContextTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class SiteContextTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteContextTesterSiteContextTesterNew()() |
 | ContentDocumentTest()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | LocalDocumentTest()() |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PropertiesTest()() |
 | TestFixtureSetUp()() |
 | TestFixtureTearDown()() |
 | TestInvalidSite()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SiteContextTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteContextTester Constructor

SiteContextTester Constructor
Namespaces >> MSS.Testing >> SiteContextTester >> SiteContextTesterSiteContextTesterNew()()
Declaration Syntax
C#
public SiteContextTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


ContentDocumentTest Method

ContentDocumentTest Method
Namespaces >> MSS.Testing >> SiteContextTester >> ContentDocumentTest()()
Declaration Syntax
C#
[TestAttribute(Description = "Test the method IsContent document")]
public void ContentDocumentTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LocalDocumentTest Method

LocalDocumentTest Method
Namespaces >> MSS.Testing >> SiteContextTester >> LocalDocumentTest()()
Declaration Syntax
C#
[TestAttribute(Description = "Test the method IsLocalDocument")]
public void LocalDocumentTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


PropertiesTest Method

PropertiesTest Method
Namespaces >> MSS.Testing >> SiteContextTester >> PropertiesTest()()
Declaration Syntax
C#
[TestAttribute]
public void PropertiesTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestFixtureSetUp Method

TestFixtureSetUp Method
Namespaces >> MSS.Testing >> SiteContextTester >> TestFixtureSetUp()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void TestFixtureSetUp()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestFixtureTearDown Method

TestFixtureTearDown Method
Namespaces >> MSS.Testing >> SiteContextTester >> TestFixtureTearDown()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void TestFixtureTearDown()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestInvalidSite Method

TestInvalidSite Method
Namespaces >> MSS.Testing >> SiteContextTester >> TestInvalidSite()()
Declaration Syntax
C#
[TestAttribute(Description = "Test invalid site")]
public void TestInvalidSite()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeManagerTester Class

SiteTypeManagerTester Class
Namespaces >> MSS.Testing >> SiteTypeManagerTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class SiteTypeManagerTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteTypeManagerTesterSiteTypeManagerTesterNew()() |
 | Dispose()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSiteTypeTest()() |
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()() |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SiteTypeManagerTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeManagerTester Constructor

SiteTypeManagerTester Constructor
Namespaces >> MSS.Testing >> SiteTypeManagerTester >> SiteTypeManagerTesterSiteTypeManagerTesterNew()()
Declaration Syntax
C#
public SiteTypeManagerTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Dispose Method

Dispose Method
Namespaces >> MSS.Testing >> SiteTypeManagerTester >> Dispose()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void Dispose()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetSiteTypeTest Method

GetSiteTypeTest Method
Namespaces >> MSS.Testing >> SiteTypeManagerTester >> GetSiteTypeTest()()
Declaration Syntax
C#
[TestAttribute]
public void GetSiteTypeTest()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Init Method

Init Method
Namespaces >> MSS.Testing >> SiteTypeManagerTester >> Init()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void Init()

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeTester Class

SiteTypeTester Class
Namespaces >> MSS.Testing >> SiteTypeTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class SiteTypeTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteTypeTesterSiteTypeTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupsTester()() |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestSetUp()() |
 | TestTearDown()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SiteTypeTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


SiteTypeTester Constructor

SiteTypeTester Constructor
Namespaces >> MSS.Testing >> SiteTypeTester >> SiteTypeTesterSiteTypeTesterNew()()
Declaration Syntax
C#
public SiteTypeTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


GroupsTester Method

GroupsTester Method
Namespaces >> MSS.Testing >> SiteTypeTester >> GroupsTester()()
Declaration Syntax
C#
[TestAttribute]
public void GroupsTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestSetUp Method

TestSetUp Method
Namespaces >> MSS.Testing >> SiteTypeTester >> TestSetUp()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void TestSetUp()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestTearDown Method

TestTearDown Method
Namespaces >> MSS.Testing >> SiteTypeTester >> TestTearDown()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void TestTearDown()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TimerTester Class

TimerTester Class
Namespaces >> MSS.Testing >> TimerTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class TimerTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TimerTesterTimerTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Test1()() |
 | Test2()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TimerTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


TimerTester Constructor

TimerTester Constructor
Namespaces >> MSS.Testing >> TimerTester >> TimerTesterTimerTesterNew()()
Declaration Syntax
C#
public TimerTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Test1 Method

Test1 Method
Namespaces >> MSS.Testing >> TimerTester >> Test1()()
Declaration Syntax
C#
[TestAttribute(Description = "Test Start, Stop, Milliseconds")]
public void Test1()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Test2 Method

Test2 Method
Namespaces >> MSS.Testing >> TimerTester >> Test2()()
Declaration Syntax
C#
[TestAttribute(Description = "Test properties")]
public void Test2()

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserTester Class

UserTester Class
Namespaces >> MSS.Testing >> UserTester
Declaration Syntax
C#
[TestFixtureAttribute]
public class UserTester
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UserTesterUserTesterNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestSetUp()() |
 | TestTearDown()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserTester

Assembly: MSS.Kernel (Module: MSS.Kernel)


UserTester Constructor

UserTester Constructor
Namespaces >> MSS.Testing >> UserTester >> UserTesterUserTesterNew()()
Declaration Syntax
C#
public UserTester()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestSetUp Method

TestSetUp Method
Namespaces >> MSS.Testing >> UserTester >> TestSetUp()()
Declaration Syntax
C#
[TestFixtureSetUpAttribute]
public void TestSetUp()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TestTearDown Method

TestTearDown Method
Namespaces >> MSS.Testing >> UserTester >> TestTearDown()()
Declaration Syntax
C#
[TestFixtureTearDownAttribute]
public void TestTearDown()

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Utilities Namespace

MSS.Utilities Namespace
Namespaces >> MSS.Utilities
Declaration Syntax
C#
namespace MSS.Utilities
Types
All Types Classes
Icon | Type | Description
 | CssBuilder | Build the cascading style sheet.
 | LinkUtil | Utility methods for working with Sitecore link.
 | Mail | Utility methods for working with mail.
 | Singleton<(Of <T>)> | Base class for the singleton classes.
 | SitecoreUtils |
 | Timer | Timer
 | TwoWayLock | This class is used when we need to synchronize objects while doing read operations (left locks) and modifying operations (right locks).
 | Utils | Utility methods
 | WebUtil | Web utility methods.
 | XmlUtil | Xml utility methods.


CssBuilder Class

CssBuilder Class
Namespaces >> MSS.Utilities >> CssBuilder
Build the cascading style sheet.
Declaration Syntax
C#
public class CssBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CssBuilderCssBuilderNew()() |
 | Add(String) | Adds the style.
 | Add(String, String) | Adds the specified style for the control.
 | AddClass(String, String) | Adds the class.
 | AddQualifiedClass(String, String) | Adds the qualified class.
 | AddTag(String, String) | Adds the tag.
 | Css | Gets the cascading style sheet.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CssBuilder

Assembly: MSS.Kernel (Module: MSS.Kernel)


CssBuilder Constructor

CssBuilder Constructor
Namespaces >> MSS.Utilities >> CssBuilder >> CssBuilderCssBuilderNew()()
Declaration Syntax
C#
public CssBuilder()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Add Method

Add Method
Namespaces >> MSS.Utilities >> CssBuilder >> Add()()
Members
Icon | Member | Description
 | Add(String) | Adds the style.
 | Add(String, String) | Adds the specified style for the control.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Add Method (style)

Add Method (style)
Namespaces >> MSS.Utilities >> CssBuilder >> Add(String)
Adds the style.
Declaration Syntax
C#
public void Add(
    string style
)
Parameters
style (String)
The style.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Add Method (controlId, style)

Add Method (controlId, style)
Namespaces >> MSS.Utilities >> CssBuilder >> Add(String, String)
Adds the specified style for the control.
Declaration Syntax
C#
public void Add(
    string controlId,
    string style
)
Parameters
controlId (String)
The control id.
style (String)
The style.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddClass Method (id, style)

AddClass Method (id, style)
Namespaces >> MSS.Utilities >> CssBuilder >> AddClass(String, String)
Adds the class.
Declaration Syntax
C#
public void AddClass(
    string id,
    string style
)
Parameters
id (String)
The id.
style (String)
The style.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddQualifiedClass Method (id, style)

AddQualifiedClass Method (id, style)
Namespaces >> MSS.Utilities >> CssBuilder >> AddQualifiedClass(String, String)
Adds the qualified class.
Declaration Syntax
C#
public void AddQualifiedClass(
    string id,
    string style
)
Parameters
id (String)
The id.
style (String)
The style.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddTag Method (tagName, style)

AddTag Method (tagName, style)
Namespaces >> MSS.Utilities >> CssBuilder >> AddTag(String, String)
Adds the tag.
Declaration Syntax
C#
public void AddTag(
    string tagName,
    string style
)
Parameters
tagName (String)
Name of the tag.
style (String)
The style.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Css Property

Css Property
Namespaces >> MSS.Utilities >> CssBuilder >> Css
Gets the cascading style sheet.
Declaration Syntax
C#
public string Css{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


LinkUtil Class

LinkUtil Class
Namespaces >> MSS.Utilities >> LinkUtil
Utility methods for working with Sitecore link.
Declaration Syntax
C#
public class LinkUtil
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LinkUtilLinkUtilNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateLinks(Item, Item) | After item was copied this method update internal links and lookup field.
Inheritance Hierarchy
Object
LinkUtil

Assembly: MSS.Kernel (Module: MSS.Kernel)


LinkUtil Constructor

LinkUtil Constructor
Namespaces >> MSS.Utilities >> LinkUtil >> LinkUtilLinkUtilNew()()
Declaration Syntax
C#
public LinkUtil()

Assembly: MSS.Kernel (Module: MSS.Kernel)


UpdateLinks Method (source, dest)

UpdateLinks Method (source, dest)
Namespaces >> MSS.Utilities >> LinkUtil >> UpdateLinks(Item, Item)
After item was copied this method update internal links and lookup field.
Declaration Syntax
C#
public static void UpdateLinks(
    Item source,
    Item dest
)
Parameters
source (Item)
The source.
dest (Item)
The destination.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Mail Class

Mail Class
Namespaces >> MSS.Utilities >> Mail
Utility methods for working with mail.
Declaration Syntax
C#
public sealed class Mail
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EmailIsValid(String) | Checks if an e-mail string has valid syntax.
 | EmailIsValidFullCheck(String) | Performs a full check of whether an email address is valid.
 | EmailListIsValid(String) | Checks whether a list of e-mails have valid syntax.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SendMail(String, String, String, String) | Sends an email.
 | SendMail(String, String, String, String, Boolean) | Sends an email.
 | SendMails(String, String, String, String, Boolean) | Send an email to a list of subscribers.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Mail

Assembly: MSS.Kernel (Module: MSS.Kernel)


EmailIsValid Method (email)

EmailIsValid Method (email)
Namespaces >> MSS.Utilities >> Mail >> EmailIsValid(String)
Checks if an e-mail string has valid syntax.
Declaration Syntax
C#
public static bool EmailIsValid(
    string email
)
Parameters
email (String)
E-mail
Return Value
True, if email has valid 'e-mail' syntax; otherwise false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


EmailIsValidFullCheck Method (email)

EmailIsValidFullCheck Method (email)
Namespaces >> MSS.Utilities >> Mail >> EmailIsValidFullCheck(String)
Performs a full check of whether an email address is valid.
Declaration Syntax
C#
public static bool EmailIsValidFullCheck(
    string email
)
Parameters
email (String)
E-mail address

Assembly: MSS.Kernel (Module: MSS.Kernel)


EmailListIsValid Method (emailList)

EmailListIsValid Method (emailList)
Namespaces >> MSS.Utilities >> Mail >> EmailListIsValid(String)
Checks whether a list of e-mails have valid syntax.
Declaration Syntax
C#
public static bool EmailListIsValid(
    string emailList
)
Parameters
emailList (String)
The list of e-mails, separated by a semicolon ";".
Return Value
True, for each email that has valid 'e-mail' syntax; otherwise false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SendMail Method

SendMail Method
Namespaces >> MSS.Utilities >> Mail >> SendMail()()
Members
Icon | Member | Description
 | SendMail(String, String, String, String) | Sends an email.
 | SendMail(String, String, String, String, Boolean) | Sends an email.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SendMail Method (to, from, subject, body)

SendMail Method (to, from, subject, body)
Namespaces >> MSS.Utilities >> Mail >> SendMail(String, String, String, String)
Sends an email.
Declaration Syntax
C#
public static bool SendMail(
    string to,
    string from,
    string subject,
    string body
)
Parameters
to (String)
To.
from (String)
From.
subject (String)
The subject.
body (String)
The main email text.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SendMail Method (to, from, subject, body, throwException)

SendMail Method (to, from, subject, body, throwException)
Namespaces >> MSS.Utilities >> Mail >> SendMail(String, String, String, String, Boolean)
Sends an email.
Declaration Syntax
C#
public static bool SendMail(
    string to,
    string from,
    string subject,
    string body,
    bool throwException
)
Parameters
to (String)
To.
from (String)
From.
subject (String)
The subject.
body (String)
The main email text.
throwException (Boolean)
If set to true throw exception.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SendMails Method (emailList, from, subject, body, throwException)

SendMails Method (emailList, from, subject, body, throwException)
Namespaces >> MSS.Utilities >> Mail >> SendMails(String, String, String, String, Boolean)
Send an email to a list of subscribers.
Declaration Syntax
C#
public static bool SendMails(
    string emailList,
    string from,
    string subject,
    string body,
    bool throwException
)
Parameters
emailList (String)
The email subscribers list.
from (String)
From.
subject (String)
The subject.
body (String)
The main email text.
throwException (Boolean)
If set to true throw exception.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Singleton Class

Singleton<(Of <T>)> Class
Namespaces >> MSS.Utilities >> Singleton<(Of <T>)>
Base class for the singleton classes.
Declaration Syntax
C#
public class Singleton<T> where T : class
Generic Template Parameters
T
The type name.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Singleton<(Of <T>)>Singleton<(Of <T>)>New()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Singleton<(Of <T>)>
 |  | Settings
 |  | ConfigFile
 |  | ServerManager
 |  | IISManager
 |  | MediaControlsFactory

Assembly: MSS.Kernel (Module: MSS.Kernel)


Singleton Constructor

Singleton<(Of <T>)> Constructor
Namespaces >> MSS.Utilities >> Singleton<(Of <T>)> >> Singleton<(Of <T>)>Singleton<(Of <T>)>New()()
Declaration Syntax
C#
public Singleton()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Instance Property

Instance Property
Namespaces >> MSS.Utilities >> Singleton<(Of <T>)> >> Instance
Declaration Syntax
C#
public static T Instance{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


SitecoreUtils Class

SitecoreUtils Class
Namespaces >> MSS.Utilities >> SitecoreUtils
Declaration Syntax
C#
public class SitecoreUtils
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SitecoreUtilsSitecoreUtilsNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromSitecore(Item) | Loads field values from the item and puts them into the StringDictionary.
 | LoadFromSitecore(Item, Boolean) | Loads field values from the item and puts them into the StringDictionary.
 | LoadFromSitecore(Item, Boolean, StringDictionary) | Loads fields values from the item and put them to the StringDictionary.
 | LoadFromSitecore(Item, Boolean, StringDictionary, Boolean) | Loads fields value from the item and put them to the StringDictionary
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveToSitecore(Item, Boolean, StringDictionary) | Sets field values to the item got from the data represented by the StringDictionary.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SitecoreUtils

Assembly: MSS.Kernel (Module: MSS.Kernel)


SitecoreUtils Constructor

SitecoreUtils Constructor
Namespaces >> MSS.Utilities >> SitecoreUtils >> SitecoreUtilsSitecoreUtilsNew()()
Declaration Syntax
C#
public SitecoreUtils()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadFromSitecore Method

LoadFromSitecore Method
Namespaces >> MSS.Utilities >> SitecoreUtils >> LoadFromSitecore()()
Members
Icon | Member | Description
 | LoadFromSitecore(Item) | Loads field values from the item and puts them into the StringDictionary.
 | LoadFromSitecore(Item, Boolean) | Loads field values from the item and puts them into the StringDictionary.
 | LoadFromSitecore(Item, Boolean, StringDictionary) | Loads fields values from the item and put them to the StringDictionary.
 | LoadFromSitecore(Item, Boolean, StringDictionary, Boolean) | Loads fields value from the item and put them to the StringDictionary

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadFromSitecore Method (item)

LoadFromSitecore Method (item)
Namespaces >> MSS.Utilities >> SitecoreUtils >> LoadFromSitecore(Item)
Loads field values from the item and puts them into the StringDictionary.
Declaration Syntax
C#
public static StringDictionary LoadFromSitecore(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadFromSitecore Method (item, bOverwriteAll)

LoadFromSitecore Method (item, bOverwriteAll)
Namespaces >> MSS.Utilities >> SitecoreUtils >> LoadFromSitecore(Item, Boolean)
Loads field values from the item and puts them into the StringDictionary.
Declaration Syntax
C#
public static StringDictionary LoadFromSitecore(
    Item item,
    bool bOverwriteAll
)
Parameters
item (Item)
The item.
bOverwriteAll (Boolean)
If set to true then all the settings will be overwritten otherwise only settings with empty values will be overwritten.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadFromSitecore Method (item, bOverwriteAll, data)

LoadFromSitecore Method (item, bOverwriteAll, data)
Namespaces >> MSS.Utilities >> SitecoreUtils >> LoadFromSitecore(Item, Boolean, StringDictionary)
Loads fields values from the item and put them to the StringDictionary.
Declaration Syntax
C#
public static void LoadFromSitecore(
    Item item,
    bool bOverwriteAll,
    StringDictionary data
)
Parameters
item (Item)
The item.
bOverwriteAll (Boolean)
If set to true then all the settings will be overwritten otherwise only settings with empty values will be overwritten.
data (StringDictionary)
The data.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadFromSitecore Method (item, overwriteAll, data, overwriteBlank)

LoadFromSitecore Method (item, overwriteAll, data, overwriteBlank)
Namespaces >> MSS.Utilities >> SitecoreUtils >> LoadFromSitecore(Item, Boolean, StringDictionary, Boolean)
Loads fields value from the item and put them to the StringDictionary
Declaration Syntax
C#
public static void LoadFromSitecore(
    Item item,
    bool overwriteAll,
    StringDictionary data,
    bool overwriteBlank
)
Parameters
item (Item)
The item.
overwriteAll (Boolean)
data (StringDictionary)
The data.
overwriteBlank (Boolean)
if set to true than settings will be overwritten with empty values too

Assembly: MSS.Kernel (Module: MSS.Kernel)


SaveToSitecore Method (item, publish, data)

SaveToSitecore Method (item, publish, data)
Namespaces >> MSS.Utilities >> SitecoreUtils >> SaveToSitecore(Item, Boolean, StringDictionary)
Sets field values to the item got from the data represented by the StringDictionary.
Declaration Syntax
C#
public static void SaveToSitecore(
    Item item,
    bool publish,
    StringDictionary data
)
Parameters
item (Item)
The item.
publish (Boolean)
if set to true then the item will be published.
data (StringDictionary)
The data to be saved in fields.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Timer Class

Timer Class
Namespaces >> MSS.Utilities >> Timer
Timer
Declaration Syntax
C#
public class Timer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimerTimerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Milliseconds | Gets the milliseconds.
 | Pause()() | Pauses timer.
 | Paused | Gets or sets a value indicating whether the timer has paused.
 | Reset()() | Resets the timer.
 | Restart()() | Stops the timer if it's run and restarts it.
 | Resume()() | Resumes the timer.
 | Start()() | Starts the timer. Timer shouldn't be running.
 | Started | Gets or sets a value indicating whether the timer has started.
 | Stop()() | Stops the timer.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Timer

Assembly: MSS.Kernel (Module: MSS.Kernel)


Timer Constructor

Timer Constructor
Namespaces >> MSS.Utilities >> Timer >> TimerTimerNew()()
Declaration Syntax
C#
public Timer()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Milliseconds Property

Milliseconds Property
Namespaces >> MSS.Utilities >> Timer >> Milliseconds
Gets the milliseconds.
Declaration Syntax
C#
public int Milliseconds{ get;}
Value
The milliseconds.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Pause Method

Pause Method
Namespaces >> MSS.Utilities >> Timer >> Pause()()
Pauses timer.
Declaration Syntax
C#
public void Pause()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Paused Property

Paused Property
Namespaces >> MSS.Utilities >> Timer >> Paused
Gets or sets a value indicating whether the timer has paused.
Declaration Syntax
C#
public bool Paused{ get; set;}
Value
true if the timer has paused; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Reset Method

Reset Method
Namespaces >> MSS.Utilities >> Timer >> Reset()()
Resets the timer.
Declaration Syntax
C#
public void Reset()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Restart Method

Restart Method
Namespaces >> MSS.Utilities >> Timer >> Restart()()
Stops the timer if it's run and restarts it.
Declaration Syntax
C#
public void Restart()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Resume Method

Resume Method
Namespaces >> MSS.Utilities >> Timer >> Resume()()
Resumes the timer.
Declaration Syntax
C#
public void Resume()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Start Method

Start Method
Namespaces >> MSS.Utilities >> Timer >> Start()()
Starts the timer. Timer shouldn't be running.
Declaration Syntax
C#
public void Start()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Started Property

Started Property
Namespaces >> MSS.Utilities >> Timer >> Started
Gets or sets a value indicating whether the timer has started.
Declaration Syntax
C#
public bool Started{ get; set;}
Value
True if the timer has started; otherwise, false.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Stop Method

Stop Method
Namespaces >> MSS.Utilities >> Timer >> Stop()()
Stops the timer.
Declaration Syntax
C#
public void Stop()

Assembly: MSS.Kernel (Module: MSS.Kernel)


TwoWayLock Class

TwoWayLock Class
Namespaces >> MSS.Utilities >> TwoWayLock
This class is used when we need to synchronize objects while doing read operations (left locks) and modifying operations (right locks).
Declaration Syntax
C#
public class TwoWayLock
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TwoWayLockTwoWayLockNew()() |
 | EnterLeft()() | Waiting while there will be no right locks and then adding left lock.
 | EnterRight()() | Waiting while there will be no right locks then adding a right lock and waiting till all left locks are closed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | LeaveLeft()() | Removes left lock
 | LeaveRight()() | Removes right lock
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TwoWayLock

Assembly: MSS.Kernel (Module: MSS.Kernel)


TwoWayLock Constructor

TwoWayLock Constructor
Namespaces >> MSS.Utilities >> TwoWayLock >> TwoWayLockTwoWayLockNew()()
Declaration Syntax
C#
public TwoWayLock()

Assembly: MSS.Kernel (Module: MSS.Kernel)


EnterLeft Method

EnterLeft Method
Namespaces >> MSS.Utilities >> TwoWayLock >> EnterLeft()()
Waiting while there will be no right locks and then adding left lock.
Declaration Syntax
C#
public void EnterLeft()

Assembly: MSS.Kernel (Module: MSS.Kernel)


EnterRight Method

EnterRight Method
Namespaces >> MSS.Utilities >> TwoWayLock >> EnterRight()()
Waiting while there will be no right locks then adding a right lock and waiting till all left locks are closed.
Declaration Syntax
C#
public void EnterRight()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LeaveLeft Method

LeaveLeft Method
Namespaces >> MSS.Utilities >> TwoWayLock >> LeaveLeft()()
Removes left lock
Declaration Syntax
C#
public void LeaveLeft()

Assembly: MSS.Kernel (Module: MSS.Kernel)


LeaveRight Method

LeaveRight Method
Namespaces >> MSS.Utilities >> TwoWayLock >> LeaveRight()()
Removes right lock
Declaration Syntax
C#
public void LeaveRight()

Assembly: MSS.Kernel (Module: MSS.Kernel)


Utils Class

Utils Class
Namespaces >> MSS.Utilities >> Utils
Utility methods
Declaration Syntax
C#
public class Utils
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UtilsUtilsNew()() |
 | CloneStringDictionary(StringDictionary) | Makes a deep clone of the given instance.
 | Combine(String, String) | Combines the specified string1 and string2, separated by a single "/" character.
 | Combine(String, String, String) | Combines the specified string1 and string2, separated by a single separator character given.
 | CreateMediaItem(Item, String, Stream) | Creates a media item.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FastPublish(Item, Boolean) | Fast publish items.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(Control, String) | Finds the control.
 | GeneratePassword()() | Generates a password with the default length.
 | GeneratePassword(Int32) | Generates a password with the necessary length.
 | GetChild(Item, String) | Return item's child which has childName name. This method works more fast than item.Childrent[childName] for the big databases.
 | GetFieldValue(Item, String, String) | Gets the field value.
 | GetFieldValue(Item, String, String, String) | Gets the field value.
 | GetFriendlyUrl(Item) | Gets the friendly URL for the item.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMenuTitle(Item) | Gets the menu title for the item.
 | GetMSSMaster(String) | Gets the MSS master by its name.
 | GetRenderings(Page, Item) | Gets the item's renderings.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue<(Of <T>)>(Object, T) | Tries to cast the value to the type T
 | GetValueFromString(String, Boolean) | Gets the bool value from a string.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseInt(String, Int32) | Parses the string that represents integer value.
 | PublishItem(Item) | Publishes items recursively and waits for the operation to finish.
 | PublishItem(Item, Boolean) | Publish items and wait for the operation to finish.
 | PublishItem(Item, Boolean, Boolean) | Publish items
 | PublishItem(Item, Boolean, Boolean, Boolean) | Publish items.
 | Random |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimChars(String, array<Char>[]()) | Trims the chars.
Inheritance Hierarchy
Object
Utils

Assembly: MSS.Kernel (Module: MSS.Kernel)


Utils Constructor

Utils Constructor
Namespaces >> MSS.Utilities >> Utils >> UtilsUtilsNew()()
Declaration Syntax
C#
public Utils()

Assembly: MSS.Kernel (Module: MSS.Kernel)


CloneStringDictionary Method (original)

CloneStringDictionary Method (original)
Namespaces >> MSS.Utilities >> Utils >> CloneStringDictionary(StringDictionary)
Makes a deep clone of the given instance.
Declaration Syntax
C#
public static StringDictionary CloneStringDictionary(
    StringDictionary original
)
Parameters
original (StringDictionary)
The original instance.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


Combine Method

Combine Method
Namespaces >> MSS.Utilities >> Utils >> Combine()()
Members
Icon | Member | Description
 | Combine(String, String) | Combines the specified string1 and string2, separated by a single "/" character.
 | Combine(String, String, String) | Combines the specified string1 and string2, separated by a single separator character given.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Combine Method (string1, string2)

Combine Method (string1, string2)
Namespaces >> MSS.Utilities >> Utils >> Combine(String, String)
Combines the specified string1 and string2, separated by a single "/" character.
Declaration Syntax
C#
public static string Combine(
    string string1,
    string string2
)
Parameters
string1 (String)
String 1
string2 (String)
String 2
Return Value
The resulting combined string.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Combine Method (string1, string2, seperator)

Combine Method (string1, string2, seperator)
Namespaces >> MSS.Utilities >> Utils >> Combine(String, String, String)
Combines the specified string1 and string2, separated by a single separator character given.
Declaration Syntax
C#
public static string Combine(
    string string1,
    string string2,
    string seperator
)
Parameters
string1 (String)
String 1
string2 (String)
String 2
seperator (String)
The given separator.
Return Value
The resulting combined string.

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateMediaItem Method (parentItem, fileName, stream)

CreateMediaItem Method (parentItem, fileName, stream)
Namespaces >> MSS.Utilities >> Utils >> CreateMediaItem(Item, String, Stream)
Creates a media item.
Declaration Syntax
C#
public static MediaItem CreateMediaItem(
    Item parentItem,
    string fileName,
    Stream stream
)
Parameters
parentItem (Item)
The parent item.
fileName (String)
Name of the file.
stream (Stream)
The stream.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


FastPublish Method (item, deep)

FastPublish Method (item, deep)
Namespaces >> MSS.Utilities >> Utils >> FastPublish(Item, Boolean)
Fast publish items.
Declaration Syntax
C#
public static void FastPublish(
    Item item,
    bool deep
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true [deep].

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method (ctrl, ID)

FindControl Method (ctrl, ID)
Namespaces >> MSS.Utilities >> Utils >> FindControl(Control, String)
Finds the control.
Declaration Syntax
C#
public static Control FindControl(
    Control ctrl,
    string ID
)
Parameters
ctrl (Control)
The control.
ID (String)
The ID.
Return Value
The control

Assembly: MSS.Kernel (Module: MSS.Kernel)


GeneratePassword Method

GeneratePassword Method
Namespaces >> MSS.Utilities >> Utils >> GeneratePassword()()
Members
Icon | Member | Description
 | GeneratePassword()() | Generates a password with the default length.
 | GeneratePassword(Int32) | Generates a password with the necessary length.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GeneratePassword Method

GeneratePassword Method
Namespaces >> MSS.Utilities >> Utils >> GeneratePassword()()
Generates a password with the default length.
Declaration Syntax
C#
public static string GeneratePassword()
Return Value
The password.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GeneratePassword Method (length)

GeneratePassword Method (length)
Namespaces >> MSS.Utilities >> Utils >> GeneratePassword(Int32)
Generates a password with the necessary length.
Declaration Syntax
C#
public static string GeneratePassword(
    int length
)
Parameters
length (Int32)
The length.
Return Value
The password.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetChild Method (item, childName)

GetChild Method (item, childName)
Namespaces >> MSS.Utilities >> Utils >> GetChild(Item, String)
Return item's child which has childName name. This method works more fast than item.Childrent[childName] for the big databases.
Declaration Syntax
C#
public static Item GetChild(
    Item item,
    string childName
)
Parameters
item (Item)
The parrent item.
childName (String)
The child item name.
Return Value
The child item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method

GetFieldValue Method
Namespaces >> MSS.Utilities >> Utils >> GetFieldValue()()
Members
Icon | Member | Description
 | GetFieldValue(Item, String, String) | Gets the field value.
 | GetFieldValue(Item, String, String, String) | Gets the field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (item, field, subvalue)

GetFieldValue Method (item, field, subvalue)
Namespaces >> MSS.Utilities >> Utils >> GetFieldValue(Item, String, String)
Gets the field value.
Declaration Syntax
C#
public static string GetFieldValue(
    Item item,
    string field,
    string subvalue
)
Parameters
item (Item)
The item.
field (String)
The field.
subvalue (String)
The subvalue.
Return Value
The field value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFieldValue Method (item, fieldName, subFieldName, languageName)

GetFieldValue Method (item, fieldName, subFieldName, languageName)
Namespaces >> MSS.Utilities >> Utils >> GetFieldValue(Item, String, String, String)
Gets the field value.
Declaration Syntax
C#
public static string GetFieldValue(
    Item item,
    string fieldName,
    string subFieldName,
    string languageName
)
Parameters
item (Item)
The item.
fieldName (String)
Name of the field.
subFieldName (String)
Name of the sub field.
languageName (String)
The language.
Return Value
The field value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFriendlyUrl Method (item)

GetFriendlyUrl Method (item)
Namespaces >> MSS.Utilities >> Utils >> GetFriendlyUrl(Item)
Gets the friendly URL for the item.
Declaration Syntax
C#
public static string GetFriendlyUrl(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The friendly URL.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetMenuTitle Method (item)

GetMenuTitle Method (item)
Namespaces >> MSS.Utilities >> Utils >> GetMenuTitle(Item)
Gets the menu title for the item.
Declaration Syntax
C#
public static string GetMenuTitle(
    Item item
)
Parameters
item (Item)
The item.
Return Value
The menu title.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetMSSMaster Method (masterName)

GetMSSMaster Method (masterName)
Namespaces >> MSS.Utilities >> Utils >> GetMSSMaster(String)
Gets the MSS master by its name.
Declaration Syntax
C#
public static MasterItem GetMSSMaster(
    string masterName
)
Parameters
masterName (String)
Name of the master.
Return Value
The MSS master.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetRenderings Method (page, item)

GetRenderings Method (page, item)
Namespaces >> MSS.Utilities >> Utils >> GetRenderings(Page, Item)
Gets the item's renderings.
Declaration Syntax
C#
public static Control[] GetRenderings(
    Page page,
    Item item
)
Parameters
page (Page)
The page.
item (Item)
The item.
Return Value
The renderings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetValue Method (value, _default)

GetValue<(Of <T>)> Method (value, _default)
Namespaces >> MSS.Utilities >> Utils >> GetValue<(Of <T>)>(Object, T)
Tries to cast the value to the type T
Declaration Syntax
C#
public static T GetValue<T>(
    Object value,
    T _default
)
Generic Template Parameters
T
Type
Parameters
value (Object)
The value.
_default (T)
Default value in the case of a bad typecast

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetValueFromString Method (value, _default)

GetValueFromString Method (value, _default)
Namespaces >> MSS.Utilities >> Utils >> GetValueFromString(String, Boolean)
Gets the bool value from a string.
Declaration Syntax
C#
public static bool GetValueFromString(
    string value,
    bool _default
)
Parameters
value (String)
The value.
_default (Boolean)
Default value in the case of unsuccesfull conversion.
Return Value
The bool value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ParseInt Method (Number, Default)

ParseInt Method (Number, Default)
Namespaces >> MSS.Utilities >> Utils >> ParseInt(String, Int32)
Parses the string that represents integer value.
Declaration Syntax
C#
public static int ParseInt(
    string Number,
    int Default
)
Parameters
Number (String)
The number.
Default (Int32)
The default value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


PublishItem Method

PublishItem Method
Namespaces >> MSS.Utilities >> Utils >> PublishItem()()
Members
Icon | Member | Description
 | PublishItem(Item) | Publishes items recursively and waits for the operation to finish.
 | PublishItem(Item, Boolean) | Publish items and wait for the operation to finish.
 | PublishItem(Item, Boolean, Boolean) | Publish items
 | PublishItem(Item, Boolean, Boolean, Boolean) | Publish items.

Assembly: MSS.Kernel (Module: MSS.Kernel)


PublishItem Method (item)

PublishItem Method (item)
Namespaces >> MSS.Utilities >> Utils >> PublishItem(Item)
Publishes items recursively and waits for the operation to finish.
Declaration Syntax
C#
public static void PublishItem(
    Item item
)
Parameters
item (Item)
Item to publish, if a null value is given all items are published.

Assembly: MSS.Kernel (Module: MSS.Kernel)


PublishItem Method (item, deep)

PublishItem Method (item, deep)
Namespaces >> MSS.Utilities >> Utils >> PublishItem(Item, Boolean)
Publish items and wait for the operation to finish.
Declaration Syntax
C#
public static void PublishItem(
    Item item,
    bool deep
)
Parameters
item (Item)
Item to publish, if null value is given all items are published.
deep (Boolean)
Publish items recursively

Assembly: MSS.Kernel (Module: MSS.Kernel)


PublishItem Method (item, deep, wait)

PublishItem Method (item, deep, wait)
Namespaces >> MSS.Utilities >> Utils >> PublishItem(Item, Boolean, Boolean)
Publish items
Declaration Syntax
C#
public static void PublishItem(
    Item item,
    bool deep,
    bool wait
)
Parameters
item (Item)
Item to publish, if null value is given all items are published.
deep (Boolean)
Publish items recursively
wait (Boolean)
Wait for publishing to finish

Assembly: MSS.Kernel (Module: MSS.Kernel)


PublishItem Method (item, deep, wait, fullPublish)

PublishItem Method (item, deep, wait, fullPublish)
Namespaces >> MSS.Utilities >> Utils >> PublishItem(Item, Boolean, Boolean, Boolean)
Publish items.
Declaration Syntax
C#
public static void PublishItem(
    Item item,
    bool deep,
    bool wait,
    bool fullPublish
)
Parameters
item (Item)
The item.
deep (Boolean)
if set to true [deep].
wait (Boolean)
if set to true [wait].
fullPublish (Boolean)
if set to true [full publish].

Assembly: MSS.Kernel (Module: MSS.Kernel)


Random Property

Random Property
Namespaces >> MSS.Utilities >> Utils >> Random
Declaration Syntax
C#
public static Random Random{ get;}

Assembly: MSS.Kernel (Module: MSS.Kernel)


TrimChars Method (Value, chars)

TrimChars Method (Value, chars)
Namespaces >> MSS.Utilities >> Utils >> TrimChars(String, array<Char>[]())
Trims the chars.
Declaration Syntax
C#
public static string TrimChars(
    string Value,
    char[] chars
)
Parameters
Value (String)
The value to be trimmed.
chars (array< Char >[]())
The chars.
Return Value
The trimed value.

Assembly: MSS.Kernel (Module: MSS.Kernel)


WebUtil Class

WebUtil Class
Namespaces >> MSS.Utilities >> WebUtil
Web utility methods.
Declaration Syntax
C#
public class WebUtil
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebUtilWebUtilNew()() |
 | DomainNameRegEx |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteWebPage(String) | Executes the web page.
 | ExecuteWebPage(String, NameValueCollection) | Executes the web page.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtension(String) | Gets the url extension.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostnameIsValid(String) |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateControl(Control, String) | Translates a single control.
 | TranslateControls(Control, String) | Translates multiple controls.
 | TranslateControls(ControlCollection, String) | Translates multiple controls.
Inheritance Hierarchy
Object
WebUtil

Assembly: MSS.Kernel (Module: MSS.Kernel)


WebUtil Constructor

WebUtil Constructor
Namespaces >> MSS.Utilities >> WebUtil >> WebUtilWebUtilNew()()
Declaration Syntax
C#
public WebUtil()

Assembly: MSS.Kernel (Module: MSS.Kernel)


DomainNameRegEx Field

DomainNameRegEx Field
Namespaces >> MSS.Utilities >> WebUtil >> DomainNameRegEx
Declaration Syntax
C#
protected static readonly string DomainNameRegEx

Assembly: MSS.Kernel (Module: MSS.Kernel)


ExecuteWebPage Method

ExecuteWebPage Method
Namespaces >> MSS.Utilities >> WebUtil >> ExecuteWebPage()()
Members
Icon | Member | Description
 | ExecuteWebPage(String) | Executes the web page.
 | ExecuteWebPage(String, NameValueCollection) | Executes the web page.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ExecuteWebPage Method (url)

ExecuteWebPage Method (url)
Namespaces >> MSS.Utilities >> WebUtil >> ExecuteWebPage(String)
Executes the web page.
Declaration Syntax
C#
public static string ExecuteWebPage(
    string url
)
Parameters
url (String)
The URL.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


ExecuteWebPage Method (url, headers)

ExecuteWebPage Method (url, headers)
Namespaces >> MSS.Utilities >> WebUtil >> ExecuteWebPage(String, NameValueCollection)
Executes the web page.
Declaration Syntax
C#
public static string ExecuteWebPage(
    string url,
    NameValueCollection headers
)
Parameters
url (String)
The URL.
headers (NameValueCollection)
The headers.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetExtension Method (urlPath)

GetExtension Method (urlPath)
Namespaces >> MSS.Utilities >> WebUtil >> GetExtension(String)
Gets the url extension.
Declaration Syntax
C#
public static string GetExtension(
    string urlPath
)
Parameters
urlPath (String)
The URL path.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


HostnameIsValid Method (domainName)

HostnameIsValid Method (domainName)
Namespaces >> MSS.Utilities >> WebUtil >> HostnameIsValid(String)
Declaration Syntax
C#
public static bool HostnameIsValid(
    string domainName
)
Parameters
domainName (String)

Assembly: MSS.Kernel (Module: MSS.Kernel)


TranslateControl Method (control, dictionaryPath)

TranslateControl Method (control, dictionaryPath)
Namespaces >> MSS.Utilities >> WebUtil >> TranslateControl(Control, String)
Translates a single control.
Declaration Syntax
C#
public static void TranslateControl(
    Control control,
    string dictionaryPath
)
Parameters
control (Control)
The control.
dictionaryPath (String)
The dictionary path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


TranslateControls Method

TranslateControls Method
Namespaces >> MSS.Utilities >> WebUtil >> TranslateControls()()
Members
Icon | Member | Description
 | TranslateControls(Control, String) | Translates multiple controls.
 | TranslateControls(ControlCollection, String) | Translates multiple controls.

Assembly: MSS.Kernel (Module: MSS.Kernel)


TranslateControls Method (control, dictionaryPath)

TranslateControls Method (control, dictionaryPath)
Namespaces >> MSS.Utilities >> WebUtil >> TranslateControls(Control, String)
Translates multiple controls.
Declaration Syntax
C#
public static void TranslateControls(
    Control control,
    string dictionaryPath
)
Parameters
control (Control)
The control.
dictionaryPath (String)
The dictionary path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


TranslateControls Method (controls, dictionaryPath)

TranslateControls Method (controls, dictionaryPath)
Namespaces >> MSS.Utilities >> WebUtil >> TranslateControls(ControlCollection, String)
Translates multiple controls.
Declaration Syntax
C#
public static void TranslateControls(
    ControlCollection controls,
    string dictionaryPath
)
Parameters
controls (ControlCollection)
The controls.
dictionaryPath (String)
The dictionary path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XmlUtil Class

XmlUtil Class
Namespaces >> MSS.Utilities >> XmlUtil
Xml utility methods.
Declaration Syntax
C#
public class XmlUtil
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XmlUtilXmlUtilNew()() |
 | CreateItemNavigator(Item) | Creates the item navigator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem(XPathNodeIterator, Database) | Gets the item.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlUtil

Assembly: MSS.Kernel (Module: MSS.Kernel)


XmlUtil Constructor

XmlUtil Constructor
Namespaces >> MSS.Utilities >> XmlUtil >> XmlUtilXmlUtilNew()()
Declaration Syntax
C#
public XmlUtil()

Assembly: MSS.Kernel (Module: MSS.Kernel)


CreateItemNavigator Method (item)

CreateItemNavigator Method (item)
Namespaces >> MSS.Utilities >> XmlUtil >> CreateItemNavigator(Item)
Creates the item navigator.
Declaration Syntax
C#
public static ItemNavigator CreateItemNavigator(
    Item item
)
Parameters
item (Item)
The item.
Return Value

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetItem Method (ni, database)

GetItem Method (ni, database)
Namespaces >> MSS.Utilities >> XmlUtil >> GetItem(XPathNodeIterator, Database)
Gets the item.
Declaration Syntax
C#
public static Item GetItem(
    XPathNodeIterator ni,
    Database database
)
Parameters
ni (XPathNodeIterator)
The node iterator.
database (Database)
The database.
Return Value
The item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MSS.Web Namespace

MSS.Web Namespace
Namespaces >> MSS.Web
Declaration Syntax
C#
namespace MSS.Web
Types
All Types Classes
Icon | Type | Description
 | WebEngineDef | Web engine's constants.


WebEngineDef Class

WebEngineDef Class
Namespaces >> MSS.Web >> WebEngineDef
Web engine's constants.
Declaration Syntax
C#
public class WebEngineDef
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebEngineDefWebEngineDefNew()() |
 | EmptyImage | Path to the blank image.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | XmlControlPage | Path to the XmlControlPage. This page is used for show sitecore xml application.
Inheritance Hierarchy
Object
WebEngineDef

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WebEngineDef Constructor

WebEngineDef Constructor
Namespaces >> MSS.Web >> WebEngineDef >> WebEngineDefWebEngineDefNew()()
Declaration Syntax
C#
public WebEngineDef()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


EmptyImage Field

EmptyImage Field
Namespaces >> MSS.Web >> WebEngineDef >> EmptyImage
Path to the blank image.
Declaration Syntax
C#
public const string EmptyImage

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XmlControlPage Field

XmlControlPage Field
Namespaces >> MSS.Web >> WebEngineDef >> XmlControlPage
Path to the XmlControlPage. This page is used for show sitecore xml application.
Declaration Syntax
C#
public const string XmlControlPage

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.Web.UI.Adapters Namespace

MSS.Web.UI.Adapters Namespace
Namespaces >> MSS.Web.UI.Adapters
Declaration Syntax
C#
namespace MSS.Web.UI.Adapters
Types
All Types Classes
Icon | Type | Description
 | BaseControlAdapter | Base class for control adapters.
 | HtmlLinkControlAdapter | HtmlLink control adapter.
 | HtmlMetaControlAdapter | Renders HtmlMetaControl without close tag.


BaseControlAdapter Class

BaseControlAdapter Class
Namespaces >> MSS.Web.UI.Adapters >> BaseControlAdapter
Base class for control adapters.
Declaration Syntax
C#
public class BaseControlAdapter : ControlAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseControlAdapterBaseControlAdapterNew()() |
 | BeginRender(HtmlTextWriter) | Called prior to the rendering of a control. In a derived adapter class, generates opening tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Browser | Gets a reference to the browser capabilities of the client making the current HTTP request. (Inherited from ControlAdapter.)
 | Control | Gets a reference to the control to which this control adapter is attached. (Inherited from ControlAdapter.)
 | CreateChildControls()() | Creates the target-specific child controls for a composite control. (Inherited from ControlAdapter.)
 | EndRender(HtmlTextWriter) | Called after the rendering of a control. In a derived adapter class, generates closing tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAdapterControlState(Object) | Loads adapter control state information that was saved by SaveAdapterControlState()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | LoadAdapterViewState(Object) | Loads adapter view state information that was saved by SaveAdapterViewState()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnInit(EventArgs) | Overrides the OnInit(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnLoad(EventArgs) | Overrides the OnLoad(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnPreRender(EventArgs) | Overrides the OnPreRender(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnUnload(EventArgs) | Overrides the OnUnload(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | Page | Gets a reference to the page where the control associated with this adapter resides. (Inherited from ControlAdapter.)
 | PageAdapter | Gets a reference to the page adapter for the page where the associated control resides. (Inherited from ControlAdapter.)
 | Render(HtmlTextWriter) | Generates the target-specific markup for the control to which the control adapter is attached. (Inherited from ControlAdapter.)
 | RenderAttributes(HtmlTextWriter) | Renders control attributes.
 | RenderChildren(HtmlTextWriter) | Generates the target-specific markup for the child controls in a composite control to which the control adapter is attached. (Inherited from ControlAdapter.)
 | SaveAdapterControlState()() | Saves control state information for the control adapter. (Inherited from ControlAdapter.)
 | SaveAdapterViewState()() | Saves view state information for the control adapter. (Inherited from ControlAdapter.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlAdapter
 |  | BaseControlAdapter
 |  |  | HtmlLinkControlAdapter
 |  |  | HtmlMetaControlAdapter

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


BaseControlAdapter Constructor

BaseControlAdapter Constructor
Namespaces >> MSS.Web.UI.Adapters >> BaseControlAdapter >> BaseControlAdapterBaseControlAdapterNew()()
Declaration Syntax
C#
public BaseControlAdapter()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderAttributes Method (writer)

RenderAttributes Method (writer)
Namespaces >> MSS.Web.UI.Adapters >> BaseControlAdapter >> RenderAttributes(HtmlTextWriter)
Renders control attributes.
Declaration Syntax
C#
protected virtual void RenderAttributes(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The text writer.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HtmlLinkControlAdapter Class

HtmlLinkControlAdapter Class
Namespaces >> MSS.Web.UI.Adapters >> HtmlLinkControlAdapter
HtmlLink control adapter.
Declaration Syntax
C#
public class HtmlLinkControlAdapter : BaseControlAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlLinkControlAdapterHtmlLinkControlAdapterNew()() |
 | BeginRender(HtmlTextWriter) | Called prior to the rendering of a control. In a derived adapter class, generates opening tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Browser | Gets a reference to the browser capabilities of the client making the current HTTP request. (Inherited from ControlAdapter.)
 | Control | Gets a reference to the control to which this control adapter is attached. (Inherited from ControlAdapter.)
 | CreateChildControls()() | Creates the target-specific child controls for a composite control. (Inherited from ControlAdapter.)
 | EndRender(HtmlTextWriter) | Called after the rendering of a control. In a derived adapter class, generates closing tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAdapterControlState(Object) | Loads adapter control state information that was saved by SaveAdapterControlState()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | LoadAdapterViewState(Object) | Loads adapter view state information that was saved by SaveAdapterViewState()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnInit(EventArgs) | Overrides the OnInit(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnLoad(EventArgs) | Overrides the OnLoad(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnPreRender(EventArgs) | Overrides the OnPreRender(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnUnload(EventArgs) | Overrides the OnUnload(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | Page | Gets a reference to the page where the control associated with this adapter resides. (Inherited from ControlAdapter.)
 | PageAdapter | Gets a reference to the page adapter for the page where the associated control resides. (Inherited from ControlAdapter.)
 | Render(HtmlTextWriter) | (Overrides ControlAdapter.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | Renders control attributes. (Overrides BaseControlAdapter.RenderAttributes(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | Generates the target-specific markup for the child controls in a composite control to which the control adapter is attached. (Inherited from ControlAdapter.)
 | SaveAdapterControlState()() | Saves control state information for the control adapter. (Inherited from ControlAdapter.)
 | SaveAdapterViewState()() | Saves view state information for the control adapter. (Inherited from ControlAdapter.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlAdapter
 |  | BaseControlAdapter
 |  |  | HtmlLinkControlAdapter

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HtmlLinkControlAdapter Constructor

HtmlLinkControlAdapter Constructor
Namespaces >> MSS.Web.UI.Adapters >> HtmlLinkControlAdapter >> HtmlLinkControlAdapterHtmlLinkControlAdapterNew()()
Declaration Syntax
C#
public HtmlLinkControlAdapter()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.Adapters >> HtmlLinkControlAdapter >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderAttributes Method (writer)

RenderAttributes Method (writer)
Namespaces >> MSS.Web.UI.Adapters >> HtmlLinkControlAdapter >> RenderAttributes(HtmlTextWriter)
Renders control attributes.
Declaration Syntax
C#
protected override void RenderAttributes(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The text writer.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HtmlMetaControlAdapter Class

HtmlMetaControlAdapter Class
Namespaces >> MSS.Web.UI.Adapters >> HtmlMetaControlAdapter
Renders HtmlMetaControl without close tag.
Declaration Syntax
C#
public class HtmlMetaControlAdapter : BaseControlAdapter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlMetaControlAdapterHtmlMetaControlAdapterNew()() |
 | BeginRender(HtmlTextWriter) | Called prior to the rendering of a control. In a derived adapter class, generates opening tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Browser | Gets a reference to the browser capabilities of the client making the current HTTP request. (Inherited from ControlAdapter.)
 | Control | Gets a reference to the control to which this control adapter is attached. (Inherited from ControlAdapter.)
 | CreateChildControls()() | Creates the target-specific child controls for a composite control. (Inherited from ControlAdapter.)
 | EndRender(HtmlTextWriter) | Called after the rendering of a control. In a derived adapter class, generates closing tags that are required by a specific target but not needed by HTML browsers. (Inherited from ControlAdapter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAdapterControlState(Object) | Loads adapter control state information that was saved by SaveAdapterControlState()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | LoadAdapterViewState(Object) | Loads adapter view state information that was saved by SaveAdapterViewState()() during a previous request to the page where the control associated with this control adapter resides. (Inherited from ControlAdapter.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnInit(EventArgs) | Overrides the OnInit(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnLoad(EventArgs) | Overrides the OnLoad(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnPreRender(EventArgs) | Overrides the OnPreRender(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | OnUnload(EventArgs) | Overrides the OnUnload(EventArgs) method for the associated control. (Inherited from ControlAdapter.)
 | Page | Gets a reference to the page where the control associated with this adapter resides. (Inherited from ControlAdapter.)
 | PageAdapter | Gets a reference to the page adapter for the page where the associated control resides. (Inherited from ControlAdapter.)
 | Render(HtmlTextWriter) | (Overrides ControlAdapter.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | Renders control attributes. (Inherited from BaseControlAdapter.)
 | RenderChildren(HtmlTextWriter) | Generates the target-specific markup for the child controls in a composite control to which the control adapter is attached. (Inherited from ControlAdapter.)
 | SaveAdapterControlState()() | Saves control state information for the control adapter. (Inherited from ControlAdapter.)
 | SaveAdapterViewState()() | Saves view state information for the control adapter. (Inherited from ControlAdapter.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlAdapter
 |  | BaseControlAdapter
 |  |  | HtmlMetaControlAdapter

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HtmlMetaControlAdapter Constructor

HtmlMetaControlAdapter Constructor
Namespaces >> MSS.Web.UI.Adapters >> HtmlMetaControlAdapter >> HtmlMetaControlAdapterHtmlMetaControlAdapterNew()()
Declaration Syntax
C#
public HtmlMetaControlAdapter()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.Adapters >> HtmlMetaControlAdapter >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.Web.UI.Pages Namespace

MSS.Web.UI.Pages Namespace
Namespaces >> MSS.Web.UI.Pages
Declaration Syntax
C#
namespace MSS.Web.UI.Pages
Types
All Types Classes
Icon | Type | Description
 | EmptyLayout | Empty layout which contains one placeholder with the "content" key.
 | MSSPage | MSS page.
 | ResponseFilter | Http response filter. Filters character for the html 4.0 compatibility.
 | SitePage | Site page.
 | WelcomeControl | Render the welcome text on the start page.


EmptyLayout Class

EmptyLayout Class
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout
Empty layout which contains one placeholder with the "content" key.
Declaration Syntax
C#
[HidePageExtendersAttribute]
public class EmptyLayout : MSSPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmptyLayoutEmptyLayoutNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control. (Inherited from MSSPage.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Inherited from MSSPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer. (Inherited from MSSPage.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet. (Inherited from MSSPage.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script. (Inherited from MSSPage.)
 | RegisterScriptBlock(String, String) | Registers the script block. (Inherited from MSSPage.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings. (Inherited from MSSPage.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | EmptyLayout

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


EmptyLayout Constructor

EmptyLayout Constructor
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> EmptyLayoutEmptyLayoutNew()()
Declaration Syntax
C#
public EmptyLayout()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSSPage Class

MSSPage Class
Namespaces >> MSS.Web.UI.Pages >> MSSPage
MSS page.
Declaration Syntax
C#
public class MSSPage : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSSPageMSSPageNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control.
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer.
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet.
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script.
 | RegisterScriptBlock(String, String) | Registers the script block.
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | SitePage
 |  |  |  |  | EmptyLayout
 |  |  |  |  | WizardPage

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSSPage Constructor

MSSPage Constructor
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> MSSPageMSSPageNew()()
Declaration Syntax
C#
public MSSPage()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindFormControl Method (control)

FindFormControl Method (control)
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> FindFormControl(Control)
Finds the form control.
Declaration Syntax
C#
protected HtmlForm FindFormControl(
    Control control
)
Parameters
control (Control)
The control.
Return Value

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PrintOnLoad Method

PrintOnLoad Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> PrintOnLoad()()
Add javascript to the page which will send page to printer.
Declaration Syntax
C#
public virtual void PrintOnLoad()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RegisterCSSStylesheet Method (CSSRelativePath)

RegisterCSSStylesheet Method (CSSRelativePath)
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> RegisterCSSStylesheet(String)
Registers a stylesheet.
Declaration Syntax
C#
public virtual void RegisterCSSStylesheet(
    string CSSRelativePath
)
Parameters
CSSRelativePath (String)
The CSS relative path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RegisterScript Method (name, src)

RegisterScript Method (name, src)
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> RegisterScript(String, String)
Registers the script.
Declaration Syntax
C#
public virtual void RegisterScript(
    string name,
    string src
)
Parameters
name (String)
The name.
src (String)
The source.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RegisterScriptBlock Method (name, text)

RegisterScriptBlock Method (name, text)
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> RegisterScriptBlock(String, String)
Registers the script block.
Declaration Syntax
C#
public virtual void RegisterScriptBlock(
    string name,
    string text
)
Parameters
name (String)
The name.
text (String)
The text.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Settings Property

Settings Property
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> Settings
Gets the site settings.
Declaration Syntax
C#
public SettingsCollection Settings{ get;}
Value
The settings.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ResponseFilter Class

ResponseFilter Class
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter
Http response filter. Filters character for the html 4.0 compatibility.
Declaration Syntax
C#
public class ResponseFilter : Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResponseFilterResponseFilterNew(Stream) |
 | BeginRead(array<Byte>[](), Int32, Int32, AsyncCallback, Object) | Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[](), Int32, Int32, AsyncCallback, Object) | Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | (Overrides Stream.CanRead.)
 | CanSeek | (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | (Overrides Stream.CanWrite.)
 | Close()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()() | (Overrides Stream.Flush()().)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLifetimeService()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | Position | (Overrides Stream.Position.)
 | Read(array<Byte>[](), Int32, Int32) | (Overrides Stream.Read(array<Byte>[](), Int32, Int32).)
 | ReadByte()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | (Overrides Stream.SetLength(Int64).)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WrapCharacters(String) |
 | Write(array<Byte>[](), Int32, Int32) | (Overrides Stream.Write(array<Byte>[](), Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | ResponseFilter

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ResponseFilter Constructor (stream)

ResponseFilter Constructor (stream)
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> ResponseFilterResponseFilterNew(Stream)
Declaration Syntax
C#
public ResponseFilter(
    Stream stream
)
Parameters
stream (Stream)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CanRead Property

CanRead Property
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> CanRead
Declaration Syntax
C#
public override bool CanRead{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CanSeek Property

CanSeek Property
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> CanSeek
Declaration Syntax
C#
public override bool CanSeek{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CanWrite Property

CanWrite Property
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> CanWrite
Declaration Syntax
C#
public override bool CanWrite{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Flush Method

Flush Method
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> Flush()()
Declaration Syntax
C#
public override void Flush()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Length Property

Length Property
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> Length
Declaration Syntax
C#
public override long Length{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Position Property

Position Property
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> Position
Declaration Syntax
C#
public override long Position{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> Read(array<Byte>[](), Int32, Int32)
Declaration Syntax
C#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Parameters
buffer (array< Byte >[]())
offset (Int32)
count (Int32)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Seek Method (offset, origin)

Seek Method (offset, origin)
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> Seek(Int64, SeekOrigin)
Declaration Syntax
C#
public override long Seek(
    long offset,
    SeekOrigin origin
)
Parameters
offset (Int64)
origin (SeekOrigin)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetLength Method (value)

SetLength Method (value)
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> SetLength(Int64)
Declaration Syntax
C#
public override void SetLength(
    long value
)
Parameters
value (Int64)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WrapCharacters Method (html)

WrapCharacters Method (html)
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> WrapCharacters(String)
Declaration Syntax
C#
protected string WrapCharacters(
    string html
)
Parameters
html (String)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> Write(array<Byte>[](), Int32, Int32)
Declaration Syntax
C#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Parameters
buffer (array< Byte >[]())
offset (Int32)
count (Int32)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SitePage Class

SitePage Class
Namespaces >> MSS.Web.UI.Pages >> SitePage
Site page.
Declaration Syntax
C#
public class SitePage : MSSPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SitePageSitePageNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddDropDownMenu()() | Adds the drop down menu to the page.
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control. (Inherited from MSSPage.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Inherited from MSSPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer. (Inherited from MSSPage.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet. (Inherited from MSSPage.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script. (Inherited from MSSPage.)
 | RegisterScriptBlock(String, String) | Registers the script block. (Inherited from MSSPage.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings. (Inherited from MSSPage.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | SitePage

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SitePage Constructor

SitePage Constructor
Namespaces >> MSS.Web.UI.Pages >> SitePage >> SitePageSitePageNew()()
Declaration Syntax
C#
public SitePage()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddDropDownMenu Method

AddDropDownMenu Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> AddDropDownMenu()()
Adds the drop down menu to the page.
Declaration Syntax
C#
protected virtual void AddDropDownMenu()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Web.UI.Pages >> SitePage >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Web.UI.Pages >> SitePage >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WelcomeControl Class

WelcomeControl Class
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl
Render the welcome text on the start page.
Declaration Syntax
C#
public class WelcomeControl : SiteControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WelcomeControlWelcomeControlNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | WelcomeControl

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WelcomeControl Constructor

WelcomeControl Constructor
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> WelcomeControlWelcomeControlNew()()
Declaration Syntax
C#
public WelcomeControl()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.Web.UI.Pages.Shell Namespace

MSS.Web.UI.Pages.Shell Namespace
Namespaces >> MSS.Web.UI.Pages.Shell
Declaration Syntax
C#
namespace MSS.Web.UI.Pages.Shell
Types
All Types Classes
Icon | Type | Description
 | LoginAndRedirect | Logs the user in and returns to the "returnPath" page.


LoginAndRedirect Class

LoginAndRedirect Class
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect
Logs the user in and returns to the "returnPath" page.
Declaration Syntax
C#
public class LoginAndRedirect : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginAndRedirectLoginAndRedirectNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 |
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | LoginAndRedirect

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoginAndRedirect Constructor

LoginAndRedirect Constructor
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> LoginAndRedirectLoginAndRedirectNew()()
Declaration Syntax
C#
public LoginAndRedirect()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


form1 Field

form1 Field
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> form1
Declaration Syntax
C#
protected HtmlForm form1

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.Web.UI.UserControls Namespace

MSS.Web.UI.UserControls Namespace
Namespaces >> MSS.Web.UI.UserControls
Declaration Syntax
C#
namespace MSS.Web.UI.UserControls
Types
All Types Classes
Icon | Type | Description
 | DocumentList | DocumentList class.
 | FunctionBar | Site function bar.
 | MainMenu | Site's main menu.
 | Modules | Modules class. Adds modules to the page.
 | Reorganize | Opens reorganize application.
 | SiteControl | MSS site control.
 | SubMenu | Displays sub menu on the page.


DocumentList Class

DocumentList Class
Namespaces >> MSS.Web.UI.UserControls >> DocumentList
DocumentList class.
Declaration Syntax
C#
public class DocumentList : SiteControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentListDocumentListNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | DocumentList

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DocumentList Constructor

DocumentList Constructor
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> DocumentListDocumentListNew()()
Declaration Syntax
C#
public DocumentList()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FunctionBar Class

FunctionBar Class
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar
Site function bar.
Declaration Syntax
C#
public class FunctionBar : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FunctionBarFunctionBarNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | functionBar |
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | FunctionBar

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FunctionBar Constructor

FunctionBar Constructor
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> FunctionBarFunctionBarNew()()
Declaration Syntax
C#
public FunctionBar()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


functionBar Field

functionBar Field
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> functionBar
Declaration Syntax
C#
protected XslFile functionBar

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MainMenu Class

MainMenu Class
Namespaces >> MSS.Web.UI.UserControls >> MainMenu
Site's main menu.
Declaration Syntax
C#
public class MainMenu : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MainMenuMainMenuNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | xslMainMenu |
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | MainMenu

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MainMenu Constructor

MainMenu Constructor
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> MainMenuMainMenuNew()()
Declaration Syntax
C#
public MainMenu()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


xslMainMenu Field

xslMainMenu Field
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> xslMainMenu
Declaration Syntax
C#
protected XslFile xslMainMenu

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Modules Class

Modules Class
Namespaces >> MSS.Web.UI.UserControls >> Modules
Modules class.
Adds modules to the page.
Declaration Syntax
C#
public class Modules : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModulesModulesNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | FunctionSelector1 | FunctionSelector1 control.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | Modules

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Modules Constructor

Modules Constructor
Namespaces >> MSS.Web.UI.UserControls >> Modules >> ModulesModulesNew()()
Declaration Syntax
C#
public Modules()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FunctionSelector1 Field

FunctionSelector1 Field
Namespaces >> MSS.Web.UI.UserControls >> Modules >> FunctionSelector1
FunctionSelector1 control.
Declaration Syntax
C#
protected FunctionSelector FunctionSelector1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.UserControls >> Modules >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Reorganize Class

Reorganize Class
Namespaces >> MSS.Web.UI.UserControls >> Reorganize
Opens reorganize application.
Declaration Syntax
C#
public class Reorganize : UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReorganizeReorganizeNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | Reorganize

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Reorganize Constructor

Reorganize Constructor
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> ReorganizeReorganizeNew()()
Declaration Syntax
C#
public Reorganize()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SiteControl Class

SiteControl Class
Namespaces >> MSS.Web.UI.UserControls >> SiteControl
MSS site control.
Declaration Syntax
C#
public class SiteControl : UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteControlSiteControlNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage.
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ModuleControl
 |  |  |  |  | Picture
 |  |  |  |  | SubMenu
 |  |  |  |  | MainMenu
 |  |  |  |  | FunctionBar
 |  |  |  |  | Modules
 |  |  |  |  | DocumentList
 |  |  |  |  | WelcomeControl
 |  |  |  |  | SearchResultForm
 |  |  |  |  | SiteMap
 |  |  |  |  | ContactForm
 |  |  |  |  | LoginSpot

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SiteControl Constructor

SiteControl Constructor
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> SiteControlSiteControlNew()()
Declaration Syntax
C#
public SiteControl()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SitePage Property

SitePage Property
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> SitePage
Gets the MSSPage.
Declaration Syntax
C#
public virtual MSSPage SitePage{ get;}
Value
The site page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SubMenu Class

SubMenu Class
Namespaces >> MSS.Web.UI.UserControls >> SubMenu
Displays sub menu on the page.
Declaration Syntax
C#
public class SubMenu : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubMenuSubMenuNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | xslSubMenu |
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | SubMenu

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SubMenu Constructor

SubMenu Constructor
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> SubMenuSubMenuNew()()
Declaration Syntax
C#
public SubMenu()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


xslSubMenu Field

xslSubMenu Field
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> xslSubMenu
Declaration Syntax
C#
protected XslFile xslSubMenu

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.Web.UI.WebControls Namespace

MSS.Web.UI.WebControls Namespace
Namespaces >> MSS.Web.UI.WebControls
Declaration Syntax
C#
namespace MSS.Web.UI.WebControls
Types
All Types Classes Delegates
Icon | Type | Description
 | Breadcrumb | Breadcrumb web control.
 | Button | Dictionary button. Gets the text, tool tip and access key from the dictionary.
 | CheckBox | Dictionary check box. Gets text, tool tip and access key from the dictionary.
 | CollapsePanel |
 | Flash | Displays flash video on the page.
 | Form | Dictionary form.
 | FunctionSelector | Adds modules to the page.
 | HyperLink | Dictionary hyper link web control.
 | Image | Renders image.
 | ImageButton | Dictionary image button. Gets tool tip, access key and tab index from the dictionary.
 | ItemNameValidator | Checks text for right item name
 | Label | Dictionary label. Gets text, tool tip and access key from the dictionary.
 | Link | Dictionary link. Gets the text, the tool tip and the access key from the dictionary.
 | MediaControlsFactory | Media control factory.
 | MediaItem | Media item. Creates media object by source extension and renders it.
 | MediaObject | Base class for the media objects.
 | MultiMediaObject | Base class from the multimedia objects.
 | NoLicense |
 | Quicktime | Displays quick time video on the page.
 | RadioButton | Radio button with mss dictionary functionality.
 | RealPlayer | Display "ra", "ram", "rpm" files on the page.
 | RegularExpressionValidator | Dictionary regular expression validater. Gets the error message, text, tool tip, access key and tab index from the dictionary.
 | MultiMediaObject..::RenderNestedElementDelegate |
 | RenderSpotsControl | Renders spot controls
 | RequiredFieldValidator | Dictionary required field validater.
 | TextBox | Dictionary text box with additional functionality.
 | WindowsMediaPlayer | Displays "wma", "wmv", "avi", "mpeg" files on the page.


Breadcrumb Class

Breadcrumb Class
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb
Breadcrumb web control.
Declaration Syntax
C#
public class Breadcrumb : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BreadcrumbBreadcrumbNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CurrentItem | Gets the current item.
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item | Gets or sets the item id or item path.
 | LastElementLink | Gets or sets a value indicating whether render last element in breadcrumb as link.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MaxSymbolsCount | Gets or sets a max count of symbols to display in control. If count of symbols more than this parameter the shorting Breadcrumb will be displayed.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | Separator | Gets or sets the separator.
 | SeparatorType | Gets or sets the type of the separator. "Left" - render separator on the left site, "right" - render separator on right site of text.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | ShorteningText | Gets or sets the shotering text.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | Templates | Gets or sets the templates. Only items with these templates will be rendered.
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Breadcrumb

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Breadcrumb Constructor

Breadcrumb Constructor
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> BreadcrumbBreadcrumbNew()()
Declaration Syntax
C#
public Breadcrumb()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CurrentItem Property

CurrentItem Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> CurrentItem
Gets the current item.
Declaration Syntax
C#
public Item CurrentItem{ get;}
Value
The current item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Item Property

Item Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> Item
Gets or sets the item id or item path.
Declaration Syntax
C#
public string Item{ get; set;}
Value
The item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LastElementLink Property

LastElementLink Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> LastElementLink
Gets or sets a value indicating whether render last element in breadcrumb as link.
Declaration Syntax
C#
public bool LastElementLink{ get; set;}
Value
True if render last element as link otherwise, false.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MaxSymbolsCount Property

MaxSymbolsCount Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> MaxSymbolsCount
Gets or sets a max count of symbols to display in control. If count of symbols more than this parameter the shorting Breadcrumb will be displayed.
Declaration Syntax
C#
public int MaxSymbolsCount{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Separator Property

Separator Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> Separator
Gets or sets the separator.
Declaration Syntax
C#
public string Separator{ get; set;}
Value
The separator.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SeparatorType Property

SeparatorType Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> SeparatorType
Gets or sets the type of the separator. "Left" - render separator on the left site, "right" - render separator on right site of text.
Declaration Syntax
C#
public string SeparatorType{ get; set;}
Value
The type of separator.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShorteningText Property

ShorteningText Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> ShorteningText
Gets or sets the shotering text.
Declaration Syntax
C#
public string ShorteningText{ get; set;}
Value
The shotering text.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Templates Property

Templates Property
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> Templates
Gets or sets the templates. Only items with these templates will be rendered.
Declaration Syntax
C#
public string Templates{ get; set;}
Value
The templates.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Button Class

Button Class
Namespaces >> MSS.Web.UI.WebControls >> Button
Dictionary button. Gets the text, tool tip and access key from the dictionary.
Declaration Syntax
C#
public class Button : Button
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ButtonButtonNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the attributes of the Button control to the output stream for rendering on the client. (Inherited from Button.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether validation is performed when the Button control is clicked. (Inherited from Button.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Occurs when the Button control is clicked. (Inherited from Button.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Occurs when the Button control is clicked. (Inherited from Button.)
 | CommandArgument | Gets or sets an optional parameter passed to the Command event along with the associated CommandName. (Inherited from Button.)
 | CommandName | Gets or sets the command name associated with the Button control that is passed to the Command event. (Inherited from Button.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Formname | Gets or sets the form name.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPostBackOptions()() | Creates a PostBackOptions object that represents the Button control's postback behavior. (Inherited from Button.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event of the Button control. (Inherited from Button.)
 | OnClientClick | Gets or sets the client-side script that executes when a Button control's Click event is raised. (Inherited from Button.)
 | OnCommand(CommandEventArgs) | Raises the Command event of the Button control. (Inherited from Button.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides Button.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PostBackUrl | Gets or sets the URL of the page to post to from the current page when the Button control is clicked. (Inherited from Button.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(String) | Raises events for the Button control when it posts back to the server. (Inherited from Button.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. (Inherited from Button.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IPostBackEventHandler..::RaisePostBackEvent(String) | (Inherited from Button.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text caption displayed in the Button control. (Inherited from Button.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UseSubmitBehavior | Gets or sets a value indicating whether the Button control uses the client browser's submit mechanism or the ASP.NET postback mechanism. (Inherited from Button.)
 | ValidationGroup | Gets or sets the group of controls for which the Button control causes validation when it posts back to the server. (Inherited from Button.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Button
 |  |  |  | Button

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Button Constructor

Button Constructor
Namespaces >> MSS.Web.UI.WebControls >> Button >> ButtonButtonNew()()
Declaration Syntax
C#
public Button()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> Button >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> Button >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Formname Property

Formname Property
Namespaces >> MSS.Web.UI.WebControls >> Button >> Formname
Gets or sets the form name.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Formname{ get; set;}
Value
The form name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> Button >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> Button >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Button >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CheckBox Class

CheckBox Class
Namespaces >> MSS.Web.UI.WebControls >> CheckBox
Dictionary check box. Gets text, tool tip and access key from the dictionary.
Declaration Syntax
C#
public class CheckBox : CheckBox
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckBoxCheckBoxNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the HTML attributes and styles of a CheckBox control to be rendered to the specified output stream. (Inherited from CheckBox.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoPostBack | Gets or sets a value indicating whether the CheckBox state automatically posts back to the server when clicked. (Inherited from CheckBox.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether validation is performed when the CheckBox control is clicked. (Inherited from CheckBox.)
 | Checked | Gets or sets a value indicating whether the CheckBox control is checked. (Inherited from CheckBox.)
 | CheckedChanged | Occurs when the value of the Checked property changes between posts to the server. (Inherited from CheckBox.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Formname | Gets or sets the formname.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InputAttributes | Gets a reference to the collection of attributes for the rendered input element of the CheckBox control. (Inherited from CheckBox.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LabelAttributes | Gets a reference to the collection of attributes for the rendered LABEL element of the CheckBox control. (Inherited from CheckBox.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | Processes the postback data for the CheckBox control. (Inherited from CheckBox.)
 | LoadViewState(Object) | Loads the previously saved view state of the CheckBox control. (Inherited from CheckBox.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCheckedChanged(EventArgs) | Raises the CheckedChanged event of the CheckBox control. This allows you to handle the event directly. (Inherited from CheckBox.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides CheckBox.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | Invokes the OnCheckedChanged(EventArgs) method when the posted data for the CheckBox control has changed. (Inherited from CheckBox.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides CheckBox.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves the changes to the CheckBox view state since the time the page was posted back to the server. (Inherited from CheckBox.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IPostBackDataHandler..::LoadPostData(String, NameValueCollection) | (Inherited from CheckBox.)
 | IPostBackDataHandler..::RaisePostDataChangedEvent()() | (Inherited from CheckBox.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text label associated with the CheckBox. (Inherited from CheckBox.)
 | TextAlign | Gets or sets the alignment of the text label associated with the CheckBox control. (Inherited from CheckBox.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Tracks view-state changes to the CheckBox control so that they can be stored in the control's StateBag object. This object is accessible through the ViewState property. (Inherited from CheckBox.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationGroup | Gets or sets the group of controls for which the CheckBox control causes validation when it posts back to the server. (Inherited from CheckBox.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CheckBox
 |  |  |  | CheckBox

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CheckBox Constructor

CheckBox Constructor
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> CheckBoxCheckBoxNew()()
Declaration Syntax
C#
public CheckBox()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Formname Property

Formname Property
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> Formname
Gets or sets the formname.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Formname{ get; set;}
Value
The formname.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CollapsePanel Class

CollapsePanel Class
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel
Declaration Syntax
C#
public class CollapsePanel : GridPanel
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CollapsePanelCollapsePanelNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | CellPadding()() | (Inherited from GridPanel.)
 | CellSpacing()() | (Inherited from GridPanel.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapsed |
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Columns()() | (Inherited from GridPanel.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides GridPanel.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Fixed()() | (Inherited from GridPanel.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | HeaderText |
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon |
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown()() | (Inherited from GridPanel.)
 | KeyFilter()() | (Inherited from GridPanel.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderCssLink(HtmlTextWriter) |
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | GridPanel
 |  |  |  |  | CollapsePanel

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CollapsePanel Constructor

CollapsePanel Constructor
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> CollapsePanelCollapsePanelNew()()
Declaration Syntax
C#
public CollapsePanel()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Collapsed Property

Collapsed Property
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> Collapsed
Declaration Syntax
C#
public bool Collapsed{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DoRender Method (writer)

DoRender Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HeaderText Property

HeaderText Property
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> HeaderText
Declaration Syntax
C#
public string HeaderText{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Icon Property

Icon Property
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> Icon
Declaration Syntax
C#
public string Icon{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderCssLink Method (writer)

RenderCssLink Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> RenderCssLink(HtmlTextWriter)
Declaration Syntax
C#
protected virtual void RenderCssLink(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Flash Class

Flash Class
Namespaces >> MSS.Web.UI.WebControls >> Flash
Displays flash video on the page.
Declaration Syntax
C#
public class Flash : MultiMediaObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlashFlashNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) | (Inherited from MediaObject.)
 | AddAttribute(HtmlTextWriter, String, String, Boolean) | (Inherited from MediaObject.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddObjectAttribute(String, String) | Adds the object attributes. (Inherited from MultiMediaObject.)
 | AddObjectParameter(String, String) | Adds the object parameters. (Inherited from MultiMediaObject.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddStandardAttributes()() | Adds the standard attributes. (Inherited from MultiMediaObject.)
 | alt | (Inherited from MediaObject.)
 | Alt | Gets or sets the alt text. (Inherited from MediaObject.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the error message. (Inherited from MultiMediaObject.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetFullUrl(String) | Gets the full URL. (Inherited from MultiMediaObject.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | height | (Inherited from MediaObject.)
 | Height | Gets or sets the height of the Web server control. (Inherited from MediaObject.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | RemoveObjectAttribute(String) | Removes the object attribute. (Inherited from MultiMediaObject.)
 | RemoveObjectParameter(String) | Removes the object parameter. (Inherited from MultiMediaObject.)
 | Render(HtmlTextWriter) | (Overrides MultiMediaObject.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderNestetObjects(HtmlTextWriter) | Renders the nestet objects. (Inherited from MultiMediaObject.)
 | RenderObject(HtmlTextWriter) | (Inherited from MultiMediaObject.)
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) | (Inherited from MultiMediaObject.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | src | (Inherited from MediaObject.)
 | Src | Gets or sets the location of an image. (Inherited from MediaObject.)
 | srcParamName | (Inherited from MultiMediaObject.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | width | (Inherited from MediaObject.)
 | Width | Gets or sets the width of the Web server control. (Inherited from MediaObject.)
 | WriteObjectAttributes(HtmlTextWriter) | Writes the object attributes. (Inherited from MultiMediaObject.)
 | WriteObjectParametrs(HtmlTextWriter) | Writes the object parametres. (Inherited from MultiMediaObject.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | MediaObject
 |  |  |  | MultiMediaObject
 |  |  |  |  | Flash

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Flash Constructor

Flash Constructor
Namespaces >> MSS.Web.UI.WebControls >> Flash >> FlashFlashNew()()
Declaration Syntax
C#
public Flash()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Flash >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Form Class

Form Class
Namespaces >> MSS.Web.UI.WebControls >> Form
Dictionary form.
Declaration Syntax
C#
public class Form : Panel
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormFormNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds information about the background image, alignment, wrap, and direction to the list of attributes to render. (Inherited from Panel.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BackImageUrl | Gets or sets the URL of the background image for the panel control. (Inherited from Panel.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates a style object that is used internally by the Panel control to implement all style related properties. (Inherited from Panel.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DefaultButton | Gets or sets the identifier for the default button that is contained in the Panel control. (Inherited from Panel.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Direction | Gets or sets the direction in which to display controls that include text in a Panel control. (Inherited from Panel.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | FormName | Gets or sets the name of the form.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupingText | Gets or sets the caption for the group of controls that is contained in the panel control. (Inherited from Panel.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | HorizontalAlign | Gets or sets the horizontal alignment of the contents within the panel. (Inherited from Panel.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | (Overrides WebControl.LoadViewState(Object).)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the Panel control to the specified writer. (Inherited from Panel.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the Panel control into the specified writer. (Inherited from Panel.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ScrollBars | Gets or sets the visibility and position of scroll bars in a Panel control. (Inherited from Panel.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Wrap | Gets or sets a value indicating whether the content wraps within the panel. (Inherited from Panel.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Panel
 |  |  |  | Form

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Form Constructor

Form Constructor
Namespaces >> MSS.Web.UI.WebControls >> Form >> FormFormNew()()
Declaration Syntax
C#
public Form()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> Form >> FormName
Gets or sets the name of the form.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadViewState Method (savedState)

LoadViewState Method (savedState)
Namespaces >> MSS.Web.UI.WebControls >> Form >> LoadViewState(Object)
Declaration Syntax
C#
protected override void LoadViewState(
    Object savedState
)
Parameters
savedState (Object)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FunctionSelector Class

FunctionSelector Class
Namespaces >> MSS.Web.UI.WebControls >> FunctionSelector
Adds modules to the page.
Declaration Syntax
C#
public class FunctionSelector : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FunctionSelectorFunctionSelectorNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | FunctionSelector

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FunctionSelector Constructor

FunctionSelector Constructor
Namespaces >> MSS.Web.UI.WebControls >> FunctionSelector >> FunctionSelectorFunctionSelectorNew()()
Declaration Syntax
C#
public FunctionSelector()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Web.UI.WebControls >> FunctionSelector >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> FunctionSelector >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HyperLink Class

HyperLink Class
Namespaces >> MSS.Web.UI.WebControls >> HyperLink
Dictionary hyper link web control.
Declaration Syntax
C#
public class HyperLink : HyperLink
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HyperLinkHyperLinkNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the attributes of a HyperLink control to the output stream for rendering. (Inherited from HyperLink.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the control that an element was parsed, and adds the element to the HyperLink control. (Inherited from HyperLink.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | FormName | Gets or sets the name of the form.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | ImageUrl | Gets or sets the path to an image to display for the HyperLink control. (Inherited from HyperLink.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from HyperLink.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NavigateUrl | Gets or sets the URL to link to when the HyperLink control is clicked. (Inherited from HyperLink.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Displays the HyperLink control on a page. (Inherited from HyperLink.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | Target | Gets or sets the target window or frame in which to display the Web page content linked to when the HyperLink control is clicked. (Inherited from HyperLink.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text caption for the HyperLink control. (Inherited from HyperLink.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | HyperLink
 |  |  |  | HyperLink

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HyperLink Constructor

HyperLink Constructor
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> HyperLinkHyperLinkNew()()
Declaration Syntax
C#
public HyperLink()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> FormName
Gets or sets the name of the form.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Image Class

Image Class
Namespaces >> MSS.Web.UI.WebControls >> Image
Renders image.
Declaration Syntax
C#
public class Image : MediaObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageImageNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) | (Inherited from MediaObject.)
 | AddAttribute(HtmlTextWriter, String, String, Boolean) | (Inherited from MediaObject.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | alt | (Inherited from MediaObject.)
 | Alt | Gets or sets the alt text. (Inherited from MediaObject.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | height | (Inherited from MediaObject.)
 | Height | Gets or sets the height of the Web server control. (Inherited from MediaObject.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | src | (Inherited from MediaObject.)
 | Src | Gets or sets the location of an image. (Inherited from MediaObject.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | width | (Inherited from MediaObject.)
 | Width | Gets or sets the width of the Web server control. (Inherited from MediaObject.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | MediaObject
 |  |  |  | Image

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Image Constructor

Image Constructor
Namespaces >> MSS.Web.UI.WebControls >> Image >> ImageImageNew()()
Declaration Syntax
C#
public Image()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Image >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ImageButton Class

ImageButton Class
Namespaces >> MSS.Web.UI.WebControls >> ImageButton
Dictionary image button. Gets tool tip, access key and tab index from the dictionary.
Declaration Syntax
C#
public class ImageButton : ImageButton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageButtonImageButtonNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the attributes of an ImageButton to the output stream for rendering on the client. (Inherited from ImageButton.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AlternateText | Gets or sets the alternate text displayed in the Image control when the image is unavailable. Browsers that support the ToolTips feature display this text as a ToolTip. (Inherited from Image.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether validation is performed when the ImageButton control is clicked. (Inherited from ImageButton.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Occurs when the ImageButton is clicked. (Inherited from ImageButton.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Occurs when the ImageButton is clicked. (Inherited from ImageButton.)
 | CommandArgument | Gets or sets an optional argument that provides additional information about the CommandName property. (Inherited from ImageButton.)
 | CommandName | Gets or sets the command name associated with the ImageButton control. (Inherited from ImageButton.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DescriptionUrl | Gets or sets the location to a detailed description for the image. (Inherited from Image.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the ImageButton can be clicked to perform a post back to the server. (Inherited from ImageButton.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties for the text associated with the control. (Inherited from Image.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | FormName | Gets or sets the name of the form.
 | GenerateEmptyAlternateText | Gets or sets a value indicating whether the control generates an alternate-text attribute for an empty string value. (Inherited from ImageButton.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPostBackOptions()() | Creates a PostBackOptions object that represents the ImageButton control's postback behavior. (Inherited from ImageButton.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | ImageAlign | Gets or sets the alignment of the Image control in relation to other elements on the Web page. (Inherited from Image.)
 | ImageUrl | Gets or sets the location of an image to display in the Image control. (Inherited from Image.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | Processes posted data for the ImageButton control. (Inherited from ImageButton.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick(ImageClickEventArgs) | Raises the Click event and allows you to handle the Click event directly. (Inherited from ImageButton.)
 | OnClientClick | Gets or sets the client-side script that executes when an ImageButton control's Click event is raised. (Inherited from ImageButton.)
 | OnCommand(CommandEventArgs) | Raises the Command event and allows you to handle the Command event directly. (Inherited from ImageButton.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Determines whether the image has been clicked prior to rendering on the client. (Inherited from ImageButton.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PostBackUrl | Gets or sets the URL of the page to post to from the current page when the ImageButton control is clicked. (Inherited from ImageButton.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(String) | Raises events for the ImageButton control when it posts back to the server. (Inherited from ImageButton.)
 | RaisePostDataChangedEvent()() | Notifies the ASP.NET application that the state of the ImageButton control has changed. (Inherited from ImageButton.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the image control contents to the specified writer. (Inherited from Image.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IPostBackDataHandler..::LoadPostData(String, NameValueCollection) | (Inherited from ImageButton.)
 | IPostBackDataHandler..::RaisePostDataChangedEvent()() | (Inherited from ImageButton.)
 | IPostBackEventHandler..::RaisePostBackEvent(String) | (Inherited from ImageButton.)
 | System.Web.UI.WebControls.IButtonControl.Click | (Inherited from ImageButton.)
 | IButtonControl..::Text | (Inherited from ImageButton.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to the ImageButton control. (Inherited from ImageButton.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the value of the ImageButton control's AlternateText property. (Inherited from ImageButton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationGroup | Gets or sets the group of controls for which the ImageButton control causes validation when it posts back to the server. (Inherited from ImageButton.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Image
 |  |  |  | ImageButton
 |  |  |  |  | ImageButton

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ImageButton Constructor

ImageButton Constructor
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> ImageButtonImageButtonNew()()
Declaration Syntax
C#
public ImageButton()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> FormName
Gets or sets the name of the form.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ItemNameValidator Class

ItemNameValidator Class
Namespaces >> MSS.Web.UI.WebControls >> ItemNameValidator
Checks text for right item name
Declaration Syntax
C#
public class ItemNameValidator : RegularExpressionValidator
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemNameValidatorItemNameValidatorNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds to the specified HtmlTextWriter object the HTML attributes and styles that need to be rendered for the control. (Inherited from RegularExpressionValidator.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the control that an element was parsed and adds the element to the Label control. (Inherited from Label.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssociatedControlID | This property is not supported. (Inherited from BaseValidator.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CheckControlValidationProperty(String, String) | Verifies whether the specified control is on the page and contains validation properties. (Inherited from BaseValidator.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlPropertiesValid()() | Determines whether the control specified by the ControlToValidate property is a valid control. (Inherited from BaseValidator.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DetermineRenderUplevel()() | Determines whether the validation control can be rendered for a newer ("uplevel") browser. (Inherited from BaseValidator.)
 | DictionaryItem | Gets or sets the dictionary item. (Inherited from RegularExpressionValidator.)
 | DictionaryPath | Gets or sets the dictionary path. (Inherited from RegularExpressionValidator.)
 | Display | Gets or sets the display behavior of the error message in a validation control. (Inherited from BaseValidator.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableClientScript | Gets or sets a value indicating whether client-side validation is enabled. (Inherited from BaseValidator.)
 | Enabled | Gets or sets a value that indicates whether the validation control is enabled. (Inherited from BaseValidator.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the text for the error message displayed in a ValidationSummary control when validation fails. (Inherited from BaseValidator.)
 | EvaluateIsValid()() | (Overrides RegularExpressionValidator.EvaluateIsValid()().)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the color of the message displayed when validation fails. (Inherited from BaseValidator.)
 | FormName | Gets or sets the name of the form. (Inherited from RegularExpressionValidator.)
 | GetControlRenderID(String) | Gets the client ID of the specified control. (Inherited from BaseValidator.)
 | GetControlValidationValue(String) | Gets the value associated with the specified input control. (Inherited from BaseValidator.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language. (Inherited from RegularExpressionValidator.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Loads the previously saved state for the control. (Inherited from Label.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from BaseValidator.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from BaseValidator.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from BaseValidator.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertiesValid | Gets a value that indicates whether the control specified by the ControlToValidate property is a valid control. (Inherited from BaseValidator.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterValidatorCommonScript()() | Registers code on the page for client-side validation. (Inherited from BaseValidator.)
 | RegisterValidatorDeclaration()() | Registers an ECMAScript array declaration using the array name Page_Validators. (Inherited from BaseValidator.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Displays the control on the client. (Inherited from BaseValidator.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the Label into the specified writer. (Inherited from Label.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderUplevel | Gets a value that indicates whether the client's browser supports "uplevel" rendering. (Inherited from BaseValidator.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocusOnError | Gets or sets a value that indicates whether focus is set to the control specified by the ControlToValidate property when validation fails. (Inherited from BaseValidator.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HTML tag that is used to render the Label control. (Inherited from Label.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text displayed in the validation control when validation fails. (Inherited from BaseValidator.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Validate()() | Performs validation on the associated input control and updates the IsValid property. (Inherited from BaseValidator.)
 | ValidationExpression | Gets or sets the regular expression that determines the pattern used to validate a field. (Inherited from RegularExpressionValidator.)
 | ValidationGroup | Gets or sets the name of the validation group to which this validation control belongs. (Inherited from BaseValidator.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Label
 |  |  |  | BaseValidator
 |  |  |  |  | RegularExpressionValidator
 |  |  |  |  |  | RegularExpressionValidator
 |  |  |  |  |  |  | ItemNameValidator

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ItemNameValidator Constructor

ItemNameValidator Constructor
Namespaces >> MSS.Web.UI.WebControls >> ItemNameValidator >> ItemNameValidatorItemNameValidatorNew()()
Declaration Syntax
C#
public ItemNameValidator()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


EvaluateIsValid Method

EvaluateIsValid Method
Namespaces >> MSS.Web.UI.WebControls >> ItemNameValidator >> EvaluateIsValid()()
Declaration Syntax
C#
protected override bool EvaluateIsValid()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Label Class

Label Class
Namespaces >> MSS.Web.UI.WebControls >> Label
Dictionary label. Gets text, tool tip and access key from the dictionary.
Declaration Syntax
C#
public class Label : Label
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LabelLabelNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the HTML attributes and styles of a Label control to render to the specified output stream. (Inherited from Label.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the control that an element was parsed and adds the element to the Label control. (Inherited from Label.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssociatedControlID | Gets or sets the identifier for a server control that the Label control is associated with. (Inherited from Label.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem |
 | DictionaryPath | Path to the dictionary item.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | FormName | Name of the form
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Language of the dictionary item.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Loads the previously saved state for the control. (Inherited from Label.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the Label into the specified writer. (Inherited from Label.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HTML tag that is used to render the Label control. (Inherited from Label.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text content of the Label control. (Inherited from Label.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Label
 |  |  |  | Label

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Label Constructor

Label Constructor
Namespaces >> MSS.Web.UI.WebControls >> Label >> LabelLabelNew()()
Declaration Syntax
C#
public Label()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> Label >> DictionaryItem
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> Label >> DictionaryPath
Path to the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> Label >> FormName
Name of the form
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> Label >> Language
Language of the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> Label >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Label >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Link Class

Link Class
Namespaces >> MSS.Web.UI.WebControls >> Link
Dictionary link. Gets the text, the tool tip and the access key from the dictionary.
Declaration Syntax
C#
public class Link : LinkButton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkLinkNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the attributes of the LinkButton control to the output stream for rendering on the client. (Inherited from LinkButton.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the control that an element, either XML or HTML, was parsed, and adds the element to the control's ControlCollection object. (Inherited from LinkButton.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether validation is performed when the LinkButton control is clicked. (Inherited from LinkButton.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click | Occurs when the LinkButton control is clicked. (Inherited from LinkButton.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Command | Occurs when the LinkButton control is clicked. (Inherited from LinkButton.)
 | CommandArgument | Gets or sets an optional argument passed to the Command event handler along with the associated CommandName property. (Inherited from LinkButton.)
 | CommandName | Gets or sets the command name associated with the LinkButton control. This value is passed to the Command event handler along with the CommandArgument property. (Inherited from LinkButton.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | FormName | Gets or sets the name of the form.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPostBackOptions()() | Creates a PostBackOptions object that represents the LinkButton control's postback behavior. (Inherited from LinkButton.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | (Inherited from LinkButton.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event of the LinkButton control. (Inherited from LinkButton.)
 | OnClientClick | Gets or sets the client-side script that executes when a LinkButton control's Click event is raised (Inherited from LinkButton.)
 | OnCommand(CommandEventArgs) | Raises the Command event of the LinkButton control. (Inherited from LinkButton.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides LinkButton.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PostBackUrl | Gets or sets the URL of the page to post to from the current page when the LinkButton control is clicked. (Inherited from LinkButton.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(String) | Raises events for the LinkButton control when it posts back to the server. (Inherited from LinkButton.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. (Inherited from LinkButton.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IPostBackEventHandler..::RaisePostBackEvent(String) | (Inherited from LinkButton.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text caption displayed on the LinkButton control. (Inherited from LinkButton.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationGroup | Gets or sets the group of controls for which the LinkButton control causes validation when it posts back to the server. (Inherited from LinkButton.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | LinkButton
 |  |  |  | Link

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Link Constructor

Link Constructor
Namespaces >> MSS.Web.UI.WebControls >> Link >> LinkLinkNew()()
Declaration Syntax
C#
public Link()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> Link >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> Link >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> Link >> FormName
Gets or sets the name of the form.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> Link >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> Link >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Link >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MediaControlsFactory Class

MediaControlsFactory Class
Namespaces >> MSS.Web.UI.WebControls >> MediaControlsFactory
Media control factory.
Declaration Syntax
C#
public class MediaControlsFactory : Singleton<MediaControlsFactory>
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMediaObject(String, Boolean) | Gets the media object.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterControl<(Of <T>)>(array<String>[]()) | Registers the control.
 | RegisterControls()() | Registers the controls.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Singleton <(Of <MediaControlsFactory>)>
 |  | MediaControlsFactory

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetMediaObject Method (extension, useDefaultObject)

GetMediaObject Method (extension, useDefaultObject)
Namespaces >> MSS.Web.UI.WebControls >> MediaControlsFactory >> GetMediaObject(String, Boolean)
Gets the media object.
Declaration Syntax
C#
public MediaObject GetMediaObject(
    string extension,
    bool useDefaultObject
)
Parameters
extension (String)
The extension.
useDefaultObject (Boolean)
If set to true then when the object does not exist use default object.
Return Value
Return media object for the extension. If object doesn't exit and useDefaultObject set to true, return default media object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RegisterControl Method (exts)

RegisterControl<(Of <T>)> Method (exts)
Namespaces >> MSS.Web.UI.WebControls >> MediaControlsFactory >> RegisterControl<(Of <T>)>(array<String>[]())
Registers the control.
Declaration Syntax
C#
public void RegisterControl<T>(
    params string[] exts
) where T : new(), MediaObject
Generic Template Parameters
T
Parameters
exts (array< String >[]())
The extensions.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RegisterControls Method

RegisterControls Method
Namespaces >> MSS.Web.UI.WebControls >> MediaControlsFactory >> RegisterControls()()
Registers the controls.
Declaration Syntax
C#
protected void RegisterControls()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MediaItem Class

MediaItem Class
Namespaces >> MSS.Web.UI.WebControls >> MediaItem
Media item. Creates media object by source extension and renders it.
Declaration Syntax
C#
public class MediaItem : Image
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaItemMediaItemNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | Align()() | (Inherited from Image.)
 | Alt()() | (Inherited from Image.)
 | AltField | Gets or sets the field which contains alt text.
 | AltText | Gets or sets the alt text.
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from Image.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides Image.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | HSpace | Gets or sets the horizontal space.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | ImageField | Gets or sets the image field.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LinkClass | Gets or sets the link class.
 | LinkField | Gets or sets the link field.
 | LinkTip | Gets or sets the link tip.
 | LinkUrl | Gets or sets the link URL.
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NewWindow | Gets or sets a value indicating whether links open in a new window.
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Src()() | (Inherited from Image.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | VSpace | Gets or sets the vertical space.
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Image
 |  |  |  |  |  |  | MediaItem

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MediaItem Constructor

MediaItem Constructor
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> MediaItemMediaItemNew()()
Declaration Syntax
C#
public MediaItem()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AltField Property

AltField Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> AltField
Gets or sets the field which contains alt text.
Declaration Syntax
C#
public string AltField{ get; set;}
Value
The alt field.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AltText Property

AltText Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> AltText
Gets or sets the alt text.
Declaration Syntax
C#
[WebControlPropertyAttribute]
public string AltText{ get; set;}
Value
The alt text.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HSpace Property

HSpace Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> HSpace
Gets or sets the horizontal space.
Declaration Syntax
C#
public string HSpace{ get; set;}
Value
The horizontal space.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ImageField Property

ImageField Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> ImageField
Gets or sets the image field.
Declaration Syntax
C#
public string ImageField{ get; set;}
Value
The image field.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LinkClass Property

LinkClass Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> LinkClass
Gets or sets the link class.
Declaration Syntax
C#
[WebControlPropertyAttribute]
public string LinkClass{ get; set;}
Value
The link class.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LinkField Property

LinkField Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> LinkField
Gets or sets the link field.
Declaration Syntax
C#
public string LinkField{ get; set;}
Value
The link field.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LinkTip Property

LinkTip Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> LinkTip
Gets or sets the link tip.
Declaration Syntax
C#
[WebControlPropertyAttribute]
public string LinkTip{ get; set;}
Value
The link tip.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LinkUrl Property

LinkUrl Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> LinkUrl
Gets or sets the link URL.
Declaration Syntax
C#
public string LinkUrl{ get; set;}
Value
The link URL.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


NewWindow Property

NewWindow Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> NewWindow
Gets or sets a value indicating whether links open in a new window.
Declaration Syntax
C#
[WebControlPropertyAttribute]
public bool NewWindow{ get; set;}
Value
True if links open in a new window; otherwise, false.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


VSpace Property

VSpace Property
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> VSpace
Gets or sets the vertical space.
Declaration Syntax
C#
public string VSpace{ get; set;}
Value
The vertical space.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MediaObject Class

MediaObject Class
Namespaces >> MSS.Web.UI.WebControls >> MediaObject
Base class for the media objects.
Declaration Syntax
C#
public class MediaObject : WebControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaObjectMediaObjectNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | alt |
 | Alt | Gets or sets the alt text.
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | height |
 | Height | Gets or sets the height of the Web server control.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | src |
 | Src | Gets or sets the location of an image.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | width |
 | Width | Gets or sets the width of the Web server control.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | MediaObject
 |  |  |  | Image
 |  |  |  | MultiMediaObject

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MediaObject Constructor

MediaObject Constructor
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> MediaObjectMediaObjectNew()()
Declaration Syntax
C#
public MediaObject()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddAttribute Method

AddAttribute Method
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> AddAttribute()()
Members
Icon | Member | Description
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddAttribute Method (writer, key, value, skipEmpty)

AddAttribute Method (writer, key, value, skipEmpty)
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> AddAttribute(HtmlTextWriter, String, String, Boolean)
Declaration Syntax
C#
protected void AddAttribute(
    HtmlTextWriter writer,
    string key,
    string value,
    bool skipEmpty
)
Parameters
writer (HtmlTextWriter)
key (String)
value (String)
skipEmpty (Boolean)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddAttribute Method (writer, key, value, skipEmpty)

AddAttribute Method (writer, key, value, skipEmpty)
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean)
Declaration Syntax
C#
protected void AddAttribute(
    HtmlTextWriter writer,
    HtmlTextWriterAttribute key,
    string value,
    bool skipEmpty
)
Parameters
writer (HtmlTextWriter)
key (HtmlTextWriterAttribute)
value (String)
skipEmpty (Boolean)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


alt Field

alt Field
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> alt
Declaration Syntax
C#
protected string alt

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Alt Property

Alt Property
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> Alt
Gets or sets the alt text.
Declaration Syntax
C#
public string Alt{ get; set;}
Value
The alt text.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


height Field

height Field
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> height
Declaration Syntax
C#
protected string height

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Height Property

Height Property
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> Height
Gets or sets the height of the Web server control.
Declaration Syntax
C#
public string Height{ get; set;}
Value
The height of the control.
Return Value
A Unit that represents the height of the control. The default is Empty.
Exceptions
Exception | Condition
ArgumentException | The height was set to a negative value.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


src Field

src Field
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> src
Declaration Syntax
C#
protected string src

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Src Property

Src Property
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> Src
Gets or sets the location of an image.
Declaration Syntax
C#
public string Src{ get; set;}
Value
The location of the image.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


width Field

width Field
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> width
Declaration Syntax
C#
protected string width

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Width Property

Width Property
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> Width
Gets or sets the width of the Web server control.
Declaration Syntax
C#
public string Width{ get; set;}
Value
The width of the control.
Return Value
A Unit that represents the width of the control. The default is Empty.
Exceptions
Exception | Condition
ArgumentException | The width of the Web server control was set to a negative value.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MultiMediaObject Class

MultiMediaObject Class
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject
Base class from the multimedia objects.
Declaration Syntax
C#
public class MultiMediaObject : MediaObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiMediaObjectMultiMediaObjectNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) | (Inherited from MediaObject.)
 | AddAttribute(HtmlTextWriter, String, String, Boolean) | (Inherited from MediaObject.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddObjectAttribute(String, String) | Adds the object attributes.
 | AddObjectParameter(String, String) | Adds the object parameters.
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddStandardAttributes()() | Adds the standard attributes.
 | alt | (Inherited from MediaObject.)
 | Alt | Gets or sets the alt text. (Inherited from MediaObject.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the error message.
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetFullUrl(String) | Gets the full URL.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | height | (Inherited from MediaObject.)
 | Height | Gets or sets the height of the Web server control. (Inherited from MediaObject.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | RemoveObjectAttribute(String) | Removes the object attribute.
 | RemoveObjectParameter(String) | Removes the object parameter.
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderNestetObjects(HtmlTextWriter) | Renders the nestet objects.
 | RenderObject(HtmlTextWriter) |
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) |
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | src | (Inherited from MediaObject.)
 | Src | Gets or sets the location of an image. (Inherited from MediaObject.)
 | srcParamName |
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | width | (Inherited from MediaObject.)
 | Width | Gets or sets the width of the Web server control. (Inherited from MediaObject.)
 | WriteObjectAttributes(HtmlTextWriter) | Writes the object attributes.
 | WriteObjectParametrs(HtmlTextWriter) | Writes the object parametres.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | MediaObject
 |  |  |  | MultiMediaObject
 |  |  |  |  | Quicktime
 |  |  |  |  | RealPlayer
 |  |  |  |  | Flash
 |  |  |  |  | WindowsMediaPlayer

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MultiMediaObject Constructor

MultiMediaObject Constructor
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> MultiMediaObjectMultiMediaObjectNew()()
Declaration Syntax
C#
public MultiMediaObject()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddObjectAttribute Method (key, value)

AddObjectAttribute Method (key, value)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> AddObjectAttribute(String, String)
Adds the object attributes.
Declaration Syntax
C#
public void AddObjectAttribute(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddObjectParameter Method (key, value)

AddObjectParameter Method (key, value)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> AddObjectParameter(String, String)
Adds the object parameters.
Declaration Syntax
C#
public void AddObjectParameter(
    string key,
    string value
)
Parameters
key (String)
The key.
value (String)
The value.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddStandardAttributes Method

AddStandardAttributes Method
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> AddStandardAttributes()()
Adds the standard attributes.
Declaration Syntax
C#
protected void AddStandardAttributes()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ErrorMessage Property

ErrorMessage Property
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> ErrorMessage
Gets or sets the error message.
Declaration Syntax
C#
public string ErrorMessage{ get; set;}
Value
The error message.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetFullUrl Method (url)

GetFullUrl Method (url)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> GetFullUrl(String)
Gets the full URL.
Declaration Syntax
C#
protected string GetFullUrl(
    string url
)
Parameters
url (String)
The URL.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RemoveObjectAttribute Method (key)

RemoveObjectAttribute Method (key)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> RemoveObjectAttribute(String)
Removes the object attribute.
Declaration Syntax
C#
public void RemoveObjectAttribute(
    string key
)
Parameters
key (String)
The key.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RemoveObjectParameter Method (key)

RemoveObjectParameter Method (key)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> RemoveObjectParameter(String)
Removes the object parameter.
Declaration Syntax
C#
public void RemoveObjectParameter(
    string key
)
Parameters
key (String)
The key.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderNestetObjects Method (writer)

RenderNestetObjects Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> RenderNestetObjects(HtmlTextWriter)
Renders the nestet objects.
Declaration Syntax
C#
protected virtual void RenderNestetObjects(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The writer.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderObject Method

RenderObject Method
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> RenderObject()()
Members
Icon | Member | Description
 | RenderObject(HtmlTextWriter) |
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderObject Method (writer)

RenderObject Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> RenderObject(HtmlTextWriter)
Declaration Syntax
C#
protected void RenderObject(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderObject Method (writer, renderNestedElement)

RenderObject Method (writer, renderNestedElement)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate)
Declaration Syntax
C#
protected void RenderObject(
    HtmlTextWriter writer,
    MultiMediaObject.MultiMediaObject..::RenderNestedElementDelegate renderNestedElement
)
Parameters
writer (HtmlTextWriter)
renderNestedElement (MultiMediaObject..::RenderNestedElementDelegate)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


srcParamName Field

srcParamName Field
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> srcParamName
Declaration Syntax
C#
protected string srcParamName

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WriteObjectAttributes Method (writer)

WriteObjectAttributes Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> WriteObjectAttributes(HtmlTextWriter)
Writes the object attributes.
Declaration Syntax
C#
protected void WriteObjectAttributes(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The writer.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WriteObjectParametrs Method (writer)

WriteObjectParametrs Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> WriteObjectParametrs(HtmlTextWriter)
Writes the object parametres.
Declaration Syntax
C#
protected void WriteObjectParametrs(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
The writer.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


NoLicense Class

NoLicense Class
Namespaces >> MSS.Web.UI.WebControls >> NoLicense
Declaration Syntax
C#
public class NoLicense : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoLicenseNoLicenseNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text |
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | NoLicense

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


NoLicense Constructor

NoLicense Constructor
Namespaces >> MSS.Web.UI.WebControls >> NoLicense >> NoLicenseNoLicenseNew()()
Declaration Syntax
C#
public NoLicense()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DoRender Method (writer)

DoRender Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> NoLicense >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Text Property

Text Property
Namespaces >> MSS.Web.UI.WebControls >> NoLicense >> Text
Declaration Syntax
C#
public string Text{ get; set;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Quicktime Class

Quicktime Class
Namespaces >> MSS.Web.UI.WebControls >> Quicktime
Displays quick time video on the page.
Declaration Syntax
C#
public class Quicktime : MultiMediaObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QuicktimeQuicktimeNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) | (Inherited from MediaObject.)
 | AddAttribute(HtmlTextWriter, String, String, Boolean) | (Inherited from MediaObject.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddObjectAttribute(String, String) | Adds the object attributes. (Inherited from MultiMediaObject.)
 | AddObjectParameter(String, String) | Adds the object parameters. (Inherited from MultiMediaObject.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddStandardAttributes()() | Adds the standard attributes. (Inherited from MultiMediaObject.)
 | alt | (Inherited from MediaObject.)
 | Alt | Gets or sets the alt text. (Inherited from MediaObject.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the error message. (Inherited from MultiMediaObject.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetFullUrl(String) | Gets the full URL. (Inherited from MultiMediaObject.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | height | (Inherited from MediaObject.)
 | Height | Gets or sets the height of the Web server control. (Inherited from MediaObject.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | RemoveObjectAttribute(String) | Removes the object attribute. (Inherited from MultiMediaObject.)
 | RemoveObjectParameter(String) | Removes the object parameter. (Inherited from MultiMediaObject.)
 | Render(HtmlTextWriter) | (Overrides MultiMediaObject.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderNestetObjects(HtmlTextWriter) | (Overrides MultiMediaObject.RenderNestetObjects(HtmlTextWriter).)
 | RenderObject(HtmlTextWriter) | (Inherited from MultiMediaObject.)
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) | (Inherited from MultiMediaObject.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | src | (Inherited from MediaObject.)
 | Src | Gets or sets the location of an image. (Inherited from MediaObject.)
 | srcParamName | (Inherited from MultiMediaObject.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | width | (Inherited from MediaObject.)
 | Width | Gets or sets the width of the Web server control. (Inherited from MediaObject.)
 | WriteObjectAttributes(HtmlTextWriter) | Writes the object attributes. (Inherited from MultiMediaObject.)
 | WriteObjectParametrs(HtmlTextWriter) | Writes the object parametres. (Inherited from MultiMediaObject.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | MediaObject
 |  |  |  | MultiMediaObject
 |  |  |  |  | Quicktime

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Quicktime Constructor

Quicktime Constructor
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> QuicktimeQuicktimeNew()()
Declaration Syntax
C#
public Quicktime()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderNestetObjects Method (writer)

RenderNestetObjects Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> RenderNestetObjects(HtmlTextWriter)
Declaration Syntax
C#
protected override void RenderNestetObjects(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RadioButton Class

RadioButton Class
Namespaces >> MSS.Web.UI.WebControls >> RadioButton
Radio button with mss dictionary functionality.
Declaration Syntax
C#
public class RadioButton : RadioButton
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RadioButtonRadioButtonNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the HTML attributes and styles of a CheckBox control to be rendered to the specified output stream. (Inherited from CheckBox.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoPostBack | Gets or sets a value indicating whether the CheckBox state automatically posts back to the server when clicked. (Inherited from CheckBox.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether validation is performed when the CheckBox control is clicked. (Inherited from CheckBox.)
 | Checked | Gets or sets a value indicating whether the CheckBox control is checked. (Inherited from CheckBox.)
 | CheckedChanged | Occurs when the value of the Checked property changes between posts to the server. (Inherited from CheckBox.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | FormName | Gets or sets the form name.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupName | Gets or sets the name of the group that the radio button belongs to. (Inherited from RadioButton.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InputAttributes | Gets a reference to the collection of attributes for the rendered input element of the CheckBox control. (Inherited from CheckBox.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LabelAttributes | Gets a reference to the collection of attributes for the rendered LABEL element of the CheckBox control. (Inherited from CheckBox.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | Processes postback data for the RadioButton control. (Inherited from RadioButton.)
 | LoadViewState(Object) | Loads the previously saved view state of the CheckBox control. (Inherited from CheckBox.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCheckedChanged(EventArgs) | Raises the CheckedChanged event of the CheckBox control. This allows you to handle the event directly. (Inherited from CheckBox.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides RadioButton.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | Raises the CheckedChanged event, if the Checked property has changed on postback. (Inherited from RadioButton.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides CheckBox.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves the changes to the CheckBox view state since the time the page was posted back to the server. (Inherited from CheckBox.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IPostBackDataHandler..::LoadPostData(String, NameValueCollection) | (Inherited from RadioButton.)
 | IPostBackDataHandler..::RaisePostDataChangedEvent()() | (Inherited from RadioButton.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text label associated with the CheckBox. (Inherited from CheckBox.)
 | TextAlign | Gets or sets the alignment of the text label associated with the CheckBox control. (Inherited from CheckBox.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Tracks view-state changes to the CheckBox control so that they can be stored in the control's StateBag object. This object is accessible through the ViewState property. (Inherited from CheckBox.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationGroup | Gets or sets the group of controls for which the CheckBox control causes validation when it posts back to the server. (Inherited from CheckBox.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | CheckBox
 |  |  |  | RadioButton
 |  |  |  |  | RadioButton

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RadioButton Constructor

RadioButton Constructor
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> RadioButtonRadioButtonNew()()
Declaration Syntax
C#
public RadioButton()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> FormName
Gets or sets the form name.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RealPlayer Class

RealPlayer Class
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer
Display "ra", "ram", "rpm" files on the page.
Declaration Syntax
C#
public class RealPlayer : MultiMediaObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RealPlayerRealPlayerNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) | (Inherited from MediaObject.)
 | AddAttribute(HtmlTextWriter, String, String, Boolean) | (Inherited from MediaObject.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddObjectAttribute(String, String) | Adds the object attributes. (Inherited from MultiMediaObject.)
 | AddObjectParameter(String, String) | Adds the object parameters. (Inherited from MultiMediaObject.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddStandardAttributes()() | Adds the standard attributes. (Inherited from MultiMediaObject.)
 | alt | (Inherited from MediaObject.)
 | Alt | Gets or sets the alt text. (Inherited from MediaObject.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the error message. (Inherited from MultiMediaObject.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetFullUrl(String) | Gets the full URL. (Inherited from MultiMediaObject.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | height | (Inherited from MediaObject.)
 | Height | Gets or sets the height of the Web server control. (Inherited from MediaObject.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | RemoveObjectAttribute(String) | Removes the object attribute. (Inherited from MultiMediaObject.)
 | RemoveObjectParameter(String) | Removes the object parameter. (Inherited from MultiMediaObject.)
 | Render(HtmlTextWriter) | (Overrides MultiMediaObject.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderNestetObjects(HtmlTextWriter) | Renders the nestet objects. (Inherited from MultiMediaObject.)
 | RenderObject(HtmlTextWriter) | (Inherited from MultiMediaObject.)
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) | (Inherited from MultiMediaObject.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | src | (Inherited from MediaObject.)
 | Src | Gets or sets the location of an image. (Inherited from MediaObject.)
 | srcParamName | (Inherited from MultiMediaObject.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | width | (Inherited from MediaObject.)
 | Width | Gets or sets the width of the Web server control. (Inherited from MediaObject.)
 | WriteObjectAttributes(HtmlTextWriter) | Writes the object attributes. (Inherited from MultiMediaObject.)
 | WriteObjectParametrs(HtmlTextWriter) | Writes the object parametres. (Inherited from MultiMediaObject.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | MediaObject
 |  |  |  | MultiMediaObject
 |  |  |  |  | RealPlayer

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RealPlayer Constructor

RealPlayer Constructor
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer >> RealPlayerRealPlayerNew()()
Declaration Syntax
C#
public RealPlayer()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RegularExpressionValidator Class

RegularExpressionValidator Class
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator
Dictionary regular expression validater. Gets the error message, text, tool tip, access key and tab index from the dictionary.
Declaration Syntax
C#
public class RegularExpressionValidator : RegularExpressionValidator
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegularExpressionValidatorRegularExpressionValidatorNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds to the specified HtmlTextWriter object the HTML attributes and styles that need to be rendered for the control. (Inherited from RegularExpressionValidator.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the control that an element was parsed and adds the element to the Label control. (Inherited from Label.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssociatedControlID | This property is not supported. (Inherited from BaseValidator.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CheckControlValidationProperty(String, String) | Verifies whether the specified control is on the page and contains validation properties. (Inherited from BaseValidator.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlPropertiesValid()() | Determines whether the control specified by the ControlToValidate property is a valid control. (Inherited from BaseValidator.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DetermineRenderUplevel()() | Determines whether the validation control can be rendered for a newer ("uplevel") browser. (Inherited from BaseValidator.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Display | Gets or sets the display behavior of the error message in a validation control. (Inherited from BaseValidator.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableClientScript | Gets or sets a value indicating whether client-side validation is enabled. (Inherited from BaseValidator.)
 | Enabled | Gets or sets a value that indicates whether the validation control is enabled. (Inherited from BaseValidator.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the text for the error message displayed in a ValidationSummary control when validation fails. (Inherited from BaseValidator.)
 | EvaluateIsValid()() | (Overrides RegularExpressionValidator.EvaluateIsValid()().)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the color of the message displayed when validation fails. (Inherited from BaseValidator.)
 | FormName | Gets or sets the name of the form.
 | GetControlRenderID(String) | Gets the client ID of the specified control. (Inherited from BaseValidator.)
 | GetControlValidationValue(String) | Gets the value associated with the specified input control. (Inherited from BaseValidator.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Loads the previously saved state for the control. (Inherited from Label.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from BaseValidator.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from BaseValidator.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from BaseValidator.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertiesValid | Gets a value that indicates whether the control specified by the ControlToValidate property is a valid control. (Inherited from BaseValidator.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterValidatorCommonScript()() | Registers code on the page for client-side validation. (Inherited from BaseValidator.)
 | RegisterValidatorDeclaration()() | Registers an ECMAScript array declaration using the array name Page_Validators. (Inherited from BaseValidator.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Displays the control on the client. (Inherited from BaseValidator.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the Label into the specified writer. (Inherited from Label.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderUplevel | Gets a value that indicates whether the client's browser supports "uplevel" rendering. (Inherited from BaseValidator.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocusOnError | Gets or sets a value that indicates whether focus is set to the control specified by the ControlToValidate property when validation fails. (Inherited from BaseValidator.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HTML tag that is used to render the Label control. (Inherited from Label.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text displayed in the validation control when validation fails. (Inherited from BaseValidator.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Validate()() | Performs validation on the associated input control and updates the IsValid property. (Inherited from BaseValidator.)
 | ValidationExpression | Gets or sets the regular expression that determines the pattern used to validate a field. (Inherited from RegularExpressionValidator.)
 | ValidationGroup | Gets or sets the name of the validation group to which this validation control belongs. (Inherited from BaseValidator.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Label
 |  |  |  | BaseValidator
 |  |  |  |  | RegularExpressionValidator
 |  |  |  |  |  | RegularExpressionValidator
 |  |  |  |  |  |  | ItemNameValidator

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RegularExpressionValidator Constructor

RegularExpressionValidator Constructor
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> RegularExpressionValidatorRegularExpressionValidatorNew()()
Declaration Syntax
C#
public RegularExpressionValidator()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


EvaluateIsValid Method

EvaluateIsValid Method
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> EvaluateIsValid()()
Declaration Syntax
C#
protected override bool EvaluateIsValid()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> FormName
Gets or sets the name of the form.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MultiMediaObject.RenderNestedElementDelegate Delegate

MultiMediaObject..::RenderNestedElementDelegate Delegate
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> MultiMediaObject..::RenderNestedElementDelegate
Declaration Syntax
C#
protected delegate void RenderNestedElementDelegate(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderSpotsControl Class

RenderSpotsControl Class
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl
Renders spot controls
Declaration Syntax
C#
public class RenderSpotsControl : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderSpotsControlRenderSpotsControlNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IncludeLeftAndRight | If IsLeft is true only spots marked with "Left" are considered
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLeft | If IsLeft is true only spots marked with "Left" are considered
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsSpot | If IsSpot is true only modules with "IsSpot" checked are used, otherwise only modules with "IsSpot" unchecked are used
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | RenderSpotsControl

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderSpotsControl Constructor

RenderSpotsControl Constructor
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> RenderSpotsControlRenderSpotsControlNew()()
Declaration Syntax
C#
public RenderSpotsControl()

Assembly: MSS.WebSite (Module: MSS.WebSite)


IncludeLeftAndRight Property

IncludeLeftAndRight Property
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> IncludeLeftAndRight
If IsLeft is true only spots marked with "Left" are considered
Declaration Syntax
C#
public bool IncludeLeftAndRight{ get; set;}

Assembly: MSS.WebSite (Module: MSS.WebSite)


IsLeft Property

IsLeft Property
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> IsLeft
If IsLeft is true only spots marked with "Left" are considered
Declaration Syntax
C#
public bool IsLeft{ get; set;}

Assembly: MSS.WebSite (Module: MSS.WebSite)


IsSpot Property

IsSpot Property
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> IsSpot
If IsSpot is true only modules with "IsSpot" checked are used, otherwise only modules with "IsSpot" unchecked are used
Declaration Syntax
C#
public bool IsSpot{ get; set;}

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebSite (Module: MSS.WebSite)


RequiredFieldValidator Class

RequiredFieldValidator Class
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator
Dictionary required field validater.
Declaration Syntax
C#
public class RequiredFieldValidator : RequiredFieldValidator
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RequiredFieldValidatorRequiredFieldValidatorNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the HTML attributes and styles that need to be rendered for the control to the specified HtmlTextWriter object. (Inherited from RequiredFieldValidator.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the control that an element was parsed and adds the element to the Label control. (Inherited from Label.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssociatedControl | Gets the associated control.
 | AssociatedControlID | This property is not supported. (Inherited from BaseValidator.)
 | Asterix | Gets or sets a value indicating whether to add asterix to the text.
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CheckControlValidationProperty(String, String) | Verifies whether the specified control is on the page and contains validation properties. (Inherited from BaseValidator.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearText | Gets or sets a value indicating whether display an empty text.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlPropertiesValid()() | Determines whether the control specified by the ControlToValidate property is a valid control. (Inherited from BaseValidator.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DetermineRenderUplevel()() | Determines whether the validation control can be rendered for a newer ("uplevel") browser. (Inherited from BaseValidator.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Display | Gets or sets the display behavior of the error message in a validation control. (Inherited from BaseValidator.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableClientScript | Gets or sets a value indicating whether client-side validation is enabled. (Inherited from BaseValidator.)
 | Enabled | Gets or sets a value that indicates whether the validation control is enabled. (Inherited from BaseValidator.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the text for the error message displayed in a ValidationSummary control when validation fails. (Inherited from BaseValidator.)
 | EvaluateIsValid()() | (Overrides RequiredFieldValidator.EvaluateIsValid()().)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the color of the message displayed when validation fails. (Inherited from BaseValidator.)
 | FormName | Gets or sets the name of the form.
 | GetControlRenderID(String) | Gets the client ID of the specified control. (Inherited from BaseValidator.)
 | GetControlValidationValue(String) | Gets the value associated with the specified input control. (Inherited from BaseValidator.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitialValue | Gets or sets the initial value of the associated input control. (Inherited from RequiredFieldValidator.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets or sets a value that indicates whether the associated input control passes validation. (Inherited from BaseValidator.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Loads the previously saved state for the control. (Inherited from Label.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from BaseValidator.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides BaseValidator.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from BaseValidator.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertiesValid | Gets a value that indicates whether the control specified by the ControlToValidate property is a valid control. (Inherited from BaseValidator.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterValidatorCommonScript()() | Registers code on the page for client-side validation. (Inherited from BaseValidator.)
 | RegisterValidatorDeclaration()() | Registers an ECMAScript array declaration using the array name Page_Validators. (Inherited from BaseValidator.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides BaseValidator.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the Label into the specified writer. (Inherited from Label.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderUplevel | Gets a value that indicates whether the client's browser supports "uplevel" rendering. (Inherited from BaseValidator.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocusOnError | Gets or sets a value that indicates whether focus is set to the control specified by the ControlToValidate property when validation fails. (Inherited from BaseValidator.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HTML tag that is used to render the Label control. (Inherited from Label.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text displayed in the validation control when validation fails. (Inherited from BaseValidator.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | Validate()() | Performs validation on the associated input control and updates the IsValid property. (Inherited from BaseValidator.)
 | ValidationGroup | Gets or sets the name of the validation group to which this validation control belongs. (Inherited from BaseValidator.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Label
 |  |  |  | BaseValidator
 |  |  |  |  | RequiredFieldValidator
 |  |  |  |  |  | RequiredFieldValidator

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RequiredFieldValidator Constructor

RequiredFieldValidator Constructor
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> RequiredFieldValidatorRequiredFieldValidatorNew()()
Declaration Syntax
C#
public RequiredFieldValidator()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AssociatedControl Property

AssociatedControl Property
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> AssociatedControl
Gets the associated control.
Declaration Syntax
C#
protected Control AssociatedControl{ get;}
Value
The associated control.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Asterix Property

Asterix Property
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> Asterix
Gets or sets a value indicating whether to add asterix to the text.
Declaration Syntax
C#
public bool Asterix{ get; set;}
Value
True if asterix; otherwise, false.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ClearText Property

ClearText Property
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> ClearText
Gets or sets a value indicating whether display an empty text.
Declaration Syntax
C#
[BindableAttribute(true)]
public bool ClearText{ get; set;}
Value
True if clear text; otherwise, false.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


EvaluateIsValid Method

EvaluateIsValid Method
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> EvaluateIsValid()()
Declaration Syntax
C#
protected override bool EvaluateIsValid()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> FormName
Gets or sets the name of the form.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


TextBox Class

TextBox Class
Namespaces >> MSS.Web.UI.WebControls >> TextBox
Dictionary text box with additional functionality.
Declaration Syntax
C#
public class TextBox : TextBox
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxTextBoxNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter instance. (Inherited from TextBox.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Overridden to allow only literal controls to be added as the Text property. (Inherited from TextBox.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoCompleteType | Gets or sets a value that indicates the AutoComplete behavior of the TextBox control (Inherited from TextBox.)
 | AutoPostBack | Gets or sets a value indicating whether an automatic post back to the server occurs whenever the user presses the ENTER or the TAB key while in the TextBox control. (Inherited from TextBox.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether validation is performed when the TextBox control is set to validate when a postback occurs. (Inherited from TextBox.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Columns | Gets or sets the display width of the text box in characters. (Inherited from TextBox.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DefaultButton | Gets or sets the default button. This button will be clicked if user presses “Enter” when he enters text in the text box.
 | DefaultText | Gets the default text.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictionaryItem | Gets or sets the dictionary item.
 | DictionaryPath | Gets or sets the dictionary path.
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | FormName | Gets or sets the name of the form.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsModified | Gets a value indicating whether text has been modified.
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Language | Gets or sets the language.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | Processes the postback data for the TextBox control. (Inherited from TextBox.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MaxLength | Gets or sets the maximum number of characters allowed in the text box. (Inherited from TextBox.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoValues | Gets or sets a value indicating whether fill control's fields with values from the dictionary.
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides TextBox.OnPreRender(EventArgs).)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. This allows you to handle the event directly. (Inherited from TextBox.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | Invokes the OnTextChanged(EventArgs) method when the posted data for the TextBox control has changed. (Inherited from TextBox.)
 | ReadOnly | Gets or sets a value indicating whether the contents of the TextBox control can be changed. (Inherited from TextBox.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides TextBox.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Rows | Gets or sets the number of rows displayed in a multiline text box. (Inherited from TextBox.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves the changes to the text box view state since the time the page was posted back to the server. (Inherited from TextBox.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IPostBackDataHandler..::LoadPostData(String, NameValueCollection) | (Inherited from TextBox.)
 | IPostBackDataHandler..::RaisePostDataChangedEvent()() | (Inherited from TextBox.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HTML tag for the text box control. This property is protected. (Inherited from TextBox.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text content of the TextBox control. (Overrides TextBox.Text.)
 | TextChanged | Occurs when the content of the text box changes between posts to the server. (Inherited from TextBox.)
 | TextMode | Gets or sets the behavior mode (single-line, multiline, or password) of the TextBox control. (Inherited from TextBox.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidationGroup | Gets or sets the group of controls for which the TextBox control causes validation when it posts back to the server. (Inherited from TextBox.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Wrap | Gets or sets a value indicating whether the text content wraps within a multiline text box. (Inherited from TextBox.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | TextBox
 |  |  |  | TextBox

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


TextBox Constructor

TextBox Constructor
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> TextBoxTextBoxNew()()
Declaration Syntax
C#
public TextBox()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DefaultButton Property

DefaultButton Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> DefaultButton
Gets or sets the default button. This button will be clicked if user presses “Enter” when he enters text in the text box.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DefaultButton{ get; set;}
Value
The default button.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DefaultText Property

DefaultText Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> DefaultText
Gets the default text.
Declaration Syntax
C#
public string DefaultText{ get;}
Value
The default text.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryItem Property

DictionaryItem Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> DictionaryItem
Gets or sets the dictionary item.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryItem{ get; set;}
Value
The dictionary item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryPath Property

DictionaryPath Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> DictionaryPath
Gets or sets the dictionary path.
Declaration Syntax
C#
[BindableAttribute(true)]
public string DictionaryPath{ get; set;}
Value
The dictionary path.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FormName Property

FormName Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> FormName
Gets or sets the name of the form.
Declaration Syntax
C#
[BindableAttribute(true)]
public string FormName{ get; set;}
Value
The name of the form.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


IsModified Property

IsModified Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> IsModified
Gets a value indicating whether text has been modified.
Declaration Syntax
C#
public bool IsModified{ get;}
Value
true if the text has been modified; otherwise, false.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Language Property

Language Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> Language
Gets or sets the language.
Declaration Syntax
C#
[BindableAttribute(true)]
public string Language{ get; set;}
Value
The language.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


NoValues Property

NoValues Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> NoValues
Gets or sets a value indicating whether fill control's fields with values from the dictionary.
Declaration Syntax
C#
[BindableAttribute(true)]
public bool NoValues{ get; set;}
Value
true if no values; otherwise, false.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Text Property

Text Property
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> Text
Gets or sets the text content of the TextBox control.
Declaration Syntax
C#
[BindableAttribute(true)]
public override string Text{ get; set;}
Value
Return Value
The text displayed in the TextBox control. The default is an empty string ("").

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WindowsMediaPlayer Class

WindowsMediaPlayer Class
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer
Displays "wma", "wmv", "avi", "mpeg" files on the page.
Declaration Syntax
C#
public class WindowsMediaPlayer : MultiMediaObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowsMediaPlayerWindowsMediaPlayerNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) | (Inherited from MediaObject.)
 | AddAttribute(HtmlTextWriter, String, String, Boolean) | (Inherited from MediaObject.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddObjectAttribute(String, String) | Adds the object attributes. (Inherited from MultiMediaObject.)
 | AddObjectParameter(String, String) | Adds the object parameters. (Inherited from MultiMediaObject.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddStandardAttributes()() | Adds the standard attributes. (Inherited from MultiMediaObject.)
 | alt | (Inherited from MediaObject.)
 | Alt | Gets or sets the alt text. (Inherited from MediaObject.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | Gets or sets the error message. (Inherited from MultiMediaObject.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetFullUrl(String) | Gets the full URL. (Inherited from MultiMediaObject.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | height | (Inherited from MediaObject.)
 | Height | Gets or sets the height of the Web server control. (Inherited from MediaObject.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | RemoveObjectAttribute(String) | Removes the object attribute. (Inherited from MultiMediaObject.)
 | RemoveObjectParameter(String) | Removes the object parameter. (Inherited from MultiMediaObject.)
 | Render(HtmlTextWriter) | (Overrides MultiMediaObject.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderNestetObjects(HtmlTextWriter) | Renders the nestet objects. (Inherited from MultiMediaObject.)
 | RenderObject(HtmlTextWriter) | (Inherited from MultiMediaObject.)
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) | (Inherited from MultiMediaObject.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | src | (Inherited from MediaObject.)
 | Src | Gets or sets the location of an image. (Inherited from MediaObject.)
 | srcParamName | (Inherited from MultiMediaObject.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | width | (Inherited from MediaObject.)
 | Width | Gets or sets the width of the Web server control. (Inherited from MediaObject.)
 | WriteObjectAttributes(HtmlTextWriter) | Writes the object attributes. (Inherited from MultiMediaObject.)
 | WriteObjectParametrs(HtmlTextWriter) | Writes the object parametres. (Inherited from MultiMediaObject.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | MediaObject
 |  |  |  | MultiMediaObject
 |  |  |  |  | WindowsMediaPlayer

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WindowsMediaPlayer Constructor

WindowsMediaPlayer Constructor
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer >> WindowsMediaPlayerWindowsMediaPlayerNew()()
Declaration Syntax
C#
public WindowsMediaPlayer()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.Web.UI.XamlControls Namespace

MSS.Web.UI.XamlControls Namespace
Namespaces >> MSS.Web.UI.XamlControls
Declaration Syntax
C#
namespace MSS.Web.UI.XamlControls
Types
All Types Classes
Icon | Type | Description
 | DataTreeviewEx | Display node name in the format: MenuTitle - [ItemName]
 | MssXmlControl | Base class for mss xml control.
 | TaskBoxEx | Renders the task box panel.


DataTreeviewEx Class

DataTreeviewEx Class
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx
Display node name in the format: MenuTitle - [ItemName]
Declaration Syntax
C#
public class DataTreeviewEx : DataTreeview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataTreeviewExDataTreeviewExNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddChecked(String) | (Inherited from Treeview.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddSelected(String) | (Inherited from Treeview.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AllowDragging()() | (Inherited from DataTreeview.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoUpdateDataContext()() | (Inherited from DataTreeview.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | Checked()() | (Inherited from Treeview.)
 | CheckParents()() | (Inherited from Treeview.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChecked()() | (Inherited from Treeview.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearNodes()() | (Inherited from Treeview.)
 | ClearSelection()() | (Inherited from Treeview.)
 | Click()() | (Inherited from Treeview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse(TreeNode) | (Inherited from Treeview.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | ColumnNames()() | (Inherited from Treeview.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DblClick()() | (Inherited from Treeview.)
 | Deactivate()() | (Inherited from Control.)
 | Depth()() | (Inherited from Treeview.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableEvents()() | (Inherited from DataTreeview.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoClick(Message) | (Inherited from Treeview.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDblclick(Message) | (Inherited from Treeview.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Treeview.)
 | DoRender(HtmlTextWriter) | (Inherited from Treeview.)
 | Drag()() | (Inherited from Treeview.)
 | DrawDots()() | (Inherited from WebControl.)
 | Drop()() | (Inherited from Treeview.)
 | DropItem(String) | (Inherited from DataTreeview.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableEvents()() | (Inherited from DataTreeview.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Expand(TreeNode, Boolean) | (Inherited from DataTreeview.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindNode(String) | (Inherited from Treeview.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetContextMenu()() | (Inherited from DataTreeview.)
 | GetContextMenu(String) | (Inherited from DataTreeview.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetNewMenu(String) | (Inherited from DataTreeview.)
 | GetNodeByItemID(String) | (Inherited from DataTreeview.)
 | GetSelectionItem()() | (Inherited from DataTreeview.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetTreeNode(Item, Control) | (Overrides DataTreeview.GetTreeNode(Item, Control).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreSorting()() | (Inherited from DataTreeview.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | ItemsOnly()() | (Inherited from Treeview.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | MultiSelect()() | (Inherited from Treeview.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NodeClicked(Message, TreeNode) | (Inherited from DataTreeview.)
 | Nodes()() | (Inherited from Treeview.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick()() | (Inherited from Treeview.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from DataTreeview.)
 | OnDblClick()() | (Inherited from Treeview.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from DataTreeview.)
 | OnPreRender(EventArgs) | (Inherited from DataTreeview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate(Control, Int32) | (Inherited from DataTreeview.)
 | Populate(Control, DataContext) | (Inherited from DataTreeview.)
 | Populate(DataContext, Control, Item, Item, String) | (Inherited from DataTreeview.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | Refresh()() | (Inherited from DataTreeview.)
 | Refresh(TreeNode) | (Inherited from DataTreeview.)
 | Refresh(String) | (Inherited from DataTreeview.)
 | Refresh(ID) | (Inherited from DataTreeview.)
 | RefreshNode(TreeNode) | (Inherited from DataTreeview.)
 | RefreshRoot()() | (Inherited from DataTreeview.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | Root()() | Obsolete. (Inherited from DataTreeview.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | Selected()() | (Inherited from Treeview.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | ShowCheckboxes()() | (Inherited from Treeview.)
 | ShowRoot()() | (Inherited from DataTreeview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Toggle(String) | (Inherited from Treeview.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Treeview
 |  |  |  |  |  |  | DataTreeview
 |  |  |  |  |  |  |  | DataTreeviewEx

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataTreeviewEx Constructor

DataTreeviewEx Constructor
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> DataTreeviewExDataTreeviewExNew()()
Declaration Syntax
C#
public DataTreeviewEx()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetTreeNode Method (item, parent)

GetTreeNode Method (item, parent)
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> GetTreeNode(Item, Control)
Declaration Syntax
C#
protected override TreeNode GetTreeNode(
    Item item,
    Control parent
)
Parameters
item (Item)
parent (Control)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MssXmlControl Class

MssXmlControl Class
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl
Base class for mss xml control.
Declaration Syntax
C#
public class MssXmlControl : XmlControl, IMessageHandler
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MssXmlControlMssXmlControlNew()() |
 | _ControlName()() | (Inherited from XmlControl.)
 | _Mode()() | (Inherited from XmlControl.)
 | _NamespacePrefix()() | (Inherited from XmlControl.)
 | _Placeholders()() | (Inherited from XmlControl.)
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddAttributeSubscriber(Control) | (Inherited from XmlControl.)
 | AddControl(Control) | (Inherited from XmlControl.)
 | AddControl(Control, String) | (Inherited from XmlControl.)
 | AddControl(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddControl(Control, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddGeneric(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddLiteral(String, String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddPlaceholder(String, Control, String, array<String>[]()) | (Inherited from XmlControl.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AttributeChanged(String, String) | (Inherited from XmlControl.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from XmlControl.)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetPlaceholders()() | (Inherited from XmlControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Overrides XmlControl.HandleMessage(Message).)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | idref(String) | (Inherited from XmlControl.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | Initialize()() | (Inherited from XmlControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Item(String) | (Inherited from XmlControl.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageViewState | Gets the view state of the page.
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | qs(String) | (Inherited from XmlControl.)
 | qs(String, String) | (Inherited from XmlControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetAttribute(Control, String, String) | (Inherited from XmlControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperties(Control, array<String>[]()) | (Inherited from XmlControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetProperty(Control, String, String) | (Inherited from XmlControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStyle(Control, String) | (Inherited from XmlControl.)
 | ShowAlert(String) | Shows the alert message.
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | UpdateIDRefs()() | (Inherited from XmlControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | XmlControl
 |  |  |  |  | MssXmlControl
 |  |  |  |  |  | CreateSiteForm
 |  |  |  |  |  | SitesOverviewForm
 |  |  |  |  |  | SiteTypesForm

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MssXmlControl Constructor

MssXmlControl Constructor
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> MssXmlControlMssXmlControlNew()()
Declaration Syntax
C#
public MssXmlControl()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HandleMessage Method (message)

HandleMessage Method (message)
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> HandleMessage(Message)
Declaration Syntax
C#
public override void HandleMessage(
    Message message
)
Parameters
message (Message)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PageViewState Property

PageViewState Property
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> PageViewState
Gets the view state of the page.
Declaration Syntax
C#
public StateBag PageViewState{ get;}
Value
The state of the page view.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlert Method (text)

ShowAlert Method (text)
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> ShowAlert(String)
Shows the alert message.
Declaration Syntax
C#
protected void ShowAlert(
    string text
)
Parameters
text (String)
The text.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method (dictionaryEntry)

ShowAlertFromDictionary Method (dictionaryEntry)
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> ShowAlertFromDictionary(String)
Shows the alert message. The text of the message is taken from the dictionary.
Declaration Syntax
C#
protected void ShowAlertFromDictionary(
    string dictionaryEntry
)
Parameters
dictionaryEntry (String)
The dictionary entry.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method (dictionaryEntry, args)

ShowAlertFromDictionary Method (dictionaryEntry, args)
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> ShowAlertFromDictionary(String, array<Object>[]())
Shows the alert message. The text of the message is taken from the dictionary.
Declaration Syntax
C#
protected void ShowAlertFromDictionary(
    string dictionaryEntry,
    params Object[] args
)
Parameters
dictionaryEntry (String)
The dictionary entry.
args (array< Object >[]())
The args.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


TaskBoxEx Class

TaskBoxEx Class
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx
Renders the task box panel.
Declaration Syntax
C#
public class TaskBoxEx : HeaderedItemsControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskBoxExTaskBoxExNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BodyClass | Gets or sets the body class.
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Collapse()() |
 | Collapsed | Gets or sets a value indicating whether this TaskBoxEx is collapsed.
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides Component.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | FormattedHeader()() | Obsolete. (Inherited from HeaderedItemsControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetFormattedHeader()() | (Inherited from HeaderedItemsControl.)
 | GetFormattedHeader(Boolean) | (Inherited from HeaderedItemsControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header()() | (Inherited from HeaderedItemsControl.)
 | HeaderClass | Gets or sets the header class.
 | HeaderStyle()() | (Inherited from HeaderedItemsControl.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | Icon | Gets or sets the icon.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from Control.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from Control.)
 | OnItemDeleted(DataContext, ID) | (Inherited from Control.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | HeaderedItemsControl
 |  |  |  |  |  |  | TaskBoxEx

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


TaskBoxEx Constructor

TaskBoxEx Constructor
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> TaskBoxExTaskBoxExNew()()
Declaration Syntax
C#
public TaskBoxEx()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


BodyClass Property

BodyClass Property
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> BodyClass
Gets or sets the body class.
Declaration Syntax
C#
public string BodyClass{ get; set;}
Value
The body class.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Collapse Method

Collapse Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> Collapse()()
Declaration Syntax
C#
protected void Collapse()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Collapsed Property

Collapsed Property
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> Collapsed
Gets or sets a value indicating whether this TaskBoxEx is collapsed.
Declaration Syntax
C#
public bool Collapsed{ get; set;}
Value
true if collapsed; otherwise, false.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HeaderClass Property

HeaderClass Property
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> HeaderClass
Gets or sets the header class.
Declaration Syntax
C#
public string HeaderClass{ get; set;}
Value
The header class.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Icon Property

Icon Property
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> Icon
Gets or sets the icon.
Declaration Syntax
C#
public string Icon{ get; set;}
Value
The icon.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.Web.UI.XslControls Namespace

MSS.Web.UI.XslControls Namespace
Namespaces >> MSS.Web.UI.XslControls
Declaration Syntax
C#
namespace MSS.Web.UI.XslControls
Types
All Types Classes
Icon | Type | Description
 | Breadcrumb | Renders breadcrumb.
 | DictionaryLink | Dictionary link
 | Flash | Renders the flash on the page.
 | Html | WebUI Xsl controls application.
 | Image | Display an image on the page.
 | Label | Dictionary label xsl control. Renders label and inserts result in xslt.
 | Link | Link xsl control.
 | Text | Renders text from a field.
 | XslControl | Base type for all xsl controls.


Breadcrumb Class

Breadcrumb Class
Namespaces >> MSS.Web.UI.XslControls >> Breadcrumb
Renders breadcrumb.
Declaration Syntax
C#
public class Breadcrumb : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BreadcrumbBreadcrumbNew()() |
 | AddParameters(XmlNode, XmlNode) | Adds the parameters. (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolXslParameter(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXslParameter(XmlNode, String) | (Inherited from XslControl.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Overrides XslControl.PreprocessControl(XmlNode, IXslControlContainer).)
 | Render(NameValueCollection, Item) | (Inherited from XslControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | XslControl
 |  |  | Breadcrumb

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Breadcrumb Constructor

Breadcrumb Constructor
Namespaces >> MSS.Web.UI.XslControls >> Breadcrumb >> BreadcrumbBreadcrumbNew()()
Declaration Syntax
C#
public Breadcrumb()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreprocessControl Method (controlNode, container)

PreprocessControl Method (controlNode, container)
Namespaces >> MSS.Web.UI.XslControls >> Breadcrumb >> PreprocessControl(XmlNode, IXslControlContainer)
Declaration Syntax
C#
public override XmlNode PreprocessControl(
    XmlNode controlNode,
    IXslControlContainer container
)
Parameters
controlNode (XmlNode)
container (IXslControlContainer)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryLink Class

DictionaryLink Class
Namespaces >> MSS.Web.UI.XslControls >> DictionaryLink
Dictionary link
Declaration Syntax
C#
public class DictionaryLink : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DictionaryLinkDictionaryLinkNew()() |
 | AddParameters(XmlNode, XmlNode) | (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Inherited from XslControl.)
 | Render(NameValueCollection, Item) | (Overrides XslControl.Render(NameValueCollection, Item).)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | DictionaryLink

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DictionaryLink Constructor

DictionaryLink Constructor
Namespaces >> MSS.Web.UI.XslControls >> DictionaryLink >> DictionaryLinkDictionaryLinkNew()()
Declaration Syntax
C#
public DictionaryLink()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (parameters, itm)

Render Method (parameters, itm)
Namespaces >> MSS.Web.UI.XslControls >> DictionaryLink >> Render(NameValueCollection, Item)
Declaration Syntax
C#
public override string Render(
    NameValueCollection parameters,
    Item itm
)
Parameters
parameters (NameValueCollection)
itm (Item)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Flash Class

Flash Class
Namespaces >> MSS.Web.UI.XslControls >> Flash
Renders the flash on the page.
Declaration Syntax
C#
public class Flash : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FlashFlashNew()() |
 | AddParameters(XmlNode, XmlNode) | Adds the parameters. (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolXslParameter(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXslParameter(XmlNode, String) | (Inherited from XslControl.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Overrides XslControl.PreprocessControl(XmlNode, IXslControlContainer).)
 | Render(NameValueCollection, Item) | (Inherited from XslControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | XslControl
 |  |  | Flash

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Flash Constructor

Flash Constructor
Namespaces >> MSS.Web.UI.XslControls >> Flash >> FlashFlashNew()()
Declaration Syntax
C#
public Flash()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreprocessControl Method (controlNode, container)

PreprocessControl Method (controlNode, container)
Namespaces >> MSS.Web.UI.XslControls >> Flash >> PreprocessControl(XmlNode, IXslControlContainer)
Declaration Syntax
C#
public override XmlNode PreprocessControl(
    XmlNode controlNode,
    IXslControlContainer container
)
Parameters
controlNode (XmlNode)
container (IXslControlContainer)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Html Class

Html Class
Namespaces >> MSS.Web.UI.XslControls >> Html
WebUI Xsl controls application.
Declaration Syntax
C#
public class Html : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HtmlHtmlNew()() |
 | AddParameters(XmlNode, XmlNode) | Adds the parameters. (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolXslParameter(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXslParameter(XmlNode, String) | (Inherited from XslControl.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Overrides XslControl.PreprocessControl(XmlNode, IXslControlContainer).)
 | Render(NameValueCollection, Item) | (Inherited from XslControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | XslControl
 |  |  | Html

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Html Constructor

Html Constructor
Namespaces >> MSS.Web.UI.XslControls >> Html >> HtmlHtmlNew()()
Declaration Syntax
C#
public Html()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreprocessControl Method (controlNode, container)

PreprocessControl Method (controlNode, container)
Namespaces >> MSS.Web.UI.XslControls >> Html >> PreprocessControl(XmlNode, IXslControlContainer)
Declaration Syntax
C#
public override XmlNode PreprocessControl(
    XmlNode controlNode,
    IXslControlContainer container
)
Parameters
controlNode (XmlNode)
container (IXslControlContainer)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Image Class

Image Class
Namespaces >> MSS.Web.UI.XslControls >> Image
Display an image on the page.
Declaration Syntax
C#
public class Image : Image
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ImageImageNew()() |
 | AddParameters(XmlNode, XmlNode) | (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Overrides Image.PreprocessControl(XmlNode, IXslControlContainer).)
 | Render(NameValueCollection, Item) | (Inherited from XslControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | Image
 |  |  | Image

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Image Constructor

Image Constructor
Namespaces >> MSS.Web.UI.XslControls >> Image >> ImageImageNew()()
Declaration Syntax
C#
public Image()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreprocessControl Method (controlNode, container)

PreprocessControl Method (controlNode, container)
Namespaces >> MSS.Web.UI.XslControls >> Image >> PreprocessControl(XmlNode, IXslControlContainer)
Declaration Syntax
C#
public override XmlNode PreprocessControl(
    XmlNode controlNode,
    IXslControlContainer container
)
Parameters
controlNode (XmlNode)
container (IXslControlContainer)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Label Class

Label Class
Namespaces >> MSS.Web.UI.XslControls >> Label
Dictionary label xsl control. Renders label and inserts result in xslt.
Declaration Syntax
C#
public class Label : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LabelLabelNew()() |
 | AddParameters(XmlNode, XmlNode) | (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Inherited from XslControl.)
 | Render(NameValueCollection, Item) | (Overrides XslControl.Render(NameValueCollection, Item).)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | Label

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Label Constructor

Label Constructor
Namespaces >> MSS.Web.UI.XslControls >> Label >> LabelLabelNew()()
Declaration Syntax
C#
public Label()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Render Method (parameters, itm)

Render Method (parameters, itm)
Namespaces >> MSS.Web.UI.XslControls >> Label >> Render(NameValueCollection, Item)
Declaration Syntax
C#
public override string Render(
    NameValueCollection parameters,
    Item itm
)
Parameters
parameters (NameValueCollection)
itm (Item)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Link Class

Link Class
Namespaces >> MSS.Web.UI.XslControls >> Link
Link xsl control.
Declaration Syntax
C#
public class Link : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LinkLinkNew()() |
 | AddParameters(XmlNode, XmlNode) | Adds the parameters. (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolXslParameter(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXslParameter(XmlNode, String) | (Inherited from XslControl.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Overrides XslControl.PreprocessControl(XmlNode, IXslControlContainer).)
 | Render(NameValueCollection, Item) | (Inherited from XslControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | XslControl
 |  |  | Link

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Link Constructor

Link Constructor
Namespaces >> MSS.Web.UI.XslControls >> Link >> LinkLinkNew()()
Declaration Syntax
C#
public Link()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreprocessControl Method (controlNode, container)

PreprocessControl Method (controlNode, container)
Namespaces >> MSS.Web.UI.XslControls >> Link >> PreprocessControl(XmlNode, IXslControlContainer)
Declaration Syntax
C#
public override XmlNode PreprocessControl(
    XmlNode controlNode,
    IXslControlContainer container
)
Parameters
controlNode (XmlNode)
container (IXslControlContainer)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Text Class

Text Class
Namespaces >> MSS.Web.UI.XslControls >> Text
Renders text from a field.
Declaration Syntax
C#
public class Text : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TextTextNew()() |
 | AddParameters(XmlNode, XmlNode) | Adds the parameters. (Inherited from XslControl.)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolXslParameter(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXslParameter(XmlNode, String) | (Inherited from XslControl.)
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Overrides XslControl.PreprocessControl(XmlNode, IXslControlContainer).)
 | Render(NameValueCollection, Item) | (Inherited from XslControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | XslControl
 |  |  | Text

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Text Constructor

Text Constructor
Namespaces >> MSS.Web.UI.XslControls >> Text >> TextTextNew()()
Declaration Syntax
C#
public Text()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreprocessControl Method (controlNode, container)

PreprocessControl Method (controlNode, container)
Namespaces >> MSS.Web.UI.XslControls >> Text >> PreprocessControl(XmlNode, IXslControlContainer)
Declaration Syntax
C#
public override XmlNode PreprocessControl(
    XmlNode controlNode,
    IXslControlContainer container
)
Parameters
controlNode (XmlNode)
container (IXslControlContainer)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XslControl Class

XslControl Class
Namespaces >> MSS.Web.UI.XslControls >> XslControl
Base type for all xsl controls.
Declaration Syntax
C#
public class XslControl : XslControl
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XslControlXslControlNew()() |
 | AddParameters(XmlNode, XmlNode) | Adds the parameters. (Overrides XslControl.AddParameters(XmlNode, XmlNode).)
 | BuildParameterString(SafeDictionary<(Of <String>)>) | (Inherited from XslControl.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBoolXslParameter(XmlNode, String, Boolean) |
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMethodCall(XmlNode, String, Boolean) | (Overrides XslControl.GetMethodCall(XmlNode, String, Boolean).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXslParameter(XmlNode, String) |
 | InitializeControl(NameValueCollection) | (Inherited from XslControl.)
 | InsertMethodCall(XmlNode, String, Boolean) | (Inherited from XslControl.)
 | InsertValueNode(XmlNode, String, Boolean) | (Overrides XslControl.InsertValueNode(XmlNode, String, Boolean).)
 | InsertValueNode(XmlNode, String, Boolean, Boolean) | (Inherited from XslControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreprocessControl(XmlNode, IXslControlContainer) | (Inherited from XslControl.)
 | Render(NameValueCollection, Item) | (Inherited from XslControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XslControl
 |  | XslControl
 |  |  | Link
 |  |  | Html
 |  |  | Breadcrumb
 |  |  | Text
 |  |  | Flash

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XslControl Constructor

XslControl Constructor
Namespaces >> MSS.Web.UI.XslControls >> XslControl >> XslControlXslControlNew()()
Declaration Syntax
C#
public XslControl()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddParameters Method (tagNode, controlNode)

AddParameters Method (tagNode, controlNode)
Namespaces >> MSS.Web.UI.XslControls >> XslControl >> AddParameters(XmlNode, XmlNode)
Adds the parameters.
Declaration Syntax
C#
protected override void AddParameters(
    XmlNode tagNode,
    XmlNode controlNode
)
Parameters
tagNode (XmlNode)
The tag node.
controlNode (XmlNode)
The control node.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetBoolXslParameter Method (node, key, defaultValue)

GetBoolXslParameter Method (node, key, defaultValue)
Namespaces >> MSS.Web.UI.XslControls >> XslControl >> GetBoolXslParameter(XmlNode, String, Boolean)
Declaration Syntax
C#
protected string GetBoolXslParameter(
    XmlNode node,
    string key,
    bool defaultValue
)
Parameters
node (XmlNode)
key (String)
defaultValue (Boolean)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetMethodCall Method (controlNode, function, disableOutputEscaping)

GetMethodCall Method (controlNode, function, disableOutputEscaping)
Namespaces >> MSS.Web.UI.XslControls >> XslControl >> GetMethodCall(XmlNode, String, Boolean)
Declaration Syntax
C#
public override XmlNode GetMethodCall(
    XmlNode controlNode,
    string function,
    bool disableOutputEscaping
)
Parameters
controlNode (XmlNode)
function (String)
disableOutputEscaping (Boolean)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetXslParameter Method (node, key)

GetXslParameter Method (node, key)
Namespaces >> MSS.Web.UI.XslControls >> XslControl >> GetXslParameter(XmlNode, String)
Declaration Syntax
C#
protected string GetXslParameter(
    XmlNode node,
    string key
)
Parameters
node (XmlNode)
key (String)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InsertValueNode Method (controlNode, function, disableOutputEscaping)

InsertValueNode Method (controlNode, function, disableOutputEscaping)
Namespaces >> MSS.Web.UI.XslControls >> XslControl >> InsertValueNode(XmlNode, String, Boolean)
Declaration Syntax
C#
public override XmlNode InsertValueNode(
    XmlNode controlNode,
    string function,
    bool disableOutputEscaping
)
Parameters
controlNode (XmlNode)
function (String)
disableOutputEscaping (Boolean)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebEngine Namespace

MSS.WebEngine Namespace
Namespaces >> MSS.WebEngine
Declaration Syntax
C#
namespace MSS.WebEngine
Types
All Types Classes
Icon | Type | Description
 | Engine | Web engine.


Engine Class

Engine Class
Namespaces >> MSS.WebEngine >> Engine
Web engine.
Declaration Syntax
C#
public static class Engine
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AppendQueryPair(String, String, String) | Appends the query parameter to the url.
 | ConfirmationPage | Returns the URL of the sitemap document
 | ContactDocument | Returns the URL of the Contact form document
 | Context | Gets the HttpContext.
 | GetContactDocumentItem()() | Gets the contact document item.
 | GetCurrentPage()() | Gets the current page.
 | GetGlobalDocument(String) | Gets the global document.
 | GetGlobalDocumentUrl(String) | Gets the global document URL.
 | GetGlobalItem()() | Gets the global item.
 | GetLoginDocumentItem()() | Gets the login document item.
 | GetLogoutDocumentItem()() | Gets the logout document item.
 | GetSiteMapDocumentItem()() | Gets the site map document item.
 | LanguageDocument | Returns the URL of the language selection document
 | LoginDocument | Returns the URL of the login document
 | LogoutDocument | Returns the URL of the logout document
 | PrintDocument | Returns the URL of the print friendly page
 | Redirect(String) | Redirects to the specified URL.
 | Redirect(String, Boolean) | Redirects to the specified URL.
 | RedirectToHomePage()() | Redirects to site's home page.
 | RedirectToLoginPage()() | Redirects to login page.
 | RedirectToLoginPage(Boolean) | Redirects to login page.
 | Request | Gets the HttpRequest.
 | Response | Gets the HttpResponse.
 | Return()() | Returns to the previous page.
 | SearchResultsDocument | Returns the URL of the search results document
 | SitemapDocument | Returns the URL of the sitemap document
 | SpotsDocument | Gets the spots document.
 | UrlEncode(String) | Encodes an url.
Inheritance Hierarchy
Object
Engine

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AppendQueryPair Method (url, key, value)

AppendQueryPair Method (url, key, value)
Namespaces >> MSS.WebEngine >> Engine >> AppendQueryPair(String, String, String)
Appends the query parameter to the url.
Declaration Syntax
C#
public static string AppendQueryPair(
    string url,
    string key,
    string value
)
Parameters
url (String)
The URL.
key (String)
The key.
value (String)
The value.
Return Value
The URL with the query parameter appended.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ConfirmationPage Property

ConfirmationPage Property
Namespaces >> MSS.WebEngine >> Engine >> ConfirmationPage
Returns the URL of the sitemap document
Declaration Syntax
C#
public static string ConfirmationPage{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ContactDocument Property

ContactDocument Property
Namespaces >> MSS.WebEngine >> Engine >> ContactDocument
Returns the URL of the Contact form document
Declaration Syntax
C#
public static string ContactDocument{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Context Property

Context Property
Namespaces >> MSS.WebEngine >> Engine >> Context
Gets the HttpContext.
Declaration Syntax
C#
public static HttpContext Context{ get;}
Value
The context.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetContactDocumentItem Method

GetContactDocumentItem Method
Namespaces >> MSS.WebEngine >> Engine >> GetContactDocumentItem()()
Gets the contact document item.
Declaration Syntax
C#
public static Item GetContactDocumentItem()
Return Value
The contact document.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetCurrentPage Method

GetCurrentPage Method
Namespaces >> MSS.WebEngine >> Engine >> GetCurrentPage()()
Gets the current page.
Declaration Syntax
C#
public static SitePage GetCurrentPage()
Return Value
The current page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalDocument Method (documentName)

GetGlobalDocument Method (documentName)
Namespaces >> MSS.WebEngine >> Engine >> GetGlobalDocument(String)
Gets the global document.
Declaration Syntax
C#
public static Item GetGlobalDocument(
    string documentName
)
Parameters
documentName (String)
Name of the document.
Return Value
The global document.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalDocumentUrl Method (documentName)

GetGlobalDocumentUrl Method (documentName)
Namespaces >> MSS.WebEngine >> Engine >> GetGlobalDocumentUrl(String)
Gets the global document URL.
Declaration Syntax
C#
public static string GetGlobalDocumentUrl(
    string documentName
)
Parameters
documentName (String)
Name of the document.
Return Value
The global document URL.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalItem Method

GetGlobalItem Method
Namespaces >> MSS.WebEngine >> Engine >> GetGlobalItem()()
Gets the global item.
Declaration Syntax
C#
public static Item GetGlobalItem()
Return Value
The global item.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLoginDocumentItem Method

GetLoginDocumentItem Method
Namespaces >> MSS.WebEngine >> Engine >> GetLoginDocumentItem()()
Gets the login document item.
Declaration Syntax
C#
public static Item GetLoginDocumentItem()
Return Value
The login document.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLogoutDocumentItem Method

GetLogoutDocumentItem Method
Namespaces >> MSS.WebEngine >> Engine >> GetLogoutDocumentItem()()
Gets the logout document item.
Declaration Syntax
C#
public static Item GetLogoutDocumentItem()
Return Value
The logout document.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetSiteMapDocumentItem Method

GetSiteMapDocumentItem Method
Namespaces >> MSS.WebEngine >> Engine >> GetSiteMapDocumentItem()()
Gets the site map document item.
Declaration Syntax
C#
public static Item GetSiteMapDocumentItem()
Return Value
The site map document.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LanguageDocument Property

LanguageDocument Property
Namespaces >> MSS.WebEngine >> Engine >> LanguageDocument
Returns the URL of the language selection document
Declaration Syntax
C#
public static string LanguageDocument{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoginDocument Property

LoginDocument Property
Namespaces >> MSS.WebEngine >> Engine >> LoginDocument
Returns the URL of the login document
Declaration Syntax
C#
public static string LoginDocument{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LogoutDocument Property

LogoutDocument Property
Namespaces >> MSS.WebEngine >> Engine >> LogoutDocument
Returns the URL of the logout document
Declaration Syntax
C#
public static string LogoutDocument{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PrintDocument Property

PrintDocument Property
Namespaces >> MSS.WebEngine >> Engine >> PrintDocument
Returns the URL of the print friendly page
Declaration Syntax
C#
public static string PrintDocument{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Redirect Method

Redirect Method
Namespaces >> MSS.WebEngine >> Engine >> Redirect()()
Members
Icon | Member | Description
 | Redirect(String) | Redirects to the specified URL.
 | Redirect(String, Boolean) | Redirects to the specified URL.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Redirect Method (url)

Redirect Method (url)
Namespaces >> MSS.WebEngine >> Engine >> Redirect(String)
Redirects to the specified URL.
Declaration Syntax
C#
public static void Redirect(
    string url
)
Parameters
url (String)
The URL.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Redirect Method (url, endResponse)

Redirect Method (url, endResponse)
Namespaces >> MSS.WebEngine >> Engine >> Redirect(String, Boolean)
Redirects to the specified URL.
Declaration Syntax
C#
public static void Redirect(
    string url,
    bool endResponse
)
Parameters
url (String)
The URL.
endResponse (Boolean)
if set to true [end response].

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RedirectToHomePage Method

RedirectToHomePage Method
Namespaces >> MSS.WebEngine >> Engine >> RedirectToHomePage()()
Redirects to site's home page.
Declaration Syntax
C#
public static void RedirectToHomePage()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RedirectToLoginPage Method

RedirectToLoginPage Method
Namespaces >> MSS.WebEngine >> Engine >> RedirectToLoginPage()()
Members
Icon | Member | Description
 | RedirectToLoginPage()() | Redirects to login page.
 | RedirectToLoginPage(Boolean) | Redirects to login page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RedirectToLoginPage Method

RedirectToLoginPage Method
Namespaces >> MSS.WebEngine >> Engine >> RedirectToLoginPage()()
Redirects to login page.
Declaration Syntax
C#
public static void RedirectToLoginPage()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RedirectToLoginPage Method (endResponse)

RedirectToLoginPage Method (endResponse)
Namespaces >> MSS.WebEngine >> Engine >> RedirectToLoginPage(Boolean)
Redirects to login page.
Declaration Syntax
C#
public static void RedirectToLoginPage(
    bool endResponse
)
Parameters
endResponse (Boolean)
if set to true [end response].

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Request Property

Request Property
Namespaces >> MSS.WebEngine >> Engine >> Request
Gets the HttpRequest.
Declaration Syntax
C#
public static HttpRequest Request{ get;}
Value
The request.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Response Property

Response Property
Namespaces >> MSS.WebEngine >> Engine >> Response
Gets the HttpResponse.
Declaration Syntax
C#
public static HttpResponse Response{ get;}
Value
The response.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Return Method

Return Method
Namespaces >> MSS.WebEngine >> Engine >> Return()()
Returns to the previous page.
Declaration Syntax
C#
public static void Return()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SearchResultsDocument Property

SearchResultsDocument Property
Namespaces >> MSS.WebEngine >> Engine >> SearchResultsDocument
Returns the URL of the search results document
Declaration Syntax
C#
public static string SearchResultsDocument{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SitemapDocument Property

SitemapDocument Property
Namespaces >> MSS.WebEngine >> Engine >> SitemapDocument
Returns the URL of the sitemap document
Declaration Syntax
C#
public static string SitemapDocument{ get;}

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SpotsDocument Property

SpotsDocument Property
Namespaces >> MSS.WebEngine >> Engine >> SpotsDocument
Gets the spots document.
Declaration Syntax
C#
public static string SpotsDocument{ get;}
Value
The spots document.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


UrlEncode Method (url)

UrlEncode Method (url)
Namespaces >> MSS.WebEngine >> Engine >> UrlEncode(String)
Encodes an url.
Declaration Syntax
C#
public static string UrlEncode(
    string url
)
Parameters
url (String)
The URL.
Return Value
The encoded URL.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebEngine.Commands Namespace

MSS.WebEngine.Commands Namespace
Namespaces >> MSS.WebEngine.Commands
Declaration Syntax
C#
namespace MSS.WebEngine.Commands
Types
All Types Classes
Icon | Type | Description
 | PreviewItem | Shows an item in preview mode.


PreviewItem Class

PreviewItem Class
Namespaces >> MSS.WebEngine.Commands >> PreviewItem
Shows an item in preview mode.
Declaration Syntax
C#
public class PreviewItem : PreviewItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreviewItemPreviewItemNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Executes the command. (Overrides PreviewItem.Execute(CommandContext).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | (Inherited from Command.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | Queries the state of the command. (Overrides PreviewItem.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PreviewItem
 |  |  | PreviewItem

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreviewItem Constructor

PreviewItem Constructor
Namespaces >> MSS.WebEngine.Commands >> PreviewItem >> PreviewItemPreviewItemNew()()
Declaration Syntax
C#
public PreviewItem()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Execute Method (context)

Execute Method (context)
Namespaces >> MSS.WebEngine.Commands >> PreviewItem >> Execute(CommandContext)
Executes the command.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The context.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


QueryState Method (context)

QueryState Method (context)
Namespaces >> MSS.WebEngine.Commands >> PreviewItem >> QueryState(CommandContext)
Queries the state of the command.
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)
The context.
Return Value
The state of the command.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebEngine.Framework Namespace

MSS.WebEngine.Framework Namespace
Namespaces >> MSS.WebEngine.Framework
Declaration Syntax
C#
namespace MSS.WebEngine.Framework
Types
All Types Classes
Icon | Type | Description
 | Items |


Items Class

Items Class
Namespaces >> MSS.WebEngine.Framework >> Items
Declaration Syntax
C#
public static class Items
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PreviewItem(Item) | Displays an item in the preview mode.
Inheritance Hierarchy
Object
Items

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreviewItem Method (item)

PreviewItem Method (item)
Namespaces >> MSS.WebEngine.Framework >> Items >> PreviewItem(Item)
Displays an item in the preview mode.
Declaration Syntax
C#
public static void PreviewItem(
    Item item
)
Parameters
item (Item)
The item

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebEngine.Framework.Commands Namespace

MSS.WebEngine.Framework.Commands Namespace
Namespaces >> MSS.WebEngine.Framework.Commands
Declaration Syntax
C#
namespace MSS.WebEngine.Framework.Commands
Types
All Types Classes
Icon | Type | Description
 | EditImage | Manage EditImage button in Media Library. Enable EditImage button for site preview.
 | PublishItemNow | Manage visibility of "Publish" button which has a sub menu with two items: "Publish Item" and "Publish Site"
 | PublishItemNowSecond | Manage visibility of "Publish" button which has a sub menu with one item - "Publish Site"
 | SystemPublish | This class has the advantage that if we have logged in as a local user "system:publish" should provide publishing only for the related local site
 | WebEdit | Starts web edit.


EditImage Class

EditImage Class
Namespaces >> MSS.WebEngine.Framework.Commands >> EditImage
Manage EditImage button in Media Library. Enable EditImage button for site preview.
Declaration Syntax
C#
public class EditImage : EditImage
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditImageEditImageNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | (Inherited from EditImage.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | (Inherited from Command.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | (Overrides EditImage.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | EditImage
 |  |  | EditImage

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


EditImage Constructor

EditImage Constructor
Namespaces >> MSS.WebEngine.Framework.Commands >> EditImage >> EditImageEditImageNew()()
Declaration Syntax
C#
public EditImage()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


QueryState Method (context)

QueryState Method (context)
Namespaces >> MSS.WebEngine.Framework.Commands >> EditImage >> QueryState(CommandContext)
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PublishItemNow Class

PublishItemNow Class
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNow
Manage visibility of "Publish" button which has a sub menu with two items: "Publish Item" and "Publish Site"
Declaration Syntax
C#
public class PublishItemNow : PublishNow
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishItemNowPublishItemNowNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | (Inherited from PublishNow.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | (Inherited from Command.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | (Overrides PublishNow.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) | (Inherited from PublishNow.)
 | secondButton |
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PublishNow
 |  |  | PublishItemNow
 |  |  |  | PublishItemNowSecond

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PublishItemNow Constructor

PublishItemNow Constructor
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNow >> PublishItemNowPublishItemNowNew()()
Declaration Syntax
C#
public PublishItemNow()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


QueryState Method (context)

QueryState Method (context)
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNow >> QueryState(CommandContext)
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


secondButton Field

secondButton Field
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNow >> secondButton
Declaration Syntax
C#
protected bool secondButton

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PublishItemNowSecond Class

PublishItemNowSecond Class
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNowSecond
Manage visibility of "Publish" button which has a sub menu with one item - "Publish Site"
Declaration Syntax
C#
public class PublishItemNowSecond : PublishItemNow
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishItemNowSecondPublishItemNowSecondNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | (Inherited from PublishNow.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | (Inherited from Command.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | (Inherited from PublishItemNow.)
 | Run(ClientPipelineArgs) | (Inherited from PublishNow.)
 | secondButton | (Inherited from PublishItemNow.)
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | PublishNow
 |  |  | PublishItemNow
 |  |  |  | PublishItemNowSecond

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PublishItemNowSecond Constructor

PublishItemNowSecond Constructor
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNowSecond >> PublishItemNowSecondPublishItemNowSecondNew()()
Declaration Syntax
C#
public PublishItemNowSecond()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SystemPublish Class

SystemPublish Class
Namespaces >> MSS.WebEngine.Framework.Commands >> SystemPublish
This class has the advantage that if we have logged in as a local user "system:publish" should provide publishing only for the related local site
Declaration Syntax
C#
public class SystemPublish : Publish
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SystemPublishSystemPublishNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | (Overrides Publish.Execute(CommandContext).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | (Inherited from Command.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | (Inherited from Publish.)
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | Publish
 |  |  | SystemPublish

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SystemPublish Constructor

SystemPublish Constructor
Namespaces >> MSS.WebEngine.Framework.Commands >> SystemPublish >> SystemPublishSystemPublishNew()()
Declaration Syntax
C#
public SystemPublish()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Execute Method (context)

Execute Method (context)
Namespaces >> MSS.WebEngine.Framework.Commands >> SystemPublish >> Execute(CommandContext)
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WebEdit Class

WebEdit Class
Namespaces >> MSS.WebEngine.Framework.Commands >> WebEdit
Starts web edit.
Declaration Syntax
C#
public class WebEdit : WebEdit
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WebEditWebEditNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | Opens a item in the web edit mode. (Overrides WebEdit.Execute(CommandContext).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | (Inherited from Command.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | (Overrides Command.QueryState(CommandContext).)
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | WebEdit
 |  |  | WebEdit

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WebEdit Constructor

WebEdit Constructor
Namespaces >> MSS.WebEngine.Framework.Commands >> WebEdit >> WebEditWebEditNew()()
Declaration Syntax
C#
public WebEdit()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Execute Method (context)

Execute Method (context)
Namespaces >> MSS.WebEngine.Framework.Commands >> WebEdit >> Execute(CommandContext)
Opens a item in the web edit mode.
Declaration Syntax
C#
public override void Execute(
    CommandContext context
)
Parameters
context (CommandContext)
The command context

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


QueryState Method (context)

QueryState Method (context)
Namespaces >> MSS.WebEngine.Framework.Commands >> WebEdit >> QueryState(CommandContext)
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebEngine.Framework.Commands.ContentEditor Namespace

MSS.WebEngine.Framework.Commands.ContentEditor Namespace
Namespaces >> MSS.WebEngine.Framework.Commands.ContentEditor
Declaration Syntax
C#
namespace MSS.WebEngine.Framework.Commands.ContentEditor
Types
All Types Classes
Icon | Type | Description
 | CheckIn |


CheckIn Class

CheckIn Class
Namespaces >> MSS.WebEngine.Framework.Commands.ContentEditor >> CheckIn
Declaration Syntax
C#
public class CheckIn : CheckIn
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckInCheckInNew()() |
 | DeserializeItems(String) | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(CommandContext) | (Inherited from CheckIn.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClick(CommandContext, String) | (Inherited from Command.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeader(CommandContext, String) | (Inherited from Command.)
 | GetIcon(CommandContext, String) | (Inherited from Command.)
 | GetSubmenuItems(CommandContext) | (Inherited from Command.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasField(Item, ID) | (Inherited from Command.)
 | HasField(Item, String) | (Inherited from Command.)
 | IsAdvancedClient()() | (Inherited from Command.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name()() | (Inherited from Command.)
 | QueryState(CommandContext) | (Overrides CheckIn.QueryState(CommandContext).)
 | Run(ClientPipelineArgs) |
 | SerializeItems(array<Item>[]()) | (Inherited from Command.)
 | Start(String, Item) | (Inherited from Command.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Command
 |  | CheckIn
 |  |  | CheckIn

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CheckIn Constructor

CheckIn Constructor
Namespaces >> MSS.WebEngine.Framework.Commands.ContentEditor >> CheckIn >> CheckInCheckInNew()()
Declaration Syntax
C#
public CheckIn()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


QueryState Method (context)

QueryState Method (context)
Namespaces >> MSS.WebEngine.Framework.Commands.ContentEditor >> CheckIn >> QueryState(CommandContext)
Declaration Syntax
C#
public override CommandState QueryState(
    CommandContext context
)
Parameters
context (CommandContext)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Run Method (args)

Run Method (args)
Namespaces >> MSS.WebEngine.Framework.Commands.ContentEditor >> CheckIn >> Run(ClientPipelineArgs)
Declaration Syntax
C#
protected void Run(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebEngine.Web.PageExtenders Namespace

MSS.WebEngine.Web.PageExtenders Namespace
Namespaces >> MSS.WebEngine.Web.PageExtenders
Declaration Syntax
C#
namespace MSS.WebEngine.Web.PageExtenders
Types
All Types Classes
Icon | Type | Description
 | Debugger | Summary: Adds debugger control to a page which has no HidePageExtendersAttribute attribute.
 | ExtenderWrapper<(Of <InnerExtender>)> | Wrap a page extender to hide them if pages have a HidePageExtendersAttribute attribute.
 | HidePageExtendersAttribute | The page extenders aren't displayed on the page with this attributes.
 | PreviewPageExtender | Adds a preview control to a page which has no HidePageExtendersAttribute attribute
 | WebEditPageExtender | Adds web edit control to a page which has no HidePageExtendersAttribute attribute


Debugger Class

Debugger Class
Namespaces >> MSS.WebEngine.Web.PageExtenders >> Debugger
Summary: Adds debugger control to a page which has no HidePageExtendersAttribute attribute.
Declaration Syntax
C#
public class Debugger : ExtenderWrapper<Debugger>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DebuggerDebuggerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()() | Inserts inner extender to the page. (Inherited from ExtenderWrapper<(Of <InnerExtender>)>.)
 | InsertControl(Control) | (Inherited from PageExtender.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | ExtenderWrapper <(Of <Debugger>)>
 |  |  | Debugger

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Debugger Constructor

Debugger Constructor
Namespaces >> MSS.WebEngine.Web.PageExtenders >> Debugger >> DebuggerDebuggerNew()()
Declaration Syntax
C#
public Debugger()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ExtenderWrapper Class

ExtenderWrapper<(Of <InnerExtender>)> Class
Namespaces >> MSS.WebEngine.Web.PageExtenders >> ExtenderWrapper<(Of <InnerExtender>)>
Wrap a page extender to hide them if pages have a HidePageExtendersAttribute attribute.
Declaration Syntax
C#
public class ExtenderWrapper<InnerExtender> : PageExtender where InnerExtender : new(), PageExtender
Generic Template Parameters
InnerExtender
The inner extender.
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExtenderWrapper<(Of <InnerExtender>)>ExtenderWrapper<(Of <InnerExtender>)>New()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()() | Inserts inner extender to the page. (Overrides PageExtender.Insert()().)
 | InsertControl(Control) | (Inherited from PageExtender.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | ExtenderWrapper<(Of <InnerExtender>)>
 |  |  | Debugger
 |  |  | WebEditPageExtender
 |  |  | PreviewPageExtender

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ExtenderWrapper Constructor

ExtenderWrapper<(Of <InnerExtender>)> Constructor
Namespaces >> MSS.WebEngine.Web.PageExtenders >> ExtenderWrapper<(Of <InnerExtender>)> >> ExtenderWrapper<(Of <InnerExtender>)>ExtenderWrapper<(Of <InnerExtender>)>New()()
Declaration Syntax
C#
public ExtenderWrapper()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Insert Method

Insert Method
Namespaces >> MSS.WebEngine.Web.PageExtenders >> ExtenderWrapper<(Of <InnerExtender>)> >> Insert()()
Inserts inner extender to the page.
Declaration Syntax
C#
public override void Insert()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HidePageExtendersAttribute Class

HidePageExtendersAttribute Class
Namespaces >> MSS.WebEngine.Web.PageExtenders >> HidePageExtendersAttribute
The page extenders aren't displayed on the page with this attributes.
Declaration Syntax
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class HidePageExtendersAttribute : Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HidePageExtendersAttributeHidePageExtendersAttributeNew()() |
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | _Attribute..::GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | HidePageExtendersAttribute

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HidePageExtendersAttribute Constructor

HidePageExtendersAttribute Constructor
Namespaces >> MSS.WebEngine.Web.PageExtenders >> HidePageExtendersAttribute >> HidePageExtendersAttributeHidePageExtendersAttributeNew()()
Declaration Syntax
C#
public HidePageExtendersAttribute()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreviewPageExtender Class

PreviewPageExtender Class
Namespaces >> MSS.WebEngine.Web.PageExtenders >> PreviewPageExtender
Adds a preview control to a page which has no HidePageExtendersAttribute attribute
Declaration Syntax
C#
public class PreviewPageExtender : ExtenderWrapper<PreviewPageExtender>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PreviewPageExtenderPreviewPageExtenderNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()() | Inserts inner extender to the page. (Inherited from ExtenderWrapper<(Of <InnerExtender>)>.)
 | InsertControl(Control) | (Inherited from PageExtender.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | ExtenderWrapper <(Of <PreviewPageExtender>)>
 |  |  | PreviewPageExtender

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


PreviewPageExtender Constructor

PreviewPageExtender Constructor
Namespaces >> MSS.WebEngine.Web.PageExtenders >> PreviewPageExtender >> PreviewPageExtenderPreviewPageExtenderNew()()
Declaration Syntax
C#
public PreviewPageExtender()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WebEditPageExtender Class

WebEditPageExtender Class
Namespaces >> MSS.WebEngine.Web.PageExtenders >> WebEditPageExtender
Adds web edit control to a page which has no HidePageExtendersAttribute attribute
Declaration Syntax
C#
public sealed class WebEditPageExtender : ExtenderWrapper<WebEditPageExtender>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WebEditPageExtenderWebEditPageExtenderNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert()() | Inserts inner extender to the page. (Inherited from ExtenderWrapper<(Of <InnerExtender>)>.)
 | InsertControl(Control) | (Inherited from PageExtender.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PageExtender
 |  | ExtenderWrapper <(Of <WebEditPageExtender>)>
 |  |  | WebEditPageExtender

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


WebEditPageExtender Constructor

WebEditPageExtender Constructor
Namespaces >> MSS.WebEngine.Web.PageExtenders >> WebEditPageExtender >> WebEditPageExtenderWebEditPageExtenderNew()()
Declaration Syntax
C#
public WebEditPageExtender()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebEngine.Web.UI.Pages.Shell Namespace

MSS.WebEngine.Web.UI.Pages.Shell Namespace
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell
Declaration Syntax
C#
namespace MSS.WebEngine.Web.UI.Pages.Shell
Types
All Types Classes
Icon | Type | Description
 | LoginPage | This class is used for redirect to site login page.


LoginPage Class

LoginPage Class
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage
This class is used for redirect to site login page.
Declaration Syntax
C#
public class LoginPage : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginPageLoginPageNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 |
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | LoginPage

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoginPage Constructor

LoginPage Constructor
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> LoginPageLoginPageNew()()
Declaration Syntax
C#
public LoginPage()

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


form1 Field

form1 Field
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> form1
Declaration Syntax
C#
protected HtmlForm form1

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MSS.WebSite.Components Namespace

MSS.WebSite.Components Namespace
Namespaces >> MSS.WebSite.Components
Declaration Syntax
C#
namespace MSS.WebSite.Components
Types
All Types Classes
Icon | Type | Description
 | ContactForm | Sends contact information to the server
 | SearchSpot | Search form
 | SiteMap | Renders the site map.


ContactForm Class

ContactForm Class
Namespaces >> MSS.WebSite.Components >> ContactForm
Sends contact information to the server
Declaration Syntax
C#
public class ContactForm : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContactFormContactFormNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnSend |
 | btnSend_Click(Object, EventArgs) |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblEmail |
 | lblFirstname |
 | lblMessage |
 | lblPhone |
 | lblRequiredFields |
 | lblSurname |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssWebEngineContactForm |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtEmail |
 | txtFirstname |
 | txtMessage |
 | txtPhone |
 | txtSurname |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valEmail |
 | valFirstname |
 | ValidationSummary1 |
 | valMessage |
 | valSurname |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | ContactForm

Assembly: MSS.WebSite (Module: MSS.WebSite)


ContactForm Constructor

ContactForm Constructor
Namespaces >> MSS.WebSite.Components >> ContactForm >> ContactFormContactFormNew()()
Declaration Syntax
C#
public ContactForm()

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnSend Field

btnSend Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> btnSend
Declaration Syntax
C#
protected Button btnSend

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnSend_Click Method (sender, e)

btnSend_Click Method (sender, e)
Namespaces >> MSS.WebSite.Components >> ContactForm >> btnSend_Click(Object, EventArgs)
Declaration Syntax
C#
protected void btnSend_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblEmail Field

lblEmail Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> lblEmail
Declaration Syntax
C#
protected Label lblEmail

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblFirstname Field

lblFirstname Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> lblFirstname
Declaration Syntax
C#
protected Label lblFirstname

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblMessage Field

lblMessage Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> lblMessage
Declaration Syntax
C#
protected Label lblMessage

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblPhone Field

lblPhone Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> lblPhone
Declaration Syntax
C#
protected Label lblPhone

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblRequiredFields Field

lblRequiredFields Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> lblRequiredFields
Declaration Syntax
C#
protected Label lblRequiredFields

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblSurname Field

lblSurname Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> lblSurname
Declaration Syntax
C#
protected Label lblSurname

Assembly: MSS.WebSite (Module: MSS.WebSite)


MssWebEngineContactForm Field

MssWebEngineContactForm Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> MssWebEngineContactForm
Declaration Syntax
C#
protected Form MssWebEngineContactForm

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.WebSite.Components >> ContactForm >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.WebSite.Components >> ContactForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtEmail Field

txtEmail Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> txtEmail
Declaration Syntax
C#
protected TextBox txtEmail

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtFirstname Field

txtFirstname Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> txtFirstname
Declaration Syntax
C#
protected TextBox txtFirstname

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtMessage Field

txtMessage Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> txtMessage
Declaration Syntax
C#
protected TextBox txtMessage

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtPhone Field

txtPhone Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> txtPhone
Declaration Syntax
C#
protected TextBox txtPhone

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtSurname Field

txtSurname Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> txtSurname
Declaration Syntax
C#
protected TextBox txtSurname

Assembly: MSS.WebSite (Module: MSS.WebSite)


valEmail Field

valEmail Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> valEmail
Declaration Syntax
C#
protected RegularExpressionValidator valEmail

Assembly: MSS.WebSite (Module: MSS.WebSite)


valFirstname Field

valFirstname Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> valFirstname
Declaration Syntax
C#
protected RequiredFieldValidator valFirstname

Assembly: MSS.WebSite (Module: MSS.WebSite)


ValidationSummary1 Field

ValidationSummary1 Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> ValidationSummary1
Declaration Syntax
C#
protected ValidationSummary ValidationSummary1

Assembly: MSS.WebSite (Module: MSS.WebSite)


valMessage Field

valMessage Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> valMessage
Declaration Syntax
C#
protected RequiredFieldValidator valMessage

Assembly: MSS.WebSite (Module: MSS.WebSite)


valSurname Field

valSurname Field
Namespaces >> MSS.WebSite.Components >> ContactForm >> valSurname
Declaration Syntax
C#
protected RequiredFieldValidator valSurname

Assembly: MSS.WebSite (Module: MSS.WebSite)


SearchSpot Class

SearchSpot Class
Namespaces >> MSS.WebSite.Components >> SearchSpot
Search form
Declaration Syntax
C#
public class SearchSpot : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchSpotSearchSpotNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Box |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblEmpy |
 | lblSearchHeader |
 | LinkButton |
 | LinkButton_Click(Object, EventArgs) |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtInput |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valInput |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SearchSpot

Assembly: MSS.WebSite (Module: MSS.WebSite)


SearchSpot Constructor

SearchSpot Constructor
Namespaces >> MSS.WebSite.Components >> SearchSpot >> SearchSpotSearchSpotNew()()
Declaration Syntax
C#
public SearchSpot()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Box Field

Box Field
Namespaces >> MSS.WebSite.Components >> SearchSpot >> Box
Declaration Syntax
C#
protected HtmlGenericControl Box

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblEmpy Field

lblEmpy Field
Namespaces >> MSS.WebSite.Components >> SearchSpot >> lblEmpy
Declaration Syntax
C#
protected Label lblEmpy

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblSearchHeader Field

lblSearchHeader Field
Namespaces >> MSS.WebSite.Components >> SearchSpot >> lblSearchHeader
Declaration Syntax
C#
protected Label lblSearchHeader

Assembly: MSS.WebSite (Module: MSS.WebSite)


LinkButton Field

LinkButton Field
Namespaces >> MSS.WebSite.Components >> SearchSpot >> LinkButton
Declaration Syntax
C#
protected Link LinkButton

Assembly: MSS.WebSite (Module: MSS.WebSite)


LinkButton_Click Method (sender, e)

LinkButton_Click Method (sender, e)
Namespaces >> MSS.WebSite.Components >> SearchSpot >> LinkButton_Click(Object, EventArgs)
Declaration Syntax
C#
protected void LinkButton_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebSite.Components >> SearchSpot >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtInput Field

txtInput Field
Namespaces >> MSS.WebSite.Components >> SearchSpot >> txtInput
Declaration Syntax
C#
protected TextBox txtInput

Assembly: MSS.WebSite (Module: MSS.WebSite)


valInput Field

valInput Field
Namespaces >> MSS.WebSite.Components >> SearchSpot >> valInput
Declaration Syntax
C#
protected RequiredFieldValidator valInput

Assembly: MSS.WebSite (Module: MSS.WebSite)


SiteMap Class

SiteMap Class
Namespaces >> MSS.WebSite.Components >> SiteMap
Renders the site map.
Declaration Syntax
C#
public class SiteMap : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteMapSiteMapNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MSS_WebEngine_Sitemap |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | SiteMap

Assembly: MSS.WebSite (Module: MSS.WebSite)


SiteMap Constructor

SiteMap Constructor
Namespaces >> MSS.WebSite.Components >> SiteMap >> SiteMapSiteMapNew()()
Declaration Syntax
C#
public SiteMap()

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS_WebEngine_Sitemap Field

MSS_WebEngine_Sitemap Field
Namespaces >> MSS.WebSite.Components >> SiteMap >> MSS_WebEngine_Sitemap
Declaration Syntax
C#
protected XslFile MSS_WebEngine_Sitemap

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebSite.Components >> SiteMap >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.Language Namespace

MSS.WebSite.Components.Language Namespace
Namespaces >> MSS.WebSite.Components.Language
Declaration Syntax
C#
namespace MSS.WebSite.Components.Language
Types
All Types Classes
Icon | Type | Description
 | LanguageForm | Allow user to select the language of a site.


LanguageForm Class

LanguageForm Class
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm
Allow user to select the language of a site.
Declaration Syntax
C#
public class LanguageForm : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageFormLanguageFormNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlLanguages |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | rblLanguages |
 | rblLanguages_SelectedIndexChanged(Object, EventArgs) |
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | ReturnPath |
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | LanguageForm

Assembly: MSS.WebSite (Module: MSS.WebSite)


LanguageForm Constructor

LanguageForm Constructor
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> LanguageFormLanguageFormNew()()
Declaration Syntax
C#
public LanguageForm()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


pnlLanguages Field

pnlLanguages Field
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> pnlLanguages
Declaration Syntax
C#
protected Panel pnlLanguages

Assembly: MSS.WebSite (Module: MSS.WebSite)


rblLanguages Field

rblLanguages Field
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> rblLanguages
Declaration Syntax
C#
protected RadioButtonList rblLanguages

Assembly: MSS.WebSite (Module: MSS.WebSite)


rblLanguages_SelectedIndexChanged Method (sender, e)

rblLanguages_SelectedIndexChanged Method (sender, e)
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> rblLanguages_SelectedIndexChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rblLanguages_SelectedIndexChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


ReturnPath Field

ReturnPath Field
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> ReturnPath
Declaration Syntax
C#
protected HtmlInputHidden ReturnPath

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.Login Namespace

MSS.WebSite.Components.Login Namespace
Namespaces >> MSS.WebSite.Components.Login
Declaration Syntax
C#
namespace MSS.WebSite.Components.Login
Types
All Types Classes
Icon | Type | Description
 | LoginControl | Login control
 | LoginSpot | Login spot


LoginControl Class

LoginControl Class
Namespaces >> MSS.WebSite.Components.Login >> LoginControl
Login control
Declaration Syntax
C#
public class LoginControl : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginControlLoginControlNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnLogin_Click(Object, EventArgs) |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblLoggedIn |
 | lblNotLoggedIn |
 | lblResult |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginControls |
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLogin |
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtLogin |
 | txtPassword |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValName |
 | ValPassword |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | LoginControl

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoginControl Constructor

LoginControl Constructor
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> LoginControlLoginControlNew()()
Declaration Syntax
C#
public LoginControl()

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnLogin_Click Method (sender, e)

btnLogin_Click Method (sender, e)
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> btnLogin_Click(Object, EventArgs)
Declaration Syntax
C#
protected void btnLogin_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblLoggedIn Field

lblLoggedIn Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> lblLoggedIn
Declaration Syntax
C#
protected Label lblLoggedIn

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblNotLoggedIn Field

lblNotLoggedIn Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> lblNotLoggedIn
Declaration Syntax
C#
protected Label lblNotLoggedIn

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblResult Field

lblResult Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> lblResult
Declaration Syntax
C#
protected Label lblResult

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoginControls Field

LoginControls Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> LoginControls
Declaration Syntax
C#
protected HtmlGenericControl LoginControls

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLogin Field

OnLogin Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> OnLogin
Declaration Syntax
C#
public EventHandler OnLogin

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtLogin Field

txtLogin Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> txtLogin
Declaration Syntax
C#
protected TextBox txtLogin

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtPassword Field

txtPassword Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> txtPassword
Declaration Syntax
C#
protected TextBox txtPassword

Assembly: MSS.WebSite (Module: MSS.WebSite)


ValName Field

ValName Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> ValName
Declaration Syntax
C#
protected RequiredFieldValidator ValName

Assembly: MSS.WebSite (Module: MSS.WebSite)


ValPassword Field

ValPassword Field
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> ValPassword
Declaration Syntax
C#
protected RequiredFieldValidator ValPassword

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoginSpot Class

LoginSpot Class
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot
Login spot
Declaration Syntax
C#
public class LoginSpot : SiteControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginSpotLoginSpotNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Box |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblLoggedIn |
 | lblLoggedInUserName |
 | lblNotLoggedIn |
 | lblResult |
 | linkbtnLogin |
 | linkbtnLogin_Click(Object, EventArgs) |
 | linkbtnLogout_Click(Object, EventArgs) |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | (Overrides Control.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlLoggedIn |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtLogin |
 | txtPassword |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValName |
 | ValPassword |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | LoginSpot

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoginSpot Constructor

LoginSpot Constructor
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> LoginSpotLoginSpotNew()()
Declaration Syntax
C#
public LoginSpot()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Box Field

Box Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> Box
Declaration Syntax
C#
protected HtmlGenericControl Box

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblLoggedIn Field

lblLoggedIn Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> lblLoggedIn
Declaration Syntax
C#
protected Label lblLoggedIn

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblLoggedInUserName Field

lblLoggedInUserName Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> lblLoggedInUserName
Declaration Syntax
C#
protected Label lblLoggedInUserName

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblNotLoggedIn Field

lblNotLoggedIn Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> lblNotLoggedIn
Declaration Syntax
C#
protected Label lblNotLoggedIn

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblResult Field

lblResult Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> lblResult
Declaration Syntax
C#
protected Label lblResult

Assembly: MSS.WebSite (Module: MSS.WebSite)


linkbtnLogin Field

linkbtnLogin Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> linkbtnLogin
Declaration Syntax
C#
protected Link linkbtnLogin

Assembly: MSS.WebSite (Module: MSS.WebSite)


linkbtnLogin_Click Method (sender, e)

linkbtnLogin_Click Method (sender, e)
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> linkbtnLogin_Click(Object, EventArgs)
Declaration Syntax
C#
protected void linkbtnLogin_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


linkbtnLogout_Click Method (sender, e)

linkbtnLogout_Click Method (sender, e)
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> linkbtnLogout_Click(Object, EventArgs)
Declaration Syntax
C#
protected void linkbtnLogout_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


pnlLoggedIn Field

pnlLoggedIn Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> pnlLoggedIn
Declaration Syntax
C#
protected HtmlGenericControl pnlLoggedIn

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtLogin Field

txtLogin Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> txtLogin
Declaration Syntax
C#
protected TextBox txtLogin

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtPassword Field

txtPassword Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> txtPassword
Declaration Syntax
C#
protected TextBox txtPassword

Assembly: MSS.WebSite (Module: MSS.WebSite)


ValName Field

ValName Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> ValName
Declaration Syntax
C#
protected RequiredFieldValidator ValName

Assembly: MSS.WebSite (Module: MSS.WebSite)


ValPassword Field

ValPassword Field
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> ValPassword
Declaration Syntax
C#
protected RequiredFieldValidator ValPassword

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.Navigation Namespace

MSS.WebSite.Components.Navigation Namespace
Namespaces >> MSS.WebSite.Components.Navigation
Declaration Syntax
C#
namespace MSS.WebSite.Components.Navigation
Types
All Types Classes
Icon | Type | Description
 | EnterWebEdit | Enters WebEdit mode and redirects back.
 | LeaveWebEdit | Leaves edit module and redirects back.
 | LogOut | Logout from the current domain and redirect to site start page
 | PublishWeb | Publishes the site and redirect back


EnterWebEdit Class

EnterWebEdit Class
Namespaces >> MSS.WebSite.Components.Navigation >> EnterWebEdit
Enters WebEdit mode and redirects back.
Declaration Syntax
C#
public class EnterWebEdit : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EnterWebEditEnterWebEditNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | EnterWebEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


EnterWebEdit Constructor

EnterWebEdit Constructor
Namespaces >> MSS.WebSite.Components.Navigation >> EnterWebEdit >> EnterWebEditEnterWebEditNew()()
Declaration Syntax
C#
public EnterWebEdit()

Assembly: MSS.WebSite (Module: MSS.WebSite)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.WebSite.Components.Navigation >> EnterWebEdit >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.WebSite (Module: MSS.WebSite)


LeaveWebEdit Class

LeaveWebEdit Class
Namespaces >> MSS.WebSite.Components.Navigation >> LeaveWebEdit
Leaves edit module and redirects back.
Declaration Syntax
C#
public class LeaveWebEdit : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LeaveWebEditLeaveWebEditNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | LeaveWebEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


LeaveWebEdit Constructor

LeaveWebEdit Constructor
Namespaces >> MSS.WebSite.Components.Navigation >> LeaveWebEdit >> LeaveWebEditLeaveWebEditNew()()
Declaration Syntax
C#
public LeaveWebEdit()

Assembly: MSS.WebSite (Module: MSS.WebSite)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.WebSite.Components.Navigation >> LeaveWebEdit >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.WebSite (Module: MSS.WebSite)


LogOut Class

LogOut Class
Namespaces >> MSS.WebSite.Components.Navigation >> LogOut
Logout from the current domain and redirect to site start page
Declaration Syntax
C#
public class LogOut : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogOutLogOutNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | LogOut

Assembly: MSS.WebSite (Module: MSS.WebSite)


LogOut Constructor

LogOut Constructor
Namespaces >> MSS.WebSite.Components.Navigation >> LogOut >> LogOutLogOutNew()()
Declaration Syntax
C#
public LogOut()

Assembly: MSS.WebSite (Module: MSS.WebSite)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.WebSite.Components.Navigation >> LogOut >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.WebSite (Module: MSS.WebSite)


PublishWeb Class

PublishWeb Class
Namespaces >> MSS.WebSite.Components.Navigation >> PublishWeb
Publishes the site and redirect back
Declaration Syntax
C#
public class PublishWeb : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PublishWebPublishWebNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from WebControl.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Overrides WebControl.DoRender(HtmlTextWriter).)
 | DrawDots()() | (Inherited from WebControl.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItem()() | (Inherited from WebControl.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | PublishWeb

Assembly: MSS.WebSite (Module: MSS.WebSite)


PublishWeb Constructor

PublishWeb Constructor
Namespaces >> MSS.WebSite.Components.Navigation >> PublishWeb >> PublishWebPublishWebNew()()
Declaration Syntax
C#
public PublishWeb()

Assembly: MSS.WebSite (Module: MSS.WebSite)


DoRender Method (output)

DoRender Method (output)
Namespaces >> MSS.WebSite.Components.Navigation >> PublishWeb >> DoRender(HtmlTextWriter)
Declaration Syntax
C#
protected override void DoRender(
    HtmlTextWriter output
)
Parameters
output (HtmlTextWriter)

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.RecycleBin Namespace

MSS.WebSite.Components.RecycleBin Namespace
Namespaces >> MSS.WebSite.Components.RecycleBin
Declaration Syntax
C#
namespace MSS.WebSite.Components.RecycleBin
Types
All Types Classes
Icon | Type | Description
 | MSSRecycleBinListview | Display recycle bin items
 | RecycleBinForm | RecycleBin form


MSSRecycleBinListview Class

MSSRecycleBinListview Class
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview
Display recycle bin items
Declaration Syntax
C#
public class MSSRecycleBinListview : RecycleBinListview
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSSRecycleBinListviewMSSRecycleBinListviewNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Action()() | (Inherited from Control.)
 | Activate()() | (Inherited from Control.)
 | Activation()() | (Inherited from Control.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddDebugValue(String, String) | (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddToCache(String, String) | (Inherited from WebControl.)
 | AddViewsMenu(Menu) | (Inherited from Listview.)
 | AfterRender(HtmlTextWriter) | (Inherited from WebControl.)
 | AllowDragging()() | (Inherited from DataListview.)
 | AppendScript(ScriptCollection) | (Inherited from Component.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssertLoadOnlyProperty(String) | (Inherited from Component.)
 | AtRoot()() | (Inherited from DataListview.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | Background()() | (Inherited from Control.)
 | BeforeRender(HtmlTextWriter) | (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Border()() | (Inherited from WebControl.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | Bordered()() | (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cacheable()() | (Inherited from WebControl.)
 | CacheKey()() | (Inherited from WebControl.)
 | CachingID()() | (Inherited from WebControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | Class()() | (Inherited from Control.)
 | ClassAttribute()() | (Inherited from WebControl.)
 | Clear()() | (Inherited from WebControl.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearSelection()() | (Inherited from Listview.)
 | Click()() | (Inherited from Listview.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CollectDebugInformation()() | (Inherited from WebControl.)
 | ColumnNames()() | (Inherited from Listview.)
 | Connection()() | (Inherited from WebControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ContextMenu()() | (Inherited from Control.)
 | ControlAttributes()() | (Inherited from Control.)
 | ControlInfo()() | Obsolete. (Inherited from WebControl.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateListviewItem(Item) | (Inherited from DataListview.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssStyle()() | (Inherited from WebControl.)
 | Cursor()() | (Inherited from WebControl.)
 | Database()() | (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataContext()() | (Inherited from Control.)
 | DataSource()() | (Inherited from WebControl.)
 | DblClick()() | (Inherited from Listview.)
 | Deactivate()() | (Inherited from Control.)
 | DesignMode()() | (Inherited from WebControl.)
 | DesignSource()() | (Inherited from WebControl.)
 | Disabled()() | (Inherited from Control.)
 | DisableDebug()() | (Inherited from WebControl.)
 | DisableDots()() | (Inherited from WebControl.)
 | DisableSecurity()() | (Inherited from WebControl.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoActivate(Message) | (Inherited from Control.)
 | DoClick(Message) | (Inherited from DataListview.)
 | DoContextmenu(Message) | (Inherited from Control.)
 | DoDblclick(Message) | (Inherited from Listview.)
 | DoDeactivate(Message) | (Inherited from Control.)
 | DoKeydown(Message) | (Inherited from Control.)
 | DoRender(HtmlTextWriter) | (Inherited from Listview.)
 | DoSetView(String) | (Inherited from Listview.)
 | DrawDots()() | (Inherited from WebControl.)
 | Drop()() | (Inherited from Listview.)
 | DropItem(String) | (Inherited from DataListview.)
 | EmitRenderingInfoScript()() | Obsolete. (Inherited from WebControl.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Float()() | (Inherited from WebControl.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | FontBold()() | (Inherited from Control.)
 | FontItalic()() | (Inherited from Control.)
 | FontName()() | (Inherited from Control.)
 | FontOverline()() | (Inherited from Control.)
 | FontSize()() | (Inherited from Control.)
 | FontStrikeout()() | (Inherited from Control.)
 | FontUnderline()() | (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Foreground()() | (Inherited from WebControl.)
 | FormatAttribute(String, String) | (Inherited from Component.)
 | GetAncestorItem(array<String>[](), Item) | (Inherited from WebControl.)
 | GetCacheKey()() | (Inherited from WebControl.)
 | GetCachingID()() | (Inherited from WebControl.)
 | GetColumnValues(Item, DataListviewItem) | (Inherited from RecycleBinListview.)
 | GetContentItemFromQueryString()() | (Inherited from Component.)
 | GetContextItem()() | (Inherited from WebControl.)
 | GetContextMenu()() | (Inherited from DataListview.)
 | GetControlAttributes()() | (Inherited from Control.)
 | GetDatabase()() | (Inherited from WebControl.)
 | GetDataContext()() | (Inherited from Control.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetDesignTimeHtml(XmlNode) | (Inherited from WebControl.)
 | GetExtensibleProperties(Control) | (Inherited from WebControl.)
 | GetExtensibleProperty(Control, String) | (Inherited from WebControl.)
 | GetFieldValue(String) | (Inherited from WebControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetID(String) | (Inherited from Component.)
 | GetItem()() | (Inherited from WebControl.)
 | GetItemByID(String) | (Inherited from Listview.)
 | GetItemFromQueryString()() | (Inherited from Component.)
 | GetSelectedItem()() | (Inherited from DataListview.)
 | GetSelectedItems()() | (Inherited from Listview.)
 | GetShellViewsMenu(String) | (Inherited from DataListview.)
 | GetTraceName()() | (Inherited from WebControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetViews()() | (Inherited from Listview.)
 | GetViewsMenu(String) | (Inherited from Listview.)
 | GetViewStateBool(String) | (Inherited from Component.)
 | GetViewStateBool(String, Boolean) | (Inherited from Component.)
 | GetViewStateInt(String) | (Inherited from Component.)
 | GetViewStateInt(String, Int32) | (Inherited from Component.)
 | GetViewStateProperty(String, Object) | (Inherited from Component.)
 | GetViewStateString(String) | (Inherited from Component.)
 | GetViewStateString(String, String) | (Inherited from Component.)
 | HandleMessage(Message) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items()() | (Inherited from Listview.)
 | ItemsOnly()() | (Inherited from Listview.)
 | KeyDown()() | (Inherited from Control.)
 | KeyFilter()() | (Inherited from Control.)
 | LiveDisplay()() | (Inherited from WebControl.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPostData(String) | (Inherited from Component.)
 | LoadPostData(String, NameValueCollection) | (Inherited from Component.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginRendering()() | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, ContentGetter) | (Inherited from WebControl.)
 | MakeEditable(HtmlControl, String, String) | (Inherited from WebControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margin()() | (Inherited from WebControl.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | MoveExtensibleProperties(Control, Control) | (Inherited from WebControl.)
 | MultiSelect()() | (Inherited from Listview.)
 | Name()() | (Inherited from Control.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnActionChanged(Action) | (Inherited from Control.)
 | OnActivate()() | (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick()() | (Inherited from Listview.)
 | OnContextMenu()() | (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnDataContextChanged(DataContext) | (Inherited from DataListview.)
 | OnDblClick()() | (Inherited from Listview.)
 | OnDeactivate()() | (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnItemAdded(DataContext, ID) | (Inherited from DataListview.)
 | OnItemDeleted(DataContext, ID) | (Inherited from DataListview.)
 | OnItemRenamed(DataContext, ID) | (Inherited from Control.)
 | OnItemSaved(DataContext, ID) | (Inherited from Control.)
 | OnKeyDown()() | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from DataListview.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnSelectionChanged()() | (Inherited from Listview.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OnViewChanged()() | (Inherited from Listview.)
 | Open()() | (Inherited from DataListview.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Padding()() | (Inherited from WebControl.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parameters()() | (Inherited from WebControl.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | Populate()() | (Overrides DataListview.Populate()().)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PropertyChanged(String, Object, Object) | (Inherited from WebControl.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()() | (Inherited from Component.)
 | Refresh()() | (Inherited from DataListview.)
 | Refresh(DataContext) | (Inherited from DataListview.)
 | RegisterDebugScript()() | (Inherited from WebControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Inherited from WebControl.)
 | RenderAs()() | (Inherited from WebControl.)
 | RenderAsText()() | (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(XmlNode) | (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderError(String, String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderFooter(HtmlTextWriter) | (Inherited from Listview.)
 | RenderFromCache(String, HtmlTextWriter) | (Inherited from WebControl.)
 | RenderHeader(HtmlTextWriter) | (Inherited from Listview.)
 | RenderingID()() | (Inherited from WebControl.)
 | RenderingName()() | (Inherited from WebControl.)
 | RenderXml(XmlNode, TextWriter) | (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RollOver()() | (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | (Inherited from Listview.)
 | Selected()() | (Inherited from DataListview.)
 | SelectedItems()() | (Inherited from Listview.)
 | SelectionChanged()() | (Inherited from DataListview.)
 | ServerProperties()() | (Inherited from Component.)
 | SetControlAttribute(String, String, HtmlControl) | (Inherited from WebControl.)
 | SetDataSource(String) | (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDesignSource(String) | (Inherited from WebControl.)
 | SetExtensibleProperty(Control, String, String) | (Inherited from WebControl.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetViewStateBool(String, Boolean) | (Inherited from Component.)
 | SetViewStateBool(String, Boolean, Boolean) | (Inherited from Component.)
 | SetViewStateInt(String, Int32) | (Inherited from Component.)
 | SetViewStateInt(String, Int32, Int32) | (Inherited from Component.)
 | SetViewStateProperty(String, Object, Object) | (Inherited from Component.)
 | SetViewStateString(String, String) | (Inherited from Component.)
 | SetViewStateString(String, String, String) | (Inherited from Component.)
 | SetWidthAndHeightAttributes()() | (Inherited from Control.)
 | SetWidthAndHeightStyle()() | (Inherited from Control.)
 | ShowCheckboxes()() | (Inherited from Listview.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SortAscending()() | (Inherited from Listview.)
 | SortBy()() | (Inherited from Listview.)
 | SortByColumn(Int32) | (Inherited from DataListview.)
 | Src()() | Obsolete. (Inherited from DataListview.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | StyleAttribute()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#BeginInit()() | (Inherited from WebControl.)
 | System#ComponentModel#ISupportInitialize#EndInit()() | (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TabStop()() | (Inherited from Control.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | TransferAttributes(Control) | (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UpdateDataSource()() | (Inherited from WebControl.)
 | Value()() | (Inherited from Control.)
 | VaryByData()() | (Inherited from WebControl.)
 | VaryByDevice()() | (Inherited from WebControl.)
 | VaryByLogin()() | (Inherited from WebControl.)
 | VaryByParm()() | (Inherited from WebControl.)
 | VaryByQueryString()() | (Inherited from WebControl.)
 | VaryByUser()() | (Inherited from WebControl.)
 | View()() | (Inherited from Listview.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible()() | (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | WebControl
 |  |  |  | Component
 |  |  |  |  | Control
 |  |  |  |  |  | Listview
 |  |  |  |  |  |  | DataListview
 |  |  |  |  |  |  |  | RecycleBinListview
 |  |  |  |  |  |  |  |  | MSSRecycleBinListview

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSSRecycleBinListview Constructor

MSSRecycleBinListview Constructor
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> MSSRecycleBinListviewMSSRecycleBinListviewNew()()
Declaration Syntax
C#
public MSSRecycleBinListview()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Populate Method

Populate Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> Populate()()
Declaration Syntax
C#
protected override void Populate()

Assembly: MSS.WebSite (Module: MSS.WebSite)


RecycleBinForm Class

RecycleBinForm Class
Namespaces >> MSS.WebSite.Components.RecycleBin >> RecycleBinForm
RecycleBin form
Declaration Syntax
C#
public class RecycleBinForm : RecycleBinForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecycleBinFormRecycleBinFormNew()() |
 | Empty(ClientPipelineArgs) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLoad(EventArgs) | (Inherited from RecycleBinForm.)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | OnRestore()() | (Inherited from RecycleBinForm.)
 | Open()() | (Inherited from RecycleBinForm.)
 | RecycleBin()() | (Inherited from RecycleBinForm.)
 | RecycleBinDataContext()() | (Inherited from RecycleBinForm.)
 | Restore()() | (Inherited from RecycleBinForm.)
 | ServerProperties()() | (Inherited from BaseForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | RecycleBinForm
 |  |  | RecycleBinForm

Assembly: MSS.WebSite (Module: MSS.WebSite)


RecycleBinForm Constructor

RecycleBinForm Constructor
Namespaces >> MSS.WebSite.Components.RecycleBin >> RecycleBinForm >> RecycleBinFormRecycleBinFormNew()()
Declaration Syntax
C#
public RecycleBinForm()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Empty Method (args)

Empty Method (args)
Namespaces >> MSS.WebSite.Components.RecycleBin >> RecycleBinForm >> Empty(ClientPipelineArgs)
Declaration Syntax
C#
[HandleMessageAttribute("recyclebin:emptynew", true)]
protected void Empty(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.Reorganize Namespace

MSS.WebSite.Components.Reorganize Namespace
Namespaces >> MSS.WebSite.Components.Reorganize
Declaration Syntax
C#
namespace MSS.WebSite.Components.Reorganize
Types
All Types Classes
Icon | Type | Description
 | ReorganizeForm | Reorganize form
 | ReorganizeItemManager | Reorganize item manager


ReorganizeForm Class

ReorganizeForm Class
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm
Reorganize form
Declaration Syntax
C#
public class ReorganizeForm : BaseForm
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReorganizeFormReorganizeFormNew()() |
 | AttachmentDownClick()() |
 | AttachmentFirstClick()() |
 | AttachmentLastClick()() |
 | AttachmentsChanged()() |
 | attachmentTreeView_Click()() |
 | AttachmentUpClick()() |
 | CloseForm()() | Closes the form.
 | contentTreeView_Click()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | ItemDownClick()() |
 | ItemFirstClick()() |
 | ItemLastClick()() |
 | ItemMoveIn()() |
 | ItemMoveOut()() |
 | ItemUpClick()() |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | RenameSelectedItem(ClientPipelineArgs) |
 | ServerProperties()() | (Inherited from BaseForm.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | ReorganizeForm

Assembly: MSS.WebSite (Module: MSS.WebSite)


ReorganizeForm Constructor

ReorganizeForm Constructor
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> ReorganizeFormReorganizeFormNew()()
Declaration Syntax
C#
public ReorganizeForm()

Assembly: MSS.WebSite (Module: MSS.WebSite)


AttachmentDownClick Method

AttachmentDownClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> AttachmentDownClick()()
Declaration Syntax
C#
protected void AttachmentDownClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


AttachmentFirstClick Method

AttachmentFirstClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> AttachmentFirstClick()()
Declaration Syntax
C#
protected void AttachmentFirstClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


AttachmentLastClick Method

AttachmentLastClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> AttachmentLastClick()()
Declaration Syntax
C#
protected void AttachmentLastClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


AttachmentsChanged Method

AttachmentsChanged Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> AttachmentsChanged()()
Declaration Syntax
C#
protected void AttachmentsChanged()

Assembly: MSS.WebSite (Module: MSS.WebSite)


attachmentTreeView_Click Method

attachmentTreeView_Click Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> attachmentTreeView_Click()()
Declaration Syntax
C#
protected void attachmentTreeView_Click()

Assembly: MSS.WebSite (Module: MSS.WebSite)


AttachmentUpClick Method

AttachmentUpClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> AttachmentUpClick()()
Declaration Syntax
C#
protected void AttachmentUpClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


CloseForm Method

CloseForm Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> CloseForm()()
Closes the form.
Declaration Syntax
C#
protected void CloseForm()

Assembly: MSS.WebSite (Module: MSS.WebSite)


contentTreeView_Click Method

contentTreeView_Click Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> contentTreeView_Click()()
Declaration Syntax
C#
protected void contentTreeView_Click()

Assembly: MSS.WebSite (Module: MSS.WebSite)


ItemDownClick Method

ItemDownClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> ItemDownClick()()
Declaration Syntax
C#
protected void ItemDownClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


ItemFirstClick Method

ItemFirstClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> ItemFirstClick()()
Declaration Syntax
C#
protected void ItemFirstClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


ItemLastClick Method

ItemLastClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> ItemLastClick()()
Declaration Syntax
C#
protected void ItemLastClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


ItemMoveIn Method

ItemMoveIn Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> ItemMoveIn()()
Declaration Syntax
C#
protected void ItemMoveIn()

Assembly: MSS.WebSite (Module: MSS.WebSite)


ItemMoveOut Method

ItemMoveOut Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> ItemMoveOut()()
Declaration Syntax
C#
protected void ItemMoveOut()

Assembly: MSS.WebSite (Module: MSS.WebSite)


ItemUpClick Method

ItemUpClick Method
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> ItemUpClick()()
Declaration Syntax
C#
protected void ItemUpClick()

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenameSelectedItem Method (args)

RenameSelectedItem Method (args)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeForm >> RenameSelectedItem(ClientPipelineArgs)
Declaration Syntax
C#
[HandleMessageAttribute("ReorganizeForm:rename", true)]
protected void RenameSelectedItem(
    ClientPipelineArgs args
)
Parameters
args (ClientPipelineArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


ReorganizeItemManager Class

ReorganizeItemManager Class
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager
Reorganize item manager
Declaration Syntax
C#
public class ReorganizeItemManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReorganizeItemManagerReorganizeItemManagerNew(Item, String) | Initializes a new instance of the ReorganizeItemManager class.
 | CanMoveDown(Item) | Determines whether the specified item can move down the list.
 | CanMoveFirst(Item) | Determines whether the specified item can move to be the first item in the list.
 | CanMoveIn(Item) | Determines whether the specified item can move to be in the list.
 | CanMoveLast(Item) | Determines whether the specified item can move to be the last item in the list.
 | CanMoveOut(Item, Item) |
 | CanMoveUp(Item) | Determines whether the specified item can be moved up the list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveDown(Item) | Moves an item down the list.
 | MoveFirst(Item) | Moves an item to the first position in the list.
 | MoveIn(Item) | Moves the item to child level.
 | MoveLast(Item) | Moves the item to the last position in the list.
 | MoveOut(Item) | Moves the item to parent level.
 | MoveUp(Item) | Moves an item up the list.
 | RebuildItemList(Item) | Rebuilds the item list.
 | RootItem | Gets or sets the root item.
 | SetSelectedItem(Item) | Sets the selected item.
 | Templates | Gets or sets the display item templates.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ReorganizeItemManager

Assembly: MSS.WebSite (Module: MSS.WebSite)


ReorganizeItemManager Constructor (rootItem, templates)

ReorganizeItemManager Constructor (rootItem, templates)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> ReorganizeItemManagerReorganizeItemManagerNew(Item, String)
Initializes a new instance of the ReorganizeItemManager class.
Declaration Syntax
C#
public ReorganizeItemManager(
    Item rootItem,
    string templates
)
Parameters
rootItem (Item)
The root item.
templates (String)
The templates.

Assembly: MSS.WebSite (Module: MSS.WebSite)


CanMoveDown Method (item)

CanMoveDown Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> CanMoveDown(Item)
Determines whether the specified item can move down the list.
Declaration Syntax
C#
public bool CanMoveDown(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified item can move down the list; otherwise, false.

Assembly: MSS.WebSite (Module: MSS.WebSite)


CanMoveFirst Method (item)

CanMoveFirst Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> CanMoveFirst(Item)
Determines whether the specified item can move to be the first item in the list.
Declaration Syntax
C#
public bool CanMoveFirst(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified item can move to be the first item in the list; otherwise, false.

Assembly: MSS.WebSite (Module: MSS.WebSite)


CanMoveIn Method (item)

CanMoveIn Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> CanMoveIn(Item)
Determines whether the specified item can move to be in the list.
Declaration Syntax
C#
public bool CanMoveIn(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified item can move to be in the list; otherwise, false.

Assembly: MSS.WebSite (Module: MSS.WebSite)


CanMoveLast Method (item)

CanMoveLast Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> CanMoveLast(Item)
Determines whether the specified item can move to be the last item in the list.
Declaration Syntax
C#
public bool CanMoveLast(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified item can move to be the last item in the list; otherwise, false.

Assembly: MSS.WebSite (Module: MSS.WebSite)


CanMoveOut Method (item, rootItem)

CanMoveOut Method (item, rootItem)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> CanMoveOut(Item, Item)
Declaration Syntax
C#
public bool CanMoveOut(
    Item item,
    Item rootItem
)
Parameters
item (Item)
rootItem (Item)

Assembly: MSS.WebSite (Module: MSS.WebSite)


CanMoveUp Method (item)

CanMoveUp Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> CanMoveUp(Item)
Determines whether the specified item can be moved up the list.
Declaration Syntax
C#
public bool CanMoveUp(
    Item item
)
Parameters
item (Item)
The item.
Return Value
True if the specified item can move up the list; otherwise, false.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MoveDown Method (item)

MoveDown Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> MoveDown(Item)
Moves an item down the list.
Declaration Syntax
C#
public void MoveDown(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MoveFirst Method (item)

MoveFirst Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> MoveFirst(Item)
Moves an item to the first position in the list.
Declaration Syntax
C#
public void MoveFirst(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MoveIn Method (item)

MoveIn Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> MoveIn(Item)
Moves the item to child level.
Declaration Syntax
C#
public void MoveIn(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MoveLast Method (item)

MoveLast Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> MoveLast(Item)
Moves the item to the last position in the list.
Declaration Syntax
C#
public void MoveLast(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MoveOut Method (item)

MoveOut Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> MoveOut(Item)
Moves the item to parent level.
Declaration Syntax
C#
public void MoveOut(
    Item item
)
Parameters
item (Item)
the item.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MoveUp Method (item)

MoveUp Method (item)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> MoveUp(Item)
Moves an item up the list.
Declaration Syntax
C#
public void MoveUp(
    Item item
)
Parameters
item (Item)
The item.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RebuildItemList Method (root)

RebuildItemList Method (root)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> RebuildItemList(Item)
Rebuilds the item list.
Declaration Syntax
C#
public void RebuildItemList(
    Item root
)
Parameters
root (Item)
The root.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RootItem Property

RootItem Property
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> RootItem
Gets or sets the root item.
Declaration Syntax
C#
public Item RootItem{ get; set;}
Value
The root item.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetSelectedItem Method (selected)

SetSelectedItem Method (selected)
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> SetSelectedItem(Item)
Sets the selected item.
Declaration Syntax
C#
public void SetSelectedItem(
    Item selected
)
Parameters
selected (Item)
The selected.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Templates Property

Templates Property
Namespaces >> MSS.WebSite.Components.Reorganize >> ReorganizeItemManager >> Templates
Gets or sets the display item templates.
Declaration Syntax
C#
public string Templates{ get; set;}
Value
The templates.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.Search Namespace

MSS.WebSite.Components.Search Namespace
Namespaces >> MSS.WebSite.Components.Search
Declaration Syntax
C#
namespace MSS.WebSite.Components.Search
Types
All Types Classes
Icon | Type | Description
 | NativeSearch | Native search using lucene engine for search.
 | NativeSearchHighlighter | Highlights search string in the text.
 | SearchResultForm | Displays search result


NativeSearch Class

NativeSearch Class
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch
Native search using lucene engine for search.
Declaration Syntax
C#
public class NativeSearch : ISearch
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NativeSearchNativeSearchNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHighlighter(String, Int32, Int32, String, String) | Gets the text highlighter.
 | GetIndex()() | Gets the index for the current site.
 | GetIndex(String) | Gets the index for a specified site.
 | GetIndex(SiteContext) | Gets the index for a specified site.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RebuildIndexDatabase(SiteContext) | Rebuilds the index database.
 | Search(String) | Searches the text.
 | Search(String, Int32, Int32, String) | Searches the text.
 | Search(String, SearchOption, ResultOption, Int32, Int32, String) | Searches the text.
 | SearchEngine | Gets the search engine name.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NativeSearch

Assembly: MSS.WebSite (Module: MSS.WebSite)


NativeSearch Constructor

NativeSearch Constructor
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> NativeSearchNativeSearchNew()()
Declaration Syntax
C#
public NativeSearch()

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetHighlighter Method (searchText, maxTextLength, maxFragments, separator, cssClass)

GetHighlighter Method (searchText, maxTextLength, maxFragments, separator, cssClass)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> GetHighlighter(String, Int32, Int32, String, String)
Gets the text highlighter.
Declaration Syntax
C#
public IHighlighter GetHighlighter(
    string searchText,
    int maxTextLength,
    int maxFragments,
    string separator,
    string cssClass
)
Parameters
searchText (String)
The search text.
maxTextLength (Int32)
Length of the max text.
maxFragments (Int32)
The max fragments.
separator (String)
The separator.
cssClass (String)
The CSS class.
Return Value
The text highlighter.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetIndex Method

GetIndex Method
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> GetIndex()()
Members
Icon | Member | Description
 | GetIndex()() | Gets the index for the current site.
 | GetIndex(String) | Gets the index for a specified site.
 | GetIndex(SiteContext) | Gets the index for a specified site.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetIndex Method

GetIndex Method
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> GetIndex()()
Gets the index for the current site.
Declaration Syntax
C#
public static Index GetIndex()
Return Value
The index for the current site.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetIndex Method (site)

GetIndex Method (site)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> GetIndex(SiteContext)
Gets the index for a specified site.
Declaration Syntax
C#
public static Index GetIndex(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The index for the site.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetIndex Method (siteAddress)

GetIndex Method (siteAddress)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> GetIndex(String)
Gets the index for a specified site.
Declaration Syntax
C#
public static Index GetIndex(
    string siteAddress
)
Parameters
siteAddress (String)
The site address.
Return Value
The index for the site.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RebuildIndexDatabase Method (site)

RebuildIndexDatabase Method (site)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> RebuildIndexDatabase(SiteContext)
Rebuilds the index database.
Declaration Syntax
C#
public void RebuildIndexDatabase(
    SiteContext site
)
Parameters
site (SiteContext)
The site.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Search Method

Search Method
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> Search()()
Members
Icon | Member | Description
 | Search(String) | Searches the text.
 | Search(String, Int32, Int32, String) | Searches the text.
 | Search(String, SearchOption, ResultOption, Int32, Int32, String) | Searches the text.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Search Method (searchText)

Search Method (searchText)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> Search(String)
Searches the text.
Declaration Syntax
C#
public ISearchResult Search(
    string searchText
)
Parameters
searchText (String)
The search text.
Return Value
The search result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Search Method (searchText, option, resultOption, offset, count, templates)

Search Method (searchText, option, resultOption, offset, count, templates)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> Search(String, SearchOption, ResultOption, Int32, Int32, String)
Searches the text.
Declaration Syntax
C#
public ISearchResult Search(
    string searchText,
    SearchOption option,
    ResultOption resultOption,
    int offset,
    int count,
    string templates
)
Parameters
searchText (String)
The search text.
option (SearchOption)
The option.
resultOption (ResultOption)
The result option.
offset (Int32)
The offset.
count (Int32)
The count.
templates (String)
The templates.
Return Value
The search result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Search Method (searchText, offset, count, templates)

Search Method (searchText, offset, count, templates)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> Search(String, Int32, Int32, String)
Searches the text.
Declaration Syntax
C#
public ISearchResult Search(
    string searchText,
    int offset,
    int count,
    string templates
)
Parameters
searchText (String)
The search text.
offset (Int32)
The offset.
count (Int32)
The count.
templates (String)
The templates.
Return Value
The search result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SearchEngine Property

SearchEngine Property
Namespaces >> MSS.WebSite.Components.Search >> NativeSearch >> SearchEngine
Gets the search engine name.
Declaration Syntax
C#
public string SearchEngine{ get;}
Value
The search engine.

Assembly: MSS.WebSite (Module: MSS.WebSite)


NativeSearchHighlighter Class

NativeSearchHighlighter Class
Namespaces >> MSS.WebSite.Components.Search >> NativeSearchHighlighter
Highlights search string in the text.
Declaration Syntax
C#
public class NativeSearchHighlighter : IHighlighter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NativeSearchHighlighterNativeSearchHighlighterNew(Query, String, Int32, Int32, String, String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBestFragment(String) | Gets the best fragment of the text for display it on the search result
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NativeSearchHighlighter

Assembly: MSS.WebSite (Module: MSS.WebSite)


NativeSearchHighlighter Constructor (query, searchText, maxTextLength, maxFragments, separator, cssClass)

NativeSearchHighlighter Constructor (query, searchText, maxTextLength, maxFragments, separator, cssClass)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearchHighlighter >> NativeSearchHighlighterNativeSearchHighlighterNew(Query, String, Int32, Int32, String, String)
Declaration Syntax
C#
public NativeSearchHighlighter(
    Query query,
    string searchText,
    int maxTextLength,
    int maxFragments,
    string separator,
    string cssClass
)
Parameters
query (Query)
searchText (String)
maxTextLength (Int32)
maxFragments (Int32)
separator (String)
cssClass (String)

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetBestFragment Method (text)

GetBestFragment Method (text)
Namespaces >> MSS.WebSite.Components.Search >> NativeSearchHighlighter >> GetBestFragment(String)
Gets the best fragment of the text for display it on the search result
Declaration Syntax
C#
public string GetBestFragment(
    string text
)
Parameters
text (String)
The text.
Return Value
The best fragment of the text.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SearchResultForm Class

SearchResultForm Class
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm
Displays search result
Declaration Syntax
C#
public class SearchResultForm : SiteControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultFormSearchResultFormNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SitePage | Gets the MSSPage. (Inherited from SiteControl.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteControl
 |  |  |  |  | SearchResultForm

Assembly: MSS.WebSite (Module: MSS.WebSite)


SearchResultForm Constructor

SearchResultForm Constructor
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> SearchResultFormSearchResultFormNew()()
Declaration Syntax
C#
public SearchResultForm()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.Search.Native Namespace

MSS.WebSite.Components.Search.Native Namespace
Namespaces >> MSS.WebSite.Components.Search.Native
Declaration Syntax
C#
namespace MSS.WebSite.Components.Search.Native
Types
All Types Classes
Icon | Type | Description
 | InitializeNativeSearchIndexer | Initialize the NativeSearchIndexer.
 | NativeSearchIndexer | Indexes items using lucene engine.


InitializeNativeSearchIndexer Class

InitializeNativeSearchIndexer Class
Namespaces >> MSS.WebSite.Components.Search.Native >> InitializeNativeSearchIndexer
Initialize the NativeSearchIndexer.
Declaration Syntax
C#
public class InitializeNativeSearchIndexer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InitializeNativeSearchIndexerInitializeNativeSearchIndexerNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(PipelineArgs) |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InitializeNativeSearchIndexer

Assembly: MSS.WebSite (Module: MSS.WebSite)


InitializeNativeSearchIndexer Constructor

InitializeNativeSearchIndexer Constructor
Namespaces >> MSS.WebSite.Components.Search.Native >> InitializeNativeSearchIndexer >> InitializeNativeSearchIndexerInitializeNativeSearchIndexerNew()()
Declaration Syntax
C#
public InitializeNativeSearchIndexer()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Process Method (args)

Process Method (args)
Namespaces >> MSS.WebSite.Components.Search.Native >> InitializeNativeSearchIndexer >> Process(PipelineArgs)
Declaration Syntax
C#
public void Process(
    PipelineArgs args
)
Parameters
args (PipelineArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


NativeSearchIndexer Class

NativeSearchIndexer Class
Namespaces >> MSS.WebSite.Components.Search.Native >> NativeSearchIndexer
Indexes items using lucene engine.
Declaration Syntax
C#
public class NativeSearchIndexer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NativeSearchIndexerNativeSearchIndexerNew()() |
 | AlarmClock_Ring(Object, EventArgs) | Handles the Ring event of the AlarmClock.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize()() | Initializes the NativeSearchIndexer.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateIndexAsync()() | Updates the index for changed items.
Inheritance Hierarchy
Object
NativeSearchIndexer

Assembly: MSS.WebSite (Module: MSS.WebSite)


NativeSearchIndexer Constructor

NativeSearchIndexer Constructor
Namespaces >> MSS.WebSite.Components.Search.Native >> NativeSearchIndexer >> NativeSearchIndexerNativeSearchIndexerNew()()
Declaration Syntax
C#
public NativeSearchIndexer()

Assembly: MSS.WebSite (Module: MSS.WebSite)


AlarmClock_Ring Method (sender, args)

AlarmClock_Ring Method (sender, args)
Namespaces >> MSS.WebSite.Components.Search.Native >> NativeSearchIndexer >> AlarmClock_Ring(Object, EventArgs)
Handles the Ring event of the AlarmClock.
Declaration Syntax
C#
public static void AlarmClock_Ring(
    Object sender,
    EventArgs args
)
Parameters
sender (Object)
The source of the event.
args (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Initialize Method

Initialize Method
Namespaces >> MSS.WebSite.Components.Search.Native >> NativeSearchIndexer >> Initialize()()
Initializes the NativeSearchIndexer.
Declaration Syntax
C#
public static void Initialize()

Assembly: MSS.WebSite (Module: MSS.WebSite)


UpdateIndexAsync Method

UpdateIndexAsync Method
Namespaces >> MSS.WebSite.Components.Search.Native >> NativeSearchIndexer >> UpdateIndexAsync()()
Updates the index for changed items.
Declaration Syntax
C#
public virtual void UpdateIndexAsync()

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.SecurityEditor Namespace

MSS.WebSite.Components.SecurityEditor Namespace
Namespaces >> MSS.WebSite.Components.SecurityEditor
Declaration Syntax
C#
namespace MSS.WebSite.Components.SecurityEditor
Types
All Types Classes
Icon | Type | Description
 | MediaSecurityField | Media security field MediaSecurityField class.


MediaSecurityField Class

MediaSecurityField Class
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField
Media security field
MediaSecurityField class.
Declaration Syntax
C#
public class MediaSecurityField : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaSecurityFieldMediaSecurityFieldNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | cblWhoCanUploadImages | cblWhoCanUploadImages control.
 | cbWhoCanCreateFolders | cblCanCreateFolders control.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | lblItemProtected | lblItemProtected control.
 | lblNotEnoughRights | lblNotEnoughRights control.
 | lblNotMssContentItem | lblNotMssContentItem control.
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | litWhoCanCreateFolder | litWhoCanCreateFolder control.
 | litWhoCanUploadImages | litWhoCanUploadImages control.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mlvMain | mlvMain control.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | viewItemIsProtected | viewItemIsProtected control.
 | viewNoAccess | viewNoAccess control.
 | viewNotMSSItem | viewNotMSSItem control.
 | viewSecurity | viewSecurity control.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MediaSecurityField

Assembly: MSS.WebSite (Module: MSS.WebSite)


MediaSecurityField Constructor

MediaSecurityField Constructor
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> MediaSecurityFieldMediaSecurityFieldNew()()
Declaration Syntax
C#
public MediaSecurityField()

Assembly: MSS.WebSite (Module: MSS.WebSite)


cblWhoCanUploadImages Field

cblWhoCanUploadImages Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> cblWhoCanUploadImages
cblWhoCanUploadImages control.
Declaration Syntax
C#
protected CheckBoxList cblWhoCanUploadImages
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


cbWhoCanCreateFolders Field

cbWhoCanCreateFolders Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> cbWhoCanCreateFolders
cblCanCreateFolders control.
Declaration Syntax
C#
protected CheckBoxList cbWhoCanCreateFolders
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


form1 Field

form1 Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblItemProtected Field

lblItemProtected Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> lblItemProtected
lblItemProtected control.
Declaration Syntax
C#
protected Label lblItemProtected
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblNotEnoughRights Field

lblNotEnoughRights Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> lblNotEnoughRights
lblNotEnoughRights control.
Declaration Syntax
C#
protected Label lblNotEnoughRights
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblNotMssContentItem Field

lblNotMssContentItem Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> lblNotMssContentItem
lblNotMssContentItem control.
Declaration Syntax
C#
protected Label lblNotMssContentItem
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


litWhoCanCreateFolder Field

litWhoCanCreateFolder Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> litWhoCanCreateFolder
litWhoCanCreateFolder control.
Declaration Syntax
C#
protected Literal litWhoCanCreateFolder
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


litWhoCanUploadImages Field

litWhoCanUploadImages Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> litWhoCanUploadImages
litWhoCanUploadImages control.
Declaration Syntax
C#
protected Literal litWhoCanUploadImages
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


mlvMain Field

mlvMain Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> mlvMain
mlvMain control.
Declaration Syntax
C#
protected MultiView mlvMain
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewItemIsProtected Field

viewItemIsProtected Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> viewItemIsProtected
viewItemIsProtected control.
Declaration Syntax
C#
protected View viewItemIsProtected
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewNoAccess Field

viewNoAccess Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> viewNoAccess
viewNoAccess control.
Declaration Syntax
C#
protected View viewNoAccess
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewNotMSSItem Field

viewNotMSSItem Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> viewNotMSSItem
viewNotMSSItem control.
Declaration Syntax
C#
protected View viewNotMSSItem
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewSecurity Field

viewSecurity Field
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> viewSecurity
viewSecurity control.
Declaration Syntax
C#
protected View viewSecurity
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.SecurityEditor.Codebeside Namespace

MSS.WebSite.Components.SecurityEditor.Codebeside Namespace
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside
Declaration Syntax
C#
namespace MSS.WebSite.Components.SecurityEditor.Codebeside
Types
All Types Classes
Icon | Type | Description
 | EditGroup | Edit group page
 | EditUser | Edit user page
 | SecurityBasePage | Base class of the security editor controls


EditGroup Class

EditGroup Class
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup
Edit group page
Declaration Syntax
C#
public class EditGroup : SecurityBasePage
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditGroupEditGroupNew()() |
 | Alert(String) | (Inherited from SecurityBasePage.)
 | Alert(String, array<Object>[]()) | (Inherited from SecurityBasePage.)
 | brdAccess |
 | brdCenter |
 | brdCreate |
 | brdDelete |
 | brdEdit |
 | brdEditable |
 | brdGroups |
 | brdGroupTemplates |
 | brdGroupTemplatesEditSection |
 | brdHasAdminRights |
 | brdMembers |
 | brdProperties |
 | btnCreate |
 | btnDelete |
 | btnEdit |
 | btnUpdate |
 | createGroupName |
 | editName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | FillGroupsList(String) |
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFromDictionary(String) | (Inherited from SecurityBasePage.)
 | GetGroupTemplateByName(String) | (Inherited from SecurityBasePage.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSelectedFromNames(String, array<String>[]()) | (Inherited from SecurityBasePage.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | litCannotEdit |
 | litHasAdminRights |
 | lstGroups |
 | lstTasks |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnClose(Message) | (Inherited from SecurityBasePage.)
 | OnCreateGroup(Message) |
 | OnDeleteGroup(Message) |
 | OnEditGroup(Message) |
 | OnGroupChanged(Message) |
 | OnKeyDown(Message) |
 | OnLoad(EventArgs) | (Overrides SecurityBasePage.OnLoad(EventArgs).)
 | OnModeChanged(Message) |
 | OnPreRender(EventArgs) | (Overrides BaseForm.OnPreRender(EventArgs).)
 | OnUsers(Message) |
 | rgpGroupTemplate |
 | ServerProperties()() | (Inherited from BaseForm.)
 | tbnClose |
 | tbnUsers |
 | title |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | tsbTasks |
Inheritance Hierarchy
Object
 | BaseForm
 |  | SecurityBasePage
 |  |  | EditGroup

Assembly: MSS.WebSite (Module: MSS.WebSite)


EditGroup Constructor

EditGroup Constructor
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> EditGroupEditGroupNew()()
Declaration Syntax
C#
public EditGroup()

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdAccess Field

brdAccess Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdAccess
Declaration Syntax
C#
protected Border brdAccess

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdCenter Field

brdCenter Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdCenter
Declaration Syntax
C#
protected Border brdCenter

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdCreate Field

brdCreate Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdCreate
Declaration Syntax
C#
protected Border brdCreate

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdDelete Field

brdDelete Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdDelete
Declaration Syntax
C#
protected Border brdDelete

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdEdit Field

brdEdit Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdEdit
Declaration Syntax
C#
protected Border brdEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdEditable Field

brdEditable Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdEditable
Declaration Syntax
C#
protected Border brdEditable

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdGroups Field

brdGroups Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdGroups
Declaration Syntax
C#
protected Border brdGroups

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdGroupTemplates Field

brdGroupTemplates Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdGroupTemplates
Declaration Syntax
C#
protected Border brdGroupTemplates

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdGroupTemplatesEditSection Field

brdGroupTemplatesEditSection Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdGroupTemplatesEditSection
Declaration Syntax
C#
protected Border brdGroupTemplatesEditSection

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdHasAdminRights Field

brdHasAdminRights Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdHasAdminRights
Declaration Syntax
C#
protected Border brdHasAdminRights

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdMembers Field

brdMembers Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdMembers
Declaration Syntax
C#
protected Border brdMembers

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdProperties Field

brdProperties Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> brdProperties
Declaration Syntax
C#
protected Border brdProperties

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnCreate Field

btnCreate Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> btnCreate
Declaration Syntax
C#
protected Button btnCreate

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnDelete Field

btnDelete Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> btnDelete
Declaration Syntax
C#
protected Button btnDelete

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnEdit Field

btnEdit Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> btnEdit
Declaration Syntax
C#
protected Button btnEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnUpdate Field

btnUpdate Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> btnUpdate
Declaration Syntax
C#
protected Button btnUpdate

Assembly: MSS.WebSite (Module: MSS.WebSite)


createGroupName Field

createGroupName Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> createGroupName
Declaration Syntax
C#
protected Edit createGroupName

Assembly: MSS.WebSite (Module: MSS.WebSite)


editName Field

editName Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> editName
Declaration Syntax
C#
protected Edit editName

Assembly: MSS.WebSite (Module: MSS.WebSite)


FillGroupsList Method (selectedGroup)

FillGroupsList Method (selectedGroup)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> FillGroupsList(String)
Declaration Syntax
C#
protected void FillGroupsList(
    string selectedGroup
)
Parameters
selectedGroup (String)

Assembly: MSS.WebSite (Module: MSS.WebSite)


litCannotEdit Field

litCannotEdit Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> litCannotEdit
Declaration Syntax
C#
protected Literal litCannotEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


litHasAdminRights Field

litHasAdminRights Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> litHasAdminRights
Declaration Syntax
C#
protected Literal litHasAdminRights

Assembly: MSS.WebSite (Module: MSS.WebSite)


lstGroups Field

lstGroups Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> lstGroups
Declaration Syntax
C#
protected Listbox lstGroups

Assembly: MSS.WebSite (Module: MSS.WebSite)


lstTasks Field

lstTasks Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> lstTasks
Declaration Syntax
C#
protected Listbox lstTasks

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnCreateGroup Method (msg)

OnCreateGroup Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnCreateGroup(Message)
Declaration Syntax
C#
[HandleMessageAttribute("CreateGroup:Submit")]
public void OnCreateGroup(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnDeleteGroup Method (msg)

OnDeleteGroup Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnDeleteGroup(Message)
Declaration Syntax
C#
[HandleMessageAttribute("DeleteGroup:Submit")]
public void OnDeleteGroup(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnEditGroup Method (msg)

OnEditGroup Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnEditGroup(Message)
Declaration Syntax
C#
[HandleMessageAttribute("EditGroup:Submit")]
public void OnEditGroup(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnGroupChanged Method (msg)

OnGroupChanged Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnGroupChanged(Message)
Declaration Syntax
C#
[HandleMessageAttribute("EditGroup:GroupChanged")]
public void OnGroupChanged(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnKeyDown Method (msg)

OnKeyDown Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnKeyDown(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Form:KeyDown")]
public void OnKeyDown(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnModeChanged Method (msg)

OnModeChanged Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnModeChanged(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:ChangeMode")]
public void OnModeChanged(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnUsers Method (msg)

OnUsers Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> OnUsers(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Users")]
public void OnUsers(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


rgpGroupTemplate Field

rgpGroupTemplate Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> rgpGroupTemplate
Declaration Syntax
C#
protected Radiogroup rgpGroupTemplate

Assembly: MSS.WebSite (Module: MSS.WebSite)


tbnClose Field

tbnClose Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> tbnClose
Declaration Syntax
C#
protected TaskboxItem tbnClose

Assembly: MSS.WebSite (Module: MSS.WebSite)


tbnUsers Field

tbnUsers Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> tbnUsers
Declaration Syntax
C#
protected TaskboxItem tbnUsers

Assembly: MSS.WebSite (Module: MSS.WebSite)


title Field

title Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> title
Declaration Syntax
C#
protected Literal title

Assembly: MSS.WebSite (Module: MSS.WebSite)


tsbTasks Field

tsbTasks Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> tsbTasks
Declaration Syntax
C#
protected TaskBoxEx tsbTasks

Assembly: MSS.WebSite (Module: MSS.WebSite)


EditUser Class

EditUser Class
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser
Edit user page
Declaration Syntax
C#
public class EditUser : SecurityBasePage
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditUserEditUserNew()() |
 | Alert(String) | (Inherited from SecurityBasePage.)
 | Alert(String, array<Object>[]()) | (Inherited from SecurityBasePage.)
 | brdCenter |
 | brdCreate |
 | brdDelete |
 | brdEdit |
 | brdGroups |
 | brdUserInfo |
 | brdUserToDelete |
 | btnCreate |
 | btnDelete |
 | btnUpdate |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFromDictionary(String) | (Inherited from SecurityBasePage.)
 | GetGroupTemplateByName(String) | (Inherited from SecurityBasePage.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSelectedFromNames(String, array<String>[]()) | (Inherited from SecurityBasePage.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | lstTasks |
 | lstUserNames |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnClose(Message) | (Inherited from SecurityBasePage.)
 | OnKeyDown(Message) |
 | OnLoad(EventArgs) | (Overrides SecurityBasePage.OnLoad(EventArgs).)
 | OnModeChanged(Message) |
 | OnPreRender(EventArgs) | (Overrides BaseForm.OnPreRender(EventArgs).)
 | OnUserAddPress(Message) |
 | OnUserChanged(Message) |
 | OnUserEdit(Message) |
 | OnUsers(Message) |
 | OnUsersDelete(Message) |
 | ServerProperties()() | (Inherited from BaseForm.)
 | tbnClose |
 | tbnGroups |
 | title |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | tsbTasks |
 | txtConfirmPassword |
 | txtEditName |
 | txtEmail |
 | txtFullName |
 | txtPassword |
Inheritance Hierarchy
Object
 | BaseForm
 |  | SecurityBasePage
 |  |  | EditUser

Assembly: MSS.WebSite (Module: MSS.WebSite)


EditUser Constructor

EditUser Constructor
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> EditUserEditUserNew()()
Declaration Syntax
C#
public EditUser()

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdCenter Field

brdCenter Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> brdCenter
Declaration Syntax
C#
protected Border brdCenter

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdCreate Field

brdCreate Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> brdCreate
Declaration Syntax
C#
protected Border brdCreate

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdDelete Field

brdDelete Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> brdDelete
Declaration Syntax
C#
protected Border brdDelete

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdEdit Field

brdEdit Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> brdEdit
Declaration Syntax
C#
protected Border brdEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdGroups Field

brdGroups Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> brdGroups
Declaration Syntax
C#
protected Border brdGroups

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdUserInfo Field

brdUserInfo Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> brdUserInfo
Declaration Syntax
C#
protected Border brdUserInfo

Assembly: MSS.WebSite (Module: MSS.WebSite)


brdUserToDelete Field

brdUserToDelete Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> brdUserToDelete
Declaration Syntax
C#
protected Border brdUserToDelete

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnCreate Field

btnCreate Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> btnCreate
Declaration Syntax
C#
protected Button btnCreate

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnDelete Field

btnDelete Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> btnDelete
Declaration Syntax
C#
protected Button btnDelete

Assembly: MSS.WebSite (Module: MSS.WebSite)


btnUpdate Field

btnUpdate Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> btnUpdate
Declaration Syntax
C#
protected Button btnUpdate

Assembly: MSS.WebSite (Module: MSS.WebSite)


lstTasks Field

lstTasks Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> lstTasks
Declaration Syntax
C#
protected Listbox lstTasks

Assembly: MSS.WebSite (Module: MSS.WebSite)


lstUserNames Field

lstUserNames Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> lstUserNames
Declaration Syntax
C#
protected Listbox lstUserNames

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnKeyDown Method (msg)

OnKeyDown Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnKeyDown(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Form:KeyDown")]
public void OnKeyDown(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnModeChanged Method (msg)

OnModeChanged Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnModeChanged(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:ChangeMode")]
public void OnModeChanged(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnUserAddPress Method (msg)

OnUserAddPress Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnUserAddPress(Message)
Declaration Syntax
C#
[HandleMessageAttribute("AddUser:Submit")]
public void OnUserAddPress(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnUserChanged Method (msg)

OnUserChanged Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnUserChanged(Message)
Declaration Syntax
C#
[HandleMessageAttribute("EditUser:UserChanged")]
public void OnUserChanged(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnUserEdit Method (msg)

OnUserEdit Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnUserEdit(Message)
Declaration Syntax
C#
[HandleMessageAttribute("EditUser:Submit")]
public void OnUserEdit(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnUsers Method (msg)

OnUsers Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnUsers(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Groups")]
public void OnUsers(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnUsersDelete Method (msg)

OnUsersDelete Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> OnUsersDelete(Message)
Declaration Syntax
C#
[HandleMessageAttribute("DeleteUser:Submit")]
public void OnUsersDelete(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


tbnClose Field

tbnClose Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> tbnClose
Declaration Syntax
C#
protected TaskboxItem tbnClose

Assembly: MSS.WebSite (Module: MSS.WebSite)


tbnGroups Field

tbnGroups Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> tbnGroups
Declaration Syntax
C#
protected TaskboxItem tbnGroups

Assembly: MSS.WebSite (Module: MSS.WebSite)


title Field

title Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> title
Declaration Syntax
C#
protected Literal title

Assembly: MSS.WebSite (Module: MSS.WebSite)


tsbTasks Field

tsbTasks Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> tsbTasks
Declaration Syntax
C#
protected TaskBoxEx tsbTasks

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtConfirmPassword Field

txtConfirmPassword Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> txtConfirmPassword
Declaration Syntax
C#
protected Edit txtConfirmPassword

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtEditName Field

txtEditName Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> txtEditName
Declaration Syntax
C#
protected Edit txtEditName

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtEmail Field

txtEmail Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> txtEmail
Declaration Syntax
C#
protected Edit txtEmail

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtFullName Field

txtFullName Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> txtFullName
Declaration Syntax
C#
protected Edit txtFullName

Assembly: MSS.WebSite (Module: MSS.WebSite)


txtPassword Field

txtPassword Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> txtPassword
Declaration Syntax
C#
protected Edit txtPassword

Assembly: MSS.WebSite (Module: MSS.WebSite)


SecurityBasePage Class

SecurityBasePage Class
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage
Base class of the security editor controls
Declaration Syntax
C#
public class SecurityBasePage : BaseForm
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityBasePageSecurityBasePageNew()() |
 | Alert(String) |
 | Alert(String, array<Object>[]()) |
 | DictionaryPath |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventsEnabled()() | (Inherited from BaseForm.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFromDictionary(String) |
 | GetGroupTemplateByName(String) |
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSelectedFromNames(String, array<String>[]()) |
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HandleMessage(Message) | (Inherited from BaseForm.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnClose(Message) |
 | OnLoad(EventArgs) | (Overrides BaseForm.OnLoad(EventArgs).)
 | OnPreRender(EventArgs) | (Inherited from BaseForm.)
 | ServerProperties()() | (Inherited from BaseForm.)
 | SetTitle(String) |
 | TitleKey |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseForm
 |  | SecurityBasePage
 |  |  | EditUser
 |  |  | EditGroup

Assembly: MSS.WebSite (Module: MSS.WebSite)


SecurityBasePage Constructor

SecurityBasePage Constructor
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> SecurityBasePageSecurityBasePageNew()()
Declaration Syntax
C#
public SecurityBasePage()

Assembly: MSS.WebSite (Module: MSS.WebSite)


Alert Method

Alert Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> Alert()()
Members
Icon | Member | Description
 | Alert(String) |
 | Alert(String, array<Object>[]()) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


Alert Method (dicKey)

Alert Method (dicKey)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> Alert(String)
Declaration Syntax
C#
public void Alert(
    string dicKey
)
Parameters
dicKey (String)

Assembly: MSS.WebSite (Module: MSS.WebSite)


Alert Method (dicKey, values)

Alert Method (dicKey, values)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> Alert(String, array<Object>[]())
Declaration Syntax
C#
public void Alert(
    string dicKey,
    params Object[] values
)
Parameters
dicKey (String)
values (array< Object >[]())

Assembly: MSS.WebSite (Module: MSS.WebSite)


DictionaryPath Field

DictionaryPath Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> DictionaryPath
Declaration Syntax
C#
protected static readonly string DictionaryPath

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetFromDictionary Method (key)

GetFromDictionary Method (key)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> GetFromDictionary(String)
Declaration Syntax
C#
public string GetFromDictionary(
    string key
)
Parameters
key (String)

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGroupTemplateByName Method (groupTemplateName)

GetGroupTemplateByName Method (groupTemplateName)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> GetGroupTemplateByName(String)
Declaration Syntax
C#
protected GroupTemplate GetGroupTemplateByName(
    string groupTemplateName
)
Parameters
groupTemplateName (String)

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetSelectedFromNames Method (prefix, names)

GetSelectedFromNames Method (prefix, names)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> GetSelectedFromNames(String, array<String>[]())
Declaration Syntax
C#
protected string[] GetSelectedFromNames(
    string prefix,
    string[] names
)
Parameters
prefix (String)
names (array< String >[]())

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnClose Method (msg)

OnClose Method (msg)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> OnClose(Message)
Declaration Syntax
C#
[HandleMessageAttribute("Tasks:Close")]
public void OnClose(
    Message msg
)
Parameters
msg (Message)

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnLoad Method (e)

OnLoad Method (e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> OnLoad(EventArgs)
Declaration Syntax
C#
protected override void OnLoad(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetTitle Method (title)

SetTitle Method (title)
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> SetTitle(String)
Declaration Syntax
C#
protected static void SetTitle(
    string title
)
Parameters
title (String)

Assembly: MSS.WebSite (Module: MSS.WebSite)


TitleKey Field

TitleKey Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> SecurityBasePage >> TitleKey
Declaration Syntax
C#
protected static readonly string TitleKey

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.SecurityEditor.SecurityField Namespace

MSS.WebSite.Components.SecurityEditor.SecurityField Namespace
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField
Declaration Syntax
C#
namespace MSS.WebSite.Components.SecurityEditor.SecurityField
Types
All Types Classes
Icon | Type | Description
 | SecurityField | Security field control. Render user's rights for the current item


SecurityField Class

SecurityField Class
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField
Security field control. Render user's rights for the current item
Declaration Syntax
C#
[HidePageExtendersAttribute]
public class SecurityField : Page
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityFieldSecurityFieldNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | cblWhoCanEdit |
 | cblWhoHasAccess |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 |
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | lblItemProtected |
 | lblNotEnoughRights |
 | lblNotMssContentItem |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | litWhoCanEdit |
 | litWhoHasAccess |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mlvMain |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides Page.OnInit(EventArgs).)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Page_PreRender(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | rbnAccessToAll |
 | rbnRestricted |
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | viewItemIsProtected |
 | viewNoAccess |
 | viewNotMSSItem |
 | viewSecurity |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | SecurityField

Assembly: MSS.WebSite (Module: MSS.WebSite)


SecurityField Constructor

SecurityField Constructor
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> SecurityFieldSecurityFieldNew()()
Declaration Syntax
C#
public SecurityField()

Assembly: MSS.WebSite (Module: MSS.WebSite)


cblWhoCanEdit Field

cblWhoCanEdit Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> cblWhoCanEdit
Declaration Syntax
C#
protected CheckBoxList cblWhoCanEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


cblWhoHasAccess Field

cblWhoHasAccess Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> cblWhoHasAccess
Declaration Syntax
C#
protected CheckBoxList cblWhoHasAccess

Assembly: MSS.WebSite (Module: MSS.WebSite)


form1 Field

form1 Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> form1
Declaration Syntax
C#
protected HtmlForm form1

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblItemProtected Field

lblItemProtected Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> lblItemProtected
Declaration Syntax
C#
protected Label lblItemProtected

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblNotEnoughRights Field

lblNotEnoughRights Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> lblNotEnoughRights
Declaration Syntax
C#
protected Label lblNotEnoughRights

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblNotMssContentItem Field

lblNotMssContentItem Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> lblNotMssContentItem
Declaration Syntax
C#
protected Label lblNotMssContentItem

Assembly: MSS.WebSite (Module: MSS.WebSite)


litWhoCanEdit Field

litWhoCanEdit Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> litWhoCanEdit
Declaration Syntax
C#
protected Literal litWhoCanEdit

Assembly: MSS.WebSite (Module: MSS.WebSite)


litWhoHasAccess Field

litWhoHasAccess Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> litWhoHasAccess
Declaration Syntax
C#
protected Literal litWhoHasAccess

Assembly: MSS.WebSite (Module: MSS.WebSite)


mlvMain Field

mlvMain Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> mlvMain
Declaration Syntax
C#
protected MultiView mlvMain

Assembly: MSS.WebSite (Module: MSS.WebSite)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_PreRender Method (sender, e)

Page_PreRender Method (sender, e)
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> Page_PreRender(Object, EventArgs)
Declaration Syntax
C#
protected void Page_PreRender(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


rbnAccessToAll Field

rbnAccessToAll Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> rbnAccessToAll
Declaration Syntax
C#
protected RadioButton rbnAccessToAll

Assembly: MSS.WebSite (Module: MSS.WebSite)


rbnRestricted Field

rbnRestricted Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> rbnRestricted
Declaration Syntax
C#
protected RadioButton rbnRestricted

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewItemIsProtected Field

viewItemIsProtected Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> viewItemIsProtected
Declaration Syntax
C#
protected View viewItemIsProtected

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewNoAccess Field

viewNoAccess Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> viewNoAccess
Declaration Syntax
C#
protected View viewNoAccess

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewNotMSSItem Field

viewNotMSSItem Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> viewNotMSSItem
Declaration Syntax
C#
protected View viewNotMSSItem

Assembly: MSS.WebSite (Module: MSS.WebSite)


viewSecurity Field

viewSecurity Field
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> viewSecurity
Declaration Syntax
C#
protected View viewSecurity

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.WebSite.Components.Site_updated Namespace

MSS.WebSite.Components.Site_updated Namespace
Namespaces >> MSS.WebSite.Components.Site_updated
Declaration Syntax
C#
namespace MSS.WebSite.Components.Site_updated
Types
All Types Classes
Icon | Type | Description
 | SiteUpdated | Login user to client when site status is updated.


SiteUpdated Class

SiteUpdated Class
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated
Login user to client when site status is updated.
Declaration Syntax
C#
public class SiteUpdated : UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteUpdatedSiteUpdatedNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblNoContentEditingRight |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LoginForm |
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | SiteUpdated

Assembly: MSS.WebSite (Module: MSS.WebSite)


SiteUpdated Constructor

SiteUpdated Constructor
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> SiteUpdatedSiteUpdatedNew()()
Declaration Syntax
C#
public SiteUpdated()

Assembly: MSS.WebSite (Module: MSS.WebSite)


lblNoContentEditingRight Field

lblNoContentEditingRight Field
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> lblNoContentEditingRight
Declaration Syntax
C#
protected Label lblNoContentEditingRight

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoginForm Field

LoginForm Field
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> LoginForm
Declaration Syntax
C#
protected LoginControl LoginForm

Assembly: MSS.WebSite (Module: MSS.WebSite)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.WebSite (Module: MSS.WebSite)


MSS.Wizard Namespace

MSS.Wizard Namespace
Namespaces >> MSS.Wizard
Declaration Syntax
C#
namespace MSS.Wizard
Types
All Types Classes
Icon | Type | Description
 | ColorPalette | Color palette.
 | SkinSettings | Skin setting keys.


ColorPalette Class

ColorPalette Class
Namespaces >> MSS.Wizard >> ColorPalette
Color palette.
Declaration Syntax
C#
public class ColorPalette
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColorPaletteColorPaletteNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | P2x1 |
 | P4x9 |
 | P8x9 |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ColorPalette

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColorPalette Constructor

ColorPalette Constructor
Namespaces >> MSS.Wizard >> ColorPalette >> ColorPaletteColorPaletteNew()()
Declaration Syntax
C#
public ColorPalette()

Assembly: MSS.Wizard (Module: MSS.Wizard)


Name Field

Name Field
Namespaces >> MSS.Wizard >> ColorPalette >> Name
Declaration Syntax
C#
public const string Name

Assembly: MSS.Wizard (Module: MSS.Wizard)


P2x1 Field

P2x1 Field
Namespaces >> MSS.Wizard >> ColorPalette >> P2x1
Declaration Syntax
C#
public const string P2x1

Assembly: MSS.Wizard (Module: MSS.Wizard)


P4x9 Field

P4x9 Field
Namespaces >> MSS.Wizard >> ColorPalette >> P4x9
Declaration Syntax
C#
public const string P4x9

Assembly: MSS.Wizard (Module: MSS.Wizard)


P8x9 Field

P8x9 Field
Namespaces >> MSS.Wizard >> ColorPalette >> P8x9
Declaration Syntax
C#
public const string P8x9

Assembly: MSS.Wizard (Module: MSS.Wizard)


SkinSettings Class

SkinSettings Class
Namespaces >> MSS.Wizard >> SkinSettings
Skin setting keys.
Declaration Syntax
C#
public class SkinSettings
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkinSettingsSkinSettingsNew()() |
 | BackgroundColor |
 | BackgroundColorNotFound |
 | BackgroundImage |
 | BottomBarImage |
 | BottomBarTextColor |
 | BreadcrumbShow |
 | ButtonSet |
 | ColorNotFoundDicItem |
 | ColumnBarImage |
 | ColumnBarTextColor |
 | ColumnBoxColor |
 | ColumnCenterColor |
 | ColumnLeftColor |
 | ColumnRightColor |
 | ColumnsBackgroundColor |
 | ColumnsBackgroundImage |
 | ContactInfoCity |
 | ContactInfoEmail |
 | ContactInfoName |
 | ContactInfoStreet |
 | ContactInfoStreetNumber |
 | ContactInfoTelefaxNumber |
 | ContactInfoTelephoneNumber |
 | ContactInfoZipCode |
 | ContentBarImage |
 | ContentBarTextColor |
 | DefaultLanguage |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FrontPageColumnColor |
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IdentityColor |
 | IdentityImage |
 | IdentityName |
 | IdentityTextColor |
 | IdentityTextSize |
 | IdentityUploadImage |
 | Languages |
 | LeftMenuDynamic |
 | LeftMenuLevels |
 | LeftMenuRootLevel |
 | LeftMenuShow |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modules |
 | NoIdentityImage |
 | NoTopImage |
 | SiteStatus |
 | SpotCharacterCount |
 | SpotCount |
 | TextColor |
 | TextColorFrontPage |
 | TopBarImage |
 | TopBarTextColor |
 | TopColor |
 | TopImage |
 | TopMenuDynamic |
 | TopMenuLevels |
 | TopMenuRootLevel |
 | TopMenuShow |
 | TopName |
 | TopTextColor |
 | TopTextSize |
 | TopUploadImage |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SkinSettings

Assembly: MSS.Wizard (Module: MSS.Wizard)


SkinSettings Constructor

SkinSettings Constructor
Namespaces >> MSS.Wizard >> SkinSettings >> SkinSettingsSkinSettingsNew()()
Declaration Syntax
C#
public SkinSettings()

Assembly: MSS.Wizard (Module: MSS.Wizard)


BackgroundColor Field

BackgroundColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> BackgroundColor
Declaration Syntax
C#
public const string BackgroundColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


BackgroundColorNotFound Field

BackgroundColorNotFound Field
Namespaces >> MSS.Wizard >> SkinSettings >> BackgroundColorNotFound
Declaration Syntax
C#
public const string BackgroundColorNotFound

Assembly: MSS.Wizard (Module: MSS.Wizard)


BackgroundImage Field

BackgroundImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> BackgroundImage
Declaration Syntax
C#
public const string BackgroundImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


BottomBarImage Field

BottomBarImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> BottomBarImage
Declaration Syntax
C#
public const string BottomBarImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


BottomBarTextColor Field

BottomBarTextColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> BottomBarTextColor
Declaration Syntax
C#
public const string BottomBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


BreadcrumbShow Field

BreadcrumbShow Field
Namespaces >> MSS.Wizard >> SkinSettings >> BreadcrumbShow
Declaration Syntax
C#
public const string BreadcrumbShow

Assembly: MSS.Wizard (Module: MSS.Wizard)


ButtonSet Field

ButtonSet Field
Namespaces >> MSS.Wizard >> SkinSettings >> ButtonSet
Declaration Syntax
C#
public const string ButtonSet

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColorNotFoundDicItem Field

ColorNotFoundDicItem Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColorNotFoundDicItem
Declaration Syntax
C#
public static readonly string ColorNotFoundDicItem

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnBarImage Field

ColumnBarImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnBarImage
Declaration Syntax
C#
public const string ColumnBarImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnBarTextColor Field

ColumnBarTextColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnBarTextColor
Declaration Syntax
C#
public const string ColumnBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnBoxColor Field

ColumnBoxColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnBoxColor
Declaration Syntax
C#
public const string ColumnBoxColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnCenterColor Field

ColumnCenterColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnCenterColor
Declaration Syntax
C#
public const string ColumnCenterColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnLeftColor Field

ColumnLeftColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnLeftColor
Declaration Syntax
C#
public const string ColumnLeftColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnRightColor Field

ColumnRightColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnRightColor
Declaration Syntax
C#
public const string ColumnRightColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnsBackgroundColor Field

ColumnsBackgroundColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnsBackgroundColor
Declaration Syntax
C#
public const string ColumnsBackgroundColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnsBackgroundImage Field

ColumnsBackgroundImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> ColumnsBackgroundImage
Declaration Syntax
C#
public const string ColumnsBackgroundImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoCity Field

ContactInfoCity Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoCity
Declaration Syntax
C#
public const string ContactInfoCity

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoEmail Field

ContactInfoEmail Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoEmail
Declaration Syntax
C#
public const string ContactInfoEmail

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoName Field

ContactInfoName Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoName
Declaration Syntax
C#
public const string ContactInfoName

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoStreet Field

ContactInfoStreet Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoStreet
Declaration Syntax
C#
public const string ContactInfoStreet

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoStreetNumber Field

ContactInfoStreetNumber Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoStreetNumber
Declaration Syntax
C#
public const string ContactInfoStreetNumber

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoTelefaxNumber Field

ContactInfoTelefaxNumber Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoTelefaxNumber
Declaration Syntax
C#
public const string ContactInfoTelefaxNumber

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoTelephoneNumber Field

ContactInfoTelephoneNumber Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoTelephoneNumber
Declaration Syntax
C#
public const string ContactInfoTelephoneNumber

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInfoZipCode Field

ContactInfoZipCode Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContactInfoZipCode
Declaration Syntax
C#
public const string ContactInfoZipCode

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContentBarImage Field

ContentBarImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContentBarImage
Declaration Syntax
C#
public const string ContentBarImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContentBarTextColor Field

ContentBarTextColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> ContentBarTextColor
Declaration Syntax
C#
public const string ContentBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


DefaultLanguage Field

DefaultLanguage Field
Namespaces >> MSS.Wizard >> SkinSettings >> DefaultLanguage
Declaration Syntax
C#
public const string DefaultLanguage

Assembly: MSS.Wizard (Module: MSS.Wizard)


FrontPageColumnColor Field

FrontPageColumnColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> FrontPageColumnColor
Declaration Syntax
C#
public const string FrontPageColumnColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


IdentityColor Field

IdentityColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> IdentityColor
Declaration Syntax
C#
public const string IdentityColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


IdentityImage Field

IdentityImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> IdentityImage
Declaration Syntax
C#
public const string IdentityImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


IdentityName Field

IdentityName Field
Namespaces >> MSS.Wizard >> SkinSettings >> IdentityName
Declaration Syntax
C#
public const string IdentityName

Assembly: MSS.Wizard (Module: MSS.Wizard)


IdentityTextColor Field

IdentityTextColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> IdentityTextColor
Declaration Syntax
C#
public const string IdentityTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


IdentityTextSize Field

IdentityTextSize Field
Namespaces >> MSS.Wizard >> SkinSettings >> IdentityTextSize
Declaration Syntax
C#
public const string IdentityTextSize

Assembly: MSS.Wizard (Module: MSS.Wizard)


IdentityUploadImage Field

IdentityUploadImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> IdentityUploadImage
Declaration Syntax
C#
public const string IdentityUploadImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


Languages Field

Languages Field
Namespaces >> MSS.Wizard >> SkinSettings >> Languages
Declaration Syntax
C#
public const string Languages

Assembly: MSS.Wizard (Module: MSS.Wizard)


LeftMenuDynamic Field

LeftMenuDynamic Field
Namespaces >> MSS.Wizard >> SkinSettings >> LeftMenuDynamic
Declaration Syntax
C#
public const string LeftMenuDynamic

Assembly: MSS.Wizard (Module: MSS.Wizard)


LeftMenuLevels Field

LeftMenuLevels Field
Namespaces >> MSS.Wizard >> SkinSettings >> LeftMenuLevels
Declaration Syntax
C#
public const string LeftMenuLevels

Assembly: MSS.Wizard (Module: MSS.Wizard)


LeftMenuRootLevel Field

LeftMenuRootLevel Field
Namespaces >> MSS.Wizard >> SkinSettings >> LeftMenuRootLevel
Declaration Syntax
C#
public const string LeftMenuRootLevel

Assembly: MSS.Wizard (Module: MSS.Wizard)


LeftMenuShow Field

LeftMenuShow Field
Namespaces >> MSS.Wizard >> SkinSettings >> LeftMenuShow
Declaration Syntax
C#
public const string LeftMenuShow

Assembly: MSS.Wizard (Module: MSS.Wizard)


Modules Field

Modules Field
Namespaces >> MSS.Wizard >> SkinSettings >> Modules
Declaration Syntax
C#
public const string Modules

Assembly: MSS.Wizard (Module: MSS.Wizard)


NoIdentityImage Field

NoIdentityImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> NoIdentityImage
Declaration Syntax
C#
public const string NoIdentityImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


NoTopImage Field

NoTopImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> NoTopImage
Declaration Syntax
C#
public const string NoTopImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


SiteStatus Field

SiteStatus Field
Namespaces >> MSS.Wizard >> SkinSettings >> SiteStatus
Declaration Syntax
C#
public const string SiteStatus

Assembly: MSS.Wizard (Module: MSS.Wizard)


SpotCharacterCount Field

SpotCharacterCount Field
Namespaces >> MSS.Wizard >> SkinSettings >> SpotCharacterCount
Declaration Syntax
C#
public const string SpotCharacterCount

Assembly: MSS.Wizard (Module: MSS.Wizard)


SpotCount Field

SpotCount Field
Namespaces >> MSS.Wizard >> SkinSettings >> SpotCount
Declaration Syntax
C#
public const string SpotCount

Assembly: MSS.Wizard (Module: MSS.Wizard)


TextColor Field

TextColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> TextColor
Declaration Syntax
C#
public const string TextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


TextColorFrontPage Field

TextColorFrontPage Field
Namespaces >> MSS.Wizard >> SkinSettings >> TextColorFrontPage
Declaration Syntax
C#
public const string TextColorFrontPage

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopBarImage Field

TopBarImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopBarImage
Declaration Syntax
C#
public const string TopBarImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopBarTextColor Field

TopBarTextColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopBarTextColor
Declaration Syntax
C#
public const string TopBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopColor Field

TopColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopColor
Declaration Syntax
C#
public const string TopColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopImage Field

TopImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopImage
Declaration Syntax
C#
public const string TopImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopMenuDynamic Field

TopMenuDynamic Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopMenuDynamic
Declaration Syntax
C#
public const string TopMenuDynamic

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopMenuLevels Field

TopMenuLevels Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopMenuLevels
Declaration Syntax
C#
public const string TopMenuLevels

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopMenuRootLevel Field

TopMenuRootLevel Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopMenuRootLevel
Declaration Syntax
C#
public const string TopMenuRootLevel

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopMenuShow Field

TopMenuShow Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopMenuShow
Declaration Syntax
C#
public const string TopMenuShow

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopName Field

TopName Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopName
Declaration Syntax
C#
public const string TopName

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopTextColor Field

TopTextColor Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopTextColor
Declaration Syntax
C#
public const string TopTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopTextSize Field

TopTextSize Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopTextSize
Declaration Syntax
C#
public const string TopTextSize

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopUploadImage Field

TopUploadImage Field
Namespaces >> MSS.Wizard >> SkinSettings >> TopUploadImage
Declaration Syntax
C#
public const string TopUploadImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


MSS.Wizard.API Namespace

MSS.Wizard.API Namespace
Namespaces >> MSS.Wizard.API
Declaration Syntax
C#
namespace MSS.Wizard.API
Types
All Types Classes
Icon | Type | Description
 | WizardHelper | Wizard helper
 | WizardXslHelper | Wizard xsl helper


WizardHelper Class

WizardHelper Class
Namespaces >> MSS.Wizard.API >> WizardHelper
Wizard helper
Declaration Syntax
C#
public class WizardHelper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WizardHelperWizardHelperNew()() |
 | ColorNotFountText | Gets the colour not fount text.
 | DarkColorRecommendation | Gets the dark colour recommendation text from the dictionary.
 | EnableCustomColor | Gets a value indicating whether custom colour is enabled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBrightnesAverage(Bitmap) | Gets the brightness average.
 | GetColorBrightness(String) | Gets the colour brightness.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSelectedImage(ImagePickerDiv, array<SkinImageFile>[]()) | Gets the selected image.
 | GetSelectedImage(array<SkinImageFile>[](), String) | Gets the selected image.
 | GetSelectedImageID(ImagePickerDiv, array<SkinImageFile>[]()) | Gets the selected image ID.
 | GetSelectedSkinImage(array<SkinImageFile>[](), String) | Gets the selected skin image.
 | GetTextColorRecomendation(ImagePickerDiv, array<SkinImageFile>[](), RadioButton, RadioButton) | Gets the text colour recommendation.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeColorPicker(ColorPickerDiv, SkinPackage, String, String, String) | Initializes the colour picker.
 | InitializeImagePicker(ImagePickerDiv, array<SkinImageFile>[](), String) | Initializes the image picker.
 | LightColorRecommendation | Gets the light colour recommendation text from the dictionary.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetClosetsMatchByColor(ColorPickerDiv, String) | Sets the closet by a colour.
 | SetValid(Page, Boolean) | Sets the value for the all page validators.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WizardHelper

Assembly: MSS.Wizard (Module: MSS.Wizard)


WizardHelper Constructor

WizardHelper Constructor
Namespaces >> MSS.Wizard.API >> WizardHelper >> WizardHelperWizardHelperNew()()
Declaration Syntax
C#
public WizardHelper()

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColorNotFountText Property

ColorNotFountText Property
Namespaces >> MSS.Wizard.API >> WizardHelper >> ColorNotFountText
Gets the colour not fount text.
Declaration Syntax
C#
public static string ColorNotFountText{ get;}
Value
The colour not fount text.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DarkColorRecommendation Property

DarkColorRecommendation Property
Namespaces >> MSS.Wizard.API >> WizardHelper >> DarkColorRecommendation
Gets the dark colour recommendation text from the dictionary.
Declaration Syntax
C#
public static string DarkColorRecommendation{ get;}
Value
The dark colour recommendation.

Assembly: MSS.Wizard (Module: MSS.Wizard)


EnableCustomColor Property

EnableCustomColor Property
Namespaces >> MSS.Wizard.API >> WizardHelper >> EnableCustomColor
Gets a value indicating whether custom colour is enabled.
Declaration Syntax
C#
public static bool EnableCustomColor{ get;}
Value
True if custom colors are enabled; otherwise, false.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetBrightnesAverage Method (bm)

GetBrightnesAverage Method (bm)
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetBrightnesAverage(Bitmap)
Gets the brightness average.
Declaration Syntax
C#
public static double GetBrightnesAverage(
    Bitmap bm
)
Parameters
bm (Bitmap)
The bitmap.
Return Value
The brightnes average.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetColorBrightness Method (color)

GetColorBrightness Method (color)
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetColorBrightness(String)
Gets the colour brightness.
Declaration Syntax
C#
public static float GetColorBrightness(
    string color
)
Parameters
color (String)
The colour.
Return Value
The colour brightness.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetSelectedImage Method

GetSelectedImage Method
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetSelectedImage()()
Members
Icon | Member | Description
 | GetSelectedImage(ImagePickerDiv, array<SkinImageFile>[]()) | Gets the selected image.
 | GetSelectedImage(array<SkinImageFile>[](), String) | Gets the selected image.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetSelectedImage Method (images, selectedId)

GetSelectedImage Method (images, selectedId)
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetSelectedImage(array<SkinImageFile>[](), String)
Gets the selected image.
Declaration Syntax
C#
public static Bitmap GetSelectedImage(
    SkinImageFile[] images,
    string selectedId
)
Parameters
images (array< SkinImageFile >[]())
The images.
selectedId (String)
The selected id.
Return Value
The selected image.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetSelectedImage Method (ip, images)

GetSelectedImage Method (ip, images)
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetSelectedImage(ImagePickerDiv, array<SkinImageFile>[]())
Gets the selected image.
Declaration Syntax
C#
public static Bitmap GetSelectedImage(
    ImagePickerDiv ip,
    SkinImageFile[] images
)
Parameters
ip (ImagePickerDiv)
The ip.
images (array< SkinImageFile >[]())
The images.
Return Value
The selected image.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetSelectedImageID Method (imagePicker, images)

GetSelectedImageID Method (imagePicker, images)
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetSelectedImageID(ImagePickerDiv, array<SkinImageFile>[]())
Gets the selected image ID.
Declaration Syntax
C#
public static string GetSelectedImageID(
    ImagePickerDiv imagePicker,
    SkinImageFile[] images
)
Parameters
imagePicker (ImagePickerDiv)
The image picker.
images (array< SkinImageFile >[]())
The images.
Return Value
The selected image ID.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetSelectedSkinImage Method (images, selectedId)

GetSelectedSkinImage Method (images, selectedId)
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetSelectedSkinImage(array<SkinImageFile>[](), String)
Gets the selected skin image.
Declaration Syntax
C#
public static SkinImageFile GetSelectedSkinImage(
    SkinImageFile[] images,
    string selectedId
)
Parameters
images (array< SkinImageFile >[]())
The images.
selectedId (String)
The selected id.
Return Value
The selected skin image.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetTextColorRecomendation Method (ip, images, rbLight, rbDark)

GetTextColorRecomendation Method (ip, images, rbLight, rbDark)
Namespaces >> MSS.Wizard.API >> WizardHelper >> GetTextColorRecomendation(ImagePickerDiv, array<SkinImageFile>[](), RadioButton, RadioButton)
Gets the text colour recommendation.
Declaration Syntax
C#
public static string GetTextColorRecomendation(
    ImagePickerDiv ip,
    SkinImageFile[] images,
    RadioButton rbLight,
    RadioButton rbDark
)
Parameters
ip (ImagePickerDiv)
The image picker.
images (array< SkinImageFile >[]())
The images.
rbLight (RadioButton)
The radio button light.
rbDark (RadioButton)
The radio button dark.
Return Value
The text colour recommendation.

Assembly: MSS.Wizard (Module: MSS.Wizard)


InitializeColorPicker Method (colorPicker, skinPackage, paletteGroup, paletteName, color)

InitializeColorPicker Method (colorPicker, skinPackage, paletteGroup, paletteName, color)
Namespaces >> MSS.Wizard.API >> WizardHelper >> InitializeColorPicker(ColorPickerDiv, SkinPackage, String, String, String)
Initializes the colour picker.
Declaration Syntax
C#
public static bool InitializeColorPicker(
    ColorPickerDiv colorPicker,
    SkinPackage skinPackage,
    string paletteGroup,
    string paletteName,
    string color
)
Parameters
colorPicker (ColorPickerDiv)
The colour picker.
skinPackage (SkinPackage)
The skin package.
paletteGroup (String)
The palette group.
paletteName (String)
Name of the palette.
color (String)
The color.
Return Value
The colour.

Assembly: MSS.Wizard (Module: MSS.Wizard)


InitializeImagePicker Method (imagePicker, images, selectedId)

InitializeImagePicker Method (imagePicker, images, selectedId)
Namespaces >> MSS.Wizard.API >> WizardHelper >> InitializeImagePicker(ImagePickerDiv, array<SkinImageFile>[](), String)
Initializes the image picker.
Declaration Syntax
C#
public static bool InitializeImagePicker(
    ImagePickerDiv imagePicker,
    SkinImageFile[] images,
    string selectedId
)
Parameters
imagePicker (ImagePickerDiv)
The image picker.
images (array< SkinImageFile >[]())
The images.
selectedId (String)
The selected id.
Return Value

Assembly: MSS.Wizard (Module: MSS.Wizard)


LightColorRecommendation Property

LightColorRecommendation Property
Namespaces >> MSS.Wizard.API >> WizardHelper >> LightColorRecommendation
Gets the light colour recommendation text from the dictionary.
Declaration Syntax
C#
public static string LightColorRecommendation{ get;}
Value
The light colour recommendation.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetClosetsMatchByColor Method (colorPicker, colorValue)

SetClosetsMatchByColor Method (colorPicker, colorValue)
Namespaces >> MSS.Wizard.API >> WizardHelper >> SetClosetsMatchByColor(ColorPickerDiv, String)
Sets the closet by a colour.
Declaration Syntax
C#
public static void SetClosetsMatchByColor(
    ColorPickerDiv colorPicker,
    string colorValue
)
Parameters
colorPicker (ColorPickerDiv)
The colour picker.
colorValue (String)
The colour value.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetValid Method (page, value)

SetValid Method (page, value)
Namespaces >> MSS.Wizard.API >> WizardHelper >> SetValid(Page, Boolean)
Sets the value for the all page validators.
Declaration Syntax
C#
public static void SetValid(
    Page page,
    bool value
)
Parameters
page (Page)
The page.
value (Boolean)
if set to true [value].

Assembly: MSS.Wizard (Module: MSS.Wizard)


WizardXslHelper Class

WizardXslHelper Class
Namespaces >> MSS.Wizard.API >> WizardXslHelper
Wizard xsl helper
Declaration Syntax
C#
public class WizardXslHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WizardXslHelperWizardXslHelperNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetIdentityImage()() | Gets the identity image.
 | GetIdentityImageType()() | Gets the type(extension) of the identity image.
 | GetTopImage()() | Gets the top image.
 | GetTopImageType()() | Gets the type(extension) of the top image.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWizardImage(String, array<SkinImageFile>[](), String) | Returns top image path and filename
 | GetWizardImageType(String, array<SkinImageFile>[](), String) | Gets the file type(extension) of top image.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WizardXslHelper

Assembly: MSS.Wizard (Module: MSS.Wizard)


WizardXslHelper Constructor

WizardXslHelper Constructor
Namespaces >> MSS.Wizard.API >> WizardXslHelper >> WizardXslHelperWizardXslHelperNew()()
Declaration Syntax
C#
public WizardXslHelper()

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetIdentityImage Method

GetIdentityImage Method
Namespaces >> MSS.Wizard.API >> WizardXslHelper >> GetIdentityImage()()
Gets the identity image.
Declaration Syntax
C#
public static string GetIdentityImage()
Return Value
The identity image.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetIdentityImageType Method

GetIdentityImageType Method
Namespaces >> MSS.Wizard.API >> WizardXslHelper >> GetIdentityImageType()()
Gets the type(extension) of the identity image.
Declaration Syntax
C#
public static string GetIdentityImageType()
Return Value
The type(extension).

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetTopImage Method

GetTopImage Method
Namespaces >> MSS.Wizard.API >> WizardXslHelper >> GetTopImage()()
Gets the top image.
Declaration Syntax
C#
public static string GetTopImage()
Return Value
The top image.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetTopImageType Method

GetTopImageType Method
Namespaces >> MSS.Wizard.API >> WizardXslHelper >> GetTopImageType()()
Gets the type(extension) of the top image.
Declaration Syntax
C#
public static string GetTopImageType()
Return Value
The top image type.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetWizardImage Method (uploadSetting, images, imageSetting)

GetWizardImage Method (uploadSetting, images, imageSetting)
Namespaces >> MSS.Wizard.API >> WizardXslHelper >> GetWizardImage(String, array<SkinImageFile>[](), String)
Returns top image path and filename
Declaration Syntax
C#
public static string GetWizardImage(
    string uploadSetting,
    SkinImageFile[] images,
    string imageSetting
)
Parameters
uploadSetting (String)
images (array< SkinImageFile >[]())
imageSetting (String)
Return Value
The top image path and file name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetWizardImageType Method (uploadSetting, images, imageSetting)

GetWizardImageType Method (uploadSetting, images, imageSetting)
Namespaces >> MSS.Wizard.API >> WizardXslHelper >> GetWizardImageType(String, array<SkinImageFile>[](), String)
Gets the file type(extension) of top image.
Declaration Syntax
C#
public static string GetWizardImageType(
    string uploadSetting,
    SkinImageFile[] images,
    string imageSetting
)
Parameters
uploadSetting (String)
images (array< SkinImageFile >[]())
imageSetting (String)
Return Value
The file type(extension).

Assembly: MSS.Wizard (Module: MSS.Wizard)


MSS.Wizard.Pages Namespace

MSS.Wizard.Pages Namespace
Namespaces >> MSS.Wizard.Pages
Declaration Syntax
C#
namespace MSS.Wizard.Pages
Types
All Types Classes
Icon | Type | Description
 | MainLayout | Main wizard layout
 | RgbColor | RgbColor class. Rgb color page shows rgb control.
 | Upload | Upload image dialog
 | Wizard | Wizard page. Redirects to the site type wizard.
 | WizardPage | Base class for the wizard pages


MainLayout Class

MainLayout Class
Namespaces >> MSS.Wizard.Pages >> MainLayout
Main wizard layout
Declaration Syntax
C#
public class MainLayout : WizardPage
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MainLayoutMainLayoutNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | ddlLanguageSelection |
 | ddlLanguageSelection_SelectedIndexChanged(Object, EventArgs) | Handles the SelectedIndexChanged event of the Language Selection control.
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control. (Inherited from MSSPage.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | lblAbout |
 | lblLanguageSelection |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | mainform |
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Inherited from MSSPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveData()() | Called when data is to be saved. (Inherited from WizardPage.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | (Inherited from WizardPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PlaceHolder |
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer. (Inherited from MSSPage.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RedirectToStartPage()() | Redirects to the wizard start page. (Inherited from WizardPage.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet. (Inherited from MSSPage.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script. (Inherited from MSSPage.)
 | RegisterScriptBlock(String, String) | Registers the script block. (Inherited from MSSPage.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | Save()() | Saves the settings. (Inherited from WizardPage.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveData | (Inherited from WizardPage.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings. (Inherited from MSSPage.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | Wizard_Logo |
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | WizardPage
 |  |  |  |  |  | MainLayout

Assembly: MSS.Wizard (Module: MSS.Wizard)


MainLayout Constructor

MainLayout Constructor
Namespaces >> MSS.Wizard.Pages >> MainLayout >> MainLayoutMainLayoutNew()()
Declaration Syntax
C#
public MainLayout()

Assembly: MSS.Wizard (Module: MSS.Wizard)


ddlLanguageSelection Field

ddlLanguageSelection Field
Namespaces >> MSS.Wizard.Pages >> MainLayout >> ddlLanguageSelection
Declaration Syntax
C#
protected DropDownList ddlLanguageSelection

Assembly: MSS.Wizard (Module: MSS.Wizard)


ddlLanguageSelection_SelectedIndexChanged Method (sender, e)

ddlLanguageSelection_SelectedIndexChanged Method (sender, e)
Namespaces >> MSS.Wizard.Pages >> MainLayout >> ddlLanguageSelection_SelectedIndexChanged(Object, EventArgs)
Handles the SelectedIndexChanged event of the Language Selection control.
Declaration Syntax
C#
protected void ddlLanguageSelection_SelectedIndexChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblAbout Field

lblAbout Field
Namespaces >> MSS.Wizard.Pages >> MainLayout >> lblAbout
Declaration Syntax
C#
protected Label lblAbout

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblLanguageSelection Field

lblLanguageSelection Field
Namespaces >> MSS.Wizard.Pages >> MainLayout >> lblLanguageSelection
Declaration Syntax
C#
protected Label lblLanguageSelection

Assembly: MSS.Wizard (Module: MSS.Wizard)


mainform Field

mainform Field
Namespaces >> MSS.Wizard.Pages >> MainLayout >> mainform
Declaration Syntax
C#
protected HtmlForm mainform

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.Pages >> MainLayout >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


PlaceHolder Field

PlaceHolder Field
Namespaces >> MSS.Wizard.Pages >> MainLayout >> PlaceHolder
Declaration Syntax
C#
protected Placeholder PlaceHolder

Assembly: MSS.Wizard (Module: MSS.Wizard)


Wizard_Logo Field

Wizard_Logo Field
Namespaces >> MSS.Wizard.Pages >> MainLayout >> Wizard_Logo
Declaration Syntax
C#
protected XslFile Wizard_Logo

Assembly: MSS.Wizard (Module: MSS.Wizard)


RgbColor Class

RgbColor Class
Namespaces >> MSS.Wizard.Pages >> RgbColor
RgbColor class.
Rgb color page shows rgb control.
Declaration Syntax
C#
public class RgbColor : WizardPage
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RgbColorRgbColorNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | colorPicker | colorPicker control.
 | colorPicker_Click(Object, EventArgs) |
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control. (Inherited from MSSPage.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 | form1 control.
 | frameFieldValue | frameFieldValue control.
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Inherited from MSSPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveData()() | Called when data is to be saved. (Inherited from WizardPage.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | (Inherited from WizardPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer. (Inherited from MSSPage.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RedirectToStartPage()() | Redirects to the wizard start page. (Inherited from WizardPage.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet. (Inherited from MSSPage.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script. (Inherited from MSSPage.)
 | RegisterScriptBlock(String, String) | Registers the script block. (Inherited from MSSPage.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | Save()() | Saves the settings. (Inherited from WizardPage.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveData | (Inherited from WizardPage.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings. (Inherited from MSSPage.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | WizardPage
 |  |  |  |  |  | RgbColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


RgbColor Constructor

RgbColor Constructor
Namespaces >> MSS.Wizard.Pages >> RgbColor >> RgbColorRgbColorNew()()
Declaration Syntax
C#
public RgbColor()

Assembly: MSS.Wizard (Module: MSS.Wizard)


colorPicker Field

colorPicker Field
Namespaces >> MSS.Wizard.Pages >> RgbColor >> colorPicker
colorPicker control.
Declaration Syntax
C#
protected ColorPickerDiv colorPicker
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Wizard (Module: MSS.Wizard)


colorPicker_Click Method (sender, e)

colorPicker_Click Method (sender, e)
Namespaces >> MSS.Wizard.Pages >> RgbColor >> colorPicker_Click(Object, EventArgs)
Declaration Syntax
C#
protected void colorPicker_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


form1 Field

form1 Field
Namespaces >> MSS.Wizard.Pages >> RgbColor >> form1
form1 control.
Declaration Syntax
C#
protected HtmlForm form1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Wizard (Module: MSS.Wizard)


frameFieldValue Field

frameFieldValue Field
Namespaces >> MSS.Wizard.Pages >> RgbColor >> frameFieldValue
frameFieldValue control.
Declaration Syntax
C#
protected HiddenField frameFieldValue
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.Pages >> RgbColor >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Upload Class

Upload Class
Namespaces >> MSS.Wizard.Pages >> Upload
Upload image dialog
Declaration Syntax
C#
public class Upload : WizardPage
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UploadUploadNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnCancel |
 | btnCancel_Click(Object, EventArgs) |
 | btnOK |
 | btnOK_Click(Object, EventArgs) |
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control. (Inherited from MSSPage.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | Form1 |
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | lblUpload |
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Inherited from MSSPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveData()() | Called when data is to be saved. (Inherited from WizardPage.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | (Inherited from WizardPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlNavigation |
 | pnlText |
 | pnlUpload |
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer. (Inherited from MSSPage.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RedirectToStartPage()() | Redirects to the wizard start page. (Inherited from WizardPage.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet. (Inherited from MSSPage.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script. (Inherited from MSSPage.)
 | RegisterScriptBlock(String, String) | Registers the script block. (Inherited from MSSPage.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | Save()() | Saves the settings. (Inherited from WizardPage.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveData | (Inherited from WizardPage.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings. (Inherited from MSSPage.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | UploadFile |
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | WizardPage
 |  |  |  |  |  | Upload

Assembly: MSS.Wizard (Module: MSS.Wizard)


Upload Constructor

Upload Constructor
Namespaces >> MSS.Wizard.Pages >> Upload >> UploadUploadNew()()
Declaration Syntax
C#
public Upload()

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnCancel Field

btnCancel Field
Namespaces >> MSS.Wizard.Pages >> Upload >> btnCancel
Declaration Syntax
C#
protected Button btnCancel

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnCancel_Click Method (sender, e)

btnCancel_Click Method (sender, e)
Namespaces >> MSS.Wizard.Pages >> Upload >> btnCancel_Click(Object, EventArgs)
Declaration Syntax
C#
protected void btnCancel_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnOK Field

btnOK Field
Namespaces >> MSS.Wizard.Pages >> Upload >> btnOK
Declaration Syntax
C#
protected Button btnOK

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnOK_Click Method (sender, e)

btnOK_Click Method (sender, e)
Namespaces >> MSS.Wizard.Pages >> Upload >> btnOK_Click(Object, EventArgs)
Declaration Syntax
C#
protected void btnOK_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Form1 Field

Form1 Field
Namespaces >> MSS.Wizard.Pages >> Upload >> Form1
Declaration Syntax
C#
protected HtmlForm Form1

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblUpload Field

lblUpload Field
Namespaces >> MSS.Wizard.Pages >> Upload >> lblUpload
Declaration Syntax
C#
protected Label lblUpload

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlNavigation Field

pnlNavigation Field
Namespaces >> MSS.Wizard.Pages >> Upload >> pnlNavigation
Declaration Syntax
C#
protected Panel pnlNavigation

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlText Field

pnlText Field
Namespaces >> MSS.Wizard.Pages >> Upload >> pnlText
Declaration Syntax
C#
protected Panel pnlText

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlUpload Field

pnlUpload Field
Namespaces >> MSS.Wizard.Pages >> Upload >> pnlUpload
Declaration Syntax
C#
protected Panel pnlUpload

Assembly: MSS.Wizard (Module: MSS.Wizard)


UploadFile Field

UploadFile Field
Namespaces >> MSS.Wizard.Pages >> Upload >> UploadFile
Declaration Syntax
C#
protected HtmlInputFile UploadFile

Assembly: MSS.Wizard (Module: MSS.Wizard)


Wizard Class

Wizard Class
Namespaces >> MSS.Wizard.Pages >> Wizard
Wizard page. Redirects to the site type wizard.
Declaration Syntax
C#
public class Wizard : WizardPage
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WizardWizardNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control. (Inherited from MSSPage.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | form1 |
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Inherited from MSSPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveData()() | Called when data is to be saved. (Inherited from WizardPage.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | (Inherited from WizardPage.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer. (Inherited from MSSPage.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RedirectToStartPage()() | Redirects to the wizard start page. (Inherited from WizardPage.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet. (Inherited from MSSPage.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script. (Inherited from MSSPage.)
 | RegisterScriptBlock(String, String) | Registers the script block. (Inherited from MSSPage.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | Save()() | Saves the settings. (Inherited from WizardPage.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveData | (Inherited from WizardPage.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings. (Inherited from MSSPage.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | WizardPage
 |  |  |  |  |  | Wizard

Assembly: MSS.Wizard (Module: MSS.Wizard)


Wizard Constructor

Wizard Constructor
Namespaces >> MSS.Wizard.Pages >> Wizard >> WizardWizardNew()()
Declaration Syntax
C#
public Wizard()

Assembly: MSS.Wizard (Module: MSS.Wizard)


form1 Field

form1 Field
Namespaces >> MSS.Wizard.Pages >> Wizard >> form1
Declaration Syntax
C#
protected HtmlForm form1

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.Pages >> Wizard >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


WizardPage Class

WizardPage Class
Namespaces >> MSS.Wizard.Pages >> WizardPage
Base class for the wizard pages
Declaration Syntax
C#
[HidePageExtendersAttribute]
public class WizardPage : MSSPage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WizardPageWizardPageNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | FindFormControl(Control) | Finds the form control. (Inherited from MSSPage.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | (Inherited from MSSPage.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveData()() | Called when data is to be saved.
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | (Overrides Control.OnUnload(EventArgs).)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | PrintOnLoad()() | Add javascript to the page which will send page to printer. (Inherited from MSSPage.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RedirectToStartPage()() | Redirects to the wizard start page.
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterCSSStylesheet(String) | Registers a stylesheet. (Inherited from MSSPage.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterScript(String, String) | Registers the script. (Inherited from MSSPage.)
 | RegisterScriptBlock(String, String) | Registers the script block. (Inherited from MSSPage.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | Save()() | Saves the settings.
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveData |
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the site settings. (Inherited from MSSPage.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | MSSPage
 |  |  |  |  | WizardPage
 |  |  |  |  |  | MainLayout
 |  |  |  |  |  | Wizard
 |  |  |  |  |  | RgbColor
 |  |  |  |  |  | Upload

Assembly: MSS.Wizard (Module: MSS.Wizard)


WizardPage Constructor

WizardPage Constructor
Namespaces >> MSS.Wizard.Pages >> WizardPage >> WizardPageWizardPageNew()()
Declaration Syntax
C#
public WizardPage()

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnSaveData Method

OnSaveData Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> OnSaveData()()
Called when data is to be saved.
Declaration Syntax
C#
protected void OnSaveData()

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnUnload Method (e)

OnUnload Method (e)
Namespaces >> MSS.Wizard.Pages >> WizardPage >> OnUnload(EventArgs)
Declaration Syntax
C#
protected override void OnUnload(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


RedirectToStartPage Method

RedirectToStartPage Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> RedirectToStartPage()()
Redirects to the wizard start page.
Declaration Syntax
C#
public void RedirectToStartPage()

Assembly: MSS.Wizard (Module: MSS.Wizard)


Save Method

Save Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> Save()()
Saves the settings.
Declaration Syntax
C#
public void Save()

Assembly: MSS.Wizard (Module: MSS.Wizard)


SaveData Event

SaveData Event
Namespaces >> MSS.Wizard.Pages >> WizardPage >> SaveData
Declaration Syntax
C#
public event EventHandler SaveData

Assembly: MSS.Wizard (Module: MSS.Wizard)


MSS.Wizard.Skins Namespace

MSS.Wizard.Skins Namespace
Namespaces >> MSS.Wizard.Skins
Declaration Syntax
C#
namespace MSS.Wizard.Skins
Types
All Types Classes
Icon | Type | Description
 | CssFactrory | Css factory
 | SkinCssPage | Writes wizard styles to the response.


CssFactrory Class

CssFactrory Class
Namespaces >> MSS.Wizard.Skins >> CssFactrory
Css factory
Declaration Syntax
C#
public class CssFactrory : ICssFactory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CssFactroryCssFactroryNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCss(SiteContext) | Gets the CSS for a site.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetCache(SiteContext) | Resets the css cache.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CssFactrory

Assembly: MSS.Wizard (Module: MSS.Wizard)


CssFactrory Constructor

CssFactrory Constructor
Namespaces >> MSS.Wizard.Skins >> CssFactrory >> CssFactroryCssFactroryNew()()
Declaration Syntax
C#
public CssFactrory()

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetCss Method (site)

GetCss Method (site)
Namespaces >> MSS.Wizard.Skins >> CssFactrory >> GetCss(SiteContext)
Gets the CSS for a site.
Declaration Syntax
C#
public string GetCss(
    SiteContext site
)
Parameters
site (SiteContext)
The site.
Return Value
The CSS.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ResetCache Method (site)

ResetCache Method (site)
Namespaces >> MSS.Wizard.Skins >> CssFactrory >> ResetCache(SiteContext)
Resets the css cache.
Declaration Syntax
C#
public void ResetCache(
    SiteContext site
)
Parameters
site (SiteContext)
The site.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SkinCssPage Class

SkinCssPage Class
Namespaces >> MSS.Wizard.Skins >> SkinCssPage
Writes wizard styles to the response.
Declaration Syntax
C#
public class SkinCssPage : Page
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkinCssPageSkinCssPageNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddContentTemplate(String, ITemplate) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AddWrappedFileDependencies(Object) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
 | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | AspCompatBeginProcessRequest(HttpContext, AsyncCallback, Object) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatEndProcessRequest(IAsyncResult) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
 | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
 | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
 | AsyncPageBeginProcessRequest(HttpContext, AsyncCallback, Object) | Begins processing an asynchronous page request. (Inherited from Page.)
 | AsyncPageEndProcessRequest(IAsyncResult) | Ends processing an asynchronous page request. (Inherited from Page.)
 | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
 | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
 | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
 | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
 | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateHtmlTextWriter(TextWriter) | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DeterminePostBackMode()() | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableEventValidation | (Inherited from Page.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
 | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | ExecuteRegisteredAsyncTasks()() | Starts the execution of an asynchronous task. (Inherited from Page.)
 | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form | Gets the HTML form for the page. (Inherited from Page.)
 | FrameworkInitialize()() | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
 | GetDataItem()() | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetPostBackClientEvent(Control, String) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackClientHyperlink(Control, String) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeHashCode()() | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
 | GetValidators(String) | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
 | GetWrappedFileDependencies(array<String>[]()) | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
 | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
 | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
 | InitializeCulture()() | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
 | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
 | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsClientScriptBlockRegistered(String) | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
 | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
 | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
 | IsStartupScriptRegistered(String) | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
 | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadPageStateFromPersistenceMedium()() | Loads any saved view-state information to the Page object. (Inherited from Page.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
 | MapPath(String) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
 | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
 | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event to initialize the page. (Inherited from Page.)
 | OnInitComplete(EventArgs) | Raises the InitComplete event after page initialization. (Inherited from Page.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnLoadComplete(EventArgs) | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
 | OnPreInit(EventArgs) | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
 | OnPreLoad(EventArgs) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnPreRenderComplete(EventArgs) | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
 | OnSaveStateComplete(EventArgs) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
 | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
 | PreLoad | Occurs before the page Load event. (Inherited from Page.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
 | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
 | ProcessRequest(HttpContext) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(IPostBackEventHandler, String) | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RegisterArrayDeclaration(String, String) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
 | RegisterAsyncTask(PageAsyncTask) | Registers a new asynchronous task with the page. (Inherited from Page.)
 | RegisterClientScriptBlock(String, String) | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
 | RegisterHiddenField(String, String) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
 | RegisterOnSubmitStatement(String, String) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
 | RegisterRequiresControlState(Control) | Registers a control as one whose control state must be persisted. (Inherited from Page.)
 | RegisterRequiresPostBack(Control) | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
 | RegisterRequiresRaiseEvent(IPostBackEventHandler) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
 | RegisterRequiresViewStateEncryption()() | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
 | RegisterStartupScript(String, String) | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
 | RegisterViewStateHandler()() | Causes page view state to be persisted, if called. (Inherited from Page.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
 | RequiresControlState(Control) | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
 | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SavePageStateToPersistenceMedium(Object) | Saves any view-state and control-state information for the page. (Inherited from Page.)
 | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
 | SaveViewState()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
 | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
 | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
 | Title | Gets or sets the title for the page. (Inherited from Page.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
 | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
 | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
 | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
 | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UnregisterRequiresControlState(Control) | Stops persistence of control state for the specified control. (Inherited from Page.)
 | User | Gets information about the user making the page request. (Inherited from Page.)
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
 | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
 | VerifyRenderingInServerForm(Control) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
 | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | Page
 |  |  |  | SkinCssPage

Assembly: MSS.Wizard (Module: MSS.Wizard)


SkinCssPage Constructor

SkinCssPage Constructor
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> SkinCssPageSkinCssPageNew()()
Declaration Syntax
C#
public SkinCssPage()

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


MSS.Wizard.UserControls Namespace

MSS.Wizard.UserControls Namespace
Namespaces >> MSS.Wizard.UserControls
Declaration Syntax
C#
namespace MSS.Wizard.UserControls
Types
All Types Classes
Icon | Type | Description
 | Background | Renders background configuration panel
 | BarDesign | Renders identity bar configuration panel
 | BarDesignExtra | Renders individual bar configuration panel
 | BaseIdentityControl | Renders the Base Identity.
 | Buttons | Render button set for the selected skin
 | ChooseSkin | Render list of the available skins for the selected skin package.
 | ChooseSkinPackage | Render list of the skin packages
 | Columns | Renders columns colour configuration panel.
 | ColumnsBackground | Renders columns background color configurate panel
 | ContactInformation | Renders contact information panel
 | FrontPageColumn | Renders site front page colour configuration panel.
 | Identity | Renders site identity configuration panel
 | Introduction | Introduction class. Renders wizard menu, content and navigation buttons
 | Language | Renders a list of available languages and the current default language.
 | Modules | Modules application.
 | Navigation | Displays the site navigation configuration panel.
 | NavigationButtons |
 | Normal | Normal wizard control.
 | Settings | Settings application.
 | TopBar | Top bar configuration page
 | WizardControl | Base wizard control


Background Class

Background Class
Namespaces >> MSS.Wizard.UserControls >> Background
Renders background configuration panel
Declaration Syntax
C#
public class Background : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BackgroundBackgroundNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | cpBackgroundColor |
 | cpBackgroundColor_Click(Object, EventArgs) |
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipBackgroundImage |
 | ipBackgroundImage_Click(Object, EventArgs) |
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtBackground |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valBackgroundReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Background

Assembly: MSS.Wizard (Module: MSS.Wizard)


Background Constructor

Background Constructor
Namespaces >> MSS.Wizard.UserControls >> Background >> BackgroundBackgroundNew()()
Declaration Syntax
C#
public Background()

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpBackgroundColor Field

cpBackgroundColor Field
Namespaces >> MSS.Wizard.UserControls >> Background >> cpBackgroundColor
Declaration Syntax
C#
protected ColorPickerDiv cpBackgroundColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpBackgroundColor_Click Method (sender, e)

cpBackgroundColor_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Background >> cpBackgroundColor_Click(Object, EventArgs)
Declaration Syntax
C#
protected void cpBackgroundColor_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipBackgroundImage Field

ipBackgroundImage Field
Namespaces >> MSS.Wizard.UserControls >> Background >> ipBackgroundImage
Declaration Syntax
C#
protected ImagePickerDiv ipBackgroundImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipBackgroundImage_Click Method (sender, e)

ipBackgroundImage_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Background >> ipBackgroundImage_Click(Object, EventArgs)
Declaration Syntax
C#
protected void ipBackgroundImage_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Background >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


txtBackground Field

txtBackground Field
Namespaces >> MSS.Wizard.UserControls >> Background >> txtBackground
Declaration Syntax
C#
protected TextBox txtBackground

Assembly: MSS.Wizard (Module: MSS.Wizard)


valBackgroundReq Field

valBackgroundReq Field
Namespaces >> MSS.Wizard.UserControls >> Background >> valBackgroundReq
Declaration Syntax
C#
protected RequiredFieldValidator valBackgroundReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


BarDesign Class

BarDesign Class
Namespaces >> MSS.Wizard.UserControls >> BarDesign
Renders identity bar configuration panel
Declaration Syntax
C#
public class BarDesign : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarDesignBarDesignNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | form |
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipBars |
 | ipBars_Click(Object, EventArgs) |
 | ipTopbar |
 | ipTopbar_Click(Object, EventArgs) |
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblBarRemark |
 | lblbars |
 | lblBarTextColor |
 | lblTopbars |
 | lblTopRemark |
 | lblTopTextColor |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlBarTextColor |
 | pnlTopTextColor |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | rbBar_CheckedChanged(Object, EventArgs) |
 | rbBarDark |
 | rbBarLight |
 | rbTop_CheckedChanged(Object, EventArgs) |
 | rbTopDark |
 | rbTopLight |
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valColumnReq |
 | valTopReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | BarDesign

Assembly: MSS.Wizard (Module: MSS.Wizard)


BarDesign Constructor

BarDesign Constructor
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> BarDesignBarDesignNew()()
Declaration Syntax
C#
public BarDesign()

Assembly: MSS.Wizard (Module: MSS.Wizard)


form Field

form Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> form
Declaration Syntax
C#
protected Form form

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipBars Field

ipBars Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> ipBars
Declaration Syntax
C#
protected ImagePickerDiv ipBars

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipBars_Click Method (sender, e)

ipBars_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> ipBars_Click(Object, EventArgs)
Declaration Syntax
C#
protected void ipBars_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipTopbar Field

ipTopbar Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> ipTopbar
Declaration Syntax
C#
protected ImagePickerDiv ipTopbar

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipTopbar_Click Method (sender, e)

ipTopbar_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> ipTopbar_Click(Object, EventArgs)
Declaration Syntax
C#
protected void ipTopbar_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblBarRemark Field

lblBarRemark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> lblBarRemark
Declaration Syntax
C#
protected Label lblBarRemark

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblbars Field

lblbars Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> lblbars
Declaration Syntax
C#
protected Label lblbars

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblBarTextColor Field

lblBarTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> lblBarTextColor
Declaration Syntax
C#
protected Label lblBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblTopbars Field

lblTopbars Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> lblTopbars
Declaration Syntax
C#
protected Label lblTopbars

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblTopRemark Field

lblTopRemark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> lblTopRemark
Declaration Syntax
C#
protected Label lblTopRemark

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblTopTextColor Field

lblTopTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> lblTopTextColor
Declaration Syntax
C#
protected Label lblTopTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlBarTextColor Field

pnlBarTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> pnlBarTextColor
Declaration Syntax
C#
protected Panel pnlBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlTopTextColor Field

pnlTopTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> pnlTopTextColor
Declaration Syntax
C#
protected Panel pnlTopTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbBar_CheckedChanged Method (sender, e)

rbBar_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> rbBar_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbBar_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbBarDark Field

rbBarDark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> rbBarDark
Declaration Syntax
C#
protected RadioButton rbBarDark

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbBarLight Field

rbBarLight Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> rbBarLight
Declaration Syntax
C#
protected RadioButton rbBarLight

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbTop_CheckedChanged Method (sender, e)

rbTop_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> rbTop_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbTop_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbTopDark Field

rbTopDark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> rbTopDark
Declaration Syntax
C#
protected RadioButton rbTopDark

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbTopLight Field

rbTopLight Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> rbTopLight
Declaration Syntax
C#
protected RadioButton rbTopLight

Assembly: MSS.Wizard (Module: MSS.Wizard)


valColumnReq Field

valColumnReq Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> valColumnReq
Declaration Syntax
C#
protected RequiredFieldValidator valColumnReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valTopReq Field

valTopReq Field
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> valTopReq
Declaration Syntax
C#
protected RequiredFieldValidator valTopReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


BarDesignExtra Class

BarDesignExtra Class
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra
Renders individual bar configuration panel
Declaration Syntax
C#
public class BarDesignExtra : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarDesignExtraBarDesignExtraNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BottombarForm |
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | ContentBarForm |
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Form1 |
 | Form2 |
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipBottombar |
 | ipBottombar_Click(Object, EventArgs) |
 | ipContentBars |
 | ipContentBars_Click(Object, EventArgs) |
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblBottombars |
 | lblBottombarTextColor |
 | lblBottomRemark |
 | lblContentBarRemark |
 | lblContentbars |
 | lblContentBarTextColor |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlBottombarTextColor |
 | pnlContentBarTextColor |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | rbBottom_CheckedChanged(Object, EventArgs) |
 | rbBottomDark |
 | rbBottomLight |
 | rbContentBar_CheckedChanged(Object, EventArgs) |
 | rbContentBarDark |
 | rbContentBarLight |
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valBottomReq |
 | valContentReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | BarDesignExtra

Assembly: MSS.Wizard (Module: MSS.Wizard)


BarDesignExtra Constructor

BarDesignExtra Constructor
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> BarDesignExtraBarDesignExtraNew()()
Declaration Syntax
C#
public BarDesignExtra()

Assembly: MSS.Wizard (Module: MSS.Wizard)


BottombarForm Field

BottombarForm Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> BottombarForm
Declaration Syntax
C#
protected Form BottombarForm

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContentBarForm Field

ContentBarForm Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> ContentBarForm
Declaration Syntax
C#
protected Form ContentBarForm

Assembly: MSS.Wizard (Module: MSS.Wizard)


Form1 Field

Form1 Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> Form1
Declaration Syntax
C#
protected Form Form1

Assembly: MSS.Wizard (Module: MSS.Wizard)


Form2 Field

Form2 Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> Form2
Declaration Syntax
C#
protected Form Form2

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipBottombar Field

ipBottombar Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> ipBottombar
Declaration Syntax
C#
protected ImagePickerDiv ipBottombar

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipBottombar_Click Method (sender, e)

ipBottombar_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> ipBottombar_Click(Object, EventArgs)
Declaration Syntax
C#
protected void ipBottombar_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipContentBars Field

ipContentBars Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> ipContentBars
Declaration Syntax
C#
protected ImagePickerDiv ipContentBars

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipContentBars_Click Method (sender, e)

ipContentBars_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> ipContentBars_Click(Object, EventArgs)
Declaration Syntax
C#
protected void ipContentBars_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblBottombars Field

lblBottombars Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> lblBottombars
Declaration Syntax
C#
protected Label lblBottombars

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblBottombarTextColor Field

lblBottombarTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> lblBottombarTextColor
Declaration Syntax
C#
protected Label lblBottombarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblBottomRemark Field

lblBottomRemark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> lblBottomRemark
Declaration Syntax
C#
protected Label lblBottomRemark

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblContentBarRemark Field

lblContentBarRemark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> lblContentBarRemark
Declaration Syntax
C#
protected Label lblContentBarRemark

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblContentbars Field

lblContentbars Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> lblContentbars
Declaration Syntax
C#
protected Label lblContentbars

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblContentBarTextColor Field

lblContentBarTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> lblContentBarTextColor
Declaration Syntax
C#
protected Label lblContentBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlBottombarTextColor Field

pnlBottombarTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> pnlBottombarTextColor
Declaration Syntax
C#
protected Panel pnlBottombarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlContentBarTextColor Field

pnlContentBarTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> pnlContentBarTextColor
Declaration Syntax
C#
protected Panel pnlContentBarTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbBottom_CheckedChanged Method (sender, e)

rbBottom_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> rbBottom_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbBottom_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbBottomDark Field

rbBottomDark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> rbBottomDark
Declaration Syntax
C#
protected RadioButton rbBottomDark

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbBottomLight Field

rbBottomLight Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> rbBottomLight
Declaration Syntax
C#
protected RadioButton rbBottomLight

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbContentBar_CheckedChanged Method (sender, e)

rbContentBar_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> rbContentBar_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbContentBar_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbContentBarDark Field

rbContentBarDark Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> rbContentBarDark
Declaration Syntax
C#
protected RadioButton rbContentBarDark

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbContentBarLight Field

rbContentBarLight Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> rbContentBarLight
Declaration Syntax
C#
protected RadioButton rbContentBarLight

Assembly: MSS.Wizard (Module: MSS.Wizard)


valBottomReq Field

valBottomReq Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> valBottomReq
Declaration Syntax
C#
protected RequiredFieldValidator valBottomReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valContentReq Field

valContentReq Field
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> valContentReq
Declaration Syntax
C#
protected RequiredFieldValidator valContentReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


BaseIdentityControl Class

BaseIdentityControl Class
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl
Renders the Base Identity.
Declaration Syntax
C#
public class BaseIdentityControl : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseIdentityControlBaseIdentityControlNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnUpload |
 | btnUpload_Click(Object, EventArgs) | Handles the Click event of the upload button.
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ColorSetting |
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | cpIdentitybar |
 | cpIdentitybar_Click(Object, EventArgs) | Handles the Click event of the identity bar colour picker.
 | cpTextColor |
 | cpTextColor_Click(Object, EventArgs) | Handles the Click event of the text colour picker control.
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | ddTextsize |
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | identityForm |
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Images |
 | ImageSetting |
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipIdentitybar |
 | ipIdentitybar_Click(Object, EventArgs) | Handles the Click event of the identity bar image picker.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblIdentitybarName |
 | lblImage |
 | lblTextColor |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NameSetting |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NotUseImageSetting |
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Init(Object, EventArgs) |
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlCenter |
 | pnlColor |
 | pnlImage |
 | pnlName |
 | pnlUpload |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | rbColor |
 | rbColor_CheckedChanged(Object, EventArgs) |
 | rbCustomImage |
 | rbCustomImage_CheckedChanged(Object, EventArgs) |
 | rbImage |
 | rbImage_CheckedChanged(Object, EventArgs) |
 | rbTransparent |
 | rbTransparent_CheckedChanged(Object, EventArgs) |
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | TextColorSetting |
 | TextSizeSetting |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtIdentitybarname |
 | txtTextColor |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | uploadedImage |
 | UploadImageSetting |
 | valColorReq |
 | valImageReq |
 | valTextColorReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | BaseIdentityControl

Assembly: MSS.Wizard (Module: MSS.Wizard)


BaseIdentityControl Constructor

BaseIdentityControl Constructor
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> BaseIdentityControlBaseIdentityControlNew()()
Declaration Syntax
C#
public BaseIdentityControl()

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnUpload Field

btnUpload Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> btnUpload
Declaration Syntax
C#
protected Button btnUpload

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnUpload_Click Method (sender, e)

btnUpload_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> btnUpload_Click(Object, EventArgs)
Handles the Click event of the upload button.
Declaration Syntax
C#
protected void btnUpload_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColorSetting Property

ColorSetting Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> ColorSetting
Declaration Syntax
C#
public string ColorSetting{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpIdentitybar Field

cpIdentitybar Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> cpIdentitybar
Declaration Syntax
C#
protected ColorPickerDiv cpIdentitybar

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpIdentitybar_Click Method (sender, e)

cpIdentitybar_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> cpIdentitybar_Click(Object, EventArgs)
Handles the Click event of the identity bar colour picker.
Declaration Syntax
C#
protected void cpIdentitybar_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpTextColor Field

cpTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> cpTextColor
Declaration Syntax
C#
protected ColorPickerDiv cpTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpTextColor_Click Method (sender, e)

cpTextColor_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> cpTextColor_Click(Object, EventArgs)
Handles the Click event of the text colour picker control.
Declaration Syntax
C#
protected void cpTextColor_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ddTextsize Field

ddTextsize Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> ddTextsize
Declaration Syntax
C#
protected DropDownList ddTextsize

Assembly: MSS.Wizard (Module: MSS.Wizard)


identityForm Field

identityForm Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> identityForm
Declaration Syntax
C#
protected Form identityForm

Assembly: MSS.Wizard (Module: MSS.Wizard)


Images Property

Images Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> Images
Declaration Syntax
C#
public SkinImageFile[] Images{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


ImageSetting Property

ImageSetting Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> ImageSetting
Declaration Syntax
C#
public string ImageSetting{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipIdentitybar Field

ipIdentitybar Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> ipIdentitybar
Declaration Syntax
C#
protected ImagePickerDiv ipIdentitybar

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipIdentitybar_Click Method (sender, e)

ipIdentitybar_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> ipIdentitybar_Click(Object, EventArgs)
Handles the Click event of the identity bar image picker.
Declaration Syntax
C#
protected void ipIdentitybar_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblIdentitybarName Field

lblIdentitybarName Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> lblIdentitybarName
Declaration Syntax
C#
protected Label lblIdentitybarName

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblImage Field

lblImage Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> lblImage
Declaration Syntax
C#
protected Label lblImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblTextColor Field

lblTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> lblTextColor
Declaration Syntax
C#
protected Label lblTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


NameSetting Property

NameSetting Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> NameSetting
Declaration Syntax
C#
public string NameSetting{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


NotUseImageSetting Property

NotUseImageSetting Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> NotUseImageSetting
Declaration Syntax
C#
public string NotUseImageSetting{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Init Method (sender, e)

Page_Init Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> Page_Init(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Init(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlCenter Field

pnlCenter Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> pnlCenter
Declaration Syntax
C#
protected Panel pnlCenter

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlColor Field

pnlColor Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> pnlColor
Declaration Syntax
C#
protected Panel pnlColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlImage Field

pnlImage Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> pnlImage
Declaration Syntax
C#
protected Panel pnlImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlName Field

pnlName Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> pnlName
Declaration Syntax
C#
protected Panel pnlName

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlUpload Field

pnlUpload Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> pnlUpload
Declaration Syntax
C#
protected Panel pnlUpload

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbColor Field

rbColor Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbColor
Declaration Syntax
C#
protected RadioButton rbColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbColor_CheckedChanged Method (sender, e)

rbColor_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbColor_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbColor_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbCustomImage Field

rbCustomImage Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbCustomImage
Declaration Syntax
C#
protected RadioButton rbCustomImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbCustomImage_CheckedChanged Method (sender, e)

rbCustomImage_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbCustomImage_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbCustomImage_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbImage Field

rbImage Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbImage
Declaration Syntax
C#
protected RadioButton rbImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbImage_CheckedChanged Method (sender, e)

rbImage_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbImage_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbImage_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbTransparent Field

rbTransparent Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbTransparent
Declaration Syntax
C#
protected RadioButton rbTransparent

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbTransparent_CheckedChanged Method (sender, e)

rbTransparent_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> rbTransparent_CheckedChanged(Object, EventArgs)
Declaration Syntax
C#
protected void rbTransparent_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


TextColorSetting Property

TextColorSetting Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> TextColorSetting
Declaration Syntax
C#
public string TextColorSetting{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


TextSizeSetting Property

TextSizeSetting Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> TextSizeSetting
Declaration Syntax
C#
public string TextSizeSetting{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


txtIdentitybarname Field

txtIdentitybarname Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> txtIdentitybarname
Declaration Syntax
C#
protected TextBox txtIdentitybarname

Assembly: MSS.Wizard (Module: MSS.Wizard)


txtTextColor Field

txtTextColor Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> txtTextColor
Declaration Syntax
C#
protected TextBox txtTextColor

Assembly: MSS.Wizard (Module: MSS.Wizard)


uploadedImage Field

uploadedImage Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> uploadedImage
Declaration Syntax
C#
protected Label uploadedImage

Assembly: MSS.Wizard (Module: MSS.Wizard)


UploadImageSetting Property

UploadImageSetting Property
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> UploadImageSetting
Declaration Syntax
C#
public string UploadImageSetting{ set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


valColorReq Field

valColorReq Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> valColorReq
Declaration Syntax
C#
protected RequiredFieldValidator valColorReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valImageReq Field

valImageReq Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> valImageReq
Declaration Syntax
C#
protected RequiredFieldValidator valImageReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valTextColorReq Field

valTextColorReq Field
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> valTextColorReq
Declaration Syntax
C#
protected RequiredFieldValidator valTextColorReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


Buttons Class

Buttons Class
Namespaces >> MSS.Wizard.UserControls >> Buttons
Render button set for the selected skin
Declaration Syntax
C#
public class Buttons : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ButtonsButtonsNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipButtonSet |
 | ipButtonSet_Click(Object, EventArgs) | Handles the Click event of the button set image picker.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valButtonsReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Buttons

Assembly: MSS.Wizard (Module: MSS.Wizard)


Buttons Constructor

Buttons Constructor
Namespaces >> MSS.Wizard.UserControls >> Buttons >> ButtonsButtonsNew()()
Declaration Syntax
C#
public Buttons()

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipButtonSet Field

ipButtonSet Field
Namespaces >> MSS.Wizard.UserControls >> Buttons >> ipButtonSet
Declaration Syntax
C#
protected ImagePickerDiv ipButtonSet

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipButtonSet_Click Method (sender, e)

ipButtonSet_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Buttons >> ipButtonSet_Click(Object, EventArgs)
Handles the Click event of the button set image picker.
Declaration Syntax
C#
protected void ipButtonSet_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Buttons >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


valButtonsReq Field

valButtonsReq Field
Namespaces >> MSS.Wizard.UserControls >> Buttons >> valButtonsReq
Declaration Syntax
C#
protected RequiredFieldValidator valButtonsReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


ChooseSkin Class

ChooseSkin Class
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin
Render list of the available skins for the selected skin package.
Declaration Syntax
C#
public class ChooseSkin : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChooseSkinChooseSkinNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipSkins |
 | ipSkins_Click(Object, EventArgs) | Handles the Click event of the skins image picker control.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valSkinReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | ChooseSkin

Assembly: MSS.Wizard (Module: MSS.Wizard)


ChooseSkin Constructor

ChooseSkin Constructor
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> ChooseSkinChooseSkinNew()()
Declaration Syntax
C#
public ChooseSkin()

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipSkins Field

ipSkins Field
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> ipSkins
Declaration Syntax
C#
protected ImagePickerDiv ipSkins

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipSkins_Click Method (sender, e)

ipSkins_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> ipSkins_Click(Object, EventArgs)
Handles the Click event of the skins image picker control.
Declaration Syntax
C#
protected void ipSkins_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


valSkinReq Field

valSkinReq Field
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> valSkinReq
Declaration Syntax
C#
protected RequiredFieldValidator valSkinReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


ChooseSkinPackage Class

ChooseSkinPackage Class
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage
Render list of the skin packages
Declaration Syntax
C#
public class ChooseSkinPackage : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChooseSkinPackageChooseSkinPackageNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipSkinPackages |
 | ipSkinPackages_Click(Object, EventArgs) | Handles the Click event of the skin packages image picker control.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | pnlTab |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valSkinPackagesReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | ChooseSkinPackage

Assembly: MSS.Wizard (Module: MSS.Wizard)


ChooseSkinPackage Constructor

ChooseSkinPackage Constructor
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> ChooseSkinPackageChooseSkinPackageNew()()
Declaration Syntax
C#
public ChooseSkinPackage()

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipSkinPackages Field

ipSkinPackages Field
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> ipSkinPackages
Declaration Syntax
C#
protected ImagePickerDiv ipSkinPackages

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipSkinPackages_Click Method (sender, e)

ipSkinPackages_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> ipSkinPackages_Click(Object, EventArgs)
Handles the Click event of the skin packages image picker control.
Declaration Syntax
C#
protected void ipSkinPackages_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


pnlTab Field

pnlTab Field
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> pnlTab
Declaration Syntax
C#
protected Panel pnlTab

Assembly: MSS.Wizard (Module: MSS.Wizard)


valSkinPackagesReq Field

valSkinPackagesReq Field
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> valSkinPackagesReq
Declaration Syntax
C#
protected RequiredFieldValidator valSkinPackagesReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


Columns Class

Columns Class
Namespaces >> MSS.Wizard.UserControls >> Columns
Renders columns colour configuration panel.
Declaration Syntax
C#
public class Columns : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColumnsColumnsNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | cpColumnCenter |
 | cpColumnCenter_Click(Object, EventArgs) | Handles the Click event of the centre column colour text colour picker.
 | cpColumnLeft |
 | cpColumnLeft_Click(Object, EventArgs) | Handles the Click event of the left column colour text colour picker.
 | cpColumnRight |
 | cpColumnRight_Click(Object, EventArgs) | Handles the Click event of the right column colour text colour picker.
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblLeft |
 | lblMid |
 | lblRight |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valLeftColReq |
 | valMidColReq |
 | valRightColReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Columns

Assembly: MSS.Wizard (Module: MSS.Wizard)


Columns Constructor

Columns Constructor
Namespaces >> MSS.Wizard.UserControls >> Columns >> ColumnsColumnsNew()()
Declaration Syntax
C#
public Columns()

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnCenter Field

cpColumnCenter Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> cpColumnCenter
Declaration Syntax
C#
protected ColorPickerDiv cpColumnCenter

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnCenter_Click Method (sender, e)

cpColumnCenter_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Columns >> cpColumnCenter_Click(Object, EventArgs)
Handles the Click event of the centre column colour text colour picker.
Declaration Syntax
C#
protected void cpColumnCenter_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnLeft Field

cpColumnLeft Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> cpColumnLeft
Declaration Syntax
C#
protected ColorPickerDiv cpColumnLeft

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnLeft_Click Method (sender, e)

cpColumnLeft_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Columns >> cpColumnLeft_Click(Object, EventArgs)
Handles the Click event of the left column colour text colour picker.
Declaration Syntax
C#
protected void cpColumnLeft_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnRight Field

cpColumnRight Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> cpColumnRight
Declaration Syntax
C#
protected ColorPickerDiv cpColumnRight

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnRight_Click Method (sender, e)

cpColumnRight_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Columns >> cpColumnRight_Click(Object, EventArgs)
Handles the Click event of the right column colour text colour picker.
Declaration Syntax
C#
protected void cpColumnRight_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblLeft Field

lblLeft Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> lblLeft
Declaration Syntax
C#
protected Label lblLeft

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblMid Field

lblMid Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> lblMid
Declaration Syntax
C#
protected Label lblMid

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblRight Field

lblRight Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> lblRight
Declaration Syntax
C#
protected Label lblRight

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Columns >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


valLeftColReq Field

valLeftColReq Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> valLeftColReq
Declaration Syntax
C#
protected RequiredFieldValidator valLeftColReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valMidColReq Field

valMidColReq Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> valMidColReq
Declaration Syntax
C#
protected RequiredFieldValidator valMidColReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valRightColReq Field

valRightColReq Field
Namespaces >> MSS.Wizard.UserControls >> Columns >> valRightColReq
Declaration Syntax
C#
protected RequiredFieldValidator valRightColReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnsBackground Class

ColumnsBackground Class
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground
Renders columns background color configurate panel
Declaration Syntax
C#
public class ColumnsBackground : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColumnsBackgroundColumnsBackgroundNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | cpColumnsBackground |
 | cpColumnsBackground_Click(Object, EventArgs) | Handles the Click event of the columns background color picker control.
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | ipColumnsBackground |
 | ipColumnsBackground_Click(Object, EventArgs) | Handles the Click event of the columns background image picker control.
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | txtColumnBackground |
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valColumnBackgroundReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | ColumnsBackground

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColumnsBackground Constructor

ColumnsBackground Constructor
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> ColumnsBackgroundColumnsBackgroundNew()()
Declaration Syntax
C#
public ColumnsBackground()

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnsBackground Field

cpColumnsBackground Field
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> cpColumnsBackground
Declaration Syntax
C#
protected ColorPickerDiv cpColumnsBackground

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpColumnsBackground_Click Method (sender, e)

cpColumnsBackground_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> cpColumnsBackground_Click(Object, EventArgs)
Handles the Click event of the columns background color picker control.
Declaration Syntax
C#
protected void cpColumnsBackground_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipColumnsBackground Field

ipColumnsBackground Field
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> ipColumnsBackground
Declaration Syntax
C#
protected ImagePickerDiv ipColumnsBackground

Assembly: MSS.Wizard (Module: MSS.Wizard)


ipColumnsBackground_Click Method (sender, e)

ipColumnsBackground_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> ipColumnsBackground_Click(Object, EventArgs)
Handles the Click event of the columns background image picker control.
Declaration Syntax
C#
protected void ipColumnsBackground_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


txtColumnBackground Field

txtColumnBackground Field
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> txtColumnBackground
Declaration Syntax
C#
protected TextBox txtColumnBackground

Assembly: MSS.Wizard (Module: MSS.Wizard)


valColumnBackgroundReq Field

valColumnBackgroundReq Field
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> valColumnBackgroundReq
Declaration Syntax
C#
protected RequiredFieldValidator valColumnBackgroundReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInformation Class

ContactInformation Class
Namespaces >> MSS.Wizard.UserControls >> ContactInformation
Renders contact information panel
Declaration Syntax
C#
public class ContactInformation : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContactInformationContactInformationNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | City |
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataForm |
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Email |
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblCity |
 | lblEmail |
 | lblFax |
 | lblName |
 | lblStreet |
 | lblStreetno |
 | lblTelephone |
 | lblZipcode |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | Name |
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Page_SaveData(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | Postalcode |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | Street |
 | Streetno |
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | Telefaxno |
 | Telephoneno |
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valEmailReg |
 | valNameReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | ContactInformation

Assembly: MSS.Wizard (Module: MSS.Wizard)


ContactInformation Constructor

ContactInformation Constructor
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> ContactInformationContactInformationNew()()
Declaration Syntax
C#
public ContactInformation()

Assembly: MSS.Wizard (Module: MSS.Wizard)


City Field

City Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> City
Declaration Syntax
C#
protected TextBox City

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataForm Field

DataForm Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> DataForm
Declaration Syntax
C#
protected Form DataForm

Assembly: MSS.Wizard (Module: MSS.Wizard)


Email Field

Email Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Email
Declaration Syntax
C#
protected TextBox Email

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblCity Field

lblCity Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblCity
Declaration Syntax
C#
protected Label lblCity

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblEmail Field

lblEmail Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblEmail
Declaration Syntax
C#
protected Label lblEmail

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblFax Field

lblFax Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblFax
Declaration Syntax
C#
protected Label lblFax

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblName Field

lblName Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblName
Declaration Syntax
C#
protected Label lblName

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblStreet Field

lblStreet Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblStreet
Declaration Syntax
C#
protected Label lblStreet

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblStreetno Field

lblStreetno Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblStreetno
Declaration Syntax
C#
protected Label lblStreetno

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblTelephone Field

lblTelephone Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblTelephone
Declaration Syntax
C#
protected Label lblTelephone

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblZipcode Field

lblZipcode Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> lblZipcode
Declaration Syntax
C#
protected Label lblZipcode

Assembly: MSS.Wizard (Module: MSS.Wizard)


Name Field

Name Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Name
Declaration Syntax
C#
protected TextBox Name

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_SaveData Method (sender, e)

Page_SaveData Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Page_SaveData(Object, EventArgs)
Declaration Syntax
C#
public void Page_SaveData(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Postalcode Field

Postalcode Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Postalcode
Declaration Syntax
C#
protected TextBox Postalcode

Assembly: MSS.Wizard (Module: MSS.Wizard)


Street Field

Street Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Street
Declaration Syntax
C#
protected TextBox Street

Assembly: MSS.Wizard (Module: MSS.Wizard)


Streetno Field

Streetno Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Streetno
Declaration Syntax
C#
protected TextBox Streetno

Assembly: MSS.Wizard (Module: MSS.Wizard)


Telefaxno Field

Telefaxno Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Telefaxno
Declaration Syntax
C#
protected TextBox Telefaxno

Assembly: MSS.Wizard (Module: MSS.Wizard)


Telephoneno Field

Telephoneno Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Telephoneno
Declaration Syntax
C#
protected TextBox Telephoneno

Assembly: MSS.Wizard (Module: MSS.Wizard)


valEmailReg Field

valEmailReg Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> valEmailReg
Declaration Syntax
C#
protected RegularExpressionValidator valEmailReg

Assembly: MSS.Wizard (Module: MSS.Wizard)


valNameReq Field

valNameReq Field
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> valNameReq
Declaration Syntax
C#
protected RequiredFieldValidator valNameReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


FrontPageColumn Class

FrontPageColumn Class
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn
Renders site front page colour configuration panel.
Declaration Syntax
C#
public class FrontPageColumn : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrontPageColumnFrontPageColumnNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | cpFrontpageColummText |
 | cpFrontpageColummText_Click(Object, EventArgs) | Handles the Click event of the front page column text colour picker control.
 | cpFrontpageColumn |
 | cpFrontpageColumn_Click(Object, EventArgs) | Handles the Click event of the front page column colour picker control.
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblCenterColumn |
 | lblCenterColumnText |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valCenterColumnReq |
 | valCenterColumnTextReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | FrontPageColumn

Assembly: MSS.Wizard (Module: MSS.Wizard)


FrontPageColumn Constructor

FrontPageColumn Constructor
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> FrontPageColumnFrontPageColumnNew()()
Declaration Syntax
C#
public FrontPageColumn()

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpFrontpageColummText Field

cpFrontpageColummText Field
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> cpFrontpageColummText
Declaration Syntax
C#
protected ColorPickerDiv cpFrontpageColummText

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpFrontpageColummText_Click Method (sender, e)

cpFrontpageColummText_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> cpFrontpageColummText_Click(Object, EventArgs)
Handles the Click event of the front page column text colour picker control.
Declaration Syntax
C#
protected void cpFrontpageColummText_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpFrontpageColumn Field

cpFrontpageColumn Field
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> cpFrontpageColumn
Declaration Syntax
C#
protected ColorPickerDiv cpFrontpageColumn

Assembly: MSS.Wizard (Module: MSS.Wizard)


cpFrontpageColumn_Click Method (sender, e)

cpFrontpageColumn_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> cpFrontpageColumn_Click(Object, EventArgs)
Handles the Click event of the front page column colour picker control.
Declaration Syntax
C#
protected void cpFrontpageColumn_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblCenterColumn Field

lblCenterColumn Field
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> lblCenterColumn
Declaration Syntax
C#
protected Label lblCenterColumn

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblCenterColumnText Field

lblCenterColumnText Field
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> lblCenterColumnText
Declaration Syntax
C#
protected Label lblCenterColumnText

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


valCenterColumnReq Field

valCenterColumnReq Field
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> valCenterColumnReq
Declaration Syntax
C#
protected RequiredFieldValidator valCenterColumnReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valCenterColumnTextReq Field

valCenterColumnTextReq Field
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> valCenterColumnTextReq
Declaration Syntax
C#
protected RequiredFieldValidator valCenterColumnTextReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


Identity Class

Identity Class
Namespaces >> MSS.Wizard.UserControls >> Identity
Renders site identity configuration panel
Declaration Syntax
C#
public class Identity : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IdentityIdentityNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | identityControl |
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Identity

Assembly: MSS.Wizard (Module: MSS.Wizard)


Identity Constructor

Identity Constructor
Namespaces >> MSS.Wizard.UserControls >> Identity >> IdentityIdentityNew()()
Declaration Syntax
C#
public Identity()

Assembly: MSS.Wizard (Module: MSS.Wizard)


identityControl Field

identityControl Field
Namespaces >> MSS.Wizard.UserControls >> Identity >> identityControl
Declaration Syntax
C#
protected BaseIdentityControl identityControl

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Wizard.UserControls >> Identity >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Introduction Class

Introduction Class
Namespaces >> MSS.Wizard.UserControls >> Introduction
Introduction class.
Renders wizard menu, content and navigation buttons
Declaration Syntax
C#
public class Introduction : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntroductionIntroductionNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NavigationButtons1 | NavigationButtons1 control.
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PlaceHolder | PlaceHolder control.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | SCX_Wizard_menu | SCX_Wizard_menu control.
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Remarks
Auto-generated class.
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Introduction

Assembly: MSS.Wizard (Module: MSS.Wizard)


Introduction Constructor

Introduction Constructor
Namespaces >> MSS.Wizard.UserControls >> Introduction >> IntroductionIntroductionNew()()
Declaration Syntax
C#
public Introduction()

Assembly: MSS.Wizard (Module: MSS.Wizard)


NavigationButtons1 Field

NavigationButtons1 Field
Namespaces >> MSS.Wizard.UserControls >> Introduction >> NavigationButtons1
NavigationButtons1 control.
Declaration Syntax
C#
protected NavigationButtons NavigationButtons1
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Introduction >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


PlaceHolder Field

PlaceHolder Field
Namespaces >> MSS.Wizard.UserControls >> Introduction >> PlaceHolder
PlaceHolder control.
Declaration Syntax
C#
protected Placeholder PlaceHolder
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SCX_Wizard_menu Field

SCX_Wizard_menu Field
Namespaces >> MSS.Wizard.UserControls >> Introduction >> SCX_Wizard_menu
SCX_Wizard_menu control.
Declaration Syntax
C#
protected XslFile SCX_Wizard_menu
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Language Class

Language Class
Namespaces >> MSS.Wizard.UserControls >> Language
Renders a list of available languages and the current default language.
Declaration Syntax
C#
public class Language : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LanguageLanguageNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | ddlDefaultLanguage |
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | languageform |
 | lbLanguages |
 | lbLanguages_SelectedIndexChanged(Object, EventArgs) | Handles the SelectedIndexChanged event of the lbLanguages control.
 | lblDefaultLanguage |
 | LblLanguages |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | valDefaultLanguageReq |
 | valLanguagesReq |
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Language

Assembly: MSS.Wizard (Module: MSS.Wizard)


Language Constructor

Language Constructor
Namespaces >> MSS.Wizard.UserControls >> Language >> LanguageLanguageNew()()
Declaration Syntax
C#
public Language()

Assembly: MSS.Wizard (Module: MSS.Wizard)


ddlDefaultLanguage Field

ddlDefaultLanguage Field
Namespaces >> MSS.Wizard.UserControls >> Language >> ddlDefaultLanguage
Declaration Syntax
C#
protected DropDownList ddlDefaultLanguage

Assembly: MSS.Wizard (Module: MSS.Wizard)


languageform Field

languageform Field
Namespaces >> MSS.Wizard.UserControls >> Language >> languageform
Declaration Syntax
C#
protected Form languageform

Assembly: MSS.Wizard (Module: MSS.Wizard)


lbLanguages Field

lbLanguages Field
Namespaces >> MSS.Wizard.UserControls >> Language >> lbLanguages
Declaration Syntax
C#
protected ListBox lbLanguages

Assembly: MSS.Wizard (Module: MSS.Wizard)


lbLanguages_SelectedIndexChanged Method (sender, e)

lbLanguages_SelectedIndexChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Language >> lbLanguages_SelectedIndexChanged(Object, EventArgs)
Handles the SelectedIndexChanged event of the lbLanguages control.
Declaration Syntax
C#
protected void lbLanguages_SelectedIndexChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblDefaultLanguage Field

lblDefaultLanguage Field
Namespaces >> MSS.Wizard.UserControls >> Language >> lblDefaultLanguage
Declaration Syntax
C#
protected Label lblDefaultLanguage

Assembly: MSS.Wizard (Module: MSS.Wizard)


LblLanguages Field

LblLanguages Field
Namespaces >> MSS.Wizard.UserControls >> Language >> LblLanguages
Declaration Syntax
C#
protected Label LblLanguages

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Wizard.UserControls >> Language >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Language >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


valDefaultLanguageReq Field

valDefaultLanguageReq Field
Namespaces >> MSS.Wizard.UserControls >> Language >> valDefaultLanguageReq
Declaration Syntax
C#
protected RequiredFieldValidator valDefaultLanguageReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


valLanguagesReq Field

valLanguagesReq Field
Namespaces >> MSS.Wizard.UserControls >> Language >> valLanguagesReq
Declaration Syntax
C#
protected RequiredFieldValidator valLanguagesReq

Assembly: MSS.Wizard (Module: MSS.Wizard)


Modules Class

Modules Class
Namespaces >> MSS.Wizard.UserControls >> Modules
Modules application.
Declaration Syntax
C#
public class Modules : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModulesModulesNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblModules |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModulesList |
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Modules

Assembly: MSS.Wizard (Module: MSS.Wizard)


Modules Constructor

Modules Constructor
Namespaces >> MSS.Wizard.UserControls >> Modules >> ModulesModulesNew()()
Declaration Syntax
C#
public Modules()

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblModules Field

lblModules Field
Namespaces >> MSS.Wizard.UserControls >> Modules >> lblModules
Declaration Syntax
C#
protected Label lblModules

Assembly: MSS.Wizard (Module: MSS.Wizard)


ModulesList Field

ModulesList Field
Namespaces >> MSS.Wizard.UserControls >> Modules >> ModulesList
Declaration Syntax
C#
protected CheckBoxList ModulesList

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Wizard.UserControls >> Modules >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Modules >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Navigation Class

Navigation Class
Namespaces >> MSS.Wizard.UserControls >> Navigation
Displays the site navigation configuration panel.
Declaration Syntax
C#
public class Navigation : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NavigationNavigationNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | languageform |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | option_CheckedChanged(Object, EventArgs) | Handles the CheckedChanged event of the option control.
 | Option1 |
 | Option2 |
 | Option3 |
 | Option4 |
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Navigation

Assembly: MSS.Wizard (Module: MSS.Wizard)


Navigation Constructor

Navigation Constructor
Namespaces >> MSS.Wizard.UserControls >> Navigation >> NavigationNavigationNew()()
Declaration Syntax
C#
public Navigation()

Assembly: MSS.Wizard (Module: MSS.Wizard)


languageform Field

languageform Field
Namespaces >> MSS.Wizard.UserControls >> Navigation >> languageform
Declaration Syntax
C#
protected Form languageform

Assembly: MSS.Wizard (Module: MSS.Wizard)


option_CheckedChanged Method (sender, e)

option_CheckedChanged Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Navigation >> option_CheckedChanged(Object, EventArgs)
Handles the CheckedChanged event of the option control.
Declaration Syntax
C#
protected void option_CheckedChanged(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Option1 Field

Option1 Field
Namespaces >> MSS.Wizard.UserControls >> Navigation >> Option1
Declaration Syntax
C#
protected RadioButton Option1

Assembly: MSS.Wizard (Module: MSS.Wizard)


Option2 Field

Option2 Field
Namespaces >> MSS.Wizard.UserControls >> Navigation >> Option2
Declaration Syntax
C#
protected RadioButton Option2

Assembly: MSS.Wizard (Module: MSS.Wizard)


Option3 Field

Option3 Field
Namespaces >> MSS.Wizard.UserControls >> Navigation >> Option3
Declaration Syntax
C#
protected RadioButton Option3

Assembly: MSS.Wizard (Module: MSS.Wizard)


Option4 Field

Option4 Field
Namespaces >> MSS.Wizard.UserControls >> Navigation >> Option4
Declaration Syntax
C#
protected RadioButton Option4

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Navigation >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


NavigationButtons Class

NavigationButtons Class
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons
Declaration Syntax
C#
public class NavigationButtons : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NavigationButtonsNavigationButtonsNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | btnCancel |
 | btnCancel_Click(Object, EventArgs) | Handles the Click event of the Cancel button.
 | btnNext |
 | btnNext_Click(Object, EventArgs) | Handles the Click event of the Next button.
 | btnPreview |
 | btnPreview_Click(Object, EventArgs) | Handles the Click event of the Preview button.
 | btnPrevious |
 | btnPrevious_Click(Object, EventArgs) | Handles the Click event of the Previous button.
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | hiddenControl |
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Panel1 |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | NavigationButtons

Assembly: MSS.Wizard (Module: MSS.Wizard)


NavigationButtons Constructor

NavigationButtons Constructor
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> NavigationButtonsNavigationButtonsNew()()
Declaration Syntax
C#
public NavigationButtons()

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnCancel Field

btnCancel Field
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnCancel
Declaration Syntax
C#
protected Button btnCancel

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnCancel_Click Method (sender, e)

btnCancel_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnCancel_Click(Object, EventArgs)
Handles the Click event of the Cancel button.
Declaration Syntax
C#
protected void btnCancel_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnNext Field

btnNext Field
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnNext
Declaration Syntax
C#
protected Button btnNext

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnNext_Click Method (sender, e)

btnNext_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnNext_Click(Object, EventArgs)
Handles the Click event of the Next button.
Declaration Syntax
C#
protected void btnNext_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnPreview Field

btnPreview Field
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnPreview
Declaration Syntax
C#
protected Button btnPreview

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnPreview_Click Method (sender, e)

btnPreview_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnPreview_Click(Object, EventArgs)
Handles the Click event of the Preview button.
Declaration Syntax
C#
protected void btnPreview_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnPrevious Field

btnPrevious Field
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnPrevious
Declaration Syntax
C#
protected Button btnPrevious

Assembly: MSS.Wizard (Module: MSS.Wizard)


btnPrevious_Click Method (sender, e)

btnPrevious_Click Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> btnPrevious_Click(Object, EventArgs)
Handles the Click event of the Previous button.
Declaration Syntax
C#
protected void btnPrevious_Click(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
The source of the event.
e (EventArgs)
The EventArgs instance containing the event data.

Assembly: MSS.Wizard (Module: MSS.Wizard)


hiddenControl Field

hiddenControl Field
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> hiddenControl
Declaration Syntax
C#
protected HiddenField hiddenControl

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnPreRender Method (e)

OnPreRender Method (e)
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> OnPreRender(EventArgs)
Declaration Syntax
C#
protected override void OnPreRender(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Panel1 Field

Panel1 Field
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> Panel1
Declaration Syntax
C#
protected Panel Panel1

Assembly: MSS.Wizard (Module: MSS.Wizard)


Normal Class

Normal Class
Namespaces >> MSS.Wizard.UserControls >> Normal
Normal wizard control.
Declaration Syntax
C#
public class Normal : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NormalNormalNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NavigationButtons1 |
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PlaceHolder |
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | StepSelector |
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | Xslfile1 |
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Normal

Assembly: MSS.Wizard (Module: MSS.Wizard)


Normal Constructor

Normal Constructor
Namespaces >> MSS.Wizard.UserControls >> Normal >> NormalNormalNew()()
Declaration Syntax
C#
public Normal()

Assembly: MSS.Wizard (Module: MSS.Wizard)


NavigationButtons1 Field

NavigationButtons1 Field
Namespaces >> MSS.Wizard.UserControls >> Normal >> NavigationButtons1
Declaration Syntax
C#
protected NavigationButtons NavigationButtons1

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Normal >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


PlaceHolder Field

PlaceHolder Field
Namespaces >> MSS.Wizard.UserControls >> Normal >> PlaceHolder
Declaration Syntax
C#
protected Placeholder PlaceHolder

Assembly: MSS.Wizard (Module: MSS.Wizard)


StepSelector Field

StepSelector Field
Namespaces >> MSS.Wizard.UserControls >> Normal >> StepSelector
Declaration Syntax
C#
protected StepSelector StepSelector

Assembly: MSS.Wizard (Module: MSS.Wizard)


Xslfile1 Field

Xslfile1 Field
Namespaces >> MSS.Wizard.UserControls >> Normal >> Xslfile1
Declaration Syntax
C#
protected XslFile Xslfile1

Assembly: MSS.Wizard (Module: MSS.Wizard)


Settings Class

Settings Class
Namespaces >> MSS.Wizard.UserControls >> Settings
Settings application.
Declaration Syntax
C#
public class Settings : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SettingsSettingsNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | lblSiteStatus |
 | lblSpotcharacters |
 | lblSpotcount |
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Page_Init(Object, EventArgs) |
 | Page_Load(Object, EventArgs) |
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | rbOffline |
 | rbOnline |
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | SettingsForm |
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SpotCharacters |
 | Spotcount |
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | Settings

Assembly: MSS.Wizard (Module: MSS.Wizard)


Settings Constructor

Settings Constructor
Namespaces >> MSS.Wizard.UserControls >> Settings >> SettingsSettingsNew()()
Declaration Syntax
C#
public Settings()

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblSiteStatus Field

lblSiteStatus Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> lblSiteStatus
Declaration Syntax
C#
protected Label lblSiteStatus

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblSpotcharacters Field

lblSpotcharacters Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> lblSpotcharacters
Declaration Syntax
C#
protected Label lblSpotcharacters

Assembly: MSS.Wizard (Module: MSS.Wizard)


lblSpotcount Field

lblSpotcount Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> lblSpotcount
Declaration Syntax
C#
protected Label lblSpotcount

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Init Method (sender, e)

Page_Init Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Settings >> Page_Init(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Init(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Page_Load Method (sender, e)

Page_Load Method (sender, e)
Namespaces >> MSS.Wizard.UserControls >> Settings >> Page_Load(Object, EventArgs)
Declaration Syntax
C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbOffline Field

rbOffline Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> rbOffline
Declaration Syntax
C#
protected RadioButton rbOffline

Assembly: MSS.Wizard (Module: MSS.Wizard)


rbOnline Field

rbOnline Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> rbOnline
Declaration Syntax
C#
protected RadioButton rbOnline

Assembly: MSS.Wizard (Module: MSS.Wizard)


SettingsForm Field

SettingsForm Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> SettingsForm
Declaration Syntax
C#
protected Form SettingsForm

Assembly: MSS.Wizard (Module: MSS.Wizard)


SpotCharacters Field

SpotCharacters Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> SpotCharacters
Declaration Syntax
C#
protected TextBox SpotCharacters

Assembly: MSS.Wizard (Module: MSS.Wizard)


Spotcount Field

Spotcount Field
Namespaces >> MSS.Wizard.UserControls >> Settings >> Spotcount
Declaration Syntax
C#
protected TextBox Spotcount

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopBar Class

TopBar Class
Namespaces >> MSS.Wizard.UserControls >> TopBar
Top bar configuration page
Declaration Syntax
C#
public class TopBar : WizardControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TopBarTopBarNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server. (Inherited from WizardControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | (Overrides UserControl.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings. (Inherited from WizardControl.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | topBarIdentityControl |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page. (Inherited from WizardControl.)
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | TopBar

Assembly: MSS.Wizard (Module: MSS.Wizard)


TopBar Constructor

TopBar Constructor
Namespaces >> MSS.Wizard.UserControls >> TopBar >> TopBarTopBarNew()()
Declaration Syntax
C#
public TopBar()

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Wizard.UserControls >> TopBar >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


topBarIdentityControl Field

topBarIdentityControl Field
Namespaces >> MSS.Wizard.UserControls >> TopBar >> topBarIdentityControl
Declaration Syntax
C#
protected BaseIdentityControl topBarIdentityControl

Assembly: MSS.Wizard (Module: MSS.Wizard)


WizardControl Class

WizardControl Class
Namespaces >> MSS.Wizard.UserControls >> WizardControl
Base wizard control
Declaration Syntax
C#
public class WizardControl : UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WizardControlWizardControlNew()() |
 | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
 | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
 | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
 | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
 | Construct()() | Performs design-time logic. (Inherited from TemplateControl.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateResourceBasedLiteralControl(Int32, Int32, Boolean) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignerInitialize()() | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
 | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FrameworkInitialize()() | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InitializeAsUserControl(Page) | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadTemplate(String) | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
 | LoadViewState(Object) | Restores the view-state information from a previous user control request that was saved by the SaveViewState()() method. (Inherited from UserControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPath(String) | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MssServer | Gets the MSS server.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnAbortTransaction(EventArgs) | Raises the AbortTransaction event. (Inherited from TemplateControl.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnCommitTransaction(EventArgs) | Raises the CommitTransaction event. (Inherited from TemplateControl.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnError(EventArgs) | Raises the Error event. (Inherited from TemplateControl.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from UserControl.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | ReadStringResource()() | Reads a string resource. The ReadStringResource()() method is not intended for use from within your code. (Inherited from TemplateControl.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
 | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
 | Session | Gets the HttpSessionStateobject for the current Web request. (Inherited from UserControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetStringResourcePointer(Object, Int32) | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | Settings | Gets the wizard control settings.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from UserControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from UserControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IFilterResolutionService..::CompareFilters(String, String) | (Inherited from TemplateControl.)
 | IFilterResolutionService..::EvaluateFilter(String) | (Inherited from TemplateControl.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | IUserControlDesignerAccessor..::InnerText | (Inherited from UserControl.)
 | IUserControlDesignerAccessor..::TagName | (Inherited from UserControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TestDeviceFilter(String) | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
 | TrackViewState()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WPage | Gets the Wizard page.
 | WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
 | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Inheritance Hierarchy
Object
 | Control
 |  | TemplateControl
 |  |  | UserControl
 |  |  |  | WizardControl
 |  |  |  |  | TopBar
 |  |  |  |  | Settings
 |  |  |  |  | ColumnsBackground
 |  |  |  |  | Navigation
 |  |  |  |  | Language
 |  |  |  |  | ChooseSkin
 |  |  |  |  | NavigationButtons
 |  |  |  |  | Modules
 |  |  |  |  | FrontPageColumn
 |  |  |  |  | Introduction
 |  |  |  |  | Identity
 |  |  |  |  | Columns
 |  |  |  |  | ChooseSkinPackage
 |  |  |  |  | Buttons
 |  |  |  |  | BaseIdentityControl
 |  |  |  |  | Background
 |  |  |  |  | ContactInformation
 |  |  |  |  | BarDesignExtra
 |  |  |  |  | BarDesign
 |  |  |  |  | Normal

Assembly: MSS.Wizard (Module: MSS.Wizard)


WizardControl Constructor

WizardControl Constructor
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> WizardControlWizardControlNew()()
Declaration Syntax
C#
public WizardControl()

Assembly: MSS.Wizard (Module: MSS.Wizard)


MssServer Property

MssServer Property
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> MssServer
Gets the MSS server.
Declaration Syntax
C#
public Server MssServer{ get;}
Value
The MSS server.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Settings Property

Settings Property
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> Settings
Gets the wizard control settings.
Declaration Syntax
C#
public SettingsCollection Settings{ get;}
Value
The wizard control settings.

Assembly: MSS.Wizard (Module: MSS.Wizard)


WPage Property

WPage Property
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> WPage
Gets the Wizard page.
Declaration Syntax
C#
public WizardPage WPage{ get;}
Value
The wizard page.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MSS.Wizard.WebControls Namespace

MSS.Wizard.WebControls Namespace
Namespaces >> MSS.Wizard.WebControls
Declaration Syntax
C#
namespace MSS.Wizard.WebControls
Types
All Types Classes
Icon | Type | Description
 | ColorPickerDiv | Colour picker web controls.
 | ImagePickerDiv | Image picker web control
 | StepSelector | Selects a rendering from wizard step item and renders it.


ColorPickerDiv Class

ColorPickerDiv Class
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv
Colour picker web controls.
Declaration Syntax
C#
[ValidationPropertyAttribute("ColorName")]
public class ColorPickerDiv : WebControl, INamingContainer,
    IPostBackEventHandler
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColorPickerDivColorPickerDivNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ButtonCssClass |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | Click |
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Col |
 | Color |
 | ColorName |
 | Cols |
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | (Overrides Control.CreateChildControls()().)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DisableColorPalette |
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DropShadowCssClass |
 | EnableCustomColor |
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetClosetsMatchByColor(Color) | Return coordinates for colour that best matches the given colour.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | ImageUrl |
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | (Overrides WebControl.LoadViewState(Object).)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick(EventArgs) |
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | OuterGlowCssClass |
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(String) |
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RGBColor |
 | Row |
 | Rows |
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | (Overrides WebControl.SaveViewState()().)
 | SetClosetsMatchByColor(Color) | Select the colour that best matches the given colour.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | ShowTextColor |
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | ColorPickerDiv

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColorPickerDiv Constructor

ColorPickerDiv Constructor
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> ColorPickerDivColorPickerDivNew()()
Declaration Syntax
C#
public ColorPickerDiv()

Assembly: MSS.Wizard (Module: MSS.Wizard)


ButtonCssClass Property

ButtonCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> ButtonCssClass
Declaration Syntax
C#
public string ButtonCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


Click Event

Click Event
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> Click
Declaration Syntax
C#
public event EventHandler Click

Assembly: MSS.Wizard (Module: MSS.Wizard)


Col Property

Col Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> Col
Declaration Syntax
C#
public int Col{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


Color Property

Color Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> Color
Declaration Syntax
C#
public Color Color{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


ColorName Property

ColorName Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> ColorName
Declaration Syntax
C#
public string ColorName{ get;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


Cols Property

Cols Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> Cols
Declaration Syntax
C#
public int Cols{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


CreateChildControls Method

CreateChildControls Method
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> CreateChildControls()()
Declaration Syntax
C#
protected override void CreateChildControls()

Assembly: MSS.Wizard (Module: MSS.Wizard)


DisableColorPalette Property

DisableColorPalette Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> DisableColorPalette
Declaration Syntax
C#
public bool DisableColorPalette{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


DropShadowCssClass Property

DropShadowCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> DropShadowCssClass
Declaration Syntax
C#
public string DropShadowCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


EnableCustomColor Property

EnableCustomColor Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> EnableCustomColor
Declaration Syntax
C#
public bool EnableCustomColor{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetClosetsMatchByColor Method (aColor)

GetClosetsMatchByColor Method (aColor)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> GetClosetsMatchByColor(Color)
Return coordinates for colour that best matches the given colour.
Declaration Syntax
C#
public Point GetClosetsMatchByColor(
    Color aColor
)
Parameters
aColor (Color)
Colour to search for.
Return Value
Coordinates given by a point.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ImageUrl Property

ImageUrl Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> ImageUrl
Declaration Syntax
C#
public string ImageUrl{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadViewState Method (savedState)

LoadViewState Method (savedState)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> LoadViewState(Object)
Declaration Syntax
C#
protected override void LoadViewState(
    Object savedState
)
Parameters
savedState (Object)

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnClick Method (e)

OnClick Method (e)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> OnClick(EventArgs)
Declaration Syntax
C#
protected virtual void OnClick(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


OuterGlowCssClass Property

OuterGlowCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> OuterGlowCssClass
Declaration Syntax
C#
public string OuterGlowCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


RaisePostBackEvent Method (eventArgument)

RaisePostBackEvent Method (eventArgument)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> RaisePostBackEvent(String)
Declaration Syntax
C#
public void RaisePostBackEvent(
    string eventArgument
)
Parameters
eventArgument (String)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> RenderBeginTag(HtmlTextWriter)
Renders the HTML opening tag of the control to the specified writer.
Declaration Syntax
C#
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
A HtmlTextWriter that represents the output stream to render HTML content on the client.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderEndTag Method (writer)

RenderEndTag Method (writer)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> RenderEndTag(HtmlTextWriter)
Renders the HTML closing tag of the control into the specified writer.
Declaration Syntax
C#
public override void RenderEndTag(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)
A HtmlTextWriter that represents the output stream to render HTML content on the client.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RGBColor Property

RGBColor Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> RGBColor
Declaration Syntax
C#
public int RGBColor{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


Row Property

Row Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> Row
Declaration Syntax
C#
public int Row{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


Rows Property

Rows Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> Rows
Declaration Syntax
C#
public int Rows{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


SaveViewState Method

SaveViewState Method
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> SaveViewState()()
Declaration Syntax
C#
protected override Object SaveViewState()

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetClosetsMatchByColor Method (aColor)

SetClosetsMatchByColor Method (aColor)
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> SetClosetsMatchByColor(Color)
Select the colour that best matches the given colour.
Declaration Syntax
C#
public void SetClosetsMatchByColor(
    Color aColor
)
Parameters
aColor (Color)
Colour to search for.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ShowTextColor Property

ShowTextColor Property
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> ShowTextColor
Declaration Syntax
C#
public bool ShowTextColor{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


ImagePickerDiv Class

ImagePickerDiv Class
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv
Image picker web control
Declaration Syntax
C#
[ValidationPropertyAttribute("IndexName")]
public class ImagePickerDiv : WebControl, INamingContainer,
    IPostBackEventHandler
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImagePickerDivImagePickerDivNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddImage(String, String) |
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ButtonCssClass |
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearImages()() |
 | Click |
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | ControlCssClass |
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | (Overrides Control.CreateChildControls()().)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DropShadowCssClass |
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | ImageButton_Click(Object, CommandEventArgs) |
 | ImageCssClass |
 | ImageSelectedCssClass | Gets or sets the image selected CSS class.
 | Index | Gets or sets the index.
 | IndexName | Gets the name of the index.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | (Overrides WebControl.LoadViewState(Object).)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnClick(EventArgs) |
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | OuterGlowCssClass |
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(String) |
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | (Overrides WebControl.RenderBeginTag(HtmlTextWriter).)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | (Overrides WebControl.SaveViewState()().)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TextCssClass | Gets or sets the CSS class of the text.
 | TextSelectedCssClass | Gets or sets the selected CSS class.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | ImagePickerDiv

Assembly: MSS.Wizard (Module: MSS.Wizard)


ImagePickerDiv Constructor

ImagePickerDiv Constructor
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> ImagePickerDivImagePickerDivNew()()
Declaration Syntax
C#
public ImagePickerDiv()

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddImage Method (image, text)

AddImage Method (image, text)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> AddImage(String, String)
Declaration Syntax
C#
public void AddImage(
    string image,
    string text
)
Parameters
image (String)
text (String)

Assembly: MSS.Wizard (Module: MSS.Wizard)


ButtonCssClass Property

ButtonCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> ButtonCssClass
Declaration Syntax
C#
public string ButtonCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


ClearImages Method

ClearImages Method
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> ClearImages()()
Declaration Syntax
C#
public void ClearImages()

Assembly: MSS.Wizard (Module: MSS.Wizard)


Click Event

Click Event
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> Click
Declaration Syntax
C#
public event EventHandler Click

Assembly: MSS.Wizard (Module: MSS.Wizard)


ControlCssClass Property

ControlCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> ControlCssClass
Declaration Syntax
C#
public string ControlCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


CreateChildControls Method

CreateChildControls Method
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> CreateChildControls()()
Declaration Syntax
C#
protected override void CreateChildControls()

Assembly: MSS.Wizard (Module: MSS.Wizard)


DropShadowCssClass Property

DropShadowCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> DropShadowCssClass
Declaration Syntax
C#
public string DropShadowCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


ImageButton_Click Method (sender, args)

ImageButton_Click Method (sender, args)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> ImageButton_Click(Object, CommandEventArgs)
Declaration Syntax
C#
protected void ImageButton_Click(
    Object sender,
    CommandEventArgs args
)
Parameters
sender (Object)
args (CommandEventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


ImageCssClass Property

ImageCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> ImageCssClass
Declaration Syntax
C#
public string ImageCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


ImageSelectedCssClass Property

ImageSelectedCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> ImageSelectedCssClass
Gets or sets the image selected CSS class.
Declaration Syntax
C#
public string ImageSelectedCssClass{ get; set;}
Value
The image selected CSS class.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Index Property

Index Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> Index
Gets or sets the index.
Declaration Syntax
C#
public int Index{ get; set;}
Value
The index.

Assembly: MSS.Wizard (Module: MSS.Wizard)


IndexName Property

IndexName Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> IndexName
Gets the name of the index.
Declaration Syntax
C#
public string IndexName{ get;}
Value
The name of the index.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadViewState Method (savedState)

LoadViewState Method (savedState)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> LoadViewState(Object)
Declaration Syntax
C#
protected override void LoadViewState(
    Object savedState
)
Parameters
savedState (Object)

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnClick Method (e)

OnClick Method (e)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> OnClick(EventArgs)
Declaration Syntax
C#
protected virtual void OnClick(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


OuterGlowCssClass Property

OuterGlowCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> OuterGlowCssClass
Declaration Syntax
C#
public string OuterGlowCssClass{ get; set;}

Assembly: MSS.Wizard (Module: MSS.Wizard)


RaisePostBackEvent Method (eventArgument)

RaisePostBackEvent Method (eventArgument)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> RaisePostBackEvent(String)
Declaration Syntax
C#
public void RaisePostBackEvent(
    string eventArgument
)
Parameters
eventArgument (String)

Assembly: MSS.Wizard (Module: MSS.Wizard)


Render Method (writer)

Render Method (writer)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> Render(HtmlTextWriter)
Declaration Syntax
C#
protected override void Render(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderBeginTag Method (writer)

RenderBeginTag Method (writer)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> RenderBeginTag(HtmlTextWriter)
Declaration Syntax
C#
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderEndTag Method (writer)

RenderEndTag Method (writer)
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> RenderEndTag(HtmlTextWriter)
Declaration Syntax
C#
public override void RenderEndTag(
    HtmlTextWriter writer
)
Parameters
writer (HtmlTextWriter)

Assembly: MSS.Wizard (Module: MSS.Wizard)


SaveViewState Method

SaveViewState Method
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> SaveViewState()()
Declaration Syntax
C#
protected override Object SaveViewState()

Assembly: MSS.Wizard (Module: MSS.Wizard)


TextCssClass Property

TextCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> TextCssClass
Gets or sets the CSS class of the text.
Declaration Syntax
C#
public string TextCssClass{ get; set;}
Value
The text CSS class.

Assembly: MSS.Wizard (Module: MSS.Wizard)


TextSelectedCssClass Property

TextSelectedCssClass Property
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> TextSelectedCssClass
Gets or sets the selected CSS class.
Declaration Syntax
C#
public string TextSelectedCssClass{ get; set;}
Value
The text selected CSS class.

Assembly: MSS.Wizard (Module: MSS.Wizard)


StepSelector Class

StepSelector Class
Namespaces >> MSS.Wizard.WebControls >> StepSelector
Selects a rendering from wizard step item and renders it.
Declaration Syntax
C#
public class StepSelector : WebControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StepSelectorStepSelectorNew()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()() | Saves any state that was modified after the TrackViewState()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | IAttributeAccessor..::GetAttribute(String) | (Inherited from WebControl.)
 | IAttributeAccessor..::SetAttribute(String, String) | (Inherited from WebControl.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | StepSelector

Assembly: MSS.Wizard (Module: MSS.Wizard)


StepSelector Constructor

StepSelector Constructor
Namespaces >> MSS.Wizard.WebControls >> StepSelector >> StepSelectorStepSelectorNew()()
Declaration Syntax
C#
public StepSelector()

Assembly: MSS.Wizard (Module: MSS.Wizard)


OnInit Method (e)

OnInit Method (e)
Namespaces >> MSS.Wizard.WebControls >> StepSelector >> OnInit(EventArgs)
Declaration Syntax
C#
protected override void OnInit(
    EventArgs e
)
Parameters
e (EventArgs)

Assembly: MSS.Wizard (Module: MSS.Wizard)


MSS.XslHelper Namespace

MSS.XslHelper Namespace
Namespaces >> MSS.XslHelper
Declaration Syntax
C#
namespace MSS.XslHelper
Types
All Types Classes
Icon | Type | Description
 | XslDictionaryHelper | Provides access to MSS dictionary from xsl
 | XslHelper | MSS xsl helper


XslDictionaryHelper Class

XslDictionaryHelper Class
Namespaces >> MSS.XslHelper >> XslDictionaryHelper
Provides access to MSS dictionary from xsl
Declaration Syntax
C#
public class XslDictionaryHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XslDictionaryHelperXslDictionaryHelperNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHint(String) | Gets the hint text from a dictionary.
 | GetHint(String, String, String) | Gets the hint text from a dictionary.
 | GetText(String, String, String) | Gets the text from a dictionary.
 | GetText(String) | Gets the text from a dictionary.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XslDictionaryHelper

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


XslDictionaryHelper Constructor

XslDictionaryHelper Constructor
Namespaces >> MSS.XslHelper >> XslDictionaryHelper >> XslDictionaryHelperXslDictionaryHelperNew()()
Declaration Syntax
C#
public XslDictionaryHelper()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetHint Method

GetHint Method
Namespaces >> MSS.XslHelper >> XslDictionaryHelper >> GetHint()()
Members
Icon | Member | Description
 | GetHint(String) | Gets the hint text from a dictionary.
 | GetHint(String, String, String) | Gets the hint text from a dictionary.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetHint Method (text)

GetHint Method (text)
Namespaces >> MSS.XslHelper >> XslDictionaryHelper >> GetHint(String)
Gets the hint text from a dictionary.
Declaration Syntax
C#
public virtual string GetHint(
    string text
)
Parameters
text (String)
The text.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetHint Method (text, language, dic)

GetHint Method (text, language, dic)
Namespaces >> MSS.XslHelper >> XslDictionaryHelper >> GetHint(String, String, String)
Gets the hint text from a dictionary.
Declaration Syntax
C#
public virtual string GetHint(
    string text,
    string language,
    string dic
)
Parameters
text (String)
The text.
language (String)
The language.
dic (String)
The dic.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetText Method

GetText Method
Namespaces >> MSS.XslHelper >> XslDictionaryHelper >> GetText()()
Members
Icon | Member | Description
 | GetText(String, String, String) | Gets the text from a dictionary.
 | GetText(String) | Gets the text from a dictionary.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetText Method (text)

GetText Method (text)
Namespaces >> MSS.XslHelper >> XslDictionaryHelper >> GetText(String)
Gets the text from a dictionary.
Declaration Syntax
C#
public virtual string GetText(
    string text
)
Parameters
text (String)
The text.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetText Method (text, language, dic)

GetText Method (text, language, dic)
Namespaces >> MSS.XslHelper >> XslDictionaryHelper >> GetText(String, String, String)
Gets the text from a dictionary.
Declaration Syntax
C#
public virtual string GetText(
    string text,
    string language,
    string dic
)
Parameters
text (String)
The text.
language (String)
The language.
dic (String)
The dic.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


XslHelper Class

XslHelper Class
Namespaces >> MSS.XslHelper >> XslHelper
MSS xsl helper
Declaration Syntax
C#
public class XslHelper
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XslHelperXslHelperNew()() |
 | Breadcrumb(String, String, String, String, Boolean, String, String) | Render a breadcrumb and return it as html.
 | ContactDocument()() | Returns the the Contact form document
 | DaysInMonth(String, String) | Returns the number of days for the given year and month
 | DefaultIfBlank(String, String) | Returns default value if value is null or empty string
 | EndLink(XPathNodeIterator, String) | Ends render the link.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FixFilePath(String) | Fixes the file path by replasing space symbol ' ' with the %20 code
 | Flash(String, String, String, String) | Render a flash and return it as html.
 | fld(String, XPathNodeIterator) | The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
 | fld(String, XPathNodeIterator, String) | The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
 | fld(String, XPathNodeIterator, String, String) | The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
 | GetFieldValue(String, Item) | Gets the field value from the current language. If value is empty string returns value from default site language.
 | GetFieldValue(String, Item, String) | Gets the field value the current language. If value is empty string returns value from default site language.
 | GetFieldValueRecursive(XPathNodeIterator, String, String) | Gets the field value recursive.
 | GetFileExtension(String) | Gets the file extension.
 | GetFileIcon(String, Int32, Int32) | Gets the file icon for an extension.
 | GetFullURL()() | Returns the full URL of the current request
 | GetGlobalDocument(String) | Gets the global document.
 | GetGlobalItem()() | Gets the site global item.
 | GetGlobalMenuRoot()() | Gets the global menu root.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHome()() | Gets the site home item.
 | GetItem(String) | Gets the item by its ID.
 | GetLink(XPathNodeIterator, String) | Renders a html link.
 | GetLinkItem(String, XPathNodeIterator) | Obsolete.
 | GetMediaFile(String, XPathNodeIterator) | Gets the media file.
 | GetMediaItemExtension(String) | Gets a media item file extension by media item id.
 | GetMenuTitle(XPathNodeIterator) | Gets the menu title for an item.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetYear(String) | Gets the year from the date.
 | Image(XPathNodeIterator, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean) | Render a image and return it as html.
 | imageUrl(String, XPathNodeIterator) | Get the image url
 | IsLocalDocument(XPathNodeIterator) | Determines whether [is local document].
 | IsLoggedIn()() | Determines whether there is a logged in user.
 | IsRequiredModulesAllowed(XPathNodeIterator) | Determines whether all the modulles that are necessury to the item are avaliable.
 | IsSiteUpdated()() | Determines whether [is site status updated].
 | IsVisible(XPathNodeIterator) | Determines whether the specified item is visible.
 | IsWebEdit()() | Determines whether the site is in the web edit mode.
 | IsWebEditModeCompliant(XPathNodeIterator) | Determines whether the site is in the mode (such as normal/web edit/preview) that meets requement to see the item.
 | link(String, XPathNodeIterator) | Renders a html link.
 | link(String, XPathNodeIterator, String) | Renders a html link.
 | LinkIsEmpty(String) | Indicates whether a link is empty.
 | LoggenIn()() | If user isn't logged redirect to login page
 | LoginDocument()() | Returns the login document
 | LogoutDocument()() | Returns the logout document
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModuleSettingsLowerCase(String, String) | Gets a module setting.
 | MssRightIsAllowed(String) | Indicates whether current user has a right
 | NotPublished(XPathNodeIterator) | Returns where item has been published
 | Path(XPathNodeIterator) | Gets a fiendly url to an item
 | Path(XPathNodeIterator, String) | Gets the friendly url with the specified query string to an item
 | PrintDocument()() | Returns the URL of the print friendly page
 | Replace(String, String, String) | Replaces all occuirances of oldValue in str with newValue.
 | RequiredModulesFieldName |
 | Search(String, Int32, Int32, Int32, String, String) | Searches the specified search text.
 | SiteData(String) | Get a sites data setting.
 | SiteDataDefaultLanguage |
 | SitemapDocument()() | Returns the sitemap document
 | SiteModulesSetting(String, String) | Returns the module setting in lower case for the given section and key.
 | SiteModulesSetting(String) | Returns the module setting for the given key. Section is ignored so the key is searched for in all sections
 | SiteSettings(String, String) | Gets a site setting.
 | SiteSettingsLowerCase(String, String) | Gets a site setting in lower case.
 | StartLink(XPathNodeIterator, String) | Starts render the link.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateUserName(String) | Returns user's full name (or local name if the user has no full name that has been set)
 | url(String, XPathNodeIterator) | Gets the url from the field.
 | WizardPages()() | Gets the Wizard pages.
Inheritance Hierarchy
Object
XslHelper

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


XslHelper Constructor

XslHelper Constructor
Namespaces >> MSS.XslHelper >> XslHelper >> XslHelperXslHelperNew()()
Declaration Syntax
C#
public XslHelper()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Breadcrumb Method (item, templates, separator, separatorType, lastElemtnLink, shorteningText, maxSymbolsCount)

Breadcrumb Method (item, templates, separator, separatorType, lastElemtnLink, shorteningText, maxSymbolsCount)
Namespaces >> MSS.XslHelper >> XslHelper >> Breadcrumb(String, String, String, String, Boolean, String, String)
Render a breadcrumb and return it as html.
Declaration Syntax
C#
public string Breadcrumb(
    string item,
    string templates,
    string separator,
    string separatorType,
    bool lastElemtnLink,
    string shorteningText,
    string maxSymbolsCount
)
Parameters
item (String)
The item.
templates (String)
The templates.
separator (String)
The separator.
separatorType (String)
Type of the separator.
lastElemtnLink (Boolean)
If set to true link to the last element should be included.
shorteningText (String)
The shortening text.
maxSymbolsCount (String)
The max count of symbols in Breadcrumb.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


ContactDocument Method

ContactDocument Method
Namespaces >> MSS.XslHelper >> XslHelper >> ContactDocument()()
Returns the the Contact form document
Declaration Syntax
C#
public virtual XPathNodeIterator ContactDocument()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


DaysInMonth Method (year, month)

DaysInMonth Method (year, month)
Namespaces >> MSS.XslHelper >> XslHelper >> DaysInMonth(String, String)
Returns the number of days for the given year and month
Declaration Syntax
C#
public int DaysInMonth(
    string year,
    string month
)
Parameters
year (String)
month (String)
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


DefaultIfBlank Method (value, defaultValue)

DefaultIfBlank Method (value, defaultValue)
Namespaces >> MSS.XslHelper >> XslHelper >> DefaultIfBlank(String, String)
Returns default value if value is null or empty string
Declaration Syntax
C#
public string DefaultIfBlank(
    string value,
    string defaultValue
)
Parameters
value (String)
The value.
defaultValue (String)
The default value.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


EndLink Method (iterator, parameters)

EndLink Method (iterator, parameters)
Namespaces >> MSS.XslHelper >> XslHelper >> EndLink(XPathNodeIterator, String)
Ends render the link.
Declaration Syntax
C#
public virtual string EndLink(
    XPathNodeIterator iterator,
    string parameters
)
Parameters
iterator (XPathNodeIterator)
The iterator.
parameters (String)
The parameters.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


FixFilePath Method (path)

FixFilePath Method (path)
Namespaces >> MSS.XslHelper >> XslHelper >> FixFilePath(String)
Fixes the file path by replasing space symbol ' ' with the %20 code
Declaration Syntax
C#
public static string FixFilePath(
    string path
)
Parameters
path (String)
The path.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Flash Method (src, alt, width, height)

Flash Method (src, alt, width, height)
Namespaces >> MSS.XslHelper >> XslHelper >> Flash(String, String, String, String)
Render a flash and return it as html.
Declaration Syntax
C#
public static string Flash(
    string src,
    string alt,
    string width,
    string height
)
Parameters
src (String)
The SRC.
alt (String)
The alt.
width (String)
The width.
height (String)
The height.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


fld Method

fld Method
Namespaces >> MSS.XslHelper >> XslHelper >> fld()()
Members
Icon | Member | Description
 | fld(String, XPathNodeIterator) | The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
 | fld(String, XPathNodeIterator, String) | The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
 | fld(String, XPathNodeIterator, String, String) | The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


fld Method (fieldName, item)

fld Method (fieldName, item)
Namespaces >> MSS.XslHelper >> XslHelper >> fld(String, XPathNodeIterator)
The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
Declaration Syntax
C#
public string fld(
    string fieldName,
    XPathNodeIterator item
)
Parameters
fieldName (String)
item (XPathNodeIterator)
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


fld Method (fieldName, item, subFieldName)

fld Method (fieldName, item, subFieldName)
Namespaces >> MSS.XslHelper >> XslHelper >> fld(String, XPathNodeIterator, String)
The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
Declaration Syntax
C#
public string fld(
    string fieldName,
    XPathNodeIterator item,
    string subFieldName
)
Parameters
fieldName (String)
Name of the field.
item (XPathNodeIterator)
The item.
subFieldName (String)
Name of the sub field.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


fld Method (fieldName, item, subFieldName, language)

fld Method (fieldName, item, subFieldName, language)
Namespaces >> MSS.XslHelper >> XslHelper >> fld(String, XPathNodeIterator, String, String)
The as for the Sitecore XslHelper version, besides this version defaults to the value of the field for the default language if no value found for current language
Declaration Syntax
C#
public string fld(
    string fieldName,
    XPathNodeIterator item,
    string subFieldName,
    string language
)
Parameters
fieldName (String)
Name of the field.
item (XPathNodeIterator)
The item.
subFieldName (String)
Name of the sub field.
language (String)
The language.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetFieldValue Method

GetFieldValue Method
Namespaces >> MSS.XslHelper >> XslHelper >> GetFieldValue()()
Members
Icon | Member | Description
 | GetFieldValue(String, Item) | Gets the field value from the current language. If value is empty string returns value from default site language.
 | GetFieldValue(String, Item, String) | Gets the field value the current language. If value is empty string returns value from default site language.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetFieldValue Method (fieldName, item)

GetFieldValue Method (fieldName, item)
Namespaces >> MSS.XslHelper >> XslHelper >> GetFieldValue(String, Item)
Gets the field value from the current language. If value is empty string returns value from default site language.
Declaration Syntax
C#
public string GetFieldValue(
    string fieldName,
    Item item
)
Parameters
fieldName (String)
Name of the field.
item (Item)
The item.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetFieldValue Method (fieldName, item, subFieldName)

GetFieldValue Method (fieldName, item, subFieldName)
Namespaces >> MSS.XslHelper >> XslHelper >> GetFieldValue(String, Item, String)
Gets the field value the current language. If value is empty string returns value from default site language.
Declaration Syntax
C#
public string GetFieldValue(
    string fieldName,
    Item item,
    string subFieldName
)
Parameters
fieldName (String)
Name of the field.
item (Item)
The item.
subFieldName (String)
Name of the sub field.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetFieldValueRecursive Method (iterator, field, templates)

GetFieldValueRecursive Method (iterator, field, templates)
Namespaces >> MSS.XslHelper >> XslHelper >> GetFieldValueRecursive(XPathNodeIterator, String, String)
Gets the field value recursive.
Declaration Syntax
C#
public string GetFieldValueRecursive(
    XPathNodeIterator iterator,
    string field,
    string templates
)
Parameters
iterator (XPathNodeIterator)
The iterator.
field (String)
The field.
templates (String)
The templates.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetFileExtension Method (fileName)

GetFileExtension Method (fileName)
Namespaces >> MSS.XslHelper >> XslHelper >> GetFileExtension(String)
Gets the file extension.
Declaration Syntax
C#
public static string GetFileExtension(
    string fileName
)
Parameters
fileName (String)
Name of the file.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetFileIcon Method (extension, width, height)

GetFileIcon Method (extension, width, height)
Namespaces >> MSS.XslHelper >> XslHelper >> GetFileIcon(String, Int32, Int32)
Gets the file icon for an extension.
Declaration Syntax
C#
public virtual string GetFileIcon(
    string extension,
    int width,
    int height
)
Parameters
extension (String)
The extension.
width (Int32)
The width.
height (Int32)
The height.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetFullURL Method

GetFullURL Method
Namespaces >> MSS.XslHelper >> XslHelper >> GetFullURL()()
Returns the full URL of the current request
Declaration Syntax
C#
public string GetFullURL()
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetGlobalDocument Method (docName)

GetGlobalDocument Method (docName)
Namespaces >> MSS.XslHelper >> XslHelper >> GetGlobalDocument(String)
Gets the global document.
Declaration Syntax
C#
public XPathNodeIterator GetGlobalDocument(
    string docName
)
Parameters
docName (String)
Name of the doc.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetGlobalItem Method

GetGlobalItem Method
Namespaces >> MSS.XslHelper >> XslHelper >> GetGlobalItem()()
Gets the site global item.
Declaration Syntax
C#
public XPathNodeIterator GetGlobalItem()
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetGlobalMenuRoot Method

GetGlobalMenuRoot Method
Namespaces >> MSS.XslHelper >> XslHelper >> GetGlobalMenuRoot()()
Gets the global menu root.
Declaration Syntax
C#
public XPathNodeIterator GetGlobalMenuRoot()
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetHome Method

GetHome Method
Namespaces >> MSS.XslHelper >> XslHelper >> GetHome()()
Gets the site home item.
Declaration Syntax
C#
public XPathNodeIterator GetHome()
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetItem Method (id)

GetItem Method (id)
Namespaces >> MSS.XslHelper >> XslHelper >> GetItem(String)
Gets the item by its ID.
Declaration Syntax
C#
public XPathNodeIterator GetItem(
    string id
)
Parameters
id (String)
The ID.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetLink Method (iterator, args)

GetLink Method (iterator, args)
Namespaces >> MSS.XslHelper >> XslHelper >> GetLink(XPathNodeIterator, String)
Renders a html link.
Declaration Syntax
C#
public string GetLink(
    XPathNodeIterator iterator,
    string args
)
Parameters
iterator (XPathNodeIterator)
The iterator.
args (String)
The args.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetLinkItem Method (fieldName, ni)

GetLinkItem Method (fieldName, ni)
Namespaces >> MSS.XslHelper >> XslHelper >> GetLinkItem(String, XPathNodeIterator)
Declaration Syntax
C#
[ObsoleteAttribute("Use Sitecore.Xml.Xsl.XslHelper.GetLinkItem")]
public XPathNodeIterator GetLinkItem(
    string fieldName,
    XPathNodeIterator ni
)
Parameters
fieldName (String)
ni (XPathNodeIterator)

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetMediaFile Method (fieldName, ni)

GetMediaFile Method (fieldName, ni)
Namespaces >> MSS.XslHelper >> XslHelper >> GetMediaFile(String, XPathNodeIterator)
Gets the media file.
Declaration Syntax
C#
public XPathNodeIterator GetMediaFile(
    string fieldName,
    XPathNodeIterator ni
)
Parameters
fieldName (String)
Name of the field.
ni (XPathNodeIterator)
The ni.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetMediaItemExtension Method (mediaItemID)

GetMediaItemExtension Method (mediaItemID)
Namespaces >> MSS.XslHelper >> XslHelper >> GetMediaItemExtension(String)
Gets a media item file extension by media item id.
Declaration Syntax
C#
public static string GetMediaItemExtension(
    string mediaItemID
)
Parameters
mediaItemID (String)
Media item id
Return Value
Media item file extension

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetMenuTitle Method (ni)

GetMenuTitle Method (ni)
Namespaces >> MSS.XslHelper >> XslHelper >> GetMenuTitle(XPathNodeIterator)
Gets the menu title for an item.
Declaration Syntax
C#
public string GetMenuTitle(
    XPathNodeIterator ni
)
Parameters
ni (XPathNodeIterator)
The node iterator.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


GetYear Method (date)

GetYear Method (date)
Namespaces >> MSS.XslHelper >> XslHelper >> GetYear(String)
Gets the year from the date.
Declaration Syntax
C#
public string GetYear(
    string date
)
Parameters
date (String)
The date.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Image Method (xPathIterator, imageField, width, height, altText, imageSrc, altField, vSpace, hSpace, cssClass, border, linkField, linkUrl, linkClass, linkTip, newWindow)

Image Method (xPathIterator, imageField, width, height, altText, imageSrc, altField, vSpace, hSpace, cssClass, border, linkField, linkUrl, linkClass, linkTip, newWindow)
Namespaces >> MSS.XslHelper >> XslHelper >> Image(XPathNodeIterator, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean)
Render a image and return it as html.
Declaration Syntax
C#
public string Image(
    XPathNodeIterator xPathIterator,
    string imageField,
    string width,
    string height,
    string altText,
    string imageSrc,
    string altField,
    string vSpace,
    string hSpace,
    string cssClass,
    string border,
    string linkField,
    string linkUrl,
    string linkClass,
    string linkTip,
    bool newWindow
)
Parameters
xPathIterator (XPathNodeIterator)
imageField (String)
width (String)
height (String)
altText (String)
imageSrc (String)
altField (String)
vSpace (String)
hSpace (String)
cssClass (String)
border (String)
linkField (String)
linkUrl (String)
linkClass (String)
linkTip (String)
newWindow (Boolean)

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


imageUrl Method (fieldName, iterator)

imageUrl Method (fieldName, iterator)
Namespaces >> MSS.XslHelper >> XslHelper >> imageUrl(String, XPathNodeIterator)
Get the image url
Declaration Syntax
C#
public string imageUrl(
    string fieldName,
    XPathNodeIterator iterator
)
Parameters
fieldName (String)
Name of the field.
iterator (XPathNodeIterator)
The iterator.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


IsLocalDocument Method (ni)

IsLocalDocument Method (ni)
Namespaces >> MSS.XslHelper >> XslHelper >> IsLocalDocument(XPathNodeIterator)
Determines whether [is local document].
Declaration Syntax
C#
public bool IsLocalDocument(
    XPathNodeIterator ni
)
Parameters
ni (XPathNodeIterator)
The ni.
Return Value
true if [is local document] ; otherwise, false.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


IsLoggedIn Method

IsLoggedIn Method
Namespaces >> MSS.XslHelper >> XslHelper >> IsLoggedIn()()
Determines whether there is a logged in user.
Declaration Syntax
C#
public bool IsLoggedIn()
Return Value
true if there is a logged in user; otherwise, false.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


IsRequiredModulesAllowed Method (ni)

IsRequiredModulesAllowed Method (ni)
Namespaces >> MSS.XslHelper >> XslHelper >> IsRequiredModulesAllowed(XPathNodeIterator)
Determines whether all the modulles that are necessury to the item are avaliable.
Declaration Syntax
C#
public bool IsRequiredModulesAllowed(
    XPathNodeIterator ni
)
Parameters
ni (XPathNodeIterator)
The node iterator.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


IsSiteUpdated Method

IsSiteUpdated Method
Namespaces >> MSS.XslHelper >> XslHelper >> IsSiteUpdated()()
Determines whether [is site status updated].
Declaration Syntax
C#
public bool IsSiteUpdated()
Return Value
true if [is site updated]; otherwise, false.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


IsVisible Method (ni)

IsVisible Method (ni)
Namespaces >> MSS.XslHelper >> XslHelper >> IsVisible(XPathNodeIterator)
Determines whether the specified item is visible.
Declaration Syntax
C#
public bool IsVisible(
    XPathNodeIterator ni
)
Parameters
ni (XPathNodeIterator)
The ni.
Return Value
true if the specified ni is visible; otherwise, false.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


IsWebEdit Method

IsWebEdit Method
Namespaces >> MSS.XslHelper >> XslHelper >> IsWebEdit()()
Determines whether the site is in the web edit mode.
Declaration Syntax
C#
public bool IsWebEdit()
Return Value
true if the site is in the web edit mode; otherwise, false.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


IsWebEditModeCompliant Method (ni)

IsWebEditModeCompliant Method (ni)
Namespaces >> MSS.XslHelper >> XslHelper >> IsWebEditModeCompliant(XPathNodeIterator)
Determines whether the site is in the mode (such as normal/web edit/preview) that meets requement to see the item.
Declaration Syntax
C#
public bool IsWebEditModeCompliant(
    XPathNodeIterator ni
)
Parameters
ni (XPathNodeIterator)
The node iterator.
Return Value
true if the site is in the mode (such as normal/web edit/preview) that meets requement to see the item; otherwise, false.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


link Method

link Method
Namespaces >> MSS.XslHelper >> XslHelper >> link()()
Members
Icon | Member | Description
 | link(String, XPathNodeIterator) | Renders a html link.
 | link(String, XPathNodeIterator, String) | Renders a html link.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


link Method (field, iterator)

link Method (field, iterator)
Namespaces >> MSS.XslHelper >> XslHelper >> link(String, XPathNodeIterator)
Renders a html link.
Declaration Syntax
C#
public string link(
    string field,
    XPathNodeIterator iterator
)
Parameters
field (String)
The field.
iterator (XPathNodeIterator)
The iterator.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


link Method (fieldName, iterator, args)

link Method (fieldName, iterator, args)
Namespaces >> MSS.XslHelper >> XslHelper >> link(String, XPathNodeIterator, String)
Renders a html link.
Declaration Syntax
C#
public string link(
    string fieldName,
    XPathNodeIterator iterator,
    string args
)
Parameters
fieldName (String)
Name of the field.
iterator (XPathNodeIterator)
The iterator.
args (String)
The args.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


LinkIsEmpty Method (link)

LinkIsEmpty Method (link)
Namespaces >> MSS.XslHelper >> XslHelper >> LinkIsEmpty(String)
Indicates whether a link is empty.
Declaration Syntax
C#
public bool LinkIsEmpty(
    string link
)
Parameters
link (String)
The link.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


LoggenIn Method

LoggenIn Method
Namespaces >> MSS.XslHelper >> XslHelper >> LoggenIn()()
If user isn't logged redirect to login page
Declaration Syntax
C#
public void LoggenIn()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


LoginDocument Method

LoginDocument Method
Namespaces >> MSS.XslHelper >> XslHelper >> LoginDocument()()
Returns the login document
Declaration Syntax
C#
public virtual XPathNodeIterator LoginDocument()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


LogoutDocument Method

LogoutDocument Method
Namespaces >> MSS.XslHelper >> XslHelper >> LogoutDocument()()
Returns the logout document
Declaration Syntax
C#
public virtual XPathNodeIterator LogoutDocument()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


ModuleSettingsLowerCase Method (section, key)

ModuleSettingsLowerCase Method (section, key)
Namespaces >> MSS.XslHelper >> XslHelper >> ModuleSettingsLowerCase(String, String)
Gets a module setting.
Declaration Syntax
C#
public string ModuleSettingsLowerCase(
    string section,
    string key
)
Parameters
section (String)
The section.
key (String)
The key.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


MssRightIsAllowed Method (rightName)

MssRightIsAllowed Method (rightName)
Namespaces >> MSS.XslHelper >> XslHelper >> MssRightIsAllowed(String)
Indicates whether current user has a right
Declaration Syntax
C#
public bool MssRightIsAllowed(
    string rightName
)
Parameters
rightName (String)
Name of the right.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


NotPublished Method (ni)

NotPublished Method (ni)
Namespaces >> MSS.XslHelper >> XslHelper >> NotPublished(XPathNodeIterator)
Returns where item has been published
Declaration Syntax
C#
public bool NotPublished(
    XPathNodeIterator ni
)
Parameters
ni (XPathNodeIterator)
The ni.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Path Method

Path Method
Namespaces >> MSS.XslHelper >> XslHelper >> Path()()
Members
Icon | Member | Description
 | Path(XPathNodeIterator) | Gets a fiendly url to an item
 | Path(XPathNodeIterator, String) | Gets the friendly url with the specified query string to an item

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Path Method (ni)

Path Method (ni)
Namespaces >> MSS.XslHelper >> XslHelper >> Path(XPathNodeIterator)
Gets a fiendly url to an item
Declaration Syntax
C#
public string Path(
    XPathNodeIterator ni
)
Parameters
ni (XPathNodeIterator)
The node iterator.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Path Method (ni, queryString)

Path Method (ni, queryString)
Namespaces >> MSS.XslHelper >> XslHelper >> Path(XPathNodeIterator, String)
Gets the friendly url with the specified query string to an item
Declaration Syntax
C#
public string Path(
    XPathNodeIterator ni,
    string queryString
)
Parameters
ni (XPathNodeIterator)
The node iterator.
queryString (String)
The query string.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


PrintDocument Method

PrintDocument Method
Namespaces >> MSS.XslHelper >> XslHelper >> PrintDocument()()
Returns the URL of the print friendly page
Declaration Syntax
C#
public virtual string PrintDocument()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Replace Method (str, oldValue, newValue)

Replace Method (str, oldValue, newValue)
Namespaces >> MSS.XslHelper >> XslHelper >> Replace(String, String, String)
Replaces all occuirances of oldValue in str with newValue.
Declaration Syntax
C#
public static string Replace(
    string str,
    string oldValue,
    string newValue
)
Parameters
str (String)
The STR.
oldValue (String)
The old value.
newValue (String)
The new value.

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


RequiredModulesFieldName Field

RequiredModulesFieldName Field
Namespaces >> MSS.XslHelper >> XslHelper >> RequiredModulesFieldName
Declaration Syntax
C#
public static readonly string RequiredModulesFieldName

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


Search Method (searchText, textLength, pageNubmer, count, templates, cssClass)

Search Method (searchText, textLength, pageNubmer, count, templates, cssClass)
Namespaces >> MSS.XslHelper >> XslHelper >> Search(String, Int32, Int32, Int32, String, String)
Searches the specified search text.
Declaration Syntax
C#
public XPathNodeIterator Search(
    string searchText,
    int textLength,
    int pageNubmer,
    int count,
    string templates,
    string cssClass
)
Parameters
searchText (String)
The search text.
textLength (Int32)
Length of the text.
pageNubmer (Int32)
The page nubmer.
count (Int32)
The count.
templates (String)
The templates.
cssClass (String)
The CSS class.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SiteData Method (key)

SiteData Method (key)
Namespaces >> MSS.XslHelper >> XslHelper >> SiteData(String)
Get a sites data setting.
Declaration Syntax
C#
public string SiteData(
    string key
)
Parameters
key (String)
The key.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SiteDataDefaultLanguage Field

SiteDataDefaultLanguage Field
Namespaces >> MSS.XslHelper >> XslHelper >> SiteDataDefaultLanguage
Declaration Syntax
C#
public static readonly string SiteDataDefaultLanguage

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SitemapDocument Method

SitemapDocument Method
Namespaces >> MSS.XslHelper >> XslHelper >> SitemapDocument()()
Returns the sitemap document
Declaration Syntax
C#
public virtual XPathNodeIterator SitemapDocument()

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SiteModulesSetting Method

SiteModulesSetting Method
Namespaces >> MSS.XslHelper >> XslHelper >> SiteModulesSetting()()
Members
Icon | Member | Description
 | SiteModulesSetting(String, String) | Returns the module setting in lower case for the given section and key.
 | SiteModulesSetting(String) | Returns the module setting for the given key. Section is ignored so the key is searched for in all sections

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SiteModulesSetting Method (key)

SiteModulesSetting Method (key)
Namespaces >> MSS.XslHelper >> XslHelper >> SiteModulesSetting(String)
Returns the module setting for the given key. Section is ignored so the key is searched for in all sections
Declaration Syntax
C#
public string SiteModulesSetting(
    string key
)
Parameters
key (String)
Setting key name
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SiteModulesSetting Method (section, key)

SiteModulesSetting Method (section, key)
Namespaces >> MSS.XslHelper >> XslHelper >> SiteModulesSetting(String, String)
Returns the module setting in lower case for the given section and key.
Declaration Syntax
C#
public string SiteModulesSetting(
    string section,
    string key
)
Parameters
section (String)
Setting section name
key (String)
Setting key name
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SiteSettings Method (section, key)

SiteSettings Method (section, key)
Namespaces >> MSS.XslHelper >> XslHelper >> SiteSettings(String, String)
Gets a site setting.
Declaration Syntax
C#
public string SiteSettings(
    string section,
    string key
)
Parameters
section (String)
The section.
key (String)
The key.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


SiteSettingsLowerCase Method (section, key)

SiteSettingsLowerCase Method (section, key)
Namespaces >> MSS.XslHelper >> XslHelper >> SiteSettingsLowerCase(String, String)
Gets a site setting in lower case.
Declaration Syntax
C#
public string SiteSettingsLowerCase(
    string section,
    string key
)
Parameters
section (String)
The section.
key (String)
The key.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


StartLink Method (iterator, parameters)

StartLink Method (iterator, parameters)
Namespaces >> MSS.XslHelper >> XslHelper >> StartLink(XPathNodeIterator, String)
Starts render the link.
Declaration Syntax
C#
public virtual string StartLink(
    XPathNodeIterator iterator,
    string parameters
)
Parameters
iterator (XPathNodeIterator)
The iterator.
parameters (String)
The parameters.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


UpdateUserName Method (qualifiedName)

UpdateUserName Method (qualifiedName)
Namespaces >> MSS.XslHelper >> XslHelper >> UpdateUserName(String)
Returns user's full name (or local name if the user has no full name that has been set)
Declaration Syntax
C#
public string UpdateUserName(
    string qualifiedName
)
Parameters
qualifiedName (String)
Name that is in format 'domain\user'
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


url Method (fieldName, iterator)

url Method (fieldName, iterator)
Namespaces >> MSS.XslHelper >> XslHelper >> url(String, XPathNodeIterator)
Gets the url from the field.
Declaration Syntax
C#
public string url(
    string fieldName,
    XPathNodeIterator iterator
)
Parameters
fieldName (String)
Name of the field.
iterator (XPathNodeIterator)
The iterator.
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


WizardPages Method

WizardPages Method
Namespaces >> MSS.XslHelper >> XslHelper >> WizardPages()()
Gets the Wizard pages.
Declaration Syntax
C#
public XPathNodeIterator WizardPages()
Return Value

Assembly: MSS.XslHelper (Module: MSS.XslHelper)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Sort Method

Sort Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


qs Method

qs Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Navigation >> PublishWeb >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


qs Method

qs Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary.

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadSettings Method

LoadSettings Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> LoadSettings()()
Members
Icon | Member | Description
 | LoadSettings()() | Loads the settings.
 | LoadSettings(String) | Loads the settings.
 | LoadSettings(Item) | Loads the settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.Modules.News >> News >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddControl Method

AddControl Method
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddControl Method

AddControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddControl Method

AddControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Administration (Module: MSS.Administration)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Language >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Create Method

Create Method
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> Create()()
Members
Icon | Member | Description
 | Create(String, String) | Creates the item.
 | Create(String) | Creates the item.
 | Create(DateTime) | Creates the item.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.News >> News >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Label >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> Upload >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> NoLicense >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Wizard.Pages >> Upload >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


qs Method

qs Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


Setting Method

Setting Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> Setting()()
Members
Icon | Member | Description
 | Setting(String) | Gets the setting by a key.
 | Setting(String, String) | Gets the setting from a section by a key.
 | Setting(String, String, String) | Gets the setting from a section by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadSettings Method

LoadSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> LoadSettings()()
Members
Icon | Member | Description
 | LoadSettings()() | Loads the settings.
 | LoadSettings(String) | Loads the settings.
 | LoadSettings(Item) | Loads the settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddAttribute Method

AddAttribute Method
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer >> AddAttribute()()
Members
Icon | Member | Description
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Flash >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> Flash >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean) | (Overrides XslControl.InsertValueNode(XmlNode, String, Boolean).)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddControl Method

AddControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Administration (Module: MSS.Administration)


RenderObject Method

RenderObject Method
Namespaces >> MSS.Web.UI.WebControls >> Flash >> RenderObject()()
Members
Icon | Member | Description
 | RenderObject(HtmlTextWriter) |
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Modules.News >> NewsDocument >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


Validate Method

Validate Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.News >> NewsDocument >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HasField Method

HasField Method
Namespaces >> MSS.WebEngine.Commands >> PreviewItem >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


qs Method

qs Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Image >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Background >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


qs Method

qs Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Administration (Module: MSS.Administration)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntry Method

GetEntry Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> GetEntry()()
Members
Icon | Member | Description
 | GetEntry(String) | Gets the setting collection by key.
 | GetEntry(String, String) | Gets a dictionary entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> EnterWebEdit >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetFocus Method

SetFocus Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Background >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.WebSite.Components.Navigation >> LogOut >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetFolder Method

GetFolder Method
Namespaces >> MSS.Modules.News >> NewsItem >> GetFolder()()
Members
Icon | Member | Description
 | GetFolder(DateTime) | Get month folder for the given date. If no month folder exists, it is created. If no year folder exists, it is created.
 | GetFolder(DateTime, Boolean) | Gets the folder for the date.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Background >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Validate Method

Validate Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> FunctionSelector >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Button >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Validate Method

Validate Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> LogOut >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.WebSite.Components.Navigation >> LeaveWebEdit >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


Eval Method

Eval Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Navigation >> LeaveWebEdit >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules >> ModuleControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


qs Method

qs Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Wizard.Pages >> Upload >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Administration (Module: MSS.Administration)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Modules.News >> News >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


qs Method

qs Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Init Method

Init Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> Init()()
Members
Icon | Member | Description
 | Init()() | Initialises the SettingsCollection.
 | Init(String) | Initialises the SettingsCollection.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Alert Method

Alert Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditGroup >> Alert()()
Members
Icon | Member | Description
 | Alert(String) |
 | Alert(String, array<Object>[]()) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.WebSite.Components.Navigation >> EnterWebEdit >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


HasField Method

HasField Method
Namespaces >> MSS.WebEngine.Framework.Commands >> EditImage >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules >> ModuleControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CreateEntity Method

CreateEntity Method
Namespaces >> MSS.Sites.Contexts >> SiteContextManager >> CreateEntity()()
Members
Icon | Member | Description
 | CreateEntity(Item) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.
 | CreateEntity(ID, Database) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> NoLicense >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Refresh Method

Refresh Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> Refresh()()
Members
Icon | Member | Description
 | Refresh()() |
 | Refresh(TreeNode) |
 | Refresh(String) |
 | Refresh(ID) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Validate Method

Validate Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Modules (Module: MSS.Modules)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Administration (Module: MSS.Administration)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Validate Method

Validate Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderObject Method

RenderObject Method
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer >> RenderObject()()
Members
Icon | Member | Description
 | RenderObject(HtmlTextWriter) |
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Setting Method

Setting Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> Setting()()
Members
Icon | Member | Description
 | Setting(String) | Gets the setting by a key.
 | Setting(String, String) | Gets the setting from a section by a key.
 | Setting(String, String, String) | Gets the setting from a section by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Move Method

Move Method
Namespaces >> MSS.Modules.News >> NewsItem >> Move()()
Members
Icon | Member | Description
 | Move(Item) | Moves the item.
 | Move(Item, DateTime) | Moves the item.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HasField Method

HasField Method
Namespaces >> MSS.WebEngine.Framework.Commands.ContentEditor >> CheckIn >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Refresh Method

Refresh Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> Refresh()()
Members
Icon | Member | Description
 | Refresh()() |
 | Refresh(DataContext) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


SetData Method

SetData Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> SetData()()
Members
Icon | Member | Description
 | SetData(StringDictionary) |
 | SetData(SettingsCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Administration (Module: MSS.Administration)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.News >> News >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


GetData Method

GetData Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> GetData()()
Members
Icon | Member | Description
 | GetData()() | Obsolete.
 | GetData(String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Background >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Wizard.Pages >> Upload >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.News >> News >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Label >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> FunctionSelector >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Link >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> EnterWebEdit >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetFormattedHeader Method

GetFormattedHeader Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> GetFormattedHeader()()
Members
Icon | Member | Description
 | GetFormattedHeader()() |
 | GetFormattedHeader(Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> Breadcrumb >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean) | (Overrides XslControl.InsertValueNode(XmlNode, String, Boolean).)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Background >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


qs Method

qs Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderObject Method

RenderObject Method
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer >> RenderObject()()
Members
Icon | Member | Description
 | RenderObject(HtmlTextWriter) |
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Administration (Module: MSS.Administration)


Eval Method

Eval Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


BinarySearch Method

BinarySearch Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetContextMenu Method

GetContextMenu Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> GetContextMenu()()
Members
Icon | Member | Description
 | GetContextMenu()() |
 | GetContextMenu(String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Language >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


HasField Method

HasField Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Commands >> CreateSite >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Link >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetTypeSettings Method

GetTypeSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> GetTypeSettings()()
Members
Icon | Member | Description
 | GetTypeSettings()() | Gets the type settings.
 | GetTypeSettings(String) | Gets the type settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.Pages >> Upload >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


Validate Method

Validate Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindLastIndex Method

FindLastIndex Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Modules (Module: MSS.Modules)


qs Method

qs Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


qs Method

qs Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Form >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Link >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Administration (Module: MSS.Administration)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


Validate Method

Validate Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Administration (Module: MSS.Administration)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Image >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.News >> News >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> Html >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean) | (Overrides XslControl.InsertValueNode(XmlNode, String, Boolean).)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


HasField Method

HasField Method
Namespaces >> MSS.WebEngine.Framework.Commands >> SystemPublish >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Eval Method

Eval Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadSettings Method

LoadSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> LoadSettings()()
Members
Icon | Member | Description
 | LoadSettings()() | Loads the settings.
 | LoadSettings(String) | Loads the settings.
 | LoadSettings(Item) | Loads the settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadAbsoluteSettings Method

LoadAbsoluteSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> LoadAbsoluteSettings()()
Members
Icon | Member | Description
 | LoadAbsoluteSettings(String) | Loads the absolute settings.
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CreateItem Method

CreateItem Method
Namespaces >> MSS.Modules.News >> NewsItem >> CreateItem()()
Members
Icon | Member | Description
 | CreateItem(String, String) |
 | CreateItem(Item, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> Label >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Dispose Method

Dispose Method
Namespaces >> MSS.Web.UI.Pages >> ResponseFilter >> Dispose()()
Members
Icon | Member | Description
 | Dispose()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetData Method

SetData Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> SetData()()
Members
Icon | Member | Description
 | SetData(StringDictionary) |
 | SetData(SettingsCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules >> ModuleControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddAttribute Method

AddAttribute Method
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> AddAttribute()()
Members
Icon | Member | Description
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Administration (Module: MSS.Administration)


FindControl Method

FindControl Method
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


XPath Method

XPath Method
Namespaces >> MSS.Modules.News >> NewsDocument >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Language >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules >> ModuleControl >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


AddControl Method

AddControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


qs Method

qs Method
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Form >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


GetData Method

GetData Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> GetData()()
Members
Icon | Member | Description
 | GetData()() | Obsolete.
 | GetData(String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> ItemNameValidator >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.WebControls >> StepSelector >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


AddAttribute Method

AddAttribute Method
Namespaces >> MSS.Web.UI.WebControls >> Flash >> AddAttribute()()
Members
Icon | Member | Description
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.News >> News >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.News >> NewsDocument >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.News >> NewsDocument >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.Pages >> Upload >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Validate Method

Validate Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Administration (Module: MSS.Administration)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> PublishWeb >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetData Method

GetData Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> GetData()()
Members
Icon | Member | Description
 | GetData()() | Obsolete.
 | GetData(String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.WebSite.Components.Navigation >> PublishWeb >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


Validate Method

Validate Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Move Method

Move Method
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> Move()()
Members
Icon | Member | Description
 | Move(Item) | Moves the item.
 | Move(Item, DateTime) | Moves the item.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.News >> NewsDocument >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


SetFocus Method

SetFocus Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> ItemNameValidator >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Login Method

Login Method
Namespaces >> MSS.Security >> SecurityDomain >> Login()()
Members
Icon | Member | Description
 | Login(Credentials) |
 | Login(UserItem) |
 | Login(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Setting Method

Setting Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> Setting()()
Members
Icon | Member | Description
 | Setting(String) | Gets the setting by a key.
 | Setting(String, String) | Gets the setting from a section by a key.
 | Setting(String, String, String) | Gets the setting from a section by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.Pages >> Upload >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


SetFocus Method

SetFocus Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> ImageButton >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


qs Method

qs Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> RenderSpotsControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


LastIndexOf Method

LastIndexOf Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> NoLicense >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Init Method

Init Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> Init()()
Members
Icon | Member | Description
 | Init()() | Initialises the SettingsCollection.
 | Init(String) | Initialises the SettingsCollection.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Administration (Module: MSS.Administration)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Background >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Alert Method

Alert Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.Codebeside >> EditUser >> Alert()()
Members
Icon | Member | Description
 | Alert(String) |
 | Alert(String, array<Object>[]()) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


AddControl Method

AddControl Method
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Background >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalSettings Method

GetLocalSettings Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> GetLocalSettings()()
Members
Icon | Member | Description
 | GetLocalSettings()() | Gets the local settings item.
 | GetLocalSettings(String) | Gets the local settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> RealPlayer >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


qs Method

qs Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Administration (Module: MSS.Administration)


Init Method

Init Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> Init()()
Members
Icon | Member | Description
 | Init()() | Initialises the SettingsCollection.
 | Init(String) | Initialises the SettingsCollection.

Assembly: MSS.Kernel (Module: MSS.Kernel)


HandleDropDownMenu Method

HandleDropDownMenu Method
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> HandleDropDownMenu()()
Members
Icon | Member | Description
 | HandleDropDownMenu(Control, String) |
 | HandleDropDownMenu(Control, String, Boolean) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


CopyTo Method

CopyTo Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


AddAttribute Method

AddAttribute Method
Namespaces >> MSS.Web.UI.WebControls >> Image >> AddAttribute()()
Members
Icon | Member | Description
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SaveSettings Method

SaveSettings Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> SaveSettings()()
Members
Icon | Member | Description
 | SaveSettings(Boolean) | Saves the settings.
 | SaveSettings(String) | Saves the settings using a specific path.
 | SaveSettings(String, Boolean) | Saves the settings.
 | SaveSettings(Item) | Saves the settings to the item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Language >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


AddAttribute Method

AddAttribute Method
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> AddAttribute()()
Members
Icon | Member | Description
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> FunctionSelector >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


qs Method

qs Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Administration (Module: MSS.Administration)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.News >> NewsDocument >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetRole Method

GetRole Method
Namespaces >> MSS.Security >> SecurityDomain >> GetRole()()
Members
Icon | Member | Description
 | GetRole(ID) |
 | GetRole(String) | (Overrides Domain.GetRole(String).)

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Background >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetData Method

SetData Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> SetData()()
Members
Icon | Member | Description
 | SetData(StringDictionary) |
 | SetData(SettingsCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToInt Method

ToInt Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> ToInt()()
Members
Icon | Member | Description
 | ToInt(String) | Gets the int setting by a key.
 | ToInt(String, Int32) | Gets the int setting by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.WebControls >> StepSelector >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Flash >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> Text >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean) | (Overrides XslControl.InsertValueNode(XmlNode, String, Boolean).)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Validate Method

Validate Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


qs Method

qs Method
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> FunctionBar >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.XamlControls >> MssXmlControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> MediaObject >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Navigation >> LogOut >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


CreateEntity Method

CreateEntity Method
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> CreateEntity()()
Members
Icon | Member | Description
 | CreateEntity(Item) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.
 | CreateEntity(ID, Database) | Creates the entity. Tries to get entity from the cache, if it does not exist in the cache, calls CreateNewEntity.

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterGlobalMenu >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetTypeSettings Method

GetTypeSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> GetTypeSettings()()
Members
Icon | Member | Description
 | GetTypeSettings()() | Gets the type settings.
 | GetTypeSettings(String) | Gets the type settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


qs Method

qs Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Background >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


GetTypeSettings Method

GetTypeSettings Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> GetTypeSettings()()
Members
Icon | Member | Description
 | GetTypeSettings()() | Gets the type settings.
 | GetTypeSettings(String) | Gets the type settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> PublishWeb >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetEntry Method

GetEntry Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> GetEntry()()
Members
Icon | Member | Description
 | GetEntry(String) | Gets the setting collection by key.
 | GetEntry(String, String) | Gets a dictionary entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Administration (Module: MSS.Administration)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Language >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindIndex Method

FindIndex Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Administration (Module: MSS.Administration)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Web.UI.WebControls >> NoLicense >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> RegularExpressionValidator >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Wizard.Pages >> Upload >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Eval Method

Eval Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


XPath Method

XPath Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalSettings Method

GetLocalSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> GetLocalSettings()()
Members
Icon | Member | Description
 | GetLocalSettings()() | Gets the local settings item.
 | GetLocalSettings(String) | Gets the local settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.Modules >> ModuleControl >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetFocus Method

SetFocus Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> Image >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadAbsoluteSettings Method

LoadAbsoluteSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> LoadAbsoluteSettings()()
Members
Icon | Member | Description
 | LoadAbsoluteSettings(String) | Loads the absolute settings.
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


ToInt Method

ToInt Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> ToInt()()
Members
Icon | Member | Description
 | ToInt(String) | Gets the int setting by a key.
 | ToInt(String, Int32) | Gets the int setting by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components.Language >> LanguageForm >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Populate Method

Populate Method
Namespaces >> MSS.Web.UI.XamlControls >> DataTreeviewEx >> Populate()()
Members
Icon | Member | Description
 | Populate(Control, Int32) |
 | Populate(Control, DataContext) |
 | Populate(DataContext, Control, Item, Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Spot >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Administration (Module: MSS.Administration)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


qs Method

qs Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules >> ModuleControl >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Administration (Module: MSS.Administration)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Administration (Module: MSS.Administration)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddAttribute Method

AddAttribute Method
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer >> AddAttribute()()
Members
Icon | Member | Description
 | AddAttribute(HtmlTextWriter, HtmlTextWriterAttribute, String, Boolean) |
 | AddAttribute(HtmlTextWriter, String, String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> XslControl >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean) | (Overrides XslControl.InsertValueNode(XmlNode, String, Boolean).)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Modules >> ModuleControl >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


HandleIconMenu Method

HandleIconMenu Method
Namespaces >> MSS.StatCenter.Codebeside >> MainForm >> HandleIconMenu()()
Members
Icon | Member | Description
 | HandleIconMenu(Control, String) |
 | HandleIconMenu(Control, String, Boolean) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Language >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Introduction >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Web.UI.UserControls >> DocumentList >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Form >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ToInt Method

ToInt Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> ToInt()()
Members
Icon | Member | Description
 | ToInt(String) | Gets the int setting by a key.
 | ToInt(String, Int32) | Gets the int setting by a key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Image >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Dispose Method

Dispose Method
Namespaces >> MSS.Services >> MaintenanceService >> Dispose()()
Members
Icon | Member | Description
 | Dispose()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.

Assembly: MSS.Services (Module: MSS.Services)


Create Method

Create Method
Namespaces >> MSS.Modules.News >> NewsItem >> Create()()
Members
Icon | Member | Description
 | Create(String, String) | Creates the item.
 | Create(String) | Creates the item.
 | Create(DateTime) | Creates the item.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.Web.UI.XamlControls >> TaskBoxEx >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddControl Method

AddControl Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Administration (Module: MSS.Administration)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Administration (Module: MSS.Administration)


AddControl Method

AddControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.Modules (Module: MSS.Modules)


qs Method

qs Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetUser Method

GetUser Method
Namespaces >> MSS.Security >> SecurityDomain >> GetUser()()
Members
Icon | Member | Description
 | GetUser(ID) |
 | GetUser(String) | (Overrides Domain.GetUser(String).)

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddControl Method

AddControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


DataBind Method

DataBind Method
Namespaces >> MSS.StatCenter.Codebeside >> ContentTree >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> LeaveWebEdit >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Validate Method

Validate Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Administration (Module: MSS.Administration)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.UserControls >> Reorganize >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> NewsletterControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> RadioButton >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> ItemNameValidator >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


SaveSettings Method

SaveSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> SystemSettings >> SaveSettings()()
Members
Icon | Member | Description
 | SaveSettings(Boolean) | Saves the settings.
 | SaveSettings(String) | Saves the settings using a specific path.
 | SaveSettings(String, Boolean) | Saves the settings.
 | SaveSettings(Item) | Saves the settings to the item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Validate Method

Validate Method
Namespaces >> MSS.Wizard.Pages >> Upload >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SaveSettings Method

SaveSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> SaveSettings()()
Members
Icon | Member | Description
 | SaveSettings(Boolean) | Saves the settings.
 | SaveSettings(String) | Saves the settings using a specific path.
 | SaveSettings(String, Boolean) | Saves the settings.
 | SaveSettings(Item) | Saves the settings to the item.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components >> SiteMap >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


Validate Method

Validate Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary.

Assembly: MSS.Administration (Module: MSS.Administration)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SiteTypesForm >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> CheckBox >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SubscribersList >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.Pages >> Upload >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components.Site_updated >> SiteUpdated >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


qs Method

qs Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Validate Method

Validate Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


qs Method

qs Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Administration (Module: MSS.Administration)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


qs Method

qs Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditList >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Identity >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Subscribe >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.News >> News >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.WebControls >> ColorPickerDiv >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


IndexOf Method

IndexOf Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Frame >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> Flash >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> Link >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean) | (Overrides XslControl.InsertValueNode(XmlNode, String, Boolean).)

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


HasField Method

HasField Method
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNow >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> NavigationButtons >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Namespaces

Namespaces
Namespaces


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> Picture >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageAndReplies >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


Validate Method

Validate Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Administration (Module: MSS.Administration)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkin >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> LanguageLookup >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.WebControls >> Button >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MessageList >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> CreateSiteForm >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Administration (Module: MSS.Administration)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPath Method

XPath Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Administration (Module: MSS.Administration)


Item Property

Item Property
Namespaces >> MSS.Sites.Types >> SiteTypeManager >> Item
Members
Icon | Member | Description
 | Item[([String, Database])] | Gets the SiteType with a specified name and which belongs to a specific database.
 | Item[([ID, Database])] | Gets the value with the specified key.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.WebSite.Components >> ContactForm >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> MainMenu >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.WebControls >> StepSelector >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetFolder Method

GetFolder Method
Namespaces >> MSS.Modules.EventCalendar >> EventCalendar >> GetFolder()()
Members
Icon | Member | Description
 | GetFolder(DateTime) | Get month folder for the given date. If no month folder exists, it is created. If no year folder exists, it is created.
 | GetFolder(DateTime, Boolean) | Gets the folder for the date.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.Pages >> PageNotFound >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Administration (Module: MSS.Administration)


HasField Method

HasField Method
Namespaces >> MSS.WebEngine.Framework.Commands >> WebEdit >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


HasField Method

HasField Method
Namespaces >> MSS.WebEngine.Framework.Commands >> PublishItemNowSecond >> HasField()()
Members
Icon | Member | Description
 | HasField(Item, ID) |
 | HasField(Item, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Administration (Module: MSS.Administration)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> MiniForum >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.News >> News >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterLatestVisitors >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.Pages >> Upload >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> Language >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SubscribersList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> Calendar >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.Pages >> Upload >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> Modules >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.WebSite.Components.SecurityEditor.SecurityField >> SecurityField >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.WebSite (Module: MSS.WebSite)


Validate Method

Validate Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> BarDesignExtra >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


InsertValueNode Method

InsertValueNode Method
Namespaces >> MSS.Web.UI.XslControls >> DictionaryLink >> InsertValueNode()()
Members
Icon | Member | Description
 | InsertValueNode(XmlNode, String, Boolean) |
 | InsertValueNode(XmlNode, String, Boolean, Boolean) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Reverse Method

Reverse Method
Namespaces >> MSS.Modules.Common.DataViewer.Helpers >> RowCollection >> Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> EditSubscriber >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiList >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Modules.MiniForum.UserControls >> Reply >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Administration (Module: MSS.Administration)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components.Search >> SearchResultForm >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


DataBind Method

DataBind Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.EventCalendar.UserControls >> EventDocument >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Buttons >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddControl Method

AddControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterInfo >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> LogOut >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> RequiredFieldValidator >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> SendMessage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules >> ModuleControl >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Edit >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Administration (Module: MSS.Administration)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> WizardControl >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderObject Method

RenderObject Method
Namespaces >> MSS.Web.UI.WebControls >> Quicktime >> RenderObject()()
Members
Icon | Member | Description
 | RenderObject(HtmlTextWriter) |
 | RenderObject(HtmlTextWriter, MultiMediaObject..::RenderNestedElementDelegate) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.WebControls >> ImagePickerDiv >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Validate Method

Validate Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.Wizard (Module: MSS.Wizard)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.Pages >> Upload >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.EventCalendar >> CalendarModuleControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> ChooseSkinPackage >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Web.UI.WebControls >> CollapsePanel >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterPage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Breadcrumb >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> BaseIdentityControl >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Columns >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Settings >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> MultiMediaObject >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetPostBackEventReference Method

GetPostBackEventReference Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> GetPostBackEventReference()()
Members
Icon | Member | Description
 | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
 | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


IsAllowed Method

IsAllowed Method
Namespaces >> MSS.Security >> SecurityDomain >> IsAllowed()()
Members
Icon | Member | Description
 | IsAllowed(ItemOperation, Item, RoleItem) |
 | IsAllowed(ItemOperation, Item, UserItem) | Determines whether the specified operation is allowed. (Overrides Domain.IsAllowed(ItemOperation, Item, UserItem).)

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Label >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> TextBox >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.Navigation >> LeaveWebEdit >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Web.UI.UserControls >> SiteControl >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> ContactInformation >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.WebSite.Components.Login >> LoginControl >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


XPath Method

XPath Method
Namespaces >> MSS.Modules.News.UserControls >> NewsGlobal >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.Pages >> EmptyLayout >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


SetFocus Method

SetFocus Method
Namespaces >> MSS.Web.UI.Pages.Shell >> LoginAndRedirect >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsControl >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.UserControls >> SubMenu >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditSubscriber >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert. The text is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert. The text is taken from the dictionary.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Web.UI.Pages >> SitePage >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.Navigation >> EnterWebEdit >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Web.UI.WebControls >> Button >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.Pages >> MainLayout >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.News >> NewsDocument >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Lookup >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


LoadPostData Method

LoadPostData Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> LoadPostData()()
Members
Icon | Member | Description
 | LoadPostData(String) |
 | LoadPostData(String, NameValueCollection) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> Image >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetViewStateInt Method

GetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> GetViewStateInt()()
Members
Icon | Member | Description
 | GetViewStateInt(String) |
 | GetViewStateInt(String, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetEntry Method

GetEntry Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> GetEntry()()
Members
Icon | Member | Description
 | GetEntry(String) | Gets the setting collection by key.
 | GetEntry(String, String) | Gets a dictionary entry.

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.News >> NewsDocument >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SendMessage >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableModules >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


SetViewStateInt Method

SetViewStateInt Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ModulesMultiList >> SetViewStateInt()()
Members
Icon | Member | Description
 | SetViewStateInt(String, Int32) |
 | SetViewStateInt(String, Int32, Int32) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> HyperLink >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.Skins >> SkinCssPage >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


ShowAlertFromDictionary Method

ShowAlertFromDictionary Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> ShowAlertFromDictionary()()
Members
Icon | Member | Description
 | ShowAlertFromDictionary(String) | Shows the alert message. The text of the message is taken from the dictionary.
 | ShowAlertFromDictionary(String, array<Object>[]()) | Shows the alert message. The text of the message is taken from the dictionary.

Assembly: MSS.Administration (Module: MSS.Administration)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MultiListValue >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components.RecycleBin >> MSSRecycleBinListview >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadControl Method

LoadControl Method
Namespaces >> MSS.Wizard.UserControls >> Language >> LoadControl()()
Members
Icon | Member | Description
 | LoadControl(String) | Loads a Control object from a file based on a specified virtual path.
 | LoadControl(Type, array<Object>[]()) | Loads a Control object based on a specified type and constructor parameters.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.Web.UI.WebControls >> MediaItem >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Wizard.UserControls >> BarDesign >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> TopBar >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateBool Method

SetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> SetViewStateBool()()
Members
Icon | Member | Description
 | SetViewStateBool(String, Boolean) |
 | SetViewStateBool(String, Boolean, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.Wizard (Module: MSS.Wizard)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> EditGroup >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Wizard.Pages >> Upload >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.Wizard (Module: MSS.Wizard)


AddControl Method

AddControl Method
Namespaces >> MSS.StatCenter.Codebeside >> StatCenterSearch >> AddControl()()
Members
Icon | Member | Description
 | AddControl(Control) |
 | AddControl(Control, String) |
 | AddControl(String, String, Control, String, array<String>[]()) |
 | AddControl(Control, Control, String, array<String>[]()) |

Assembly: MSS.StatCenter (Module: MSS.StatCenter)


FindControl Method

FindControl Method
Namespaces >> MSS.Wizard.UserControls >> ColumnsBackground >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Wizard (Module: MSS.Wizard)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


SetViewStateString Method

SetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> AvailableSpots >> SetViewStateString()()
Members
Icon | Member | Description
 | SetViewStateString(String, String) |
 | SetViewStateString(String, String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> ReadOnlyItemPath >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.WebSite.Components >> SearchSpot >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebSite (Module: MSS.WebSite)


SetFocus Method

SetFocus Method
Namespaces >> MSS.SitecoreExtensions.Pages >> Error >> SetFocus()()
Members
Icon | Member | Description
 | SetFocus(Control) | Sets the browser focus to the specified control.
 | SetFocus(String) | Sets the browser focus to the control with the specified identifier.

Assembly: MSS.Sitecore (Module: MSS.Sitecore)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Modules >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules >> ModuleControl >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.WebSite (Module: MSS.WebSite)


AddOnPreRenderCompleteAsync Method

AddOnPreRenderCompleteAsync Method
Namespaces >> MSS.WebEngine.Web.UI.Pages.Shell >> LoginPage >> AddOnPreRenderCompleteAsync()()
Members
Icon | Member | Description
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
 | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Modules.PictureSeries.UserControls >> PictureSeries >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Modules (Module: MSS.Modules)


MakeEditable Method

MakeEditable Method
Namespaces >> MSS.Modules.NewsLetter.CodeBeside >> MailingList >> MakeEditable()()
Members
Icon | Member | Description
 | MakeEditable(HtmlControl, String) |
 | MakeEditable(HtmlControl, String, ContentGetter) |
 | MakeEditable(HtmlControl, String, String) |

Assembly: MSS.Modules (Module: MSS.Modules)


Eval Method

Eval Method
Namespaces >> MSS.Modules.SMS.Pages >> Statistics1 >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


qs Method

qs Method
Namespaces >> MSS.Administration.Application.MultiSiteControlCenter.Controls >> SitesOverviewForm >> qs()()
Members
Icon | Member | Description
 | qs(String) |
 | qs(String, String) |

Assembly: MSS.Administration (Module: MSS.Administration)


XPathSelect Method

XPathSelect Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> XPathSelect()()
Members
Icon | Member | Description
 | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.
 | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> FrontPageColumn >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.Pages >> RgbColor >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


Eval Method

Eval Method
Namespaces >> MSS.Wizard.UserControls >> Navigation >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Wizard.UserControls >> Normal >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalResourceObject Method

GetLocalResourceObject Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> GetLocalResourceObject()()
Members
Icon | Member | Description
 | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property.
 | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name.

Assembly: MSS.Modules (Module: MSS.Modules)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.Layouts >> Subscribe >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


Validate Method

Validate Method
Namespaces >> MSS.WebSite.Components.SecurityEditor >> MediaSecurityField >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.WebSite (Module: MSS.WebSite)


FindControl Method

FindControl Method
Namespaces >> MSS.Administration.Application.DictionaryManager.Pages >> Default >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Overrides Control.FindControl(String).)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Administration (Module: MSS.Administration)


XPath Method

XPath Method
Namespaces >> MSS.Wizard.UserControls >> Language >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetLocalSettings Method

GetLocalSettings Method
Namespaces >> MSS.Sites.Contexts.Settings >> WizardSettings >> GetLocalSettings()()
Members
Icon | Member | Description
 | GetLocalSettings()() | Gets the local settings item.
 | GetLocalSettings(String) | Gets the local settings item using a specific path.

Assembly: MSS.Kernel (Module: MSS.Kernel)


XPath Method

XPath Method
Namespaces >> MSS.Modules.NewsLetter.Layouts >> Subscribe >> XPath()()
Members
Icon | Member | Description
 | XPath(String) | Evaluates an XPath data-binding expression.
 | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution.
 | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result.
 | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result.

Assembly: MSS.Modules (Module: MSS.Modules)


GetViewStateString Method

GetViewStateString Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssRolesMultiList >> GetViewStateString()()
Members
Icon | Member | Description
 | GetViewStateString(String) |
 | GetViewStateString(String, String) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


DataBind Method

DataBind Method
Namespaces >> MSS.Web.UI.WebControls >> WindowsMediaPlayer >> DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


GetGlobalResourceObject Method

GetGlobalResourceObject Method
Namespaces >> MSS.Web.UI.Pages >> WelcomeControl >> GetGlobalResourceObject()()
Members
Icon | Member | Description
 | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
 | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


Validate Method

Validate Method
Namespaces >> MSS.Wizard.Pages >> WizardPage >> Validate()()
Members
Icon | Member | Description
 | Validate()() | Instructs any validation controls included on the page to validate their assigned information.
 | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information.

Assembly: MSS.Wizard (Module: MSS.Wizard)


FindControl Method

FindControl Method
Namespaces >> MSS.WebSite.Components.Login >> LoginSpot >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.WebSite (Module: MSS.WebSite)


LoadAbsoluteSettings Method

LoadAbsoluteSettings Method
Namespaces >> MSS.Sites.Settings >> ModuleSettings >> LoadAbsoluteSettings()()
Members
Icon | Member | Description
 | LoadAbsoluteSettings(String) | Loads the absolute settings.
 | LoadAbsoluteSettings(String, String, Boolean) | Loads the absolute settings.

Assembly: MSS.Kernel (Module: MSS.Kernel)


InitOutputCache Method

InitOutputCache Method
Namespaces >> MSS.Wizard.Pages >> Wizard >> InitOutputCache()()
Members
Icon | Member | Description
 | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request.
 | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object.

Assembly: MSS.Wizard (Module: MSS.Wizard)


GetViewStateBool Method

GetViewStateBool Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssSiteLookup >> GetViewStateBool()()
Members
Icon | Member | Description
 | GetViewStateBool(String) |
 | GetViewStateBool(String, Boolean) |

Assembly: MSS.Kernel (Module: MSS.Kernel)


FindControl Method

FindControl Method
Namespaces >> MSS.Modules.SMS.CodeBeside >> SmsList >> FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Assembly: MSS.Modules (Module: MSS.Modules)


RenderControl Method

RenderControl Method
Namespaces >> MSS.SitecoreExtensions.FieldControls >> MssMultiList >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(XmlNode) |
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Kernel (Module: MSS.Kernel)


Eval Method

Eval Method
Namespaces >> MSS.Web.UI.Pages >> MSSPage >> Eval()()
Members
Icon | Member | Description
 | Eval(String) | Evaluates a data-binding expression.
 | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result.

Assembly: MSS.WebEngine (Module: MSS.WebEngine)


RenderControl Method

RenderControl Method
Namespaces >> MSS.Modules.Common.DataViewer >> ExcelConverter >> RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Assembly: MSS.Modules (Module: MSS.Modules)